# Contents

## Contact Center Solutions

- **Contact Center Solutions** ................................................................. 3
  - What’s new in Version 5.7 SP1? ....................................................... 3
  - Contact Center Enterprise Edition and Contact Center Business Edition .... 5
  - Licensing ......................................................................................... 6
  - Locating the latest versions of our guides ....................................... 9
  - Document conventions .................................................................... 9
  - Searching for key words and definitions ....................................... 10
  - Required and optional software components .................................. 10
    - Required components ................................................................. 10
    - Optional components ............................................................... 11
  - Client Component Pack ................................................................ 11

## Contact Center Concepts

- **Contact Center Concepts** ............................................................... 15
  - Automatic Call Distribution (ACD) .................................................. 15
  - Understanding ACD call flow ........................................................ 15
    - Monitoring the call flow process .................................................. 16
    - Ensuring traffic-carrying efficiency ............................................. 16
    - Scheduling to optimize call flow ................................................ 16
  - Routing calls .................................................................................. 16
    - Dialing an agent’s extension ....................................................... 17
    - Dialing a queue .......................................................................... 17
    - Overflowing calls ....................................................................... 17
    - Interflowing calls ....................................................................... 18
  - The inbound call environment ........................................................ 18

## Contact Center Planning and Management

- **Contact Center Planning and Management** .................................... 21
  - Step #1 Establish a corporate service objective ................................. 22
  - Understanding the Service Level .................................................... 22
  - Understanding why the Service Level is the most meaningful statistic . 22
  - Choosing a Service Level goal ....................................................... 24
  - Understanding Quality of Service .................................................. 24
  - Monitoring call handling techniques ............................................. 24
  - Monitoring systems and tools ....................................................... 25
  - Automating help desk workflow .................................................... 27
  - Step #2 Collect data ....................................................................... 27
    - Collecting data on call handling ................................................ 27
<table>
<thead>
<tr>
<th>Step #3 Forecast the Call Load</th>
<th>Forecasting accurately</th>
<th>Conducting forecasts</th>
<th>28</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step #4 Calculate the resources required</strong></td>
<td>Predicting agent requirements</td>
<td>Understanding Erlang C</td>
<td>29</td>
</tr>
<tr>
<td><strong>Considerations when predicting resource requirements</strong></td>
<td>30</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Performing “what-if” scenarios</td>
<td>Understanding the relationship between agents and trunks</td>
<td>Understanding Erlang B</td>
<td>30</td>
</tr>
<tr>
<td>Predicting trunk requirements</td>
<td>31</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Step #5 Schedule agents</strong></td>
<td>Understanding the Shrinkage Factor</td>
<td>Calculating the Shrinkage Factor</td>
<td>32</td>
</tr>
<tr>
<td>Optimizing schedules</td>
<td>33</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Routing calls to optimize coverage</td>
<td>Scheduling considerations</td>
<td>34</td>
<td></td>
</tr>
<tr>
<td><strong>Step #6 Determine contact center costs</strong></td>
<td>Breaking down expenses</td>
<td>Anticipating growth</td>
<td>35</td>
</tr>
</tbody>
</table>

## Getting Started

### Getting Started

<table>
<thead>
<tr>
<th>Registering Contact Center Management</th>
<th>Activating Contact Center Management</th>
<th>Updating license files on the Enterprise Server</th>
<th>41</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting up Contact Center Management on the Enterprise Server</td>
<td>Setting up Contact Center Management on client computers</td>
<td>Starting Contact Center Management</td>
<td>42</td>
</tr>
<tr>
<td>Viewing multiple Contact Center Management sessions</td>
<td>Installing the latest version of Client Component Pack</td>
<td>Installing Client Component Pack using an administrative procedure</td>
<td>43</td>
</tr>
<tr>
<td>Installing Client Component Pack using an administrative procedure</td>
<td>Installing the prerequisite software</td>
<td>Locating the client_setup.exe and extracting Client Component Pack.msi</td>
<td>44</td>
</tr>
<tr>
<td>Performing the MSI procedure for the administrative installation</td>
<td>Running the silent installation</td>
<td>Using Client Role Selector to select your Contact Center Client role</td>
<td>45</td>
</tr>
<tr>
<td>Running client role selector</td>
<td>Disabling the IE security warning</td>
<td>Setting up user preferences</td>
<td>46</td>
</tr>
<tr>
<td>Specifying your language preference</td>
<td>Specifying the number of records displayed on a page</td>
<td>47</td>
<td></td>
</tr>
</tbody>
</table>

Changing your password ............................................................... 48
Viewing security role properties ..................................................... 48
Configuring email contacts ............................................................. 48
  Adding email contacts ................................................................. 48
  Adding contact groups ................................................................. 48
  Adding email contacts to contact groups ....................................... 49
Setting up the SMTP Mail Server for report distribution ...................... 49

Services and Database Administration

Services and Database Administration ............................................. 53
  Specifying enterprise maintenance functions ................................ 53
  Backing up data ........................................................................ 53
    Backing up .xml files ................................................................ 53
    Backing up SQL Server data files .............................................. 54
      Understanding SQL Server recovery models ................................ 54
  Backing up Enterprise Server configuration data ............................ 55
  Backing up raw telephone system data files ................................... 55
Management Console .................................................................... 55
  Opening Management Console .................................................... 56
Configuration ................................................................................. 56
  Updating server IP addresses ....................................................... 56
  Importing configuration data ....................................................... 56
Maintenance .................................................................................. 60
  Running the maintenance routine immediately .............................. 60
  Summarizing data ...................................................................... 61
Support ......................................................................................... 61
  Controlling services ................................................................... 62
  Converting data files .................................................................. 63
  Converting Callview and Contact Center Suite data ......................... 63

Configuration

Configuration .................................................................................. 67
  YourSite database application areas .............................................. 69
  Enterprise setup .......................................................................... 69
Starting Contact Center Management ............................................. 71
Configuring enterprise settings ....................................................... 71
  Configuring the Enterprise Server IP address ................................ 71
  Configuring enterprise maintenance functions ............................... 71
  Configuring email alarms ............................................................. 72
  Displaying the warranty warning and expiry message ....................... 72
Adding sites .................................................................................... 72
  Configuring the SMTP Mail Server .............................................. 73
  Configuring smart algorithms for sites .......................................... 73
YourSite Explorer ................................................................. 74
Starting YourSite Explorer ................................................... 74
Searching ................................................................. 74
Paging ................................................................. 74
Filtering ................................................................. 75
Customizing the user interface .................................................. 75
Minimizing aspects of the user interface ....................................... 75
Selecting the first record of each list .......................................... 76
Changing the order of the columns .............................................. 76
Changing column options ...................................................... 76
Grouping device criteria by column headers .................................. 77
Making multiple changes .......................................................... 77
Changing the YourSite Explorer view ........................................... 77
Adding media servers ............................................................. 78
Adding a 3300 ICP media server ................................................. 79
Adding a 3300 ICP media server in YourSite Explorer ...................... 79
Configuring location settings for a 3300 ICP in YourSite Explorer ........ 80
Configuring data collection settings for a 3300 ICP in YourSite Explorer . 80
Configuring data summary options for a 3300 ICP in YourSite Explorer . 81
Configuring MiTAI options for a 3300 ICP in YourSite Explorer ................... 82
Configuring Network Monitor settings for a 3300 ICP in YourSite Explorer ... 82
Configuring call recording .......................................................... 82
Adding a 3300 ICP media server in the Contact Center Management website .... 83
Configuring data collection settings for a 3300 ICP in the Contact Center Management website 84
Configuring data summary options for a 3300 ICP in the Contact Center Management website 85
Configuring MiTAI options for a 3300 ICP in the Contact Center Management website 85
Configuring Network Monitor settings for a 3300 ICP in the Contact Center Management web-site .......................................................... 86
Adding an SX-200 ACD media server ........................................... 86
Configuring data collection settings for an SX-200 ACD .................... 86
Configuring data summary options for an SX-200 ACD ..................... 87
Configuring Network Monitor settings for an SX-200 ACD ................... 87
Adding a 5000/Axxess media server ......................................... 88
Configuring location settings for a 5000/Axxess ................................ 88
Configuring data summary options for a 5000/Axxess ........................ 89
Configuring Network Monitor settings for a 5000/Axxess ....................... 89
Adding an SX-2000 UCD media server ....................................... 90
Configuring data collection settings for an SX-2000 UCD ..................... 90
Configuring data summary options for an SX-2000 UCD ..................... 92
Configuring Network Monitor settings for an SX-2000 UCD ................... 92
Adding an SX-2000 ACD media server ....................................... 93
Configuring data collection settings for an SX-2000 ACD ..................... 93
Configuring data summary options for an SX-2000 ACD ..................... 94
Configuring Network Monitor settings for an SX-2000 ACD ................... 94
Adding a Multimedia Contact Center Email media server ..................... 94
Configuration scenario 1 .................................................. 108
Configuration scenario 2 .................................................. 109
Configuring YourSite database devices .................................. 111
  Configuring devices and device groups ................................. 112
  Configuring the YourSite database using synchronization ............ 112
  Preparing for synchronization ........................................ 114
  Specifying synchronization settings .................................. 115
  Performing synchronization .......................................... 115
  Scheduling Synchronization during the nightly maintenance routine ...... 117
  Viewing Synchronization reports ..................................... 117
  Understanding Synchronization reports ............................... 117
  Subscribing to the Synchronization report RSS feed ................... 118
Editing telephone system assignment forms ........................... 119
  Editing System options ............................................. 119
  Editing SMDR options ............................................. 119
  Editing Class of Service options .................................. 120
  Editing Class of Restriction options ................................ 120
Adding resilient and/or Network ACD hot desking agents ............. 120
Invalid ACD cluster programming ...................................... 121
Configuring devices and device groups using Quick Setup .............. 122
  Employee Quick Setup ............................................. 123
  Agent Quick Setup ................................................. 124
  Queue Quick Setup ................................................. 124
  Extension Quick Setup ............................................. 125
  Trunk Quick Setup ................................................. 126
  Trunk group Quick Setup ........................................... 126
  DNIS Quick Setup ................................................. 126
  Account Code Quick Setup ........................................ 126
  Make Busy Reason Codes Quick Setup ................................ 127
  Team Quick Setup .................................................. 127
  Device group Quick Setup .......................................... 128
Configuring devices using .csv files .................................... 128
  Fields required for successful .csv imports .......................... 129
  Importing a range of devices using a .csv file ......................... 130
Configuring devices manually .......................................... 131
  Adding employees .................................................. 132
  Adding employee groups ........................................... 135
  Adding employee divisions ......................................... 136
  Adding agents ...................................................... 136
  Adding agent groups ................................................ 138
  Adding teams ....................................................... 140
  Adding queues ...................................................... 141
  Adding queue groups ............................................... 151
  Adding extensions .................................................. 152
  Adding extension groups ........................................... 154
  Adding trunks ....................................................... 155
  Adding trunk groups ................................................ 156
  Adding DNIS ....................................................... 157
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding DNIS groups</td>
<td>158</td>
</tr>
<tr>
<td>Adding Account Codes</td>
<td>159</td>
</tr>
<tr>
<td>Adding Account Code groups</td>
<td>160</td>
</tr>
<tr>
<td>Adding ANI</td>
<td>160</td>
</tr>
<tr>
<td>Adding Make Busy Reason Codes</td>
<td>161</td>
</tr>
<tr>
<td>Adding Do Not Disturb Reason Codes</td>
<td>161</td>
</tr>
<tr>
<td>Adding phone numbers</td>
<td>161</td>
</tr>
<tr>
<td>Adding phone number groups</td>
<td>162</td>
</tr>
<tr>
<td>Adding auto-acknowledgement messages and associating them with queues</td>
<td>163</td>
</tr>
<tr>
<td>Configuring Intelligent Queue devices</td>
<td>163</td>
</tr>
<tr>
<td>Viewing Smart Choice layers</td>
<td>163</td>
</tr>
<tr>
<td>Adding Smart Choice layer groups</td>
<td>164</td>
</tr>
<tr>
<td>Adding Smart Choice layers to a Smart Choice layer group</td>
<td>164</td>
</tr>
<tr>
<td>Viewing Intelligent Queue ports</td>
<td>164</td>
</tr>
<tr>
<td>Adding Intelligent Queue port groups</td>
<td>164</td>
</tr>
<tr>
<td>Adding Intelligent Queue ports to an Intelligent Queue port group</td>
<td>165</td>
</tr>
<tr>
<td>Viewing Intelligent Queue Smart Choice layer exit codes</td>
<td>165</td>
</tr>
<tr>
<td>Configuring employee scheduling preferences</td>
<td>165</td>
</tr>
<tr>
<td>Configuring employee roles</td>
<td>166</td>
</tr>
<tr>
<td>Configuring employee work hours</td>
<td>166</td>
</tr>
<tr>
<td>Configuring employment status</td>
<td>166</td>
</tr>
<tr>
<td>Configuring employee payroll information</td>
<td>166</td>
</tr>
<tr>
<td>Configuring employee availability</td>
<td>167</td>
</tr>
<tr>
<td>Configuring employee time off</td>
<td>167</td>
</tr>
<tr>
<td>Overriding employee time off</td>
<td>167</td>
</tr>
<tr>
<td>Configuring employee skills</td>
<td>168</td>
</tr>
<tr>
<td>Configuring scheduling options</td>
<td>168</td>
</tr>
<tr>
<td>Configuring holidays</td>
<td>168</td>
</tr>
<tr>
<td>Configuring overtime types</td>
<td>169</td>
</tr>
<tr>
<td>Configuring time off types</td>
<td>169</td>
</tr>
<tr>
<td>Configuring skills</td>
<td>170</td>
</tr>
<tr>
<td>Business hour schedules</td>
<td>171</td>
</tr>
<tr>
<td>Creating schedules</td>
<td>171</td>
</tr>
<tr>
<td>Managing schedule exclusion lists</td>
<td>172</td>
</tr>
<tr>
<td>Applying schedules</td>
<td>172</td>
</tr>
<tr>
<td>Security roles</td>
<td>172</td>
</tr>
<tr>
<td>Creating and applying security roles</td>
<td>173</td>
</tr>
<tr>
<td>Creating security lists</td>
<td>174</td>
</tr>
<tr>
<td>Configuring security</td>
<td>175</td>
</tr>
<tr>
<td>Verifying security role properties</td>
<td>178</td>
</tr>
<tr>
<td>Assigning security roles to employees</td>
<td>178</td>
</tr>
</tbody>
</table>

### Real-time Monitors

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real-time Monitors</td>
<td>181</td>
</tr>
<tr>
<td>Contact Center Client</td>
<td>182</td>
</tr>
<tr>
<td>Starting Contact Center Client</td>
<td>183</td>
</tr>
<tr>
<td>Agent states</td>
<td>184</td>
</tr>
</tbody>
</table>
Extension states .......................................................... 185
Understanding Contact Center Client features .................. 186
Contact Center Client options ...................................... 187
Viewing agent availability ........................................... 189
Agent, Employee, and Extension State by Position ............. 190
Agent State and Employee State by Time ......................... 194
Agent State by Time for Queue .................................... 195
Agent Shift .............................................................. 196
Viewing queue statistics ............................................. 197
Queue by Period ....................................................... 197
Queue Now and Queue Group Now ................................. 199
Viewing queue chart statistics ...................................... 203
Queue Now and Queue Group Now ................................. 203
Queue Performance by Period and Queue Group Performance by Period .................................................. 203
Viewing web pages ................................................... 204
Viewing and customizing real-time monitors ...................... 204
Opening monitors ...................................................... 205
Docking monitors ...................................................... 205
Adding and removing devices ....................................... 207
Sorting monitor devices .............................................. 207
Rearranging cells ...................................................... 208
Setting monitor dimensions ........................................ 208
Hiding monitor columns ............................................. 208
Filtering device variables .......................................... 209
Setting alarms .......................................................... 209
Customizing the information displayed on position and time monitors .................................................. 211
Grouping data .......................................................... 214
Building marquee monitors ........................................ 214
Configuring charts characteristics ................................ 216
Using Contact Center Chat ........................................ 218
Sending an initial Contact Center Chat message ............... 219
Adding someone to a conversation ................................ 220
Responding to a Contact Center Chat message ................. 220
Using Contact Center Client with Office Communicator ...... 220
Sending an initial message in Office Communicator .......... 222
Adding someone to a conversation ................................ 224
Responding to a message in Office Communicator ............ 224
Hot desking ............................................................... 224
Providing Contact Center Client functionality to teleworkers .......................................................... 224
Setting up phones for teleworkers ................................ 225
Registering phones for use with Teleworker Solution .......... 225
Setting up soft phones to support Teleworker Solution ....... 226
Approving the Teleworker Solution certificate .................. 226
Using Teleworker Solution with Contact Center Client ...... 227
WallBoarder .............................................................. 227
WallBoarder parameters ............................................. 227
Site ........................................................................ 228
Sign groups ............................................................... 228
Signs ..................................................................... 230
Sign variables ........................................................... 231
Sign messages .......................................................... 232
Sign plans ............................................................. 233
Connecting Spectrum wall signs ..................................... 234
Configuring wall signs and wall sign messages ...................... 235
   Selecting the computer on which the WallBoarder Service is installed 235
   Creating sign groups ........................................... 236
   Adding signs to sign groups .................................... 237
   Configuring sign variables ..................................... 238
   Configuring sign messages ..................................... 239
   Creating sign plans ............................................. 240
   Activating priority messages .................................. 242
   Scheduling messages .......................................... 242
Troubleshooting real-time issues ...................................... 243
Configuring ACD resiliency and ACD hot desking .................... 243
Interactive Contact Center and resiliency ............................ 244
Enabling Enterprise Presence / Chat Integration ...................... 244
Ensuring Contact Center Client recognizes Office Communicator users 244
   Employee and agent monitors display instant message presence as Unknown 244
   Extension monitor displays instant message presence as Unknown 245
Connect using Teleworker option does not appear on log on window 245
Contact Center Client could not connect to Teleworker Solution ........ 246
Contact Center Client could not send the certificate request .......... 246
Your logon failed when you tried to log on remotely ................ 247

**Reports**

Reports .............................................................. 251
Understanding reports ............................................... 251
Setting the Service Level objective .................................. 253
   Voice queue Service Level objective ............................ 253
   Email queue service level objective ............................. 254
   Chat queue service level objective .............................. 254
   Fax queue service level objective ............................... 254
Report types ........................................................ 255
Recommended top-five reports ....................................... 256
Using reports to identify problems ................................... 257
Reporter ............................................................. 259
Reporter options .................................................. 259
Setting up contacts and contact groups ................................ 260
   Setting up email contacts for emailing reports .................. 260
   Setting up email contact groups for emailing reports .......... 260
Generating on-demand reports ...................................... 260
Generating reports ................................................ 260
Emailing reports .................................................. 262
Printing reports .................................................... 262
Scheduled Reports ................................................ 263
Scheduled reports options .......................................... 263
### Generating scheduled reports
- Creating report schedules ........................................ 263
- Adding reports to schedules ........................................ 266
- Generating scheduled reports immediately ......................... 267

### Report Inbox
- Report Inbox ............................................................ 267
- Reporter Inbox options ............................................... 268
- Viewing reports ........................................................ 268
- Viewing call recordings ............................................... 268
- Editing reports in Excel ............................................. 269
- Deleting reports ....................................................... 269
- Configuring user printer settings .................................... 270

### Troubleshooting reporting issues
- Troubleshooting reporting issues ................................... 270
- Troubleshooting missing data ........................................ 270
- Configuring reports to exclude Junk Mail from completed email statistics ........................................... 271
- Troubleshooting Reporting Service ................................. 271

### Forecasting

#### Forecasting
- Generating scheduled reports ........................................ 263
- Creating report schedules ............................................ 263
- Adding reports to schedules .......................................... 266
- Generating scheduled reports immediately ....................... 267

### Data-mining

#### Data Mining
- Generating scheduled reports .................................... 263
- Creating report schedules ........................................... 263
- Adding reports to schedules ......................................... 266
- Generating scheduled reports immediately ...................... 267

### Troubleshooting Reporting Service
- Troubleshooting Reporting Service .............................. 271

### Troubleshooting Reporting issues
- Troubleshooting Reporting issues ................................. 270
- Troubleshooting missing data ....................................... 270
- Configuring reports to exclude Junk Mail from completed email statistics ............................................ 271
- Troubleshooting Reporting Service .............................. 271

### Forecasting

#### Forecasting
- Forecasting ............................................................... 275
- Forecasting terms ..................................................... 275
- Forecasting tool ....................................................... 276
- Loading historical data .............................................. 276
- Modifying historical data ........................................... 276
  - Modifying Average Talk time .................................... 277
  - Modifying Calls Offered ......................................... 278
  - Modifying the weekly total for Calls Offered ................ 279
- Performing forecasts ................................................. 279
- Printing forecasts .................................................... 280
- Saving forecasts as Excel files .................................... 280

### Data-mining

#### Data Mining
- Data Mining ............................................................. 283
- Running searches in ACD Inspector ............................... 283
  - Agent events criteria for searches ................................ 284
  - Queue events criteria for searches ................................ 288
  - Option events criteria for searches ............................ 289
- Running agent events searches .................................... 290
  - Agent events search results ..................................... 291
  - Narrowing an Agent events search ............................. 292
- Running queue events searches ................................... 293
  - Queue events search results .................................... 294
  - Narrowing a Queue events search ............................. 295
- Running wild card queue events searches ....................... 296
  - Wild card queue events search results ....................... 298
- Running searches for error and information records .......... 298
## Contents

### Starting Contact Center Client
- Agent control .................................................. 332
  - Hiding the Monitor control option ......................... 333
  - Logging on an agent ......................................... 333
  - Logging off an agent .................................... 333
  - Logging off all of the agents on a monitor .......... 333
  - Logging an agent out of one queue and into another queue .......................... 334
  - Using agent group presence ............................... 334
  - Placing agents in Make Busy ............................ 336
  - Removing agents from Make Busy ......................... 336
  - Placing agents in Do Not Disturb ....................... 336
  - Removing agents from Do Not Disturb ................. 336
  - Cancelling agents in Work Timer ....................... 337
- Queue Control ................................................ 337
  - Manually controlling queues .............................. 337
  - Controlling queues using a schedule .................... 338
  - Controlling queues using Queue control plans ....... 339
- Interactive Visual Queue ................................ 343
  - Using Interactive Visual Queue ......................... 343
  - Configuring options in Contact Center Management .......................... 343
- Contact Center PhoneSet Manager and Contact Center Softphone .................. 353
  - Using Contact Center PhoneSet Manager and Contact Center Softphone .......... 353
  - Supported phone sets .................................... 353
  - Tested headsets ............................................ 354
  - USB-to-headset adaptors .................................. 354
    - Integrating the GN 8120 with Contact Center Softphone ......................... 355
  - Setting up the soft phone ............................... 355
  - Configuring sound and audio device properties .................... 356
    - Configuring sound and audio device properties for Windows Vista ............ 356
    - Configuring sound and audio device properties for Windows XP .............. 356
  - Opening the soft phone .................................. 357
  - Logging on to the ACD ................................... 359

### Interactive Visual Queue

- Redirecting calls ........................................... 346
  - Redirecting calls between queues ..................... 346
  - Redirecting calls to specific numbers ................ 347
  - Removing calls ........................................... 348
- Calling back abandoned callers ......................... 348
- Configuring alarms ......................................... 348
- Understanding call priority .............................. 349

### Contact Center PhoneSet Manager and Contact Center Softphone

- Starting Contact Center Client .......................... 353
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conferencing calls</td>
<td>376</td>
</tr>
<tr>
<td>Consulting with people while on calls</td>
<td>376</td>
</tr>
<tr>
<td>Requesting help while on calls</td>
<td>377</td>
</tr>
<tr>
<td>Using Camp on</td>
<td>377</td>
</tr>
<tr>
<td>Leaving and retrieving messages</td>
<td>377</td>
</tr>
<tr>
<td>Using Call me back</td>
<td>378</td>
</tr>
<tr>
<td>Tagging calls with Account Codes</td>
<td>378</td>
</tr>
<tr>
<td>Controlling your availability</td>
<td>378</td>
</tr>
<tr>
<td>Making and handling calls using Contact Center Client</td>
<td>379</td>
</tr>
<tr>
<td>Making calls</td>
<td>379</td>
</tr>
<tr>
<td>Forwarding calls</td>
<td>379</td>
</tr>
<tr>
<td>Answering calls</td>
<td>379</td>
</tr>
<tr>
<td>Adding call notes</td>
<td>379</td>
</tr>
<tr>
<td>Recording calls</td>
<td>380</td>
</tr>
<tr>
<td>Silent monitoring calls</td>
<td>380</td>
</tr>
<tr>
<td>Transferring calls</td>
<td>380</td>
</tr>
<tr>
<td>Consulting with employees while on calls</td>
<td>381</td>
</tr>
<tr>
<td>Requesting help while on calls</td>
<td>381</td>
</tr>
</tbody>
</table>

Contact Center Screen Pop

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Center Screen Pop</td>
<td>385</td>
</tr>
<tr>
<td>Using Contact Center Screen Pop</td>
<td>385</td>
</tr>
<tr>
<td>Configuring options in Contact Center Management</td>
<td>385</td>
</tr>
<tr>
<td>Enabling Contact Center Screen Pop</td>
<td>385</td>
</tr>
<tr>
<td>Configuring Contact Center Screen Pop options</td>
<td>386</td>
</tr>
<tr>
<td>Configuring Contact Center Screen Pop display variables</td>
<td>387</td>
</tr>
<tr>
<td>Configuring Contact Center Screen Pop Outlook options for journal entries</td>
<td>388</td>
</tr>
<tr>
<td>Configuring Contact Center Screen Pop to display Outlook contacts</td>
<td>389</td>
</tr>
<tr>
<td>Configuring Contact Center Screen Pop to display Goldmine contacts</td>
<td>389</td>
</tr>
<tr>
<td>Testing Contact Center Screen Pop search functions</td>
<td>390</td>
</tr>
<tr>
<td>Disabling Contact Center Screen Pop</td>
<td>390</td>
</tr>
</tbody>
</table>

Flexible Reporting

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flexible Reporting</td>
<td>393</td>
</tr>
<tr>
<td>Using Flexible Reporting</td>
<td>393</td>
</tr>
<tr>
<td>Starting Flexible Reporting</td>
<td>393</td>
</tr>
<tr>
<td>Viewing the Flexible Reporting user interface</td>
<td>394</td>
</tr>
<tr>
<td>Report Designer wizard</td>
<td>395</td>
</tr>
<tr>
<td>Layout designer window</td>
<td>395</td>
</tr>
<tr>
<td>Flexible Reporting button</td>
<td>395</td>
</tr>
<tr>
<td>Ribbon</td>
<td>396</td>
</tr>
<tr>
<td>Toolbox window</td>
<td>396</td>
</tr>
<tr>
<td>Creating new reports</td>
<td>396</td>
</tr>
<tr>
<td>Modifying standard Contact Center Management report templates</td>
<td>397</td>
</tr>
<tr>
<td>Modifying existing Flexible Reporting report templates</td>
<td>398</td>
</tr>
<tr>
<td>Designing reports</td>
<td>399</td>
</tr>
<tr>
<td>Adding images to report headers</td>
<td>399</td>
</tr>
<tr>
<td>Deleting images on report headers</td>
<td>399</td>
</tr>
</tbody>
</table>
Editing report header titles ............................................................ 399
Moving report header titles and values .............................................. 399
Removing report header titles and values ........................................ 400
Adding report header titles and values ............................................ 400
Adding existing columns ............................................................... 400
Adding custom columns ............................................................... 400
Moving columns ............................................................................ 401
Deleting columns .......................................................................... 401
Editing column heading names ....................................................... 402
Specifying column width ............................................................... 402
Specifying row height ................................................................... 402
Specifying row colors ................................................................... 402
Freezing columns ......................................................................... 403
Unfreezing columns ...................................................................... 403
Managing your Flexible Reporting reports ..................................... 403
Changing access properties ........................................................... 403
Renaming reports ......................................................................... 403
Deleting reports ........................................................................... 404
Running reports ........................................................................... 404
Running reports in the Contact Center Management website .......... 404
Running reports in Flexible Reporting ............................................ 405
Saving templates and reports ....................................................... 405
Printing reports ............................................................................ 405

Intelligent Queue

Intelligent Queue .......................................................................... 409
Using Intelligent Queue .................................................................. 409
Licensing Intelligent Queue ............................................................ 409
Registering and Activating Intelligent Queue ................................. 414
Registering your Intelligent Queue software .................................. 414
Registering online ........................................................................ 414
Registering offline ....................................................................... 415
Registering a seven-day demo license ............................................ 415
Activating your Intelligent Queue software .................................... 415
Upgrading an existing license ....................................................... 415
Intelligent Queue functionality ....................................................... 416
Optional functionality ................................................................. 416
Core functionality ........................................................................ 416
Incoming call handling ................................................................. 417
Music on hold ................................................................................ 419
System administration .................................................................. 419
Optional functionality ................................................................. 420
Callback processing ....................................................................... 420
Agent call recording ....................................................................... 421
Call detail reporting ....................................................................... 421
Planning the number of ports you require ..................................... 421
<table>
<thead>
<tr>
<th>Topics</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Types of ports</td>
<td>422</td>
</tr>
<tr>
<td>Types of messaging ports</td>
<td>422</td>
</tr>
<tr>
<td>Types of messages</td>
<td>424</td>
</tr>
<tr>
<td>Number of ports purchased</td>
<td>425</td>
</tr>
<tr>
<td>Understanding the call flow process</td>
<td>426</td>
</tr>
<tr>
<td>Creating call flows</td>
<td>426</td>
</tr>
<tr>
<td>Setting up Intelligent Queue</td>
<td>427</td>
</tr>
<tr>
<td>Administration procedures</td>
<td>428</td>
</tr>
<tr>
<td>Logging on and off for the first time (Administrator)</td>
<td>428</td>
</tr>
<tr>
<td>Entering your purchased options</td>
<td>429</td>
</tr>
<tr>
<td>Setting up administrator and user permissions</td>
<td>429</td>
</tr>
<tr>
<td>Changing system modes</td>
<td>429</td>
</tr>
<tr>
<td>Changing passwords</td>
<td>430</td>
</tr>
<tr>
<td>Setting up the automatic database backup</td>
<td>431</td>
</tr>
<tr>
<td>Configuring ports</td>
<td>432</td>
</tr>
<tr>
<td>Configuring PBX settings</td>
<td>432</td>
</tr>
<tr>
<td>Manually configuring PBX settings</td>
<td>432</td>
</tr>
<tr>
<td>Configuring Contact Center Management settings</td>
<td>433</td>
</tr>
<tr>
<td>Configuring Music Manager</td>
<td>433</td>
</tr>
<tr>
<td>Disabling Windows sounds</td>
<td>434</td>
</tr>
<tr>
<td>Preventing CDs from starting automatically</td>
<td>434</td>
</tr>
<tr>
<td>Removing a music file from the play list</td>
<td>434</td>
</tr>
<tr>
<td>Adjusting music volume</td>
<td>435</td>
</tr>
<tr>
<td>Configuring Updated position in queue</td>
<td>435</td>
</tr>
<tr>
<td>Before you configure Updated position in queue messages</td>
<td>436</td>
</tr>
<tr>
<td>Configuring Updated position in queue for all queue positions</td>
<td>436</td>
</tr>
<tr>
<td>Configuring Updated position in queue for specific queue positions</td>
<td>437</td>
</tr>
<tr>
<td>Creating action plans</td>
<td>437</td>
</tr>
<tr>
<td>Creating unverified collected digits plans</td>
<td>438</td>
</tr>
<tr>
<td>Creating verified collected digits plans</td>
<td>439</td>
</tr>
<tr>
<td>Creating interactive tree plans</td>
<td>446</td>
</tr>
<tr>
<td>Setting up messaging plans</td>
<td>450</td>
</tr>
<tr>
<td>Configuring emergency messaging</td>
<td>452</td>
</tr>
<tr>
<td>Activating emergency messaging over the phone</td>
<td>454</td>
</tr>
<tr>
<td>Setting up routing plans</td>
<td>454</td>
</tr>
<tr>
<td>Managing Conditions: Assigning conditions to call flows</td>
<td>455</td>
</tr>
<tr>
<td>Creating ANI conditions</td>
<td>455</td>
</tr>
<tr>
<td>Creating DNIS conditions</td>
<td>456</td>
</tr>
<tr>
<td>Creating emergency conditions</td>
<td>457</td>
</tr>
<tr>
<td>Creating queue conditions</td>
<td>458</td>
</tr>
<tr>
<td>Creating redirection conditions</td>
<td>458</td>
</tr>
<tr>
<td>Creating schedule conditions</td>
<td>459</td>
</tr>
<tr>
<td>Managing call flows</td>
<td>460</td>
</tr>
<tr>
<td>Overview of creating a call flow</td>
<td>460</td>
</tr>
<tr>
<td>Managing port groups: updated position in queue, messaging, callback, and recording ports</td>
<td>461</td>
</tr>
<tr>
<td>Configuring an updated position in queue port group</td>
<td>462</td>
</tr>
<tr>
<td>Configuring a messaging port group</td>
<td>462</td>
</tr>
<tr>
<td>Configuring a callback port group</td>
<td>462</td>
</tr>
</tbody>
</table>
Configuring a recording port group .......................................................... 463
Viewing system, port, and callback queue status. ...................................... 463
Viewing system status ................................................................. 463
Viewing port status ........................................................................ 464
Viewing callback queue status............................................................ 464

Callback and recording plans ................................................................. 465
Managing outgoing calls: Voice and Web Callbacks ................................. 465
  Overview of voice and web callbacks .................................................. 465
  Callback call processing ................................................................... 466
Configuring web callbacks in Windows Server 2003 ................................ 467
Configuring web callbacks in Windows Server 2008 ................................. 467
Setting up callback plans .................................................................... 468
Assigning caller messages to callback plans. .......................................... 468
Assigning agent messages to callback plans ........................................... 469
Assigning agent options to callback plans ............................................ 470
Setting callback plan parameters ......................................................... 470

Managing recording plans ................................................................. 471

Maintaining Intelligent Queue and Contact Center Management ............. 472
Adding an Intelligent Queue media server to Contact Center Management ........................................................................................................... 472

Using Network Monitor with Intelligent Queue ..................................... 472
  Configuring data collection settings for Intelligent Queue media servers .................................................................................................................. 473
  Configuring Contact Center Management settings in Intelligent Queue .................................................................................................................. 473
  Resolving Network Monitor alarms ...................................................... 473

Configuring Intelligent Queue devices .................................................. 473
  Intelligent Queue Smart Choice layers .................................................. 473
  Intelligent Queue ports ......... 474
  Intelligent Queue exit codes ................................................................ 475

Creating reports .................................................................................. 475
  Before you can produce a report ........................................................... 475
  Report types .................................................................................... 475

Recording voice prompts ...................................................................... 478
Recording messages ............................................................................ 478
  Recording messages with a microphone .............................................. 478
  Recording messages with a phone, using Intelligent Queue ................. 478

Converting .wav files ........................................................................... 479
Readback .wav file names .................................................................... 479
Recorded phrases ................................................................................. 480

Web Callback ....................................................................................... 483
Viewing the Web Callback example page .............................................. 483

Customizing your Web Callback page .................................................. 484
  Customizing the header ...................................................................... 485
  Customizing the footer ...................................................................... 485
  Customizing the Cascading Style Sheet .............................................. 485
  Customizing the Web configuration .................................................... 485
  Customizing the content of the Web Callback page ............................ 486

Troubleshooting Intelligent Queue issues ................................................. 487
Troubleshooting using the configuration wizard ..................................... 488
Establishing a connection to the database ............................................... 489
Workforce Scheduling, Schedule Adherence, and Employee Portal

Workforce Scheduling .............................................................. 501
  Before installing Workforce Scheduling.................................. 501
  Enabling remote SQL Server connections ............................... 501
  Granting SQL Server permissions......................................... 502
Upgrading from Contact Center Scheduling to Workforce Scheduling .......... 503
Installing Workforce Scheduling .............................................. 503
Using Workforce Scheduling .................................................... 503
  Viewing the Workforce Scheduling user interface..................... 504
    People pane .............................................................. 505
    Time bar pane .................................................................. 505
    Totals pane ..................................................................... 505
    Schedule details pane ...................................................... 506
Understanding forecasting concepts ............................................ 507
Understanding the Workforce Scheduling process ......................... 508
Workforce Scheduling and your contact center needs ....................... 510
  Assigned shift-based scheduling configuration scenario............. 510
  Availability-based scheduling configuration scenario ............... 510
  Rotational-based scheduling configuration scenario ................. 511
  Forecast-based scheduling configuration scenario .................... 511
Before you start scheduling ..................................................... 512
  Selecting a scheduling method ............................................. 513
    Scheduling using forecast data ........................................ 513
    Scheduling manually ..................................................... 513
Schedule setup and customization ............................................... 513
Starting Workforce Scheduling on a client computer ....................... 514
Configuring schedule options ........................................... 514
Configuring scheduling options using the Schedule wizard. .... 514
Creating schedules ....................................................... 515
Adding employees to schedules ..................................... 515
Configuring business hours for schedules ....................... 515
Renaming schedules .................................................... 516
Deleting schedules ....................................................... 516
Activating / Deactivating schedules ................................ 516
Configuring shifts ....................................................... 516
Adding fixed shifts ...................................................... 517
Adding variable shifts ................................................ 517
Renaming shifts ......................................................... 517
Deleting shifts .......................................................... 518
Configuring breaks ...................................................... 518
Adding fixed breaks .................................................... 518
Adding variable breaks .............................................. 518
Renaming breaks ........................................................ 519
Deleting breaks .......................................................... 519
Configuring jobs ........................................................ 519
Adding fixed jobs ....................................................... 520
Adding variable jobs .................................................. 520
Renaming jobs ............................................................ 520
Deleting jobs ............................................................. 521
Adding breaks or jobs to shifts ..................................... 521
Removing breaks and jobs from shifts ........................... 521
Assigning shifts to schedules ....................................... 521
Assigning shifts to employees ...................................... 522
Configuring event display preferences ............................. 522
Configuring the time bar display .................................. 522
Configuring the smallest scheduling time interval ............ 523
To prevent users from manually making changes that trigger warnings 523
Configuring the default colors on the time bar ................ 523
Configuring the time format ........................................... 524
Configuring tool tip display ......................................... 524
Configuring warnings .................................................. 524
Schedule creation ....................................................... 526
Building schedules with Schedule Builder ....................... 526
Configuring the date and time range ............................... 527
Scheduling shifts ....................................................... 527
Scheduling breaks ....................................................... 528
Generating schedules with forecast data ....................... 528
Generating schedules without forecast data ................... 528
Generating schedules for your entire workforce ............... 528
Selecting employees ..................................................... 528
Configuring scheduling options ................................. 529
Creating and adjusting schedules manually ..................... 529
Loading schedules ..................................................... 530
Populating schedules with events ................................. 530
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drag inserting events</td>
<td>530</td>
</tr>
<tr>
<td>Recurring events</td>
<td>531</td>
</tr>
<tr>
<td>Mass deleting events</td>
<td>531</td>
</tr>
<tr>
<td>Mass applying time off</td>
<td>531</td>
</tr>
<tr>
<td>Modifying forecast totals in the event totals pane</td>
<td>532</td>
</tr>
<tr>
<td>Modifying event times and notes in the schedule details pane</td>
<td>532</td>
</tr>
<tr>
<td>Schedule distribution</td>
<td>533</td>
</tr>
<tr>
<td>Viewing schedules</td>
<td>533</td>
</tr>
<tr>
<td>Viewing scheduled events</td>
<td>533</td>
</tr>
<tr>
<td>Changing the time interval of the time bar pane</td>
<td>533</td>
</tr>
<tr>
<td>Viewing event totals</td>
<td>534</td>
</tr>
<tr>
<td>Viewing schedule details</td>
<td>534</td>
</tr>
<tr>
<td>Synchronizing views</td>
<td>535</td>
</tr>
<tr>
<td>Running schedule reports</td>
<td>535</td>
</tr>
<tr>
<td>Running on-demand reports</td>
<td>535</td>
</tr>
<tr>
<td>Running scheduled reports</td>
<td>536</td>
</tr>
<tr>
<td><strong>Schedule Adherence</strong></td>
<td>537</td>
</tr>
<tr>
<td>Configuring adherence preference</td>
<td>537</td>
</tr>
<tr>
<td>Configuring adherence parameters</td>
<td>537</td>
</tr>
<tr>
<td>Configuring state groups</td>
<td>538</td>
</tr>
<tr>
<td>Viewing adherence monitors in Contact Center Client</td>
<td>538</td>
</tr>
<tr>
<td>Adherence Detail Grid monitor</td>
<td>538</td>
</tr>
<tr>
<td>Adherence Timebars monitor</td>
<td>540</td>
</tr>
<tr>
<td>Employee State by Position/Time monitors</td>
<td>541</td>
</tr>
<tr>
<td>Running adherence reports</td>
<td>542</td>
</tr>
<tr>
<td><strong>Employee Portal</strong></td>
<td>542</td>
</tr>
<tr>
<td>Employee functionality</td>
<td>542</td>
</tr>
<tr>
<td>Starting Employee Portal</td>
<td>543</td>
</tr>
<tr>
<td>Creating a desktop shortcut to Employee Portal</td>
<td>543</td>
</tr>
<tr>
<td>Viewing currently scheduled shifts</td>
<td>543</td>
</tr>
<tr>
<td>Offering shifts for other employees to take or trade</td>
<td>543</td>
</tr>
<tr>
<td>Removing shifts from the bulletin board</td>
<td>543</td>
</tr>
<tr>
<td>Proposing to take shifts</td>
<td>543</td>
</tr>
<tr>
<td>Proposing to trade shifts</td>
<td>544</td>
</tr>
<tr>
<td>Accept or reject an employee proposal to take or trade your shift</td>
<td>544</td>
</tr>
<tr>
<td>Requesting time off</td>
<td>544</td>
</tr>
<tr>
<td>Requesting availability changes</td>
<td>544</td>
</tr>
<tr>
<td>Supervisor functionality</td>
<td>545</td>
</tr>
<tr>
<td>Handling employee scheduling requests</td>
<td>545</td>
</tr>
<tr>
<td>Employee Portal reports</td>
<td>546</td>
</tr>
<tr>
<td><strong>Traffic Analysis</strong></td>
<td>549</td>
</tr>
<tr>
<td>Traffic Analysis</td>
<td>549</td>
</tr>
<tr>
<td>Using Traffic Analysis</td>
<td>549</td>
</tr>
<tr>
<td>Setting up telephone systems to collect traffic data</td>
<td>549</td>
</tr>
<tr>
<td>Setting up the SX-2000 without datasets</td>
<td>549</td>
</tr>
</tbody>
</table>
Setting up the 3300 ICP ........................................ 550
Configuring media servers in YourSite ........................................ 553
Verifying traffic data is saved on the Enterprise Server ............... 553

Multimedia Contact Center

Multimedia Contact Center ........................................ 557
Using Multimedia Contact Center ........................................ 557
Multimedia Contact Center options in Contact Center Management ........................................ 557
Disassociating email addresses ........................................ 558
Starting Multimedia Contact Center on a client computer ............... 558
Multimedia Contact Center options in Outlook ........................................ 559
Verifying real-time server connection parameters ........................................ 560
Configuring Multimedia Contact Center startup options ............... 561
  Displaying shortcuts ........................................ 561
  Displaying the agent login window ........................................ 561
  Configuring which inbox opens when you start Outlook ........................................ 561
  Displaying real-time queue statistics ........................................ 561
Configuring Multimedia Contact Center arrival options ............... 562
  Displaying Outlook as your top window when contacts arrive ........................................ 562
  Directing ACD contacts to your Agent Inbox ........................................ 562
  Configuring contact arrival sounds ........................................ 562
  Checking spelling ........................................ 563
  Replying to faxes with the original fax request ........................................ 563
Customizing the Agent Inbox columns ........................................ 563
Agent actions ........................................ 564
  Performing agent actions ........................................ 564
Logging on ........................................ 564
  Logging in to multiple media types ........................................ 565
  Logging in to one media type at a time ........................................ 565
Setting Make Busy Reason Codes ........................................ 565
  Setting Make Busy Reason Codes for multiple media types ........................................ 565
  Setting Make Busy Reason Codes for one media type at a time ........................................ 566
Requeuing contacts ........................................ 566
Contact management ........................................ 566
  Creating and using Multimedia Contact Center templates ........................................ 567
    Creating templates ........................................ 567
    Using templates ........................................ 567
  Replying to emails/SMS messages ........................................ 568
  Replying to chats ........................................ 568
Viewing faxes ........................................ 569
  Replying to faxes ........................................ 569
Tagging contacts with Account Codes ........................................ 569
Placing contacts on hold ........................................ 569
Transferring contacts ........................................ 570
Setting No Reply Needed ........................................ 570
Viewing client history ........................................ 570
  Viewing current case history ........................................ 571
  Viewing entire contact history ........................................ 571
  Viewing a specific contact history ........................................ 571
Chapter 1

Contact Center Solutions

What’s new in Version 5.7 SP1
Contact Center Enterprise Edition and Contact Center Business Edition
Licensing
About this user guide
Required and optional software components
Contact Center Solutions

Mitel Contact Center Solutions is designed for the 3300 IP Communications Platform (ICP), SX-2000, SX-200 ICP, 5000, and Axxess telephone systems. Contact Center Management is the core Contact Center Solutions product.

Contact Center Management
- Provides a browser-based user interface (UI) that works across Windows platforms.
- Operates in conjunction with familiar Microsoft Office productivity tools.
- Is installed on the server only.
- Instantly deploys configuration changes from the server to authorized intranet and Internet users.
- Enables you to log on to any computer and manage contact center operations and configure system features.

What’s new in Version 5.7 SP1?

The following features and product enhancements have been introduced with Contact Center Solutions Version 5.7 SP1.

Interactive Contact Center—Agent group presence enhancements
Support for Agent Group Presence functionality has been enhanced with new Contact Center Management website security settings that enable you to show or hide agent group presence controls in Contact Center Client based on agent Class of Service settings.

For more information, see “Using agent group presence” on page 334.

ACD license violation notifications
In Mitel MCD 4.0 SP2 and 4.1, general hot desk sets and ACD hot desk sets are no longer mutually exclusive. Any set designated as a hot desking phone is now available for both general hot desk users and ACD hot desk users to log into. This enables agents to move freely around an organization, log in at any phone, and have the ACD system route calls to them at their location.

Hot desk agents using Contact Center PhoneSet Manager and Contact Center Softphone will now participate in the new concurrent licensing model on the 3300 ICP. When a hot desk agent logs in to the system a license is drawn from the MCD Active Agent licensing pool and upon logout, the license is released back to the pool. Any user who attempts to log in when there are no available licenses will receive a notification that the number of current active users has exceeded the number of available licenses. Supervisors who attempt to log in agents using Interactive Contact Center will receive the same notification if there are no remaining licenses.

Support for Personal Identification Number (PIN) protection
Similar to general hot desk user logins, ACD hot desk agent logins now offer the ability to password protect the agent login with a PIN. Contact Center PhoneSet Manager and Contact Center Softphone now prompt users participating in the use of PINs to enter their PIN upon login. Hot desk users who use Interactive Contact Center to login will also be prompted for their PIN. However, supervisors who use Interactive Contact Center to login agents will not be prompted for the agent’s PIN as they will have a higher permission level, controlled by Class of Service, that does not require them to specify PINs when using interactive agent controls. Contact Center Client users who do not want to participate in the use of PINs will continue to operate as usual.

For more information, see "Logging on an agent" or "Opening the soft phone" in the Contact Center Solutions User Guide.
Reporting enhancements
Contact Center Management now offers Queue Group Performance by Queue and Queue Group Performance by Queue - Multi-select reports. Both reports provide Reporting number, Name, Max agents logged in, Offered calls per day, ACD calls offered, Average ACD handling time, ACD calls handled, Average ACD time to answer, Service Level %, calls abandoned, Abandon %, External outbound calls, Average external outbound calls handling time, and External outbound calls handling time statistics.

The only difference between the two reports is that if you select multiple queue groups to report on for a Queue Group Performance by Queue report, Contact Center Management will make a separate report for each queue group, and if you select multiple queue groups to report on for a Queue Group Performance by Queue - Multi-select report, all of the selected queue groups will display in a single report.

For more information, see "Queue Group Performance by Queue" and "Queue Group Performance by Queue - multi-select" in the Contact Center Solutions Enterprise Edition Reports Guide.

Email alarm enhancements
The computer name and IP address of the server computer being alarmed on is now included in email alarm notifications.

Soft phone enhancements
The Automatically log off this ACD agent when closing the soft phone option is now enabled by default.

Workforce Scheduling enhancements
Workforce Scheduling has been enhanced with the following functionality for Version 5.7 SP1:
   • Added a Microsoft Office styled Recent Schedules list to the main menu
   • Added the ability to insert time off in the middle of a scheduled shift
   • Added a mass delete option to filter by employee, reporting number, full time/part time, and fixed or variable shift type
   • Added the ability to schedule staff within scheduled unavailable time and time off
   • Added the ability to mix variable shifts and fixed breaks with fixed shifts and variable breaks

For more information, see "Workforce Scheduling" in the Contact Center Solutions User Guide.

Employee Portal enhancements
Added date and time to employee requests so supervisors can prioritize requests based on date and time of submission.

For more information, see "Employee Portal" in the Contact Center Solutions User Guide.

Salesforce.com Integration enhancements
Salesforce.com Integration has been enhanced with the following functionality for Version 5.7 SP1:
   • Added support for ACD hot desking agents
   • Added support for general business, non-ACD, hot desking agents
   • Added a customizable button in the soft phone to pop up new Leads

Intelligent Queue reporting enhancements
Four new Intelligent Queue DNIS reports have been added in this release:
   • DNIS Group Performance by DNIS
   • DNIS Group Performance by DNIS by Period
   • DNIS Group Performance by Period
   • DNIS Performance by Period
Contact Center Enterprise Edition and Contact Center Business Edition

For more information, see "Intelligent Queue reports" in the Contact Center Solutions Enterprise Edition Reports Guide.

**Technology updates**
Contact Center Solutions Version 5.7 SP1 introduces support for:
- SQL Server 2008 Express R2 (10 GB database limit)
- 64-bit client computers running Windows Vista and Windows 7
- Microsoft Excel 2010 is now supported for use with Contact Center Solutions and Call Accounting

**Contact Center Enterprise Edition and Contact Center Business Edition**

The Contact Center Solutions portfolio comprises Contact Center Enterprise Edition and Contact Center Business Edition. Contact Center Business Edition is for individual contact centers with 25 or fewer agents. When customers purchase Contact Center Business Edition, they can select from a number of applications including historical reporting, real-time monitoring, dynamic agent and queue control, screen pops, and intelligent messaging.

Contact Center Enterprise Edition (formerly Contact Center Solutions) is for sophisticated contact centers and supports all forms of communication including voice, email, web chat, fax, and walk-in customer distribution. This scalable, resilient solution combines robust IP communications platforms, Automatic Call Distribution (ACD), and a modular suite of feature-rich, web-based applications for streamlining contact center management and enabling agent productivity.

The Contact Center Solutions applications and contact center devices available to you depend on whether you have Contact Center Business Edition or Enterprise Edition.

Contact Center Solutions includes the following applications:
- Contact Center Management
- Interactive Contact Center
- Interactive Visual Queue
- Contact Center PhoneSet Manager
- Contact Center Softphone*
- Contact Center Screen Pop*
- Flexible Reporting
- Intelligent Queue*
- Salesforce.com Integration
- Workforce Scheduling
- Schedule Adherence
- Traffic Analysis*
- Multimedia Contact Center
- Enterprise Node
- Teleworker Solution*
- CTI Developer Toolkit*
* Not currently supported for the Mitel 5000 and Axxess telephone systems. Support will be made available in a future release of Contact Center Solutions.

**Licensing**

An employee is a physical person you track in your contact center. In the YourSite database, you must create an employee ID for each employee who works in your contact center. Employees can have multiple agent IDs, but only one employee ID. You can run reports on licensed employees only. The number of employees you license in YourSite Configuration must be consistent with your software license.

To view details on your software license
- Click **Help=>About your Mitel applications**.

To view details on applications installed by Professional Services
- Click **Help=>About your Mitel applications=>Professional Services**

**About this user guide**

This user guide provides information on how to manage your contact center using the Contact Center Solutions applications. To make full use of Contact Center Solutions, you must have a working knowledge of the Microsoft Windows operating environment and Microsoft Excel 2003 or greater. The tutorials that accompany Microsoft Windows and Excel provide information on basic use.

**Chapter 1 Contact Center Solutions**

Chapter 1 describes
- The features and benefits of Contact Center Management
- Licensing
- The layout of the user guide
- Document conventions
- Information on how to install client applications from the Contact Center Management website

**Chapter 2 Contact Center Concepts**

Chapter 2 describes
- The inbound contact center environment
- How resources interact to process contacts

**Chapter 3 Contact Center Planning and Management**

Chapter 3 provides information on how to plan and manage your contact center, including how to
- Establish a corporate Service Level objective
- Collect data.
- Forecast the Call Load.
- Calculate the resources required.
- Schedule agents.
- Determine contact center costs.

**Chapter 4 Getting Started**

Chapter 4 describes how to
- Register your software.
- View multiple Contact Center Management sessions.
- Back up and restore the YourSite database and raw telephone system data files.
• Set up client computers to use Contact Center Management.
• Specify user preferences.

Chapter 5 Services and Database Administration
Chapter 5 describes how to
• Start and stop the Contact Center Management services.
• Perform database and maintenance functions.

Management Console resides in the Contact Center Client real-time application. Using Management Console, you can
• Back up and restore YourSite database configuration data.
• Update the server IP address.
• Import configuration data used to configure the YourSite database.
• Run the maintenance routine.
• Summarize data for running reports.
• Create a support package.

Chapter 6 Configuration
Chapter 6 describes how to
• Configure contact center devices in the YourSite database so you can view real-time activity and generate reports on these devices.
• Configure the YourSite database using Synchronization.
• Create business hour schedules.
• Configure data alarms.
• Implement security measures to restrict user access to specific Contact Center Solutions application areas and contact center devices.
• Configure call recordings.

Chapter 7 Real-time Monitors and device control
Chapter 7 describes how to
• View real-time agent and queue statistics on real-time monitors.
• Configure alarms for agent and queue performance.
• Customize monitor display characteristics.
• Build marquee monitors and broadcast statistics and messages.
• Chat online with agents or supervisors.
• Configure and display real-time statistics on one or more wall signs.
• Set up support for teleworking.
• Add and view call notes appended to calls.

Chapter 8 Reports
Chapter 8 describes how to
• Generate on-demand reports.
• Set up timetables for generating reports.

Chapter 9 Forecasting
Chapter 9 describes how to
• Create forecasts.
• Export forecasts to Excel.
Chapter 10 Data-mining Tools
Chapter 10 describes how to
• Search for agent and ACD queue event records.
• Search for specific contact center events.
• View the historical real-time events that occurred on a particular date, in the sequence they occurred.

Chapter 11 Data Collection
Chapter 11 describes how to
• View data and system alarms.
• Verify media servers are receiving telephone system data.

Chapter 12 Interactive Contact Center
Chapter 12 describes how to
• Control the availability of agents and ACD queues.

Chapter 13 Interactive Visual Queue
Chapter 13 describes how to
• View calls within queues and move calls from busy queues to less active queues.
• Call back abandoned callers.

Chapter 14 Contact Center PhoneSet Manager and Contact Center Softphone
Chapter 14 describes how to
• Enable agents to use their desktop computers as IP-based phones.

Chapter 15 Contact Center Screen Pop
Chapter 15 describes how to
• Launch applications or Web pages when agents receive calls.
• Provide agents with caller and account information via pop-ups on their computer monitors when they receive calls.

Chapter 16 Flexible Reporting
Chapter 16 describes how to
• Design your own report templates and customize existing reports.

Chapter 17 Intelligent Queue
Chapter 17 describes how to
• Provide static messaging, intelligent messaging, voice and web callbacks, and call recording.

Chapter 18 Workforce Scheduling
Chapter 18 describes how to
• Schedule agents.
• Measure employee adherence to schedules.

Chapter 19 Traffic Analysis
Chapter 19 describes how to
• Set up the telephone system and YourSite database so you can collect data and run reports on the traffic data stream.

Chapter 20 Multimedia Contact Center
Chapter 20 describes how to
• Configure Contact Center Management so you can track and run reports on multimedia contacts.
Locating the latest versions of our guides

prairieFyre recommends you obtain the latest versions of our guides.

To obtain the *Mitel Contact Center Solutions User Guide*:
- Start Internet Explorer and type http://www.prairiefyre.com/wp-content/rscs/documentation/ContactCenterSolutions_UserGuide.pdf

To obtain the *Mitel Call Accounting User Guide*:

Document conventions

This document uses the following conventions.

**UI syntax**
The following terms apply to actions you perform on the UI:
- *Click* precedes options you select with the mouse, such as buttons, menus, and items in list boxes.
- *Press* precedes keys you use on the keyboard.
- *Select or clear* precedes options you turn on or turn off, such as check boxes.
- *Select* precedes options you select in combo boxes (text boxes with attached list boxes).

For example,
1. **Click** OK.
2. **Press** Enter.
3. **Select** the **PFdatabase** check box.
4. **Drag** and **drop** the name to the **Available** list.

**Italics**
Italic typeface is used
- For emphasis (for example, *hot desking*)
- To set off words, letters, and numbers referred to as themselves in the text (for example, *overflow* is the routing of calls to more than one queue; the application saves text files as *MMDDYYYY.sql*)
Bold
Bold typeface designates paths you select in your root directory and items you click, press, type, or select.

For example,

1. Click OK.
2. Delete 50 and type 60.
3. Select the Check database integrity check box.

UI Menu items
UI menu items you select are separated by an arrow [=>]. For example, File=>Open tells you to select the Open submenu on the File menu.

Note
The word NOTE: designates essential user information.

Searching for key words and definitions
The Help Documentation menu displays the user guides and installation guides available. The documents are in .pdf format and will open in your browser in Adobe Reader or Adobe Acrobat. The first time a key word or acronym is used in the guide it is defined.

To search for a key word or definition in the guide, such as ACD

1. Click Help=>Documentation.
2. Select the Mitel Contact Center Solutions User Guide.
3. On the Adobe toolbar, click the Binocular icon to search for key words or definitions.
4. After What word or phrase would you like to search for? type ACD.
5. Click Search.
   The Table of Contents opens and the first instance of ACD is highlighted.
6. Under Results, click the ACD hypertext link to locate the next instance of ACD.

Required and optional software components
Contact Center Solutions applications have a number of required and optional applications you install on client computers.

Required components
In order to use Contact Center Solutions and Call Accounting applications, the following components must be installed on client computers.

- Microsoft .NET Framework enables your computer to run applications created with .NET. All client computers must have the latest version of .NET Framework installed.
- Microsoft Internet Explorer updates your browser software to the latest version. All client computers require IE 6.0 or greater.
- Microsoft Report Viewer 2005 Redistributable Package includes Windows Forms and ASP.NET Web server controls for viewing reports designed using Microsoft reporting technology.
- Web Services Enhancements (WSE) 3.0 for Microsoft .NET is the Microsoft .NET Framework version 3.0 redistributable package that installs the common language runtime and associated files required to run applications developed to target the .NET Framework.
- Microsoft DirectX significantly enhances graphics, sound, music, and 3-D animation in Windows applications.
Optional components

You can install the following application on client computers.

- Adobe Reader enables you to view documents and reports in .pdf format. You require Acrobat Reader to view the online user guide, user tutorial, reporting guide, and reports. If you have Microsoft Excel, you can also use it to view reports.
- Remote Server installs media servers (for voice, email, fax, or chat), and/or the WallBoarder Service on a computers other than the Enterprise Server.
- WebChat Server installs the Multimedia Contact Center WebChat Server. You install this software on the public Web server only.
  
  NOTE: If you are upgrading from a previous version of WebChat Server to version 5.4 or later, you must upgrade your WebChat Server software to the same version as your Contact Center Solutions software.

Client Component Pack

Client Component Pack contains all of the Contact Center Management, Flexible Reporting, Multimedia Contact Center, and Workforce Scheduling software components that contact center employees could need on their computers. You require administrator privileges to run this installation.

You can install Client Component Pack on individual client computers or servers running Windows or Citrix Terminal Services with or without the Mitel Unified IP Client for Sun Ray Solution.

You can install the following software components.

- Contact Center Client enables you to monitor devices in real time, run Contact Center PhoneSet Manager or Contact Center Softphone, Management Console, and Network Monitor.
- Flexible Reporting enables you to run reports, create new report templates, redesign report templates based on existing Contact Center Management voice reports, and modify report templates available in Flexible Reporting.
- The Multimedia Contact Center Outlook Extensions download enables you to use the Multimedia Contact Center Outlook Extensions download to run Multimedia Contact Center on client computers.
- Salesforce.com Integration enables you to integrate Contact Center Solutions with Salesforce.com
- The Workforce Scheduling download enables you to run Workforce Scheduling on client computers.
Chapter 2
Contact Center Concepts

Automatic Call Distribution (ACD)
Inbound call environment
Contact Center Concepts

Contact centers process a high volume of contacts to meet marketing, sales, customer service, technical support, and other business objectives. A fine-tuned contact center distributes contacts efficiently and optimizes the use of agents and other resources. This section describes the inbound contact center environment and how resources interact to process voice contacts.

Automatic Call Distribution (ACD)

Automatic Call Distribution (ACD) is a specialized mechanism for distributing incoming calls. The primary goal of ACD is to ration calls to agents in a cost-effective manner that provides acceptable service to callers.

To optimize the use of agents, you cross-train them so they can handle a variety of inquiries. Rather than distributing calls to a number of small, specialized agent or extension groups, ACD distributes them efficiently among the entire pool of available agents. When you consolidate resources (use the Pooling Principle), the same number of contact center agents handle more calls while maintaining Service Levels.

Typically, you program ACD to ensure the first call to arrive reaches the first available agent or the agent who has been idle the longest. However, you can vary the order of calls and agents to provide superior service to preferred customers, and skills-based routing.

Understanding ACD call flow

The path of an incoming call is as follows. A caller telephones your contact center via the Public Switched Telephone Network (PSTN). (The PSTN is a global collection of Central Offices (COs) interconnected by long-distance telephone switching systems.) The local CO directs the call to one of your trunk groups. An available trunk picks up the call. Typically, calls from the PSTN arrive to the contact center over incoming trunks and calls from the contact center to the PSTN travel over outgoing trunks. If no trunks are available, the call does not get through to the system (it is blocked) and the caller receives a busy signal.

When a trunk picks up a call, it forwards it through to a group of agents handling calls, or to some other answering point. The call arrives at the ACD queue of an agent group. The queue delays the call rather than blocking the call from entering the system. The length of time the caller waits in queue is the queue time. While waiting in queue, the caller listens to product features, announcements, or other messages provided by a Recorded Announcement Device (RAD). The caller can wait patiently in queue for an available agent, leave a voice mail message, or hang up (abandon) the call. (See Figure 2-1.)

An agent handles the call. The time the caller spends talking to the agent is the ACD Handling Time (including the hold time). If the agent calls the supervisor in search of more information (while the caller is on hold) and/or transfers or conferences the call, these times are added to the ACD Handling Time value.

For example, an agent speaks to a caller for two minutes and then puts the caller on hold for three minutes and tries to solve the problem. This may include a call to the supervisor. The agent then initiates a conference call with the caller and a third party and they speak for three minutes and resolve the issue. Therefore, the ACD Handling Time for the agent is 2 + 3 + 3 = 8 minutes.

When the call is completed, the agent might need to perform additional work associated with the call. The time taken to perform this work is the Wrap Up Time.
Monitoring the call flow process

Second-by-second (real-time) statistics presented on wall signs and desktop monitors enable you to monitor the service provided to callers. You can monitor the number of incoming calls, the time it takes to process them, the queue load, and the availability of agents using a Management Information System (MIS). The MIS refers processes data produced by the telephone system. The MIS uses telephone system records to provide forecasting, real-time monitoring, and reporting functions.

Ensuring traffic-carrying efficiency

To optimize traffic-carrying efficiency ensure

- Sufficient trunks are available to carry incoming calls.
- Callers experience a delay in queue.
- There is a random distribution of calls among available agents.

Scheduling to optimize call flow

You schedule agents so the number of incoming calls at any given time typically exceeds the number of agents currently available. The intent is that callers experience a slight delay before agents answer their calls. The expected number of incoming calls forecasted for the time of day, and day of the week influence scheduling decisions.

Routing calls

Call routing options you program in the telephone system provide a set of instructions that automate the movement of calls to their intended answering points. You can define options—for example, if the caller dials 1, the system forwards the caller to customer service. You can specify re-routing for calls not answered after a set period of time and parse incoming Automatic Number Identification (ANI) and Dialed Number Identification Service (DNIS) data to direct call routing. (See Figure 2-2.)
Dialing an agent’s extension

In the simplest call scenario, a single trunk picks up an incoming call to your contact center. The telephone system presents the caller with options to dial various answering points. The caller dials an individual agent at an extension through a queue number. A queue number is an address mechanism for a queue or other answering point. The programming associated with the queue number defines the routing and timing features of the call. The telephone system collects data on the agent and trunk involved in the call. The ACD management reporting application produces reports on agent and trunk activity.

Dialing a queue

In the next call scenario a trunk group picks up an incoming call to your contact center. The system presents the caller with options to dial various answering points. The caller dials queue number 1 to reach queue 1 (Customer Service). The system forwards the call to the first available agent in the agent or extension group associated with queue 1. The call is an ACD call because one dialable number represents all of the agents in the group. The telephone system collects data records for the call. The ACD management software produces Queue Reports on queue 1.

Overflowing calls

An ACD call that is not answered immediately is placed in a queue. If an agent does not pick up the call after a set amount of time (the overflow time) the system places the call in the queue of another agent group, in addition to keeping it in the first queue. The first available agent in either group handles the call. The overflow feature limits the delay faced by callers by queuing calls against two or more agent groups. (See Figure 2-3.)
Interflowing calls

You can program the telephone system to direct a queue delayed call to voice mail or to another answering point. The interflow timer runs independently of the overflow timer. If the interflow timer expires, the system removes the call from the queue and re-directs it to another answering point, such as a trunk or voice mail.

The inbound call environment

The inbound contact center environment has unique characteristics that must be considered in effective planning and management.

Predicting call arrivals

Calls arrive randomly to contact centers. You cannot predict the minute-to-minute arrival of calls. This results in unanticipated increases in workload, and impacts staffing calculations and the load carried by system and network resources.

You can predict the pattern of call arrivals for 15-minute or longer intervals. For example, you can predict that next Monday between 1:00 P.M. and 1:30 P.M. you will receive 60 phone calls. However, you cannot predict how many calls will arrive in the first five minutes, the second five minutes, and so on.

Understanding caller tolerance

Several factors influence a caller’s tolerance to queue delays:

- The immediacy of the caller’s requirement
- The availability of similar products or services
- The caller’s expectations for service
- The time available to make the call
- Whether or not the caller is paying for the call
Chapter 3
Contact Center Planning and Management

Establish a service level objective
Collect data
Forecast the Call Load
Calculate the resources required
Schedule agents
Determine contact center costs
Contact Center Planning and Management

Effective contact center management involves having the right resources in place at the right times to handle an accurately forecasted workload at the desired level of service. Commitment to a systematic planning and management strategy is essential. The strategy is based on corporate objectives that you continually assess and refine.

Whether you are managing a start-up contact center or refining the performance of an existing operation, the process illustrated in Figure 3-1 applies. It is the basic framework for achieving and maintaining your service objectives.

Figure 3-1 Planning cycle

1. Establish a Company Service Level Goal
2. Collect Data
3. Forecast the Call Load
4. Calculate Required Resources
5. Schedule Agents
6. Determine Contact Center Costs

The objective of contact center management is to find the right balance between the agents scheduled and the service provided to customers. This involves assessing and re-assessing trade-offs between the Service Level, agents scheduled, and average call duration for a known Call Load for each 15-minute or half-hour interval of the day. Collecting, properly interpreting, and applying ACD and other information allows you to accurately forecast the workload and schedule sufficient agents to meet your service objectives.
Step #1 Establish a corporate service objective

The Service Level % is a performance metric contact center managers use to determine what proportion of customers, that contact you by voice/email/chat/fax, receive “good” service. Using the Service Level %, you can gauge the level of service customer's experience, from a historical and a real-time perspective.

Defining and adequately funding a service objective should be closely tied to your corporate mission. The service objective identifies the average length of time a caller who has obtained a trunk waits for an available agent. It is the basis for planning and budgeting and links the resources you require to your service objectives. Choosing a service objective is the first step in a comprehensive planning and management solution. Once you set a service objective, you should routinely access it to see how consistently you are meeting it, on a 15-minute or half-hour basis.

Contact centers in different industries use different criteria for measuring service. Your service objective should reflect the type of service being provided and the expectations of callers seeking the service. For example, a company that sells magazine subscriptions has less to lose in the outcome of any one call than a car dealership does. A caller to a credit card “lost or stolen” line might expect different service than a caller to a customer service department at a bank. Contact center metrics across industries are designed to reflect this.

Performance targets must suit the primary function of a contact center. In revenue-based contact centers where agents sell products or services, the net revenue per call is considered when defining a service objective. Revenue-based contact centers strive to provide a high level of service with minimal blocking and delays.

Understanding the Service Level

The Service Level applies to all of the media types (voice/email/chat/fax) and is expressed as a percentage of a statistical goal: it specifies the Service Level Time and the Service Level % goals for the queue or agent group.

The Service Level is expressed as $X \text{ percent of calls handled in } Y \text{ seconds or less}$, such as 80 percent of calls handled in less than 20 seconds. Why is Service Level the standard measurement of service? Service Level provides the most accurate representation of the callers’ experience. It is ultimately the caller who decides what constitutes good service, and whether or not to end a call. It applies to inbound transactions that must be addressed as they arrive.

When a caller enters a queue, the call is processed in one of three ways:

- An agent answers the contact (handled contact).
- The client disconnects before an agent answers (abandoned contact) (for calls and chats only).
- The contact is removed from the queue, and sent to another handling point (for example, to voice mail, an automated attendant, or another queue), (Interflowed contact).

For detailed information on Calls Offered, Calls Handled, Calls Abandoned, Calls Interflowed, and other Service Level parameters see “Choosing a Service Level goal” on page 24.

Understanding why the Service Level is the most meaningful statistic

The Service Level is one of many ACD statistics used to measure performance. Each statistic has its purpose. For example, the Grade of Service (GOS) statistic relates the number of trunks to the level of traffic and indicates the likelihood an attempted call will receive a busy signal. It is expressed as a decimal fraction. For example, a GOS of P.02 means a caller will have a two percent chance of receiving a busy signal. Since trunk costs are insignificant compared to agent costs contact centers are well advised to schedule sufficient trunks, abandons should be minimal.
A delayed call is a call placed in the ACD queue because it cannot be answered immediately by an agent. The probability of delay statistic relates the number of agents or extensions to the level of traffic carried by the trunks and indicates the likelihood and amount of delay experienced. The GOS, probability of delay, and Quality of Service rendered by agents provide vital information about the callers' experience. (See Figure 3-2.)

**Figure 3-2 Service criteria**

<table>
<thead>
<tr>
<th>Grade of Service</th>
<th>Level of Service</th>
<th>Quality of Service</th>
</tr>
</thead>
<tbody>
<tr>
<td>PSTN</td>
<td>Telephone System</td>
<td>Knowledgeable agents?</td>
</tr>
<tr>
<td>call attempts</td>
<td>blocked calls</td>
<td>current information?</td>
</tr>
<tr>
<td>was your call picked up by the contact center?</td>
<td>abandoned calls</td>
<td>courteous agents?</td>
</tr>
<tr>
<td>how long did you wait for an available agent?</td>
<td>calls answered by agents</td>
<td>complete information?</td>
</tr>
<tr>
<td>how would you rate the service you received?</td>
<td></td>
<td>accurate information?</td>
</tr>
</tbody>
</table>

The GOS and probability of delay contribute to our understanding of what happens to the calls not answered in Y seconds, and give meaning to Service Level. Service Level is the primary statistic used in planning and budgeting because it is the most stable measurement of queue activity.

The following statistics are also meaningful contact center indicators:

**ASA**

The Average Speed of Answer (ASA) is an ACD statistic that measures how long the average caller waits on hold before the call is picked up by an agent. ASA is a valuable measure of service quality, but is often misinterpreted. The average does not represent what is typically experienced by individual callers. Most calls are answered by agents more quickly than the average, but a small percentage of callers wait several minutes in queue. ASA is a useful parameter, but Service Level is a more reliable indicator of what callers experience.

**Abandonment**

ACDs collect statistics on how long callers wait before abandoning calls, and what percentage of calls are abandoned. Unfortunately, abandonment is difficult to forecast because it is impossible to predict caller behavior with any reliability. Sometimes when the Service Level is high more callers abandon than expected. There are no industry standards for abandonment. It is a somewhat unreliable measure of contact center performance. However, abandonment statistics assist in planning Service Levels, and provide valuable information used to create in-queue and message-on-hold announcements.
Choosing a Service Level goal

Contrary to popular belief, there is no industry standard Service Level. Some contact centers base their Service Level goal on the targets of same-industry companies. In doing so, they assume these companies are actually meeting their intended targets. Companies are setting increasingly rigorous Service Level targets in sectors where outstanding customer service is the norm. In a survey of over 100 UK contact centers Opta Consulting was surprised to find an average performance target of 90 percent of calls answered in 15 seconds. They found that companies setting extremely rigorous targets did not necessarily meet them, and the investment required to achieve “best in class” targets was difficult to justify.

Setting an appropriate Service Level goal for your contact center is not easy. The motivation and expectations of your customers, the availability of similar goods or services, the Service Level targets of same-industry companies, and the value of calls are things to consider. It may be useful to run some calculations to determine the trade-offs in Service Level associated with adding or removing an agent, and implement customer satisfaction surveys. When defining your corporate Service Level, consider several factors and rate their relative importance.

An appropriate Service Level is one that

- Satisfies callers’ expectations for service
- Keeps abandonment in check (at less than five percent)
- Minimizes expenses and maximizes revenue
- Meets with the approval and support of agents, supervisors, and senior management

Consider this modest objective. For a Service Level of 80 percent of calls answered in less than 20 seconds, callers receive the following service:

- Approximately 30 percent of callers experience a delay in queue.
- The longest wait time is approximately three minutes.
- The average speed of answer is approximately 12 seconds.

Is this acceptable service for you and for your callers?

Understanding Quality of Service

Agent statistics reflect the time agents spend in various states and are used to assess agent performance. The average time an agent spends handling contacts, and in the Make Busy, Do Not Disturb, Unavailable, and Wrap Up states directly affects the agent’s availability and the Service Level provided to callers.

Service Level alone does not ensure customer satisfaction. The quality of the interaction between the caller and agent leaves a lasting impression. The Quality of Service reflects an agent’s ability to provide excellent service to each customer. The knowledge of the agent, the accuracy and completeness of the information provided, and the courtesy extended to the caller contribute to the caller’s experience.

Monitoring call handling techniques

Silent monitoring systems complement ACD statistics by providing a snapshot of quality and productivity in your contact center. You can track call handling techniques and determine where improvements can be made in individual performance. Advanced systems capture the voice conversations between agents and callers and record agent data tables for a complete picture of call handling. They provide online evaluation forms so you can annotate recordings with feedback.

Silent monitoring takes the bias out of performance evaluation. Silent monitoring provides a systematic process for monitoring and grading agent calls. You can schedule sessions across different times of the day, days of the week, and evaluators promoting fairness and consistency. Showing agents where improvement is needed is more effective than just telling them. Silent monitoring can contribute to a reduction in call time, a reduction in monitoring time and personnel, and increased training efficiency.
You can use pre-recorded conversations between agents and customers to train agents and for ongoing evaluation.

You can use the information to
- Provide recorded examples of exceptional service and unacceptable service to agents in training.
- Record, review, annotate with feedback, and forward call records to agents who then review your comments within the context of the actual call.
- Calibrate and routinely access the scoring consistency of call monitors.
- Assess the effectiveness of current training programs.
- Assess the efficiency of the monitoring and assessment process.

Defining scoring parameters
The parameters used to evaluate how well agents handle calls are based on the purpose of the calls. Goals vary across calls for inbound and outbound services. For example, in an outbound sales environment quality may be based on whether or not the agent made the sale, took advantage of cross-sell opportunities, and adhered to a pre-defined script. In an inbound environment quality may be based on the completeness and accuracy of the information and whether or not the caller’s questions were answered satisfactorily. Agents are also evaluated on “soft skills”, such as voice quality, pausing at regular intervals, rate of speech, use of positive language, and other listening and communication skills.

Setting performance standards and goals
Once you determine appropriate scoring parameters, you define standards for exceptional and acceptable levels of performance. Assessment standards are based on consensus and must be clearly defined and communicated to monitors and agents. Collaborate with agents in setting performance goals and clearly define exceptional service and interim performance steps. Determine a baseline of current performance and set performance steps for an agent group. Provide agents in the group who meet or exceed the interim target with rewards and recognition commensurate with their performance. When systematically used in training and coaching recorded sessions positively impact productivity. Fair assessment is good for moral and motivation, and contributes to an environment in which agents can learn and grow.

Monitoring frequency
The frequency of monitoring sessions is determined by individual companies and ranges from once a month to 15 or 20 sessions a month. Implementing five to 10 monitoring sessions per month is common practice. Trainees and agents with consistently low scores are monitored more frequently than other agents. Resource limitations typically influence the frequency of monitoring.

Monitoring systems and tools
The following monitoring systems and tools help you evaluate the performance and manage the quality of service of your contact center.

Silent monitoring systems
**Silent monitoring systems** range from tape recorders to client/server based recording systems. Advanced systems schedule, record, and store voice files in a compressed digital format using a real-time link to your telephone system. They capture any data tables accessed by the agent in addition to voice data. Silences are eliminated to optimize monitoring efficiency. Recording sessions can be played back from any telephone, anywhere, at anytime. You can customize agent evaluation forms and define parameters for quality with advanced systems. They provide activity, status, and management reports for evaluating agents and observation practices.
IT support systems

*Information Technology* (IT) support systems are commonplace in contact centers. Contact center agents divide their time between listening to customer requests, entering and updating customer information and other entries, searching for required information, and providing feedback to customers. In order to provide prompt and complete information, agents must have immediate online access to information including customer records and case histories, products and services, and company policies and procedures.

The push to increase agent efficiency and customer service has placed new demands on computer information systems and information technology. Information products that enhance agent productivity are continually being developed. Contact center systems are designed to incorporate some, or all of the following specialized support functions.

**CTI**

*Computer telephony integration* (CTI) is the merging of computers and telephone systems. Today’s computer-based telephone systems deliver synchronized voice and data, voice and data conferencing, automatic information retrieval for calls, caller-based messaging and routing, and desktop productivity tools. You can use customer databases in call handling to enhance customer service and agent productivity. When databases are shared between contact center departments each agent can access a caller’s contact information, purchasing records, call history, and preferences by a caller ID number.

**ANI**

*Automatic Number Identification* (ANI) identifies the telephone numbers of callers to your contact center, so agents can receive screen pops with calls. You can connect a database to your telephone system to simultaneously send calls and caller information. The telephone system forwards the caller’s telephone number to a software application that relays database records on the caller to the agent. Alternately, the caller enters an ID number that the database associates with a set of records for the caller and the agent is sent the information.

ANI saves agents time since they do not have to ask for and enter a name for a caller, and wait for the database to respond. This time savings significantly impacts staffing requirements and telephone service charges. ANI also identifies telephone numbers of callers who abandon calls so they can be contacted later for potential business.

Reports can identify the volume of usage and costs of internal line numbers, and help you track the long distance distribution per line number and maximize long distance efficiency.

**DNIS**

*Dialed Number Identification Service* (DNIS) is a feature of toll-free lines that identifies the telephone number the caller dials. This assists agents who handle calls for more than one business or product line. Each business or product line has its own toll-free number. When a caller dials a toll-free number, the telephone system forwards information to the agent so the agent can identify who the caller dialed. For example, a caller dials a toll-free number for a cruise line. The telephone system sends a script to the agent along with the call. The agent then knows to answer "Good morning. Thank you for calling Southern Cruises," instead of the name of another cruise line serviced by the center.
Automating help desk workflow

Agents at IT help desks require quick access to customer information and call history, and the ability to rapidly log all of the support calls and incidents. Advanced help desk packages offer automated desk help workflow systems. They assist agents in logging service requests (tickets), dispatching them to prioritized queues or agents, tracking them, and documenting activities.

External applications, help desk operators, or end users (in web-based applications) generate tickets. The system generates them manually, or in some cases automatically, in response to system events. It can correlate multiple incidents with single tickets, and multiple problems with a single call.

Automated help desk workflow systems track each step taken in answering a call, with automatic time stamping of all of the referrals, escalations, reminders, alerts, and email notifications. Calls are prioritized and referred to other departments without reassignment, reassigned (escalated) to other technicians or specialized staff, and placed in an alert condition when they are not resolved promptly. Activities are date and time stamped automatically. Most help desks offer outgoing email notification and paging. Some help desks offer automated logging of incoming emails, and automated call acknowledgment emails to clients.

Step #2 Collect data

Telephone systems generate an enormous amount of real-time and historical data used in planning and management of your contact center. You use real-time data to monitor the current Call Load and agent availability so minute-to-minute adjustments can be made. You use historical information in forecasting, staffing, and scheduling. Other critical management information comes from customer surveys, market studies, employees, external departments, telephone networks, workforce management systems, competitors, and the media. Data collection is a continuous process you implement as soon as your telephone system is up and running.

Telephone systems provide detailed report data on every aspect of call transactions. You can program computer-based telephone systems connected to a Local Area Network (LAN). Users on the LAN can view or print real-time and historical reports. Using web-enabled telephone systems, you can view and generate reports in a Web browser. You can monitor contact center activities remotely, and distribute reports to people on different networks.

Collecting data on call handling

Contact center reporting software displays real-time telephone system data on desktop monitors and wall signs. Using real-time data, you can manage current conditions and ensure agents respond to changing contact center events. The telephone system provides information on call activity, agent activity, and queue activity.

You can use historical data in forecasting and in assessing the performance of your resources. Historical reports provide vital information on load activity, resource activity, and queue activity. For example, resource activity reports on trunks can tell you the highest number of trunks used during peak traffic periods, and the total duration of calls handled by each trunk for the reporting period. You can determine how busy your trunks are, and whether or not you have the right number of trunks scheduled.

CTI provides in-depth information on call transactions. Detailed information on keystroke sequences, databases searched on, and on-screen assistance provides a clear picture of agent activities. Using ANI data, you can identify callers by area code and collate information on demographic trends in caller behavior.

Workforce management systems use telephone system data to forecast and schedule agents. Some packages monitor the real-time adherence of agents to scheduled activities, so you know the number of agents currently logged on and available to handle calls. Workforce management systems collect and store real-time adherence data. This data provides a historical account of adherence used in agent assessment.
Customer surveys provide valuable supporting information on callers’ tolerance to delay, and expectations for service. They address some of the following questions: Was the agent accessible? Was the caller put on hold for too long? Was the agent courteous and responsive to my request? Was the agent well informed? Did the agent provide the correct information and keep commitments? Contact centers use this information to estimate the repercussions of poor service: escalated costs, duplication of work, lost customers.

As the economy moves towards individual, personalized services, new ways of handing calls continue to emerge. These new features add to the complexity of collecting and measuring information. It is vital you establish an integrated, reliable system for measuring the key indicators of performance: the efficiency of call handling, the service callers experience, and their perceptions of that service.

**Step #3 Forecast the Call Load**

Finding the right balance between resources and traffic volumes is a critical step in effective contact center management. Estimating resource requirements is particularly challenging as the number of calls and the total duration of calls expected for a given time interval is difficult to predict.

Forecasting impacts contact center operations and performance in the following ways:

- The number of blocked and abandoned calls
- The level of service provided to callers and callers’ perception of service
- Agent workload, call behavior, and retention
- The accuracy and usefulness of schedules
- The success of periodic sales campaigns

**Forecasting accurately**

Forecasting is an imprecise science. The accuracy of your forecast increases markedly with the size of your data sample. You take a year (or preferably two or three years) of ACD queue traffic data, examine trends in Call Load patterns, break down the information, and determine the ACD Handling Times of the calls. You then modify the forecast based on current contact center activities and other considerations, such as absenteeism, agent breaks, holidays, and training.

The range of forecast dates you specify depends on the purpose of the forecast. Using long-term forecasts, you can estimate future budgets and expansion opportunities, and establish corporate objectives. Using short-term forecasts (of one to three months) you can determine seasonal staffing requirements, plan for short-term sales campaigns, and assess upcoming hiring needs. You can use weekly, daily, hourly and half-hour forecasts to tweak agent schedules and adjust for absenteeism.

**Conducting forecasts**

Conducting a forecast involves accurately estimating the three components of Call Load: the ACD Handling Time, Wrap Up Time, and Calls Offered. After you run a forecast, it is useful to examine the data and make adjustments based on present contact center conditions. You tweak the forecast by adding or reducing calls based on your intuition and on information gathered by yourself and others.

To forecast the agent requirement, you

1. Examine trends in Call Load patterns.
2. Break the information down in to monthly, weekly, daily, half-hour, and 15-minute intervals that reflect Call Load patterns.
3. Determine the handling times of calls.
4. Modify the forecast based on current contact center activities and other considerations, such as absenteeism, agent breaks, holidays, and training.
You may need to consider the following issues: hardware or software system changes, expected callers, advertising and media, changes to your products, services, or pricing, new products, product performance, competitors actions, and international, national, and corporate events. It is vital to have a systematic forecasting process in place that all of the departments support. For detailed information on Call Load, ACD Handling time, Wrap Up Time parameters, see “Forecasting terms” on page 275.

**Step #4 Calculate the resources required**

You calculate the agent requirement in conjunction with the trunking requirement. The number of available agents affects the likelihood and length of delay experienced by callers. The delay affects the load trunks must carry. Because the number of available agents impacts the number of trunks required, you calculate the agent requirement first.

The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent requirement for the time interval and date range in the forecast. The resultant spreadsheet displays the Call Load and agents required across time intervals.

**Predicting agent requirements**

Agent costs account for over 60 percent of all of the contact center costs. Accurately predicting the agent requirement, making the most effective use of agents, and standardizing and monitoring agent activities are paramount to achieving your service objectives. Agents are your most valuable resource: make team building and team management a high priority.

You can predict the agent requirement for your Service Level Percentage and Service Level Time targets by applying the Erlang C equation to the estimated Call Load and Average Talk Time.

**Understanding Erlang C**

Staffing models consider important factors unique to the inbound contact center environment:

- Call arrival is random.
- Consolidating resources allows the same number of contact center agents to handle more calls while maintaining Service Levels.
- Maintaining high Service Level targets requires staffing a large number of agents that will be idle a significant portion of the day.

The industry standard Erlang C equation operates on these principals. Most contact center reporting packages use Erlang C. An Erlang measures telephone traffic, or the flow of calls and call attempts to your contact center during a given period. One Erlang equals one hour or 60 x 60 = 3,600 seconds of telephone conversation. This could be one call lasting one hour, six calls lasting 10 minutes, or any combination of calls and call durations that equal 60 minutes. The Erlang formulas provide a mathematical basis for making predictions about randomly arriving workloads.

A.K. Erlang, a Danish engineer who worked for the Copenhagen Telephone Company, developed Erlang C in 1917. Agent and delay calculations use the Erlang C equation. It predicts the resources required to keep delay times within your Service Level objective. Three variables influence the delay time: the number of agents, the number of waiting callers, and the average time it takes to handle each call.
Limitations of Erlang C
Erlang C has fundamental principles that do not reflect real-world circumstances. It assumes all of the calls reach the contact center and all of the callers wait indefinitely to reach agents. Because Erlang C assumes no blocking or abandons, it may overestimate the agents you need. Erlang C requires accurate information on call flow where voice messaging and call overflow are employed, assumes your Call Load prediction is extremely accurate, and assumes you have the same number of agents handling calls the entire half hour.

Although Erlang C has its limitations, it is the preferred planning tool as it provides reasonable traffic estimates for contact centers that maintain good service-minimal blocking and few abandons.

Considerations when predicting resource requirements
Erlang C provides theoretical numbers for staffing that you need to assess in light of the following contact center realities:

- The contact center blocks a certain proportion of calls and some callers abandon their calls.
- Talk time is unpredictable, and although most calls may last two to three minutes, a few calls can last upwards of an hour.
- Agents in training may require more time to process calls.
- Agents may use wrap up (after-call paperwork) time inconsistently during busy periods.
- Not all of the agents within an agent group are available at all times to handle calls offered to the agent group.

Erlang C predicts staffing needs fairly accurately. However, contact centers that use skills-based routing, overflow, interflow, and advanced routing options need to use intuition and experience in adjusting the final numbers.

The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent requirement for the time interval and date range in the forecast. The resultant spreadsheet displays the Call Load and agents required across time intervals.

Performing “what-if” scenarios
After you run a forecast, you can perform “what-if” scenarios on the resultant data by changing the value of forecast parameters and recalculating the results. You can enter values for the ACD Calls Offered, average ACD Handling Time, Wrap Up Time, and Service Level Percent and Time and recalculate the number of agents required. For example, you can reduce the average handling time and recalculate the agents required and the calls handled across 15-minute time intervals for the shift.

Understanding the relationship between agents and trunks
You are already familiar with the terms GOS (probability of blockage) and Service Level (average wait time).

The following definitions are essential to understanding the relationship between agents and trunks.

Delay
Trunk calculations assume no queueing. For trunk calculations, the delay includes the time from when a trunk picks up a call until an agent answers it.

Agent Load
The Agent Load includes the ACD Handling Time and Wrap Up Time. See “Handled” on page 251.
Trunk Load
The \textit{Trunk Load} includes the time from when a trunk picks up a call until the agent finishes speaking to the caller and disconnects. The Trunk Load does not include Wrap Up Time.

Callers expect to have a 95 percent or better chance of obtaining a free trunk in to your contact center, and expect to connect to an agent within a reasonable amount of time. There must be sufficient trunks available to pick up calls, and sufficient agents available to handle the level of traffic carried by the trunks. The more agents handling a given Call Load, the less delay callers’ experience. Callers experience a delay if there are insufficient agents available. If the delay is considerable, calls back up and some calls do not reach the contact center.

Traffic engineering involves estimating the number of trunks and amount of communications equipment needed to service an anticipated number of callers. It revolves around basic questions concerning the relationships between service parameters and trunk and agent resources. How much traffic can a particular number of trunks handle for a particular GOS? What is the GOS for a particular number of trunks and traffic level? How many trunks are required to handle a particular traffic level and GOS? What is the probability of delay and length of delay experienced for a particular traffic level and number of agents? How many agents are required to handle a particular traffic level for a given set of delay characteristics?

Understanding Erlang B
Contact centers use the Erlang B equation to estimate the number of trunks required. Erlang B assumes calls are not queued and that callers who receive a busy signal do not attempt to call again. It can underestimate the trunks required. One Erlang equals one hour, or 60 x 60 = 3,600 seconds of telephone conversation.

Predicting your trunk requirement involves
- Determining your Busy Hour Traffic (\textit{BHT})
- Deciding how many blocked calls you can tolerate, or Grade of Service (GOS)

\textbf{BHT}
The \textit{Busy Hour Traffic} (BHT) statistic, measured in Erlangs, is the number of hours of call traffic (or trunk traffic) you experience during the busiest hour of operation. It is important that your busy hour figure represent the busiest Call Load your trunks will ever receive, and not just today’s peak traffic. BHT is the \textit{(average call duration + average delay) x calls per hour ÷ 3600}. This value represents the highest Trunk Load (occupancy) in hours.

The \textit{call center traffic} is the average number of trunks busy during the hour in question. One Erlang equals one hour, or 60 x 60 = 3,600 seconds of telephone conversation. If a contact center experiences 6.12 erlangs (or 6.12 hours of telephone conversation) during an hour, an average of six trunks were busy.

\textbf{GOS}
The \textit{Grade of Service} (GOS) value is a decimal fraction. A GOS of P.02 means a caller has a two percent chance of receiving a busy signal. Contact centers use GOS in calculating the number of trunks required. It is important to specify a GOS that is right for you in order for the trunk calculation to be realistic.

\textbf{Predicting trunk requirements}
The number of trunks you require reflects the level of traffic expected during your busiest hour of operation. The busy hour is the hour during the workday in which a trunk group carries the most traffic. You calculate the Trunk Load after you forecast the Call Load for the busiest hour and determine the number of agents required to handle the Call Load for your Service Level objective.
Traffic calculators used to predict contact center resource requirements are available on the Web from companies such as erlang.com. You can obtain basic calculators at no cost. Calculators that display and print results or calculations made during the previous week are available at a modest cost.

To calculate the trunks required you simply input two of the figures and calculate the third. For example, if you know that your Busy Hour Traffic is 10 erlangs and you want to determine how many trunks are required when two calls are blocked in every 100 call attempts, you input the busy hour time (10) and your target rate of blocking (0.02). The calculator displays a value for the trunks required (17).

Figure 3-3 illustrates the trunks required across a spectrum of GOS values. Whether you chose a GOS of 0.01, 0.05, or somewhere in between these values reflects how may calls per 100 call attempts you can afford to lose. In revenue-based contact centers minimal blocking and delay is a priority.

![Figure 3-3 Estimating the trunk requirement](image)

Although some contact centers base the trunk requirement on a staff-to-trunk ratio, such as 1.5 trunks per agent, many use the Erlang B equation. Whatever ratio results will be the right one for you.

It is better to slightly overestimate than slightly underestimate the number of trunks required: trunks are inexpensive, compared to agent costs. You can always cancel a trunk if periodic Trunk Load calculations show low occupancy on the trunk.

No staffing approach is absolute. You need to acknowledge the assumptions implicit in your calculations and use common sense when estimating your resource requirements. When you schedule resources, they must be closely monitored to ensure you are making full use of them.

**Step #5 Schedule agents**

*Scheduling* involves accurately forecasting the workload and determining which agents should work which shifts. This has traditionally been a labor-intensive manual process for contact center supervisors. You can schedule agents for breaks, split shifts, ACD and non-ACD work periods, repeating work patterns, holidays, and on call work. You can categorize agents by pay level, overtime eligibility, skill level, employment status (part time or full time), and scheduling preferences. Matching these shift and agent variables to the anticipated workload, and re-allocating agents in response to employee absenteeism can be a daunting task.
Scheduling is becoming increasingly challenging, as contact centers support a wider range of products and services, and agents require more frequent and specialized training. Advances in technology have automated many agent tasks and have resulted in more varied and challenging calls and responsibilities.

Accurately forecasting and building schedules that reflect the workload as it changes across intervals for days of the week, weeks of the month, and seasons of the year is essential in meeting your service objectives. You need a schedule that accurately matches agents to the anticipated workload and agents who aspire to adhere to the activities scheduled.

You can track the availability and activities of agents throughout the day and verify agents are performing the duties for which they are scheduled. Not adhering to the schedule, such as forgetting to log out for a break, or performing non-ACD work when scheduled to perform ACD work adversely affects your Service Level and the moral of other agents who must compensate for the unavailable agent.

**Understanding the Shrinkage Factor**

Accurately forecasting the workload and scheduling agents to satisfy your Service Level objective is a good start, but does not account for the activities that prevent agents from sitting at their desks and handling telephones.

Agents scheduled for ACD work can be involved in some of the following activities:

- On a bathroom break
- Making or receiving personal calls
- Conferring with the supervisor or another agent
- On the phone with other departments
- Sending emails or faxes
- Involved in a lengthy, difficult call
- Prolonged in after-call work
- Absent due to illness or compassionate leave

To account for short-term or daily unscheduled absences, you can calculate the rostered staff factor (Shrinkage Factor). The *Shrinkage Factor* is a numerical value that defines the percentage of time agents are scheduled to work but are unavailable to handle calls. It tells you the number of agents you must schedule in addition to the base number of agents required to meet your Service Level.

**Calculating the Shrinkage Factor**

You calculate the Shrinkage Factor for one or more agent groups as follows:

1. Determine the base staff forecasted by hour or half hour for the day.
2. Make a list of activities that prevent ACD agents from handling calls.
3. Add the base staff to the number of agents who are unavailable to handle calls because they are absent, on break, at a unanticipated meeting, etcetera.
4. Calculate the Shrinkage Factor for each time interval by dividing the scheduled staff by the base staff required to handle telephones.

The result is a set of Shrinkage Factors that represent the expected shrinkage by half hour. (See Figure 3-4.)
You multiply shrinkage values against the base staff required on telephones when setting future schedules. If your agent requirements vary considerably on certain days of the week, you can calculate a separate set of Shrinkage Factors for these days. You must use your good judgement in identifying absences that are relevant to include in your Shrinkage Factor calculations. Anticipating higher absenteeism on Fridays and Mondays is a safe bet while factoring in daily compassionate leave is not. As with all of the steps in contact center planning, routinely assess the accuracy of your shrinkage predictions and adjust them as required.

**Optimizing schedules**

Now that you have adjusted your agent requirement to account for unanticipated absences, the next step is to design a schedule that makes the most of your resources.

The following examples illustrate ways to adequately staff a contact center without having agents sit idle during slower periods.

**Scheduling split shifts**

Although not everyone likes to take a long break in the middle of a shift, for some agents split shifts fit well with priorities outside of work. For contact centers that experience heavy call traffic in the morning and evening, split shifts prevent overstaffing during these periods.

**Staggering shifts**

Staggering shifts allows you to maintain staffing levels over busy periods or periods when agents are on breaks. For example, one set of agents could start at 8:00 A.M., a second group at 9:00 A.M., and a third group at 10:00 A.M. so the contact center is fully staffed when it starts getting busy mid morning. Alternately, you could schedule morning and afternoon shifts that overlap from noon until 1:00 P.M. to enable the morning shift to break for lunch while the afternoon shift handles calls.

**Staggering breaks**

Making slight adjustments to the timing of morning, lunch, and afternoon breaks has a tremendous effect on call handling. The Erlang C equation predicts 28 agents can handle 300 calls, each lasting 280 seconds and delayed 20 seconds. (See Figure 3-5.)

Figure 3-5 illustrates that changing the availability by one agent decreases the average delay time by five seconds, and allows the contact center to handle 16 additional calls.
Figure 3-5 Staggering breaks to optimize call handling

<table>
<thead>
<tr>
<th>Calls Handled</th>
<th>Call Duration</th>
<th>Average Delay</th>
<th>Required Agents</th>
</tr>
</thead>
<tbody>
<tr>
<td>300</td>
<td>280s</td>
<td>20s</td>
<td>28</td>
</tr>
<tr>
<td>300</td>
<td>280s</td>
<td>15s</td>
<td>29</td>
</tr>
<tr>
<td>316</td>
<td>280s</td>
<td>20s</td>
<td>29</td>
</tr>
</tbody>
</table>

Forecasting non-ACD work
Not all of the non-ACD work must be performed immediately. For example, call-backs to clients, emails, and discussions with staff and supervisors can sometimes wait until less busy periods. Forecast and schedule non-ACD work for slow times to ensure sufficient agents are available during peak periods. Set availability priorities and regularly communicate them to agents.

Scheduling part-time agents and agents on call
When practical, scheduling part-time agents and agents on call can be an effective strategy for topping up your pool of available agents. Scheduling agents on call is particularly useful for days of the week and seasons when absenteeism is noticeably higher.

Routing calls to optimize coverage
To optimize service, you can use the following routing strategies that involve resources outside of the target agent group.

Overflowing calls to less busy agent groups
You can overflow calls from busy agent groups to less busy agent groups during peak periods. You can route calls to agents who primarily perform non-ACD work but act as reinforcements during busy periods, and to supervisors.

Employing call-back messaging
You can program the ACD to forward calls to voice mail so callers can leave messages instead of waiting for live agents. Call-back messaging helps to balance agent workloads between peak call periods and slow periods.

Contracting calls to customer care bureaus
Contracting calls is a growing industry. During peak periods, you can route simple, routine calls externally to customer care bureaus. Service bureaus collaborate with contact centers to set up scheduling and monitoring practices, and train agents to handle calls that vary in complexity.
Employing ACD enterprise call routing
Contact centers that provide extended, or around-the-clock service, can interflow calls to other sites. For example, you can interflow mid-day calls received by a busy center in San Francisco to agents working the late-afternoon shift at a center in Philadelphia. This optimizes call handling without scheduling additional agents.

Scheduling considerations
Scheduling should be a collaborative effort. Agents have schedule preferences, and want to know when they are working well in advance. Agents are more likely to adhere to schedules if they are involved in defining the conditions of schedule adherence and non-adherence, and in other areas of the planning process.

Producing long-term schedules is less efficient than producing monthly schedules, as contact center conditions and agent availability are continually changing. Short-term scheduling is more accurate, but less popular with agents. It is important to find a good balance.

Measuring scheduling accuracy
You can measure the effectiveness of your scheduling process. Create a line graph of the Service Level for each half-hour interval for each day over the past week. Draw a horizontal line across the graph to indicate your service objective. Look for inconsistencies in the service provided for different time intervals across days, and how far you stray from your service objective.

If the Service Level is erratic, you may have enough resources in place, but they may not be consistently available to handle calls. If the Service Level is inconsistent at certain time intervals across the week, or you are not meeting your Service Level objective, investigate to see if you are adequately staffed at these times and are making the best use of resources. Try to assess how consistently the agents are responding to real-time information displays. Determine if they are restricting non-ACD activities to slow periods and adhering to the schedule.

Scheduling agents with workforce management tools
Workforce management tools assist you in scheduling agents for work and holiday periods. Many packages offer an integrated forecasting component that uses historical data to partially automate the scheduling process for established agents. Scheduling is not entirely automated: you must tweak agent schedules and enter shift and agent variables for agents manually.

Step #6 Determine contact center costs
An effective budget conveys what is currently happening in the contact center, projections for the upcoming year, and business objectives. It is important to highlight the trade-offs between the service provided to callers and costs to the organization by developing at least two budgets that reflect different scenarios.

You need to provide a clear indication of how the money is being spent, what you are doing to reduce or curb spending, and what equipment is required to meet service objectives and expected growth over the next year. Budgeting is on-going process that needs continuous refinement.
Breaking down expenses

The costs associated with contact center operations include

• **Loaded labor costs**
  Loaded labor costs include wages, fringe benefits, and facilities, and account for over 60 percent of contact center costs. This is a significant cost and underlines the importance of accurate forecasting and scheduling.

• **Equipment and automation costs**
  Equipment and automation costs include the cost of the telephone system, computer systems, and furniture, and account for about five percent of total expenses.

• **Transmission costs**
  Transmission costs include costs incurred for voice (telephone lines) and data (email, fax, and modem) transmission, and account for 25 to 30 percent of contact center costs. Transmission costs have decreased considerably in the past few years and are continuing to drop. In revenue-based contact centers, toll-free lines cost approximately 15 cents per minute, or nine dollars per hour, per line.

The following statistics help you breakdown and analyze your contact center costs:

• **Cost of Delay**
  When insufficient agents are available to handle a given Call Load, the delay increases as does the Trunk Load. Calls are queued. For toll-free services each call delayed in queue is a cost to the organization. You are charged for the toll-free service from the time a trunk picks up a call until an agent completes the call and hangs up. The expense of queueing callers is known as the Cost of Delay. Staffing affects toll-free service costs: if insufficient agents are available and the Service Level is continually low, network costs will be high. You need to consider the Cost of Delay when estimating the agent requirement, and closely monitor it.

• **Cost per Call**
  You use a cost-per-call analysis to measure contact center profitability and performance. The cost per call measures labor, communication, and equipment costs against the revenue generated. You calculate it by dividing the total cost by the total calls for a particular period of time.

• **Average Call Value**
  You use the Average Call Value in revenue-based contact centers. You calculate it by dividing the total revenue by the number of calls received for a given period. Sales and reservations environments use the Average Call Value. The value of each call is balanced against the service provided to customers.

Anticipating growth

Predicting company growth is a challenging and essential aspect of contact center costing. Growth predictions impact budgeting considerations and must be clearly communicated to senior management. It is useful to map out your projected costs and time frames for the upcoming year and substantiate them with statistics and graphs. Determine when and how many resources you require, and lead-time issues.
Chapter 4
Getting Started

Registering Contact Center Management
Setting up Contact Center Management on the Enterprise Server
Setting up Contact Center Management on client computers
Using Client Role Selector to select your Contact Center Client role
Disabling the IE security warning
Setting up user preferences
Setting up the SMTP Mail Server for report distribution
Getting Started

After you install Contact Center Management on the Enterprise Server, you must set up the Enterprise Server and client computers to use Contact Center Management. This section provides basic information on post-installation procedures. For detailed information on installation and post-installation procedures, see the Mitel Contact Center Management Installation Guide.

Registering Contact Center Management

NOTE:

• If you have not registered your Contact Center Management software, thirty days after you install it you will no longer be able to log on to Contact Center Management and will be required to contact prairieFyre software to register the software. After you register your contact center prairieFyre emails permanent license files to you. You implement these license files on the Enterprise Server to activate your software.

• Registration information is processed during regular business hours only (Monday to Friday from 8:00 A.M. to 6:00 P.M. ET).

When you initially register your software with prairieFyre, for one year you receive

• The latest Contact Center Management software updates.

• A quarterly newsletter.

• Free technical support.

To register with prairieFyre

• Call prairieFyre at (613)-599-0045. The turn around is immediate. (Recommended)

• Visit the www.prairiefyre.com website, fill out a registration form, and submit the form. The turn around time is four hours.

• In Contact Center Management, click Help=>Register Now, fill out a registration form, and submit, email, or courier the form to prairieFyre.

Activating Contact Center Management

If you did not activate Contact Center Management during installation, you can activate it now. If you have access to the Internet, you can rerun the Installation Wizard at any time to register Contact Center Management online. If you do not have access to the Internet or if you cannot access our license server, you can register offline.

To activate the Contact Center Management software online

1. On the Enterprise Server, click Start=>Programs=>Mitel=>Mitel Contact Center Management Licensing.
2. Click Register Online.
The Online Registration window opens.
3. Open the PFlicense.txt file, type your 26-digit site serial number, enter the path to the license files, and click Register.

To activate the Contact Center Management software offline

1. On the Enterprise Server, click Start=>Programs=>Mitel=>Mitel Contact Center Management Licensing.
2. Click Register offline.
The Offline Registration window opens.
3. Click the here link in the first step to open the directory that contains the license package.
4. Email the license package (licensing.zip) to support@prairiefyre.com. prairieFyre will sign the license files and send them back to you.
5. After you receive the signed license files, save them to a directory.
   **NOTE:** We recommend you place the license files in the original directory.
6. Repeat steps 1-2 to open the Offline registration window.
7. Type your product key.
8. Click **Browse** and specify the directory that contains your license files.
9. Click **Apply License**.
   The license registration is complete.

**Updating license files on the Enterprise Server**

You must update the license files on your Enterprise Server with the new license files prairieFyre sends you.

To implement new license files

2. Save the new license files in the following directory, `<drive>:\program files\prairiefyre software\CCM`.
3. Click **Yes** to overwrite the existing files.

**Setting up Contact Center Management on the Enterprise Server**

After you install the Contact Center Management software on the Enterprise Server, you need to set up the server and client computers to use Contact Center Management. To view detailed installation procedures, click Help=>Documentation and click the *Mitel Contact Center Management Installation Guide* to open it.

**Setting up Contact Center Management on client computers**

**NOTE:**
- The date format for Contact Center Management is tied to the regional settings on your client computer. For example, if you configure your computer to display the date as mm/dd/yyyy, when you browse to the Contact Center Management Web UI, the Contact Center Management applications and any reports you generate display the date as mm/dd/yyyy.
- The system administrator must provide all of the Contact Center Management users with a user name and password.

To set up a client computer to use Contact Center Management, on the client computer

1. Start Contact Center Management.
   See “Starting Contact Center Management” on page 42.
2. Install Client Component Pack.
3. Use Client Role Selector to select your Contact Center Client role.

**Starting Contact Center Management**

To start Contact Center Management on the Enterprise Server or on a client computer

1. Start Internet Explorer type your Enterprise Server IP address http://[your Enterprise Server IP address]/CCMWeb/. Otherwise, click the Contact Center Management desktop icon.
2. If you do not see the Contact Center Management desktop icon, to create a shortcut to Contact Center Management, move the Contact Center Management Web address to your desktop using a drag-and-drop operation.
Viewing multiple Contact Center Management sessions

Sometimes you will need to view two or more instances of Contact Center Management simultaneously. For example, you need to open two or more Contact Center Management sessions to perform multiple searches for event records, and to compare report data to SMDR search results.

To view multiple Contact Center Management sessions using Favorites

1. Start Internet Explorer and type your Enterprise Server IP address http://[your Enterprise Server IP address]/CCMWeb/. Otherwise, click the Contact Center Management desktop icon.
2. Click Favorites=>Add to Favorites to add the Enterprise Server IP address to your list of favorite addresses.
3. Click OK.
4. Click Favorites, click Contact Center Management (at the bottom of the list), and move it to the top of the list using a drag-and-drop operation.
5. To start an additional Contact Center Management session, open Internet Explorer and select Contact Center Management from your list of favorites.

NOTE: You can switch between Contact Center Management sessions and desktop applications by holding down the Alt key and pressing the Tab key until you locate the desired session.

Installing the latest version of Client Component Pack

Microsoft .NET Framework 3.5 SP1 must be installed on your system before you install Client Component Pack. If you attempt to install Client Component Pack, and .NET Framework is not installed, Client Component Pack will prompt you to install a list of required components, including .NET Framework.

You can install Client Component Pack on individual client computers or servers running Windows or Citrix Terminal Services with or without the Mitel Unified IP Client for Sun Ray Solution.

NOTE: If the client is on an external network, you can either:
- VPN to the internal network and install the Contact Center Client, or
- Copy the Contact Center Client from the server to the client using a CD or USB key
- Use an administrative procedure to silently install Client Component Pack on remote desktops
- See “Installing Client Component Pack using an administrative procedure” on page 44.

To install Client Component Pack on the client computer:

1. On the client computer, start Internet Explorer and type http://[your Enterprise Server IP address]/CCMWeb.
2. Type your user name and password and click Submit.
3. Click Help=>Software downloads/Installations.
4. Click Client Component Pack.
   The File Download - Security Warning window opens.
5. Click Run.
   Close the Software downloads window.
   The Internet Explorer - Security Warning window opens.
6. Click Run.
   The Mitel Contact Center Solutions Client Component Pack Se... window opens.
7. To install Updater Service Clean Up, click Install.
8. The Mitel Contact Center Solutions Client Component Pack - InstallShield Wizard opens.
9. Click Next.
10. After **Enterprise IP Address**, type the IP address of the Enterprise Server.
11. If your Enterprise uses SSL, select the **SSL** check box.
12. Click **Install**.
    The program features you selected are installed.
13. Click **Finish**.
    The Select role window opens.

---

**Installing Client Component Pack using an administrative procedure**

You can install Client Component Pack silently on remote desktops using an MSI (Microsoft Installer) administrative installation procedure. A silently installed program is a program that can be installed with no user interaction.

To install client software silently on remote desktops

1. Install the prerequisite software.
2. Locate the client_setup.exe and extract Client Component Pack.msi.
3. Perform the .msi procedure for the administrative installation.
4. Run the silent installations.

---

**Installing the prerequisite software**

Before you install client software, you must install the prerequisite software.

To install the prerequisite software

1. Go to the src folder located in your Contact Center Solutions Installation folder.
    **NOTE**: The default location of this folder is C:\CCM\src.
2. Open the **Windows Installer 3_1** folder.
3. Install **Windows Installer 3.1**.
4. Go back to the src folder.
5. Open the **vcredist_x86** folder.
6. Install **vcredist_x86**.
7. Log onto your Contact Center Management Enterprise Server.
8. Click **Help**.
9. Click on the Software downloads/Installations tab.
10. Click **Software Downloads**.
11. Install the following components:
    - Microsoft .NET Framework 3.5 SP1.
    - Web Services Enhancements (WSE) 3.0 for Microsoft .NET.

---

**Locating the client_setup.exe and extracting Client Component Pack.msi**

To locate the client_setup.exe and extract Client Component Pack.msi

1. Go to the src folder located in your Contact Center Solutions Installation folder.
    **NOTE**: The default location of this folder is C:\CCM\src.
2. Open **client_setup.exe**.
3. Open the folder that was modified the same day you extracted client_setup.exe. The folder naming format will be xxx_xxxx.

**Client Component Pack.msi** will be in that folder.
Performing the MSI procedure for the administrative installation

**NOTE:** See Installing the Prerequisite Software for a list of programs that must be installed on each computer before you install Client Component Pack.

You must create a command for the administrative installation that is similar to the following example: msiexec /a"\Mitel Installations\Setup\Client Component Pack.msi" SSLSTATUS=0 ENTERPRISEIPADDRESS=10.1.4.12

To perform the MSI procedure for the silent installation
1. Click **Start=>Run**.
2. Type **cmd**.
   The MS-DOS window opens.
3. Open the folder where the msi file is located.
4. Type **MsiExec.exe /a**.
5. Press the spacebar.
6. Drag the msi file from the folder where it is located to the MS-DOS window.
7. Press the spacebar.
8. Type **SSLSTATUS=**.
9. If the Enterprise Server uses a secure socket layer, type 1. If it does not, type 0.
10. Press the spacebar.
11. Type **ENTERPRISEIPADDRESS=**.
12. Type the Enterprise Server IP address or DNS name.
13. Press **Enter**.
   The InstallShield Wizard opens.
14. Follow the instructions of the Wizard.
15. Ensure the file is saved to a network drive.

Running the silent installation

**NOTE:** Subsequent updates are done via the prairieFyre Updater Service.

To silently install Client Component Pack
1. Click **Start=>Run**.
2. Type "<path to administrative installation package>\Client Component Pack.msi" /qb
   Contact Center Client and the prairieFyre Updater Service are installed.

Using Client Role Selector to select your Contact Center Client role

The Contact Center Management client installation includes the Client Role Selector. It is a wizard that helps you select a Contact Center Client role based on the functions you perform. The roles are as follows:

- **Supervisor** is designed for supervisors and managers who monitor devices (for example agents and queues) and schedule agents.
- **Agent** is designed for agents who monitor themselves and/or other agents and queues.
- **Administrator** is designed for employees who manage the Enterprise Server.
- **Power user** is designed for employees who may perform the functions of a supervisor, agent, and administrator.

You can re-run Client Role Selector on a client computer at any time to change the components and applications installed on the client computer.
NOTE:

- If you want to customize the client installation, select Power User. For example, if a supervisor also performs administrative functions, select the Power User role and choose the components and applications the supervisor will need.
- For Version 5.7 SP1 of Contact Center Solutions support for the 5000 and Axxess telephone systems, client applications are limited to Real-time monitors, Management Console, Network Monitor, Multimedia Contact Center, and YourSite Explorer. All other client applications will be made available in a future release of Contact Center Solutions.

Table 4-1 lists the components and applications available for installation with each client role installation. Only those applications for which you have a license are listed here.

Table 4-1  Client role installation

<table>
<thead>
<tr>
<th>Components/applications</th>
<th>Supervisor</th>
<th>Agent</th>
<th>Administrator</th>
<th>Power User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real-time monitors</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Flexible Reporting*1</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Contact Center Softphone*1/2</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Teleworker*1/2</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Management Console</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Network Monitor</td>
<td></td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Salesforce.com Integration*1/2</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Workforce Scheduling*1</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Employee Portal*1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multimedia Contact Center*1</td>
<td></td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>(requires Outlook)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>YourSite Explorer</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>

*1 Flexible Reporting, Contact Center Softphone, Teleworker Solution V4.5 and V5.0.12.0, Salesforce.com Integration, Workforce Scheduling, Employee Portal, and Multimedia Contact Center are optional applications to Contact Center Management that you purchase separately.
*2 Contact Center Softphone, Teleworker, and Salesforce.com Integration are not currently supported with the Mitel 5000 and Axxess telephone systems.

Running client role selector

To run Client Role Selector:

1. If you are installing software on the client computer for the first time, go to step 2. Otherwise, click Start=>Programs=>Mitel=>Client Role Selector.
2. Click a client role.
3. Click Next.
4. Select the check boxes of the features you want to install.
   - Real-time monitors
   - Flexible Reporting
   - Contact Center Softphone
   - Teleworker
Disabling the IE security warning

When you browse Contact Center Management, you may see an Internet Explorer (IE) security warning. You can disable the warning.

To disable the IE security warning
1. Start Internet Explorer in your browser.
2. Click Tools=>Internet Options=>Security.
3. Select the Web content zone used to access the site. The Web content zone is typically Internet.
4. Click Custom Level.
5. Under Settings select Miscellaneous.
6. Under Miscellaneous, after Display mixed content, click Enable.
7. Click OK.

Setting up user preferences

You can change your user preferences at any time. They can be found on the Contact Center Management website, on the My options link. With these preferences you can
- Specify your language preference
- Specify the number of records displayed on a page
- Change your password
- View your security role properties
- Configure email contacts

Specifying your language preference

To specify your language preference
1. On the My options tab, click My preferences.
2. After Display this language, select a language.
3. Click Save.

Specifying the number of records displayed on a page

Contact Center Management enables you to configure the number of items that will appear in the YourSite=>Configuration.

To specify the number of records that display on a page
1. On the My options tab, click My preferences.
2. After Display this number of records, select a number.
3. Click Save.
Changing your password
To change the password for your login
1. On the My options tab, click My password.
2. After Old password, type your old password.
3. After New password, type your new password.
4. After Confirm new password, type your new password.
5. Click Save.

Viewing security role properties
You can view your security role properties. They describe the application areas to which you can gain access. Only employees with access to YourSite=>Configuration can change the security role properties of employees.

To view the security role properties of the credentials with which you logged in
- Click My options=>My security role.

Configuring email contacts
You can create a list of email contacts and contact groups to whom you email reports.

NOTE: You must configure SMTP settings in YourSite=>Enterprise in order to be able to configure email contacts.

To create a contact group
1. Add email contacts
2. Add contact groups
3. Add email contacts to the groups

Adding email contacts
To add an email contact
1. On the My contacts tab, click My email contacts.
2. Click Add.
3. After First name, type the first name of your contact.
4. After Last name, type the last name of your contact.
5. After Email address, type the email address of your contact.
6. Click Save.

Adding contact groups
To add a contact group
1. On the My contacts tab, click My email contact groups.
2. Click Add.
3. After Name, type the name of the contact group.
4. After Description, type the description of the contact group.
5. Click Save.
Adding email contacts to contact groups

To add an email contact to a contact group

1. On the My contacts tab, click My email contact groups.
2. Click Members for the contact group with which you want to associate agents.
3. Under Available contacts, select the check boxes of the members you want to add to the group and click Add >>.

Setting up the SMTP Mail Server for report distribution

If you require email distribution of your Contact Center Management reports, you must configure the SMTP Mail Server. It is the SMTP Mail Server that we use to email reports.

To set up the SMTP Mail Server for report distribution

1. In Contact Center Management, click Tools=>Administrative tools=>Manage SMTP Mail Server.
2. Click Add.
3. Click Edit adjacent to the Mail server you want to configure.
4. Under SMTP Mail Server, type the IP address or name of the mail server (for example, PFEXCHANGE).
5. Under SMTP Email Server port, type the port number of the SMTP mail server.
   The default value of this port is 25.
6. If the Mail server uses Secure Sockets Layer, under Use SSL, type True.
7. After From address, type the email address from which all Contact Center Management reports will be mailed.
   The field is mandatory because some email servers will not relay mail messages without a valid sender.
8. If the email server requires authentication, type the logon information in the Username and Password boxes.
9. Click Update.
Chapter 5

Services and Database Administration

Specifying maintenance functions
Backing up data
Management Console
Services and Database Administration

This chapter includes specifying maintenance functions, backing up data, and those functions available on Management Console (updating server IP addresses, importing configuration data using the Quick Configuration Wizard, running the maintenance routine immediately, summarizing data, creating a support package, controlling services, and converting Toolbox and Contact Center Solutions data files to prairieFyre data files).

Specifying enterprise maintenance functions

The Enterprise Server is the server computer on which you installed the Contact Center Management server software.

To specify an enterprise maintenance function

1. Click YourSite=>Enterprise. The Enterprise tab opens.
2. Click the Advanced tab.
3. If the site uses Secure Sockets Layer, select the This server uses SSL (Secure Sockets Layer) check box.
4. After Zip files older than, select the number of days after which you want to zip data files.
5. After Purge reports older than, select the number of days after which reports will be discarded.
6. After Delete maintenance logs older than, select the number of days after which maintenance logs will be discarded.
7. After Delete configuration backup files older than, select the number of days after which configuration backup files will be discarded.
8. After Time maintenance service runs, select the time at which the maintenance service summarizes data. The maintenance service is set to run at 2:00 A.M. by default. Select a time for the maintenance manager to run when your company is closed or is the least busy.
9. Click Save.

Backing up data

NOTE: We recommend you back up the SQL server data files, YourSite Database configuration data files, and raw telephone data files to an off-board media type (DVD, CD, tape, alternate network drive) each day as a precaution in case of server failure.

In the event of server failure, you can restore your company history and configuration with

- A backup copy of .xml files.
- A backup copy of the SQL server data files.
- A backup copy of the YourSite database.
- The raw telephone system data files stored on the local hard drive.

Backing up .xml files

The maintenance routine automatically backs up an .xml file of the YourSite database every night. This backup file is stored in the directory: <drive>:\program files\prairiefyre software inc\CCM\Backup Files. The maintenance routine keeps an .xml file for each of the last 30 days maintenance ran.

To back up or restore the .xml files

1. Start Contact Center Client.
2. Click View=>Administration.
3. Click Management.
4. Click Configuration.
5. Click Back up/Restore configuration data.
6. Follow the steps in the Backup and Restore Wizard to back up or restore the .xml file.
Backing up SQL Server data files

You back up SQL Server data files to ensure you can replace corrupted or lost data as a result of media problems, user errors, hardware failures, and natural disasters. Please review Microsoft procedure for creating a recovery model that controls the backup and restores operations for a database. See [http://www.exforsys.com/tutorials/sql-server-2005/sql-server-backing.html](http://www.exforsys.com/tutorials/sql-server-2005/sql-server-backing.html)

Understanding SQL Server recovery models

The following section details SQL Server recovery models and how they relate to backups and disk space usage. There are three recovery models available for use with SQL Server:

1. Simple
2. Full
3. Bulk logged


By default, SQL Server Express uses the Simple recovery model. Retail versions of SQL Server use the Full recovery model. There are two things you must consider when deciding which recovery model to use:

1. The importance of the data being stored in the SQL Server database.
2. The amount of disk space used by the transaction log file.

The only way to recover a SQL Server database is to restore it from a SQL Server backup. The type of recovery model you use impacts the ability to restore the database.

The Simple recovery model is recommended for customers who do not have an IT department upon which to rely for regular backups and who believe the summarization process is sufficient to re-generate historical data. There are several things that should be considered when using the Simple recovery model:

- The log file does not continually grow and is truncated each time a successful transaction is completed.
- When the log file is 80% full, the log will automatically clear out old transactions and rewrite the log file with the newer transactions.
- Point-in-time recovery is not supported with this model and the database can be restored only from the last full or differential backup.
- This model is ideal when the data in the database is not considered mission critical, is being backed up periodically, or can be restored from another means, such as summarization.

The Full recovery model is recommended for customers who have an IT department that can manage scheduled backups. There are several things that should be considered when using the Full recovery model:

- The log file will grow until a transaction log backup is successfully completed against the SQL Server database. Transaction logs can be applied to full database backups to ensure point-in-time recovery, up to the time when the last transaction log backup was taken.
- Point-in-time recovery is supported with this model
- This model requires a regular backup schedule and sufficient disk space to house the log file as it grows between backups.
Frequency and scope of configuration changes may be a suitable indicator in determining which recovery model to use. If configuration changes are infrequent and point-in-time recovery is not critical, the Simple recovery model may be sufficient. However, when using the Simple recovery model, we highly recommend that SQL Server backups are performed after any significant configuration changes have been made to the database.

Regardless of the recovery model used, it is strongly recommended that the data files collected by the Contact Center Solutions applications are backed up on a regular basis, as these files are used in the summarization process to re-generate historical data.

**Backing up Enterprise Server configuration data**

**CAUTION:** Restoring the YourSite database deletes all of the current database table entries and replaces them with the entries defined at the time of your last database backup. Any changes made to the database in the interim are lost.

Backing up and restoring Enterprise Server configuration data offers protection in case you program the database incorrectly, or a careless user reconfigures it. prairieFyre recommends you perform this backup weekly, in addition to regular database maintenance. If required, you can later recover the YourSite database data exclusively, rather than restoring the entire SQL database.

To back up or restore the YourSite database
1. Start Contact Center Client.
2. Click View=>Administration.
3. Click Management.
4. Click Configuration.
5. Click Back up/Restore configuration data.
6. Follow the steps in the Backup and Restore Wizard to back up or restore the database.

For any additional information contact prairieFyre technical support at 613-599-0045.

**Backing up raw telephone system data files**

To back up raw telephone system data files
1. On the Enterprise Server, right-click Start=>Explore.
2. Copy the <drive>:\program files\prairieFyre software incl\CCM\DataDirectory folder to the desktop, a network share, or optionally store it on a CD.

**Management Console**

The Management Console application resides in Contact Center Client. Using Management Console, you can administer the database, perform maintenance functions, create support packages, and update your Contact Center Management software.

Management Console consists of the following menus:

- Configuration
- Maintenance
- Support
- System
Opening Management Console

Management Console is available to users whose security permissions permit them to use Management Console.

To open Management Console

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password.
3. Click Log on.
   The Contact Center Client window opens.
4. On the main toolbar, click Management.
   See Figure 5-1.

Figure 5-1 Management Console

![Management Console]

Configuration

The Configuration menu enables you to

- Update the server IP address
- Import configuration data

Updating server IP addresses

If you want to apply Enterprise Server or SQL Database Server IP address changes to all Contact Center Solutions applications, you use the Update Server IP Address Wizard.

To apply the IP address change to all Contact Center Solutions applications

1. In Management Console, click Configuration.
2. Click Configuration.
3. Click Update server IP address.
4. Follow the steps in the wizard to apply the IP address change universally.

Importing configuration data

NOTE:

- To use the Quick Configuration Wizard, you must have a SX-2000 telephone system.
- You can use the Quick Configuration Wizard one time only.
- If you have a 3300 ICP, you must use Synchronization to synchronize the YourSite Database and the 3300 ICP.
  See “Configuring the YourSite database using synchronization” on page 112.
The Quick Configuration Wizard helps Mitel dealers configure Contact Center Management quickly and accurately. Using the wizard, you can configure queues, agents, agent groups, trunks, trunk groups, extensions, and the telephone directory. (See Table 5-1.)

**Table 5-1 Devices configured by assignment forms**

<table>
<thead>
<tr>
<th>Devices configured</th>
<th>Telephone system assignment forms</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agents, agent groups</td>
<td>Agent group assignment form</td>
</tr>
<tr>
<td>Queues</td>
<td>Path assignment form</td>
</tr>
<tr>
<td>Extensions</td>
<td>Multiline set assignment form, Station service assignment form</td>
</tr>
<tr>
<td>Trunks</td>
<td>Trunk assignment form</td>
</tr>
<tr>
<td>Trunk groups</td>
<td>Trunk group assignment form</td>
</tr>
<tr>
<td>Telephone Directory</td>
<td>Telephone Directory assignment form</td>
</tr>
</tbody>
</table>

To input telephone system data into the YourSite database using the Quick Configuration Wizard

1. Convert the telephone system Path, Agent Group, Trunk, Trunk Group, Multiline Set, Station Service, and Telephone Directory Assignment Forms to .txt files.
2. Use the Quick Configuration Wizard to input the information from these forms into the Contact Center Management YourSite database.

**Converting SX-2000 assignment forms to .txt files**

**NOTE:** It takes 10 to 15 minutes to convert each assignment form to text.

If you have an SX-2000, use the following instructions to convert the Path, Agent Group, Trunk, Trunk Group, Multiline Set, Station Service, and Telephone Directory Assignment Forms to .txt files:

1. Click Start=>Programs=>Accessories=>Communications =>HyperTerminal.
   The New Connection - HyperTerminal window and Connection Description window opens.
2. On the Connection Description window, under Name, type the name of this connection (for example, Connection1).
3. Click OK.
   The Connect To window opens.
4. After Connect using, select the Com port (for example, COM1).
5. Click OK.
   The COM1 Properties window opens.
6. Verify that the bits per second, data bits, parity, stop bits, and flow control are correct.
7. Click OK.
   The Connection1 HyperTerminal window opens.
8. Click File Properties.
9. Click the Settings tab.
10. Under Emulation, select VT-100.
11. Click OK.
12. On your keyboard, press Ctrl+W to refresh the page.
    The SX-2000 terminal session page refreshes.

**CAUTION:** To correctly import a Telephone Directory assignment form with the Quick Configuration Wizard, the names of the media servers in YourSite must be exactly the same as on the telephone switch. Otherwise, devices cannot be associated to the correct media server.
13. Log on to the SX-2000 with a username that permits installer privileges.
14. Type `formprint path ass /all /port lpr3` to convert the Path Assignments Form to text.
   See Figure 5-2.
   Or, to convert the Agent Group Assignment Form to text, type `formprint agent group ass /all /port lpr3`.
   Or, to convert the Trunk Assignments Form to text, type `formprint trunk ass /all /port lpr3`.
   Or, to convert the Trunk Group Assignment Form to text, type `formprint trunk group ass /all /port lpr3`.
   Or, to convert the Multiline Set Assignment Form to text, type `formprint multiline set ass /all /port lpr3`.
   Or, to convert the Station Service Assignment Form to text, type `formprint station service ass /all /port lpr3`.
   Or, to convert the Telephone Directory Assignment Form to text, type `formprint tel dir /port lpr3`.
   **NOTE:** The lpr3 printer is not the default printer.

**Figure 5-2 Hyperterminal-Path Assignments Form**

15. Type `show print lpr3` to confirm that formprint is queued.
    See Figure 5-3.
16. Click Transfer=>Capture Text.
   The Capture Text window opens.
17. Click Browse and specify the destination of the text file.
18. Click Start.
19. To enable printing, type `enable print /n`.
   See Figure 5-4.

20. Click Transfer=>Capture Text=>Stop.
21. Repeat steps 14-20 for the other assignment forms.
    **NOTE:** The .txt file will resemble Figure 5-5.
22. When you have converted all of the Mitel forms to text, close the **Connection1 HyperTerminal**
    window.
On the telephone system, you now send all of the valid assignments to file. Save the text files and proceed to Configuring the YourSite database.

### Importing configuration data into the YourSite database

To configure the YourSite database

1. On the Management Console main menu, click **Configuration**.
2. Click **Import configuration data**.
3. Follow the steps outlined in the Quick Configuration Wizard to import the configuration data.

When you click YourSite=>Configuration, you will see queues, agents, agent groups, trunks, trunk groups, extensions, and the telephone directory configured.

### Maintenance

Using the Maintenance menu, you can

- Run the maintenance routine
- Summarize data

### Running the maintenance routine immediately

Contact Center Management runs the prairieFyre Maintenance Service automatically at 2:00 A.M. However, you can manually invoke the prairieFyre Maintenance Service at any time with the Run maintenance command.

To run the maintenance routine

1. In Management Console, click **Maintenance**.
2. Click **Run maintenance**.
   A message notifies you that processing is complete.
Summarizing data

The Summarize Data Wizard uploads historical telephone system data to the SQL database for a specific date range.

If you run a report and notice that data for a particular device is missing from the report output, verify the device is programmed in the telephone system and in the YourSite database. If you determine the device is missing from the database, add it to the database and use the Summarize command to update Collector Service and the SQL database with the complete raw telephone system data (stored on the local hard drive). You can then produce reports on the device.

**NOTE:**
- When a summarize is performed the devices not programmed in the telephone system or YourSite database are identified and logged to an XML file located in the Logs directory. The files are named as in the following example, summarizeInspection[29-01-2007][29-01-2007][29-01-2007].xml, where the first date is the current date, the second is the start date of the summarize, and the third is the end date of the summarize.
- If you attempt to summarize data and there is no data for that date an error opens. Please select another date.

To summarize data
1. In Management Console, click **Maintenance**.
2. Click **Summarize data**.
3. Follow the steps in the Summarize Data Wizard to summarize the data.

Support

Using the Support menu, you can
- Create an Enterprise Server support package
- Create a client support package
- View contact information

Creating an Enterprise Server support package

You can package your Enterprise Server telephone system records and YourSite configuration data to send to prairieFyre for troubleshooting issues using the Support Package Wizard. The Support package formats your data in a way that helps to resolve any problems.

To create an Enterprise Server support package
1. In Management Console, click **Support**.
2. Click **Create support package**.
3. Follow the steps in the Support Package Wizard to package your telephone system records and YourSite configuration data.
4. Click **Finish**.
Creating a client support package
You can package your client configuration data to send to prairieFyre for troubleshooting issues using the Client Support Package Wizard. The Client Support Package Wizard formats your data in a way that helps to resolve any problems.

To create a client support package
2. Click Install.
3. Click Install.
   The Client Support Package Wizard opens.
4. Follow the steps in the Client Support Package Wizard to package your client configuration data.
5. Click Finish.

Viewing contact information
Should you need to contact prairieFyre Software for support, contact information is provided in Management Console.

To view contact information
1. In Management Console, click Support.
2. Click View contact information.

System
Using the System menu, you can
- Control services
- Convert data files

Controlling services
Services Manager controls all Contact Center Management services and mandatory system services. These include the prairieFyre Collector Service (v5), DataService, prairieFyre .NET Enterprise Server, MTCEService, prairieFyre Report Writer (v5), prairieFyre Reporting Service, prairieFyre SQLWriter, AuditorServer, ForecastingServer, WallboardServer, CCSServer, MitaiProxy, MCCEXchangeObjects, MCCEXchangeSetup, and IIS Admin.

To control services
1. In Management Console, click System.
2. Click Services Manager.
3. Select the service you want to control.
4. Right-click the service.
   The right-click menu opens. This enables you to control the service the following ways:
   - Start
   - Stop
   - Pause
   - Resume
   - Restart
   - Refresh
   - Restart All Running Services
5. Select the action you want to perform.
Converting data files

The Data file conversion tool enables you to convert Toolbox data files to prairieFyre data files. This enables you to restore all historical data from competitor products when changing your contact center solution to Contact Center Solutions.

To convert data files

1. In Management Console, click **System**.
2. Click **Data file conversion tool**.
   The Data file conversion tool opens.
3. Select a media server from the list.
4. Click **Browse** and specify the location of the data files to be converted.
   **NOTE:** The path must be accessible from the server. We recommend you use a Universal Naming Convention (UNC) share.
5. Click **Next**.
   The data file conversion will then process.
6. Click **Finish** to complete the data file conversion.

Converting Callview and Contact Center Suite data

If you were previously using an Inter-Tel telephone system with Contact Center Suite/Callview and Toolbox software, you can convert historic data to Contact Center Solutions format and create a historical media server so you can retain data for reporting purposes.

Historical media servers enable
- Historical reporting for queues, agents, and extensions
- Forecasting
- ACD and SMDR Inspector functionality
- Auditor functionality

Inter-Tel summary-based options, such as service level and spectrum values, can be modified in YourSite Explorer. Summarize is performed on an on-demand basis from Management Console in Contact Center Client. Historical media servers have no real-time functionality. All devices associated with historical media servers are historical by default and can not be edited or used to collect any new data.

**NOTE:**
- In order to convert Callview or Contact Center Suite data to Contact Center Solutions and Call Accounting format, the Callview and Contact Center Suite database must be Version 3.x or 4.x.
- The conversion tool requires the following files: System.mdw, config.mdb, and one or any combination of the following: Ha<MMYYYY>.mdb, Hc<MMYYYY>.mdb, Haday.mdb, Hcday.mdb, Hamonth.mdb, Hcmonth.mdb. For version 4.11 or earlier, select cvgwcfg.mdb instead of config.mdb.

To convert Callview and Contact Center Suite data

1. Click **Start=>All Programs=>Mitel=>Inter-Tel Import Tool**.
2. After **Access Databases**, click **Browse**.
3. Browse to the location of the files to convert.’
   The conversion tool requires the following files: System.mdw, config.mdb, and one or any combination of the following: Ha<MMYYYY>.mdb, Hc<MMYYYY>.mdb, Haday.mdb, Hcday.mdb, Hamonth.mdb, Hcmonth.mdb. For version 4.11 or earlier, select cvgwcfg.mdb instead of config.mdb.
   Click **OK**.
4. After **Start Date**, select the start date of the data to import.
5. After **End Date**, select the end date of the data to import.
6. If you are upgrading from a 5000/Axxess telephone system to a 3300 ICP/SX-2000/SX-200 telephone system, but want to retain historic Inter-Tel data for reporting purposes, click **Create historic media server**. Otherwise, continue to step 9.

   The Inter-Tel Database Migration Tool will import the telephone system configuration information, such as agents, extensions, and trunks, and associate it to the 5000/Axxess media server. It will also convert all historic telephone system records to ACD and SMDR files.

7. If you are upgrading to Contact Center Solutions or Call Accounting and continuing to use your 5000/Axxess telephone system, after **Target to Import**, select the Inter-Tel 5000/Axxess media to associate the converted data with. Otherwise, continue to step 10.

   **NOTE:** If you are upgrading to Contact Center Solutions or Call Accounting and continuing to use your 5000/Axxess telephone system, you must run Synchronization before running the Inter-Tel Database Migration Tool. See “Configuring the YourSite database using synchronization” on page 112.

   The Inter-Tel Database Migration Tool will not import configuration data because synchronization provides a more accurate configuration. However, telephone system records will be converted telephone system records to ACD/SMDR.

8. If you have remote 5000/Axxess telephone systems and use a CT Gateway, select **Synchronized system uses CT Gateway**.

   **NOTE:** Before you run the Inter-Tel Database Migration Tool, you must have created an Inter-Tel media server for each of the telephone systems connected to the CT Gateway, selected **This media server belongs to a CT Gateway** and provided the Gateway ID in YourSite Explorer. See “Adding a 5000/Axxess media server” on page 88.

9. If you want to summarize the data immediately after the conversion, select **Summarize upon completion**.

10. Click **Import**.
Chapter 6
Configuration

YourSite database application areas
Enterprise setup
YourSite Explorer
Adding media servers
Network Monitor alarms
YourSite database configuration
Adding resilient and/or Network ACD hot desking agents
Configuring employee scheduling preferences
Configuring scheduling options
Business hour schedules
Security roles
Chapter 6  Configuration
Configuration

Contact Center Solutions Version 5.7 SP1 includes a phased introduction of a configuration interface known as YourSite Explorer. YourSite Explorer simplifies data management by enabling you to configure and administer devices for Contact Center Solutions and Call Accounting in one application.

YourSite Explorer streamlines configuration. For example, you can
• Select multiple devices and change their attributes in one step.
• View group membership information on the same window as the devices are listed.
• View multiple windows of devices simultaneously and tab between them.
• Edit in line in an extended grid.

If you have a 3300 ICP, we recommend you configure media servers, Network Monitor alarms, devices, and business hour schedules in YourSite Explorer. However, you can optionally perform 3300 ICP configuration in the Contact Center Management website. We recommend you perform Synchronization in YourSite Explorer.

If you have a 5000 or Axxess, you must configure media servers, Network Monitor alarms, devices, and business hour schedules in YourSite Explorer. You must perform Synchronization in YourSite Explorer.

If you have an SX-200 or SX-2000, you must configure media servers, Network Monitor alarms, devices, and business hour schedules in the Contact Center Management website.

We recommend you add Multimedia Contact Center Email, Webchat, and Fax media servers to your site in YourSite Explorer. However, you can optionally add Multimedia Contact Center media servers in the Contact Center Management website.

Intelligent Queue media servers are added to your site in the Contact Center Management website.

The following table outlines what is configured in YourSite Explorer, the Contact Center Management website, or both. See Table 6-1.

Table 6-1 Configuration outline

<table>
<thead>
<tr>
<th>Item</th>
<th>Contact Center Management website</th>
<th>YourSite Explorer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enterprise Settings</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Sites</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Security</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Adding 3300 ICP media servers</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Adding SX-200 media servers</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Adding 5000 / Axxess media servers</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Adding SX-2000 (UCD and ACD) media servers</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Adding Multimedia Contact Center Email, WebChat, and Fax media servers</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Adding Intelligent Queue media servers</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Call recording</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Network Monitor alarms</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>
### Table 6-1 Configuration outline

<table>
<thead>
<tr>
<th>Item</th>
<th>Contact Center Management website</th>
<th>YourSite Explorer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business hour schedules</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Agents, agent groups, and queues that you will synchronize</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>with/write back to the telephone system</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Synchronization nightly maintenance</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Editing telephone system assignment forms (System Options,</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>SMDR Options, Class of Service, and Class of Restriction)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quick Setup device configuration (employees, agents,</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>extensions, trunks, trunk groups, DNIS, account codes, make</td>
<td></td>
<td></td>
</tr>
<tr>
<td>busy reason codes, teams, and device groups)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quick Setup device configuration (extension divisions and</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>account code groups)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quick Setup device configuration (queues)</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>.csv file import device configuration</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manual device configuration (ANI and Intelligent Queue</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>devices)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manual device configuration (account code groups, do not</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>disturb reason codes, extension divisions, phone numbers, and</td>
<td></td>
<td></td>
</tr>
<tr>
<td>phone number groups)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manual device configuration (account codes, agents, agent</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>groups, DNIS, DNIS groups, employees, employee groups,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>extensions, extension groups, make busy reason codes,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>queues, queue groups, teams, trunks, trunk groups, and</td>
<td></td>
<td></td>
</tr>
<tr>
<td>employee divisions)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Call Classification codes</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Contact Center Work Timer</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Queue Spectrum settings</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Interactive Contact Center queue control</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Multimedia Contact Center queue configuration</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Workforce Scheduling employees and schedule attributes</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Call Accounting extensions, trunks, and phone numbers</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Call Accounting location information</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Call Accounting Subscriber Services and Traffic Analysis</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>components</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
YourSite database application areas

The YourSite database includes five application areas. You must set them up in the following order:

- **Enterprise**
  You must browse to the Contact Center Management website and use YourSite=>Enterprise to set up your site structure and specify enterprise settings, add sites, and add SX-200, SX-2000, and Intelligent Queue media servers. You can add 3300 ICP media servers and Multimedia Contact Center media servers in either YourSite=>Enterprise or in YourSite Explorer. You must add 5000 and Axxess media servers in YourSite Explorer. See “Enterprise setup” on page 69.

- **Network Monitor**
  Depending on your telephone system, you browse to YourSite Explorer or the Contact Center Management website under YourSite=>Network Monitor and specify the days and times during which data alarms are active. For SX-200, SX-2000, and Intelligent Queue media servers you must configure data alarms in YourSite=>Network Monitor. For 3300 ICP and Multimedia Contact Center media servers you configure data alarms in either YourSite Explorer or YourSite=>Network Monitor. Data alarms for the 5000 and Axxess must be configured in YourSite Explorer. See “Network Monitor alarms” on page 104.

- **Configuration**
  You must browse to the Contact Center Management website and use YourSite=>Configuration to set up the YourSite database to mirror the information on the SX-200 or SX-2000 telephone system. We recommend you set up the YourSite database to mirror the information on the 3300 ICP using YourSite Explorer. However, you can optionally use the Contact Center Management website (YourSite =>Configuration).
  You must use YourSite Explorer to set up the YourSite database to mirror the information on the 5000 or Axxess telephone system. See “YourSite database configuration” on page 106.

- **Schedule**
  For the SX-200 and SX-2000 you must browse to the Contact Center Management website under YourSite=>Schedule to create schedules that reflect the business hours of your operation. We recommend you create schedules for the 3300 ICP in YourSite Explorer. You must create schedules for the 5000 and Axxess in YourSite Explorer. You can apply the schedules to media servers, queues, Network Monitors, wall signs, and Interactive Contact Center queue control. See “Business hour schedules” on page 171.

- **Security**
  You must browse to the Contact Center Management website and use YourSite=>Security to restrict user access to specific areas of the Contact Center Management website. See “Security roles” on page 172.

Enterprise setup

For all telephone system types, you set up your site structure in the Contact Center Management website under YourSite Enterprise.

To set up your enterprise structure

1. Specify enterprise settings.
2. Add a site.
3. Add media servers to the site.
   See “Adding media servers” on page 78
You must understand the following terms to set up your enterprise structure.

- **Enterprise**
  The *enterprise* is all of the contact center sites that comprise your company. See Figure 6-1.

- **Site**
  A *site* is an office location with one or more media servers. It can be the office where the Enterprise Server is installed or a branch office.

- **Media server**
  The *media servers* are the means by which customers communicate with you. For example, if customers contact you by telephone only, and you have an Axxess telephone system, then you would configure an Axxess media server.

For example, you have a business called ABC Company. You have two offices. One office is in Salt Lake City and your head office is in Los Angeles. The Salt Lake City site has Contact Center Management software installed on the Enterprise Server. Both sites have the Axxess telephone system and the Exchange Server installed. Your customers contact you at either site by telephone or email.

When setting up your enterprise site structure, you install Contact Center Management on the Enterprise Server. You define the site with the Enterprise Server (Salt Lake City). You add the Los Angeles site to the enterprise. Finally, you program two media servers at each site: Axxess (for calls) and Exchange (for emails).

**Figure 6-1 Enterprise structure**

Enterprise
The *enterprise* is all of the contact center sites (office locations) that comprise your company. The enterprise consists of the site where the Contact Center Management server software is installed, and branch offices.
Starting Contact Center Management

To start Contact Center Management on the Enterprise Server or on a client computer

1. Start Internet Explorer in your browser and type your Enterprise Server IP address http://[your Enterprise Server IP address]/CCMweb/.
2. Click Favorites=>Add to Favorites to add the Enterprise Server IP address to your list of favorite addresses.
3. Click OK.
4. Click Favorites, locate the Contact Center Management entry (at the bottom of the list) and drag it to the top of the list.
5. Optionally click Make Home Page to set the Enterprise Server IP address as your home page.
6. Type your username and password and click Submit.

Configuring enterprise settings

When programming the enterprise, you verify the IP address of the Enterprise Server, the Real-time port, the Auditor port, and some maintenance services. The Enterprise Server is the computer on which Contact Center Management is installed.

Configuring the Enterprise Server IP address

To configure the Enterprise Server IP address

1. In Contact Center Management, click YourSite=>Enterprise. The Enterprise tab appears.
2. After IP address, verify the IP address of the Enterprise Server.
3. If the IP address is incorrect, after or type the IP address, type the IP address of the Enterprise Server.
4. After Real-time port, type the real-time port number. The default real-time port is 5024.
5. After Auditor port, type the Auditor port number. The default Auditor port is 5025.
6. After MiTAI proxy server port, type the MiTAI proxy server port number. The default MiTAI proxy server port is 5026.
7. If you want Lifecycle reports, select the Enable LifeCycle reports check box.
8. Specify enterprise maintenance functions. See “Configuring enterprise maintenance functions” on page 71.

Configuring enterprise maintenance functions

To configure enterprise maintenance functions

1. In Contact Center Management, click YourSite=>Enterprise. The Enterprise tab appears.
2. Click the Advanced tab.
3. If the site uses Secure Sockets Layer, select the This server uses Secure Sockets Layer (SSL) check box.
4. After Zip files older than, select the number of days after which you want to zip data files.
5. After Purge reports older than, select the age after which reports will be discarded.
6. After Delete maintenance logs older than, select the age after which maintenance logs will be discarded.
7. After **Delete configuration backup files older than**, select the age after which configuration backup files will be discarded.

8. After **Time Maintenance Service runs**, select the time the maintenance service summarizes data. The maintenance service is set to run at 2:15 A.M. by default. Select a time for the maintenance manager to run when your contact center is closed or is the least busy.

9. If you want to run synchronization with the nightly maintenance routine, select the **Run synchronization with nightly maintenance routine** check box.

10. If you want client applications to be automatically updated, select the **Auto update client applications** check box.

11. Click **Save**.

### Configuring email alarms

To configure email alarms

1. In Contact Center Management, click **YourSite=>Enterprise**.
   The Enterprise tab appears.

2. Click the **Email alarms** tab.

3. After **SMTP Mail Server address**, select the IP address of the SMTP Mail Server.

4. After **Email notification interval minutes**, select the duration (in minutes) after which you will be notified when an alarm occurs.

5. If you want the system to send an email notification when an alarm occurs, select the **Enable email alarms** check box.

6. After **Send Enterprise Server alarms to the following address(es)**, type the email address of the employee(s) who will receive the email notification.

### Displaying the warranty warning and expiry message

To display the warranty warning and expiry message

1. In Contact Center Management, click **YourSite=>Enterprise**.
   The Enterprise tab appears.

2. Click the **System messages** tab.

3. Select the **Display warranty warning and expiration message** check box.

### Adding sites

When you add a site, you add the name of the site, the time zone, and smart algorithms (optional). By making each site distinct, you can restrict user access to that site. See “Security roles” on page 172.

To add a site

1. In Contact Center Management, click **YourSite=>Enterprise**.

2. Click **Add a site**.

3. After **Site name**, type the name of the site.
   You can add a number to the name of the site to indicate the number of sites in this location.

4. After **Time zone**, select the time zone for the site.

5. After **Site language setting**, select your preferred language for your Contact Center Management website.

6. If you want to override the language setting for all of the employees at this site, select the **Apply the preceding language preference to all employees at this site** check box.

**NOTE:** The language setting you specify here becomes the default language for all of the Contact Center Management client computers. However, you can customize this setting for individual employees in the Contact Center Management website, under My Options=>My preferences.
7. After SMTP Mail Server, verify the mail server address Reporting Service will use to email reports (for example, type the IP address of your mail server, or the name of your mail server computer). 
   **NOTE:** The email server setting you specify here becomes the default email server setting for all of the Contact Center Management client computers.

8. If the correct mail server is not in the list, click **Manage SMTP Mail Server** and configure the SMTP mail server.

9. After Chat settings, select the **Chat enabled** check box to enable Contact Center Chat. 
   **NOTE:** Contact Center Chat is enabled by default.

10. If you want to use Office Communicator as your default instant messaging client and view enhanced presence on real-time monitors, select the **Enable enterprise presence and chat integration** check box.

11. If required, specify smart algorithms. 
   See “Configuring smart algorithms for sites” on page 73.

12. Click **Save**.

### Configuring the SMTP Mail Server

**To configure an SMTP mail server**

1. In Contact Center Management, click **Tools=>Administrative tools=>Manage SMTP Mail Server**.

2. Click **Add**.

3. Click **Edit** adjacent to the Mail server you want to configure.

4. Under **SMTP Mail Server**, type the IP address or name of the mail server (for example, PFEXCHANGE).

5. Under **SMTP Email Server port**, type the port number of the SMTP mail server. 
   **NOTE:** The default value of this port is 25.

6. If the Mail server uses Secure Sockets Layer, under **Enable SSL**, type **True**. 

7. After **From address**, type the email address from which all Contact Center Management reports will be mailed. 
   **NOTE:** The field is mandatory as some email servers will not relay mail messages without a valid sender.

8. If the email server requires authentication, type the logon information in the Username and Password boxes.

9. Click **Update**.

### Configuring smart algorithms for sites

**NOTE:** If your site uses smart algorithms, agents can handle only one contact at a time.

If your site handles email, SMS, fax, and chat requests in addition to voice requests, you can use smart algorithms to prioritize the incoming requests. When you select smart algorithms, Contact Center Management routes the different media requests to multi-media agents in the order you specify on the Smart algorithms tab.

**To configure smart algorithms**

1. In Contact Center Management, click **YourSite=>Enterprise**.

2. Click **Add a site**.

3. Click the **Smart algorithms** tab.

4. Select the **This site uses smart algorithms** check box.

5. Select media types in the order you want them offered to agents.

6. Click **Save**.
YourSite Explorer

Contact Center Solutions Version 5.7 SP1 includes a phased introduction of a configuration interface known as YourSite Explorer.

NOTE: YourSite Explorer enables you to have multiple device tabs open simultaneously. As a best practice, we recommend you only have the device tabs open that you are currently using.

For detailed information regarding which devices are configured in YourSite Explorer see “Configuration” on page 67.

Starting YourSite Explorer

To start YourSite Explorer

1. Click Start=>All programs=>Mitel=>YourSite Explorer.
2. Type your username and password and verify the Enterprise Server IP address.
3. Click Log on.

Searching

When you perform searches in YourSite Explorer, you can filter on specific criteria to narrow the search. YourSite Explorer searches on criteria you type into the Search box. The search result will consist of all instances of the search item. For example, if you ran a search for ext, your search result could contain: extension, text, and next time.

After you perform an initial search, you can type additional criteria in the box to narrow the search. If no words or numbers match your search request, the resultant list will be blank.

YourSite Explorer searches on the following variables:

- Employees, employee groups—first and last name
- Extensions, extension groups—reporting number
- Trunks, trunk groups, DNIS, DNIS groups, Account Codes, divisions—name and reporting number
- Phone numbers, phone number groups—search on information found in all columns except Created by, Created date, Last modified by, or Last modified.

To search for a specific word or number

- In Search box, type a word or number surrounded by quotation marks.
  For example, to search for an extension named Extension1, type "Extension1."
  A list of devices that match the search criteria appears.

Paging

Paging enables you to specify the number of items to be included per page. You can reduce the page size to increase the application speed. By default, the page size allows for 100 items. When changing the page size, you must close and re-open the device window.

To change the number of items viewed per page

1. In YourSite Explorer, click YourSite.
2. On the ribbon, click the View tab.
3. After Page size, select the number of items to be viewed per page.
4. Click Save.
Filtering

The filtering bar enables you to access records alphabetically.

YourSite Explorer filters records on the following variables:

- Employee—last name
- Phone number—country name
- Employee group, extension, extension group, trunk, trunk group, DNIS, DNIS group, Account Code, division, and phone number group—name.

To filter records alphabetically

- On the filter bar, click the letter with which the record begins.

To filter numerically

- On the filter bar, click # to view records that start with numbers 0 through 9.

To reset filtering

- On the filter bar, click All to view all records.

You can filter and then search within the filtered records. For example, click F to filter for all records that start with the letter F. Then type th to search within that list for any record with th.

Customizing the user interface

You can customize the user interface by minimizing aspects of it, changing the order of the columns, changing column options, and adjusting the page size. This customization is referred to as a profile. Your profile is associated with the username you use to access YourSite Explorer. Each time you close YourSite Explorer, your profile is automatically saved. When you reopen YourSite Explorer using the same username, the user interface displays your profile.

Minimizing aspects of the user interface

To add space to the user interface so you can view additional rows of data, you can minimize the

- **Filter bar**
  The filter bar is the bar on which the alphabet is displayed.

- **Page bar**
  The page bar is located above the filter bar. The page number is displayed on the left side of the page bar.

- **Ribbon**
  The ribbon is located at the top of the user interface. The ribbon includes Home, View, and Configuration tabs, and enables you to add devices and change the view (horizontal, vertical, or data grid). Ribbon attributes change depending on the area you are viewing.

To hide the filter bar

1. On the ribbon, click the View tab.
2. In YourSite Explorer, click YourSite.
3. Clear the Show filter bar check box.

To hide the page bar

1. On the ribbon, click the View tab.
2. In YourSite Explorer, click YourSite.
3. Clear the Show paging bar check box.
To minimize the ribbon

1. Right-click the ribbon.
2. Click **Minimize the Ribbon**.
   The ribbon at the top of YourSite Explorer is hidden.

**Selecting the first record of each list**

You can save time by configuring YourSite Explorer to automatically select the first record on a page.

To select the first record of each list

1. On the ribbon, click the **View** tab.
2. In YourSite Explorer, click **YourSite**.
3. Select the **Select the first record** check box.

**Changing the order of the columns**

You can reorder columns in either of two ways. You can drag a column heading to a different position on the table, or you can change column order using Column options. See “Changing column options” on page 76.

To drag column headings

1. With the device window open, select the column heading to be moved.
2. Drag it to a different position on the table.

**Changing column options**

You can adjust the width and order of columns, and hide or show columns in device windows.

To adjust column width

1. Drag the column to the left or right to adjust its width.
2. Click **OK**.

To hide a column

1. Right-click a column heading.
   The Column options window opens.
2. Select **Column options**.
3. Select the column heading to be hidden.
4. Click **<<**.
5. Click **OK**.

To change the order of columns

1. Right-click a column heading.
   The Column options window opens.
2. Select **Column options**.
3. Select the column heading to be moved.
4. Use the arrows to change the order of the column headings.
   The top column appears first in the device window.
5. Click **OK**.
Grouping device criteria by column headers

You can group devices by column heading in the grid view. For example, if you click the Site column heading on the Employees window, you can group employees by site. Grouping enables you to quickly select like devices and make changes to them simultaneously. For example, if you click the Media server column heading on the Extensions window (to group the extensions by media server), you can then readily select the extensions associated with a particular media server and change their attributes, such as licensing or failover media server. See “Making multiple changes” on page 77.

To group device criteria by column headers

1. Open the device with the criteria to be grouped.
2. Click Group by.
3. Select the method of grouping.

Making multiple changes

In one action, you can edit common information across multiple devices of the same type. If, for example, you recently set up your system to be resilient, you must configure your employees as resilient. You assign resiliency to multiple employees by selecting multiple employees and then selecting the This employee is resilient check box.

You can change information that is common across multiple devices only. For example, you cannot change Name and Reporting number across multiple employees because they are specific to each device item.

You can make multiple changes to

- Employees
- Trunk groups
- DNIS

Changing the YourSite Explorer view

You can select from three window orientations or views: horizontal, vertical, and data grid. The horizontal view displays information in a horizontal layout. The vertical view displays information in a vertical layout.

The data grid view contains a table in which you can readily edit device attributes. Pressing the Tab key enables you to move from column to column. When viewing a device group in grid view, you can associate members within the same window.

When you close YourSite Explorer and then restart it, YourSite displays the view and device windows that were open the last time you used YourSite Explorer.

To select a particular view

1. On the ribbon, click the View tab.
2. In YourSite Explorer, click YourSite.
3. Select Horizontal, Vertical, or Data grid.
Adding media servers

NOTE: Mixing Mitel 5000/Axxess (formerly Inter-Tel 5000/Axxess) and 3300/SX-200 media servers in the same enterprise is supported by Contact Center Solutions and Call Accounting applications.

We recommend you add 3300 ICP media servers to your site in YourSite Explorer, but you can, optionally, add them in the Contact Center Management website.

You must add SX-200 and SX-2000 media servers to your site for voice, email, SMS messages, chat, and/or fax communications in the Contact Center Management website under YourSite=>Enterprise.

You must add 5000 and Axxess media servers to your site in YourSite Explorer.

You can choose to add Multimedia Contact Center Email, Webchat, and Fax media servers to your site in either YourSite Explorer or in the Contact Center Management website under YourSite=>Enterprise.

You add Intelligent Queue media servers to your site in the Contact Center Management website under YourSite=>Enterprise.

To distinguish between the various types of media for management and reporting purposes, you must make each media server distinct when you set up your site.

NOTE: Although the Mitel SX-200 17 (Release 4 or greater) platform works with Contact Center Management and Call Accounting, the SX-200 ML/EL has been manufacture discontinued and is no longer supported by Mitel or prairieFyre Software. Any issues or limitations arising from the use of the SX-200 telephone system will not be supported with software fixes or customization. Instead, upgrading to the SX-200 ICP or another supported platform will be required. Contact your Mitel Channel Partner for information on the “SX-200 ML/EL trade up” program.

You can click Help=>About Your Mitel Applications to verify the types of media servers and the number of employees for which you are licensed.

Contact Center Management works with the following media server types:

3300 IP Communications Platform (ICP)
The 3300 ICP ACD system streams SMDR and ACD real-time data over TCP/IP. See “Adding a 3300 ICP media server” on page 79.

SX-200 ACD (for 17 Release 4.0 and greater with real-time option enabled)
The SX-200 post 17 Release 4.0 (SX-200 ACD) system has both SMDR and ACD real-time data streams delivered over RS-232. See “Adding an SX-200 ACD media server” on page 86.

Mitel 5000/Axxess
The Mitel 5000 and Axxess telephone systems stream ACD and OAI data over TCP/IP. In addition, the MiTAI remote telephone system software is installed locally on the Enterprise Server and communicates over TCP/IP with the telephone systems. See “Adding a 5000/Axxess media server” on page 88.

SX-2000 UCD (Uniform Call Distributor)
The SX-2000 UCD system runs without ACD Telemarketer 2000 (ACD-2) software. It has a single SMDR data stream delivered over RS-232 or TPC/IP. All of the data is derived from the SMDR stream. See “Adding an SX-2000 UCD media server” on page 90.
SX-2000 ACD (Automatic Call Distributor)
The SX-2000 ACD system runs with ACD Telemarketer 2000 (ACD-2) software. It has SMDR and ACD real-time data streams over RS-232 or TCP/IP.
See “Adding an SX-2000 ACD media server” on page 93.

SX-200 Call Accounting
The SX-200 system has SMDR records delivered over a single data connection, RS-232, or TCP/IP.
See “Adding an SX-200 Call Accounting media server to a site” in the Mitel Call Accounting User Guide.

Multimedia Contact Center Email
See “Adding a Multimedia Contact Center Email media server” on page 94.

Multimedia Contact Center WebChat
See “Adding a Multimedia Contact Center WebChat media server” on page 97.

Multimedia Contact Center Fax
The corporate fax server converts customer faxes to electronic format. Then the Multimedia Contact Center Fax routing engine dynamically allocates faxes from customers to agents on their Microsoft® Outlook desktops.
See “Adding a Multimedia Contact Center Fax media server” on page 100.

Intelligent Queue
Intelligent Queue is an “all-in-one” announcement package for contact centers. Intelligent Queue uses the Enterprise Server for real-time statistics (required for the Intelligent Queue Talk option) and for historical reporting of Intelligent Queue caller activity (Call Detail reporting option).
See “Adding an Intelligent Queue media server” on page 103.

Adding a 3300 ICP media server
We recommend that you add 3300 ICP media servers in YourSite Explorer. However, you can optionally add 3300 ICP media servers in the Contact Center Management website.
You must first add the 3300 ICP media server and then configure its location settings, data collection settings, data summary options, MiTAI options, Network Monitor settings, and, optionally, call recording (YourSite Explorer only).

Adding a 3300 ICP media server in YourSite Explorer
To add a 3300 ICP media server in YourSite Explorer
1. In YourSite Explorer, click Media servers.
2. Click Add=>3300 ICP.
3. After Name, type the name of the media server.
   NOTE: To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
4. After Site, select the site where the media server resides.
5. After Computer name, select the computer where the server resides.
6. After Media server type, select the type of media server.
7. If you have hot desking agents, enable the **Uses hot desking agents** check box.
8. Specify the licenses to use for the media server.
   For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for a product the check box for that product does not show. If you have no remaining licenses, although the check box still shows, an error message indicates that all available licenses have been used.
9. After **IP/DNS address**, specify the IP.DNS address of the media server.
10. After **Username**, type the username used to connect to the telephone system.
11. After **Password**, type the password used to connect to the telephone system.
12. After **Confirm password**, type the password used to connect to the telephone system.
13. Click the **Test Connection** button to test the connection between the media server and the telephone system.
   This connection is required to ensure Synchronization functionality.
14. If this media server is part of a Mitel cluster, under **Cluster setting**, select the **This media server is part of a Mitel cluster** check box. Otherwise, skip to step 18.
15. After **Cluster ID**, type the cluster ID.
   The cluster ID can be found on the telephone system.
16. After **Cluster ID Digits**, type the digits used to identify the cluster.
17. After **Cluster name**, select the cluster name.
18. Click **Save**.
19. Specify the location settings.
   See “Configuring location settings for a 3300 ICP in YourSite Explorer” on page 80.

### Configuring location settings for a 3300 ICP in YourSite Explorer

To configure location settings for a 3300 ICP in YourSite Explorer

1. Click the **Location** tab.
2. After **Country**, select the country where the media server is located.
   If you are setting up a node, select the country in which the node is located.
3. After **Area**, select the area code where the media server is located.
   If you are setting up a node, select the area in which the node is located.
4. After **Minimum digits to dial locally**, type the minimum number of digits dialed for a local call in your city.
5. After **Maximum digits to dial locally**, type the maximum number of digits dialed for a local call in your city.
6. After **Outbound dialing prefix**, type the number you dial to access an outside line.
   This information is required if you use a general business model and want to view when phone extensions are active or inactive.
7. After **ARS Digit**, type the prefix number you dial for internal calls.
8. Specify the data collection settings options.
   See “Configuring data collection settings for a 3300 ICP in YourSite Explorer” on page 80.

### Configuring data collection settings for a 3300 ICP in YourSite Explorer

To configure data collection settings for a 3300 ICP in YourSite Explorer

1. Click the **Data collection** tab.
2. If you do not use OPS Manager, click **TCP**. Otherwise, skip to step 8.
3. After **SMDR**, type the SMDR port number of the media server.
4. If you will be entering ACD information, enable the **ACD** check box.
5. After **ACD**, type the ACD port number of the media server.
6. If you use Traffic Analysis, enable the **Traffic Analysis** check box.
7. After **Traffic Analysis**, type the Traffic Analysis port number of the media server.
8. If you use OPS Manager, click **Enterprise Manager (OPS Manager)**.
9. After **IP/DNS address**, type the IP address, or name, of the OPS Manager computer.
10. After **FTP port**, type the FTP port number.
11. After **FTP user name**, type the FTP user name to gain access to OPS Manager.
12. After **FTP password**, type the FTP password to gain access to OPS Manager.
13. After **Remote directory to data files**, type the directory path where the data from the telephone system is stored by OPS Manager.
14. Specify the data summary options.
   See “Configuring data summary options for a 3300 ICP in YourSite Explorer” on page 81.

### Configuring data summary options for a 3300 ICP in YourSite Explorer

To configure data summary options for a 3300 ICP in YourSite Explorer

1. Click the **Data summary options** tab.
2. If you want to use Trace reporting, enable the **Inbound/Outbound/Make Busy Trace reporting** check box.
3. If your business operates around the clock, enable the **This enterprise operates 24 hours a day** check box.
   **NOTE:** If you do not enable the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. If you want to track outbound calls that were not answered, enable the **Credit unanswered outbound calls** check box.
5. If you want to display when calls ring at agents’ extensions, enable the **Monitor Agent Ringing state** check box.
6. After **Digits dialed prefix**, type the digits that must precede a telephone number to make an outbound call.
7. After **Digits dialed postfix**, type the digits that must follow a telephone number to make an outbound call.
8. After **Maximum MiTAI monitors**, specify the maximum number of MiTAI monitors.
9. Under **Agent state timeout audit**, after **Clear line if agent Hold Time exceeds**, select the number of minutes or hours you are in a hold state before the telephone system clears the line.
10. After **Clear line if agent primary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.
11. After **Clear line if agent secondary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.
12. If you do not want to report on the secondary line (non-ACD and outbound calls), select the **Ignore agent secondary line activity** check box.
13. After **Change the agent state from Ringing to Idle after**, select the number of minutes or hours after which you want the agent state to change from Ringing to Idle.
14. Enable **Reset MKB/DND time in realtime after call ends** check box, if you want the MKB/DND time to reset in real time when the call concludes.
15. Under **ACD Options**, to store ACD redundant events, select the **File all ACD stream redundant events** check box.
16. If you do not consider ACD real-time sequence errors as record errors, select the **Ignore ACD real-time sequence errors as record errors** check box.
17. Specify MiTAI options.
   See “Configuring MiTAI options for a 3300 ICP in YourSite Explorer” on page 82.
Configuring MiTAI options for a 3300 ICP in YourSite Explorer

To configure MiTAI options for a 3300 ICP in YourSite Explorer

1. Click the MiTAI Options tab.
2. After Maximum messages per second, select the number of messages per second from the list.
   The default number of messages is 10 per second. The higher the version of MiTAI, the greater the number of messages per second.
3. After MiTAI auto-synchronization will occur at, select the time you want Automatic Synchronization to run from the list.
4. After Specify the port used for the MiTAI data stream, type the port number used for the MiTAI data stream.
5. Specify Network Monitor settings.
   See “Configuring Network Monitor settings for a 3300 ICP in YourSite Explorer” on page 82.

Configuring Network Monitor settings for a 3300 ICP in YourSite Explorer

To configure Network Monitor settings for a 3300 ICP in YourSite Explorer

1. Click the Network Monitor tab.
2. After Alarm name, click ...
3. Select an alarm from the list and click OK.
4. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click Manage alarms and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
5. If you want to modify a schedule for the media server, click Manage schedule.
   See “Creating schedules” on page 171.
6. Click Save.

Configuring call recording

Contact Center Management offers 24/7 call recording by integrating with Verint Audiolog and OAISYS Tracer (Versions 4 and 5) call recording software. Using the OAISYS Tracer, Contact Center Management can optionally record calls based on pre-defined schedules. With OAISYS Tracer, call recording can be temporarily started or stopped in Contact Center Client to ensure customer confidentiality or to create a record of volatile or sensitive calls. See “Recording calls” on page 380. For enhanced call security, Contact Center Management also integrates with the Mitel Secure Recording Connector software to encrypt Voice over IP calls. Verint Audiolog and OAISYS Tracer can optionally be used in conjunction with the Mitel Secure Recording Connector. When a call recording is complete, a hyperlink to the recording is appended to call-specific Lifecycle reports. See the Mitel Contact Center Solutions Reports Guide for more information about Lifecycle reporting.

NOTE:
• The OAISYS Tracer and Verint Audiolog call recording integration is supported for use with the Mitel 3300 ICP only.
• Before you can configure call recording in YourSite Explorer, you must configure your Verint Audiolog or OAISYS Tracer and/or the Mitel Secure Recording Connector by following the recommended installation and configuration guidelines included with these products. Contact your Verint or OAISYS approved vendor for all set up and troubleshooting issues.
• Contact Verint or OAISYS for information on integrating call recording with the Mitel Secure Recording Connector.
• Ensure call recordings are working properly for all configured extensions before activating the call recording integration in YourSite Explorer.
• If you use the Mitel Secure Recording Connector and Contact Center Softphone, you must enter the IP addresses of the Mitel Secure Recording Connector in YourSite Explorer.
Adding media servers

If you use Verint Audiolog call recording software, you must re-run the Contact Center Management/Call Accounting Configuration Wizard and specify the domain user account information for Verint Audiolog server DCOM setup on the Local Administrator Account window.

If you use Verint Audiolog call recording software and Windows Server 2008, you must allow COM+ network access in the Windows firewall rules and add your DCOM server to the list of program exceptions in the Windows firewall.

To configure the Secure Recording Connector

1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP media server from the list.
3. Click the Call recording options tab.
4. Under Mitel Secure Call Recording,
   • After IP address 1, type the primary IP address of the Secure Recording Connector.
   • If you load balance the Secure Recording Connector, after IP address 2, type the secondary IP address of the Secure Recording Connector.
5. Click Save.

To configure Verint or OAISYS call recording

1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a media server from the list.
3. Click the Call recording options tab.
4. Under Call recording provider options
   • After Recorder type, select either Verint or OAISYS.
   • After Recorder Server, type the IP address of the call recorder.
   • After Recorder port, specify the port of the call recorder.
   • After Username, type the username of the call recorder.
   • After Password, type the password of the call recorder.
5. Click Save.

Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle reports.

Adding a 3300 ICP media server in the Contact Center Management website

To add a 3300 ICP media server in the Contact Center Management website

1. In Contact Center Management, click YourSite=>Enterprise.
2. Click Add a media server=>3300 ICP.
   NOTE: To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After Name, type the name of the media server.
4. After Site, select the site where the media server resides.
5. After This media server is installed on the computer you named, select the computer on which the media server is installed.
   NOTE: The Change the media server type for this media server list appears only after you have saved the media server. It allows you to edit the media server type after the media server has been added to the site.
6. If you have ACD Resiliency, after This media server functions as a, select the media server function.
7. After All agents associated with this media server are, if you have hot desking agents or ACD resilient agents, click **ACD hot desking agents**.

8. After **Country**, select the country where the media server is located. If you are setting up a node, select the country in which the node is located.

9. After **Area**, select the area where the media server is located. If you are setting up a node, select the area in which the node is located.

10. After **Minimum digits dialed**, type the minimum number of digits dialed for a local call in your city.

11. After **Maximum digits dialed**, type the maximum number of digits dialed for a local call in your city.

12. After **Outbound call digits**, type the number you dial to access an outside line. This information is required if you use a general business model and want to view when phone extensions are active or inactive or if you have the Contact Center Softphone option.

13. After **Apply license for**, select the product for which you are applying a license. For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for a product the check box for that product does not show. If you have no remaining licenses, although the check box still shows, an error message indicates that all available licenses have been used.

14. Specify the data collection settings. See “Configuring data collection settings for a 3300 ICP in the Contact Center Management website” on page 84.

---

### Configuring data collection settings for a 3300 ICP in the Contact Center Management website

To specify data collection settings for a 3300 ICP in the Contact Center Management website

1. Click the **Data collection** tab.

2. Under **Specify data collection settings**, if you do not use OPS Manager, click **TCP**. Otherwise, skip to step 8.

3. Click **IP Address**, or **DNS**, and type the IP address, or name, of the collection point.

4. After **SMDR**, type the SMDR port number of the media server.

5. If you will be entering ACD information, select **ACD**. Otherwise, skip to step 16.

6. After **ACD**, type the ACD port number of the media server. Skip to step 16.

7. If you use OPS Manager, click **Enterprise Manager (OPS Manager)**. Otherwise, skip to step 16.

8. Click **IP address**, or **DNS**, and type the IP address, or name, of the OPS Manager computer.

9. After **FTP port**, type the FTP port number.

10. After **FTP user name**, type the FTP user name to gain access to OPS Manager.

11. After **FTP password**, type the FTP password to gain access to OPS Manager.

12. After **Remote directory to data files**, type the directory path where the data from the telephone system is stored by OPS Manager. If you will be entering ACD information, skip to step 14. If you will not be entering ACD information, skip to step 16.

13. To store ACD redundant events, select the **File all ACD stream redundant events** check box.

14. If you do not consider ACD real-time sequence errors as record errors, select the **Ignore ACD real-time sequence errors as record errors** check box.

15. If this media server is part of a Mitel cluster, under **Cluster settings**, select the **This media server is part of a Mitel cluster** check box. Otherwise, skip to step 19.

16. After **Cluster ID**, type the cluster ID. The cluster ID can be found on the telephone system.

17. After **Cluster name**, type the cluster name.

18. Specify the data summary options. See “Configuring data summary options for a 3300 ICP in the Contact Center Management website” on page 85.
Configuring data summary options for a 3300 ICP in the Contact Center Management website

To configure data summary options for a 3300 ICP in the Contact Center Management website

1. Click the Data summary options tab.
2. If you want SMDR reporting, select the Inbound/Outbound/Make Busy Trace reporting check box.
3. If your business operates around the clock, select the This enterprise operates 24 hours a day check box.
   NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. If you want to track outbound calls that were not answered, select the Credit unanswered outbound calls check box.
5. If you want to display when calls ring at agents’ extensions, select the Monitor Agent Ringing state check box.
6. Under Agent state timeout audit, after Clear line if agent Hold Time exceeds, select the number of minutes or hours you are in a hold state before the telephone system clears the line.
7. After Clear line if agent primary Talk Time exceeds, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.
8. After Clear line if agent secondary Talk Time exceeds, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.
9. If you do not want to report on the secondary line (non-ACD and outbound calls), select the Ignore agent secondary line activity check box.
10. If your telephone system outputs leading digits in SMDR, after Prefix digits, type the digits.
11. If your telephone system outputs trailing digits in SMDR, after Postfix digits, type the digits.
12. Specify MiTAI options.
   See “Configuring MiTAI options for a 3300 ICP in the Contact Center Management website” on page 85.

Configuring MiTAI options for a 3300 ICP in the Contact Center Management website

To configure MiTAI options for a 3300 ICP in the Contact Center Management website

1. Click the MiTAI options tab.
2. After Maximum messages per second, select the number of messages per second from the list. The default number of messages is 10 per second. The higher the version of MiTAI, the greater the number of messages per second.
3. After MiTAI auto-synchronization will occur at, select the time you want Automatic Synchronization to run from the list.
4. After Delay MiTAI Service startup by, select the number of seconds by which you want to delay MiTAI Service startup.
5. After Specify the port used for the MiTAI data stream, type the port number used for the MiTAI data stream.
6. Under Secure call recording
   • After IP address 1, type the primary IP address of the Secure Recording Connector.
   • If you load balance the Secure Recording Connector, after IP address 2, type the secondary IP address of the Secure Recording Connector.
7. Specify Network Monitor settings.
   See “Configuring Network Monitor settings for a 3300 ICP in the Contact Center Management website” on page 86.
Configuring Network Monitor settings for a 3300 ICP in the Contact Center Management website

To configure Network Monitor settings in the Contact Center Management website

1. Click the **Network Monitor** tab.
2. After **Alarm name**, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm. See “Configuring data alarms for media servers” on page 105.
4. Under **Notify me during these business hours**, after **Schedule name**, select a schedule that reflects the hours of operation for the media server.
5. If you must create or modify a schedule for the media server, click **Manage schedule** and configure a schedule. See “Creating schedules” on page 171.
6. Click **Save**.

Adding an SX-200 ACD media server

To add an SX-200 ACD media server

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Click **Add media server=>SX-200 ACD with Real-time**.
   
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **This media server is installed on the computer you named**, select the computer on which the media server is installed.
   
   **NOTE:** The Change the media server type for this media server list appears only after you have saved the media server. It allows you to edit the media server type after the media server has been added to the site.
6. After **Country**, select the country where the media server is located. If you are setting up a node, select the country in which the node is located.
7. After **Area**, select the area where the media server is located. If you are setting up a node, select the area in which the node is located.
8. After **Minimum digits dialed**, type the minimum number of digits dialed for a local call in your city.
9. After **Maximum digits dialed**, type the maximum number of digits dialed for a local call in your city.
10. After **Apply license for**, select the product to which you are applying a license. For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for a product the check box for that product does not show. If you have no remaining licenses, although the check box still shows, an error message indicates that all available licenses have been used.
11. Specify the data collection settings. See “Configuring data collection settings for an SX-200 ACD” on page 86.

Configuring data collection settings for an SX-200 ACD

To configure data collection settings for an SX-200 ACD

1. Click the **Data collection** tab.
2. If the media server streams ACD and SMDR data over RS-232, under **Specify data collection settings**, click **Com port**. Otherwise, skip to step 4.
3. Accept the default ACD and SMDR settings for Com port, baud rate, data bits, parity bit, and stop bits. Skip to step 7.
4. Click **TCP**.
5. Click **IP address**, or **DNS**, and type the IP address, or name, of the collection point.
6. After Specify ports, type the SMDR, ACD, and Traffic Analysis port numbers of the telephone system.
   **NOTE:** You must select the ACD and Traffic Analysis check boxes to enable data collection.

7. If you want to store ACD redundant events, select the **File all ACD stream redundant events** check box.
   This appears on the SX-200 with Real-time user interface only.

8. If you do not consider ACD real-time sequence errors as record errors, select the **Ignore ACD real-time sequence errors as record errors** check box.
   This appears on the SX-200 with Real-time user interface only.

9. If you have clustering, select the **This media server is part of a Mitel cluster** check box.
10. After **Cluster ID**, type the cluster ID.
11. After **Cluster name**, type the cluster name.
12. Specify the data summary options.
    See “Configuring data summary options for an SX-200 ACD” on page 87.

### Configuring data summary options for an SX-200 ACD

To configure data summary options for an SX-200 ACD

1. Click the **Data summary options** tab.
2. If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting** check box.
3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. If you want to track outbound calls that were not answered, select the **Credit unanswered outbound calls** check box.
5. If you want reports and media servers to have a 24-hour clock format (for example, if you want 1:00 P.M. to show as 13:00), select the **24-hour clock format** check box.
6. Under **Agent state timeout audit**, after **Clear line if agent Hold Time exceeds**, select the number of minutes or hours you are in a hold state before the telephone system clears the line.
7. After **Clear line if agent primary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.
8. After **Clear line if agent secondary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.
9. If you do not want to report on the secondary line (non-ACD and outbound calls), select the **Ignore agent secondary line activity** check box.
10. If your telephone system outputs leading digits in SMDR, after **Prefix digits**, type the digits.
11. If your telephone system outputs trailing digits in SMDR, after **Postfix digits**, type the digits.
    See “Configuring Network Monitor settings for an SX-200 ACD” on page 87.

### Configuring Network Monitor settings for an SX-200 ACD

To configure Network Monitor settings for an SX-200 ACD

1. Click the **Network Monitor** tab.
2. After **Alarm name**, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
4. Under **Notify me during these business hours**, after **Schedule name**, select a schedule that reflects the hours of operation for the media server.

5. If you must create or modify a schedule for the media server, click **Manage schedule** and configure a schedule.
   See “Creating schedules” on page 171.

6. Click **Save**.

### Adding a 5000/Axxess media server

To add a 5000/Axxess media server

1. In **YourSite Explorer**, click **Media servers**.
2. Click **Add=>Mitel 5000/Axxess**.
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **Computer name**, select the computer where the server resides.
6. After **Media server type**, select the type of media server.
7. Specify the licenses to use for the media server.
   For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for a product the check box for that product does not show. If you have no remaining licenses, although the check box still shows, an error message indicates that all available licenses have been used.
8. After **IP/DNS address**, specify the IP/DNS address of the media server.
9. After **Password**, type the password used to connect to the telephone system.
10. After **Confirm password**, type the password used to connect to the telephone system.
11. If the 5000/Axxess is connected to a CT Gateway, under **Gateway settings**, select **This media server belongs to a gateway** and specify the Gateway ID.
12. Click **Save**.
13. Configure the location settings.
   See “Configuring location settings for a 5000/Axxess” on page 88.

### Configuring location settings for a 5000/Axxess

To configure location settings for a 5000/Axxess

1. Click the **Location** tab.
2. After **Country**, select the country where the media server is located.
   If you are setting up a node, select the country in which the node is located.
3. After **Area**, select the area code where the media server is located.
   If you are setting up a node, select the area in which the node is located.
4. After **Minimum digits to dial locally**, type the minimum number of digits dialed for a local call in your city.
5. After **Maximum digits to dial locally**, type the maximum number of digits dialed for a local call in your city.
6. After **Outbound dialing prefix**, type the number you dial to access an outside line.
   This information is required if you use a general business model and want to view when phone extensions are active or inactive.
7. Configure the data summary options.
   See “Configuring data summary options for a 5000/Axxess” on page 89
Adding media servers

Configuring data summary options for a 5000/Axxess

To configure data summary options for a 5000/Axxess

1. Click the **Data summary options** tab.
2. If you want to use Trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting**.
3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. If you want to track outbound calls that were not answered, select the **Credit unanswered outbound calls** check box.
5. After **Digits dialed prefix**, type the digits that must precede a telephone number to make an outbound call.
6. After **Digits dialed postfix**, type the digits that must follow a telephone number to make an outbound call.
7. After **Maximum monitors**, specify the maximum number of MiTAI monitors.
8. Under **Agent state timeout audit**, after **Clear line if agent Hold Time exceeds**, select the number of minutes or hours you are in a hold state before the telephone system clears the line.
9. After **Clear line if agent primary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.
10. **Clear line if agent secondary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.
11. If you do not want to report on the secondary line (non-ACD and outbound calls), select the **Ignore agent secondary line activity** check box.
12. Enable **Reset MKB/DND time in realtime after call ends** check box, if you want the MKB/DND time to reset in real time when the call concludes.
13. Under **ACD options**, if you want to file all ACD stream redundant events, select the **File all ACD stream redundant events** check box.
14. If you want to ignore data stream sequence number errors, select the **Ignore stream sequence number errors**.
15. Configure the data collection settings.
   
   See “Configuring data collection settings for a 5000/Axxess” on page 89.

Configuring data collection settings for a 5000/Axxess

To configure data collection settings for a 5000/Axxess

1. Click the **Data collection** tab.
2. After **OAI Listening Port**, specify the port number.
   
   The default Listening Port is 4000.
3. Specify the Network Monitor settings.
   
   See “Configuring Network Monitor settings for a 5000/Axxess” on page 89.

Configuring Network Monitor settings for a 5000/Axxess

To configure Network Monitor settings for a 5000/Axxess

1. Click the **Network Monitor** tab.
2. After **Alarm name**, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   
   See “Configuring data alarms for media servers” on page 105.
4. Under **Notify me during these business hours**, after **Schedule name**, select a schedule that reflects the hours of operation for the media server.

5. If you must create or modify a schedule for the media server, click **Manage schedule** and configure a schedule.
   See “Creating schedules” on page 171.

6. Click **Save**.

### Adding an SX-2000 UCD media server

To add an SX-2000 UCD media server

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Click **Add a media server=>SX-2000 UCD**.
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **This media server is installed on the computer you named**, select the computer on which the media server is installed.
   **NOTE:** The Change the media server type for this media server list appears only after you have saved the media server. It allows you to edit the media server type after the media server has been added to the site.
   **CAUTION:** The following four steps determine location information in your reports. Ensure these steps are accurately configured to ensure accurate reporting.
6. After **Country**, select the country where the media server is located.
   If you are setting up a node, select the country in which the node is located.
7. After **Area**, select the area where the media server is located.
   If you are setting up a node, select the area in which the node is located.
8. After **Minimum digits dialed**, type the minimum number of digits dialed for a local call in your city.
9. After **Maximum digits dialed**, type the maximum number of digits dialed for a local call in your city.
10. After **Outbound call digits**, type the number you dial to access an outside line.
    This information is required if you use a general business model and want to view when phone extensions are active or inactive or if you have the Contact Center Softphone option.
11. After **Apply license for**, select the product for which you are applying a license.
    For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for the product or if you have no remaining licenses, that check box will not appear.
12. Specify the data collection settings.
    See “Configuring data collection settings for an SX-2000 UCD” on page 90.

### Configuring data collection settings for an SX-2000 UCD

To configure data collection settings for an SX-2000 UCD

1. Click the **Data collection** tab.
2. If the media server streams SMDR data over RS-232, under **Specify data collection settings**, click **Com port**. Otherwise skip to step 4.
3. Accept the default SMDR settings for Com port, baud rate, data bits, parity bit, and stop bits. Skip to step 13.
4. If the media server streams SMDR data over TCP/IP, click **TCP**. Otherwise, skip to step 7.
5. Click **IP address**, or **DNS**, and type the IP address, or name, of the collection point.
6. After **SMDR**, type the port number of the telephone system. Skip to step 13.
7. If you have the Call Accounting application and use Mitel OPS Manager, click **Enterprise Manager** (OPS Manager).
8. Click **IP address**, or **DNS**, and type the IP address, or name, of the OPS Manager computer.
9. After **FTP port**, type the FTP port number.
10. After **FTP user name**, type the FTP user name to gain access to OPS Manager.
11. After **FTP password**, type the FTP password to gain access to OPS Manager.
12. After **Remote directory to data files**, type the directory path where the data from the telephone system is stored by OPS Manager, and skip to step 14.
13. If the SX-2000 is a redundant telephone system, under **Redundancy**, select the **This is an SX-2000 redundant telephone system** check box, and type the alternate IP address.
14. If you have clustering, select the **This media server is part of a Mitel cluster** check box.
15. After **Cluster ID**, type the cluster ID.
16. After **Cluster name**, type the cluster name.
17. Click **Save**.
18. If you use datasets to collect traffic data, configure Com port traffic data collection settings.
   See “Configuring Com port traffic data collection settings” on page 91.

**Configuring Com port traffic data collection settings**

Configure Com port data collection settings when you use datasets to collect traffic data.

To configure Com port traffic data collection settings
1. Click the **Data collection** tab.
2. Click the **Traffic** tab.
3. Select the **Specify traffic data collections settings** check box.
4. Click **Com port**.
5. After **Traffic Analysis**, specify the collection settings for the dataset used by the media server to collect traffic data.
6. Click **Save**.

**Configuring FTP traffic data collection settings**

You do not require a dataset if you use FTP to collect traffic data. The .NET Collector uploads the traffic data files stored on the telephone system to the FTP server. You must specify the directory used on the FTP server when you configure media servers for traffic collection. For example, if you specify SX2000\Traffic in the Remote directory to data files field, you must create a directory on the FTP server called SX2000\Traffic\Node_0X (where X is the media server ID).

**NOTE:** Omit the Node_0X folder when you specify the **Remote directory to data files** path. The .NET Collector will create this folder when it uploads the traffic data. The upload will fail if the file structure on the FTP server does not match the file structure you specified. The action will continue to fail until Summarize occurs.

To configure FTP traffic data collection settings
1. Click the **Data collection** tab.
2. Click the **Traffic** tab.
3. Select the **Specify traffic data collections settings** check box.
4. Click **FTP & VT100**.
   **NOTE:** You can use the OPS Manager server as the FTP server.
5. In the FTP settings section, click **IP address** or **DNS** and type the address of the FTP server.
6. After **FTP port**, type the FTP port number.
   **NOTE:** The FTP account you specify must have ReadWriteList permissions for the traffic directories on the FTP server. These FTP credentials are used to transfer the traffic files from the FTP server to the Enterprise Server.
7. After **FTP user name** and **FTP password**, type the user name and password the .NET Collector will use to access the FTP server.
Chapter 6  Configuration

8. After **Remote directory to data files**, type the directory path used to save the traffic data.
   **NOTE:** You must create these folders in the Data Directory. If the folder structure does not match, error messages will be logged until the maintenance routine runs and creates the folders.

9. In the VT100 settings section, click **IP address** or **DNS** and type the address of the VT100 server.

10. After **VT100 port**, type the VT100 port number.

11. After **VT100 user name** and **VT100 password**, type the user name and password the maintenance routine will use to access the VT100 server.

12. Click **Save**.

13. Create a directory on the FTP server called SX2000\Traffic\Node_0X, where X is the media server ID.

   See “Configuring data summary options for an SX-2000 UCD” on page 92.

**Configuring data summary options for an SX-2000 UCD**

To configure data summary options for the SX-2000 UCD

1. Click the **Data summary options** tab.

2. If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting** check box.

3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.

4. If you want to track outbound calls that were not answered, select the **Credit unanswered outbound calls** check box.

5. Under **Agent state timeout audit**, after **Clear line if agent Hold Time exceeds**, select the number of minutes or hours you are in a hold state before the telephone system clears the line.

6. After **Clear line if agent primary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.

7. After **Clear line if agent secondary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.

8. If you do not want to report on the secondary line (non-ACD and outbound calls), select the **Ignore agent secondary line activity** check box.

9. If your telephone system outputs leading digits in SMDR, after **Prefix digits**, type the digits.

10. If your telephone system outputs trailing digits in SMDR, after **Postfix digits**, type the digits.

   See “Configuring Network Monitor settings for an SX-2000 UCD” on page 92.

**Configuring Network Monitor settings for an SX-2000 UCD**

To configure Network Monitor settings for an SX-2000 UCD

1. Click the **Network Monitor** tab.

2. After **Alarm name**, select an alarm.

3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.

4. Under **Notify me during these business hours**, after **Schedule name**, select a schedule that reflects the hours of operation for the media server.

5. If you must create or modify a schedule for the media server, click **Manage schedule** and configure a schedule.
   See “Creating schedules” on page 171.

6. Click **Save**.
Adding an SX-2000 ACD media server

To add an SX-2000 ACD media server

1. In Contact Center Management, click YourSite=>Enterprise.
2. Click Add a media server=>SX-2000 ACD.
   NOTE: To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After Name, type the name of the media server.
4. After Site, select the site where the media server resides.
5. After This media server is installed on the computer you named, select the computer on which the media server is installed.
   NOTE: The Change the media server type for this media server list appears only after you have saved the media server. It allows you to edit the media server type after the media server has been added to the site.
   CAUTION: The following four steps determine location information in your reports. Ensure these steps are accurately configured to ensure accurate reporting.
6. After Country, select the country where the media server is located.
   If you are setting up a node, select the country in which the node is located.
7. After Area, select the area where the media server is located.
   If you are setting up a node, select the area in which the node is located.
8. After Minimum digits dialed, type the minimum number of digits dialed for a local call in your city.
9. After Maximum digits dialed, type the maximum number of digits dialed for a local call in your city.
10. After Apply license for, select the product to which you are applying a license.
    For example, select Call Accounting if you are applying a Call Accounting license. If you are not licensed for a product the check box for that product does not show. If you have no remaining licenses, although the check box still shows, an error message indicates that all available licenses have been used.
11. Specify the data collection settings.
    See “Configuring data collection settings for an SX-2000 ACD” on page 93.

Configuring data collection settings for an SX-2000 ACD

To configure data collection settings for an SX-2000 ACD

1. Click the Data collection tab.
2. If the media server streams data over RS-232, under Specify data collection settings, click Com port. Otherwise skip to step 4.
   NOTE: We highly recommend migrating to 32+ and using TCP/IP for data collection.
3. Accept the SMDR and ACD default settings for Com port, baud rate, data bits, parity bit, and stop bits. Skip to step 8.
4. Click TCP.
5. Click IP address, or DNS, and type the IP address, or name, of the collection point.
6. After SMDR, type the SMDR port number of the media server.
7. After ACD, type the ACD port number of the media server.
8. If you have clustering, select the This media server is part of a Mitel cluster check box.
9. After Cluster ID, type the cluster ID.
10. After Cluster name, type the cluster name.
11. If the SX-2000 is a redundant telephone system, under Redundancy, select the This is an SX-2000 redundant telephone system check box, and type the alternate IP address.
12. If you want to store ACD redundant events, select the File all ACD stream redundant events check box.
13. If you do not consider ACD real-time sequence errors as record errors, select the Ignore ACD real-time sequence errors as record errors check box.
14. If you have the Traffic Analysis application, specify the traffic collection settings.
    See “Configuring Com port traffic data collection settings” on page 91 or “Configuring FTP traffic data collection settings” on page 91.
15. Specify the data summary options.
    See “Configuring data summary options for an SX-2000 ACD” on page 94.
### Configuring data summary options for an SX-2000 ACD

To configure data summary options for the SX-2000 ACD:

1. Click the **Data summary options** tab.
2. If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting** check box. See the Mitel Contact Center Solutions Reports Guide for more information about trace reporting.
3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. If you want to track outbound calls that were not answered, select the **Credit unanswered outbound calls** check box.
5. If you want to display when calls ring at agents’ extensions, select the **Monitor Agent Ringing state** check box.
6. Under **Agent state timeout audit**, after **Clear line if agent Hold Time exceeds**, select the number of minutes or hours you are in a hold state before the telephone system clears the line.
7. After **Clear line if agent primary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the primary line (ACD line) before the system clears that line.
8. After **Clear line if agent secondary Talk Time exceeds**, select the number of minutes or hours you are in a single state on the secondary line (Non ACD) before the system clears that line.
9. If you do not want to report on the secondary line (non-ACD and outbound calls), select the **Ignore agent secondary line activity** check box.
10. If your telephone system outputs leading digits in SMDR, after **Prefix digits**, type the digits.
11. If you telephone system outputs trailing digits in SMDR, after **Postfix digits**, type the digits.
   See “Configuring Network Monitor settings for an SX-2000 ACD” on page 94.

### Configuring Network Monitor settings for an SX-2000 ACD

To configure Network Monitor settings for an SX-2000 ACD:

1. Click the **Network Monitor** tab.
2. After **Alarm name**, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
4. Under **Notify me during these business hours**, after **Schedule name**, select a schedule that reflects the hours of operation for the media server.
5. If you must create or modify a schedule for the media server, click **Manage schedule** and configure a schedule.
   See “Creating schedules” on page 171.
6. Click **Save**.

### Adding a Multimedia Contact Center Email media server

We recommend that you add Multimedia Contact Center Email media servers in YourSite Explorer. However, you can optionally add them in the Contact Center Management website.

You must first add the Multimedia Contact Center Email media server and then configure its options and Network Monitor settings.
Adding a Multimedia Contact Center Email media server in YourSite Explorer

To add a Multimedia Contact Center Email media server in YourSite Explorer

1. In YourSite Explorer, click Media servers.
2. Click Add=>MCC Email.
3. After Name, type the name of the media server.
   NOTE: To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
4. After Site, select the site where the media server resides.
5. After Computer name, select the computer where the server resides.
6. Specify the options.
   See “Configuring options for a Multimedia Contact Center Email media server in YourSite Explorer” on page 95.

Configuring options for a Multimedia Contact Center Email media server in YourSite Explorer

To specify options for a Multimedia Contact Center Email media server in YourSite Explorer

1. Click the Options tab.
2. Under General
   • Select the Delete messages from the Agents sent items folder that are older than x days check box.
     If you do not select this check box, the messages will remain until an administrator removes them.
   • After Delete messages from the Agents sent items folder that are older than, select the number of days after which past messages will be deleted.
3. Under Data summary options
   • If you want trace reporting, select the Inbound/Outbound/Make Busy Trace Reporting check box.
   • If your business operates around the clock, select the This enterprise operates 24 hours a day check box.
     NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
   • Enable Reset MKB/DND time in realtime after call ends check box, if you want the MKB/DND time to reset in real time when the call concludes.
   See “Configuring Network Monitor settings for a Multimedia Contact Center Email media server in YourSite Explorer” on page 96.
Configuring Network Monitor settings for a Multimedia Contact Center Email media server in YourSite Explorer

To configure Network Monitor settings for a Multimedia Contact Center Email media server in YourSite Explorer

1. Click the **Network Monitor** tab.
2. After **Alarm name**, click **...**.
3. Select an alarm from the list and click **OK**.
4. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
5. If you want to modify a schedule for the media server, click **Manage schedule**.
   See “Creating schedules” on page 171.
6. Click **Save**.

Adding a Multimedia Contact Center Email media server in the Contact Center Management website

To add a Multimedia Contact Center Email media server in the Contact Center Management website

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Click **Add a media server=>Multimedia Contact Center Email**.
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **This media server is installed on the computer you named**, select the computer on which the media server is installed.
6. Specify the data summary options.
   See “Configuring data summary options for a Multimedia Contact Center Email media server in the Contact Center Management website” on page 96.

Configuring data summary options for a Multimedia Contact Center Email media server in the Contact Center Management website

To configure data summary options for a Multimedia Contact Center Email media server in the Contact Center Management website

1. Click the **Data summary options** tab.
2. If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting** check box.
3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. Specify Multimedia Contact Center Email options.
   See “Configuring Multimedia Contact Center Email media server options in the Contact Center Management website” on page 97.
Configuring Multimedia Contact Center Email media server options in the Contact Center Management website

To configure Multimedia Contact Center Email server options in the Contact Center Management website

1. Click the Multimedia Contact Center Email options tab.
2. Select the Delete messages from the Agent's sent items folder that are older than \( x \) days check box.
   If you do not select this check box, the messages will remain until an administrator removes them.
3. After Delete messages from the Agent's sent items folder that are older than, select the number of days after which past messages will be deleted.
   See “Configuring Network Monitor settings for a Multimedia Contact Center Email media server in the Contact Center Management website” on page 97.

Configuring Network Monitor settings for a Multimedia Contact Center Email media server in the Contact Center Management website

To configure Network Monitor settings for a Multimedia Contact Center Email media server in the Contact Center Management website

1. Click the Network Monitor tab.
2. After Alarm name, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click Manage alarms and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
4. Under Notify me during these business hours, after Schedule name, select a schedule that reflects the hours of operation for the media server.
5. If you must create or modify a schedule for the media server, click Manage schedule and configure a schedule.
   See “Creating schedules” on page 171.
6. Click Save.

Adding a Multimedia Contact Center WebChat media server

We recommend that you add Multimedia Contact Center WebChat media servers in YourSite Explorer. However, you can optionally add them in the Contact Center Management website.

You must first add the Multimedia Contact Center WebChat media server and then configure its options and Network Monitor settings.

Adding a Multimedia Contact Center WebChat media server in YourSite Explorer

To add a Multimedia Contact Center WebChat media server in YourSite Explorer

1. In YourSite Explorer, click Media servers.
2. Click Add=>MCC WebChat.
3. After Name, type the name of the media server.
   NOTE: To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
4. After Site, select the site where the media server resides.
5. After Computer name, select the name of the Exchange Server computer.
6. Specify the options.
   See “Configuring options for a Multimedia Contact Center WebChat media server in YourSite Explorer” on page 98.
Configuring options for a Multimedia Contact Center WebChat media server in YourSite Explorer

To specify options for a Multimedia Contact Center WebChat media server in YourSite Explorer

1. Click the Options tab.
2. Under General
   - Select the Delete messages from the Agents sent items folder that are older than x days check box.
     If you do not select this check box, the messages will remain until an administrator removes them.
   - After Delete messages from the Agents sent items folder that are older than, select the number of days after which past messages will be deleted.
3. Under Data summary options
   - If you want trace reporting, select the Inbound/Outbound/Make Busy Trace Reporting check box.
   - If your business operates around the clock, select the This enterprise operates 24 hours a day check box.
     NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
   - Enable Reset MKB/DND time in realtime after call ends check box, if you want the MKB/DND time to reset in real time when the call concludes.
   See “Configuring Network Monitor settings for a Multimedia Contact Center WebChat media server in YourSite Explorer” on page 98.

Configuring Network Monitor settings for a Multimedia Contact Center WebChat media server in YourSite Explorer

To configure Network Monitor settings for a Multimedia Contact Center WebChat media server in YourSite Explorer

1. Click the Network Monitor tab.
2. After Alarm name, click ...
3. Select an alarm from the list and click OK.
4. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click Manage alarms and configure an alarm.
   See “Configuring data alarms for media servers” on page 105.
5. If you want to modify a schedule for the media server, click Manage schedule.
   See “Creating schedules” on page 171.
6. Click Save.
Adding a Multimedia Contact Center WebChat media server in the Contact Center Management website

To add a Multimedia Contact Center WebChat media server in the Contact Center Management website:

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Click **Add a media server=>Multimedia Contact Center WebChat**.
   
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **This media server is installed on the computer you named**, select the computer on which the media server is installed.
6. Specify the data summary options.
   
   See “Configuring data summary options for a Multimedia Contact Center WebChat media server in the Contact Center Management website“ on page 99.

Configuring data summary options for a Multimedia Contact Center WebChat media server in the Contact Center Management website

To configure data summary options for a Multimedia Contact Center WebChat media server in the Contact Center Management website:

1. Click the **Data summary options** tab.
2. If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace reporting** check box.
3. If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
4. Specify Multimedia Contact Center WebChat options.
   
   See “Configuring Multimedia Contact Center WebChat media server options in the Contact Center Management website“ on page 99.

Configuring Multimedia Contact Center WebChat media server options in the Contact Center Management website

To configure Multimedia Contact Center WebChat media server options in the Contact Center Management website:

1. Click the **Multimedia Contact Center WebChat options** tab.
2. Select the **Delete messages from the Agent’s sent items folder that are older than x days** check box.
   
   If you do not select this check box, the messages will remain until an administrator removes them.
3. After **Delete messages from the Agent’s sent items folder that are older than**, select the age threshold after which past messages will be deleted.
   
   See “Configuring Network Monitor settings for a Multimedia Contact Center WebChat media server in the Contact Center Management website“ on page 100.
Configuring Network Monitor settings for a Multimedia Contact Center WebChat media server in the Contact Center Management website

To configure Network Monitor settings for a Multimedia Contact Center WebChat media server in the Contact Center Management website:

1. Click the Network Monitor tab.
2. After Alarm name, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click Manage alarms and configure an alarm. See “Configuring data alarms for media servers” on page 105.
4. Under Notify me during these business hours, after Schedule name, select a schedule that reflects the hours of operation for the media server.
5. If you must create or modify a schedule for the media server, click Manage schedule and configure a schedule. See “Creating schedules” on page 171.
6. Click Save.

Adding a Multimedia Contact Center Fax media server

Adding a Multimedia Contact Center Fax media server in YourSite Explorer

To add a Multimedia Contact Center Fax media server in YourSite Explorer:

1. In YourSite Explorer, click Media servers.
2. Click Add=>MCC Fax.
3. After Name, type the name of the media server.
   
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
4. After Site, select the site where the media server resides.
5. After Computer name, select the computer where the server resides.
6. Specify the options. See “Configuring options for a Multimedia Contact Center Fax media server in YourSite Explorer” on page 100.

Configuring options for a Multimedia Contact Center Fax media server in YourSite Explorer

To specify options for a Multimedia Contact Center Fax media server in YourSite Explorer:

1. Click the Options tab.
2. Under General:
   - Select the Delete messages from the Agents sent items folder that are older than x days check box.
     
     If you do not select this check box, the messages will remain until an administrator removes them.
   - After Delete messages from the Agents sent items folder that are older than, select the number of days after which past messages will be deleted.
3. Under **Data summary options**
   - If you want trace reporting, select the **Inbound/Outbound/Make Busy Trace Reporting** check box.
   - If your business operates around the clock, select the **This enterprise operates 24 hours a day** check box.
   
   **NOTE:** If you do not select the **This enterprise operates 24 hours a day** check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display “Unknown Make Busy code.” This can be remedied by logging out of the application and logging back in.
   - Enable **Reset MKB/DND time in realtime after call ends** check box, if you want the MKB/DND time to reset in real time when the call concludes.

   See “Configuring Network Monitor settings for a Multimedia Contact Center Fax media server in the Contact Center Management website” on page 102.

### Configuring Network Monitor settings for a Multimedia Contact Center Fax media server in YourSite Explorer

To configure Network Monitor settings for a Multimedia Contact Center Fax media server in YourSite Explorer

1. Click the **Network Monitor** tab.
2. After **Alarm name**, click ... .
3. Select an alarm from the list and click **OK**.
4. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click **Manage alarms** and configure an alarm.
   See "Configuring data alarms for media servers" on page 105.
5. If you want to modify a schedule for the media server, click **Manage schedule**.
   See “Creating schedules” on page 171.
6. Click **Save**.

### Adding a Multimedia Contact Center Fax media server in the Contact Center Management website

You must first add the Multimedia Contact Center Fax media server and then configure its options and Network Monitor settings.

To add a Multimedia Contact Center Fax media server in the Contact Center Management website

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Click **Add a media server=>Multimedia Contact Center Fax**.
   **NOTE:** To distinguish between the various types of media for management and reporting purposes, you must give each media server a unique name when setting up your site.
3. After **Name**, type the name of the media server.
4. After **Site**, select the site where the media server resides.
5. After **This media server is installed on the computer you named**, select the computer on which the media server is installed.
6. Specify the data summary options.
   See “Configuring data summary options for a Multimedia Contact Center Fax media server in the Contact Center Management website” on page 102.
Configuring data summary options for a Multimedia Contact Center Fax media server in the Contact Center Management website

To configure data summary options for a Multimedia Contact Center Fax media server in the Contact Center Management website:

1. Click the Data summary options tab.
2. If you want trace reporting, select the Inbound/Outbound/Make Busy Trace reporting check box.
3. If your business operates around the clock, select the This enterprise operates 24 hours a day check box.
   
   NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents logged in to Contact Center Solutions applications overnight, you may experience problems with shift-related statistics, such as agent shift monitor and Make Busy Reason codes. For example, if logged in to Contact Center Client overnight with a Make Busy Reason code, when you change the Make Busy Reason code the following day, Contact Center Client will display "Unknown Make Busy code." This can be remedied by logging out of the application and logging back in.
4. Specify Multimedia Contact Center Fax options.
   See “Configuring Multimedia Contact Center Fax media server options in the Contact Center Management website” on page 102.

Configuring Multimedia Contact Center Fax media server options in the Contact Center Management website

To configure Multimedia Contact Center Fax media server options in the Contact Center Management website:

1. Click the Multimedia Contact Center Fax options tab.
2. Select the Delete messages from the Agent's sent items folder that are older than x days check box.
   
   If you do not select this check box, the messages will remain until an administrator removes them.
3. After Delete messages from the Agent's sent items folder that are older than, select the age threshold after which past messages will be deleted.
   See “Configuring Network Monitor settings for a Multimedia Contact Center Fax media server in the Contact Center Management website” on page 102.

Configuring Network Monitor settings for a Multimedia Contact Center Fax media server in the Contact Center Management website

To configure Network Monitor settings for a Multimedia Contact Center Fax media server in the Contact Center Management website:

1. Click the Network Monitor tab.
2. After Alarm name, select an alarm.
3. If you must create or modify an alarm that will warn you if data is not being collected for this media server, click Manage alarms and configure an alarm.
   
   See “Configuring data alarms for media servers” on page 105.
4. Under Notify me during these business hours, after Schedule name, select a schedule that reflects the hours of operation for the media server.
5. If you must create or modify a schedule for the media server, click Manage schedule and configure a schedule.
   
   See “Creating schedules” on page 171.
6. Click Save.
Adding an Intelligent Queue media server

To add an Intelligent Queue media server

1. In Contact Center Management, click YourSite=>Enterprise.
2. Click Add a media server=>Intelligent Queue.
3. After Name, type the name of the media server.
4. After Site, select the site where this media server resides.
5. After This media server is installed on the computer you named, select the computer on which the media server is installed.
6. Click Save.

Configuring data collection settings for an Intelligent Queue media server

To configure data collection settings for an Intelligent Queue media server

1. Select an Intelligent Queue media server from the tree view.
2. Click the Intelligent Queue Reporting data collection tab.
3. Under Specify data collection settings, click TCP.
4. Click IP Address, or DNS, and type the IP address, or name, of the collection point.
5. After SMDR, type the SMDR port number of the media server.
6. If you will be entering ACD information, select ACD.
7. After ACD, type the ACD port number of the media server.
8. Click Save.

Deleting media servers

CAUTION: If you delete a media server, you will delete all of the devices associated to the media server.

To delete a media server in YourSite Explorer

1. In YourSite Explorer, click Media servers.
2. Select the media server you want to delete.
3. Click Delete.
   A window opens with the message “All of the data associated with this media server will be permanently deleted. Are you sure you want to delete this media server?”
4. Click OK.

To delete a media server in the Contact Center Management website

1. In Contact Center Management, click YourSite=>Enterprise.
2. Expand the Enterprise tree and select the media server to be deleted.
3. Click Delete.
   A window opens with the message “All of the data associated with this media server will be permanently deleted. Are you sure you want to delete this media server?”
4. Click OK.
Network Monitor alarms

You can configure one or more data alarm schedules for your media servers. You specify the days and times during which data alarms will be activated. For those days and times, the system will notify you if the Enterprise Server Collector Service is not receiving data from your media servers, or if the server disk space is low. The Low Disk Threshold setting detects if the disk space is low on the disk housing the text files and SQL database. If the disk space is less than the threshold you specify, the system sets off an alarm.

In Network Monitor, you can verify if alarms are enabled for your media servers and if the media servers are reporting any alarms. The Network Monitor icon in your system tray is marked with a red line and blinks when the system is reporting alarms. See “Viewing alarms” on page 321.

The list of alarms is as follows:

- Invalid configuration
- Node offline
- No alarms configured
- PBX PC time drift
- No ACD agent licenses available
- SMDR Record error
- ACD Sequence number error
- Exchange link down
- WebChat Server link down
- Alarm outside of business hours
- SMDR Link down
- SMDR Data timeout
- ACD Link down
- ACD Data timeout
- MiTAI link down
- Intelligent Queue SQL Server is down
- Intelligent Queue Messaging Service is down
- Intelligent Queue Callback Service is down
- Intelligent Queue Recording Service is down
- Intelligent Queue Music Service is down
- Intelligent Queue Watchdog Service is down
- Intelligent Queue Mitel IP Emulation Service is down
- Intelligent Queue is missing an audio file
- Intelligent Queue has detected an incompatible audio file
- Intelligent Queue has no audio functions
- Intelligent Queue has detected a MiTAI error
- Intelligent Queue is low on disk space
- The agent callback destination is invalid. Please enter a valid agent callback destination.
- Due to a lack of available ports, all Updated position in queue messages could not be sent. Please add additional ports to the Updated position in queue port group or reduce the number of Updated position in queue messages to be sent.

You must configure Network Monitor alarms for the SX-200 and SX-2000 media servers in the Contact Center Management website. We recommend that you configure Network Monitor alarms for 3300 ICP media servers in YourSite Explorer. You must configure Network Monitor alarms for 5000 and Axxess media servers in YourSite Explorer.
Configuring data alarms for media servers

In the Contact Center Management website or YourSite Explorer, you set the days and times during which data alarms will be activated.

To configure a data alarm in YourSite Explorer

1. In YourSite Explorer, click Node alarms.
2. Click Add.
3. After Name, type the name of the data alarm.
4. After Schedule, click ... and select the schedule that reflects the company’s hours of operation. The schedule must accurately reflect the hours and days of the week the business is open and data is being received so data alarms are not activated after hours.
5. After Low disk threshold, select the value in MB for the threshold below which you want the data alarm to be activated. (For example, select 50. An alarm will be activated when the disk space is less than 50 MB).
6. If you want to automatically restart the data ports in the event Collector Service detects a problem with the Com ports, enable the Auto restart data ports check box.
7. After Data alarm timeout minutes, select the duration of the time lapse in minutes from when the data stops streaming to when you want the alarm to appear. This setting relates to the SMDR Data timeout and ACD Data timeout Network Monitor alarms.
   NOTE: In a resilient environment, SMDR and ACD Data timeout alarms may trigger unnecessarily. To prevent this, set Data alarm timeout minutes to zero.
8. Click Save.

To configure a data alarm in the Contact Center Management website

1. In Contact Center Management, click YourSite=>Network Monitor=>Configure alarms. The Configure alarms window appears.
2. Click Add.
3. After Name, type the name of the data alarm.
4. After Schedule, select the schedule that reflects the company’s hours of operation. The schedule must accurately reflect the hours and days of the week the business is open and data is being received so data alarms are not activated after hours.
5. After Low disk threshold, select the value in MB for the threshold below which you want the data alarm to be activated. (For example, select 50. An alarm will be activated when the disk space is less than 50 MB).
6. If you want to automatically restart the data ports in the event Collector Service detects a problem with the Com ports, select the Auto restart data ports check box.
7. After Data alarm timeout minutes, select the duration of the time lapse in minutes from when the data stops streaming to when you want the alarm to appear. This setting relates to the SMDR Data timeout and ACD Data timeout Network Monitor alarms.
   NOTE: In a resilient environment, SMDR and ACD Data timeout alarms may trigger unnecessarily. To prevent this, set Data alarm timeout minutes to zero.
8. Click Save.
YourSite database configuration

NOTE:

• The 5000/Axxess telephone system concept of hunt group will be referred to as queue or agent group when used in conjunction with Contact Center Solutions. Hunt groups will be referred to as queues when discussing routing and call treatment options. Hunt groups will be referred to as agent groups when discussing membership roles. Since the 5000/Axxess hunt group acts as both queue and agent group, the telephone systems will not queue on multiple hunt groups at the same time. However, agents can be logged in to multiple hunt groups simultaneously.

• YourSite Explorer enables you to have multiple device tabs open simultaneously. As a best practice, we recommend you only have the device tabs open that you are currently using.

In an ACD contact center using Contact Center Management there are two main databases: the telephone system database and the prairieFyre YourSite database. Your dealer is responsible for assessing your contact center requirements and configuring the telephone system database accordingly. You are responsible for configuring the YourSite database to mirror the trunk, extension, agent, agent group, queue, Account Code numbers, and routing and timing options in use on the telephone system. This can be achieved quickly using the Quick Configuration Wizard for the SX-2000 or Synchronization for the 3300 ICP, 5000, and Axxess. See “Importing configuration data” on page 56 (for the SX-2000) and “Performing synchronization” on page 115.

YourSite database permissions are based on teams and groups. In the YourSite database, you create associations between devices and device groups in order to view real-time data and run reports.

You must

1. Add employees.
2. Add one or more agent login IDs for each employee.
3. Associate the agent login IDs with the employees.
4. Add agent groups.
5. Associate the agent login IDs with agent groups.
6. Add queues.
7. Associate the agent groups with the queues for which they answer calls.

If you intend to run reports on extensions, queue groups, employee groups, trunks, trunk groups, DNIS numbers, or Account Codes, you must add these devices and device groups to the YourSite database also. (See Figure 6-2.)
Figure 6-2 Configuration flow chart

1. Add employees (create employee IDs and associated agent IDs)
2. Add additional agent IDs (for agents who handle calls for multiple queues)
3. Associate employees to additional agent IDs
4. Add agent groups
5. Associate agents to agent groups
6. Add queues
7. Associate agent groups to queues
8. Add queue groups
9. Associate queues to queue groups (optional)
10. Add employee groups
11. Associate employee IDs to employee groups (optional)

**NOTE:** For reporting purposes, the agent, agent group, and queue reporting numbers in the YourSite database must be identical to those configured on the telephone system.

Each employee can have one or more agent IDs. You must associate employee IDs to agent IDs to identify employees.

An agent group must be composed of agents who handle contacts for the same media server type. A group of agents of mixed media types would produce a report that compares voice agents to email agents to chat agents. The comparison would not be valid. You want to compare apples to apples (emails to emails) not apples to oranges (emails to chat).

You must associate agent groups to the queues for which they answer calls.

You must associate queues to queue groups if you want to generate reports on queue groups.

You must associate employees to employee groups if you want to generate reports on employee groups.
Determining your contact center configuration needs

**NOTE:** If you are running Contact Center Management concurrently with Call Accounting, see Chapter 1 of the Mitel Call Accounting User Guide for information on how to configure your system for Call Accounting.

If you want each of your employees to have one agent login ID only, then you must set up your contact center as described in configuration scenario 1. If you want your employees to have an agent login ID for each agent group to which they belong, then you must set up your contact center as described in configuration scenario 2.

**Configuration scenario 1**

In configuration scenario 1, an employee has one agent login ID. The employee belongs to four agent groups that handle calls for four queues. The employee is simultaneously available to handle calls to all four queues without having to log out of one queue and into another queue. (See Figure 6-3.)

**Figure 6-3 Configuration scenario 1**

*Scenario 1*

The employee has only one agent ID and belongs to several agent groups.

*NOTE:* If you have the optional Multimedia Contact Center application, you can use the same agent login ID across voice, email, chat, and/or fax media types. For example, in YourSite=>Configuration, you could add Agent 1000, and associate Agent 1000 with voice, email, chat and/or fax media types.

In configuration scenario 1, you can use the employee Quick Setup tool to create agent login IDs from employee IDs. You add a range of employee IDs, and then select the Create an agent login ID for each employee ID check box. Employee 1000 becomes Agent login ID 1000. On the Edit agent group members tab, you add Agent login ID 1000 to Agent groups 1 to 4. Using Agent login ID 1000, the employee is now simultaneously available to handle calls for Agent groups 1, 2, 3, and 4. (See Figure 6-4.)
Configuration scenario 2

In configuration scenario 2, employees are cross-trained and answer calls for various products and services. The employees monitor call volumes in all of the queues for which they have been cross-trained. If an employee notices a queue is particularly busy, the employee logs off of the telephone system and logs on with an agent login ID associated with the busy queue. (See Figure 6-5.)
In configuration scenario 2, you can use the employee Quick Setup tool to create agent login IDs from employee IDs. You add a range of employee IDs and increment them according to the number of agent login IDs you require for each employee. Then you select the Create an agent login ID for each employee ID check box. Employee 1000 becomes Agent login ID 1000. On the Agent login window, you manually add additional agent login IDs for employees who are cross trained (Employee 1000 also becomes Agent login ID 1001, Agent 1002, and Agent 1003). (See Figure 6-6.)

On the Edit agent group members tab, you add each agent login ID to the appropriate agent group. Employees are available to handle calls for one agent group at a time. If an employee is handling calls for Agent group 2 and notices the call volume is particularly busy for Agent group 4, the employee must log off of the telephone system and log on with an agent login ID associated with Agent group 4.
Figure 6-6 Creating employee IDs for agents with multiple agent IDs

<table>
<thead>
<tr>
<th>Active number from</th>
<th>1000</th>
<th>Active number to</th>
<th>1300</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name Prefix</td>
<td></td>
<td>Name Postfix</td>
<td></td>
</tr>
</tbody>
</table>

General | Agent Associations | Extension Associations | Account Code Associations

- Create an agent for each employee
- Associate the entries to this media server: pfacd1
- Associate the entries to this failover media server: pfacd2
- Start the agent ID numbers at: 1000
- Increment the agent ID numbers by: 4

Configuring YourSite database devices

You can configure the YourSite database in the following ways:

- **Synchronization**
  If you have a 3300 ICP, you can synchronize the YourSite database with the queues, agents (including their skill level within each agent group), agent groups, agent skill groups, trunks, and extensions programmed on the telephone system using Synchronization. You can perform Synchronization on individual 3300 ICPs or all 3300 ICPs in your enterprise.
  If you have a 5000, or Axxess, you can synchronize the YourSite database with the queues, agents, agent groups, agent skill groups, trunks, and extensions programmed on the telephone system using Synchronization. You can perform Synchronization on individual telephone systems or all telephone systems in your enterprise.
  See “Configuring the YourSite database using synchronization” on page 112.

- **Quick Configuration Wizard**
  In the Management Console application, the Quick Configuration Wizard configures Contact Center Management quickly for contact centers with the SX-2000. You start Management Console in Contact Center Client. See “Importing configuration data” on page 56.

- **Quick Setup**
  If you want to add a range of devices (employees, employee groups, employee divisions, agent logins, agent groups, queues, queue groups, extensions, extension groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Account Code groups, Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams) you can use Quick Setup.
  See “Configuring devices and device groups using Quick Setup” on page 122.

- **Comma-separated value (.csv) import**
  If you have a 3300 ICP, 5000, or Axxess. you can also add a range of devices (employee, employee groups, employee divisions, agents, agent groups, queues, queue groups, extensions, extension groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Account Code groups, Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams) using .csv files.
  See “Configuring devices using .csv files” on page 128.

- **Manual configuration**
  If you want to configure devices manually, see “Configuring devices manually” on page 131.
Configuring devices and device groups

The following devices and device groups are configured in YourSite Explorer and/or the Contact Center Management website (under YourSite=>Configuration):

- Employees, employee groups
- Employee divisions
- Agents, agent groups
- Queues, queue groups
- Extensions, extension groups
- Extension divisions (YourSite Explorer only)
- Trunks, trunk groups
- DNIS (Dialed Number Identification Service), DNIS groups
- Account Codes
- Account Code groups (YourSite Explorer only)
- Make Busy Reason Codes
- Do Not Disturb Reason Codes (YourSite Explorer only)
- Phone numbers, phone number groups (YourSite Explorer only)
- Teams
- ANI (Automatic Number Identification) (Contact Center Management website only)
- Intelligent Queue Smart Choice layer, Intelligent Queue Smart Choice layer group, Intelligent Queue extension, Intelligent Queue extension group, Intelligent Queue voice callback queue, Intelligent Queue voice callback queue group, Intelligent Queue Web callback queue, Intelligent Queue Web callback queue group and Intelligent Queue voice exit codes (Contact Center Management website only)

Configuring the YourSite database using synchronization

Synchronization functionality differs depending on the telephone system you use.

Synchronization for the 3300 ICP

YourSite Explorer enables you to configure and write 3300 ICP queues, agent skill groups, and agents (including skill level), and validate/edit contact center related Class of Service, Class of Restriction, System Options, and SMDR Options settings using synchronization.

During synchronization, the queues, agent skill groups, and agents configured in YourSite Explorer are written to the telephone system. This enhanced functionality enables you to configure Contact Center Solutions applications from your desktop. Validation of device and assignment form settings ensures quality data collection and accurate reporting. After running synchronization, Class of Service and Class of Restriction settings programmed in the telephone system can be edited in YourSite Explorer.

During synchronization, administrators can preview device changes, identify devices that should be excluded from synchronization, and manage the business rules related to synchronization of device names and associated device creation.

While synchronizing data, the telephone system continues to operate without experiencing downtime. After synchronization is complete, the Contact Center Client applications open on agent desktops will be refreshed with a device update. After synchronization is complete, all critical programming, such as SMDR Options, System Option, Class of Service, and Class of Restriction settings will be validated. A report is then generated to summarize the results of synchronization. We highly recommend that you correct invalid programming, as detailed on the Telephone system settings tab of media servers in YourSite Explorer, immediately.
In Mitel 3300 release MCD 4.0 SP2, configuring your network using SDS Directory synchronization mode is optional. Customers can continue to operate in the Classic mode, with OPS Manager if operating in a clustered environment. In Mitel 3300 release MCD 4.1, configuring your network using SDS Directory synchronization mode is mandatory for all sites operating with 20 nodes or less. For more information, see “Classic mode synchronization” on page 113 and “SDS Directory synchronization mode” on page 113.

Classic mode synchronization
Using YourSite Explorer and the 3300 ICP in Classic mode, you can add, edit, and delete standard agents, agent groups, and queues, as well as ACD related Class of Service (COS), Class of Restriction (COR), SMDR Options, and System Options. When not in a clustered environment, you can also continue to add hot desk agents and all synchronization device names. Adding hot desk agents in a clustered environment requires the use of Mitel OPS Manager. See “Adding resilient and/or Network ACD hot desking agents” on page 120.

SDS Directory synchronization mode
Using YourSite Explorer and the 3300 ICP in SDS Directory synchronization mode, you can now add, edit and delete standard and hot desk agents, agent groups, queues, trunks, trunk groups, and extensions, synchronize device names, as well as ACD related Class of Service (COS), Class of Restriction (COR) SMDR options and System Options in both a single site and in a clustered environment. When operating in SDS Directory synchronization mode, you can configure Network ACD queue set up on the 3300 ICP without any manual configuration previously required using Mitel OPS Manager.

NOTE:
- You can only use synchronization to synchronize the YourSite database with resilient, Network ACD, and clustered telephone systems if you are using 3300 ICP Release MCD 4.0 SP2 or greater, with the SDS Directory synchronization option enabled on all of the telephone systems in your enterprise.
- If you edit the feature access code used for silent monitoring on the media server, you must also manually edit the feature access code on the telephone system. The feature access code entered in YourSite Explorer must be identical to that on the telephone system and be valid for use with silent monitoring. See “Editing System options” on page 6.
- Intelligent Queue port settings are not programmed during synchronization.

Synchronization for the 5000 and Axxess
If you have a 5000 or Axxess, you can synchronize the YourSite database with the queues, agents, agent groups, extensions, Do Not Disturb Reason codes, and trunks programmed on the telephone system using synchronization. Synchronization can be performed on demand or scheduled to run with the nightly maintenance routine.

NOTE: The device write-back functionality available in YourSite Explorer for the 3300 ICP is not currently available for the 5000 and Axxess telephone systems.

During synchronization, queues, agents, extensions, Do Not Disturb Reason codes, and trunks programmed on the 5000 or Axxess will be synchronized with the YourSite database. Reporting numbers for queues and agent groups will be automatically generated during synchronization.

NOTE: If agents, queues, and extensions on the telephone system have the same reporting or dialable number as the devices programmed in the YourSite database, but they do not have the same name, synchronization will change the name of the device in the YourSite database to match the name of the device on the telephone system.

For Network ACD environments, synchronization looks for agents configured in the cluster. If not found, agents are added to the media server being synchronized. Once agents are created, or matches are found, agent group associations are synchronized for those agents. Agent name changes are only synchronized for the agent's primary media server. Name changes found on other telephone systems are ignored.
While synchronizing data, the telephone system continues to operate without experiencing downtime. After synchronization is complete, the Contact Center Client applications open on agent desktops will be refreshed with a device update. After synchronization is complete, all critical programming will be validated. A report is then generated to summarize the results of synchronization. We highly recommend that you correct invalid programming, as detailed in the report, immediately.

Preparing for synchronization

NOTE:

- Only Mitel IP phones are supported for use with synchronization. Analog and digital phones are not currently supported.
- Only Mitel telephones that are programmed on the IP Multiline set assignment form will synchronize with the YourSite database. For details on the phones that are supported, please refer to your Mitel 3300 ICP documentation.

Before you perform synchronization for the 3300 ICP

- Ensure the 3300 ICP is V8.x or greater. You can only use synchronization to synchronize the YourSite database with resilient, Network ACD, and clustered telephone systems if you are using 3300 ICP Release MCD 4.0 SP2 or greater, with the SDS Directory synchronization option enabled on all of the telephone systems in your enterprise.
- Ensure that you have completed programming the 3300 ICP and created a username and password for synchronization (on the 3300 ICP User Authorization Profile form). The 3300 ICP User Authorization Profile must include Application Access and System Admin Access. Desktop Admin and Group Admin options can be disabled. These steps must be completed for all 3300 ICPs in your Enterprise.
- Ensure your MiXML service is started by clicking Start=>Control Panel=>MiXML. Verify that port 18000 is entered on the Settings tab and click Start.
- Ensure that your Windows or Corporate firewall is not blocking the following ports
  - SOAP: 18000 (HTTPS)
  - UDP: 53
  - TCP: 7011
  - TCP: 22
  - TCP: 443 (SSH)
- Configure the user name and password for each of the 3300 ICP media servers in YourSite Explorer. See "Programming the telephone system for synchronization" in the Contact Center Management Installation Guide.
- If you are running 3300 ICP Release 9.x or earlier, resilient Network ACD, and clustered telephone systems must be programmed using OPS Manager, RDNs, and cluster element IDs. 3300 ICPs programmed with Remote Agent Subgroups and ARS are not supported. Contact Center Management clusters and cluster element IDs must match what is programmed on the telephone system. See "Adding resilient and/or Network ACD hot desking agents" in the Contact Center Solutions User Guide.

Before you perform synchronization for the 5000 and Axxess

- If you have a 5000, ensure it is Version 2.20 or greater. If you have an Axxess, ensure it is Version 10.00 or greater.
- Ensure that you have programmed an OAI IP address and port number on the 5000/Axxess.
- If there is a firewall between your Enterprise Server and the 5000/Axxess, ensure that your Windows or corporate firewall is not blocking port 4000 (TCP).
Specifying synchronization settings

YourSite Explorer enables you to specify the synchronization settings, read options, and write options used by synchronization. When you select a media server in YourSite Explorer, the following synchronization options are available from the ribbon, on the Telephone system tab:

- **Settings**
  - **Disabled**
    This option will fully disable synchronization.
  - **Read**
    This option will read devices programmed on your telephone systems and synchronize them with the YourSite database.
  - **Read/Write**
    This option will read the devices programmed on your telephone systems and synchronize them with the YourSite database and enable devices programmed in YourSite Explorer to be written to the telephone systems.

- **Read Options**
  - **Create employees with new agents**
    For every new agent added to the YourSite database, a new employee will be created and associated with the agent.
  - **Create employees with new extensions**
    For every new extension added to the YourSite database, a new employee will be created and associated with the agent.
  - **Enabled Advanced Real time on new extensions**
    Enable Advanced Real time and Reporting on all new extensions.
  - **Use telephone system device names**
    Override device names programmed in YourSite Explorer with the device names configured on the telephone system.

- **Write Options**
  - **Update telephone directory names**
    Override telephone directory names with agent, agent group, queue, and extension names configured in YourSite Explorer.

Performing synchronization

There are two ways to perform synchronization:

- **Full synchronization**
  Running full synchronization will synchronize the devices programmed on the telephone system and enable you to review all devices, and optionally exclude any devices, before committing changes to YourSite Explorer. See “To perform full synchronization” on page 116.

- **Telephone system settings synchronization**
  Running telephone system settings synchronization will read the current telephone system settings and enable you to view any errors or warnings related to the telephone system configuration. See “To perform telephone system synchronization” on page 117.

**NOTE:**

- You can only use synchronization to synchronize the YourSite database with resilient, Network ACD, and clustered telephone systems if you are using 3300 ICP Release 10.0 (MCD 4.0 SP2) or greater, with the SDS Directory synchronization option enabled on all of the telephone systems in your enterprise.
- As a best practice, we recommend all new installations run Full synchronization to ensure the telephone systems in your enterprise are synchronized with the YourSite database and that there are no critical telephone system programming errors.
- You must program your 3300 ICPs and perform synchronization before you can configure telephone system assignment form options in YourSite Explorer.
• We recommend you do not exchange the reporting number of one device with that of another device.
• Synchronization will not synchronize a device being added to the YourSite database with the telephone system if the device has the same reporting number as an existing device with a different dialable number.
• If you are synchronizing a single telephone system, agents and queues must be programmed on the same telephone system. Single node synchronization can disassociate agents and queues if agents and queues reside on separate telephone systems.
• If you are running 3300 ICP Release 9.x or earlier and you synchronized your network ACD assignments and/or resilient agents using OPS Manager, you must synchronize all of the 3300 ICPs in your enterprise. Otherwise, agent group and queue group associations will be lost.

To perform full synchronization
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP or a 5000/Axxess media server from the list.
3. Click the Telephone system tab.
4. In the ribbon, specify the settings to use with synchronization. See “Specifying synchronization settings” on page 115.
5. In the ribbon, click Run. The Synchronization window opens.
6. Select the media servers to synchronize.
7. Ensure Full synchronization is selected.
8. If this is the first time you have run synchronization, click Synchronize and continue to step 11. If you have already run full synchronization, click Next.
9. Optionally, select the telephone system media servers and devices to include with synchronization. All media servers and devices are selected by default.
10. Specify how you would like to proceed with synchronization:
   • Synchronize—selecting this option will synchronize the devices programmed on the telephone system and enable you to review all entries and optionally exclude any devices before committing them to YourSite Explorer. If you select this option, continue to step 11.
   • Save settings—selecting this option will save the device settings you specified to be used for the next scheduled or on-demand synchronization. If you select this option, the synchronization window will close.
   • Cancel—selecting this option will cancel the synchronization. No changes will be made to YourSite database or the telephone systems. If you select this option, the synchronization window will close.
   • Auto commit—selecting this option and clicking Synchronize will synchronize the devices programmed on the telephone systems and automatically commit them to YourSite Explorer. There will be no opportunity for you to review the entries and optionally exclude any devices before committing them to YourSite Explorer.
11. When the synchronization report displays, you have the following three options:
   • Commit—selecting this option will commit the specified changes and synchronize telephone system devices with YourSite Explorer.
   • Cancel—selecting this option will cancel the specified changes. No devices will be synchronized and the synchronization window will close.
   • Edit—selecting this option will rerun synchronization and enable you to modify the devices to be included in synchronization. If you select this option, return to step 9.

If this is the first time you have run synchronization, any telephone system errors and warnings will display in the synchronization report. You can correct any errors or warnings found in this report by clicking Edit, clicking the Telephone system settings tab and changing the telephone systems settings to the recommended settings. If this is not the first time you have run synchronization, the synchronization window will close once it is complete and you can review any telephone system setting errors and warnings on by selecting a media server in YourSite Explorer and clicking the Telephone system settings tab.
To perform telephone system synchronization

1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP or a 5000/Axxess media server from the list.
3. Click the Telephone system tab.
4. In the ribbon, specify the settings to use with synchronization.
   See “Specifying synchronization settings” on page 115.
5. In the ribbon, click Run.
   The Synchronization window opens.
6. Select the media servers to synchronize.
7. Ensure Telephone system settings is selected.
8. Click Synchronize.
   The Synchronization report window will open and display the progress and status of the
   synchronization. Once synchronization is complete, any telephone system errors and warnings will
   display in the synchronization report. You can correct any errors or warnings found in this report by
   clicking Edit, clicking the Telephone system settings tab and changing the telephone systems settings
   to the recommended settings.

Scheduling Synchronization during the nightly maintenance routine

We recommend you schedule Synchronization to run with the nightly maintenance routine to ensure the
YourSite database and your telephone system are properly programmed.

To schedule synchronization during the nightly maintenance routine

1. In Contact Center Management, click YourSite=>Enterprise.
2. Click the Advanced tab.
3. Select the Run synchronization with nightly maintenance routine check box.

Viewing Synchronization reports

NOTE: The Synchronization report is currently available in English only.

To view a Synchronization report

1. In Contact Center Management, click Tools=>Administrative tools=>Administrative reports.
2. After Status, click View.

Understanding Synchronization reports

After you perform Synchronization, a report summarizing the results of the synchronization is generated. The
Synchronization report contains a synchronization summary, synchronization details, validation results, and
any warnings and errors. Table 6-2 describes the information provided in the Synchronization report

Table 6-2 Synchronization report overview

<table>
<thead>
<tr>
<th>Contents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronization Summary</td>
<td>For each media server in your enterprise, the number of devices added and updated are listed. A license summary is also included in the Synchronization Summary section of the Synchronization report. The License Summary lists the number of employee licenses added and the number of licenses that remain. If you have exceeded the number of employee licenses you currently own, a warning will be displayed and you will be instructed to resolve the problem.</td>
</tr>
</tbody>
</table>
Subscribing to the Synchronization report RSS feed

You can subscribe to a Really Simple Syndication (RSS) feed using a RSS aggregator of your choice (for example, Microsoft Outlook or Internet Explorer), so you are informed every time a Synchronization report is generated. RSS enhances management productivity because you can automatically receive reports without having to browse to the Administrative Reports inbox in Contact Center Management.

To subscribe to the Synchronization report RSS feed

1. In Contact Center Management, click Tools=>Administrative tools=>Administrative reports.
2. Click Access RSS feed.
3. Click Subscribe to this feed.
4. Follow the steps required by your RSS aggregator to subscribe to the Synchronization report feed.

**NOTE:** When you browse to a Web page that contains RSS information, the orange RSS button appears next to the Home icon.

To add a RSS feed through Microsoft Internet Explorer 7+

1. Click the RSS feed button.
   A list of all available RSS feeds on the Web page is displayed.
2. Click the RSS feed you want to subscribe to.
   You can optionally click the RSS or XML buttons in the Web page to subscribe to a RSS feed.

To add a RSS feed through Microsoft Office Outlook 2007

1. On the Tools menu, click Account Settings.
2. On the RSS Feeds tab, click New.
3. In the New RSS Feed dialog box, type or copy and paste the URL of the RSS feed, for example, http://www.example.com/feed/main.xml.
4. Click Add.
5. Click OK.

### Table 6-2 Synchronization report overview

<table>
<thead>
<tr>
<th>Contents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronization Details</td>
<td>The Synchronization Details section of the Synchronization report lists specific details that pertain to the devices added and updated, or associations made or deleted during the synchronization.</td>
</tr>
<tr>
<td>Validation Results</td>
<td>The Validation Results section of the Synchronization report lists any system and device level warnings and any critical programming errors.</td>
</tr>
<tr>
<td>Warnings</td>
<td>The Warnings section of the Synchronization report lists any non-critical warnings that may have affected the results of the synchronization process. We highly recommend that you immediately correct any invalid programming that may have caused warnings to appear.</td>
</tr>
<tr>
<td>Errors</td>
<td>The Errors section of the Synchronization report lists any critical errors that would have prevented synchronization from occurring. If critical errors are detected, the Synchronization report will display the Warnings and Errors sections of the report only. We highly recommend you immediately correct any invalid programming that may have caused the error, to ensure your contact center functions properly.</td>
</tr>
</tbody>
</table>
Editing telephone system assignment forms

After you run Synchronization for the 3300 ICP in YourSite Explorer, you can edit a subset of contact center related 3300 ICP System Options, SMDR Options, Class of Service, and Class of Restriction assignment forms. Any changes made to the telephone system assignment forms in YourSite Explorer are written to the telephone system when a user clicks Save.

NOTE: You must perform Synchronization for the 3300 ICP before you can edit any telephone system assignment forms in YourSite Explorer.

Editing System options

Using YourSite Explorer, you can edit the ACD 2000 - Automatically log out last agent on no answer and ACD Real-time Events Feature Level. YourSite Explorer displays the recommended value for these System Options.

To edit System Options

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Enterprise**, click **Media servers**.
3. Under **Media servers**, select a 3300 ICP media server.
4. Click the **Telephone system settings** tab.
5. In the left pane, click **System options**.
6. After **Feature access code for silent monitoring**, type the feature access code used for silent monitoring, as programmed on the telephone system.
   
   **NOTE:** If you edit the feature access code on the media server, you must also manually edit the feature access code on the telephone system. The feature access code entered in YourSite Explorer must be identical to that on the telephone system and be valid for use with silent monitoring.
7. After **ACD 2000 - Automatically log out last agent on no answer**, click **Yes** or **No**.
8. After **ACD Real-time Events Feature Level**, specify the feature level value.
9. After **ACD Make Busy Walk Away Codes**, click **Yes** or **No**.
10. In the ribbon, click **Save**.

Editing SMDR options

Using YourSite Explorer, you can edit a subset of contact center related SMDR options. YourSite Explorer displays the recommended value for these SMDR options.

To edit SMDR Options

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Enterprise**, click **Media servers**.
3. Under **Media servers**, select a 3300 ICP media server.
4. Click the **Telephone system settings** tab.
5. In the left pane, click **SMDR options**.
6. After **Extended digit length**, click **Yes** or **No**.
7. Specify the system options.
8. In the ribbon, click **Save**.
Editing Class of Service options
Using YourSite Explorer, you can edit a subset of contact center related Class of Service options. YourSite Explorer displays the recommended value for these Class of Service options.

To edit Class of Service options
1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Enterprise**, click **Media servers**.
3. Under **Media servers**, select a 3300 ICP media server.
4. Click the **Telephone system settings** tab.
5. In the left pane, click **Class of Service**.
6. Under **Name**, select the Class of Service to edit.
7. After **Comment**, enter a description for the Class of Service.
8. After **Use this Class of Service as the default value for new agents**, click Yes or No.
9. After **HCI/CTI/TAPI call control allowed**, click Yes or No.
10. After **HCI/CTI/TAPI monitor allowed**, click Yes or No.
11. After **SMDR external**, click Yes or No.
12. After **SMDR internal**, click Yes or No.
13. In the ribbon, click **Save**.

Editing Class of Restriction options
Using YourSite Explorer, you can edit a subset of contact center related Class of Restriction options.

To edit the Class of Restriction options
1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Enterprise**, click **Media servers**.
3. Under **Media servers**, select a 3300 ICP media server.
4. Click the **Telephone system settings** tab.
5. In the left pane, click **Class of Restriction**.
6. Under **Number**, select the Class of Restriction to edit.
7. After **Do you want this Class of Restriction to be the default setting**, click Yes or No.
8. After **Classes of Restriction for the group**, enter the Class of Restriction numbers to include in the group.
   A range of numbers may be specified. Separate numbers using commas or dashes. For example, 1 though 9 may be entered as 1-9 or a combination of individual numbers and ranges may be entered as 1,2,3,7-10,13.
   **NOTE:** Class of Restriction numbers must be entered in ascending order within each group.
9. In the ribbon, click **Save**.

Adding resilient and/or Network ACD hot desking agents
If you use resilient or Network ACD hot desking agents, you must first program them on the telephone system using OPS Manager. After you have added the resilient or Network ACD hot desking agents to the telephone system, you must synchronize network elements using OPS Manager. You then perform Synchronization on all 3300 ICPs in your enterprise. Once you have performed Synchronization, the resilient and/or Network ACD hot desking agents you programmed using OPS Manager will be programmed in the YourSite database and available in YourSite Explorer.

It is important to understand that traditional and hot desking agents cannot be combined on the same telephone system or within a cluster. For more information about invalid ACD agent programming, see “Invalid ACD cluster programming” on page 121.
To add a resilient or Network ACD hot desking agent using OPS Manager

1. In Internet Explorer, browse to OPS Manager.
3. Click Add User. Optionally, click Edit user to edit an existing user.
4. Under Identification, type a name.
5. After Number, type the agent's dialable number.
6. After Home Element, select the primary telephone system from the list.
7. After Type, select ACD Agent.
8. Under Appliances and Services, select Enable Resiliency.
9. After Secondary Element, select the secondary telephone system from the list.
10. Under Telephone Directory, after Distribution List, select the distribution list you have created.
11. Click Add. The user is added to the telephone system.
12. Once the user has been added to the telephone system, click Configuration=>Directory Management=>Synchronize with=>Network Elements.
13. Under Not selected, select the telephone systems to synchronize from the list and click < to move them to the Selected list.
14. Click Sync Now. The telephone directories for the specified telephone systems are synchronized.
15. After the telephone systems are synchronized, perform Synchronization on all 3300 ICPs in your enterprise.

See “Configuring the YourSite database using synchronization” on page 112. Once Synchronization is complete, the resilient and/or Network ACD hot desking agents you added using OPS Manager are available in YourSite Explorer.

Invalid ACD cluster programming

Combining traditional ACD agents and ACD hot desking agents on the same telephone system is not supported. All media servers within a cluster must be configured with the same type of agents. If the telephone systems within a cluster are configured with both ACD hot desking agents and traditional ACD agents, agent states will not display correctly in Contact Center Client real-time monitors and you will receive an "Invalid ACD cluster programming" error in YourSite Explorer.

The "Invalid ACD cluster programming" error is displayed when the following conditions are met

• One or more media servers in a cluster are programmed with both traditional and ACD hot desking agents and/or
• The media servers in a cluster are not programmed with the same type of ACD agents

**NOTE:** As a best practice, we recommend you perform Synchronization before attempting to resolve any invalid ACD cluster programming errors on the telephone system. This will ensure that your configuration is accurate and any errors being reported are valid.

The following scenarios provide examples of different invalid ACD cluster programming, with the problem areas identified in red text.

**Scenario 1**
In the scenario shown in Table 6-3, media servers with mixed agent types are programmed in YourSite Explorer.
Table 6-3 Invalid ACD agent programming scenario 1

<table>
<thead>
<tr>
<th>Cluster name: Primary</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Server</td>
</tr>
<tr>
<td>Kanata 3300 5th floor</td>
</tr>
<tr>
<td>Kanata 3300 7th floor</td>
</tr>
</tbody>
</table>

Scenario 2
In the scenario shown in Table 6-4, media servers have the correct agent type settings programmed in YourSite Explorer, but have mixed agent types programmed against a single 3300 ICP.

Table 6-4 Invalid ACD agent programming scenario 2

<table>
<thead>
<tr>
<th>Cluster name: Master</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Server</td>
</tr>
<tr>
<td>Kanata 3300 5th floor</td>
</tr>
<tr>
<td>Kanata 3300 7th floor</td>
</tr>
</tbody>
</table>

For more information on ACD agent programming, see "ACD" in the Mitel 3300 System Administration Tool Help, which can be found at http://edocs.mitel.com/default.htm.

Configuring devices and device groups using Quick Setup

If you have a 3300 ICP or 5000/Axxess telephone system, you add a range of contact center devices in YourSite Explorer using Quick Setup. If you have an SX-2000 telephone system, you add a range of contact center devices in the Contact Center Management website using YourSite=>Configuration. If you have an SX-200 ACD, you must configure your system manually. See “Configuring devices manually” on page 131.

NOTE: Quick Setup is not offered in the Data grid view.

In the Contact Center Management website under YourSite=>Configuration, if you move your mouse over the Configuration menu on the left side of the Configuration window, the menu displays devices you can configure. Moving your mouse over the arrows to the right of these devices exposes additional devices. Alternatively, you can click the Configuration menu to view the complete list of devices to configure.

You can add a range of employee and agent login IDs in one action with Quick Setup, or you can add employee and agent login IDs manually on their respective windows. Using Quick Setup is faster and less tedious than adding individual employee and agent login IDs. However, if you want to use existing numbers for employee IDs (for example, the first three numbers of each employee’s social security number), then you must add the employee and agent login IDs manually.

You can use Quick Setup to add ranges of the following devices:
- Employees and employee groups'
- Employee divisions
- Agents and agent groups
• Queues and queue groups (Contact Center Management website only)
• Extensions and extension groups
• Extension divisions (YourSite Explorer only)
• Trunks and trunk groups
• DNIS and DNIS groups
• Account Codes
• Account Code groups (YourSite Explorer only)
• Make Busy Reason Codes
• Teams

**Employee Quick Setup**

**NOTE:**

- When you create employee IDs and agent login IDs, group all of the employees together from each site, and then group all of the employees together who have similar contact characteristics. For example, if half of the employees at a site will be voice agents (similar characteristic) and half of the employees will be email agents (similar characteristic), then group the voice agents together and group the email agents together. Using Quick Setup, you create the employee IDs and agent login IDs for the voice agents group, and then create the employee IDs and agent login IDs for the email agents group.

- If you are upgrading a Contact Center Management (voice) employee to a Multimedia Contact Center (voice, email, and/or chat) employee, before you use Quick Setup, you must assign a folder to the employee prior to assigning the employee an agent login ID. To do so, click Configuration=>Employee=>Employee=>Edit, and update the Multimedia Contact Center properties for the employee.

If you have an SX-200 or SX-2000, you add a series of employees in the Contact Center Management website under YourSite=>Configuration, Employee=>Employee.

If you have a 3300 ICP, 5000, or Axxess, to add a series of employees

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Click **Quick Setup**.
4. In the **Active number from** and **Active number to** boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name postfix** type the prefix and/or postfix.
6. If you will monitor the employees in real-time and run reports on them, on the **General** tab, select the **This employee will be tracked in real time and reporting** check box.
7. If the employees will be scheduled using Workforce Scheduling, select the **This employee will be scheduled using Workforce Scheduling** check box.
8. If the employees are resilient, select the **This employee is resilient and will be monitored in real time and reporting** check box.
9. If you want to create an agent login ID for each employee, on the **Agent associations** tab, select the **Create an agent login ID for each employee** check box.

**NOTE:** It is recommended you create agent login IDs from employee IDs.

10. Select the media server and failover media server the agent will use.

**NOTE:** If the employees are resilient, they can be associated with only one voice media server per cluster and you can select the failover media server for the employees.

11. After **Start the agent login IDs at**, type the first agent login ID number to associate to the employee ID range.
12. After **Increment the agent login IDs by**, type the increment by which the agent login ID numbers will increase.
13. If you want to create an extension for each employee, on the **Extension associations** tab, select the **Create an extension number for each employee** check box.
14. Select the media server and failover media server the extension will use.
15. If the extension will be costed with Call Accounting, select the **Cost this extension** check box.
16. After **Start the extension numbers at**, type the first extension number to associate with the employee ID range.
17. After **Increment the extension numbers by**, type the increment by which the extension numbers will increase.
18. If you want to create Account Code associations, on the **Account Code associations** tab, select the **Create an Account Code for each employee** check box.
19. After **Start the Account Code numbers at**, type the first Account Code number to associate to the employee ID range.
20. After **Increment the Account Code numbers by**, type the increment by which the Account Code numbers will increase.
21. Click **Run**.

**Agent Quick Setup**

**NOTE:** You cannot use Quick Setup to create agent login IDs for a Multimedia Contact Center Email media server.

If you have an SX-200 or SX-2000, you add a series of agents in the Contact Center Management website under YourSite=>Configuration, Agent login=>Agent login.

If you have a 3300 ICP, 5000, or Axxess, to add a series of agents
1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Agents**.
3. Click **Quick Setup**.
4. In the **Active number from** and **Active number to** boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name postfix** type the prefix and/or postfix.
6. On the **General** tab, after **Associate the devices to this media server**, click ... and select a media server.
7. If you want to create an employee ID for each agent, on the **Agent associations** tab, select the **Create an employee ID for each agent** check box.
   **NOTE:** Select this check box only if you have not already added employee IDs to the database.
8. After **Start the employee IDs at**, type the first employee ID number to associate with the agent reporting number range.
9. After **Increment the employee IDs by**, type the increment by which the employee ID numbers will increase.
10. If you want to append a prefix to the agent reporting number, on the **Reporting numbers** tab, select the **Append a prefix/and or postfix to the reporting number** check box and type a prefix and/or postfix.
11. Click **Run**.

**Queue Quick Setup**

If you have an SX-200, SX-2000, 3300 ICP, or 5000/Axxess, to add a series of queues
1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the configuration menu, click **Queue=>Queue**.
3. Click **Quick Setup**.
4. Select a site and the media server the queues will use.
5. In the **Active number from** and **Active number to** boxes, type a range of queue numbers.
6. On the General tab, if you want to add a prefix or postfix to this range of queue numbers, select the **Append a prefix and/or a postfix to the device name** check box and type the prefix and/or postfix.

7. If you want to add a prefix or postfix to the range of dialable numbers, select the **Append a prefix and/or a postfix to the dialable number** check box and type the prefix and/or postfix.

8. On the Metrics tab, after **Short Abandon**, type the Short Abandon threshold (in seconds) for the queues.

9. After **Short Talk**, type the Short Handle threshold (in seconds) for the queues.

10. After **The goal for this queue is to handle**, type the Service Level Percent objective for the queues.

11. After **% of calls in less than**, type the Service Level Time objective for the queues.

12. If you selected a 3300 ICP media server, click the **MiTAI** tab and complete steps 14 to 16.

13. After **Business hours**, select the business hours of the media server.

14. If the queues are unavailable outside of business hours, select the **Set the queue to unavailable outside of these business hours** check box.

15. Select the **Auto-synchronize the YourSite database with the telephone system** check box.

16. Click **Run**.

**Extension Quick Setup**

If you have an SX-200 or SX-2000, you add a series of extensions in the Contact Center Management website under **YourSite=>Configuration, Extension=>Extension**.

If you have a 3300 ICP, 5000, or Axxess, to add a series of extensions

1. In YourSite Explorer, in the left pane, click **YourSite**.

2. Under **Devices**, click **Extensions**.

3. Click **Quick Setup**.

4. In the **Active number from** and **Active number to** boxes, type a range of device numbers.

5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name Postfix** type the prefix and/or postfix.

6. On the General tab, select a media server and a failover media server for the extension.

7. If the extension will be costed with Call Accounting, select the **Cost this extension** check box.

8. Under **Reporting and real-time options**

   - Select **Historical reporting only** if you want to run reports for the extension but not monitor it in real time.
   - Select **Real time and reporting** if you want to run reports on and monitor the extension in real-time.

9. Under **Advanced options**, select the **Extension type**.

10. If you want to create an employee for each extension, on the **Employee Associations** tab, select the **Create an employee ID for each extension** check box.

    **NOTE:** Select this check box only if you have not already added employee IDs to the database.

11. After **Start the employee IDs at**, type the first employee ID number to associate with the extension number range.

12. After **Increment the employee IDs by**, type the increment by which the employee ID numbers will increase.

13. Click **Run**.
Trunk Quick Setup

If you have an SX-200 or SX-2000, you add a series of trunks in the Contact Center Management website under YourSite=>Configuration, Trunk=>Trunk.

If you have a 3300 ICP, 5000, or Axxess, to add a series of trunks

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Trunks**.
3. Click **Quick Setup**.
4. In the **Active number from** and **Active number to** boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name postfix** type the prefix and/or postfix.
6. On the **General** tab, click ... and select a media server for the trunk.
7. Click **Run**.

Trunk group Quick Setup

If you have an SX-200 or SX-2000, you add a series of trunk groups in the Contact Center Management website under YourSite=>Configuration, Trunk=>Trunk group.

If you have a 3300 ICP, 5000, or Axxess, to add a series of trunk groups

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Trunk groups**.
3. Click **Quick Setup**.
4. In the **Active number from** and **Active number to** boxes, enter a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name postfix** type the prefix and/or postfix.
6. On the **General** tab, click ... and select the voice media server associated with the trunk (for example, 3300 ICP Voice).
7. If this trunk group uses an intra switch, select the **Intra switch** check box.
8. To cost calls using this trunk, clear the **Do not cost calls** check box.
9. Click **Run**.

DNIS Quick Setup

If you have an SX-200 or SX-2000, you add a series of DNIS in the Contact Center Management website under YourSite=>Configuration, DNIS=>DNIS.

If you have a 3300 ICP, 5000, or Axxess, to add a series of DNIS

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **DNIS**.
3. Click **Quick Setup**.
4. In the **Active number from** and **Active number to** boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after **Name prefix** and/or **Name postfix** type the prefix and/or postfix.
6. On the **General** tab, after **Associate the devices to this media server**, click ... and select a media server.
7. After **Short Abandon**, type the Short Abandon threshold for the DNIS.
8. After **Service Level**, type the Service Level time for the DNIS.
9. Click **Run**.
Account Code Quick Setup

If you have an SX-200 or SX-2000, you add a series of Account Codes in the Contact Center Management website under YourSite=>Configuration, Account Codes=>Account Codes.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Account Codes

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or Name postfix type the prefix and/or postfix.
6. To you want to create an employee for each Account Code, on the Employee Associations tab, select the Create an employee ID for each Account Code check box.
   **NOTE:** Select this check box only if you have not already added employee IDs to the database.
7. After Start the employee IDs at, type the first employee ID number to associate to the Account Code range.
8. After Increment the employee IDs by, type the increment by which the employee ID numbers will increase.
9. Click Run.

Make Busy Reason Codes Quick Setup

If you have an SX-200 or SX-2000, you add a series of Make Busy Reason Codes in the Contact Center Management website under YourSite=>Configuration=>Make Busy Reason Code.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Make Busy Reason Codes

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Make Busy Reasons.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or Name postfix type the prefix and/or postfix.
6. Click Run.

Team Quick Setup

If you have an SX-200 or SX-2000, you add a series of Teams in the Contact Center Management website under YourSite=>Configuration=>Team.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Teams

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Teams.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or Name postfix type the prefix and/or postfix.
6. Click Run.
Device group Quick Setup

If you have an SX-200 or SX-2000, you add a series of employee groups, agent groups, queue groups, extension groups, and DNIS groups in the Contact Center Management website under YourSite=>Configuration.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Account Code groups, agent groups, DNIS groups, employee groups and divisions, extension groups and divisions, and queue groups

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click the device group name.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. To add a prefix or postfix to the range of device numbers, after Name prefix and/or Name postfix type the prefix and/or postfix.
6. If you are adding an agent group, click ... and select a media server and failover media server to associate with the agent group.
7. Click Run.

Configuring devices using .csv files

If you have a 3300 ICP, 5000, or Axxess telephone system, you can import devices to YourSite Explorer using comma-separated value (.csv) files. The following device types are currently supported for use with the YourSite Explorer .csv import tool: employees, employee groups, employee divisions, agents, agent groups, queues, queue groups, extensions, extension groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams.

A .csv file is used for the digital storage of data structured in a table of lists form, where each associated item (member) in a group is in association with others also separated by the commas or tabs of its set.

There are two ways to create .csv files: Notepad or Microsoft Excel. We recommend making .csv files in Excel, as adding and editing a large number of entries at once using auto-fill functions is much simpler and more convenient than using Notepad.

Alternatively, you can also import tabbed delimited text files created in Excel. Tabbed delimited text files are almost identical to .csv files, but use tabs to differentiate data fields instead of commas.

The following images provide two examples of how .csv files can be formatted. Figure 6-7 displays Microsoft Excel .csv formatting and Figure 6-8 displays Notepad .csv formatting. Both .csv examples contain the following data: first name, last name, agent login ID, and media server.

**NOTE:** To import configuration options that display in the YourSite Explorer grid view as a checkbox, you must enter True or False as the field data. For example, if an employee was enabled for real-time and reporting, you would enter the value True in your .csv file and map it to the Real-time license field.
Figure 6-7 Microsoft Excel .csv formatting example

![Microsoft Excel .csv formatting example](image1)

Figure 6-8 Notepad .csv formatting example

![Notepad .csv formatting example](image2)

**Fields required for successful .csv imports**

The following table details the fields that are required in order to successfully import devices into YourSite Explorer using a .csv file.

**NOTE:** Data must be entered in .csv files using the exact order detailed in the table below. Failure to import data in the order specified will result in import errors.

**Table 6-5 Mandatory device fields for .csv imports**

<table>
<thead>
<tr>
<th>Device</th>
<th>Mandatory fields</th>
<th>Optional fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employees</td>
<td>First name, last name, employee ID (reporting number)</td>
<td>Full time, middle name, email address, suffix, real-time license, nickname, resiliency license, activated, scheduling license, site, password, is a supervisor, username, supervisor, is active, security role, preferred printer, print locally, use employee email for report distribution, fax number, hire date, birth date, business phone number, emergency contact phone number, emergency contact relationship, emergency contact name, country, ZIP or postal code, street address, city, state or province, pager number, phone number</td>
</tr>
<tr>
<td>Employee groups</td>
<td>Name, employee group ID (reporting number)</td>
<td>N/A</td>
</tr>
</tbody>
</table>
### Device mandatory fields

<table>
<thead>
<tr>
<th>Device</th>
<th>Mandatory fields</th>
<th>Optional fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee divisions</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Agents</td>
<td>First name, last name, agent login ID, media server</td>
<td>Failover media server, employee, real time and reporting, is active</td>
</tr>
<tr>
<td>Agent groups</td>
<td>Name, reporting number, media server</td>
<td>Failover media server, real time and reporting, is active</td>
</tr>
<tr>
<td>Queue groups</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Extensions</td>
<td>Name, reporting number, media server</td>
<td>Extension type, failover media server, real-time license, is active, cost this extension, notes, is general business hotdesking</td>
</tr>
<tr>
<td>Extension groups</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Extension divisions</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Trunks</td>
<td>Name, reporting number, media server</td>
<td>N/A</td>
</tr>
<tr>
<td>Trunk groups</td>
<td>Name, reporting number</td>
<td>Media server, do not cost calls, carrier plan, intra switch</td>
</tr>
<tr>
<td>DNIS</td>
<td>Name, reporting number, media server</td>
<td>Short abandon, service level, carrier plan, call type, call rate</td>
</tr>
<tr>
<td>DNIS groups</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Account Codes</td>
<td>Name, reporting number</td>
<td>Use as classification code</td>
</tr>
<tr>
<td>Make Busy Reason Codes</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Do Not Disturb Reason Codes</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
<tr>
<td>Teams</td>
<td>Name, reporting number</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Importing a range of devices using a .csv file

**NOTE:** Before you attempt to import a device using a .csv file, ensure

- The .csv file contains data for all of the fields required to save a device in YourSite Explorer as detailed in “Mandatory device fields for .csv imports” on page 129.
- If a device requires a dependency to be specified, for example specifying a media server is required in order to save an agent, the dependency must already exist in YourSite Explorer. The Import Wizard cannot create new dependencies and will fail if the dependency does not already exist in the database.

To import a range of devices using a .csv file

1. In YourSite Explorer, under **Devices**, click the name of the device you will add using a .csv file.
2. Click **Import**.
3. After **Select file type**, specify whether the .csv file uses **Comma separated values** (.csv) or **Tab separated values** (.txt).
4. After **Select file**, click **Browse** and specify the location of the .csv file.
5. Under **Options**, specify how the Import Wizard will handle duplicate items.
   - If duplicates are found:
     - Overwrite entries if duplicates are found will use the .csv file as the master and overwrite duplicate entries in the YourSite database with data in the .csv file.
Adding resilient and/or Network ACD hot desking agents

- Skip duplicate entries during import will retain data configured in YourSite Explorer as the master and import any new data entries from the .csv file into the YourSite database.
- Do not import if duplicates are found will scan the .csv and YourSite database for duplicates. If duplicates are found in either the .csv or the YourSite database, the import is cancelled and no data is imported to the YourSite database.

6. Click Next.
7. On the Field Mappings window, map the fields in the Available columns list to the Selected columns list using the arrow buttons, so they appear in the exact same order as they do in your .csv file.
8. Click Next.
9. When the import has completed, click Finish.

The imported devices will display in the data grid view of YourSite Explorer.

NOTE: If the import fails, the Import Wizard will notify you of whether the YourSite database or .csv file contained the duplicate(s) and which row(s) of the .csv file contained the error(s) that resulted in the failure. Fixing these errors will allow devices to be successfully imported.

Configuring devices manually

CAUTION: For reporting purposes, the trunk, extension, agent, agent group, queue, DNIS, dialable numbers, and Account Code numbers you configure in the YourSite database must be identical to those of the telephone system.

If you have an SX-200 or SX-2000 telephone system, you must add contact center devices in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add contact center devices in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add contact center devices in YourSite Explorer.

Throughout the manual device configuration section of this chapter instructions for YourSite Explorer configuration are given first, followed by instructions for configuring devices in the Contact Center Management website.

NOTE:
- When you configure numbers for groups in YourSite, use numerical characters only, such as 1 (for Extension group 1). Do not insert symbols, such as a star [*] or pound sign [#], in the number.
- If you attempt to add a device or device group to YourSite that is already in the database, the system notifies you that the device or device group is already present. When you add a series of devices or device groups to YourSite, such as Extensions 5001 to 5005, if the system detects you have already added Extension 5002, then it will not add Extension 5002 or any subsequent extensions in the series (that is, Extensions 5003 to 5005) to the database.
- If you are upgrading a Contact Center Management (voice) employee to a Multimedia Contact Center (voice, email, chat and/or fax) employee, before you assign the employee to an agent login ID, you must assign a public folder to the employee. To do so, click Configuration=>Employee=>Edit and update the Multimedia Contact Center properties for the employee.
- If you have the optional Intelligent Queue application, after you set up your contact center site (in YourSite Enterprise) and add an Intelligent Queue media server to the site, the information in the YourSite database automatically synchronizes to that of the telephone system.
Adding employees
You must add all contact center employees (agents, supervisors, and managers) to the YourSite database so you can run reports on employee activities and view employee performance in real time, and so the employees can use Contact Center Management.

You must add agent login IDs to the YourSite database for employees you want to track in real time and reporting. When you add an employee, you can simultaneously create an agent login ID for the employee, provided you want the agent login ID to be the same as the employee ID.

NOTE: You must assign each employee a unique ID number.

If you have an SX-200 or SX-2000 telephone system, you must add employees in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add employees in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add employees in YourSite Explorer.

Configuring general information and licensing information (in YourSite Explorer)
To configure general information and licensing information for an employee
1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Click **Add**.
   You must provide the date the employee became an active part of the enterprise if you intend to generate administrative employee reports, or if you have Workforce Scheduling and will schedule employees based on seniority, or will manage time off entitlements and business rules based on time off allocation.
   You must enter a unique employee ID number for each employee.
   
   NOTE: If the employee will use enterprise presence and chat integration and the employee’s email address differs from the employee’s OCS (SIP) email address, you must enter the OCS (SIP) email address in the email field.
5. Under Licensing, select the features and applications for which you want to decrement a licence.
   • The **Reporting only** option enables you to run reports on the employee but not monitor the employee in real-time.
   • The **Real-time and reporting** option enables you to run reports on the employee and monitor the employee in real-time, and decrements one employee license.
   • The **Contact Center Management ACD resiliency** check box ensures continuous real-time monitoring and reporting for the employee during failover.
   • The **Workforce Scheduling** check box enables you to schedule the employee.
   NOTE: You cannot license an employee if no licenses remain.
6. On the ribbon, click **Save**.

Configuring user account information (in YourSite Explorer)
To configure user account information for an employee
1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Select an employee from the list.
4. On the **User account** tab, under **User account**, specify login credentials for the employee and select the site to which the employee is associated.
5. Under **Security**, select a security role for the employee.
   The default security role permits users full access to all applications and devices.
6. Under **Report distribution**, specify the path of the network printer and select print and email options. You must configure the network printer as the default printer on the Enterprise Server. The printer path name is case sensitive.
7. On the ribbon, click **Save**.

**Associating employees with agent IDs, extensions, and Account Codes (in YourSite Explorer)**

To associate the employee with an agent login ID, extension, and Account Code

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Select an employee from the list.
4. On the **Create associated devices** tab
   - Click the **Agent login** tab and select the check boxes of the media servers to which the employee will log in. This creates an agent login ID based on the employee ID for each media server you select, which is recommended.
   - Click the **Extension** tab and select the **Create an extension number for the employee** check box, select a media server and failover media server for the extension, and, if the extension will be costed with Call Accounting, select the **Cost this extension** check box.
   - Click the **Account Code** tab and select the **Create an Account Code for the employee** check box.
5. On the ribbon, click **Save**.

**Configuring multimedia user settings (in YourSite Explorer)**

To configure Multimedia Contact Center user settings

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Select an employee from the list.
4. On the **Multimedia Contact Center** tab, select the **This employee will be a Multimedia Contact Center agent** check box and type the employee’s Exchange public folder name.
5. On the ribbon, click **Save**.

**Configuring employee personal information (in YourSite Explorer)**

To configure employee personal information

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Select an employee from the list.
4. On the **Details** tab, specify contact, hire, and emergency information for the employee.
5. On the ribbon, click **Save**.

**Configuring general information and licensing information (in the Contact Center Management website)**

To configure general information and licensing information for an employee

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Employee=>Employee**.
3. Click **Add**.
4. On the **Add an employee** tab, specify identification information for the employee.
   **NOTE:** You must enter a unique employee ID number for the employee.
5. After **Employee ID**, type an identification number for the employee (for example, 100).
6. If you will track and run reports on the employee, select the **The employee will be tracked in real-time and reporting** check box.

7. If the employee is a supervisor, select the **The employee is a supervisor** check box.

8. If the employee is resilient, select the **This employee is resilient and will be tracked in real time and reporting** check box.

   **NOTE:** If the number of employees in the YourSite database exceeds the number for which you are licensed, you will not be able to select this check box.

9. After **Email address**, type the employee’s email address.

   Reporting Service uses this email address to send and receive reports.

10. After **Active from**, select the date the employee ID was created.

11. After **Nickname**, type the employee’s nickname.

12. Click **Save**.

### Configuring user account information (in the Contact Center Management website)

To configure user account information for an employee

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Employee=>Employee**.
3. Select an employee from the list.
4. On the **User account** tab, select the **This employee will use these credentials to log on to applications** check box, and specify security and report distribution information.
5. Click **Save**.

   **NOTE:** If you are upgrading a Contact Center Management (voice) employee to a Multimedia Contact Center (voice, email, chat and/or fax) employee, you must assign a public folder to the employee prior to assigning him an agent login ID. To do so, click **Configuration=> Employee=>Employee=>Edit** and update the Multimedia Contact Center properties for the employee.

### Associating employees with agent IDs, extensions, and Account Codes (in the Contact Center Management website)

To associate the employee with an agent login ID, extension, and Account Code

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Employee=>Employee**.
3. Select an employee from the list.
4. On the **Create associated devices** tab, under **Agent login**, select the check boxes of the media servers to which the employee will log in.

   This creates an agent login ID based on the employee ID for each media server you select, which is recommended.
5. On the **Extension** tab, select the **Create an extension reporting number for each employee ID** check box and select a media server and failover media server for the extension.
6. If the extension will be costed with Call Accounting, select the **Cost this extension** check box.
7. On the **Account Code** tab, select the **Create Account Code for employee** check box.
8. On the ribbon, click **Save**.

### Configuring multimedia user settings (in the Contact Center Management website)

To configure Multimedia Contact Center user settings

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Employee=>Employee**.
3. Select an employee from the list.
4. On the **Multimedia Contact Center user** tab, select the **The employee will be a Multimedia Contact Center agent** check box and specify the employee’s Exchange public folder name.
5. Click **Save**.
Adding resilient and/or Network ACD hot desking agents

After adding employees, you add employee groups and associate employees to these groups.

If you have an SX-200 or SX-2000 telephone system, you must add employee groups in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add employee groups in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add employee groups in YourSite Explorer.

Adding employee groups (in YourSite Explorer)

To add an employee group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee groups.
3. Click Add.
5. On the ribbon, click Save.

Associating employees with employee groups (in YourSite Explorer)

To associate an employee with an employee group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee groups.
3. Select an employee group from the list.
4. On the Membership tab, under Available members, select an employee and click > to move the employee to the Selected members list.
5. On the ribbon, click Save.

Adding employee groups (in the Contact Center Management website)

To add an employee group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Employee=>Employee group.
3. Click Add.
4. Specify employee group identification information.
5. If you want all employees to be added to this employee group, select the Automatically add all employees to this employee group check box.
6. Click Save.

Associating employees with employee groups (in the Contact Center Management website)

To associate an employee with an employee group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Employee=>Employee group.
3. Across from the employee group to which you want to associate employees, click Members.
4. Under Available employees, select the check boxes of the members to be added to the group and click Add selected>>.
5. Click Save.
Adding employee divisions

A division is composed of several employee groups. The Division tab shows the employee groups that belong to the division currently selected. When you create employee divisions in YourSite, you can run reports for several employee groups simultaneously.

If you have a 3300 ICP, 5000, or Axxess, you add employee divisions and associate employee groups to these divisions in YourSite Explorer.

To add an employee division
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee Divisions.
3. Click Add.
4. Type a Name and Reporting number for the employee division.
5. On the ribbon, click Save.

To associate an employee group with an employee division
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee Divisions.
3. Select an employee division from the list.
4. On the Membership tab, under Available members, select an employee group and click > to move the employee group to the Selected members list.
5. On the ribbon, click Save.

Adding agents

You must add agent login IDs to the YourSite database for employees you want to track in real time and reporting. An employee can have more than one agent login ID but only one employee ID. You assign multiple agent login IDs to employees who are cross-trained to handle calls for different departments (different queues). For example, Carol Jones handles calls for English, French, and Spanish queues. In the YourSite database, you assign Carol three agent login IDs, one for each queue that she handles.

We recommend you browse to the employee window and create agent login IDs based on employee IDs. See “Adding employees” on page 132.

When you designate an extension, agent, or queue as historical reporting only reports can be created for that device but they cannot be monitored in real time. The following issues should be considered when designating devices for historical reporting only.

Retiring an Agent
If you want to retire and reuse an agent ID, for example, when an employee leaves the company or is no longer an agent, the following applies: If a retiring agent's ID (Agent A) is issued to a new agent (Agent B) and a report is run for the period when Agent A was an active employee, Agent B’s name will display in the report but the statistics will be those of Agent A.

Deleting an Agent
If you delete an agent you will not be able to select this agent in the Contact Center Management website in order to run reports for them. Furthermore, if you summarize historical data, the data for the deleted agent will be purged from the database.

Instead of deleting an agent, designate the agent as historical reporting only. Their statistics will not be deleted from the database and you will be able to continue to run historical reports for them.

NOTE: Summarizing historical data removes it from the database. If, after summarizing, you need to access this historical data, you can re-designate the agent and their associated devices (employee and extension) as licensed for real time and reporting and re-summarize the data.
To reduce the amount of unnecessary real-time monitoring in Contact Center Management and Call Accounting, advanced real-time monitoring that provides a variety of features and functionality is disabled by default for extensions and can optionally be disabled for agents and queues. A new option in YourSite Explorer called Advanced real time and reporting (previously called Real time and reporting) can be set on extensions, agents, and queues to enable devices to be used with the following applications and features:

- Busy Lamp Field (BLF)
- Interactive Visual Queue queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information
- Interactive Contact Center work timer functionality
- Call recording start and stop controls
- Lifecycle reports
- CTI Developer Toolkit functionality
- Professional Services custom screen pop displays

The Real time and reporting option now provides real-time information only, such as ACD states and statistics and presence. Enterprises with a large number of agents and queues may optionally turn off Advanced real time and reporting to alleviate bandwidth congestion and to increase system performance. Turning off Advanced real time and reporting will have the following impact:

- BLF will not display
- Interactive Visual Queue will not display queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information will not populate in Interactive Visual Queue, Contact Center PhoneSet Manager, Contact Center Softphone, and screen pop displays
- Interactive Contact Center will not be able to cancel work timer
- Call recording integration will not be able to start and stop recordings
- Lifecycle reports will not display IVR entry, IVR exit, in queue, call end, call recording, and call note statistics
- Any of the following functionality that is exposed using the CTI Developer Toolkit library will be similarly affected, for example, the ability to receive call event notifications or cancel work timer
- Any professional services custom applications will not populate screen pop displays properly

We recommend you contact your Channel Partner before changing the default settings and enabling advanced real time and reporting for extensions, agents, and queues or disabling advanced real time reporting for agents and queues.

**NOTE:** Agents are programmed in YourSite Explorer. If agents are in a clustered environment but not hot desking and not resilient, the agent names will not appear on the telephone switch. You must enter these agent names outside of Contact Center Management.

In order to provide Contact Center Work Timer functionality in Contact Center Client, every traditional agent’s extension or every hot desking Agent ID must be enabled with a MiTAI monitor and be set to Advanced real time and reporting in YourSite Explorer.

If your agents handle calls for multiple voice queues, you can add additional agent login IDs. For the SX-200 and SX-2000, you do so in YourSite=>Configuration=>Employee=>Employee=>View agent logins. For the 3300 ICP, 5000, and Axxess, you do so in YourSite Explorer.

To add an agent:

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under Devices, click **Agents**.
3. Click **Add**.
4. After **Employee**, if you want to associate the agent to an employee, click ... and select an employee.
5. After **First name** and **Last name**, type the agent’s name.
6. After **Agent login ID**, type the agent login ID.
7. After Media Server, click ... and select the media server the agent will use.
8. Under Reporting and real-time options, select
   • Historical reporting only if you want to run reports on the agent without real-time monitoring.
   • Real time and reporting if you want to run reports on the agent and monitor the agent with basic real-time functionality, such as ACD states and statistics and presence.
   • Advanced real time and reporting if you want to run reports on the agent and monitor the agent with advanced real-time functionality, such as BLF and Collected Digits.
9. On the ribbon, click Save.

Specifying 3300 ICP options for agents
You can specify Class of Service, Class of Restriction, and failover media server options for agents in YourSite Explorer.

To specify 3300 ICP options for an agent
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Agents.
3. Select an agent from the list.
4. Under 3300 ICP Options, after COS, select a Class of Service from the list.
5. After COR, select a Class of Restriction from the list.
6. After Failover media server, click ... and select a failover media server from the list.
7. On the ribbon, click Save.

Adding additional agent login IDs
To add additional agent login IDs
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employees.
3. Select an employee from the list.
4. Click the Agent logins tab.
5. Select an employee from the Available members list and click > to move the employee to the Selected Members list.
6. On the ribbon, click Save.

Adding agent groups
You must add agent groups to the YourSite database and associate agent login IDs to the agent groups so you can run reports on agent group activities and view agent group activities in real time.

You can associate an agent login ID to more than one agent group. See “Determining your contact center configuration needs” on page 108.

NOTE:
• If you attempt to add a group to YourSite that is already in the database the system notifies you that the group is already present. When you add a series of groups to YourSite, such as Extension Groups 1 to 5, if the system detects you have already added Extension Group 3, then it will not add Extension Group 3 or any subsequent extensions in the series (that is, Extension Group 4 or 5) to the database.
• An agent group must be composed of agents who handle contacts for the same media server type. A group of agents of mixed media types would produce a report that compares voice agents to email agents to chat agents. The comparison would not be valid. You want to compare apples to apples (emails to emails) not apples to oranges (emails to chats).
If you have an SX-200 or SX-2000 telephone system, you must add agent groups in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add agent groups in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add agent groups in YourSite Explorer.

**Adding agent groups (in YourSite Explorer)**

To add an agent group

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Agent groups**.
3. Click **Add**.
4. Configure agent group identification information, and select the media server for the agent group.
5. Under **Reporting and real-time options**, select
   - **Historical reporting only** if you want to run reports on an agent group without real time monitoring.
   - **Real time and reporting** if you want to run reports on an agent group and monitor it with basic real time functionality, such as ACD states and statistics and presence.
6. On the ribbon, click **Save**.

**Associating agents with agent groups (in YourSite Explorer)**

To associate an agent with an agent group

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Agent groups**.
3. Select an agent group from the list.
4. On the **Membership** tab, under **Available members**, select an agent and click > to move the agent to the **Selected members** list.
5. On the ribbon, click **Save**.

**Specifying 3300 ICP options for agent groups (in YourSite Explorer)**

To specify 3300 ICP options for an agent group

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Agent groups**.
3. Select an agent group from the list.
4. On the **3300 ICP options** tab, click ... and select a failover media server.
5. Specify if the agent group uses skills and if calls are to be queued to the agent group when no agents are logged in.
6. On the ribbon, click **Save**.

**Adding agent groups (in the Contact Center Management website)**

To add an agent group

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Agent login=>Agent group**.
3. Click **Add**.
4. Specify agent group identification information and select the media server and failover media server for the agent group.
5. If you want all agents associated with the media server for the agent group to belong to the agent group, select the **Automatically add all agents associated with this media server to this agent group** check box.
6. Click **Save**.
Associating agents with agent groups (in the Contact Center Management website)

To associate an agent with an agent group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Agent login=>Agent group.
3. Across from the agent group to which you want to associate agents, click Members.
The Edit agent group members window appears.
4. Under Available agent login IDs, select the check boxes of the members to be added to the group and click Add selected>>.
5. Click Save.

Adding teams

After adding agent groups, you can add teams and associate agent groups to these teams.

If you have an SX-200 or SX-2000 telephone system, you must add teams in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add teams in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add teams in YourSite Explorer.

Adding teams (in YourSite Explorer)

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Teams.
3. Click Add.
4. Type a Name and Reporting number for the team.
5. On the ribbon, click Save.

Associating agent groups to teams (in YourSite Explorer)

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Teams.
3. Select a team from the list.
4. On the Membership tab, under Available members, select an agent group and click > to move the agent group to the Selected members list.
5. On the ribbon, click Save.

Adding teams (in the Contact Center Management website)

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Team.
3. Click Add.
4. Type a Name and Reporting number for the team.
5. If you want to add all agent groups to the team, select Automatically add all agent groups to this team.
6. Click Save.

Associating agent groups to teams (in the Contact Center Management website)

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Team.
3. Across from the team to which you want to associate agent groups, click Members.
The Edit team members window appears.
4. Under Available agent groups, select the check boxes of the members you want to add to the team and click Add selected >>.
5. Click Save.
Adding queues

You must add queues to the YourSite database so you can run reports on queue activities and view queue performance in real time. When you add a queue to the YourSite database, the configuration options available depend upon the media server you select. Media servers fall under five general categories: voice (a telephone system with or without MiTAI enabled), Intelligent Queue, email, SMS, chat, and fax.

When you designate a queue as historical reporting only, reports can be created for the queue but it cannot be monitored in real time. The following issues should be considered when designating devices for historical reporting only.

Deleting queues

If a queue is deleted, it is no longer a selectable device in the Contact Center Management website. If you want to be able to run historical reports, deleting queues is not recommended. Instead of deleting queues, designate them as historical reporting only but remember that if a historical summarization is performed this queue’s data will be removed from the database.

NOTE: Summarizing historical data removes it from the database. If, after summarizing, you need to access this historical data, you can re-designate the queue as licensed for real time and reporting and re-summarize the data.

To reduce the amount of unnecessary real-time monitoring in Contact Center Management and Call Accounting, advanced real-time monitoring that provides a variety of features and functionality is disabled by default for extensions and can optionally be disabled for agents and queues. A new option in YourSite Explorer called Advanced real time and reporting (previously called Real time and reporting) can be set on extensions, agents, and queues to enable devices to be used with the following applications and features:

- Busy Lamp Field (BLF)
- Interactive Visual Queue queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information
- Interactive Contact Center work timer functionality
- Call recording start and stop controls
- Lifecycle reports
- CTI Developer Toolkit functionality
- Professional Services custom screen pop displays

The Real time and reporting option now provides real-time information only, such as ACD states and statistics and presence. Enterprises with a large number of agents and queues may optionally turn off Advanced real time and reporting to alleviate bandwidth congestion and to increase system performance. Turning off Advanced real time and reporting will have the following impact:

- BLF will not display
- Interactive Visual Queue will not display queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information will not populate in Interactive Visual Queue, Contact Center PhoneSet Manager, Contact Center Softphone, and screen pop displays
- Interactive Contact Center will not be able to cancel work timer
- Call recording integration will not be able to start and stop recordings
- Lifecycle reports will not display IVR entry, IVR exit, in queue, call end, call recording, and call note statistics
- Any of the following functionality that is exposed using the CTI Developer Toolkit library will be similarly affected, for example, the ability to receive call event notifications or cancel work timer
- Any professional services custom applications will not populate screen pop displays properly
When you add a queue to the YourSite database, you associate the queue with the agent groups that handle calls for the queue. You do this so you know which agent groups handle which queues. You must associate at least one agent group with a queue in order to produce reports on the queue. When configuring queues, you can optionally configure work timer options, such as extending the telephone system work timer beyond the ten minute maximum, or forcing agents to enter call classification codes before they handle other requests. If you select the Force entry of a classification code check box, agents will receive a pop-up in their Contact Center Client forcing them to enter a call classification code before they can answer more calls.

NOTE: When a queue is added in Contact Center Management and synchronized with the telephone system, real-time events are turned on by default.

If you have an SX-200 or SX-2000 telephone system, you must add queues in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add queues in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add queues in YourSite Explorer.

**Configuring general information for queues (in Your Site Explorer)**

To configure general information for a queue

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Queues**.
3. Click **Add**.
4. Specify queue identification information.
   The queue reporting number for a phone queue must be the same as the path reporting number on the telephone system assignment forms (for example, if the reporting number is 20, then you type P0020 for the SX-200 Real-time, or P020 for the SX-2000).
   **NOTE:** To ensure accurate reporting, queue reporting numbers must be unique across both active and inactive queues.
5. Click ... and select the media server for the queue.
6. Under **Queue service objective**, specify the **Service Level goal** and the **Service Level time**.
7. If the queue is a voice or chat queue, after **Short Handle less than**, type the duration for the call talk parameter.
   If the talk time is less than the call talk parameter, then the call is a short talk call (for example, type 3 to define a short talk call as a call the agent makes that lasts less than 3 seconds). Short talk calls are included in call statistics.
8. After **Short Abandon less than**, type the duration for the call abandon parameter.
   If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).
9. Under **Reporting and real-time options**, select
   - **Historical reporting only** if you want to run reports on a queue without real time monitoring.
   - **Real time and reporting** if you want to run reports on a queue and monitor it with basic real time functionality, such as ACD states and statistics and presence.
   - **Advanced real time and reporting** if you want to run reports on a queue and monitor it with advanced real time functionality, including BLF and Collected Digits.
10. If the queue is a voice queue, after **Dialable number**, type the path directory number listed on the telephone system assignment forms.
11. If you want to extend the telephone system work timer beyond the ten minute maximum, under **Work timer options**, select the **Use work timer** check box and specify the duration.
    **NOTE:** In order to extend work timer beyond the ten minute maximum, the telephone system must have a ten second work timer set on the queue.
12. To force agents to enter call classification Account Codes, select the **Force entry of a classification code** check box.
    This feature is hidden unless you are licensed for Contact Center PhoneSet Manager.
13. To automatically cancel contact center work timer, select the **Cancel work timer once code is entered** check box.

14. If you want to add contact center work timer time to handling time, select the **Include work timer as part of handling time** check box.

15. On the ribbon, click **Save**.

**Associating agent groups with queues (in YourSite Explorer)**

To associate an agent group with a queue

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under Devices, click **Queues**.
3. Select a queue from the list.
4. On the **Membership** tab, under **Available members**, select an agent group and click > to move the agent group to the **Selected members** list.
5. On the ribbon, click **Save**.

**Specifying 3300 ICP options for queues (in YourSite Explorer)**

On the 3300 ICP options tab, you can specify queue priority and the method a queue uses for handling interflowed calls in Interactive Visual Queue.

To specify 3300 ICP options for a queue

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Queues**.
3. Select a queue from the list.
4. On the **3300 ICP options** tab, under **General**, specify the priority level of the queue and the queue unavailable answer point directory number.
   - The highest priority level is 1. The lowest priority level is 64.
5. Under **Interflow options**, specify interflow options for the queue.
   - You select Interflow to this queue uses this queue’s priority if you want interflowed calls to use the queue’s priority. Otherwise, interflowed calls will retain the priority levels of their originating queues.
6. On the ribbon, click **Save**.

**Configuring general information for queues (in the Contact Center Management website)**

To configure general information for a queue

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Click **Add**.
4. On the **Queue** tab, specify queue identification information and select the media server for the queue.
   - The queue reporting number for a phone queue must be the same as the path reporting number on the telephone system assignment forms (for example, if the reporting number is 20, then you type P0020 for the SX-200 Real-time, or P020 for the SX-2000).
5. If the queue is a voice queue, after **Dialable number**, type the path directory number listed on the telephone system assignment forms.
6. After **Queue service objective**, type your queue service level goal.
7. If the queue is a voice or chat queue, after **Short Abandon**, type the duration for the call abandon parameter.
   - If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).
8. After **Short Handle**, type the duration for the call talk parameter.
   - If the talk time is less than the call talk parameter, then the call is a short talk call (for example, type 3 to define a short talk call as a call the agent makes that lasts less than 3 seconds). Short talk calls are included in call statistics.
9. On the **Queue spectrum** tab, configure queue spectrum settings.
10. Click **Save**.
Associating agent groups with queues (in the Contact Center Management website)

To associate an agent group with a queue

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from the queue to which you want to associate agent groups, click **Members**.
   The Edit queue members window appears.
4. Under **Available agent groups**, select the check boxes of the members you want to add to the queue and click Add >>.
5. Click **Save**.

Configuring business hours for queues (in the Contact Center Management website)

If you want to apply business hours to queues, you do so in the Contact Center Management website.

To configure business hours for a queue

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from the queue for which you want to configure business hours, click **Edit**.
4. On the **Business hours** tab of the queue, select a business-hour schedule.
   See “Applying schedules” on page 172.
   For voice queues, the schedule specifies when real-time data should not be filed to the SQL database.
   For chat and email queues, the business-hours schedule specifies the time of day customers receive the business-hours auto-acknowledgment message.
5. If you must create or modify a schedule for the queue, click **Manage schedule** and configure a schedule.
   See “Applying schedules” on page 172.
   For voice queues, the schedule specifies when real-time data should not be filed to the SQL database.
   For chat and email queues, the business-hours schedule specifies the time of day customers receive the business-hours auto-acknowledgment message.
6. If you want to apply this schedule to all of the queues with the same media server, select the **Apply this business-hour schedule to all queues associated with this media server** check box.
7. If the queue is a voice queue and you want to exclude statistics generated for calls received or dialed outside of business hours, select the **Generate real-time statistics and reports only within the business hours selected** check box.
   Enabling this option prevents data from being filed to the SQL database outside of business hours.
8. If you are configuring a voice queue using Interactive Visual Queue, click the **Interactive Visual Queue** tab and specify the queue priority settings.
9. If the queue is a voice queue using a media server with MiTAI, click the **Interactive Contact Center queue control** tab and specify the queue control plan.
   See “Configuring Interactive Contact Center Queue control” on page 145.
10. If the queue is a voice queue, click **Save**. Otherwise continue with step 11.
11. If the queue is an email queue, specify Multimedia Contact Center Email options.
    See “Configuring Multimedia Contact Center Email routing options” on page 148.
12. If the queue is a chat queue, specify Multimedia Contact Center Chat routing options.
    See “Configuring Multimedia Contact Center Chat routing options” on page 148.
13. If the queue is a fax queue, specify Multimedia Contact Center Fax options.
    See “Configuring Multimedia Contact Center Fax options” on page 148.
14. Click **Save**.
Configuring Interactive Contact Center Queue control

**NOTE:**
- You must install Interactive Contact Center before you can use Interactive Contact Center Queue control. It is available to queues associated with 3300 ICP and 5000/Axxess media servers only.
- Before you can use Interactive Contact Center Queue control, you must save the queue.

Using queue control plans, you can place queues in and remove queues from Do Not Disturb automatically based on predefined criteria. Each queue control plan monitors one queue, and based on the activity of the queue, either places a queue in, or removes a queue from Do Not Disturb.

**NOTE:** 5000/Axxess queues cannot be placed in Do Not Disturb and can only redirect calls to an alternate answering point.

Queue control plans open and close queues based on plan parameters only during business hours. Each queue is controlled by only one queue control plan at a time. You can apply the same queue control plan to several queues.

Interactive Contact Center Queue control is configured in the Contact Center Management website.

To configure Interactive Contact Center Queue control
1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from the queue for which you want to configure Interactive Contact Center Queue control, click **Edit**.
4. On the the **Interactive Contact Center queue control** tab of the queue, select the **This queue uses Interactive Contact Center queue control** check box.
5. After **Interactive Contact Center queue control schedule**, select the business hours schedule for the queue.
6. If you must create or modify a schedule for the queue, click **Manage schedule and configure a schedule.**
   See “Applying schedules” on page 172.
7. After **Interactive Contact Center queue control plan**, select the queue control plan for the queue.
8. If you must create or modify a control plan for the queue, click **Manage queue control plan and configure a plan.**
   See “Managing a queue control plan (3300 ICP)” on page 145.
9. Click **Save**.

Managing a queue control plan (3300 ICP)

To manage a queue control plan
1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from the queue for which you want to manage a queue control plan, click **Edit**.
4. On the **Interactive Contact Center queue control** tab of the queue, click **Manage queue control plan.**
   See Figure 6-9.
5. After **Name**, type the name of the plan.
6. After **Monitor**, select the **current queue** or an alternate queue. An alternate queue is available only when you have more than one queue programmed in YourSite Explorer. The queues are displayed in the following format: site - media server - queue reporting number - queue name.
7. Select the queue or device that you want to place in, or remove from Do Not Disturb. You can control the current queue, an alternate queue (on the same media server), or a directory number. The current queue is always the queue to which the plan is applied. If you do not monitor the current queue, then the current queue must be affected. The directory number is the dialable number of a queue or extension. The directory number can be between 1 and 7 digits, inclusive. If you monitor the current queue you can affect an alternate queue. For example, you can affect another voice queue in your contact center.
8. After **Place the device in DND when the following conditions are true for**, type the duration, in seconds, that you want a condition to be true before the queue or device enters Do Not Disturb.
9. After **Remove the device from DND when the following conditions are false for**, type the duration, in seconds, that you want a condition to be false before the queue or device is removed from Do Not Disturb.
10. After **Enabled**, select the check boxes of the variables to be included in the plan.
11. After **Variable type**, if you select **Calls Waiting**, select a symbol or combination of symbols (>=, <, =, >, <=) and type the relevant number of calls after which you want the queue plan to take action. For example, if you select = 5, then the queue control plan will take action only when there are 5 calls waiting in queue.
12. After **Variable type**, if you select **Longest Waiting**, select a symbol or combination of symbols (\(\geq\), \(<\), \(=\), \(>\), \(\leq\)) and type the duration (hh:mm:ss) after which you want the queue plan to take action. For example, if you select \(> 00:05:00\), then the queue control plan will take action only after the longest call waiting in queue has been waiting for more than five minutes.

13. After **Variable type**, if you select **Call Load**, select a symbol or combination of symbols (\(\geq\), \(<\), \(=\), \(>\), \(\leq\)) and type the duration (hh:mm:ss) after which you want the queue plan to take action. For example, if you select \(\geq 10\), then the queue control plan will take action only when the call load is at 10 calls, or more, per agent.

14. Click **Save**.

**Managing a queue control plan (5000/Axxess)**

To manage a queue control plan

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from the queue for which you want to manage a queue control plan, click **Edit**.
4. On the **Interactive Contact Center queue control** tab of the queue, click **Manage queue control plan**.
5. After **Name**, type the name of the plan.
6. After **Monitor**, select the current queue or an alternate queue. An alternate queue is available only when you have more than one queue programmed in YourSite Explorer. The queues are displayed in the following format: site - media server - queue reporting number - queue name.
7. Select the queue or device that you want to redirect calls to. You can control the current queue, an alternate queue (on the same media server), or a directory number. The current queue is always the queue to which the plan is applied. If you do not monitor the current queue, then the current queue must be affected. The directory number is the dialable number of a queue or extension. The directory number can be between 1 and 7 digits, inclusive. If you monitor the current queue you can affect an alternate queue. For example, you can affect another voice queue in your contact center.
8. After **Redirect the device when the following conditions are true for**, type the duration, in seconds, that you want a condition to be true before the queue or device is redirected.
9. After **Remove the device from redirection when the following conditions are false for**, type the duration, in seconds, that you want a condition to be false before the queue or device is redirected.
10. After **Enabled**, select the check boxes of the variables to be included in the plan.
11. After **Variable type**, if you select **Calls Waiting**, select a symbol or combination of symbols (\(\geq\), \(<\), \(=\), \(>\), \(\leq\)) and type the relevant number of calls after which you want the queue plan to take action. For example, if you select = 5, then the queue control plan will take action only when there are 5 calls waiting in queue.
12. After **Variable type**, if you select **Longest Waiting**, select a symbol or combination of symbols (\(\geq\), \(<\), \(=\), \(>\), \(\leq\)) and type the duration (hh:mm:ss) after which you want the queue plan to take action. For example, if you select > 00:05:00, then the queue control plan will take action only after the longest call waiting in queue has been waiting for more than five minutes.
13. After **Variable type**, if you select **Call Load**, select a symbol or combination of symbols (\(\geq\), \(<\), \(=\), \(>\), \(\leq\)) and type the duration (hh:mm:ss) after which you want the queue plan to take action. For example, if you select >= 10, then the queue control plan will take action only when the call load is at 10 calls, or more, per agent.
14. Click **Save**.
Configuring reporting intervals (SX-200 and SX-2000)

Configuring reporting intervals is done in the Contact Center Management website.

To configure the reporting intervals for the abandon, answer, interflow, and handle statistics for the queue
1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from the queue for which you want to configure reporting intervals, click Edit.
4. On the Queue spectrum tab, edit the spectrum time intervals.
   When you run spectrum reports the statistics will be spread across the time intervals selected.
5. Optionally select the Apply spectrums to all queues associated with this media server check box.
6. On the Business hours tab, specify the business hours for the queue.
7. Click Save.

Configuring Multimedia Contact Center Email options

You can optionally configure email queues to handle SMS media. Configuring Multimedia Contact Center Email options is done in the Contact Center Management website.

To configure email options
1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from an email queue, click Edit.
4. Click the Multimedia Contact Center Email options tab.
5. After Public email address, type the email or Web address customers use to contact your company.
   NOTE:
   • The Queue public folder name is permanent.
   • Exchange will attempt to assign an email address (<QueueName>@yourdomain.com) to the queue public folder. However, if that email address already exists, it might assign an email address named <QueueName>2@yourdomain.com. To correct this, you must use Active Directory Users and Computers and/or Exchange System Manager to swap the email address of the conflicting mail-enabled items. To do this, you modify the properties on the email address tab for the appropriate User, Distribution List, or Public Folder.
6. After Queue public folder name, type the name associated with the public email address.
   The queue public folder name is the name used to describe the alias email for the queue. For example, if the alias is Support@yourcompany.com, then the public folder name could be Support. The Queue Public Folder Name appears in the Outlook public folder list as CyberAED/Queues/ <QueueName>.
7. Click Save.

Configuring Multimedia Contact Center Email routing options

You can configure Multimedia Contact Center queues to handle email or short messaging service (SMS) messages. As a best practice, we recommend you configure each multimedia queue to handle one contact type only.

In order to handle SMS contacts, you must configure a Multi-Tech SMSFinder modem on the Multimedia Contact Center server. Each SMS queue requires a modem and you can install as many modems as you have queues.
Configuring Multimedia Contact Center Email routing options is done in the Contact Center Management website.

To configure email routing options

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from an email queue, click Edit.
4. Click the Multimedia Contact Center Email/SMS routing options tab.
5. After Priority of this queue in relation to all other queues associated with this media server, type a priority value between 1 and 10 inclusive. The priority value is assigned to the queue. The value 1 has the highest priority.
6. After Agent requeue time, type the time in minutes that an email will ring in the assigned agent’s inbox before it is put back into the same queue and offered to the next available agent.
7. After Duration an email is on hold before the agent requeue timer begins, type the time in minutes that an email can be on hold in the assigned agent’s inbox before a warning flashes to indicate that the requeue timer will start. You specify the length of time the requeue timer runs in the Agent requeue time field.
8. After Interflow Time, type the time in minutes an email can wait in the original queue before it is sent to another queue (the interflow queue).
9. If you want to direct queue-delayed emails to an alternate queue, click Internally interflow contacts to this email queue and select the queue to which you will interflow the emails. The email will be interflowed to this queue after it has waited in the original queue for a set period of time (the interflow time).
10. If you want to direct queue-delayed emails to a specific email address, click Externally interflow contacts to this email address and type the address to which you will interflow the emails.
11. If this queue handles SMS messages, under SMS Options
    - After Phone Number, type the phone number of the SMS modem’s SIM card.
    - After SMSFinder Server, type the IP address of the SMS modem.
    - After User name, type the SMS modem user name.
    - After Password, type the SMS modem password.
    - After Remote Port, type the connection port number of the modem.
    **NOTE:** Entering the connection port number of the modem is not required but is strongly encouraged to avoid cycling through all occupied ports.
12. Click Save.

**Configuring Multimedia Contact Center WebChat routing options**

Configuring Multimedia Contact Center Webchat routing options is done in the Contact Center Management website.

To configure chat routing options

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from a chat queue, click Edit.
4. Click the Multimedia Contact Center WebChat Routing options tab.
5. After Priority of this queue in relation to all other queues associated with this media server, type a priority value between 1 and 10 inclusive. The priority value 1 has the highest priority.
6. After Number of chat sessions that can be simultaneously routed to each agent for this queue, enter a number between 1 and 10 inclusive.
7. After Requeue time, type the time (in seconds) that a chat message will ring in the assigned agent’s inbox before it is put back into the same queue and offered to the next available agent.
8. After Interflow time, type the time in minutes a chat message can wait in the original queue before it is sent to another queue (the interflow queue).

9. If you want to direct queue-delayed chat messages to an alternate queue, after Internally interflow contacts to this chat queue select the queue. The chat message will be interflowed to this queue after it has waited in the original queue for a set period of time (the interflow time you specified above).

10. After Queue public folder name, type the name associated with the public email address. The queue public folder name is the name used to describe the alias email for the queue. For example, if the alias is Support@yourcompany.com, then the public folder name could be Support. The Queue Public Folder Name appears in the Outlook public folder list as CyberAED/Queues/<QueueName>.

11. After Internal email address, type the email address the Multimedia Contact Center server uses to send chat requests to the chat public folder corresponding with the queue.

12. Click Save.

Configuring Multimedia Contact Center WebChat transcript options

Configuring Multimedia Contact Center Webchat transcript options is done in the Contact Center Management website.

To configure transcript options

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from a chat queue, click Edit.
4. Click the Multimedia Contact Center WebChat Transcript options tab.
5. If you want your customers to receive chat transcripts, select the Email a chat transcript to the customer after the chat session is complete check box.
6. After Transcript email address, type your company’s public email address.
7. Click the Multimedia Contact Center auto acknowledgement tab.
8. If you want to activate auto acknowledgement messages for this queue, select the Enable auto-acknowledgement messages for this queue check box.
9. Select auto acknowledgement messages to be used during business hours and outside business hours.
10. If you want to create or modify an auto acknowledgement message, click Manage, type a title and body text for the auto acknowledgement message, click Apply or Add (depending on whether you are creating a new message or modifying a previous message), and click Save.
11. Click Save.

Configuring Multimedia Contact Center Fax options

Configuring Multimedia Contact Center Fax options is done in the Contact Center Management website.

To configure fax options

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Queue=>Queue.
3. Across from a fax queue, click Edit.
4. Click the Multimedia Contact Center Fax options tab.
5. After Public email address, type the address of the public fax address.

NOTE:
- The queue public folder name is permanent.
- Exchange will attempt to assign an email address (<QueueName>@yourdomain.com) to the queue public folder. However, if that email address already exists, it might assign an email address named <QueueName>2@yourdomain.com. To correct this, you must use Active Directory Users and Computers and/or Exchange System Manager to swap the email address of the conflicting mail-enabled items. To do this, you modify the properties on the email address tab for the appropriate User, Distribution List, or Public Folder.
6. After **Queue public folder name**, type the name associated with the public email address. The queue public folder name is the name used to describe the alias email for the queue. For example, if the alias is Support@yourcompany.com, then the public folder name could be Support. The Queue Public Folder Name appears in the Outlook public folder list as CyberAED/Queues/<QueueName>.

7. After **Email address for email replies**, type the email address where you want email replies sent.

8. After **Email address for fax replies**, type the email address where you want fax replies sent.

9. After **GFI reply commands**, optionally type fax code for additional fax directives. For example, you might want to add a cover sheet to each fax sent out.

10. Click **Save**.

### Configuring Multimedia Contact Center Fax routing options

Configuring Multimedia Contact Center Fax routing options is done in the Contact Center Management website.

To configure fax routing options:

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the Configuration menu, click **Queue=>Queue**.
3. Across from a fax queue, click **Edit**.
4. Click the **Multimedia Contact Center Fax Routing options** tab.
5. After **Priority of this queue in relation to all other queues associated with this media server**, type a priority value between 1 and 10 inclusive. The priority value 1 has the highest priority.
6. Under **Requeue Options**, after **Agent requeue time**, type the minutes after which the fax contact requeues.
7. After **Duration a fax is on hold before the agent requeue timer starts**, type the minutes after which the fax contact enters the requeuing sequence.
8. Under **Interflow options**, after **Interflow Time**, type the minutes after which the fax contact is interflowed.
9. If you want the fax to interflow to a specific fax queue, select the **Internally interflow to this fax queue** check box, and select the interflow queue.
10. If you want the fax to interflow to a specific email address, select the **Externally interflow contacts to this email address** check box, and type the interflow email address.
11. Click **Save**.

### Adding queue groups

You must add queue groups to the YourSite database, and associate queues to the queue groups so you can run reports on queue group activities and view queue group activities in real time.

**NOTE:** When a queue is added in Contact Center Management and synchronized with the telephone system, real-time events are turned on by default.

If you have an SX-200 or SX-2000 telephone system, you must add queue groups in the Contact Center Management website using **YourSite=>Configuration**. If you have a 3300 ICP, we recommend you add queue groups in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add queue groups in YourSite Explorer.
Adding queue groups (in YourSite Explorer)

To add a queue group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Queue Groups.
3. Click Add.
4. Type a Name and a Reporting number for the queue group.
5. On the ribbon, click Save.

Associating queues with queue groups (in YourSite Explorer)

To associate a queue with a queue group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Queue Groups.
3. Select a queue group from the list.
4. On the Membership tab, under Available members, select a queue and click > to move the queue to the Selected members list.
5. On the ribbon, click Save.

Adding queue groups (in the Contact Center Management website)

To add a queue group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Queue=>Queue group.
3. Click Add.
4. Specify queue group identification information.
5. If you want to add all queues to this queue group, select the Automatically add all queues to this queue group check box.
6. Click Save.

Associating queues with queue groups (in the Contact Center Management website)

To associate a queue with a queue group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Queue=>Queue group.
3. Across from the queue group to which you want to associate queues, click Members. The Edit queue group members window appears.
4. Under Available queues, select the check boxes of the members to be added to the group and click Add selected >>.
5. Click Save.

Adding extensions

When you perform Synchronization, YourSite Explorer is configured to mirror the phone set extension numbers/base directory numbers (DNs) on the 3300 ICP. If you have traditional agents that can sit at multiple locations within your organization, hot desking agents, or general business hot desking extensions, we recommend you give these base extensions generic names based on the position of the physical DNs (for example, Base DN: Floor 2, Desk 1). We recommend only general business hot desking extensions assigned to specific hot desking users be given user-based names (for example, Hot desking extension: John, Smith). If you have traditional ACD agents who sit at the same desk each day, or traditional extension phone sets that belong to single users, we recommend that the base DNs be configured with the user’s names.
To reduce the amount of unnecessary real-time monitoring in Contact Center Management and Call Accounting, advanced real-time monitoring that provides a variety of features and functionality is disabled by default for extensions and can optionally be disabled for agents and queues. A new option in YourSite Explorer called Advanced real time and reporting (previously called Real time and reporting) can be set on extensions, agents, and queues to enable devices to be used with the following applications and features:

- Busy Lamp Field (BLF)
- Interactive Visual Queue queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information
- Interactive Contact Center work timer functionality
- Call recording start and stop controls
- Lifecycle reports
- CTI Developer Toolkit functionality
- Professional Services custom screen pop displays

The Real time and reporting option now provides real-time information only, such as ACD states and statistics and presence. Enterprises with a large number of agents and queues may optionally turn off Advanced real time and reporting to alleviate bandwidth congestion and to increase system performance. Turning off Advanced real time and reporting will have the following impact:

- BLF will not display
- Interactive Visual Queue will not display queue statistics
- DNIS name, agent ID, extension, Collected Caller Entered Digits, and Customer Collected Information will not populate in Interactive Visual Queue, Contact Center PhoneSet Manager, Contact Center Softphone, and screen pop displays
- Interactive Contact Center will not be able to cancel work timer
- Call recording integration will not be able to start and stop recordings
- Lifecycle reports will not display IVR entry, IVR exit, in queue, call end, call recording, and call note statistics
- Any of the following functionality that is exposed using the CTI Developer Toolkit library will be similarly affected, for example, the ability to receive call event notifications or cancel work timer
- Any professional services custom applications will not populate screen pop displays properly

In order to provide Contact Center Work Timer functionality in Contact Center Client, every traditional agent’s extension or every hot desking Agent ID must be enabled with a MiTAI monitor and be set to Advanced real time and reporting in YourSite Explorer.

If you have an SX-200 or SX-2000 telephone system, you must add extensions in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add extensions in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add extensions in YourSite Explorer.

**Adding extensions (in YourSite Explorer)**

To add an extension

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Extensions**.
3. Click **Add**.
4. Under **General**, specify extension identification information and click **...** to select the media server and failover media server for the extension.
5. If the extension is a general business hot desking extension, select the **Is general business hot desking** check box.

6. Under **Reporting and real-time options**, select
   - **Historical reporting only** if you want to run reports on an extension, queue, or agent without real time monitoring.
   - **Real time and reporting** if you want to run reports on an extension, queue, or agent and monitor it with basic real time functionality, such as ACD states and statistics and presence.
   - **Advanced real time and reporting** if you want to run reports on an extension and monitor it with advanced real time functionality, including BLF and Collected Digits.

**NOTE:** Contact Center Softphone and Contact Center PhoneSet Manager extensions must have Real-time and reporting enabled in YourSite Explorer. If they are programmed as Historical reporting only, the Dialable Numbers will not appear in the list of available soft phone extensions when you launch the soft phone.

7. If the extension will be costed with Call Accounting, under **Licensing**, select the **Cost this extension** check box.

8. On the ribbon, click **Save**.

### Adding extensions (in the Contact Center Management website)

**To add an extension**

1. In Contact Center Management, click **YourSite=>Configuration**.
2. On the configuration menu, click **Extension=>Extension**.
3. Click **Add**.
4. If you want to create an employee ID and associate it with the extension, select the **Create a new employee for this extension** check box.
   **NOTE:** Select this check box only if you have not already added employee IDs to the database. Some employees have multiple extension reporting numbers. Associating an employee with each of the employee’s extensions enables you to run an employee report and consolidate the data for all of the employee’s extensions.
5. Specify extension identification information and select a media server and failover media server for the extension.
6. After **Site**, select the site with which to filter the media server list.
7. Under **Advanced options** *(3300 ICP only)*,
   - If the extension is resilient, click **This extension is resilient**.
   - If the extension will be costed with Call Accounting and you are not licensed for Call Accounting resiliency, click **This extension is costed**.
   - If you are licensed for Call Accounting resiliency and the extension will be resilient and costed, click **This extension is resilient and costed**.
   - To apply the advanced option to all extensions associated with the media server, select the **Apply this setting to all extensions associated with this media server** check box.
8. Click **Save**.

### Adding extension groups

After adding extensions, you add extension groups and associate extensions with these groups.

If you have an SX-200 or SX-2000 telephone system, you must add extension groups in the Contact Center Management website using **YourSite=>Configuration**. If you have a 3300 ICP, we recommend you add extension groups in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add extension groups in YourSite Explorer.
Adding resilient and/or Network ACD hot desking agents

Adding extension groups (in YourSite Explorer)

To add an extension group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Extension groups.
3. Click Add.
4. Type a Name and a Reporting number for the extension group.
5. On the ribbon, click Save.

Associating extensions with extension groups (in YourSite Explorer)

To associate an extension with an extension group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Extension groups.
3. Select an Extension group from the list.
4. On the Membership tab, under Available members, select an extension and click > to move the extension to the Selected members list.
5. On the ribbon, click Save.

Adding extension groups (in the Contact Center Management website)

To add an extension group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Extension=>Extension group.
3. Click Add.
4. Type a Name and a Reporting number for the extension group.
5. If you want to add all voice extensions to this extension group, select Automatically add all voice extensions to this extension group.
6. On the ribbon, click Save.

Associating extensions with extension groups (in the Contact Center Management website)

To associate an extension with an extension group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Extension=>Extension group.
3. Across from the extension group to which you want to associate extensions, click Members. The Edit extension group members window appears.
4. Under Available extensions, select the check boxes of the members to be added to the group and click Add selected >.
5. Click Save.

Adding trunks

If you have an SX-200 or SX-2000 telephone system, you must add trunks in the Contact Center Management website using YourSite=>Configuration. If you have a 3300 ICP, we recommend you add trunks in YourSite Explorer. If you have a 5000 or Axxess telephone system, you must add trunks in YourSite Explorer.
NOTE: If you want to report on SMDR information for SIP trunks you must ensure your SMDR tag is numbered. Please see “SMDR reporting on SIP trunks” in Appendix A in the Contact Center Management Installation Guide.

Adding trunks (in YourSite Explorer)

To add a trunk
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunks.
3. Click Add.
4. Type a Name and a Reporting number for the trunk.
5. Click ... and select a Media server to associate with the trunk.
6. On the ribbon, click Save.

Adding trunks (in the Contact Center Management website)

To add a trunk
1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Trunk=>Trunk.
3. Click Add.
4. Type a Name and a Reporting number for the trunk.
5. Select a Site to associate with the trunk.
6. Select a Media server to associate with the trunk.
7. Click Save.

Adding trunk groups

You add trunk groups and then associate trunks with the trunk groups.

If you have a 3300 ICP, 5000, or Axxess, you add trunk groups in YourSite Explorer. If you have an SX-200 or SX-2000, you add trunk groups in the Contact Center Management website.

NOTE: If you have Traffic Analysis and/or Call Accounting and use the same trunk group numbers across multiple telephone systems, you must associate each trunk group with a media server.

Adding trunk groups (in YourSite Explorer)

To add a trunk group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunk groups.
3. Click Add.
4. Type a Name and a Reporting number for the trunk group.
5. Click ... and select a Media server to associate with the trunk group.
6. On the ribbon, click Save.

Associating trunks with trunk groups (in YourSite Explorer)

To associate a trunk with a trunk group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunk groups.
3. Select a trunk group from the list.
4. On the Membership tab, under Available members, select a trunk and click > to move the trunk to the Selected members list.
5. On the ribbon, click Save.
Adding resilient and/or Network ACD hot desking agents

Adding trunk groups (in the Contact Center Management website)
To add a trunk group
1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Trunk=>Trunk Group.
3. Click Add.
4. Type a Name and a Reporting number for the trunk group.
5. Select a Media server to associate with the trunk group.
6. If you want to add all trunks to this trunk group, select the Automatically add all trunks to this trunk group check box.
7. Click Save.

Associating trunks with trunk groups (in the Contact Center Management website)
To associate a trunk with a trunk group
1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Trunk=>Trunk group.
3. Across from the trunk group to which you want to associate trunks, click Members.
   The Edit trunk group members window appears.
4. Under Available trunks, select the check boxes of the members to be added to the trunk group and click Add selected >.
5. Click Save.

Adding DNIS
Dialed Number Identification Service (DNIS) is a feature of toll-free lines that identifies the telephone number the caller dials. This assists agents who handle calls for more than one business or product line. Each business or product line has its own toll-free number. When a caller dials a toll-free number, the telephone system forwards information to the agent allowing the agent to identify who the caller dialed. For example, a caller dials a toll-free number for a cruise line. The telephone system sends a script to the agent along with the call. The agent then knows to answer “Good morning. Thank you for calling Southern Cruises,” instead of the name of another cruise line serviced by the center.

Adding DNIS (in YourSite Explorer)
To add a DNIS
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS.
3. Click Add.
4. Specify DNIS identification information and click ... to select the media server for the DNIS.
5. After Short Abandon, type the duration for the call abandon parameter. If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).
6. After Service Level, type the Service Level time.
7. If you have Call Accounting, select a carrier plan, call type, and call rate.
8. On the ribbon, click Save.
Adding DNIS (in the Contact Center Management website)

To add a DNIS

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click DNIS=>DNIS.
3. Click Add.
4. Specify DNIS identification information and select the media server for the DNIS.
5. After Short Abandon, type the duration for the call abandon parameter. If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).
6. After Service Level, type the Service Level time.
7. Click Save.

Adding DNIS groups

After adding DNIS, you can create DNIS groups and then associate DNIS numbers for specific businesses or product lines to those groups.

Adding DNIS groups (in YourSite Explorer)

To add a DNIS group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS groups.
3. Click Add.
4. Type a Name and a Reporting number for the DNIS group.
5. On the ribbon, click Save.

Associating DNIS to DNIS groups (in YourSite Explorer)

To associate a DNIS with a DNIS group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS groups.
3. Select a DNIS group from the list.
4. On the Membership tab, under Available members, select a DNIS and click < to move the DNIS to the Selected members list.
5. On the ribbon, click Save.

Adding DNIS groups (in the Contact Center Management website)

To add a DNIS group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click DNIS=>DNIS Group.
3. Click Add.
4. Type a Name and a Reporting number for the DNIS group.
5. If you want to add all DNIS to this DNIS group, select the Automatically add all DNIS to this DNIS group check box.
6. Click Save.
Associating DNIS to DNIS groups (in the Contact Center Management website)

To associate a DNIS with a DNIS group

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click DNIS=>DNIS Group.
3. Across from the DNIS group to which you want to associate DNIS, click Members. The Edit DNIS group members window appears.
4. Under Available DNIS, select the check boxes of the members to be added to the DNIS group and click Add selected >>.
5. Click Save.

Adding Account Codes

Account Codes can be verified, non-verified, or forced.

- Verified and Non-Verified Account Codes
  Verified and Non-Verified Account Codes allow callers to complete a call without entering a code. These codes are used to categorize calls or portions of calls. You define Account Codes in the YourSite database to generate reports for specific departments, services, and companies. For example, an agent who receives calls for three catalog companies enters Account Code 01 for calls to company X, Account Code 02 for calls to company Y, and Account Code 03 for calls to company Z. When you configure the Account Codes, Contact Center Management generates reports on the number, origin, and handling of calls for each of the departments, services, or companies.

- Forced Account Codes
  Both Verified and Non-Verified Account Codes can be forced. With Forced Verified Account Codes, you must enter the Account Code as soon as the phone is off-hook. With Forced Non-Verified Account Codes, you must enter the Account Code after you dial the phone number.

  For example, you might have 03 programmed on the telephone system as the trunk access code for calling England. Before you make a call to England, you must preface the telephone number with the Account Code 03, otherwise the call will not go through. To report on these verified Account Codes, you define them in the YourSite database.

NOTE: If you will used forced account codes and have a Make Busy button programmed on your Mitel phone set, you must remove the Make Busy button, or forced account codes will not work with Interactive Contact Center and Contact Center PhoneSet Manager.

You can add Account Codes for individual departments, projects, and services and generate reports on them. Agents can tag incoming calls with Account Codes for various services. Agents who work for companies that use Call Accounting can use Account Codes to gain access to outside lines.

If you are adding Account Codes to be used by voice agents, you print a copy of your telephone system assignment forms to use as a guide for programming. If you are adding Account Codes to be used by email, SMS, chat, or fax agents, you enter Account Code reporting numbers of your choice.

You can label Account Codes as call classification codes. This option associates the entire handling time to calls of this Account Code type. This option is available for contact centers that have the 3300 ICP only.

If you have an SX-200 or SX-2000, you add Account Codes in Contact Center Management, YourSite=>Configuration.

If you have a 3300 ICP, 5000 or Axxess, you add Account Codes in YourSite Explorer.
Adding Account Codes (in YourSite Explorer)

To add an Account Code

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. Click Add.
4. Type a Name and Reporting number for the Account Code.
5. If the Account Code will be used as a call classification code, select the Use as Classification Code check box.
   NOTE: As a best practice, we recommend you name all call classification codes for easy identification or group call classification codes in Account Code groups.
6. On the ribbon, click Save.

Adding Account Codes (in the Contact Center Management website)

To add an Account Code

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Account Code.
3. Click Add.
4. Select the employee ID that is associated with this Account Code.
5. Type a Name and Reporting number for the Account Code.
6. Click Save.

Adding Account Code groups

You can create Account Code groups to group similar Account Codes or to differentiate traditional Account Codes and call classification codes. Agents can readily identify and select appropriate Account Codes using the soft phone or Interactive Contact Center and supervisors can report on Account Code groups.

To add an Account Code group

1. In YourSite Explorer, in the left pane, click YourSite.
3. Click Add.
4. Type a Name and Reporting number for the Account Code group.
5. On the ribbon, click Save.

Associating Account Codes with Account Code groups

To associate an Account Code with an Account Code group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Code groups.
3. Select an Account Code group from the list.
4. On the Membership tab, under Available members, select an Account Code and click > to move the Account Code to the Selected members list.
5. On the ribbon, click Save.

Adding ANI

You define area codes and corresponding regions on the ANI tab. The ANI window provides area codes used to produce reports on the number of telephone calls originating from various geographical regions.

To add an ANI number

1. In Contact Center Management, click YourSite=>Configuration=>ANI.
2. Click Add.
4. After Digits to follow, type the digits that follow the ANI number.
5. Click Save.
Adding Make Busy Reason Codes

Voice agents can place themselves in Make Busy using their phone sets, provided the Make Busy with Reason option is enabled on the telephone system. Using Interactive Contact Center, agents can place themselves in Make Busy with reason in Contact Center Client, and supervisors can place agents in Make Busy with reason in Contact Center Client. Agents enter Make Busy Reason Codes to indicate why they are placing themselves in Make Busy and not answering contacts.

If you have Interactive Contact Center or Multimedia Contact Center, you assign Make Busy Reason Codes the reporting numbers of your choice. Otherwise, you type Make Busy Reason Code reporting numbers listed on the telephone system assignment forms.

Adding Make Busy Reason Codes (in YourSite Explorer)

To add a Make Busy Reason Code

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Make Busy Reasons.
3. Click Add.
4. Type a Name and Reporting number for the Make Busy Reason Code.
5. On the ribbon, click Save.

Adding Make Busy Reason Codes (in the Contact Center Management website)

To add a Make Busy Reason Code

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Make Busy Reason Code.
3. Click Add.
4. Type a Name and Reporting number for the Make Busy Reason Code.
5. Click Save.

Adding Do Not Disturb Reason Codes

Interactive Contact Center, an optional application, enables supervisors who have a 3300 ICP, 5000, or Axxess telephone system to control the availability of agents and ACD queues. Likewise, agents can control their own availability, including placing themselves in or removing themselves from Do Not Disturb. There are many reasons why agents place themselves in Do Not Disturb. You assign these reasons in YourSite Explorer.

To add a Do Not Disturb Reason Code

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DND Reason Codes.
3. Click Add.
4. Type a Name and Reporting number for the Do Not Disturb Reason Code.
5. On the ribbon, click Save.

Adding phone numbers

The phone number device enables you to

- Add contacts.
- Edit location information that appears in reports.
When adding a phone number to the database, you select

- **Area/City code** when you are adding or updating the area code for a province/state/city
  For the phone number 613-599-0045, 613 is the area code.

- **City exchange** when you are adding a new exchange
  For the phone number 613-599-0045, 599 is the city exchange (Kanata).

- **Contact** when you are adding a phone number with contact information
  For the phone number 613-599-0045, 5990045 is the contact.

To add a phone number area/city code

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Phone numbers**.
3. Click **Add=>Add an area/city code**.
4. Select a country and type an area/city name and area code.
   An area can be a city, region, province, or state.
5. On the ribbon, click **Save**.

To add city exchange information

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Phone numbers**.
3. Click **Add=>Add a city exchange**.
4. After **Country**, select a country.
5. After **Area/City name**, select a city, region, province, or state (for example, Greater Toronto Area).
6. After **City name**, type the name of a city or suburb (for example, Thornhill).
7. After **City/Exchange**, type a city exchange number (for example, 231).
   For the phone number 416-231-5555, 231 is the city exchange.
8. On the ribbon, click **Save**.

To add phone number contact information

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Phone numbers**.
3. Click **Add=>Add a contact**.
4. After **Country**, select a country.
5. After **Area/City name**, select a city, region, province, or state (for example, Washington).
6. After **City name**, select a city or suburb (for example, Des Moines).
7. Type a contact name and number.
   This information appears in the Phone Number Accounting Trace and Phone Number Group Accounting Trace reports.
8. If you want to hide the contact name and number in reports select the **Hide the name and number in reports** check box.
9. On the ribbon, click **Save**.

**Adding phone number groups**

You can associate Phone numbers with Phone number groups. Phone number groups are added in YourSite Explorer and then Phone numbers are associated with them.

To add a Phone number group

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Phone number groups**.
3. Click **Add**.
4. Type a **Name** and **Reporting number** for the Phone number group.
5. On the ribbon, click **Save**.
To associate a Phone number with a Phone number group

1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone number groups.
3. Select a phone number group from the list.
4. On the Membership tab, under Available members, select a Phone number and click > to move the Phone number to the Selected members list.
5. On the ribbon, click Save.

Adding auto-acknowledgement messages and associating them with queues

You define the Multimedia Contact Center acknowledgement the customer receives (after emailing or sending a chat message to your company) on the Multimedia Contact Center auto-acknowledgement tab. For example, the Payment Response acknowledgement sent to a customer upon payment for an order might be “Thank you for shopping with us. Your order is scheduled for delivery on May 05, 2009 between the hours of 9:00 A.M. and 5:00 P.M., pending credit approval.”

To add an auto-acknowledgement

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Multimedia Contact Center=>Multimedia Contact Center auto-acknowledgement.
3. Click Add.
4. After Name, type the name of the auto-acknowledgement.
5. After Body, type the message the caller will receive.
6. Click Save.

To associate an auto-acknowledgement with a queue

1. In Contact Center Management, click YourSite=>Configuration.
2. On the configuration menu, click Queue=>Queue.
3. Across from a queue with an email, chat, or fax media server, click Edit.
4. On the Multimedia Contact Center auto-acknowledgement tab, select the Enable auto-acknowledgement messages for this queue check box.
5. After During business hours, the auto-acknowledgement message is, select a business-hours auto-acknowledgement message.
   An auto-acknowledgement is a greeting the client receives in response to contacting your company by email, SMS, chat, or fax. For example, the auto-acknowledgement could be “Thank you for your email. We will respond to your request shortly.”
6. If you must create or modify an auto-acknowledgement message, click Manage and configure a message.
7. After Outside business hours, the auto-acknowledgement message is, select an after-hours auto-acknowledgement message.
8. Click Save.

Configuring Intelligent Queue devices

**NOTE:** You must have the Intelligent Queue application, and add an Intelligent Queue media server to your site before you can view the Intelligent Queue option on the YourSite Configuration menu. See “Adding an Intelligent Queue media server” on page 103.

Viewing Smart Choice layers

You can configure your ports to act as options, or Smart Choice message trees. Each option will play a user-defined message and transfer the caller to a user-defined destination, or allow the customer to create a voice callback if this option has been purchased.
To view Intelligent Queue Smart Choice layers in the YourSite database

- In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice** layer.
  The Intelligent Queue Smart Choice layer window appears.
  Under Media server, the Intelligent Queue media servers are listed.
  Under Reporting number, the Intelligent Queue Smart Choice layer reporting numbers are listed.
  Under Name, the Intelligent Queue Smart Choice layer names are listed.

### Adding Smart Choice layer groups

To add an Intelligent Queue Smart Choice layer group

1. In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice layer group**.
2. Click **Add**.
   The Add an Intelligent Queue Smart Choice layer group window appears.
3. Specify identification information for the Smart Choice layer group.
4. Click **Save**.

### Adding Smart Choice layers to a Smart Choice layer group

To add Intelligent Queue Smart Choice layers to an Intelligent Queue Smart Choice layer group

1. In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice layer group**.
2. Across from the record of the Smart Choice layer group just created, click **Members**.
3. Under **Available Intelligent Queue Smart Choice layers**, select the check boxes of the members you want to add to the group and click **Add >>**.
4. Click **Save**.

### Viewing Intelligent Queue ports

To view Intelligent Queue ports in the YourSite database

- In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice layer**.
  The Intelligent Queue Smart Choice port window appears.
  Under Media server, the media server associated with each Intelligent Queue port is listed.
  Under Reporting number, the Intelligent Queue port reporting numbers are listed.
  Under Name, the Intelligent Queue port names are listed.
  Under Dialable number, the dialable numbers are listed.

### Adding Intelligent Queue port groups

To add an Intelligent Queue port group

1. In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice port group**.
2. Click **Add**.
   The Add an Intelligent Queue Smart Choice port group window appears.
3. Specify identification information for the Intelligent Queue port group.
4. Click **Save**.
Adding Intelligent Queue ports to an Intelligent Queue port group

To add an Intelligent Queue port to an Intelligent Queue port group

1. In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice port group**.
   The Intelligent Queue Smart Choice port group window appears.
2. Across from the record of the Intelligent Queue Smart Choice port group just created, click **Members**.
   The Edit Intelligent Queue Smart Choice port group members window appears.
3. Under **Available Intelligent Queue Smart Choice ports**, select the check box of the member you want to add to the group and click **Add >>**.
4. Click **Save**.

Viewing Intelligent Queue Smart Choice layer exit codes

Exit codes trigger each exit from a queue or from the auto attendant. They apply to Smart Choice message queues, RAD queues, and routing queues.

To view Intelligent Queue Smart Choice layer exit codes in the YourSite database

- In Contact Center Management, click **YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice layer exit code**.
  The Intelligent Queue Smart Choice layer exit code window appears.
  Under Reporting number, the Intelligent Queue exit code reporting numbers are listed.
  Under Name, the Intelligent Queue exit code names are listed.

Configuring employee scheduling preferences

Schedule Builder uses employee preferences/options as parameters when scheduling employees. You must configure employee scheduling preferences accurately in YourSite Explorer to create a meaningful schedule.

To configure employee information for scheduling

1. Select the employee or employees you want to configure.
2. Specify the employee role.
   See “Configuring employee roles” on page 166.
3. Specify employee work hours.
   See “Configuring employee work hours” on page 166.
4. Specify employment status.
   See “Configuring employment status” on page 166.
5. Specify employee payroll information.
   See “Configuring employee payroll information” on page 166.
   See “Configuring employee availability” on page 167.
7. Specify time off information
   See “Configuring employee time off” on page 167.
8. Specify employee skills
   See “Configuring employee skills” on page 168.
Configuring employee roles

To configure an employee role

1. In YourSite Explorer, in the left pane, click **YourSite**.
2. Under **Devices**, click **Employees**.
3. Select the employee to which you will add an employee role.
4. On the **Workforce Scheduling** tab, click **General**.
5. If the employee is a supervisor, select the **Is a supervisor** check box. Otherwise, next to **Supervisor**, select the employee’s supervisor from the list.
6. On the ribbon, click **Save**.

Configuring employee work hours

To configure employee work hours

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Employees**.
3. Select an employee.
4. On the **Workforce Scheduling** tab, click **Work hours**.
5. Under **Work hours**, enter the minimum and maximum number of hours the employee can work in a day and week.
6. If the want to schedule the employee for an unlimited number of hours, click **Unlimited**.
7. After **Minimum time required between shifts**, enter the minimum number of hours required between the employee’s shifts.
   **NOTE:** Ensure you set a minimum time between shifts or Schedule Builder will schedule back-to-back shifts for employees.
8. If the employee is permitted to work overtime, under **Available**, select an overtime type from the list and click **>** to move the overtime type to the **Assigned** list.
9. On the ribbon, click **Save**.

Configuring employment status

To configure employment status

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Employees**.
3. Select an employee.
4. On the **Workforce Scheduling** tab, click **Payroll**.
5. If the selected employee is full-time, under **Employment status**, select **Full time**.
6. If the selected employee is part-time, under **Employment status**, select **Part time**.
7. On the ribbon, click **Save**.

Configuring employee payroll information

**NOTE:** If you want to schedule employees by seniority, the employee must be assigned a hire date.

To configure employee payroll information

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Employees**.
3. Select an employee.
4. On the **Workforce Scheduling** tab, click **Payroll**.
5. Under **Salary**, after **Pay period**, select the pay period for the employee.
6. If the employee is paid an hourly salary, next to **Hourly salary**, specify the employee’s pay per hour.
7. If the employee is paid a yearly salary, next to **Yearly salary**, specify the employee’s yearly salary and the typical number of hours the employee works in a week.
8. On the ribbon, click **Save**.
Configuring employee availability

NOTE: If you do not specify availability, Schedule Builder assumes the employees are available 24 hours a day, seven days a week.

To configure employee availability

1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Availability.
5. Select the Uses availability check box.
6. Under New Availability, after Work day, select the day of the week the employee availability applies to from the list.
7. If the employee is available only during certain hours of the day, select Part of the day and specify the hours the employee is available.
8. If the employee is available all day, select Full day.
9. Click Add availability.
10. On the ribbon, click Save.

Configuring employee time off

To configure employee time off

1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Time off.
5. If the employee’s time off is carried over based on their start date, under Carryover date, select Employee start date.
6. If the employee’s time off is carried over based on a fixed date, under Carryover date, select Fixed date and specify the carryover date.
7. If the employee is permitted time off, under Available, select the time off type from the list and click > to move the time off type to the Assigned list.
8. On the ribbon, click Save.

Overriding employee time off

To override an employee time off type

1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Time off.
5. Under Assigned time off, select a time off type to override.
6. If you want to override the total number of time off hours allowed, select the Override total hours allowed check box and specify the number of hours.
7. If you want to override a percent of time off hours based on time worked, select the Override % of hours worked check box and specify the number of hours.
8. If you want to override the number of hours that can be carried over, select the Override allowed carry over and specify the number of hours.
9. If you want to override the time off hours available to the employee, after Available as of, specify the date after which the time off hours are available and number of hours that will be available.
10. On the ribbon, click Save.
Configuring employee skills

**NOTE:** If you have selected multiple employees to edit, skills that are not available to these employees are greyed out and cannot be assigned.

To configure employee skills

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Employees**.
3. Select an employee.
4. On the **Workforce Scheduling** tab, click **Skills**.
5. Under **Available**, select the skill type from the list and click > to move the skill type to the **Assigned** list.
6. Repeat step 5 for all skills the employee will use.
7. On the ribbon, click **Save**.

Configuring scheduling options

Before you can make schedules in Workforce Scheduling, you must configure the following scheduling options in YourSite Explorer:

- Employees
  - See “Adding employees” on page 132.
- Holidays
  - See “Configuring holidays” on page 168.
- Overtime types
  - See “Configuring overtime types” on page 169.
- Time off types
  - See “Configuring time off types” on page 169.
- Skills
  - See “Configuring skills” on page 170.

Configuring holidays

You configure holiday options on the Holidays window. You can add holidays that affect your contact center, specify which holidays give employees the day off, and specify which holidays are paid.

To configure a holiday

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Holidays**.
3. Click **Add**.
4. After **Name**, type the name of the holiday.
5. If this holiday is a company holiday and you want to receive warnings when trying to schedule employees for this day, select the **This holiday is a company holiday** check box.
6. Specify the pattern of the holiday.
   - If the holiday always falls on the same day of the month, select **Every** and specify the month and date the holiday falls on.
   - If the holiday has a pattern of falling on a certain day, week, and month, select **The** and specify the pattern, day of week, and month.
   - If the holiday is a calculated holiday, such as Good Friday or Easter Monday, select **Calculated holiday** and specify the holiday.
7. On the ribbon, click **Save**.
Configuring overtime types

You can configure the following overtime parameters:

- **Pay rate multiplier**—The number of times by which the basic pay is increased to calculate the overtime pay rate. For example, if the pay rate multiplier is 1.5 and applied to $10 per hour, the overtime pay rate is $15 per hour.
- **Color**—The color in which the job appears in the time bar pane.
- **Hours worked in a given day are greater than**—The number of hours in a day an employee must work before the employee is paid at the overtime pay rate.
- **Hours worked in a given week are greater than**—The number of hours in a week an employee must work before the employee is paid at the overtime pay rate.
- **Days of the week worked**—Any work done on these days will be considered overtime pay.
- **Day of the year worked**—Any work done on this specific date will be considered overtime pay.
- **Holiday worked**—Any work done on this specific holiday will be considered overtime pay.

To configure an overtime type:

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Overtime**.
3. Click **Add**.
4. After **Name**, type the name of the overtime type.
5. Under **Effects**, enter a pay rate modifier and select a color for the overtime type.
6. Under **Conditions**, select either **Hours worked**, **Days of the week worked**, **Days of the year worked**, or **Holiday worked**.
   - If you select Hours worked, you must select either Hours worked on a given day are greater than or Hours worked on a given week are greater than and specify the number of hours.
   - If you select Days of the week worked, you must select the days of the week to which this overtime type applies.
   - If you select Days of the year worked, select the days of the year to which this overtime type applies.
   - If you select Holiday worked, select the holiday to which this overtime type applies.
7. On the ribbon, click **Save**.

Configuring time off types

Employees might take time off work for a variety of reasons. Depending on the nature of time taken off, employees might be paid, employees might be required to take a full day as time off, and employees might accrue time off (for example, vacation).

Create time off types that reflect the time off that employees take at your contact center.

- Consider if the type of time off should accrue, such as vacation, time off for a medical procedure, or personal days.
- Consider when the time off is accrued. For example, an employee might accrue 1 day of paid sick leave per month.
- Consider if the type of time off must be taken as a full day.
- Consider if employees must qualify for the type of time off.
- Consider if employees can carry the time off over to the next year.

Workforce Scheduling can warn you when employees do not qualify for the time off or when the scheduled time off is not within the limits allowed.
To configure a time off type

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Time off**.
3. Click **Add**.
4. After **Name**, type the name of the time off type.
5. If employees will be paid for this time off type, under **Effects**, select the **Paid time off** check box and select a color for the time off type.
6. If employees can request this type of time off from Employee Portal, under **Effects**, select the **Can be requested** check box.
7. Under **Employment duration qualification**, select either the **Employed for at least** or **Employed no more than** check box and specify the number of months.
8. Under **Scheduling limitations**, select either the **You must schedule this type in increments of at least** or **You must not schedule this type for more than** check box and specify the number of hours per day/week.
9. If you want to limit the number of hours this time off type can be scheduled, select the **Limit the number of hours that can be scheduled** check box.
   - If you want to fix the annual amount of this time off type, select **Fixed annual amount of** and specify the number of hours.
   - If the annual hours of this time off type are accrued, select the **Annual hours are accrued** check box and select either **Weekly**, **Biweekly**, or **Monthly**.
   - If you want to base this time off type on a percent of the number of hours worked, select **Based on hours worked at a rate of** and specify a percent.
   - If you want to carry over a fixed amount of accumulated time off hours, select **Fixed amount of accumulated hours up to** and specify the number of hours.
   - If you want to carry over a percent of accumulated time off hours, select **Percent of accumulated hours, at a rate of** and specify a percent.
10. On the ribbon, click **Save**.

**Configuring skills**

Employees offer a variety of different skills. For example, some employees might be bilingual or have certification in a specialty. Using Workforce Scheduling, you can incorporate these skills when you create your schedules.

Configuring the different types of skills allows you to create and manage schedules that incorporate the skills and skill levels of your employees. When you create schedules, Workforce Scheduling allows you to schedule employees with specific skill sets.

**NOTE:** Skill levels range from 1 to 10, level 10 being the highest skill level, or most skilled, and level 1 being the lowest skill level. Remember this when you configure employees in YourSite Explorer or on the Contact Center Management website.

To configure a skill

1. In YourSite Explorer, in the left pane, click **Workforce Scheduling**.
2. Click **Skills**.
3. Click **Add**.
4. After **Name**, type a name for the skill.
5. On the ribbon, click **Save**.
Business hour schedules

You create schedules that accurately reflect the business hours of your operation. You can create yearly or seasonal schedules. When you install Contact Center Management, the 24/7 default schedule is created. This schedule is for businesses that operate 24 hours a day, seven days a week.

Your contact center software performs certain tasks during business hours and other tasks after business hours. For example, Multimedia Contact Center sends business hour auto-acknowledgement messages to customers who contact you by email or chat during your business hours, and sends outside business hour auto-acknowledgement messages to customers who contact you by email or chat after your business closes for the day. You create schedules so that Contact Center Management knows what the hours of operation are for your business.

Creating schedules

The schedules you create do not expire. The weekly schedule configuration applies week after week until you change the schedule or apply a different schedule to the device. You can exclude specific dates from the schedule for national holidays.

To create a schedule in YourSite Explorer

1. In YourSite Explorer, click Schedules.
2. Click Add.
3. After Name, type the name of the schedule (for example, type Fall 2008 schedule).
4. After Schedule exclusion list, click ... and select a schedule exclusion list.
5. If you must create or modify an exclusion list for the schedule, click Manage schedule exclusion list and configure a list of days to exclude from the schedule.
   See “Managing schedule exclusion lists” on page 172.
6. After Start time, select the business day start time for each day of the week.
7. After End time, select the business day end time for each day of the week.
8. After Disable for day, enable the check box for each day your business is closed.
9. Click Save.

To create a schedule in the Contact Center Management website

1. In Contact Center Management, click YourSite=>Schedule.
2. Click Add.
   The Add a schedule window opens
3. After Name, type the name of the schedule (for example, type Fall 2007 schedule).
4. After Schedule exclusion list, select a list.
5. If you must create or modify an exclusion list for the schedule, click Manage schedule exclusion list and configure a list.
   See “Managing schedule exclusion lists” on page 172.
6. After Start time, select the business day start time for each day of the week.
7. After End time, select the business day end time for each day of the week.
8. After Disable for day, select the check box for each day your business is closed.
9. Click Save.
Managing schedule exclusion lists

To manage schedule exclusion lists in YourSite Explorer

1. In **YourSite Explorer**, click **Schedules**.
2. Click **Add**.
3. Click **Manage schedule exclusion list**.
4. After **Name**, type the name of the exclusion list.
5. On the calendar, click the dates you want to exclude from the schedule.
6. Click **Save**.
7. Click **Apply** to apply the new schedule exclusion list to the schedule.

To manage schedule exclusion lists in Contact Center Management

1. In Contact Center Management, click **YourSite=>Schedule**.
   The Schedule window appears.
2. Click **Add** or **Edit**.
3. Click **Manage schedule exclusion list**.
4. After **Name**, type the name of the exclusion list.
5. On the calendar, click the dates you want to exclude from a schedule.
6. Click **Save**.
7. Click **Apply** to apply the new schedule exclusion list to the schedule.

Applying schedules

You can apply the schedules you create to

- Media servers—See “Adding media servers” on page 78.
- Queues—See “Adding queues” on page 141.
- Network Monitor alarms—See “Network Monitor alarms” on page 104.
- WallBoarder sign plan business hour and scheduled messages—See “Creating sign plans for daisy-chained signs” on page 289.
- Interactive Contact Center Queue control—See “Configuring Interactive Contact Center Queue control” on page 145.

Security roles

You create security roles if you want to restrict employees from specific devices and Contact Center Management application areas.

**NOTE:** In order for you to assign security roles, your account must be associated with a security role that does not restrict you from administering security.

The Contact Center Solutions default security role **Not restricted** allows employees full access to all of the Contact Center Solutions applications (to which the contact center is licensed) and devices. Contact Center Solutions security roles are inclusive. This means that a security role assigned to an employee defines the application areas an employee can access.

When you install Contact Center Management, a default user is created. This assures you there is at least one account with which you can access the Contact Center Management website. After you install Contact Center Management, you must change the default account password to a unique password.

The default user name and password are

- Username: _admin
- Password: _password
- Security Role: Unrestricted
Security roles have two components:

- **Basic**—Basic security controls user access to specific areas of Contact Center Management, Flexible Reporting, and to Workforce Scheduling and Schedule Adherence.
- **Advanced**—Advanced security controls user access to customized lists of devices, real-time monitors, profiles, reports, sites, and users.

**Creating and applying security roles**

You can create security roles in a number of combinations of basic and advanced properties. For example, you can create a security role with basic security only by leaving the advanced security components set to Not restricted. Alternatively, you can create a security role with the basic component granting full access to all Contact Center Management application areas and an advanced component that restricts access to a few reports and devices. (See Figure 6-10.)

To create and apply a security role with basic and advanced components, you must

1. Ensure employees are configured in the YourSite database.  
   See “Adding employees” on page 132.
2. Create security lists.
3. Configure basic security.
4. Configure advanced security.
5. Assign the security role to one or more employees.

To create and apply a security role with basic security components only, you must

1. Ensure employees are configured in the YourSite database.
2. Specify basic security.
3. Assign the security role to one or more employees.

To create and apply a security role with advanced security components only, you must

1. Create security lists if you want to apply advanced security.
2. Configure basic security.
3. Configure advanced security.
4. Ensure all employees are configured in the YourSite database.
5. Assign the security role to one or more employees.
Creating security lists

You can use advanced security to restrict user access to sites, reporting, and real-time functions.

Before you can specify advanced security, you must create security lists (device lists, real-time monitor lists, report lists, site lists, and/or user lists). Each list must contain the devices, real-time monitors, reports, sites, and/or users to which employees are granted access. You can combine these lists when you assign a security role. For example, you can specify advanced security that permits users to create Employee Group Performance by Employee reports (specific report list) on Kanata employees (specific device list) only.

Use the following security lists to define advanced security:

- **Device list**—Device lists specify devices for which employees may view real-time information. You create device lists to restrict access to statistics on specific employees. For example, you might want a manager to view certain employees only (specific device - Kanata employees). The device list must contain the device (employee group - in this case, Kanata employees) to which the user may gain access.
Devices include agents, agent groups, divisions, DNIS groups, employees, employee groups, Intelligent Queue Smart Choice Layer groups, Intelligent Queue Smart Choice Port groups, Intelligent Queue voice call back queue groups, Intelligent Queue Web call back queue groups, queue groups, teams, trunk groups, and voice extension groups. Statistics are generated from these devices. You can view these statistics or generate a report from them.

**NOTE:** If you add an agent to a device list, you must also add the associated employee.

- **Profile list**—You create a profile list to restrict users from managing specific real-time monitor profiles.
- **Real-time monitor list**—The real-time monitor list specifies real-time monitors to which you are granted access. You create a real-time monitor list to restrict access to particular real-time monitors. The real-time monitor list must contain the monitors to which the user may gain access.
- **Report list**—You create report lists to restrict users from viewing specific report types. For example, you might want managers to view employee reports only (specific report category). The report list must contain the reports the user may run. If you do not assign a report list to the employee, then the employee will see every YourSite group and team when running reports and monitoring real-time activities (unless a basic security role is assigned to that employee that does not permit the employee to gain access to any reports).
- **Site list**—The site list specifies sites you may manage. You create a site list to restrict access to devices by site. For example, you might want a supervisor to view the employees at a particular site only. The site list must contain the site (in this case, Kanata) to which the user may gain access.
- **User list**—You create a user list to restrict a user from chatting online with certain employees. The user list must contain the employees with which the user may chat. For example, you might want managers to chat online with only the employees they supervise. If Jane manages Bill, Sue, and George, then you assign Jane an advanced security role that permits Jane to chat with Bill, Sue, and George (the user list would contain Bill, Sue, and George).
- **Card design list**—You create a card design list to restrict users from managing card designs (card designs specify the information displayed on agent, employee, and extension real-time monitors).

To create a security list

1. In Contact Center Management, click **YourSite=>Security=>Security lists=>select the security list you want to create.**
2. Click **Add.**
   The Add list tab appears.
3. After **Name**, type the list name (for example, type Jane’s chat group).
4. After **Description**, type the list description (for example, type Jane’s group).
5. Click the **Members** tab.
6. If you are creating a device or reports list, after **Filter by**, select a category to narrow the items that appear in the list (for example, Agent group).
7. Select the check boxes of the members you want to include in the list.
8. Click **Save.**
   The security list appears in the list tree.

**Configuring security**

**NOTE:** When users first access the Contact Center Management website, by default, they can access all of the Contact Center Management Web applications.

You can create basic security to restrict user access to specific areas of the Contact Center Management website. For example, if you want to restrict users from viewing Contact Center Client and Enterprise Configuration, then you must create a security role with those characteristics. (See Figure 6-11.)

You must create a security list before you can create an advanced security role. Using these lists, you define a security role. See “Creating security lists” on page 174.
To configure security:

1. In Contact Center Management, click **YourSite=>Security=>Security roles**.
   The Security roles window appears. It lists all of the security roles that have been created.

2. Click **Add a role**.

3. After **Role name**, type the name of the security role, (for example, Contact Center Management only).

4. After **Role description**, type the description of this security role, (for example, No access to Workforce Scheduling and Schedule Adherence).

5. On the **Basic** tab, clear the check boxes of the items the user is not permitted to use. For example, if agents are not permitted to administer security, clear **May manage security**.
   See Table 6-6 for a description of the YourSite Explorer security setting options.

6. If required, click the **Advanced** tab and specify advanced security.
   An advanced security role restricts access to reports, real-time and Interactive Contact Center statistics, Chat, sites, and real-time monitors. (See Figure 6-12.)

7. Click **Save**.

Table 6-6 describes the security setting options for YourSite Explorer synchronization that display in the Basic security tab.
Table 6-6 YourSite Explorer synchronization - security setting options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No access</td>
<td>If No Access is enabled you cannot configure Enterprise settings or devices in YourSite Explorer.</td>
</tr>
<tr>
<td>Allow Read Access</td>
<td>Allow Read Access enables you to read Enterprise/device configuration settings on the telephone system(s).</td>
</tr>
<tr>
<td>Allow Read/Write Access</td>
<td>Allow Read/Write Access enables you to read Enterprise/device configuration settings on the telephone system(s) and write them to the YourSite database.</td>
</tr>
<tr>
<td>Allow Full Control</td>
<td>Allow Full Control enables you to read Enterprise/device configuration settings on the telephone system(s), write them to the YourSite database, and write back devices programmed in YourSite Explorer to the telephone system.</td>
</tr>
</tbody>
</table>

Figure 6-12 Advanced security tab

<table>
<thead>
<tr>
<th>Basic</th>
<th>Advanced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reporting</td>
<td>May access the reports contained in this list only Not restricted ▼-May run reports on the devices contained in this list only Not restricted ▼</td>
</tr>
<tr>
<td>Sites</td>
<td>May access the sites contained in this list only Not restricted ▼&lt;br&gt;Note: This setting restricts the user to the devices of the selected site</td>
</tr>
<tr>
<td>Real time</td>
<td>May access the real-time monitors Not restricted ▼-May access the real-time monitors contained in this list only Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May manage the appearance of real-time monitors for personal use (Personal profile) Not restricted ▼-May manage the appearance of real-time monitors for all users (shared profile) Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May manage the appearance of card designs for personal use (personal cards) Not restricted ▼-May manage shared card designs Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May access the shared card designs contained in this list only Not restricted ▼-May access real-time online chat Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May chat online with the users contained in this list only Not restricted ▼-May change the real-time states of agents and queues in Interactive Contact Center Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May control the devices contained in this list only Not restricted ▼-May view real-time information on the devices contained in this list only Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May access the real-time shared profiles contained in this list only Not restricted ▼-May manage real-time server alarms Not restricted ▼</td>
</tr>
<tr>
<td></td>
<td>May configure real-time server alarms settings Not restricted ▼-May control my real-time status in Interactive Contact Center Not restricted ▼</td>
</tr>
</tbody>
</table>
Verifying security role properties

To verify the properties of a security role

1. In Contact Center Management, click **YourSite=>Security=>Security roles**. The Security roles window appears. It lists all of the security roles that have been created.
2. Click **View** adjacent to the security role for which you want to view properties. You can assign the security roles to new users and to existing users.

Assigning security roles to employees

**NOTE:** Users who are currently logged on will not be affected by changes made to their associated role until the next time they log on. If you want the security role changes to take effect immediately, start and stop the Contact Center Management website from the Internet Server Manager. All of the clients will be disconnected and forced to log on again.

To assign a security role to an employee

1. In Contact Center Management, click **YourSite=>Configuration**.
2. Click **Employee=>Employee**.
3. Across from the record you want to edit, click **Edit**.
4. Click the **User account** tab.
5. After **Security role**, select a security role to assign to the employee. All security roles are listed here.
6. Click **Save**.
Chapter 7
Real-time Monitors

Contact Center Client
Providing Contact Center Client functionality to teleworkers
WallBoarder
Troubleshooting real-time issues
Real-time Monitors

The Enterprise Server continuously updates the real-time applications with telephone system data, and simultaneously updates connected clients through Transmission Control Protocol-Internet Protocol (TCP/IP).

The real-time applications include Contact Center Client and WallBoarder. Supervisors and agents can view real-time voice statistics in Contact Center Client and the phone availability of contact center and general business employees. In contact centers that have the Multimedia Contact Center optional application, supervisors and agents can view real-time voice, email, chat, and fax statistics. WallBoarder displays text messages and contact center statistics on one or more Spectrum Light Emitting Diode (LED) reader boards (wall signs). See “WallBoarder” on page 227.

Contact Center Management integrates with Verint and OAISYS call recording software to enable 24/7 call recording. Call recordings are appended to specific Lifecycle reports. See “Configuring call recording” on page 82.

In addition to real-time monitors, Contact Center Client includes the following application areas:

- **Network Monitor**
  Network Monitor provides information on the status of media server real-time data collection. See “Network Monitor” on page 321.

- **Auditor**
  Using Auditor, supervisors can view the historical real-time events that occurred on a particular date, in the sequence they occurred, at your own pace. See “Auditor” on page 314.

- **Management Console**
  Using Management Console, network administrators can restart services, administer the database, and perform maintenance functions. See “Management Console” on page 55.

- **Contact Center Chat**
  Contact Center Client provides instant messaging capabilities for both supervisors and agents and is typically used by contact center employees. Contact Center Chat provides the online chat presence of contact center employees, including Available, Offline, and Away. Agents can view the availability and presence of other contact center employees before they transfer calls or send online chat messages. With the Enterprise Presence / Chat Integration license, Contact Center Solutions integrates with Microsoft® Office Live Communications Server 2005 and Office Communications Server 2007 to provide enhanced presence. See “Using Contact Center Chat” on page 218.

The following optional applications and features reside in Contact Center Client:

- **Interactive Contact Center**
  Interactive Contact Center is an optional application that enables supervisors to control the availability of agents and ACD queues. Agents can log themselves on or off, and place themselves in or remove themselves from Make Busy or Do Not Disturb. See “Using Interactive Contact Center” on page 331.

- **Interactive Visual Queue**
  Interactive Visual Queue is an optional application that enables agents to monitor calls within queues, move calls from busy queues to less active queues, and call back abandoned callers. See “Using Interactive Visual Queue” on page 343.

- **Contact Center PhoneSet Manager and Contact Center Softphone**
  Contact Center PhoneSet Manager and Contact Center Softphone are optional applications that enable agents to use their desktop computers as IP-based phones. See “Contact Center PhoneSet Manager and Contact Center Softphone” on page 353.
• **Contact Center Screen Pop**
  Contact Center Screen Pop is an optional application that launches applications or Web pages. In addition, it enables agents to automatically receive caller and account information via pop-ups on their computer monitors every time they receive calls. See “Using Contact Center Screen Pop” on page 383.

• **Enterprise Presence / Chat Integration**
  With the addition of Microsoft® Office Live Communications Server 2005 and Office Communications Server 2007, agents and supervisors use Microsoft Office Communicator as their default instant messaging client. The presence of all company employees is natively delivered in Contact Center Client. Contact center employees can view the presence of both internal and external contacts to determine if they are available to communicate. In addition to Available, Offline, and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be Right Back, and other presence indicators.

Live Communications Server extends the capabilities of Contact Center Chat enabling agents to communicate with people who are

- In the same company, but are not using Contact Center Client
- In the same company, but are not on the same intranet
- External to the company, where the companies in which they work have a Federated Live Communication Server environment and use Office Communicator
- External to the company, communicate over the public internet, and use popular instant message services (MSN, AIM, Yahoo!)

In a Live Communication Server environment, you can take advantage of other forms of communication: computer voice calls, video conferencing, white boarding, and desktop sharing capabilities. Communication with MSN, AIM and Yahoo! is typically limited to instant messaging only.

**Contact Center Client**

**NOTE:**

- By default, all supervisors and agents view all real-time monitors and devices in Contact Center Client. You can specify which monitors and devices users view in YourSite=>Security=>Security lists. In addition, you can configure security in YourSite=>Security=>Security roles that dictate whether users can manage personal and/or global profiles.
- In YourSite Configuration, you must select the This employee will use these credentials to log on to applications check box on the User account tab for an employee if you want an employee to use Contact Center Management. You must associate an employee with an agent login ID, and select the This employee will be tracked in real-time and reporting check box in order to view the employee in Contact Center Client.
- In YourSite Configuration, an employee must be a member of an employee group in order for you to view the employee on the employee group monitors in Contact Center Client. A queue must be a member of a queue group in order for you to view the queue on the queue group monitors in Contact Center Client.
- The number of employees logged on at any time must be consistent with your software license.
Starting Contact Center Client

You start Contact Center Client to access real-time functionality. Supervisors and agents can view real-time voice statistics. In contact centers that have the optional Multimedia Contact Center application, supervisors and agents can view real-time voice, email, chat, and fax statistics. After starting Contact Center Client, you can choose to minimize it to either the system tray or the taskbar, depending on your operating system.

If you are working from the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select SSL.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
4. Click Log on.

If you are working outside of the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
2. Select the Connect using Teleworker check box and click Change Teleworker settings.
3. Verify the Teleworker Server IP address.
4. If you use Secure Socket Layer, select SSL and click OK.
   See “Providing Contact Center Client functionality to teleworkers” on page 224.
5. Click Log on.

When you minimize Contact Center Client and you are using Windows XP as your operating system, the Contact Center Client icon displays in your desktop system tray.

If you are using Windows Vista, you can optionally configure Contact Center Client to display in your desktop taskbar.

To display Contact Center Client in the taskbar

1. In Contact Center Client, click Tools=>Options.
2. Under Device control, clear the Hide when minimized check box and click OK.
   Contact Center Client, when minimized, will display in the taskbar.
3. To save the profile, click File=>Save as.
4. Type a Name for the profile and click OK.
   The profile is saved and will automatically be applied each time you open Contact Center Client.
Agent states

**NOTE:** If Contact Center Client becomes disconnected from the server, upon re-connection agent states will automatically be synchronized with the server.

Table 7-1 lists the agent states and their corresponding icons for voice, email, chat, and fax.

**Table 7-1 Agent states**

<table>
<thead>
<tr>
<th>Voice</th>
<th>Email</th>
<th>WebChat</th>
<th>Fax</th>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Ringing</td>
<td>an ACD call ringing on an agent’s phone waiting to be handled</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>ACD</td>
<td>an agent handling an ACD call/email/chat/fax</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>ACD Hold</td>
<td>an agent who has placed an ACD call/email/chat/fax on hold</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Idle</td>
<td>an agent logged on and waiting to receive a call/email/chat/fax</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Non-ACD</td>
<td>an agent involved in an incoming non-ACD call or agent originated call</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Non-ACD Hold</td>
<td>an agent who has placed a non-ACD call on hold</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Outbound</td>
<td>an agent on an outgoing call</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Outbound Hold</td>
<td>an agent who has placed an outgoing call on hold</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Camp on</td>
<td>a call is waiting to be answered</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Forwarded to</td>
<td>the agent has set all incoming calls to be forwarded to an alternate answer point</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Do Not Disturb</td>
<td>an agent who has activated do not disturb and is not available to receive any ACD or non-ACD calls</td>
</tr>
<tr>
<td>![Voice Icon]</td>
<td>![Email Icon]</td>
<td>![WebChat Icon]</td>
<td>![Fax Icon]</td>
<td>Make Busy</td>
<td>an agent who is not available to receive ACD calls/emails/chats/faxes but can receive calls dialed directly to the agent’s extension</td>
</tr>
</tbody>
</table>
### Extension states

**NOTE:** If your Contact Center Client becomes disconnected from the server, upon re-connection the extension states will automatically be synchronized with the server.

Table 7-2 lists the extension states and their corresponding icons.

### Table 7-2 Extension states

<table>
<thead>
<tr>
<th>Icon</th>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Image" /></td>
<td>Ringing</td>
<td>Call is ringing on the extension and waiting to be handled</td>
</tr>
<tr>
<td><img src="image2" alt="Image" /></td>
<td>Idle</td>
<td>Extension is waiting to receive a call</td>
</tr>
<tr>
<td><img src="image3" alt="Image" /></td>
<td>Non-ACD</td>
<td>Extension is involved in an incoming call or an internal extension-originated call</td>
</tr>
<tr>
<td><img src="image4" alt="Image" /></td>
<td>Non-ACD Hold</td>
<td>Extension has placed an incoming call or an internal extension-originated call on hold</td>
</tr>
</tbody>
</table>
Understanding Contact Center Client features

Contact Center Client has agent, queue, queue chart, and call note monitors. For information on adding and viewing call notes, see “Adding call notes to a call” on page 369.

You can perform the following tasks on the monitors:
- Call recording
- Open monitors
- Dock monitors
- Add and remove device IDs
- Sort monitor devices
- Rearrange cells
- Set monitor dimensions
- Freeze and unfreeze columns

### Table 7-2 Extension states

<table>
<thead>
<tr>
<th>Icon</th>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon1.png" alt="Icon" /></td>
<td>Outbound Call</td>
<td>Extension is on an outgoing call</td>
</tr>
<tr>
<td><img src="icon2.png" alt="Icon" /></td>
<td>Outbound Hold</td>
<td>Extension has placed an outgoing call on hold</td>
</tr>
<tr>
<td><img src="icon3.png" alt="Icon" /></td>
<td>Forwarded to</td>
<td>Extension has set all incoming calls to be forwarded to an alternate answer point</td>
</tr>
<tr>
<td><img src="icon4.png" alt="Icon" /></td>
<td>Camp on</td>
<td>Extension is on a call and an incoming call is camped on (waiting to be answered)</td>
</tr>
<tr>
<td><img src="icon5.png" alt="Icon" /></td>
<td>Off Hook</td>
<td>Extension’s phone is off the hook, so cannot receive calls</td>
</tr>
<tr>
<td><img src="icon6.png" alt="Icon" /></td>
<td>Do Not Disturb</td>
<td>Extension has activated Do Not Disturb and is not available to receive calls</td>
</tr>
<tr>
<td><img src="icon7.png" alt="Icon" /></td>
<td>Logged off</td>
<td>Extension is not currently logged on and is unavailable to take calls</td>
</tr>
</tbody>
</table>

Outbound Call Extension is on an outgoing call
Outbound Hold Extension has placed an outgoing call on hold
Forwarded to Extension has set all incoming calls to be forwarded to an alternate answer point
Camp on Extension is on a call and an incoming call is camped on (waiting to be answered)
Off Hook Extension’s phone is off the hook, so cannot receive calls
Do Not Disturb Extension has activated Do Not Disturb and is not available to receive calls
Logged off Extension is not currently logged on and is unavailable to take calls
• Hide and show columns
• Filter device variables
• Set alarms
• Clear alarms
• Define monitor styles
• Group data
• Print monitors
• Arrange windows
• Modify the view
• Build marquee monitors to broadcast statistics and messages
• Chat online with agents and supervisors

Contact Center Client options

The following options apply to real-time monitors.

Call recording
On the Agent State by Time, Agent State by Position, and Agent State by Queue by Time monitors, the Call recording option enables you to start, stop, and restart call recording at any time during a call. See “Recording calls” on page 380.

Clear alarms
The Clear alarms command clears any current performance variable threshold alarms.

Set alarms
The Set alarms command specifies performance thresholds for queues and agents.

Add/Remove devices
The Add/Remove devices command adds or removes devices or device groups from the monitor. If you add agents, they are added to the bottom of the monitor.

Set table dimensions
On the Agent State by Position, Employee State by Position, and Extension State by Position monitors, the Set table dimensions command adds or deletes columns or rows. If you delete devices, they are deleted from the lower-right side of the monitor.

Size table to frame
On all monitors, the Size table to frame command adjusts the table to fit within the frame.

Sort monitor
On the Agent State by Position, Employee State by Position, and Extension State by Position monitors, the Sort monitor by Agent ID, name, state, or extension command sorts agents by Agent ID, name, state and time in state, or extension.

Filter device variables
On the Agent Shift, Queue by Period, and Queue Now monitors, the Filter device variables command filters the data based on conditions you specify and displays a subset of data on the monitor.

General
On all monitors, under Properties, the General option specifies the monitor name and enables the horizontal and vertical scroll bars.
On the queue monitors, you can also enable grouping.
On the agent, employee, and extension monitors you can also display tool tips, display a pattern upon failover, and display instant messaging online presence indicators. On the Agent and Employee State by Time monitors, you can also sort logged off agents by the longest logged off first.

**Print monitor**
The Print monitor command prints the current monitor.

**Enable grouping**
Under Properties, the Enable grouping option displays a grouping panel to which users can drag columns. The grouping order determines the order in which the rows appear. The Enable grouping option affects all monitors that contain columns.

**Row settings**
Under Properties=>Layout, the Row settings option specifies the background color and font color of rows, and the font type and text alignment.

**Row alternate settings**
Under Properties=>Layout, the Row alternate settings option specifies the background color and font color of alternate rows, and the font type and text alignment.

**Column settings**
Under Properties=>Layout, the Column settings option specifies the background color and font color of columns, and the font type and text alignment.

**Column dimensions**
Under Properties=>Layout, the Column dimensions option specifies the column height and width.

**Column order**
Under Properties=>Layout, the Column order option hides or displays individual columns, and specifies the order of columns across the monitor.

**Monitor style**
Under Properties=>Layout, the Monitor style option specifies styles and skins (sets of styles) for the monitor, and the Card design option specifies how information is displayed in the cells of agent, employee, and extension monitors.

**Cascade**
When you right-click a monitor tab, under Windows, the Cascade command distributes active monitors down and across the Contact Center Client window.

**Tile vertically**
When you right-click a monitor tab, under Windows, the Tile vertically command distributes active monitors across the Contact Center Client window.

**Tile horizontally**
When you right-click a monitor tab, under Windows, the Tile horizontally command distributes active monitors down the Contact Center Client window.

**Dock Contact Center Client**
When you right-click a monitor tab, under Windows, the Dock Contact Center Client command docks Contact Center Client at the top, bottom, left, or right of your desktop.
Always on top
When you right-click a monitor tab, under Windows, and select the Always on top command, Contact Center Client always displays on your desktop on top of all other open applications.

View
The View command hides or displays the main menu, status bar, real-time monitors, and email, fax, chat, and voice legends.

Viewing agent availability
Contact Center Client provides instant messaging capabilities for both supervisors and agents and is typically used by contact center employees. Contact Center Chat provides the online chat presence of contact center employees, including Online, Offline, Away. On the agent, employee, and extension monitors, agents can view the availability and presence of other contact center employees before they transfer calls or send online chat messages. (See Figure 7-1.) If an agent cell in a monitor is grayed out, the phone is not connected to the network and considered out of service. The out of service state applies to phones that are not connected to the network, Teleworker employees that have lost their Internet connection, phones that are physically disconnected or malfunctioning, or employees that are not logged into their soft phone.

Figure 7-1 Agent State by Position - viewing agent availability and online presence

With the addition of Microsoft® Office Live Communications Server 2005, agents and supervisors use Microsoft Office Communicator as their default instant messaging client. The presence of all company employees is natively delivered in Contact Center Client. Contact center employees can view the presence of both internal and external contacts to determine if they are available to communicate. In addition to Available, Offline, and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be Right Back, and other presence indicators. (See Figure 7-2.)

Figure 7-2 Agent State by Position - viewing agent availability and enhanced presence

The following monitors display agent activities:
- Agent State by Position
- Employee State by Position
- Extension State by Position
- Agent State by Time
- Employee State by Time
- Agent Shift
Agent, Employee, and Extension State by Position

The Agent, Employee, and Extension State by Position monitors provide real-time information in cells that you can arrange to mirror your floor plan: you can view agents, employees, or phone extensions by their physical position in your contact center. In addition, these monitors enable you to view the current status of general business extensions. Card designs enable you to customize the information displayed in the cells. See “Customizing the information displayed on position and time monitors” on page 211.

When you first open an agent, employee, or extension monitor, you can select a card design:

- The Classic card displays the agent state, time in the state, presence, agent/employee name, agent login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold).
- The Caller ID card displays the caller name and number (ANI), the number the caller/employee dials for incoming/outgoing calls, the state, time in the state, presence, agent/employee name, agent login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold).
- Custom cards you create and share

Caller ID information is displayed when

- Agents, employees, and extensions are in the following real-time states: ACD, ACD Hold, Ringing, Non ACD, Non ACD Hold, Out, and Out Hold Time
- Extensions are in the following real-time states: Inbound and Outbound

You can set alarms for all real-time statistics and for caller ID information, such as the caller name and number.

**NOTE:** If you are upgrading to Contact Center Management Version 5.7 SP1, before you can select the Caller ID card on the Add devices window of agent, employee, and extension monitors, you must make the card available. To do so, right-click an open monitor, select the Caller ID card under Properties, Layout=>Card design and click Apply.

In a fault tolerant setup, if a network outage occurs the cells in the agent, employee, and extension monitors display a crisscrossed pattern to identify agents who have homed to their secondary controllers. (See Figure 7-3.)

If an agent cell in a monitor is grayed out, the phone is not connected to the network and considered out of service. The out of service state applies to phones that are not connected to the network, Teleworker employees that have lost their Internet connection, phones that are physically disconnected or malfunctioning, or employees that are not logged into their soft phone.

Viewing the activities of agents who can log on to multiple voice queues

In Figure 7-3, the Agent State by Position monitor shows three cells for Andre Bourque, each with a different agent ID. The first two cells show Andre logged off of the telephone system. The third cell shows Andre’s current state. Andre is logged on to Queue 151 using Agent ID 2013. He has been on an ACD call for 12 minutes and 50 seconds.

**Figure 7-3 Agent State by Position - viewing multiple agent IDs**
Agents can log on to the telephone system using only one agent ID at a time. If your agents have multiple voice IDs (and therefore multiple cells) the Agent State by Position monitor becomes cluttered.

If you have agents who are cross trained to answer calls for different departments (and log in and out of various voice queues) the telephone system requires you assign the agents multiple IDs. You can use the Agent State by Position monitor to view the activities of each department. You create an Agent State by Position monitor for each department. When you arrange the cells for the agents in the same order for each department, you can easily compare the activities of one department with another. See “Viewing web pages” on page 204.

**Viewing the current logged on states of agents who log on to multiple queues**

If you have voice agents who are cross trained to answer calls for different departments (and log in and out of several queues) the telephone system requires you assign the agents multiple IDs. If a voice agent has multiple agent IDs and you want to view the agent’s current logged on state only, you use the Employee State by Position monitor. For example, agent Andre Bourque answers calls for English, French, and Spanish queues. In the YourSite database you assign him three agent IDs (one for each queue for which he answers calls) and an employee ID.

To view the monitor, you open the Employee State by Position monitor and select employees to add to the monitor. The monitor shows one cell for Andre, listing his current state and agent ID. (See Figure 7-4.)

**Figure 7-4  Employee State by Position - viewing the ID to which the agent is logged on**

Andre is currently logged on to Extension 1104 using Agent ID 2001. Sometime later you notice Andre is logged on to Extension 1119 using Agent ID 2009. (See Figure 7-5.)

**Figure 7-5  Employee State by Position**
Viewing extensions

In your business, you may be monitoring:

- Traditional or hot desking ACD agents who sit at different desks each day and who log on using their agent ID
- General business, traditional extensions (non-contact center employees) who sit at the same desks each day, are assigned their own desk phone extensions, and do not log on to their phones (their phones are programmed with their personal settings and are always active)
- General business, hot desking extensions (non-contact center employees) who log on to any phone in the enterprise with a virtual extension configured with their personal settings. When the employee logs on to the extension becomes active. When the employee logs off of the extension it goes out of service.

You can set up your real-time monitor profile to include two or more Extension by Position monitors: one with cells that are arranged to show the whereabouts of agents in your contact center, and another that shows the status of general business extensions: active/inactive, inbound/outbound.

Extension Inbound

*Extension Inbound* refers to a general business extension on an inbound call.

Extension Outbound

*Extension Outbound* refers to a general business extension on an outbound call.

General business active extension

*General business active extension* refers to a Mitel desk phone/Contact Center PhoneSet Manager/Contact Center Softphone that is live with no ACD agents logged on (active extension), or an extension to which a general business hot desking user is logged on. The user is an active extension not logged on to any ACD queue.

General business inactive extension

*General business inactive extension* refers to a Mitel desk phone that has been unplugged or is damaged, or a soft phone that is not running because the computer is turned off or Contact Center Client is not running, or a hot desking extension to which nobody is logged on.

Traditional or hot desking ACD agents who sit at different desks each day

If you have traditional or hot desking ACD agents who sit at different desks each day, you use the Extension State by Position monitor to view where they are sitting in the contact center. After you add Registration Directory Numbers (RDNs)/desk phone extensions to the monitor, you can arrange the cells to match the layout of your contact center.

When nobody is logged on to a particular extension, the monitor cell displays the General business active icon and the phone set RDN ID. When an agent logs on to the desk phone, the monitor cell displays the ACD agent status, (which can include information such as the time in state, queue reporting number, and Make Busy status), the agent ID, the agent name, and the RDN (at the bottom of the cell). Depending on the agent’s current state you may see additional information, such as the time in state, queue reporting number, or Make Busy status. If the Caller ID card design is selected, you will also see the caller name and phone number. (See Figure 7-6.)

If you would prefer that Extension State by Position monitor cells be blank when there are no agents logged on to the telephone system, you can right-click the monitor, select Properties, and clear the Enable the general business view check box.
If an agent cell in a monitor is grayed out, the phone is not connected to the network and considered out of service. The out of service state applies to phones that are not connected to the network, Teleworker employees that have lost their Internet connection, phones that are physically disconnected or malfunctioning, or employees that are not logged into their soft phone.

**Figure 7-6 Extension State by Position**

![Figure 7-6 Extension State by Position](image)

**General business, traditional extensions who sit at the same desks each day**

If you have general business, traditional extensions who sit at the same desks each day, you use the Extension State by Position monitor to view where they are sitting in the contact center. After you add their extensions to the monitor, you can arrange the cells to match the layout of your business, or arrange them alphabetically or by department.

When a general business employee is in Idle, the cell for the employee’s phone extension in the Extension State by Position monitor displays the employee’s name and extension number, and the General business active icon. When the employee is on an incoming/outgoing call, the cell displays the Extension Inbound/Extension Outbound icon, the employee’s name and extension number, and the time in state. If the Caller ID card design is selected, you will also see the caller name and phone number. Either card enables you to readily determine the online and phone availability of general business subject matter experts.

**General business hot desking employees who sit at different desks each day**

General business, hot desking extensions can log on to any phone in the enterprise and access their personal settings. When adding extensions to the Extension State by Position monitor, you can arrange them alphabetically or by department.

When an employee is logged on, the monitor cell displays the General business active icon, the employee’s name and extension. When the employee is on an incoming/outgoing call, the cell displays the Extension Inbound/Extension Outbound icon and the time in state. If the Caller ID card design is selected, you will also see the caller name and phone number. When the employee logs off, the monitor cell is grayed out (inactive). (See Figure 7-7.)

**Figure 7-7 Extension State by Position**

![Figure 7-7 Extension State by Position](image)
Agent State and Employee State by Time

The Agent State by Time and Employee State by Time monitors provide real-time agent information under ACD, Idle, Non ACD, Unavailable, and Logged Off column headings. They display the same real-time information as that of the Agent State by Position, Employee State by Position, and Extension State by Position monitors. See “Agent, Employee, and Extension State by Position” on page 190.

If an agent is in an email, chat, or fax agent state, the monitors display the queue number to which the agent is logged on. Each column lists agents in order of time in state. You can specify which columns of agent statistics are displayed, and the order in which they are displayed. You can sort logged off agents by the longest logged off first. (See Figure 7-8.)

If you have agents who are cross trained to answer calls for different departments (and log in and out of various voice queues) the telephone system requires you assign the agents multiple IDs. You use the Employee State by Time monitor to view the activities of voice agents with multiple agent IDs. See “Viewing the current logged on states of agents who log on to multiple queues” on page 191.

Table 7-3 lists the Agent State by Time and Employee State by Time column headings and their associated agent states.

### Table 7-3 Agent State by Time and Employee State by Time column headings

<table>
<thead>
<tr>
<th>Category</th>
<th>Associated agent states</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>includes agents in ACD and agents in ACD Hold</td>
</tr>
<tr>
<td>Idle</td>
<td>includes agents in the Idle state</td>
</tr>
<tr>
<td>Non-ACD</td>
<td>includes agents in Non ACD, in Non ACD Hold, Outbound agents, and Outbound Hold agents</td>
</tr>
<tr>
<td>Unavailable</td>
<td>includes agents in Do Not Disturb, Make Busy, Work Timer, and Unknown</td>
</tr>
<tr>
<td>Logged Off</td>
<td>includes agents in the Logged Off state</td>
</tr>
</tbody>
</table>
Agent State by Time for Queue

The Agent State by Time for Queue monitor is a new Contact Center Client real-time monitor designed specifically for contact centers using Agent Group Presence functionality. However, the Agent State by Time for Queue monitor is available for all media server types. The Agent State by Time for Queue monitor is accessed from the Time menu in Contact Center Client and displays all agents configured in a specific Queue and agents who are on ACD calls, idle, on non-ACD calls, unavailable, logged on to the system (but not present in the queue being monitored), and logged off. (See Figure 7-9).

Figure 7-9  Agent State by Time for Queue

Table 7-4 lists the Agent State by Time and Employee State by Time column headings and their associated agent states.

Table 7-4  Agent State by Time for Queue column headings

<table>
<thead>
<tr>
<th>Category</th>
<th>Associated agent states</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD</td>
<td>includes agents in ACD and agents in ACD Hold</td>
</tr>
<tr>
<td>Idle</td>
<td>includes agents in the Idle state</td>
</tr>
<tr>
<td>Non ACD</td>
<td>includes agents in Non ACD, in Non ACD Hold, Outbound agents, and Outbound Hold agents</td>
</tr>
<tr>
<td>Unavailable</td>
<td>includes agents in Do Not Disturb, Make Busy, Work Timer, and Unknown</td>
</tr>
<tr>
<td>Logged on to system</td>
<td>includes agents who are logged on to the telephone system but not in the queue being monitored</td>
</tr>
<tr>
<td>Logged Off</td>
<td>includes agents in the Logged Off state</td>
</tr>
</tbody>
</table>

To view the Agent State by Time for Queue monitor

1. Open and log on to Contact Center Client.
2. Click View=>Real time to view the Contact Center Client monitor icons.
3. Click the Time icon and click Agent State by Time for Queue.
4. In the left pane of the Add/Remove devices window, click Media (on agent monitors only) to sort the members by media server, click ID to sort the members by ID, or click Name to sort the members alphabetically.
   You can sort members in either ascending or descending order.
5. Under Agent groups, select agent groups to monitor and/or under Agents, select agents to monitor.
6. Under Card design, select a card design.
   Card designs specify the information displayed on agent, employee, and extension monitors. See “Viewing web pages” on page 204.
7. Click OK.
Agent Shift

The Agent Shift monitor provides running totals of statistics on individual agents for the day. You can specify which columns of statistics are displayed, rearrange columns, and sort individual columns in ascending or descending order. (See Figure 7-10.)

Figure 7-10 Agent Shift

Agent Shift column heading definitions

Table 7-5 describes the Agent Shift column headings.

Table 7-5 Agent Shift column headings

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logged On</td>
<td>the time the agent logged on</td>
</tr>
<tr>
<td>Last Event Received</td>
<td>the last time an agent performed an event (for example, answered a call)</td>
</tr>
<tr>
<td>Shift Time</td>
<td>the total shift time for the agent</td>
</tr>
<tr>
<td>ACD Time</td>
<td>the total time the agent spent on ACD calls</td>
</tr>
<tr>
<td>ACD Hold Time</td>
<td>the total time for ACD calls put on hold</td>
</tr>
<tr>
<td>Non-ACD Time</td>
<td>the total time the agent spent on non-ACD calls</td>
</tr>
<tr>
<td>Non-ACD Hold Time</td>
<td>the total time for non-ACD calls put on hold</td>
</tr>
<tr>
<td>Outbound Time</td>
<td>the total time the agent spent on outbound calls</td>
</tr>
<tr>
<td>Outbound Hold Time</td>
<td>the total time for outbound calls agents put on hold</td>
</tr>
<tr>
<td>Do Not Disturb Time</td>
<td>the total time the agent spent in the Do Not Disturb state</td>
</tr>
<tr>
<td>Make Busy Time</td>
<td>the total time the agent spent in the Make Busy state</td>
</tr>
<tr>
<td>Wrap Up Time</td>
<td>the total time the agent spent in the Work Timer state</td>
</tr>
<tr>
<td>Do Not Disturb Count</td>
<td>the number of times the agent entered the Do Not Disturb state</td>
</tr>
<tr>
<td>Make Busy Count</td>
<td>the number of times the agent entered the Make Busy state</td>
</tr>
</tbody>
</table>
Viewing queue statistics

NOTE:
- You can see queue statistics during business hours as long as the business schedule you configure in YourSite=>Schedule is consistent with your company’s hours of operation. You assign a business-hours schedule to your queues in YourSite=>Configuration, Queue=>Queue.
- When an agent receives an ACD call and fails to pick up the call after X seconds or X rings, the telephone system places the agent in Make Busy. The telephone system re-queues the call (places the call back in the same queue) and offers it to the next available agent.

The following monitors display queue statistics:
- Queue by Period
- Queue Now
- Queue Group Now

Queue by Period
The Queue by Period monitor collates queue statistics by 15-minute intervals over a 24-hour period. The monitor refreshes each time there is a change in a statistic and each 15-minute interval. The Queue by Period monitor always displays the current 15 minute interval at the top of the monitor. You can specify which columns of statistics are displayed, rearrange columns, and sort individual columns in ascending or descending order. (See Figure 7-11.)

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD Count</td>
<td>the total number of ACD calls answered by the agent</td>
</tr>
<tr>
<td>Short ACD Count</td>
<td>the total number of ACD calls answered that lasted less than 20 seconds</td>
</tr>
<tr>
<td>Hold ACD Count</td>
<td>the number of times the agent put ACD calls on hold</td>
</tr>
<tr>
<td>Non-ACD Count</td>
<td>the total number of non-ACD calls answered by the agent</td>
</tr>
<tr>
<td>Non-ACD Hold Count</td>
<td>the number of times the agent put non-ACD calls on hold</td>
</tr>
<tr>
<td>Outbound Count</td>
<td>the total number of outgoing calls the agent made</td>
</tr>
<tr>
<td>Outbound Hold Count</td>
<td>the number of times the agent put outgoing calls on hold</td>
</tr>
<tr>
<td>Calls Per Hour</td>
<td>the average number of incoming ACD calls answered by the agent per hour since the beginning of the shift</td>
</tr>
<tr>
<td>Agent Unavailable %</td>
<td>the percent of time the agent was set in Do Not Disturb or Make Busy and unavailable</td>
</tr>
<tr>
<td>Average Handle</td>
<td>the average amount of time the agent spent handling ACD calls (ACD Time divided by ACD Count)</td>
</tr>
<tr>
<td>Occupancy</td>
<td>the total time the agent spent in an occupied state (occupied state excludes idle time)</td>
</tr>
</tbody>
</table>
### Figure 7-11 Queue by Period

<table>
<thead>
<tr>
<th>Interval</th>
<th>Hndl</th>
<th>Shrt</th>
<th>Abn</th>
<th>Intrfl</th>
<th>Re Q</th>
<th>% Hndl</th>
<th>% Hndl</th>
<th>% Hndl</th>
<th>% Hndl</th>
<th>Avg Time Hndl</th>
<th>Avg Time Abn</th>
<th>Avg Time Intrfl</th>
<th>Ttl Talk Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>14:00</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>00:00:00</td>
<td>00:00:00</td>
<td>00:00:00</td>
<td>00:00:00</td>
</tr>
<tr>
<td>13:45</td>
<td>2</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>00:00:04</td>
<td>00:00:00</td>
<td>00:00:27</td>
<td>00:00:27</td>
</tr>
<tr>
<td>13:30</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>00:00:22</td>
<td>00:00:00</td>
<td>00:00:10</td>
<td>00:00:10</td>
</tr>
</tbody>
</table>

### Queue by Period column heading definitions

Table 7-6 describes the Queue by Period column headings.

### Table 7-6 Queue by Period column headings

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offered</td>
<td>the total number of calls offered to the queue during the 15-minute interval</td>
</tr>
<tr>
<td>Handled</td>
<td>the total number of calls answered by agents during the 15-minute interval</td>
</tr>
<tr>
<td>Short Abandoned</td>
<td>during the 15-minute interval, the total number of calls abandoned before the short abandon time configured in YourSite</td>
</tr>
<tr>
<td>Abandoned</td>
<td>the total number of calls abandoned during the 15-minute interval before being answered by agents</td>
</tr>
<tr>
<td>Interflowed</td>
<td>the total number of calls interflowed during the 15-minute interval</td>
</tr>
<tr>
<td>Requeued</td>
<td>the total number of calls re-queued during the 15-minute interval</td>
</tr>
<tr>
<td>% Handled by 1-4</td>
<td>a count of all of the calls answered by the first, second, third, and fourth answer points during the 15-minute interval</td>
</tr>
<tr>
<td>#Handled by 1-4</td>
<td>the number of calls answered by the first, second, third, and fourth answer points during the 15-minute interval</td>
</tr>
<tr>
<td>Total Talk Time</td>
<td>the total time agents spent talking to callers during the 15-minute interval</td>
</tr>
<tr>
<td>Average Talk Time</td>
<td>the average time agents spent talking to callers during the 15-minute interval</td>
</tr>
<tr>
<td>Average Time to Handle</td>
<td>the average number of minutes callers waited before agents answered their calls during the 15-minute interval</td>
</tr>
<tr>
<td>Average Time to Abandon</td>
<td>the average number of minutes callers waited during the 15-minute interval before they abandoned their calls</td>
</tr>
<tr>
<td>Average Time to Interflow</td>
<td>the average number of minutes callers waited during the 15-minute interval before being interflowed</td>
</tr>
<tr>
<td>Service Level % Today</td>
<td>during the 15-minute interval, the percentage of calls answered within the Service Level Time specified for the queue</td>
</tr>
<tr>
<td>% Handled</td>
<td>during the 15-minute interval, the percentage of calls answered compared to the total number of calls offered to the ACD queue for the day</td>
</tr>
<tr>
<td>Wrap Up</td>
<td>the total time the agent spent in the Work Timer state during the 15-minute interval</td>
</tr>
</tbody>
</table>
NOTE:

- Contact Center Client updates Longest Waiting statistics every fifteen seconds, or more frequently as records are received from the telephone system.
- Contact Center Client obtains the Calls Waiting, Longest Waiting, and Agents Available statistics from the ACD data stream. If the telephone system has not updated Contact Center Management with ACD real-time statistics within the last 90 seconds, question marks appear in place of these statistics.
- The Average Handling Time is the Average Talk Time plus the Average Hold Time. If an agent calls a supervisor in search of more information (while the caller is on hold) and/or transfers or conferences the call, these times are added to the Average Handling Time value.
- When an agent receives an ACD call and fails to pick up the call after X seconds or X rings, the telephone system places the agent in Make Busy. The telephone system re-queues the call (places the call back in the same queue) and offers it to the next available agent.

The Queue Now and Queue Group Now monitors display the following statistics:
Calls Waiting, Longest Waiting, Agents Available, ACD, Idle, Non ACD, Outbound, Unavailable, Offered, Handled, Abandoned, Interflowed, Requeued, % Handled by 1, % Handled by 2, % Handled by 3, % Handled by 4, Average Time to Handle, Average Time to Abandon, Total Talk Time, Average Talk Time, Service Level %, % Handled, Total Queue Unavailable, Current Queue Unavailable, Offered Last Hour, Time to Handle Last Hour, % Handled Last Hour, Service Level % Last Hour, Handle Last Hour, Abandoned Last Hour, Interflowered Last Hour, Unavailable Last Hour, Average Handling Time Last Hour, Offered Last 15 Minutes, Time to Handle Last 15 Minutes, % Handled Last 15 Minutes, Service Level % Last 15 Minutes, Handle Last 15 Minutes, Abandoned Last 15 Minutes, Interflowered Last 15 Minutes, Unavailable Last 15 Minutes, Average Handling Time Last 15 Minutes, % Abandoned, % Abandoned Last Hour, % Abandoned Last 15 Minutes, Remote Calls Waiting, Remote Longest Waiting, Logged Out (5000/Axxess), Logged In Not Present (5000/Axxess), Agent Unavailable %, Wrap Up, Make Busy, Occupancy, #Handled by 1, #Handled by 2, #Handled by 3, and #Handled by 4.

On the Queue Now monitor, you can specify which columns of statistics are displayed, rearrange columns, and sort individual columns in ascending or descending order. You can expand a queue and view statistics on the agent groups associated with the queue. You can expand an agent group and view performance statistics on the agents in the group. (See Figure 7-12.)

When you open the Queue Now monitor, two new columns have been added to the Queue status section of the monitor, Logged Out and Logged In Not Present, for users with an Mitel 5000/Axxess telephone system. The Logged Out column displays the number of agents that are associated with the queue but not logged in to the queue. The Logged In Not Present column displays the number of agents that are logged into the Mitel 5000/Axxess, but not present in the queue being monitored. If you expand the Queue Now monitor to display the Agent name column, the monitor now displays agent presence in the queue. Presence is indicated by a colored star in the Present column. A green star indicates the agent is present in the queue. A grey star and grey row indicates the agent is not present in the queue.

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make Busy</td>
<td>the total time the agent spent in the Make Busy state during the 15-minute interval</td>
</tr>
<tr>
<td>Occupancy</td>
<td>the total time the agent spent in an occupied state during the 15-minute interval (occupied state excludes idle time)</td>
</tr>
</tbody>
</table>

**Queue Now and Queue Group Now**

The Queue Now and Queue Group Now monitors display the following statistics:

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make Busy</td>
<td>the total time the agent spent in the Make Busy state during the 15-minute interval</td>
</tr>
<tr>
<td>Occupancy</td>
<td>the total time the agent spent in an occupied state during the 15-minute interval (occupied state excludes idle time)</td>
</tr>
</tbody>
</table>

Table 7-6 Queue by Period column headings

**Term** | **Meaning**
---|---
Make Busy | the total time the agent spent in the Make Busy state during the 15-minute interval
Occupancy | the total time the agent spent in an occupied state during the 15-minute interval (occupied state excludes idle time)
Table 7-7 describes the real-time and over-the-business-day Queue Now and Queue Group Now statistics.

### Table 7-7  Queue Now and Queue Group Now column headings

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calls Waiting</td>
<td>the current number of callers queued up waiting for an agent to become available, including those listening to silence, music, or recorded announcements</td>
</tr>
<tr>
<td>Longest Waiting</td>
<td>the current duration, in minutes and seconds, of the call waiting the longest in queue</td>
</tr>
<tr>
<td>Agents Available</td>
<td>the current number of agents logged on and not in Do Not Disturb, Make Busy, Work Timer, Unknown, or Ringing</td>
</tr>
<tr>
<td>ACD</td>
<td>the current number of agents handling ACD calls</td>
</tr>
<tr>
<td>Idle</td>
<td>the current number of agents logged on and ready to receive calls</td>
</tr>
<tr>
<td>Non-ACD</td>
<td>The current number of agents handling non-ACD calls</td>
</tr>
<tr>
<td>Outbound</td>
<td>The current number of agents on outgoing calls</td>
</tr>
<tr>
<td>Unavailable</td>
<td>The current number of agents in Do Not Disturb, Make Busy, Work Timer, Unknown, or Ringing</td>
</tr>
<tr>
<td>Offered</td>
<td>the total number of calls offered to the queue</td>
</tr>
<tr>
<td>Handled</td>
<td>the total number of calls answered by agents for the day</td>
</tr>
<tr>
<td>Abandoned</td>
<td>the total number of calls abandoned before being answered by an agent for the day</td>
</tr>
<tr>
<td>Interflowed</td>
<td>the total number of calls interflowed for the day. Interflow is a mechanism that directs a call waiting in queue to another answer point.</td>
</tr>
<tr>
<td>Term</td>
<td>Meaning</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Requeued</td>
<td>the total number of calls re-queued for the day</td>
</tr>
<tr>
<td>Average Time to Handle</td>
<td>the average time it takes for the call to be answered by an agent</td>
</tr>
<tr>
<td>Average Time to Abandon</td>
<td>the current average duration callers wait before abandoning calls</td>
</tr>
<tr>
<td>Average Talk Time</td>
<td>The current average time agents spend talking to callers</td>
</tr>
<tr>
<td>Service Level %</td>
<td>the percentage of calls answered within your Service Level Time value over the day</td>
</tr>
<tr>
<td>% Handled</td>
<td>the percentage of calls answered compared to the total number of calls offered to the ACD queue for the day</td>
</tr>
<tr>
<td>% Handled by 1-4</td>
<td>the percentage of all of the calls answered by the first, second, third, and fourth answer points</td>
</tr>
<tr>
<td>#Handled by 1-4</td>
<td>the number of calls answered by the first, second, third, and fourth answer points</td>
</tr>
<tr>
<td>Total Talk Time</td>
<td>The current total time agents spend talking to callers</td>
</tr>
<tr>
<td>Current Queue Unavailable</td>
<td>the total number of callers that were rerouted after you set the queue to Unavailable. When you make the queue available again, this value resets to zero.</td>
</tr>
<tr>
<td>Total Queue Unavailable</td>
<td>the total number of times during the day callers dialed the queue and were rerouted because no agents were logged on to the queue or you set the queue to Unavailable</td>
</tr>
<tr>
<td>Offered Last Hour</td>
<td>the total number of calls offered to the queue in the last hour of business</td>
</tr>
<tr>
<td>Time to Handle Last Hour</td>
<td>the predicted duration callers, who call in the last hour of business, wait before being answered by an agent</td>
</tr>
<tr>
<td>% Handled Last Hour</td>
<td>the percentage of calls answered in the last hour of business, compared to the total number of calls offered to the ACD queue for the day</td>
</tr>
<tr>
<td>Service Level % Last Hour</td>
<td>the percentage of calls answered within your Service Level Time value in the last hour</td>
</tr>
<tr>
<td>Interflowed Last Hour</td>
<td>the total number of calls interflowed during the last hour of business. Interflow is a mechanism that directs a queue delayed call to voice mail or to another answering point</td>
</tr>
<tr>
<td>Handled Last Hour</td>
<td>the total number of calls answered by agents during the last hour of business</td>
</tr>
<tr>
<td>Abandoned Last Hour</td>
<td>the total number of calls abandoned during the last hour of business</td>
</tr>
<tr>
<td>Unavailable Last Hour</td>
<td>the total number of times, in the last hour of business, callers dialed the queue and were rerouted because no agents were logged on to the queue or you set the queue to Unavailable</td>
</tr>
<tr>
<td>Available Last Hour</td>
<td>the total number of times, in the last hour of business, callers dialed the queue and were answered by an agent.</td>
</tr>
<tr>
<td>Average Handling Time Last Hour</td>
<td>the average duration of calls from agent pick up to client hang up (including hold time) during the last hour of business</td>
</tr>
</tbody>
</table>
## Table 7-7  Queue Now and Queue Group Now column headings

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offered Last 15 Minutes</td>
<td>the total number of calls offered to the queue in the last 15 minutes of business</td>
</tr>
<tr>
<td>Time to Handle Last 15 Minutes</td>
<td>the predicted duration callers, who call in the last 15 minutes of business, wait before being answered by an agent</td>
</tr>
<tr>
<td>Average Handling Time Last 15 Minutes</td>
<td>the average duration of calls from agent pick up to client hang up (including hold time) during the last 15 minutes of business</td>
</tr>
<tr>
<td>% Handled Last 15 Minutes</td>
<td>the percentage of calls answered in the last 15 minutes of business, compared to the total number of calls offered to the ACD queue for the day</td>
</tr>
<tr>
<td>Service Level % Last 15 Minutes</td>
<td>the percentage of calls answered within your Service Level Time value in the last 15 minutes of business</td>
</tr>
<tr>
<td>Handled Last 15 Minutes</td>
<td>the total number of calls answered by agents during the last 15 minutes of business</td>
</tr>
<tr>
<td>Abandoned Last 15 Minutes</td>
<td>the total number of calls abandoned during the last 15 minutes of business</td>
</tr>
<tr>
<td>Interflowed Last 15 Minutes</td>
<td>the total number of calls interflowed during the last 15 minutes of business. Interflow is a mechanism that directs a queue delayed call to voice mail or to another answering point</td>
</tr>
</tbody>
</table>
| Unavailable Last 15 Minutes               | the total number of times, in the last 15 minutes of business, callers dialed the queue and were rerouted because no agents were logged on to the queue or you set the queue to Unavailable  
|                                           | See Current Queue Unavailable.                                           |
| % Abandoned                               | the percentage of calls that were abandoned. The % Abandoned = (Calls Abandoned + Calls Offered). |
| % Abandoned Last Hour                     | the percentage of calls that were abandoned in the last hour of business. |
| % Abandoned Last 15 Minutes               | the percentage of calls that were abandoned in the last 15 minutes of business. |
| Remote Calls Waiting                     | when you have more than one telephone system networked together, this is the current number of calls waiting in a remote queue to be answered by agents at your site |
| Remote Longest Waiting                   | when you have more than one telephone system networked together, this is the wait time for the caller waiting the longest in a remote queue to be answered by an available agent at your site |
| Logged Out (Mitel 5000/Axxess)           | the number of agents that are associated with the queue but not logged in to the system |
| Logged In Not Present (Mitel 5000/Axxess) | the number of agents that are logged into the Mitel 5000/Axxess, but not present in the queue being monitored |
| Agent Unavailable %                      | the percent of time the agent was set in Do Not Disturb or Make Busy and unavailable |
NOTE:

• You can see queue charts during business hours as long as the business schedule you configure in YourSite=>Schedule is consistent with your company’s hours of operation. You assign a business-hours schedule to your queues in YourSite=>Configuration=>Queue=>Queue.

The following charts display queue statistics:

• Queue Now
• Queue Group Now
• Queue Performance by Period
• Queue Group Performance by Period

### Queue Now and Queue Group Now

The Queue Now and Queue Group Now (Integer) charts show the total calls Handled, Abandoned, and Interflowed across queues and queue groups for the day. (See Figure 7-13.)

### Figure 7-13  Queue Now (Integer) chart

<table>
<thead>
<tr>
<th>Queue Now</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>3</th>
<th>2</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message Centre</td>
<td>Careers</td>
<td>Webmaster</td>
<td>Info</td>
<td>Support</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wrap Up</td>
<td>the total time the agent spent in the Work Timer state</td>
</tr>
<tr>
<td>Make Busy</td>
<td>the total time the agent spent in the Make Busy state</td>
</tr>
<tr>
<td>Occupancy</td>
<td>the total time the agent spent in an occupied state (occupied state excludes idle time)</td>
</tr>
</tbody>
</table>

### Viewing queue chart statistics

NOTE:

Queue Performance by Period and Queue Group Performance by Period

The Queue Performance by Period and Queue Group Performance by Period charts show the calls Handled, Abandoned, and Interflowed across 15-minute intervals for queues and queue groups. (See Figure 7-14.)
Figure 7-14 Queue Performance by Period chart

Viewing web pages

While using Contact Center Client, you can view web pages using the Web browser monitor.

To view a web page within Contact Center Client

1. Click View=>New Web Browser.
   The Web Browser Properties window opens.
2. After Monitor title, type a name for the monitor.
3. After Start URL, type the Web address of the website to view.
   NOTE: The website address must begin with http:// or you will not be able to view the monitor.
4. Optionally, select a value for the Web Browser refresh rate.
5. Click OK.

Viewing and customizing real-time monitors

NOTE:
- Contact Center Client has a tabbed interface for managing and arranging windows. You can dock the monitors, displaying them on overlapping tabbed panels to maximize real estate. This enables you to readily navigate between monitors.
- You can save threshold settings and display characteristics you define for monitors. When you click File=>Save, Contact Center Client saves all open monitors under one profile name. You can click File=>Open to open another profile, or File=>New to create a new profile.
Opening monitors

**NOTE:** If you are upgrading to Contact Center Management Version 5.4, before you can select the Caller ID card on the Add/Remove devices window of agent, employee, and extension monitors, you must make the card available. To do so, right-click an open monitor, select the Caller ID card under Properties, Layout=>Card design and click Apply.

To view statistics on your desktop in Contact Center Client

1. Click View=>Real time to view the Contact Center Client monitor icons.
2. Click the Position icon and click Agent State by Position.
   See Figure 7-15.
3. In the left pane of the Add/Remove devices window, click Media (on agent monitors only) to sort the members by media server, click ID to sort the members by ID, or click Name to sort the members alphabetically.
   You can sort members in either ascending or descending order.
4. Under Agent groups, select agent groups to monitor and/or under Agents, select agents to monitor.
5. Under Card design, select a card design.
   Card designs specify the information displayed on agent, employee, and extension monitors.
   See “Viewing web pages” on page 204.
6. Click OK.
7. Repeat steps 2 to 6 to open the Queue Now monitor.

![Figure 7-15 Add/Remove devices](image)

Docking monitors

You can dock monitors and readily navigate between them. You can dock a monitor to the top, bottom, left, or right of another monitor. Alternatively, you can dock a monitor on the top, bottom, left, or right side of the Contact Center Client window. You can dock monitors on top of one another, displaying them on overlapping tabbed panels to maximize real estate.

To dock a monitor on top of another monitor

1. Right-click the title bar of an open monitor and select Dock.
2. Repeat step 1 for all open monitors.
3. Click the title bar of a monitor and drag the monitor on top of a second monitor placing your cursor in the center of the four-headed arrow that appears.
   See Figure 7-16.
4. Release the mouse button.
   Your monitors are displayed on overlapping tabbed panels.
   See Figure 7-17.

Figure 7-16 Docking monitors

Figure 7-17 Docked monitor
Adding and removing devices

You can add and remove devices from all of the Contact Center Client monitors except for the chart monitors.

To add devices to the bottom of a monitor

1. Right-click an open monitor and click Add/Remove devices.
2. Under Agent/Employee/Queue groups, select additional agent, employee, or queue groups to add to the monitor, or under Agents/Employees/Queues, select additional agents, employees, or queues to add to the monitor.
3. Click OK.

On the Agent State by Position, Employee State by Position, and Extension State by Position monitors a blank row of cells separates the original agents from those you just added. To remove the blank row you must sort the monitor. See “Sorting monitor devices” on page 207.

To remove devices from a monitor

1. Right-click an open monitor and click Add/Remove devices.
2. Under Agents/Employees/Queues, clear the check boxes of the agents, employees, or queues you want to remove.
3. Click OK.

Sorting monitor devices

When you select devices to display on a monitor, you can specify the devices be sorted by media server (on agent monitors only), ID, or name (alphabetically) in ascending or descending order. When the monitor opens, the devices will appear in the order you selected.

To sort the devices displayed on a monitor

- In the left pane of the Add/Remove devices window, click Media to sort the members by media server, click Name to sort the members alphabetically, or click Reporting to sort the members by ID, in either ascending or descending order.

You can sort information by state, name, or extension on the Agent State by Position, Employee State by Position, and Extension by Position monitors.

To sort agents or employees by state

- Right-click a monitor and click Sort monitor=>By state.

If you sort agents by state, Contact Center Client displays the agents by state and time in state across the monitor in the following order:

- Ringing
- ACD
- ACD Hold
- Idle
- Non-ACD
- Non-ACD Hold
- Outbound
- Outbound Hold
- Do Not Disturb
- Make Busy
- System Make Busy
- Work Timer
- Unknown
- Logged Off
To sort agents or employees by name
• Right-click a monitor and click Sort monitor=>By name.

To sort agents or employees by extension
• Right-click a monitor and click Sort monitor=>By extension.

Rearranging cells
You can rearrange cells on the Agent State by Position, Employee State by Position, and Extension State by Position monitors.

To rearrange cells
• On an open monitor, drag a cell to a different position on the monitor.

You can rearrange columns on the Agent Shift, Queue by Period, Queue Now, and Queue Group Now monitors.

To rearrange columns
1. Right-click an open monitor and click Properties.
2. Click the Layout folder.
3. Click Column order.
4. Click a column header and click the up or down arrow key to change the position of the column relative to other columns on the monitor.

Setting monitor dimensions
You can specify the numbers of rows and columns of cells to display on the Agent State by Position, Employee State by Position, and Extension by Position monitors. You can then adjust the table to fit within the monitor frame.

To set table dimensions
1. Right-click a monitor and click Set table dimensions.
2. After Columns, type a number.
3. After Rows, type a number.
4. Click OK.
   Columns or rows are added or deleted from the monitor. You can redistribute the cells using a drag-and-drop operation.

To size the table to fit the frame
• Right-click in any real-time monitor and select Size table to frame.

Hiding monitor columns
On the Agent Shift, Queue by Period, Queue Now, and Queue Group Now monitors, you can hide specific columns of statistics.

To hide columns
1. Right-click an open monitor and click Properties.
2. Click the Layout folder.
3. Click Column order.
4. In the Visible column, clear the check boxes of the columns you want to hide from view.
Filtering device variables

On the Queue Now, Agent Shift, Queue by Period, and Queue Group Now monitors, you can filter specific device variables. For example, on the Queue by Period monitor, you could filter the Calls Offered variable and display statistics for the intervals during which the queue was offered five or more calls.

To filter variables

1. Right-click a monitor and click Filter device variables.
2. Click Filter data to show, select a variable, select an operand, and type a number.
3. Click OK.
   A subset of the data is displayed based on the conditions defined in the filter.

Setting alarms

You can define alarms to alert you to significant changes in contact center activity. Using the alarms, you specify performance thresholds for contact center elements, such as queues and agents.

Client alarms are specific to each computer. To notify you that performance thresholds are not being met, you can configure alarms so that

- Monitor cells and statistics change color.
- A pop-up notification appears on your desktop.
- A sound prompt, such as a beep or .wav file, plays.
- You are notified by email.
- Contact Center Client appears on top of all open applications.

To configure alarms for real-time monitors

1. Add performance thresholds.
2. Specify threshold colors.
3. Specify threshold notification.

Adding performance thresholds

To add performance thresholds so you can monitor alarms

1. Right-click a monitor and click Set alarms.
   The Set alarms window appears.
   **NOTE:** You can select the Apply the alarm thresholds to all devices displayed on the monitor check box to apply the threshold settings for performance variables across all queues or agents. Alternately, you can select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for a performance variables to a list of queues or agents.
2. Under Devices, select one or more queues or agents or select the Select all check box to select all queues or agents.
3. In the Performance variables list, select a variable.
4. Under Alarm Thresholds, click Add threshold and type a value for the upper boundary of the threshold.
   The lower boundary cannot be modified. The lower boundary of the next threshold is always slightly greater than the upper boundary of the previous threshold.
5. Click OK.
Specifying performance threshold colors

To configure performance threshold colors

1. For the alarm threshold for which you want to specify colors, under **Background**, click the arrow.
   A color palate appears.
2. Select a color.
3. Under **Font color**, click the arrow.
   A color palate appears.
4. Select the font color for the alarm threshold.
5. Click **OK**.

Specifying threshold sound notification

To configure performance threshold sound notification

1. For the alarm threshold for which you want to be notified by a sound, under **Sound**, select the check box.
   The Sound window appears.
2. Specify the alarm triggering properties.
3. Specify the sound you want played when the alarm is triggered.
4. Click **Save**.

To configure performance threshold pop-up window notification

1. For the alarm threshold for which you want to be notified by a pop-up window, under **Pop-up**, select the check box.
   The Pop-up window appears.
2. After **Duration**, type the number of seconds you want the pop-up alarm to be displayed when threshold conditions are satisfied.
3. If you want to display the pop-up alarm on top of all of the other applications, select the **Keep this message visible on mouse over** check box.
4. Optionally, click the **Format font** button to specify font attributes for the pop-up alarm message.
5. In the text box, type the message for the performance threshold and click the **Add variable** button to insert performance variables. (for example, type CW P001 = <calls waiting variable>.)
6. Click **Save**.

To specify Contact Center Client appear on top of all other applications when a performance threshold is satisfied

- For the alarm threshold for which you want to be notified, under **Bring to front**, select the check box.

To configure performance threshold email notification

1. For the alarm threshold for which you want to be notified, or notify others by email, under **Email**, select the check box.
   The Email window appears.
2. After **Distribution**, specify which contacts are to be notified by email when threshold conditions are satisfied.
   See “Emailing reports” on page 262.
3. After **Subject**, type the subject of the email to be sent (for example, type Calls Wtg in Sales Queue 1 >10!).
4. In the message box, type the body of the email.
5. Click **Save**.

Consider the threshold programming in Figure 7-18. When the number of agents available in the technical support queue is between 0 and 2, the cell housing the Agents Available statistic is red. When the number of agents available is between 3 and 4, the cell turns orange. When the number of agents available is 5 or greater, the cell turns white. In addition, audible alarms and pop-up alarms appear.
To clear any current client alarms in Contact Center Client

- Right-click the monitor and click **Clear alarms**.

**Figure 7-18** Set alarms window

Customizing the information displayed on position and time monitors

On the agent, employee, and extension by position and by time monitors, real-time information is displayed in cells (cards). You can select from available card designs, or customize cards to display specific information.

When you first open an agent, employee, or extension monitor, you can select a card design on the Add/Remove device IDs window:

- The Classic card displays the agent state, time in the state, presence, agent/employee name, agent login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold).
- The Caller ID card displays the caller name and number (ANI), the number the caller/employee dials for incoming/outgoing calls, the state, time in the state, presence, agent/employee name, agent login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold).
- Custom cards you create and share

The Caller ID card is the default card design. You can use this card design, or select the Classic card or a customized card. You can create new card designs or copy existing card designs and modify them. For example, you can add or remove text and variables from cards and rearrange the information displayed. You can share card designs with other employees. When you select a card design for an agent, employee, or extension monitor, it is applied to all monitors of that type.
Selecting and customizing card designs

To select a card design
1. Right-click an open position or time monitor and click Properties.
2. Click Layout=>Card design.
3. Under Design name, select a card design.
4. Click OK.

To customize cards for position and time monitors
1. Under Card design,
   If you want to create a card design, click New.
   If you want to edit an existing card design, select a card design and click Edit.
   If you want to create a card design based on the Caller ID card or the Classic card, select either card and click Copy.
2. On the New card design window, type the name of the new card design.
   If you want to share the design with other agents, select Share design.
3. Click OK.
4. Select the card and click Edit.
   See Figure 7-19.
5. After State, select a state for the card design.
   You can use the same card design for all states or you can customize cards for specific states, such as ACD, Idle, Make Busy, and Unknown.
6. Under Fields, select a field type and drag and drop it to the card design.
   See “Agent, Employee, and Extension State by Position” on page 155.
   If you want to resize the field, click the field and use your pointer to move or resize the field.
   If you want to change the properties for a field, click the field and change the properties in the right pane of Card Designer.
   If you want to change the size of the card design preview, after Zoom, select a different magnification value from the list.
7. Add additional fields to the card.
8. Select Copy to if you want to copy the current design to the card of a different state.
9. Click OK.
10. The new card design appears on the Card design list.
    Click OK.
**Figure 7-19 Card Design Window**

![Card Design Window](image)

**Adding text to card designs**

You can use a text box to add custom text to a card.

To edit text that you have added to a card

1. Select the text box.
2. Properties appear on the right.
3. Under **Properties**, in the box to the right of **Text**, type the text to be added to the card.
4. Click **OK**.
5. Click **OK**.

**Defining monitor styles**

You can customize the appearance of individual monitor elements. For example, you can configure the font size and color of column headings or apply a skin of predefined colors and font attributes to the entire monitor.

To customize the appearance of monitor elements

1. Right-click an open monitor and click **Properties**.
2. Click **General=>General settings**.
3. If you want to change the title of the monitor, after **Title**, type a name.
4. If you want to scroll horizontally on the monitor, select the **Enable horizontal scroll bars** check box.
5. If you want to scroll vertically on the monitor, select the **Enable vertical scroll bars** check box.
6. If you want to group monitor headings, select the **Enable grouping** check box.
7. If you want to apply a skin to the monitor, click **Layout=>Monitor style**.
8. Click **Load style** and select a skin.
9. Otherwise, under **Properties**, manually configure the column settings, column font, row settings, and row-alternate settings.
10. Click **OK**.
Grouping data

You can group rows of data in the Queue Now monitor, and other monitors that contain columns. For example, you can group the data by the ACD count statistic and readily see which agents handled the most calls, and which agents handled the least calls, as illustrated in Figure 7-20.

**Figure 7-20 Enable grouping**

To enable grouping

1. Right-click an open monitor and click Properties.
2. Select the Enable grouping check box.
3. Click OK.
   The monitor displays a grouping panel.
4. Drag a column heading to the panel to group by the column heading.

Building marquee monitors

You can build a marquee monitor to broadcast statistics and messages. To do so, you must

- Specify styles for the marquee monitor.
- Configure marquee text and variables.

Configuring marquee monitor styles

To specify attributes for the marquee background

1. Click the Marquee icon.
   The Configure marquee window appears.
2. Click Add message.
   The Add message window appears.
3. Type a name for the message.
4. Under Position, select Top, Right, Left, Center, or Bottom to specify how the message is to be displayed on the marquee.
5. Click **Format marquee**.  
The Format marquee window appears.
6. After **Background color**, select a color for the background.
7. After **Cell color**, select a color for the marquee cells.
8. After **Cell size**, specify a value for the size of the marquee cells.
9. After **Cell spacing**, select a value for the space between marquee cells.
10. To specify the marquee text font type and color, click **Format font**.
11. The Font window appears.
12. Select font attributes.
13. Click **OK**.
14. If you want the message and the background of the message to be displayed using pixels, select the **Matrix style** check box.
15. Click **OK**.
16. Click **OK**.
   The marquee appears.
   You must configure marquee text and variables.
   See “Configuring marquee text and variables” on page 215.

### Configuring marquee text and variables

To configure text and variables for the marquee

1. Right-click the marquee and click **Configure marquee**.  
The Configure marquee window appears.
2. In the **Message editor** text box, type a message to display on the marquee (for example, type Calls Wtg =).
3. Under **Message editor**, click the **Add variable** button.  
The Add/Edit variable window appears.
4. Click **Add**.  
The Configure variable window appears.
5. Under **Variable types**, click the monitor type to which the variable applies.
6. Under **Variables**, click a variable.
7. Under **Devices**, select the check box of a device.
8. Under **Thresholds**, click **Add threshold** and specify a value for the upper boundary of the first threshold.
9. Click **OK**.
10. For the threshold, under **Variable**, select a color to be displayed in the marquee message string.
11. For the threshold, under **Message**, select a color for the text that will precede the variable in the marquee text string.
12. After **Type a name for the variable**, type a name.
13. Click **OK**.
14. On the **Configure marquee** window, in the **Message editor** text box, position your pointer where you want to add the variable.  
   You can add variables at the beginning, middle, or end of message strings.
15. On the **Add/Edit variable** window, double-click the variable to add it to the message string.
16. Click the **Add** variable button.
17. The **Add/Edit variable** window appears.
18. Click the **Configure transition effects** button and select the check boxes for the transition effects to be included.
19. Click **OK**.  
The marquee appears displaying the text you typed and a real-time value for the performance variable.
   You can define additional thresholds for the performance variable, and add additional variables to the marquee.
Configuring charts characteristics

You can select specific call statistics to display on queue charts.

You can right-click chart titles, axis labels, and other areas of charts to
- Edit axis label titles, including text color and font
- Edit axis labels, including text color, font, and attitude
- Define chart characteristics, including monitor lines, interlacing, legend, color, point labels, and alarms
- Define queue chart (monitor) characteristics

Defining queue chart properties

Under Chart properties, you can select general chart characteristics, such as colors and stacked effects. You can define series characteristics, such as the type of chart, the fill properties, and the shape of the bars. In addition, you can define y axis characteristics.

To define queue chart properties
1. Right-click an open queue monitor and click Chart properties.
2. On the General tab, specify general chart characteristics (colors, effects, and 3D).
3. Click the Series tab.
4. Specify series characteristics (chart style, fill style, bar type, and border style).
5. Click the Y Axis tab.
6. Specify axis scale characteristics, label characteristics, and the width and color of the axis line.
7. Click OK.

Selecting call statistics to display

Under Properties, you can select call statistics to display. For example, you can add Calls Waiting, Agents Available, Idle, and Requeued statistics to the Queue Now (Integer) chart. (See Figure 7-21.)
To select call statistics to display

1. Right-click an open queue monitor and click Properties.
2. Expand the Chart properties tree and click Series data selection.
3. Select the Series data type: Integer, Percentage, or Time.
4. Under Visible, select the check box of the data you want to add to the chart.
5. Alternatively, under Visible, clear the check box of the data you want to remove from the chart.
6. Click OK.

**Specifying the queue chart title**

Under Properties, you can specify the title of the queue chart.

To specify the queue chart title

1. Right-click an open queue chart and click Properties.
2. After Monitor title, select and delete the chart title.
3. After Monitor title, type the new queue chart title.
4. Click OK.

**Specifying x and y axis titles**

To specify an x or y axis title

1. Right-click the numbers or titles of an axis and select Edit title.
2. Type the new queue chart title and press Enter.
Enabling the x axis to scroll on queue charts
Under Properties, you can enable the x axis to scroll on queue charts. When the scroll feature is enabled, and when call statistics cannot all be displayed along the x axis due to space constraints, the x axis becomes a scroll bar. You slide the scroll bar to view all of the statistics displayed along the x axis.

To enable the x axis to scroll on queue charts
1. Right-click an open queue monitor and click Properties.
2. Expand the Chart properties tree and click General.
3. Select the Scrollable check box.
4. Click OK.

Highlighting statistics
Under Properties, you can enable the highlight feature. When the highlight feature is enabled, and when you move your cursor over a bar representing a specific call statistic, that bar is highlighted and the other bars, representing other call statistics, are dimmed.

To highlight statistics
1. Right-click the open queue monitor and click Properties.
2. Expand the Chart properties tree and click General.
3. Select the Highlight check box.
4. Click OK.

Specifying the angle of the text label for the queue chart
Under Properties, you can specify the angle of the text label for the queue chart.

To specify the angle of the text label
1. Right-click the open queue monitor and click Properties.
2. Expand the Chart properties tree and click General.
3. After Point label angle, specify the angle at which you want the text to display.
   For example, if the columns are close together, you might want to use a text label angle of 90 degrees so that the text is not crowded.
4. Click OK.

Using Contact Center Chat
Contact Center Client provides instant messaging capabilities for both supervisors and agents and is typically used by contact center employees only. Contact Center Chat provides the online chat presence of contact center employees, including Online, Offline, and Away. Agents can view the availability and presence of other contact center employees before they transfer calls or send online chat messages. (See Figure 7-22.)

Using Contact Center Chat, you can communicate essential information to one or more agents, agent groups, or supervisors quickly and securely. You can coach agents and send timely messages, such as asking an agent to delay going on break when it is busy.

NOTE:
- You must have a security role that does not restrict you from gaining access to Contact Center Chat.
- You must log on to Contact Center Client in order to send and receive online messages.
- When you receive a message it is displayed immediately on top of all open windows.

Contact Center Chat is enabled by default. If you want to disable Contact Center Chat you do so in the Contact Center Management website in YourSite=>Enterprise=>local site.
NOTE:
• In order to use Enterprise / Presence Chat integration, you must enable Contact Center Chat.
• If Contact Center Chat is disabled for a particular site all employees associated to that site will be unable to communicate with each other using Contact Center Client.

Sending an initial Contact Center Chat message
On an agent, employee, or extension monitor, you can right-click an agent’s cell and click Send instant message to send an online message to the agent.

To send a chat message
1. Double-click the Contact Center Chat toolbar.

Figure 7-22  Contact Center Chat

2. Double-click a contact.
The Conversation window appears.
3. Type a message.
4. Click Send.

To send a chat message while viewing agents on an agent, employee, or extension monitor
1. Right-click a cell in any open agent monitor and click Send instant message.
The Conversation window appears.
2. Type a message.
3. Click Send.
Adding someone to a conversation

To add someone to a conversation
1. On the Conversation window, click the Invite someone to join this conversation icon.
2. Double-click a contact to add the contact to the conversation.
3. Click Send.

Responding to a Contact Center Chat message

Agents and supervisors can receive Contact Center Chat messages only if they are logged on to Contact Center Client.

To respond to a chat message
1. Type a message.
2. Click Send.
   Contact Center Chat sends your response to all chat session participants.

Using Contact Center Client with Office Communicator

NOTE: In order to use Enterprise Presence / Chat integration, an employee’s email address, as configured in YourSite Explorer under Employee, must be the same as the SIP address configured in Live Communications Server 2005 and/or Office Communications Server 2007.

With the addition of Microsoft® Office Live Communications Server 2005, agents and supervisors use Microsoft Office Communicator as their default instant messaging client. The presence of all company employees is natively delivered in Contact Center Client. Contact center employees can view the presence of both internal and external contacts to determine if they are available to communicate. In addition to Available, Offline, and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be Right Back, and other presence indicators.

If an agent views an employee on a real-time monitor and notes the employee is online, the agent can right-click the employee and send an instant message.

Table 7-8 provides details on the presence indicators that are available when Contact Center Client is used in conjunction with Office Communicator and Mitel Enterprise Presence / Chat Integration.
## Table 7-8 Presence indicators

<table>
<thead>
<tr>
<th>Presence Icon</th>
<th>Status Text</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available</td>
<td>The contact is online and can participate in conversations. Users can manually set this status, but the next automatic state change will override this setting.</td>
<td></td>
</tr>
</tbody>
</table>
| Busy          | The contact is available, but is engaged by another activity. Possible activities include the following:  
|               | • In a Call—the contact is in a phone, voice, or video conversation.  
|               | • In a Conference—the contact is in a multi-party conversation that uses phone, voice, video, or application sharing.  
|               | • In a Meeting—the Outlook calendar shows that the contact has a scheduled meeting. |
| Do Not Disturb| The contact has assigned you an access level other than Team and has manually set their status to Do Not Disturb. |
| Urgent interruptions only | The contact has assigned you to the Team access level and has manually set their status to Do Not Disturb. |
| Away          | The contact is likely unavailable. Possible reasons include the following:  
|               | • The contact’s computer has been idle for more than the away time period setting (15 minutes by default).  
|               | **NOTE:** By default, the transition from Available to Inactive occurs after five minutes. Then, after 15 more minutes, the status changes to Away if there is still no activity on the computer.  
|               | • The contact’s Outlook calendar or Out of Office Assistant indicates that they are out of the office.  
|               | • The contact is temporarily unavailable  
|               | **NOTE:** As soon as activity is detected on the contact’s computer, Communicator automatically resets the presence status to the appropriate state.  
|               | • The contact has locked their computer.  
|               | • The contact has manually set their presence to Away or Be Right Back. |
Sending an initial message in Office Communicator

On an agent or employee monitor, you can right-click an agent or employee’s cell and click Send instant message to send an online message to the agent.

If you want to send an instant message to an employee using the Extension State by Position monitor, you must first configure the business extension in Office Communicator. See “Configuring business extensions in Office Communicator” on page 223.

To send an instant message

1. Double-click the Contact Center Chat toolbar. See Figure 7-23.

<table>
<thead>
<tr>
<th>Presence Icon</th>
<th>Status Text</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Inactive</td>
<td>The contact may be available, but their computer has been idle for more than the idle time period setting (5 minutes by default) but not long enough for the status to change to Away. Alternatively, the user’s screen saver has started. This status is set by Communicator.</td>
</tr>
<tr>
<td></td>
<td>Busy (Inactive)</td>
<td>The contact is in a meeting or in a call and the computer has been inactive for the idle time period setting (5 minutes by default) or the contact’s screen saver started while their status was Busy. This status is set by Communicator.</td>
</tr>
</tbody>
</table>
|               | Offline           | The contact is not available. Possible reasons for this include the following:  
• The contact has manually set their presence status to Appear Offline.  
• The contact has not signed into Communicator.  
• The contact has blocked you from seeing their presence status.  
• Communicator is not running on the contact’s computer. |
|               | Presence unknown  | Communicator cannot determine the status of the contact. This status is typically displayed because the contact’s presence status is stored on another computer, such as that of an organization that is not a federated partner. |
|               | Blocked           | You have blocked the contact from seeing your presence status. To the contact you have blocked, your status will display as Offline. |
2. Double-click a contact.
   The Conversation window appears.
3. Type a message.
4. Click **Send**.

To send an instant message while viewing agents on an agent, employee, or extension monitor:

1. Right-click a cell in any open agent monitor and click **Send instant message**.
   The Conversation window appears.
2. Type a message.
3. Click **Send**.

**Configuring business extensions in Office Communicator**

To configure a business extension:

1. In Office Communicator, next to the status icon, click the down arrow and select **Options**.
2. Click the **Phones** tab.
3. Click **Work Phone**.
   The Edit phone number window opens.
4. Type your extension number.
5. Click **OK**.
Adding someone to a conversation

To add someone to a conversation

1. On the Conversation window, click the Invite someone to join this conversation icon.
2. Double-click a contact to add the contact to the conversation.
3. Click **Send**.

Responding to a message in Office Communicator

To respond to a chat message

1. Type a message.
2. Click **Send**.
   Office Communicator sends your response to all chat session participants.

Hot desking

When an agent is configured as a Mitel hot desking agent, the agent can sit at any extension on the network and log on to the extension. After the agent is logged on, the agent takes control of the extension. The agent's Contact Center Client and soft phone real-time profile settings are available. Any previous associations with the extension are taken out of service. When an agent logs off, the agent disconnects from the extension and the default settings for the extension are restored automatically.

Providing Contact Center Client functionality to teleworkers

Using Teleworker Solution V4.5 or V5.0.12.0 and Contact Center Client, home-based agents and remote agents and supervisors can perform telephony functions without the use of a Virtual Private Network (VPN).

**NOTE:** For V5.0.12.0, Teleworker Solution runs as Teleworker Service on the Mitel Border Gateway.

Using Contact Center Client, they can view real-time monitors and enable real-time alarming. Teleworkers can use IP-based desk phones, automate their desk phone using Contact Center PhoneSet Manager, or use a USB headset and Contact Center Softphone.

Teleworkers and supervisors at remote locations can
- Handle calls using Contact Center PhoneSet Manager or Contact Center Softphone
- View real-time monitors and enable real-time alarming
- Perform agent actions using Interactive Contact Center
- Move calls between queues and call back abandoned callers using Interactive Visual Queue
- Perform Management functions using Interactive Contact Center
- View historical events in simulated real-time in Auditor
- View Network Monitor

Agents and supervisors must be in the office to use Contact Center Chat. Supervisors must be in the office to view Network Monitor maintenance alarms. Employees require a VPN authenticated connection or a LCS Proxy server (non-VPN connection) to view reports using Contact Center Management and the online presence of colleagues and partners using Microsoft Office Communicator in Contact Center Client.
Setting up phones for teleworkers

If you work at the office and select Remember my credentials when you log on to Contact Center Client, and then subsequently attempt to log on remotely, your log on will fail. Contact Center Client does not recognize your office IP address when you log on remotely.

**NOTE:**
- Before you set up the soft phone on your client computer, ensure your network administrator has configured your soft phone as a 5020 IP phone on the telephone system.
- Users who are upgrading to Contact Center Management Version 5.7 SP1 or greater must uninstall MiAUDI0 Desktop Edition before they use Contact Center Softphone. MiAUDI0 is now bundled in the Contact Center Management software and no longer runs as the IP Phone Emulation Service.

To set up Contact Center Softphone and Contact Center PhoneSet Manager to support Teleworker Solution, you must
1. Register your phones for use with Teleworker Solution V4.5 or V5.0.12.0.
2. Set up the soft phone to support Teleworker Solution V4.5 or V5.0.12.0.
3. Approve the Teleworker Solution V4.5 or V5.0.12.0 certificate.

Registering phones for use with Teleworker Solution

The system administrator must register your phone before you can access Teleworker Solution V4.5 or V5.0.12.0. Contact Center PhoneSet Manager treats new extensions like new phones: each time you enter a new extension you must use the dial pad to type the password (provided by your system administrator) to register the phone.

To register your phone with Teleworker Solution V4.5
1. Complete the steps listed under “Setting up Teleworker Solution on the Mitel Application Server” in the Mitel Contact Center Management Installation Guide.
2. Start Telewoker Solution V4.5.
3. Click the **Set management** tab.
4. After **Input set manually**, click **Go**.
5. For Contact Center Softphone phones, after **MAC Address**, type `a1:21:00:00:xx:xx`, where `xx:xx` is the extension.
6. For Contact Center PhoneSet Manager phones, after **MAC Address**, type the MAC address located under the agent’s Mitel phone.
7. If required, type the **ICP Name, Compression, Local streaming**, and **Packet size**.
8. Optionally, after **Set Description**, type a description of the phone.
9. Click **Save**.

To register your phone with Teleworker Solution V5.0.12.0
1. Complete the steps listed under “Setting up Teleworker Solution on the Mitel Application Server” in the Mitel Contact Center Management Installation Guide.
2. Start Teleworker Solution V5.0.12.0.
3. Click the **Devices** tab.
4. Click **Add a device manually**.
5. For Contact Center Softphone phones, after **Device ID**, type `a1:21:00:00:xx:xx`, where `xx:xx` is the extension.
6. For Contact Center PhoneSet Manager phones, after **Device ID**, type the MAC address located under the agent’s Mitel phone.
7. Specify the **Configured ICP** from the drop down menu.
8. Optionally, after **Set Description**, type a description of the phone.
9. Click **Save**.
Setting up soft phones to support Teleworker Solution

To set up Contact Center Softphone or Contact Center PhoneSet Manager for Teleworker Solution V4.5 or V5.0.12.0 support on a client computer

1. Consult your network administrator to confirm your soft phone extension number.
2. Ensure your headphone is connected.
   See “Installing the latest version of Client Component Pack” on page 43.
4. If you are installing software on the client computer for the first time, go to step 5. Otherwise, click Start=>Programs=>Mitel=>Client Role Selector.
5. Click a client role.
   • Supervisor—The Supervisor role is for supervisors and managers who monitor devices, such as agents and queues, and schedule agents.
   • Agent—The Agent role is for agents who monitor themselves and/or other agents and queues.
   • Power user—The Power user role is for employees who may perform the functions of a supervisor, agent, and administrator.
6. Click Next.
7. Select Teleworker and all other options you need, such as Contact Center Softphone.
8. Click Finish.
9. Start Contact Center Client.
10. Type your user name and password.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
11. Select the Connect using Teleworker check box.
12. Click Change Teleworker settings.
13. After Teleworker IP address, type the IP address of the Teleworker Server.
14. If you use Secure Socket Layer, select SSL.
15. After Phone MAC address, select the phone type you will use for teleworking:
   • If you have a desk phone, select Desk phone and type the MAC address located on a sticker under your desk phone.
   • If you have a soft phone, select Soft phone, type your soft phone extension number, and click Get MAC Address.
16. Click OK.
17. Click Log on.
   A message stating “Waiting for certificate approval. You may need to call your system administrator to approve the certificate.”
18. After the aforementioned message appears, call your system administrator for certificate approval.

Approving the Teleworker Solution certificate

The system administrator must approve the Teleworker Solution V4.5 or V5.0.12.0 certificate before the agent can use Teleworker Solution.

To approve the Teleworker Solution V4.5 or V5.0.12.0 certificate

1. Log on to the MAS Server.
2. In the left pane under Security, select Certificate Management. The Manage Certificates window opens.
3. Under Queued CSRs, select the certificate that needs approval.
4. Select Approve or Revoke.
Using Teleworker Solution with Contact Center Client

When a remote agent first logs on to Teleworker Solution V4.5 or V5.0.12.0, the agent accesses the MAS Server through a certificate validation process. The system administrator must approve the Teleworker Solution V4.5 or V5.0.12.0 certificate before the agent can use Teleworker Solution.

To enable home-based and remote employees to use Contact Center Client:

1. If you have not yet run Client Role Selector and selected Teleworker, do so now. See “Setting up soft phones to support Teleworker Solution” on page 226.
2. Start Contact Center Client.
3. Type your user name and password. **CAUTION:** Do not select “Remember my credentials” if you intend to work both at the office and from home.
4. Select the Connect using Teleworker check box.
5. Click Change Teleworker settings and verify the Teleworker Server IP address.
6. Click OK.
7. Click Log on.
8. If the soft phone does not start automatically, click View=>Soft phone to start soft phone. The Soft phone configuration window opens.
9. Select the Display all extensions check box.
10. Under Select an extension, select the phone extension you will use for teleworking.
11. If you have a desk phone, select Desk phone. Otherwise, select Soft phone.
12. If you want to log on automatically to the soft phone with your phone extension the next time you open the current profile, select the Remember my extension check box. You must save the current profile before you quit the soft phone for this option to work.
13. If you selected Soft phone in step 11, under Soft phone settings, configure soft phone options.
14. After Address book source for contacts, select YourSite contacts or Outlook contacts. Contact Center PhoneSet Manager and Contact Center Softphone users can access YourSite database phone extensions or Outlook Personal Contact or Global Address List phone numbers when they handle calls.
15. If you want the soft phone to log you off the telephone system automatically each time you close the soft phone, select the Automatically log off this ACD agent when closing the soft phone check box.
16. Click OK. The Contact Center Client window opens and displays the soft phone, Phone and Functions toolbars.

WallBoarder

The WallBoarder application displays real-time performance statistics and text messages on one or more Spectrum Light Emitting Diode (LED) reader boards (wall signs).

WallBoarder parameters

WallBoarder consists of site(s), sign groups, signs, sign variables, sign messages, and sign plans.
Site

At the Site level, you can

- Add sign groups to your site by clicking Add=>Sign group.
- Specify the name of the computer on which the WallBoarder Service is installed on the Edit WallBoarder Service for tab.
- Enable priority messages on the Priority message tab.
- View communications between the Enterprise Server Service and the WallBoarder Service on the Database load log tab.
- Verify the serial addresses of your wall signs on the Query signs tab.
- Add sign variables to your site by clicking Add=>Sign variable.
- Add sign messages to your site by clicking Add=>Sign message.
- Add sign plans to your site by clicking Add=>Sign plan.

Edit WallBoarder Service for tab

The Edit WallBoarder Service for tab provides the following function:

- The WallBoarder Service is installed on the following computer specifies the computer on which the WallBoarder Service is installed.

Priority message tab

**NOTE:**

- You create priority messages on the Add sign message tab.
- Priority messages override all of the other messages.

The Priority message tab provides the following function:

- *Enable this priority message for this sign group immediately* sends a message to all of the wall signs in the sign group immediately, overriding any business hour, or scheduled messages.

Database load log tab

Under Diagnostics, the Database load log tab records communications between the Enterprise Server Collector Service and the WallBoarder Service, and indicates if the WallBoarder Service has loaded the sign plan configured by the Contact Center Management user.

Query signs tab

Under Diagnostics, the Query signs tab lists the wall signs the WallBoarder Service can locate, and information relating to these signs. It displays the serial addresses of the wall signs. This can come in handy.

For example, you have connected a wall sign to Com port 3, have configured the sign and specified the com port value in WallBoarder, and have reset the wall sign, but it does not display the messages in the sign plan. Most likely, the serial address of the sign is not the same as that configured in WallBoarder. The Query signs tab displays the true serial address of the wall sign. You can easily verify the address and amend the address on the Edit sign tab for the sign.

Sign groups

**NOTE:** You must create at least one sign group in order to register wall sign addresses. You can include all of the wall signs under one sign group, or create additional sign groups. Sign groups dictate which messages are displayed by particular wall signs.

At the Sign group level, you can

- Edit sign groups on the Edit sign group tab.
- Define the wall sign refresh interval and reset wall signs on the Advanced tab.
- Add signs to your sign groups by clicking Add=>Sign.
Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique sign address. You add one or more signs to a sign group. For example, you could add Wall sign 1 to Sign group 1, and Wall signs 2 to 4 to Sign group 2. You associate each sign group with a sign plan. Using sign groups and sign plans you can display the same message on one or more wall signs, or display unique messages on all wall signs.

**Edit sign group tab**

The Edit sign group tab provides the following functions:

- **Name** lists the name of the sign group.
- **Site** is the contact center site where WallBoarder is installed.

**Advanced tab**

The Advanced tab provides the following functions:

- **Reinitialize all of the wall signs every x seconds**
  The Reinitialize all of the wall signs every x seconds field restarts all of the wall signs in the sign group (clearing all of the sign memory) at the time interval you specify.

- **Refresh all of the sign messages every x seconds**
  The Refresh all of the sign messages every x seconds field resends all of the messages to all of the wall signs in the sign group at the time interval you specify. If you see question marks [???] instead of statistics on a wall sign, this means the Enterprise Service does not have a value for the variable. There are two reasons why the Enterprise Service does not have a value for the variable: it is in the process of loading the variable or the telephone system has not sent any real-time information yet.

- **Refresh all of the ACD sign variables every x seconds**
  The Refresh all of the ACD sign variables every x seconds field updates all of the variables on all of the wall signs in the sign group at the time interval you specify.

- **Update wall signs in serial for sign messages**
  The Update wall signs in serial for sign messages check box updates the wall signs in a sign group individually for sign messages, at the refresh time interval you specify.

- **Update wall signs in serial for sign variables**
  The Update wall signs in serial for sign variables check box updates the wall signs in the sign group individually for sign variables, at the refresh time interval you specify.

- **Minimum pause time between wall sign updates is x seconds**
  After WallBoarder sends a message or variable update to a wall sign, the Minimum pause time between wall sign updates is x seconds field suspends the transmission of subsequent information to the wall sign for x seconds. Typically you select a value greater than zero only if you have a small Spectrum reader board, such as the 251C reader board.

- **Minimum display time for a message is x seconds**
  After WallBoarder sends a message to a wall sign, the Minimum display time for a message is x seconds field displays the message for a minimum of x seconds. This ensures you can view the message for a sufficient amount of time before a subsequent message appears.

- **Minimum pause time after beep is sent is x seconds**
  If you select the Beep check box on the Add sign plan tab, the wall sign produces an audible beep prior to displaying each message. It takes a few seconds for the beep to occur. Therefore, the wall sign is delayed in receiving messages by a few seconds.
  The Minimum pause time after beep is sent is x seconds field suspends the transmission of messages to the wall sign for x seconds, to accommodate the beep.
Reinitialize all of the wall signs in this sign group
The Reinitialize all of the wall signs in this sign group command restarts all of the wall signs in the sign group instantly, clearing all of the sign memory.

Apply to all of the sign groups at this site
The Apply to all of the sign groups at this site command applies the configuration values on the Advanced tab to all of the sign groups at the site.

Signs
At the Sign level, you
  - Configure sign information on the Add sign tab.
  - Configure sign connectivity information on the Connectivity tab.
  - Reset the wall sign and send a test message to the wall sign on the Tools tab.
  - Add signs to your sign groups by clicking Add=>Sign.

Add sign tab
The Add sign tab provides the following functions:

Name
The Name field specifies the name of the sign.

Sign address
The Sign address field specifies the address of the wall sign. Each wall sign has a unique address. You use a keypad provided with the master sign to set the internal addresses of your signs. The addresses distinguish wall signs for messaging purposes. If you have one wall sign only, its address is 00. If you have more than one wall sign, then the address of the master sign is 01.

NOTE: When you assign serial addresses to your Spectrum wall signs using remote or software spectrum tools, you must specify sign addresses greater than 9 as hexadecimal variants. For example, the following decimals are converted to hexadecimal: 10 = a, 11 = b, 12 = c, 13 = d, 14 = e, 15 = f.

Sign group
The Sign group field specifies the sign group to which the sign belongs.

Connectivity tab
NOTE: The default data bits, parity bit, and stop bits Com port settings for newer Spectrum IP/Serial wall signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2. If you select one set of Com port values and the wall sign does not display information, try selecting the other set of Com port values, or refer to the Spectrum documentation to verify the correct default Com port settings.

The Connectivity tab provides the following functions:
  - Com port or TCP/IP specifies the sign connectivity. The default value for Com port is 1.
  - The default value for Baud rate is 9600.
  - The default value for Data bits is 8.
  - The default value for Parity bit is None.
  - The default value for Stop bits is 1.
  - TCP specifies the TCP/IP address of the wall sign.
  - DNS specifies the name you assigned the wall sign on the network.
  - Port specifies the port number used by the wall sign.
  - Sign memory specifies the memory capacity of the sign (typically 32k).
  - Reset this wall sign when it does not respond and at midnight resets the wall sign. When the WallBoarder Service restarts, it queries the wall sign for the information listed on the sign Diagnostics tabs. If it does not get an answer, it resets the wall sign.
Diagnostics
Under Diagnostics, the following tabs list information pertaining to wall sign function and are used for troubleshooting purposes:

- General
- Properties
- Tool tab
- Error reporting
- Current message tabs

Tools tab
Under Diagnostics, the Tools tab displays wall sign settings and provides the following functions:
- *Reset sign* restarts the wall sign and empties the sign memory.
- *Get status* displays the latest sign diagnostics.
- *Send test message* sends a message to the wall sign to test the connectivity.

Sign variables
At the Sign variable level, you

- Associate a queue or queue group, and a performance variable with the sign variable on the Add sign variable tab.
- Define and save display characteristics for sign variables on the Advanced tab.
- Add sign variables to your site by clicking Add.

Add sign variable tab
The Add sign variable tab provides the following functions:

- *Name* specifies the name of the sign variable.
- *Site* is the contact center site where WallBoarder is installed.
- *Select a device type group* specifies the device type (queue or queue group) you will associate with the sign variable.
- *Select a device* specifies the device you will associate with the sign variable (for example, Queue Group 1).
- *Select a variable type* specifies the performance variable you will associate with the sign variable (for example, Agents on ACD).

Advanced tab
The Advanced tab provides the following functions:

- *Select display options for this variable* specifies the number of characters reserved for a performance variable in the message string. It centers, left-justifies, or right-justifies the performance variable within the variable string position.
- *Enable variable color based on these thresholds* defines color-coded alarms for performance thresholds for the variable.
Sign messages

At the Sign message level, you

- Compose, test, and save message strings displayed on wall signs on the Add sign message tab. Message strings indicate to the wall sign how messages are displayed. They are constructed of
  - Text
  - Queue and queue group performance variables (Variables)
  - Display characteristics (Position, Color, Effects, Special, and Miscellaneous)
- Add sign messages to your site by clicking Add.

Add sign message tab

The Add message tab provides the following functions:

- **Name** specifies the name of the message.
- **Site** is the contact center site where WallBoarder is installed.
- **Test message** sends the message to the wall sign so you can verify it works.

Variables

You associate a queue, queue group, or agent group, and a performance variable with the sign variable on the Variable tab. You specify display characteristics and color-coded alarm thresholds. When you incorporate a sign variable, such as Sign Variable 6, in a message string, the real-time value of the associated performance variable is displayed.

Position

The Position tab specifies the vertical position of the message string on the wall sign. If you do not specify the text position, the wall sign defaults to the fill mode. The message enters the wall sign from the upper left corner and scrolls to fill up to three rows of text. If you specify the text position, do so before you set other display features.

Color

The Color tab specifies the color of the text you type in the message string, and the color of any pre-defined text and graphics you select on the Special tab. You can specify different colors for each word in the text string. If you specify text coloring, do so after specifying text positioning, but prior to specifying other display features. Some Spectrum signs offer more color choices than other Spectrum signs. Please refer to the Spectrum product brochure for more information.

Effect

The Effects tab specifies how messages move across wall signs. If you do not specify effects, the wall sign defaults to the Automode option. Automode produces random message display formats, such as message strings that flash or roll to the left.

Special

The Special tab provides display features and illustrations you can add to message strings.

Misc

The Misc (Miscellaneous) tab specifies the speed at which WallBoarder displays message strings, the size of message string text, the display time and date, and other features.
Sign plans

The WallBoarder Service displays messages in the following order:

1. Priority messages
2. Business-hour messages
3. Scheduled messages
4. Sign plan messages
5. Default sign plan message

At the Sign plan level, you

• Create a sign plan.
• Associate the sign plan with a sign group.
• Specify up to five statements (conditions) for the sign plan on the Add sign plan tab.
• Specify the hours of operation for your business on the Business hours tab.
• Schedule messages to be displayed on the Scheduled messages tab.

When you configure a sign plan, you can configure up to five messages for a sign group. The conditions, or values, of variables dictate which message strings WallBoarder displays, and the priority in which WallBoarder displays them. If none of the conditions are satisfied, WallBoarder displays the default message on all of the wall signs. The default message can be a message congratulating agents, or informing them of an upcoming meeting or other need-to-know information.

Add sign plan tab

The Add sign plan tab provides the following functions:

• **Name** specifies the name of the sign plan.
• **Sign group** specifies the sign group to which the sign plan applies.
• **If** check boxes activate conditional messages. You can specify up to five statements (conditions). Conditions dictate which message strings WallBoarder displays, and the priority in which WallBoarder displays them.
• **Sign variable** specifies the sign variable to display for the current (active) condition.
• **Evaluates to** specifies the value, above or below which, WallBoarder displays the message string associated with the sign variable for the current condition.
• **Play message** specifies the sign message to display for the current (active) condition.
• **Beep** programs the wall sign to produce an audible beep prior to displaying a message for a satisfied condition.
• **Default message to play if no variables have triggered a message to play** specifies a default message to display on the wall sign. WallBoarder displays the message during periods when the defined conditions (“If” statements) are not satisfied for the sign group. That is, when call center performance objectives are being met.

Business hours tab

The Business hours tab provides the following functions:

• **Outside business hours display this message** specifies which message is displayed on the wall signs after business hours.
• **Business-hours schedule for this sign plan** specifies the hours of the day for the sign plan
• **Manage schedule** creates and edits business hour schedules.
• **Apply this business-hours schedule to all of the sign plans at this site** applies the schedule to all of the sign plans at your contact center site.
The Scheduled messages tab provides the following function:
  • *Play this message during these hours* specifies the message to be displayed and the schedule for displaying the message.

**NOTE:** You create schedules under YourSite=>Schedule.

**Connecting Spectrum wall signs**

**NOTE:** For detailed information on how to install Spectrum wall signs, view the Spectrum wall sign installation manuals on the Enterprise Server at <drive>:\Program Files\prairieFyre Software Inc\CCM\Websites\CCMWeb\webforms\help\online_en.

If you have multiple wall signs, you can daisy chain the wall signs together. Figure 7-24 illustrates the connectivity between the Enterprise Server and the master sign (Wall sign 1). The Enterprise Server connects to the master sign over an RS-232 25-pin cable, an RS-485 converter, and RS-485 RJ-11 cabling. The master sign connects to slave signs over RS-485 cabling. In this setup, one Enterprise Server com port is dedicated to your wall signs.

![Figure 7-24 Setting up Spectrum wall signs](image)
If you do not want to dedicate an Enterprise Server com port to your wall signs (or you simply need another computer to connect to a wall sign), you can hook up your wall sign(s) to a client computer. You click Help=>Software downloads/Installations=>Remote server installation and install a remote media server (data collection point) on a client computer. The computer connects to the master wall sign over an RS-232 25-pin cable, an RS-485 converter, and RS-485 RJ-11 cabling, as in the proceeding setup. In this setup, one client computer com port is dedicated to your wall sign(s).

The new Spectrum IP wall signs plug into a network jack on the wall, just like your network printer.

Each wall sign has a unique sign address. You add one or more signs to a sign group. For example, you could add Wall sign 1 to Sign group 1, and Wall signs 2 to 4 to Sign group 2. Keep in mind that all of the signs in the same sign group, display the same messages. You associate each sign group with a sign plan. Using sign groups and sign plans, you can display the same message on one or more wall signs, or display unique messages on all of the wall signs.

**Configuring wall signs and wall sign messages**

To configure wall signs and wall sign messages

1. For each site, select the computer on which the WallBoarder Service is installed.
2. Add sign group(s). (In the tree under Site, click Add=>Sign group.)
3. Add sign(s) to sign group(s) and send a test message to test the sign connectivity. (In the tree under Sign group, click Add=>Sign.)
4. Configure sign variables to use in sign plans. (In the tree under Site, click Add=>Sign variable.)
5. Configure sign messages to use in sign plans and test the messages. (In the tree under Site, click Add=>Sign message.)
6. Add and configure a sign plan for each sign group. (In the tree under Site, click Add=>Sign plan.)

**Selecting the computer on which the WallBoarder Service is installed**

To select the computer on which the WallBoarder Service is installed

1. Click Real time=>WallBoarder.
2. Expand the Enterprise tree and click the name of your site.
3. The Edit WallBoarder Service for tab appears.
4. See Figure 7-25.
5. After The WallBoarder Service is installed on this computer, select the computer on which the WallBoarder Service is installed.
6. Click Save.

**Figure 7-25 Edit WallBoarder Service for prairieFyre Demo tab**

<table>
<thead>
<tr>
<th>Edit wallboarder service for prairieFyre Demo</th>
<th>Priority Message</th>
<th>Diagnostics</th>
</tr>
</thead>
<tbody>
<tr>
<td>This WallBoarder Service is installed on this computer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not Assigned</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Creating sign groups

NOTE: You must create at least one sign group in order to register wall sign addresses. You can include all of the wall signs under one sign group, or create additional sign groups. Keep in mind that all of the signs in the same sign group, display the same messages.

Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique address. You set the internal sign addresses using the keypad provided with the master sign, and register the sign addresses in WallBoarder on the Sign tab.

Each sign group has one or more signs. For example, you can specify that Sign group 1 provide real-time displays for Wall sign 1, Sign group 2 provide real-time displays for Wall signs 2 to 4, and so on. You associate each sign group with a sign plan. Using sign groups and sign plans, you can display the same message on one or more wall signs, or display unique messages on all of the wall signs.

Sign groups dictate which messages are displayed by particular wall signs.

To add a sign group and specify sign group information

1. Click Real time=>WallBoarder.
2. Click the name of your site.
   The Edit WallBoarder Service for tab appears.
3. Click Add=>Sign group.
   The Add sign group tab appears.
   See Figure 7-26.
4. After Name, type the sign group name.
5. After Site, select the contact center site where WallBoarder resides.
6. Click the Advanced tab.
7. After Reinitialize all wall signs every, select a time interval for restarting all of the wall signs in the sign group.
8. After Refresh all sign messages every, select a time interval for resending all of the messages to all of the wall signs in the sign group.
   If you see question marks [???] instead of statistics on a wall sign, this means the Enterprise Service does not have a value for the variable. The Enterprise Server does not have a value for the variable because it is in the process of loading the variable, or the telephone system has not sent any real-time information yet.
9. After Refresh all ACD sign variables every, select a time interval for updating all of the variables on all of the wall signs in the sign group.
10. After Minimum pause time between wall sign updates is, select a time interval for pausing between wall sign updates.
11. After Minimum display time for a message is, select a time interval for displaying wall sign message.
12. After Minimum pause time after beep is sent in, select a time interval for pausing after a beep is sent.
13. If you want to reinitialize all of the wall signs, click Reinitialize all wall signs in this sign group.
14. To apply the preceding options to all of the sign groups, click Apply to all sign groups at this site.
15. Click Save.

Figure 7-26 Add sign group tab
Adding signs to sign groups

NOTE: You can add one or more signs to a sign group. Keep in mind that all of the signs in the same sign group, display the same messages.

To add signs and specify sign information

1. Click **Real-time=>WallBoarder**.
2. Click a sign group.
3. Click **Add=>Sign**.
   The Add sign tab appears.
4. After **Name**, type the sign name.
5. After **Sign address**, select the address for the sign (for example, type 1).
   You set the internal sign addresses using the keypad provided with the master sign, and register the sign addresses in WallBoarder in the Sign address field.
6. After **Sign group**, select the sign group to which the sign belongs.
7. Click the **Connectivity** tab.
   **NOTE:** The default data bits, parity bit and stop bits Com port settings for newer Spectrum IP/Serial wall signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2. If you select one set of Com port values and the wall sign does display information, try selecting the other set of Com port values, or refer to the Spectrum documentation to verify the correct default Com port settings.
8. If you click **Com port**, accept the default settings for Com port, baud rate, data bits, parity bit, and stop bits.
9. If you click **TCP/IP**, click **TCP** and specify the TCP/IP address of the wall sign, or click **DNS** and specify the name you assigned the wall sign on the network.
10. After **Port**, specify the port number used by the wall sign.
11. After **Sign memory**, select the memory for the sign based on manufacturing specifications.
12. Optionally select the **Reset this wall sign when it does not respond and at midnight** check box.
13. Click the **Diagnostics** tab.
14. Click the **Tools** tab.
   **See Figure 7-27.**
15. To restart the wall sign and empty the sign memory, click **Reset sign**.
16. To display the latest sign diagnostics, click **Get status**.
17. To verify the wall sign setup, type a message and click **Send test message**.
18. Click **Add=>Sign** and repeat steps 4 to 12 to add additional signs to the sign group.
19. Click **Save**.
Configuring sign variables

You define and save display characteristics for sign variables (performance variables associated with a particular queue or queue group) on the Add sign variable tab.

To configure sign variables

1. Click **Real-time=>WallBoarder**.
2. Click +, located beside **local site**.
3. Click **Sign variables**.
   The Add sign variable tab appears.
   See Figure 7-28.
4. After **Name**, type a meaningful name for the sign variable (for example, type Calls waiting - P800). The name will appear in a list of sign variables on the Message tab.
5. After **Site**, select the contact center site where WallBoarder resides.
6. After **Select a device type**, click a device type (for example, click Queue).
7. After **Select a device**, select a device (for example, select P800).
8. After **Select a variable type**, select a performance variable (for example, select Abandoned).
9. Click the **Advanced** tab.
   **NOTE**: Some performance variables require a display width of eight characters. For example, WallBoarder displays the Average Speed of Answer Today in hh:mm:ss. If you select a value less than 8 for the width, the at symbol [@] will appear on the wall sign in place of the Average Speed of Answer Today statistic.
10. After **Select display options for this variable**, click **Left**, **Center**, or **Right** to left-justify, center, or right-justify the performance variable within the variable string position, and accept the default value for the width of displayed characters.
11. Select the **Base variable color on these thresholds** check box, and specify performance thresholds for the variable.
   In this example, we selected the calls waiting in queue performance variable and P800 to associate with the Calls waiting - P800 sign variable.
12. Click **Add** and repeat steps 3 to 10 to specify other sign variables for your queues and queue groups.
13. Click **Save**.
Configuring sign messages

You compose, test, and save message strings displayed on wall signs on the Add sign message tab. Message strings indicate to the wall sign how messages are displayed. They are constructed of performance variables, text, display features, and optionally graphics.

Consider the message strings defined in Figure 7-28. WallBoarder displays the first message string on the top line [PS02-Top Line] of the wall sign. It displays the Long Call Wtg = component of the message string in red [C001-Red]. The message string flashes [MO03-Flash] across the sign at display speed 2 [MI06-Display Speed 2]. It is comprised of text you type (Long Call Wtg = ) and Sign variable 1 [VA01-Calls], that displays the real-time value for the longest waiting caller performance variable. The color of the sign variable statistic changes with the wait time of the longest waiting caller, as per the threshold settings defined on the Variable tab.

To create sign messages

1. Click Real-time=>WallBoarder.
2. Click Sign messages. See Figure 7-29.
3. After Name, type the message name (for example, type Calls Wtg - P800). The name will appear in a list of sign messages on the Plan tab.
4. After Site, select the contact center site where WallBoarder resides.
   **NOTE:** If you do not select display attributes, WallBoarder will post the message using default display attributes.
5. Click the Position, Color, Effect, Special, and/or Misc tabs and double-click display attributes to select them.
6. Type a message (for example, type Calls Wtg 800 = ).
7. Click the Variables tab and double-click a variable to select it (for example, double-click Calls waiting - P001).
8. Click Send test message. In this example, Calls Wtg P800 = appears on the wall sign followed by the real-time value for the calls waiting in queue performance variable.
9. Click Add and repeat steps 3 to 8 to create and test other sign messages.
10. Click Save.
Creating sign plans

You associate each sign group with a sign plan. Using sign groups and sign plans, you can display the same message on one or more wall signs, or display unique messages on all of the wall signs. All of the signs in a sign group display the same messages.

If you have two wall signs (that are not daisy chained together) and you want to display the same messages on both signs, you create one sign group, add both signs to it, and associate the sign group with a sign plan. The serial addresses do not need to be unique in this case, as you are communicating with each sign on a dedicated connection (for example, one sign may be connected to a comport, and the other sign to the network using IP).

You dictate the messages displayed by particular wall signs on the Add sign plan tab. You can specify up to five statements (conditions) using sign groups. Conditions dictate which message strings WallBoarder displays and the priority in which WallBoarder displays them. If none of the conditions are satisfied, WallBoarder displays the default message on all of the wall signs in the sign group. The default message can be a message congratulating agents, or a message informing them of an upcoming meeting or other need-to-know information.

Consider the conditions defined in Figure 7-30:

- The first condition specifies “If Sign variable 1 (the calls waiting in P800) exceeds 10, play Sign message 01.”
- The second condition specifies “If Sign variable 2 (the agents logged on to P008) exceeds 45 seconds, play Sign message 02.”
- The third condition specifies “If Sign variable 3 (the longest waiting caller in P008) drops below 6, play Sign message 03.”
Creating sign plans for daisy-chained signs

If your wall signs are daisy chained together and you want to display the same messages on all of the wall signs, you create one sign group, add your signs to it, and associate the sign group with a sign plan. The wall signs share the same com port, but have unique serial addresses.

If your wall signs are daisy chained together and you want to display unique messages on all of the wall signs, you must create one sign group for each sign in the chain, and associate each sign group with a unique sign plan. The wall signs share the same com port, but have unique serial addresses.

To create a sign plan

1. Click Real-time=>WallBoarder.
2. Click Sign plan. The Add sign plan tab appears. See Figure 7-31.
3. After Name, type the plan name (for example, type Sign plan - P800).
4. After Sign group, select the sign group to which you will apply the sign plan.
5. Select the If check box to define the first conditional message for the sign plan.
6. Under Sign variable, select a sign variable.
7. Under Evaluates to, specify the threshold, above or below which, a sign message is displayed.
8. Under Play message, select a sign message.
9. If you want an audible alarm to accompany the message, select the Beep check box.
10. Click the Business hours tab.
11. After Outside business hours display the following message, select a message to be displayed on the wall signs after business hours.
   NOTE: Business-hour messages override scheduled messages.
12. After Business hours schedule for the sign plan, select a schedule that defines the hours of operation for your business.
13. If you want to apply the schedule to all of the sign plans at your contact center site, select the Apply the business hours schedule to all of the sign plans at this site check box.
14. Click Save.
Activating priority messages

NOTE:

- You create priority messages on the Add sign message tab.
- Priority messages override all of the other messages.

To activate a priority message

1. Click **Real-time=>WallBoarder**.
2. Expand the Enterprise tree and click the name of your site. The Edit WallBoarder Service for tab appears.
3. Click the **Priority message** tab. See Figure 7-32.
4. To send a priority message, select the **Enable this priority message** check box and select a priority message to display on all of the wall signs at the site.
5. If you want an audible alarm to accompany the priority message, select the **Beep when this priority message is played** check box.
6. Click **Save**.

Scheduling messages

NOTE:

- You can create schedules under YourSite=>Schedule.
- Business-hour messages override scheduled messages.
You can schedule specific messages to play according to schedules.

To schedule a message

1. Click **Real-time=>WallBoarder**.
2. Expand the Enterprise tree and click **Sign plan**. The Add sign plan tab appears.
3. Click the **Scheduled messages** tab. See Figure 7-33.
4. Select a check box to activate a schedule.
5. Select the **Play this message** check box to activate the message.
6. After **Play this message**, select a message.
   **NOTE**: When you enable a scheduled message, WallBoarder displays the message on all of the wall signs in the sign group (associated with the sign plan) until you manually clear the Play this message check box.
7. After **according to this schedule**, select a schedule.
8. Click **Save**.

**Figure 7-33** Scheduled messages tab

<table>
<thead>
<tr>
<th>Add sign plan</th>
<th>Business Hours</th>
<th>Scheduled Messages</th>
</tr>
</thead>
</table>

Scheduled messages override sign plan messages during the times indicated in the schedules

- [x] Play this message
- Play this message
- Play this message

Troubleshooting real-time issues

The following information pertains to Contact Center Client, Interactive Contact Center, Teleworker Solution 4.5 and V5.0.12.0, and Enterprise Presence / Chat Integration.

Configuring ACD resiliency and ACD hot desking

**NOTE:**
- You must use either ACD hot desk agents or standard ACD agents. The use of ACD hot desk agents and standard ACD agents in the same ACD system is not supported.
- Before configuring resiliency for ACD hot desking agents, you must first configure YourSite to support resiliency. See "Adding a Multimedia Contact Center Email media server" on page 94.

For ACD hot desking agents who work in a resilient environment, you must configure all agents as ACD hot desking agents and enable resiliency for each resilient employee in YourSite Configuration.

To configure all agents as ACD hot desking agents

1. In Contact Center Management, click **YourSite=>Enterprise**.
2. Expand the Enterprise tree and select the 3300 ICP media server.
3. Under **All Contact Center PhoneSet Manager and Contact Center Softphone agents associated with this media server are**, if you have hot desking agents or ACD resilient agents or ACD resilient agents, click **ACD hot desking agents**.
4. Click **Save**.
To specify that an employee is a resilient employee

1. In Contact Center Management, click YourSite=>Configuration.
2. On the Configuration menu, click Employee=>Employee.
3. Select an employee and click Edit.
4. If the employee will be tracked and reported in real-time and reporting in a resilient environment, select the **This employee is resilient and will be tracked in real time and reporting** check box.
5. Click Save.

**Interactive Contact Center and resiliency**

When the collector is started while the telephone system is in resilient fail-over mode, Interactive Contact Center device control will not function. If this happens, the Do Not Disturb status of the queue in the Queue Now monitor will not update.

**Enabling Enterprise Presence / Chat Integration**

If you want to use Office Communicator as your default instant messaging client and view enhanced presence on real-time monitors, you must enable Enterprise Presence / Chat Integration.

To enable Enterprise Presence / Chat Integration

1. In Contact Center Management, click YourSite=>Enterprise.
2. In the Enterprise tree, click **local site**.
3. After **Chat settings**, select the **Chat enabled** check box.
4. Select the **Enable Enterprise Presence and Chat Integration** check box.

**Ensuring Contact Center Client recognizes Office Communicator users**

In some instances, Contact Center Client agent, employee, and extension monitors will display an employee’s instant message presence as Unknown even though the employee is online. The following solutions address the most common problems in displaying instant message presence on real-time monitors.

**Employee and agent monitors display instant message presence as Unknown**

If your agent or employee monitors are displaying a user’s instant message presence as Unknown even though the user is online, this means

- Live Communication Server does not recognize the user because the user’s email address in YourSite Configuration is not the same as the SIP address of the user specified on the SIP server, or
- The user is not configured as a contact in Office Communicator.

To determine the email addresses as entered on the SIP server

1. On the Live Communication Server, click **Start=>All Programs=>Administrative Tools=>Live Communication Server 2005**.
2. In the left pane, expand the tree.
3. Under **Forest=>Domain=>Live Communication servers and pools**, select your server pool.
4. Right-click **Users** and select **Export list**.
5. Save the list of SIP email addresses to a file.

To make the user known to Live Communication Server

- In YourSite=>Configuration=>Employee, verify the user’s email address is the same as the email address of the user specified on the SIP server.
To add the user as a contact in Office Communicator

- In Communicator, click **Contacts=>Add a Contact** and add the user’s email address as specified on the SIP server.

**Extension monitor displays instant message presence as Unknown**

If your extension monitor is displaying a user’s presence as Unknown even though the user’s extension is configured in YourSite Configuration, this means

- Office Communicator does not have a user associated with the extension, or
- The user is not configured as a contact in Office Communicator.

To make the extension known to Live Communication Server

1. On the Live Communication Server, browse to **Active Directory Users and Computers**.
2. In the right pane, right-click the user and select **Properties**.
3. On the **General** tab, after **Telephone Number**, type the user’s phone extension.
4. On the **Live Communications** tab, after **SIP URI**, verify the SIP email address for the user.

To add the user as a contact in Office Communicator

- In Communicator, click **Contacts=>Add a Contact** and add the user’s email address as specified on the SIP server.

**Connect using Teleworker option does not appear on log on window**

**NOTE:** You must reselect all of the applications you use every time you run Client Role Selector.

If the Connect using Teleworker option does not appear on the Contact Center Client log on window, you need to re-run Client Role Selector and select Teleworker, Soft phone, and other options you need.

1. Click **Start=>Programs=>Mitel=>Client Role Selector**.
2. Click a client role.
   - Supervisor—The Supervisor role is designed for supervisors and managers who monitor devices (for example agents and queues) and schedule agents.
   - Agent—The Agent role is designed for agents who monitor themselves and/or other agents and queues.
   - Power user—The Power user role is designed for employees who may perform the functions of a supervisor, agent, and administrator.
3. Click **Next**.
4. Select **Teleworker** and all other options you need, such as Contact Center Softphone.
5. Click **Finish**.
6. Start Contact Center Client.
7. Type your user name and password.
   **CAUTION:** Do not select “Remember my credentials” if you intend to work both at the office and from home. If you select the Remember my credentials check box, the logon screen is not offered again. If you attempt to log on remotely, you will be unable to change log on information, including Enterprise Server information, and your logon may fail.
8. Select the **Connect using Teleworker** check box.
9. Click **Change Teleworker settings**.
10. After **Teleworker IP address**, type the IP address of the Teleworker Server.
11. If you use Secure Socket Layer, select **SSL**.
12. After **Phone MAC address**, select the phone type you will use for teleworking:
   - If you have a desk phone, select **Desk phone** and type the MAC address located on a sticker under your desk phone.
   - If you have a soft phone, select **Soft phone**, type your soft phone extension number, and click **Get MAC Address**.

13. Click **OK**.

14. Click **Log on**.
   A message appears stating “Waiting for certificate approval. You may need to call your system administrator to approve the certificate.”

15. After the aforementioned message appears, call your system administrator for certificate approval.

### Contact Center Client could not connect to Teleworker Solution

If you can connect to Teleworker Solution V4.5 or V5.0.12.0 but cannot log in, Teleworker Solution V4.5 or V5.0.12.0 may have failed to create tunnels. Teleworker Solution V4.5 or V5.0.12.0 will fail to create tunnels for two reasons: either the certificate has been revoked, or something on the Teleworker Solution V4.5 or V5.0.12.0 Server has been changed, for example, the IP address.

**To bind the correct IP address to the Teleworker Solution V4.5 server**

1. Log on to the Teleworker Solution V4.5 server.
2. In the left pane under **Applications**, click **Teleworker Solution**.
3. On the **Main** tab, after **Teleworker Solution server status**, select **Enabled**.
4. If there is a list of configured ICPs on this server, select the correct IP address. Skip to step 6.
5. If there is no list of configured ICPs, after **ICP Name**, **Mitel Networks ICP address**, and **Mitel ICP type**, type the required information.
6. Click **Save**.

**To bind the correct IP address to the Teleworker Solution V5.0.12.0 server**

1. Log on to the Teleworker Solution V5.0.12.0 server and under **Applications** click **Multi protocol border gateway**.
2. On the **Dashboard** tab, after **Start or stop MBG**, click **Start**.
3. Click **Save**.
4. On the **Main** tab, after **Teleworker Solution server status**, select **Enabled**.
5. If there is a list of configured ICPs on this server, skip to step 7.
6. If there is no list of configured ICPs, click **Add an ICP**, type the required information, and click **Save**.
7. Click **Save**.

### Contact Center Client could not send the certificate request

When connecting to Teleworker Solution V4.5 or V5.0.12.0, if your Contact Center Client cannot send the certificate request or if it failed to download the certificate, it usually indicates that the Teleworker Solution V4.5 or V5.0.12.0 settings are incorrect. If your company uses Secure Sockets Layer, ensure you select SSL otherwise the certificate request/download will fail.

**To verify the Teleworker Solution V4.5 or V5.0.12.0 settings in Contact Center Client**

1. Start Contact Center Client.
2. Type your user name and password.
   **CAUTION:** Do not select “Remember my credentials” if you intend to work both at the office and from home.
3. Select the **Connect using Teleworker** check box.
4. Click **Change Teleworker settings**.
5. After **Teleworker IP address**, type the IP address of the Teleworker Server.
6. If you use Secure Socket Layer, select SSL.
7. After **Phone MAC address**, select the phone type you will use for teleworking:
   • If you have a desk phone, select **Desk phone** and type the MAC address located on a sticker under your desk phone.
   • If you have a soft phone, select **Soft phone**, type your soft phone extension number, and click **Get MAC Address**.
8. Click **OK**.

**CAUTION:** If you will be adjusting the Teleworker Solution V4.5 or V5.0.12.0 settings in the TunnelConfig.ini document, ensure you close the Contact Center Client log on window first, otherwise the settings on the log on window will over-ride your changes.

If Contact Center Client again reports that it could not send the certificate request or failed to send the certificate, verify that the settings were updated in the Teleworker Solution V4.5 or V5.0.12.0 configuration file.
1. Click **My Computer=>My Documents**.
2. Search for the **TunnelConfig.ini** document.
3. Open **TunnelConfig.ini** in Notepad.
4. Under the **[ca_settings]** section, ensure the address field shows your correct IP address, and the SSL field shows 1 if you are using SSL or 0 if you are not.
5. Click **Save**.

**Your logon failed when you tried to log on remotely**
There are multiple reasons why your log on might fail.

**You entered your IP address incorrectly**
When you first enter your Teleworker Solution V4.5 or V5.0.12.0 IP address, if you enter it incorrectly your log on will fail.

To change your IP address
1. Start Contact Center Client and attempt to log on.
2. The login fails.
3. Select the **Connect using Teleworker** check box.
4. Click **Change Teleworker settings**.
5. After **Teleworker IP address**, type the correct IP address.
6. Click **OK**.
7. Click **Log on**.

**You selected Remember my credentials from the office and tried to work remotely**
If you are an agent who works at the office and you selected Remember my credentials when you first logged on, and then you subsequently attempt to work from home, your log on will fail. Contact Center Client remembers your office IP address which is invalid if you are working from home.

To log on using Teleworker
1. Start Contact Center Client and attempt to log on.
   The login fails.
2. Verify your user name and password.
3. Click **Retry**.
   The Contact Center Client log on window appears.
4. Select the **Connect using Teleworker** check box.
5. Click **Change Teleworker settings**.
6. Click **Log on**.
Chapter 8
Reports

Understanding reports
Reporter
Scheduled Reports
Reporting Service
NOTE: As a best practice, we recommend you limit the reports you run to under 65,000 rows of data. If you need to run reports with more than 65,000 rows of data you must take the following requirements into consideration. Reports with more than 65,000 rows can only be viewed in Microsoft Excel 2007 or greater. In addition to this, you must ensure that your Enterprise Server hardware meets the minimum memory requirements. If you are running reports with more than 65,000 rows of data, we recommend you use Server Configuration 4 as the hardware and software guidelines for the Enterprise Server. For more information, see “Server Configuration 4” in the Contact Center Solutions and Call Accounting System Engineering Guide.

The Reporter and Scheduled Reports applications provide detailed performance statistics. You use Reporter to produce on-demand reports, and Scheduled Reports to automate report generation. You can generate reports for day of week, day of month, week, or 15, 30, or 60-minute intervals, and for over-midnight shifts. You can create presentation-quality tables and charts in Microsoft Excel or Adobe Acrobat .pdf format.

The prairieFyre Service analyzes the raw telephone system data with respect to the YourSite Explorer configuration details. The service then writes the statistical data to Structured Query Language (SQL). It is this statistical data that sources the reports.

Time stamps for data produced in a 5000/Axxess configuration that uses a CT Gateway are based on the Enterprise Server’s PC clock. If the 5000/Axxess configuration includes remote servers, then time stamps are based on the remote server’s PC clock. Time stamps for the 3300 ICP are based on the telephone system clock.

You can view reports in .pdf and you must install Excel on the Enterprise Server to view reports. Whether you want to view reports in .pdf or Excel, you must set up contacts and contact groups to which you will email reports.

Understanding reports

To create meaningful reports you must understand reporting concepts.

Service Level is the standard measurement of customer service because it provides the most accurate representation of the customers’ experience. An appropriate Service Level objective is one that

• Satisfies callers’ expectations for service
• Keeps abandonment in check (at less than five percent)
• Minimizes expenses and maximizes revenue

Understanding the following terms will help you define your corporate Service Level objective.

Offered

All of the contacts (calls, emails, SMS messages, chats, faxes) received by the ACD queue, regardless of how they are handled or routed, are referred to as offered contacts. Offered contacts include ACD handled contacts, abandoned (long) contacts, and interflowed (long) contacts. ACD requeued contacts, queue unavailable (path available) contacts, and abandoned (short) contacts are not considered to be offered contacts. The Erlang C equation uses offered contacts and Average Talk Time data in calculating the agents required.

Handled

Handled contacts are calls, emails, SMS messages, chats, and faxes answered by live agents. If an agent answers a call and then forwards it to another agent or supervisor before the Short Handle time threshold, the call is classified as an ACD Short Handle Call. You define a Short Handle time threshold for queues.
Abandoned

Abandoned calls are calls that do not reach agents because callers hang up. Abandoned chats are chats that do not reach agents because customers end the chat sessions before agents become available to chat. Neither emails nor faxes can be abandoned. A call is considered a Call Abandoned (Long) call when the caller hangs up after the Short Abandon time threshold. If you define a Short Abandon time of 6 seconds, and a caller hangs up after 7 seconds, the call is considered a Call Abandoned (Long) call. A call is considered a Call Abandoned (Short) call when the caller hangs up at or before the Short Abandon time threshold. You define a Short Abandon time threshold for queues.

Interflowed

Interflow is a mechanism that directs a contact (call, email, SMS message, chat, fax) waiting in queue to another answer point. When a contact has been waiting in queue for longer than the interflow time defined in the system, the contact is interflowed and the interflow timer starts. If the interflow timer expires, the contact is re-directed to yet another answer point. The interflow timer runs independently of the overflow timer.

The interflowed statistic represents the number of contacts removed from a queue and sent to another answer point. Calls Interflowed (Short) calls are calls that interflow before the Short Abandon time threshold. Calls Interflowed (Long) calls are calls that interflow after the Short Abandon time threshold.

The telephone system Dial Out of Queue feature is a user-initiated interflow feature which removes a call from queue and sends it to an alternate answer point. A Dial Out of Queue call is considered a Calls Interflowed call in the reports.

Service Level time

The Service Level time is the time used in calculating the queue service objective, such as 80 percent (Service Level percent) of contacts answered within 120 seconds (Service Level time). You specify a service objective for queues.

Service Level Count

Service Level Count = The number of contacts answered within the specified Service Level Time.

Service Level percent

Service Level Percent = Service Level Count

For calls and chats, the Service Level percent is the number of calls/chats which are handled, abandoned, and interflowed before the Service Level time, compared to the total number of calls/chats handled, abandoned, and interflowed. The Service Level percent = (Handled + Abandoned (Long) + Interflowed (Long)) within the Service Level time ÷ Total (Handled + Abandoned (Long) + Interflowed (Long)).

For emails, SMS messages, and faxes, the Service Level percent is the number of emails/SMS messages/faxes which are handled and interflowed before the Service Level time, compared to the total number of emails/faxes handled and interflowed. The Service Level percent = (Handled + Interflowed (Long)) within the Service Level time ÷ Total (Handled + Interflowed (Long)).

In Figure 8-1, the Service Level objective is to handle 80 percent of calls in less than 30 seconds. Calls that wait in queue for 60 seconds are routed to voice mail.
An appropriate Service Level objective is one that
- Satisfies customers’ expectations for service
- Keeps abandonment in check (at less than five percent)
- Minimizes expenses and maximizes revenue
- Meets with the approval and support of agents, supervisors, and senior management

**Setting the Service Level objective**

**Voice queue Service Level objective**

You set the queue Service Level objective in YourSite Explorer, YourSite, Queues (3300 ICP, 5000, or Axxess) or YourSite=>Configuration, Queue=>Queue (SX-200 or SX-2000).

The voice statistics defaults are
- Service Level percent = 80%
- Service Level time = 20 seconds
- Short abandon threshold = 6 seconds
- Short handle threshold = 20 seconds
- Overflow is set at the telephone system switch and there is no default
- Interflow is set at the telephone system switch and there is no default
- Wrap-up time is set at the telephone system switch and we recommend you set it for 1 second
Email queue service level objective
You set the email queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The email statistics defaults are
   • Service Level percent = 80%
   • Service Level time = 120 minutes
   • Short handle threshold = 20 minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center Email routing options tab.

There is no interflow default for email.

The following do not apply to email:
   • Overflow
   • Wrap-up time
   • Abandon

Chat queue service level objective
You set the chat queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The statistics defaults are
   • Service Level percent = 80%
   • Service Level time = 120 seconds
   • Short abandon threshold = 6 seconds
   • Short handle threshold = 20 minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center WebChat routing options tab.

The queue statistic default is
   • Interflow = 120 seconds

The following do not apply to chat:
   • Overflow
   • Wrap-up time

Fax queue service level objective
You set the fax queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The statistics defaults are
   • Service Level percent = 80%
   • Service Level time = 120 minutes
   • Short handle threshold = 20 minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center Fax routing options tab.
There is no interflow default for email.

The following concepts do not apply to email:

- Overflow
- Wrap-up time
- Abandon

**Report types**

For a complete description of report types and fields, see the *Mitel Contact Center Solutions Reports Guide*.

The Contact Center Management report types include voice, email (includes SMS), chat, fax, multimedia, Workforce Scheduling, and Intelligent Queue reports.

**Administrative reports**

Administrative reports consists of the Employee Profile. It provides configuration data and contact information on each employee.

**Voice reports**

Voice reports provide detailed information about call performance. Voice reports can be generated on the following devices: Employee, Agent and Agent Group, Queue and Queue group, Team, Extension, Trunk, DNIS, and Forecast.

**Lifecycle reports**

Lifecycle reports provide detailed information on all of the events related to the life of a specific call, from the moment the call enters the telephone system to call termination. You can generate Lifecycle reports on the following devices: agent, agent group, queue, queue group, DNIS, DNIS group, extension, extension group, trunk, trunk group, media server, and site. Lifecycle reports can be filtered by call direction, DNIS, trunk, queue, duration in queue, agent, Account Code, hold duration, call duration, phone number, and extension. If you have clustered your enterprise into a single site, you can run a Lifecycle report on site to report on your entire enterprise. Lifecycle reports also include call notes and links to call recordings. For detailed information on configuring Lifecycle reports, see “Configuring Lifecycle reports” in the Contact Center Management or Call Accounting Installation Guide.

**NOTE:**

- Lifecycle reports containing data for internal transferred ACD calls will not link data properly unless the Call ID feature on the telephone system is enabled.
- If you have a Network ACD environment with telephone systems in the same time zone, you must synchronize telephone system clocks to ensure Lifecycle report accuracy.

**Email reports**

Email reports provide detailed information about email or SMS performance, depending on the media the email queue is configured to handle. Email reports can be generated on the following devices: Agent, Agent Group, Queue, and Queue Group. You can generate these reports if you are licensed for Multimedia Contact Center Email.

For Version 5.7 SP1, SMS has been added as an email queue configuration option for email media servers. To avoid confusion, when configuring an email queue to handle SMS, we recommend you name the queue with a unique identifier (for example, Sales SMS Queue). This will also assist with running reports on SMS statistics, as in this release SMS is handled as email and SMS statistics appear in email reports generated on SMS queues.

**NOTE:**

- Any email statistics in reports generated on SMS queues pertain to SMS contacts
- Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS media.
Chat reports
Chat reports provide detailed information about Chat performance. Chat reports can be generated on the following devices: Agent, Agent Group, Queue, and Queue Group. You can generate these reports if you are licensed for Multimedia Contact Center Chat.

Fax reports
Fax reports provide detailed information about fax performance. Fax reports can be generated on the following devices: Agent and Agent Group. You can generate these reports if you are licensed for Multimedia Contact Center Fax.

Multimedia reports
Multimedia reports provide detailed information across media types: Voice, Email/SMS, Chat, and Fax. Multimedia reports can be generated on the following devices: Employee Group and Queue. You can generate these reports if you are licensed for Multimedia Contact Center.

Intelligent Queue reports
Intelligent Queue reports provide detailed information about Intelligent Queue performance. Intelligent Queue reports can be generated on Smart Choice Layers and Smart Choice Ports. You can generate these reports if you are licensed for Intelligent Queue.

Workforce Scheduling reports
Workforce Scheduling reports provide detailed information about schedules. Schedule reports can be generated on Agents and Agent Groups. You can generate these reports if you are licensed for Workforce Scheduling.

Real-Time Schedule Adherence reports
Real-Time Schedule Adherence reports provide detailed information about schedule adherence. Schedule adherence can be generated on Employee Groups. You can generate these reports if you are licensed for Intelligent Queue.

Call Accounting reports
Contact Center Management with Call Accounting reports provide detailed information about Agent and Queue call costing. The remaining Call Accounting and Subscriber Services reports can be found in the Call Accounting Reports Guide.

Custom Reports
Custom Reports are a collection of reports developed based on specific customer requests. You can generate these reports if your Contact Center Management license includes this type of report.

Traffic Analysis Reports
Traffic Analysis Reports provide detailed information about trunk traffic.

Recommended top-five reports
prairieFyre recommends every contact center use the following top-five reports:

Queue Performance by Period
The Queue Performance by Period report shows traffic level highs and lows and the Service Level you provide at these times. Generate this report each day and watch for trends in the traffic level, abandon rate, and Service Level.

Queue Group Performance by Queue
The Queue Group Performance by Queue report compares queues and provides information on the performance of your entire contact center.
Queue Group (Answer, Handle, Abandon) Spectrum by Queue
The spectrum reports provide valuable information on how calls are dispersed in your contact center. You can configure answer, handle, and abandon thresholds, and describe the percent breakdown by time for
- Calls Answered - Which call waited in queue for the greatest duration before an agent answered? How quickly are most calls answered?
- Calls Handled - What was the greatest duration an agent spoke to a caller? How quickly do most agents complete a call?
- Calls Abandoned - What was the greatest duration a caller waited before hanging up? What was the average time a caller waited in queue before hanging up?

Agent Group Performance by Period
The Agent Group Performance by Period report enables you to identify trends in agent group performance.

Agent Group Event by Period (hh:mm:ss)
The Agent Group Event by Period (hh:mm:ss) report enables you to compare the performance of agents who perform similar jobs. This report provides the shift time by agent, and a variety of call counts and peg counts for phone use.

Using reports to identify problems
The recommended top-five reports help you identify problems that affect your Service Level objectives. Table 8-1 and Table 8-2 address frequently asked questions.

Table 8-1: Solving problems with queue reports

<table>
<thead>
<tr>
<th>What do I watch for in the queue reports?</th>
<th>How do I find the source of the problem and resolve it?</th>
</tr>
</thead>
<tbody>
<tr>
<td>A drop in Service Level</td>
<td>When does the Service Level drop during the day?</td>
</tr>
<tr>
<td></td>
<td>1. Check the Agent Group Performance by Period report to see the distribution. How many agents were logged on throughout the day.</td>
</tr>
<tr>
<td></td>
<td>2. Examine agent talk times. Do you have a chatterbox agent?</td>
</tr>
<tr>
<td></td>
<td>3. Use Auditor to re-run events during a time interval to see exactly what each agent was doing.</td>
</tr>
<tr>
<td></td>
<td>4. Generate a forecast report with your Service Level goals to determine the number of agents required by period for the day. Compare the forecast statistics to the Average Manned Agent statistic in the Agent Group Performance by Period report. Have you scheduled enough agents to meet your Service Level objective?</td>
</tr>
</tbody>
</table>

Why are some queues not meeting their Service Level goals while others are?
- Check the Agent Group Performance by Queue report. Are some agent groups overworked?
### Table 8-1: Solving problems with queue reports

<table>
<thead>
<tr>
<th>What do I watch for in the queue reports?</th>
<th>How do I find the source of the problem and resolve it?</th>
</tr>
</thead>
<tbody>
<tr>
<td>High abandon callers</td>
<td>Why did the callers hang up?</td>
</tr>
<tr>
<td></td>
<td>1. Check the Average Delay to Abandon statistic. Did the callers hang up because they were impatient? Did callers wait a long time in queue? Were agent talk times excessive during this time? If so, why?</td>
</tr>
<tr>
<td></td>
<td>2. In Data Mining=&gt;Auditor, re-run the interval to see exactly what each agent was doing.</td>
</tr>
<tr>
<td></td>
<td>3. Generate the Queue ANI Abandon report and then call back the customers to determine why they abandoned their calls.</td>
</tr>
<tr>
<td>A high requeue count</td>
<td>Are agents forgetting to set themselves as Unavailable on their telephone sets before they leave their desks?</td>
</tr>
<tr>
<td>(because it decreases the Average Speed of Answer time and the Service Level)</td>
<td>• Check the Agent Group Performance by Period report to see which agents are experiencing requeues. Remind agents to use the Unavailable option.</td>
</tr>
</tbody>
</table>

### Table 8-2: Solving problems with agent reports

<table>
<thead>
<tr>
<th>What do I watch for in the agent reports?</th>
<th>How do I find the source of the problem and resolve it?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extremely high or low performance statistics</td>
<td>Do some agents perform 20-30% worse than other agents?</td>
</tr>
<tr>
<td></td>
<td>1. Silent monitor agents periodically to ensure they are properly trained to handle callers’ needs, and are not chatting unnecessarily.</td>
</tr>
<tr>
<td></td>
<td>2. Check Outbound or Non-ACD statistics for peg counts and times. Generate an Agent Inbound or Outbound Trace report to see a list of all calls. Are agents spending too much time on personal calls?</td>
</tr>
<tr>
<td></td>
<td>Do some agents perform 20-30% better than other agents?</td>
</tr>
<tr>
<td></td>
<td>1. High ACD/Non-ACD/Outbound call counts is not a problem if agents are maintaining high Service Levels. Silently monitor agents periodically to ensure they are providing a high quality of service, but not rushing callers.</td>
</tr>
<tr>
<td></td>
<td>2. Check the ACD Call Count &lt;20 seconds statistic in the Agent Event by Period report. Not many voice transactions can occur in less than 20 seconds. This could indicate that agents are “padding” their ACD handle statistics by prematurely terminating calls.</td>
</tr>
</tbody>
</table>
Using the Reporter application, you can generate on-demand voice reports, email/SMS reports, chat reports, fax reports, multimedia reports, Workforce Scheduling scheduling reports, and Intelligent Queue reports. You can restrict access to any or all of the reports with advanced security roles using report lists. See “Creating and applying security roles” on page 173.

SMS reports are handled as email reports in Version 5.7 SP1. To differentiate SMS contacts from email contacts in reports, we recommend you configure a queue to handle only SMS contacts and run email reports on that queue only.

**NOTE:**
- Any email statistics in reports run on SMS only queues pertain to SMS contacts
- Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS contacts.

### Reporter options

The complete list of Reporter options follows.

- **Report type** specifies the report name.
- **Start date and End date** specify the range of dates used in the report. You can pick any calendar date as the start date and any later date in the calendar year as the end date.
- **Start hour and End hour** specify the hours of the day included in the report.
- **Days to include** specifies the days of the week to include in the report.
- **Report mode** specifies the report period: 15, 30, or 60 minutes.
- **Email the report to** emails the report spreadsheet and associated graph to the email address selected in the email to list. You add contacts and contact groups to the email to list under the My options menu.
- **Print the report check box** prints the report spreadsheet.
- **Include the charts when printing** prints the report spreadsheet and the associated graph.

---

**Table 8-2: Solving problems with agent reports**

<table>
<thead>
<tr>
<th>What do I watch for in the agent reports?</th>
<th>How do I find the source of the problem and resolve it?</th>
</tr>
</thead>
<tbody>
<tr>
<td>High Unavailable statistics</td>
<td>Are agents accumulating Unavailable time and Make Busy peg counts?</td>
</tr>
<tr>
<td></td>
<td>1. Check the Agent Event by Period (hh:mm:ss) report to evaluate individual statistics. Determine how much Make Busy and Do Not Disturb (DND) time agents are logging. Be sure agents are adhering to your contact center policies regarding when to use Make Busy and Do Not Disturb. Check if your agents are using Unavailable instead of logging out.</td>
</tr>
<tr>
<td></td>
<td>2. For agents who have high Make Busy peg counts, run the Auditor application with an Agent by Time monitor for the agent group. Be sure agents are not using Make Busy to avoid being the longest idle agent or to avoid being sent the next ACD call.</td>
</tr>
<tr>
<td></td>
<td>3. Implement Make Busy with Reason functionality. Assign reasons with which agents go into Make Busy. Track Make Busy use by generating the Agent Performance by Make Busy Reason Code report.</td>
</tr>
</tbody>
</table>
Setting up contacts and contact groups
Before you generate a report, if you want to email that report, you must set up
- My email contacts, which includes personal email addresses
- My email contact groups, which includes mailing lists comprised of global contacts and My email contacts

Setting up email contacts for emailing reports
To set up groups for emailing reports
1. Click **My options**=>**My contacts**=>**My email contacts**.
   The My email contacts window opens.
2. Click **Add**.
   The Add contact window opens.
3. Type the first name, last name, and email address of the person to whom you will email reports.
4. Click **Save**.

Setting up email contact groups for emailing reports
If you intend to email the report to more than one recipient you must add the recipients to a mailing list and then associate the recipients with a group.

To set up groups for emailing reports
1. Click **My options**=>**My contacts**=>**My email contact groups**.
   The My email contacts window opens.
2. Click **Add**.
   The Add contact window opens.
3. Type the name and description of the email group to which you will email reports.
4. Click **Save**.
   The new email contact group opens on the My email contact groups window.
5. Across from the record of the contact group, click **Members**.
6. Under **Available contacts**, select the check boxes of the contacts you want to add to the group.
7. Click **Add>>**.

Generating on-demand reports
You can generate on-demand reports on licensed employees only. The number of employees you license in YourSite Configuration must be consistent with your software license.

Generating reports
**NOTE:** The only ACD stream-based report that will work with the over-midnight setting enabled is the Agent Shift by Period report.

The following steps detail how to generate a Voice Agent Group Performance by Period report.
To generate a report

1. Click **Reporter=>Voice=>Agent reports**.
   The Basic tab appears.
   See Figure 8-2.
2. After **Report type**, select the **Agent Group Performance by Period** report.
3. After **Agent group**, click one or more agent group.
   Hold down the <Shift> key or <Ctrl> key to select more than one agent group.
   **NOTE:** If you want one report that spans two days (for example, from December 3 at 9 P.M. to December 4 at 5 A.M.), then make the Start date and the End date the date the shift begins (December 3). If you make the Start date the date the shift begins (December 3) and the End date the date the shift ends (December 4), you will generate a report that spans three days (December 3 from 9 P.M. to December 5, 5 A.M.). The time span for each shift cannot exceed 24 hours.
4. After **Start date** and **End date**, specify the start and end dates for the report.
5. After **Start hour** and **End hour**, specify the start and end hours for the report.
6. After **Interval**, specify the time interval in which the statistics will appear in the report.
7. If your contact center does not operate 24 hour a day, after **Report mode**, click **Default**.
8. If you want to run a report over midnight, click **Over midnight**.
   The Over midnight report mode is most appropriate for 24-hour contact centers.
9. After **Days to include**, select the days of the week to include in the report.
10. Click the **Filter** tab.
    **NOTE:** The Filter tab is available for Forecast, Call Accounting, Lifecycle, Workforce Scheduling, and Make Busy / DND Code reports only. For all other report types, skip to step 12.
11. Specify the filtering options to include in the report.
12. Click the **Advanced** tab.
13. If you want to create a separate report for each day in the date range you selected, select the **Create one report for each day in the selected date range** check box.
15. After **Render type**, specify how you will view reports, either in Excel or PDF format.
    This option is available for Call Accounting, Lifecycle, Workforce Scheduling, and Flexible Reporting reports only.
16. If you want to email the report, select the **Email to** check box and specify to whom you will email the report:
    - A contact group, select the this contact group check box, and select a group
    - One contact only, select the this contact check box, and select a contact
    - A contact that is not listed, select the this email address check box, and type the email address
    You add contacts and contact groups to the Email to list under My options=>My contacts.
17. If you want to print the report spreadsheet, select the **Print the report** check box.
18. If you want to print the report chart, select the **Include charts when printing** check box.
19. Click **Submit**.
    The Report submitted screen appears.
20. Click **View Report Inbox**.
    The Report Inbox window opens, listing all created reports.
21. Click **View** to open a report.
    The report opens in Microsoft Excel.
Emailing reports

To email a report

1. After selecting a report to email, click the Advanced tab.
2. After Report output language, select the language of the report from the list.
3. If you want to email the report spreadsheet, under Excel distribution, select either the this contact group or this contact check box.
4. Or, if you want to email to a specific address, select the this email address check box and type the email address.
5. Click Submit.
7. Click View report inbox.
8. After Complete, click View.

Printing reports

To print a report

1. After selecting a report to print, click the Advanced tab.
2. After Report output language, select the language of the report from the list.
3. If you want to print the report spreadsheet, under Excel distribution, select the Print the report check box.
4. Click Submit.
6. Click View report inbox.
7. After Complete, click View.
Scheduled Reports

You use Scheduled Reports to automate the generation of voice, email/SMS, chat, fax, multimedia, Workforce Scheduling, and Intelligent Queue reports. You can restrict user access to any or all of the reports with advanced security roles. See “Creating and applying security roles” on page 173.

SMS reports are handled as email reports in Version 5.7 SP1. To differentiate SMS contacts from email contacts in reports, we recommend you configure a queue to handle only SMS contacts and run email reports on that queue only.

NOTE:
- Any email statistics in reports run on SMS only queues pertain to SMS contacts
- Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS contacts.

Scheduled reports options

To create a scheduled report you must complete the following options on the properties and distribution tabs.
- **Schedule name** is a user defined name to describe the contents of the schedule.
- **Schedule will run** specifies how often the report will be generated.
- **At** defines when the scheduled report will be generated.
- **Reports time span** defines the dates of the report activity to appear in the report.
- **Output language** specifies the language used in the report tables and charts.
- **Email the report to** defines the Email contact group to which you are sending the report.
- **Print the report** indicates that the scheduled report will be printed every time it is generated.

Generating scheduled reports

NOTE:
- Ensure Contact Center Client is running before you generate a report or execute a report schedule, otherwise the report or the schedule will fail.
- You can generate reports on licensed employees only. The number of employees you license in YourSite Configuration must be consistent with your software license.

To generate a scheduled report, you must follow these steps:
1. Create a report schedule.
2. Add reports to the schedule.

Creating report schedules

NOTE: If you select printing and mailing options, Reporting Service prints and emails all of the reports included in the schedule on the date the system generates the reports.

You can create schedules for Contact Center Management Reports, Contact Center Management Individual Reports, and Workforce Scheduling Schedules.

Using Contact Center Management Reports schedules, you can
- Generate reports on all contact center devices.
- Distribute reports to yourself and to a contact, a contact group, or a specific email address.

Using Contact Center Management User reports schedules, you can
- Generate reports on agents and employees.
- Distribute reports automatically to yourself and to the individuals within the agent groups, employee groups, and/or teams you select.
Using Workforce Scheduling Schedules, you can
- Generate reports on employee schedules.
- Distribute agent/employee report schedules to yourself and to individual employees associated with
  the schedules you select.

Creating Contact Center Management Report schedules

To create a schedule for Contact Center Management reports

1. Click Reporter=>Scheduled Reports.
The Contact Center Management Report schedules tab opens.
2. Click Next>>.
   See Figure 8-3.
3. After Schedule name, type a schedule name.
4. After Schedule will run, select the schedule frequency, for example, every day, every Wednesday, or
   the start of month.
   When you select the day, all of the reports associated with the schedule will be generated that day,
   every week.
5. After at, click the time of day the schedule will be activated.
   For example, if you select Wednesday at 7:00 A.M., all of the reports associated with the schedule
   will be generated every Wednesday at 7:00 A.M.
   \textbf{NOTE}: Reports are based on the data in the SQL database. We recommend you schedule your
   reports for \textit{after} the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports
   are based on the entire day's raw telephone system data.
6. After Reports time span, select a time span.
   If you select \textit{Year to date}, the report output includes all of the days from January 1 to the present
   date. If you select \textit{From given start date to current date} you will produce reports for your fiscal year.
7. Click the Distribution tab.
8. If you want to email the report to a contact group, under Excel distribution, select the Email the
   report to check box, select the this contact group check box, and then select a group.
   \textbf{NOTE}: You add contacts and contact groups to the email to list under My options=>My contacts.
9. If you want to email the report to one contact only, select the Email the report to check box, select
   the this contact check box, and then select a contact.
10. If you want to email the report to a contact that is not listed, select the Email the report to check box,
    select the this email address check box, and then type an email address.
    \textbf{NOTE}: You add contacts and contact groups to the email to list under My options=>My contacts.
11. If you want to print the report spreadsheet, under Excel distribution, select the Print the report
    check box.
12. If you also want to print the report graphs, select the Include charts when printing check box.
13. Click Save.
14. Add the reports you want to generate using the schedule you just created.
   See “Adding Contact Center Management reports to schedules” on page 266.
Creating Contact Center Management User report schedules

To create a schedule to automatically email agents/employees their reports

1. Click **Reporter=>Scheduled Reports**.
2. Click the **Contact Center Management User report schedules** tab.
3. Click **Next>>**.
   
The Properties tab opens.
4. After **Schedule name**, type a schedule name.
5. After **Schedule will run**, select the schedule frequency, for example, every day, every Wednesday, or the start of month.
   
When you select the day, all of the reports associated with the schedule will be generated that day, every week.
6. After **at**, click the time of day the schedule will be activated.
   
For example, if you select Wednesday at 7:00 A.M., all of the reports associated with the schedule will be generated every Wednesday at 7:00 A.M.
   
**NOTE:** Reports are based on the data in the SQL database. We recommend you schedule your reports for **after** the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports are based on the entire day’s raw telephone system data.
7. After **Reports time span**, select a time span.
   
If you select **Year to date**, the report output includes all of the days from January 1 to the present date. If you select **From given start date to current date** you will produce reports for your fiscal year.
8. Click the **Distribution** tab.
   
You can email reports to members of agent groups, employee groups, and teams.
9. Click the type of group(s) to which you want to email agent and employee reports.
10. Within each type of group, select the check boxes of the groups to which you will email reports.
11. Click **Save**.
12. Add reports you want to automatically distribute to the agent group(s), employee group(s) and teams you selected.
   
See “Adding agent and employee reports to Contact Center Management User report schedules” on page 266.

Creating Workforce Scheduling report schedules

To create a schedule to automatically email agents/employees their report schedules

1. Click **Reporter=>Scheduled Reports**.
2. Click the **Workforce Scheduling Schedules** tab.
3. Click **Next>>**.
   
The Properties tab opens.
4. After **Schedule name**, type a schedule name.
5. After **Schedule will run**, select the schedule frequency, for example, every day, every Wednesday, or the start of month. When you select the day, all of the reports associated with this schedule will be generated that day, every week.

6. After **at**, click the time of day the schedule will be activated. For example, if you select Wednesday at 7:00 A.M., all of the reports associated with this schedule will be generated every Wednesday at 7:00 A.M.

**NOTE:** Reports are based on the data in the SQL database. We recommend you schedule your reports for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports are based on the entire day’s raw telephone system data.

7. After **Reports time span**, select a time span. If you select **Year to date**, the report output includes all of the days from January 1 to the present date. If you select **From given start date to current date** you will produce reports for your fiscal year.

8. Click the **Distribution** tab.

9. Select the check boxes of the schedules you want to email to employees.

10. Click **Save**.

11. Add reports. See "Adding work schedules to Workforce Scheduling Schedules" on page 267.

### Adding reports to schedules

**NOTE:** Before you can add reports to a schedule, you must create and save the schedule.

### Adding Contact Center Management reports to schedules

**NOTE:** Before you can add reports to schedules, you must create and save the schedules.

To add a report to a Contact Center Management report schedule

1. On the **Manage schedule** window, click **Add report**.
2. Select a report category, for example **Queue reports**.
3. After **Report type**, select a report to add to the schedule.
4. After **Queue**, select the queue(s) for which you will generate reports.
5. After **Days to include**, select the days of the week to include in the report (for example, if you select a date range of September 1 to September 30, and select Wed and Friday as the days to include, you will produce a report for the Wednesdays and Fridays that fall between September 1 and September 30).
6. After **Start hour** and **End hour**, select a start hour and end hour for the report.
7. If you are generating an event by period report, after **Interval**, select the time interval for reporting. **NOTE:** If you want to generate a report that spans two days (for example, from December 3 at 9 P.M. to December 4 at 5 A.M.), then select December 3 for the Start date and the End date. The time span for each shift cannot exceed 24 hours.
8. After **Report mode**, select **Default** or **Over midnight**.
9. Click the **Advanced** tab.
11. Click **Submit**.

### Adding agent and employee reports to Contact Center Management User report schedules

To add agent and employee reports to a Contact Center Management User reports schedule

1. On the Manage schedule window, click **Add report**.
2. Select a report category, for example **agent reports**.
3. Under **Report type**, select the report you want to add to the schedule.
4. After **Start hour** and **End hour**, select a start hour and end hour for the report.
5. If you are generating an event by period report, after Interval, select the time interval for reporting.
6. After Report mode, select either Default or Over midnight.
7. After Days to include, select the days of the week to include in the report (for example, if you select a date range of September 1 to 30, and select Wednesday and Friday as the days to include, you will produce a report for the Wednesdays and Fridays that fall between September 1 and September 30).
8. Click the Advanced tab.
10. Click Submit.

Adding work schedules to Workforce Scheduling Schedules

To add work schedules to a Workforce Scheduling Schedule

1. On the Manage schedule window, click Add report.
2. Click Workforce Scheduling=>Workforce Scheduling Schedule reports.
3. Under Report type, select the work schedule you want to add to the schedule.
4. Click the Advanced tab.
5. After Report Output language, select a language.
6. Click Submit.

Generating scheduled reports immediately

If you want to generate your scheduled reports at a specific time (other than immediately), you specify the date and time they will be generated when you create the schedule. See “Creating report schedules” on page 263.

To generate scheduled reports immediately

1. Click Reporter=>Scheduled Reports.
2. After Select a schedule, select the schedule you want to generate.
3. Click Execute schedule now.
   The Execute schedule now window opens.
4. In the Start date and End date calendars, select start and end dates for the report.
5. Click Submit.
   The reports associated with the schedule are generated immediately and placed in your Report Inbox.

Report Inbox

The Report Inbox application displays the on-demand, scheduled, and forecast reports generated under your user name over the past 30 days. Inbox manager deletes reports from your inbox by date range.

NOTE:
- In Report Inbox, if the report status is Pending for an extended period of time, start Client Component Pack Manager and confirm the Enterprise Server IP address and your user name and password are correct.
- In Report Inbox, if Data Limit Exceeded opens, re-generate the report using a shorter time span.

Report Inbox includes
- Today’s reports displays all of the reports generated today under your user name.
- Yesterday’s reports displays all of the reports generated yesterday under your user name.
- All of your reports displays all of the reports generated under your user name over the last 30 days.
- Inbox Manager deletes reports from your inbox by date range.
**Reporter Inbox options**

Report Inbox has the following options.

- **Report type** lists the report name.
- **Media server** defines the media server used in reporting.
- **Reporting** specifies the reporting number of the device or device group as configured on the telephone system.
- **Name** is the name of the device or device group.
- **Request date** is the date and time the report was generated.
- **Status field** confirms if your report is ready. When Complete appears in the status field the report is waiting in your Report inbox. When Pending appears, the report is not ready. No data means no records were available for the parameters you specified. Failed means the report did not generate. If a report fails, the Report writer logs errors in the NT event log.
- **View** displays reports generated in Microsoft Excel.
- **Delete** deletes reports from your report inbox.

**Viewing reports**

To view report details:

1. Click **View Report Inbox** (upon submitting a report) or click **Report Inbox=>Today's reports**.
2. Select the **Automatically refresh this page every 10 seconds** check box to automatically update the Status column.
   - **Complete**: The report is waiting in your report inbox.
   - **Pending**: The report is not ready.
   - **No data**: No records were available for the parameters you specified.
   - **Data limit exceeded**: The time span selected was too great. Select a shorter time span and re-generate the report.
   - **Failed**: The report did not generate. If a report fails, Inbox Manager logs errors in the event log. Clicking Re-submit regenerates the report.
3. Click **View** to view the report spreadsheet and chart.

**Viewing call recordings**

If you use Verint or OAISYS call recording integration, you can access call recordings from Lifecycle reports. Hyperlinks to call recordings are located after the Full Name column of call segments in Lifecycle reports. (See Figure 8-4.)

**NOTE:**

- When you access a Verint call recording from a Lifecycle report, you are not required to enter log in credentials.
- The OAISYS Tracer supports the use of non-administrative user accounts to access call recordings. We recommend you create one non-administrative user account on the Tracer system and provide the log in credentials to all employees who require access to call recordings.
- When you first access the OAISYS system from the link provided in Lifecycle reports, you are presented with a log in screen. You must enter a valid set of credentials and ensure that the "Auto Login" check box is selected. This will ensure you provide your credentials the first time you access a call recording only. Close Internet Explorer and click the link in the Lifecycle report again to access the call recording.
To view a call recording

1. Run a Lifecycle report that contains call recordings.
   See “Generating reports” on page 260.
2. Click View Report Inbox (upon submitting a report) or click Report Inbox=>Today's reports.
3. After the report is complete, click View to view the Lifecycle report.
4. Click a call recording hyperlink.
   See Figure 8-4.
   If you have a Verint call recorder, you are directed to the call recording player. If you have an OAISYS call recorder, you must provide the OAISYS Tracer system credentials, select Auto Login, close Internet Explorer, and click the hyperlink to the call recording again before you can view the call recording.
5. Click Play.

Figure 8-4  Lifecycle report call recording hyperlink

<table>
<thead>
<tr>
<th>Event type</th>
<th>Type of device</th>
<th>Reporting</th>
<th>Full Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call transferred</td>
<td>Voice extension</td>
<td>1130</td>
<td>Burnett,Mike</td>
</tr>
<tr>
<td>Answer Non ACD</td>
<td>Voice extension</td>
<td>1130</td>
<td>Burnett,Mike</td>
</tr>
<tr>
<td>Hold</td>
<td>Voice extension</td>
<td>1130</td>
<td>Burnett,Mike</td>
</tr>
<tr>
<td>Hold Retrieve</td>
<td>Voice extension</td>
<td>1130</td>
<td>Burnett,Mike</td>
</tr>
<tr>
<td>Hold Retrieve</td>
<td>Voice extension</td>
<td>1130</td>
<td>Burnett,Mike</td>
</tr>
<tr>
<td>Conference start</td>
<td>Trunk</td>
<td>8112</td>
<td>Trunk 8112</td>
</tr>
<tr>
<td>Recording..</td>
<td>Voice extension</td>
<td></td>
<td>Burnett,Mike</td>
</tr>
</tbody>
</table>

Editing reports in Excel

You can graph specific data by highlighting one or more columns of data in the Excel spreadsheet and using the Excel Chart Wizard. For more information, see Microsoft Excel Help.

Deleting reports

Maintenance Service deletes any reports that are 30 days or older from your report inbox. You must save any reports you want to retain beyond 30 days to your hard drive or network directory.

Report Writer uses the following criteria to determine a report’s age. For on-demand reports, the request date governs the report’s age. For scheduled reports, the date the system generates the report governs the report’s age. Inbox manager does not delete reports you schedule to generate in the future.

To delete all of the reports submitted on a given date

1. Click Report Inbox=>Inbox manager.
2. Select fixed dates or a date range for deleting reports.
3. Select the status type(s).
4. Click Delete.
   The Inbox manager deletes all of the reports submitted on the date(s) you specified.
Configuring user printer settings

All email and network printing is handled from the Enterprise Server. Local printing is handled from the client computer. If you want to print to a private desktop printer, you must configure the Employee user account (YourSite Explorer=>YourSite=>Employee, on the User account tab) and you must run the Contact Center Client on the client machine where the printer resides.

To configure a network printer

1. Click YourSite=>Configuration.
2. Click Edit in the row of the employee you want to modify.
3. Click the User account tab.
4. After Send printed reports to this network printer, type the name of the printer.

NOTE:
- The printer path name is case sensitive.
- The network printer MUST be installed on the server where Reporting Service is running.

NOTE: If you have Send printed reports to my personal desktop printer selected on the User account tab for an employee in YourSite Explorer, report printing is administered by the Contact Center Client application running on the client desktop computer.

To configure a local printer

1. In Windows Control Panel, set the local printer as your default printer.
   Local printing runs via the Contact Center Client.
2. In Contact Center Management, click YourSite=>Configuration.
3. Click Edit in the row of the employee you want to modify.
4. Click the User account tab.
5. Select the Send printer reports to my personal desktop printer check box.

Troubleshooting reporting issues

Common reporting troubleshooting issues are described below.

Troubleshooting missing data

NOTE: You can run reports on licensed employees only. See “Licensing” on page 6.

If you run a report and notice that the data for a device is missing from the report output, verify the device is programmed in the telephone system and in the YourSite database. If you determine the device is missing from the database, add it to the database and use the Summarize Data command (in the Management Console application) to update the prairieFyre Service and the SQL database with the complete telephone system data stored on the local hard drive. You can then produce reports on the device.

To summarize data

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password.
3. Click Log on.
   The Contact Center Client window opens.
4. On the main toolbar, click Management.
5. Click Maintenance.
6. Click Summarize data.
7. Follow the steps in the Summarize Data Wizard to summarize the data.
Configuring reports to exclude Junk Mail from completed email statistics

Using the Registry Editor on the Enterprise Server, you can configure multimedia reports to exclude Junk Mail from the completed email statistics. If you exclude Junk Mail from completed email statistics, the following statistics will be affected:

- Completed count
- Completed total duration
- Hold count
- Hold total duration
- Short handled count

To exclude Junk Mail from completed email statistics

1. Click **Start=>Run**.
2. Type **regedit**.
3. Click **OK**.
   - The Registry Editor opens.
4. Expand the tree to **HKEY_LOCAL_MACHINE\Software\prairieFyre Software Inc\CCM**.
5. Right-click **Common** and select **New=>String Value**.
6. Type **SubtractJunkEmailStatsFromCompletedStats** and click **Enter**.
7. Right-click the **SubtractJunkEmailStatsFromCompiledStats** string and select **Modify**.
   - The Edit String window opens.
8. Under **Value data**, type **1**.
9. Click **OK**.

Troubleshooting Reporting Service

Why is Reporting Service not emailing or printing my reports?

- Ensure the SMTP Mail settings are correctly configured.
- Ensure the printer settings are correctly configured.
- View the log file for Reporting Service to find out why reports are not being printed/emailed the way you expect in the installation/Log file
Chapter 9
Forecasting

Forecasting terms
Forecasting tool
Forecasting

Forecasting involves taking historical data generated by your telephone system and using it to predict future traffic volumes and patterns. Forecasting is the basis for estimating required resources, such as agents, trunks, and workstations. You take a year or more of ACD queue traffic data, examine trends in Call Load patterns and determine the ACD Handling Times of the calls. After you run a forecast, you examine the data and make adjustments based on current contact center conditions. You can tweak the forecast by adding or reducing calls, based on your intuition, and information gathered by yourself and others. See “Step #3 Forecast the Call Load” on page 28 for more information on forecast concepts.

Forecasting terms

Conducting a forecast involves accurately estimating Time to Handle, Wrap Up Time, and ACD Calls Offered values. The following terms are used in forecasting resource requirements:

- **Service Level percent**
  See “Service Level percent” on page 252.

- **Service Level time**
  See “Service Level time” on page 252.

- **Wrap Up time**
  *Wrap Up Time* is the time an agent spends completing transactions associated with a call after the agent hangs up. The Wrap Up Time is a standardized period. If an agent requires additional time to complete paperwork or online transactions, the agent can leave the ACD queue temporarily for this purpose.

- **Agent Efficiency percent**
  *Agent Efficiency percent* is the percentage of time agents spend on ACD calls relative to the time agents are scheduled to work. Agent efficiency is calculated using a straight linear relationship. For example, 50% agent efficiency means that two more agents are required to handle the forecasted call load. An Agent efficiency percentage of 100 is unrealistic. Agents routinely take breaks, perform other non-ACD duties, make outgoing calls, and place themselves in Make Busy.

- **Average Talk time**
  *Average Talk Time* is the average time agents spend talking to callers.

- **Calls Offered**
  See “Offered” on page 251.

  You can predict the agent requirement for your Service Level percent and Service Level time targets by applying the Erlang C equation to the estimated Call Load and average ACD Handling Time.

- **Manned Agents**
  *Manned Agents* is the average number of agents who were logged on for the interval of time being forecasted.

- **Time to Handle**
  *Time to Handle* is the average time calls wait in queue before agents handle them.

- **ACD Handling time**
  *ACD Handling time* is the talk time plus the hold time. If an agent calls a supervisor in search of more information (while the caller is on hold) and/or transfers or conferences the call, the system adds these times to the ACD Handling Time value.

  For example, an agent speaks to a caller for two minutes and then puts the caller on hold for three minutes and tries to solve the problem. This might include a call to the supervisor. The agent then initiates a conference call with the caller and a third party and they speak for three minutes and resolve the issue. Therefore, the ACD Handling Time for the agent is $2 + 3 + 3 = 8$ minutes.

- **Call Load**
  The term *Call Load* is to the combined effect of the number of calls received by the ACD queue and their duration, or the calls offered $x$ (average ACD Handling Time + average Wrap Up Time).
Forecasting tool

You use the Forecasting tool to create forecasts based on historical contact center traffic volumes. You can then perform "what-if" scenarios, and optimize the balance between the agents scheduled and your Service Level objectives.

To forecast resource requirements you

1. Load historical data.
2. Modify historical data if required.
3. Perform a forecast.
4. Print the forecast.

Loading historical data

When you load historical data, you include data over a historical period that best represents the call center activity for the time period. You can select sequential or non-sequential dates (for example, Monday, Wednesday, and Friday) to use in the forecast.

To load historical data

1. Click Tools=>Forecasting.
   **NOTE:** You can load historical data for a queue or queue group. If you are using the forecast to build a schedule, select historical data from the same queue group with which the schedule is associated. This data will best represent the agents required for your schedule.
2. Click Load historical data.
The Forecasting window opens.
3. Under Queues or Queue groups, click on the queue or queue groups you want to use as the source of historical data.
   **NOTE:** You can select one or more specific dates and/or date ranges of historical data.
4. If you want to add a specific date, under Historical date(s) for the forecast, click Specific day.
   • Select a date.
   • Click Add dates.
   • Repeat step 4 to add more dates.
5. If you want to add data from a date range, click Date range.
   • After Every, select the date frequency.
   • Select the check boxes for one or more days of the week.
   • After From and To, select the start and end dates of the historical data period used for the forecast.
   • Click Add dates.
   • Repeat step 5 to add more date ranges.
6. After Start hour and End hour, select the time frame for historical data.
The Interval value, in minutes, is the time increment by which the forecast will be displayed. For example, if you schedule your employee shifts in 30 minute increments, select 30 minutes as the Interval value.
7. After Interval, select the schedule interval: 15, 30, or 60 minutes.
8. Click Submit.
The forecast table is populated with historical data.

Modifying historical data

You must load historical data before you can modify it. After you perform a forecast and run "what-if" scenarios, the changes you make to the historical data (for example, Calls Offered and Average Talk time) affect the agents required.
Modifying Average Talk time

You can modify the Average Talk time value for one day or several days simultaneously.

To modify the Average Talk time parameter on the forecast grid

1. Click **Modify...**=>Average Talk time.  
   See Figure 9-1. 
2. Under **Specify how you want to change the Average Talk Time value(s)**, specify how you want to modify Average Talk time:
   - Add seconds to or subtract seconds from the value
   - Increase or decrease by a percent of the value
   - Select a fixed value
3. Under **Apply the changes to the following data source**, specify if you want to modify the original value or the current grid value.
4. Under **Apply to days**, select the days for which you want to modify Average Talk time.
5. Click **Apply**.

Figure 9-1  Average Talk Time window
Modifying Calls Offered

You can modify the Calls Offered value for one or several time intervals simultaneously.

To modify the Calls Offered parameter on the forecast grid

1. Click **Modify...⇒Calls Offered**.
   See Figure 9-2.
2. Under **Specify how you want to change the Calls Offered value(s)**, specify how you want to modify Calls Offered:
   - Add calls to or subtract calls from the values
   - Increase or decrease by a percent of the values
   - Select a fixed value
3. Under **Apply the changes to the following data source**, specify if you want to modify the original value or the current grid value.
4. Under **Apply to times**, select the days and time interval for which you want to modify Calls Offered.
5. Click **Apply**.

Figure 9-2  Calls Offered window
Modifying the weekly total for Calls Offered

You can modify the Calls Offered values for an entire week simultaneously. Modifying these values changes the number of Calls Offered while maintaining the same proportion of calls across all time intervals. For example, if you increase the weekly total by 10 percent, an interval with 10 calls will change to 11. However, an interval with zero calls will remain zero.

To modify the Calls Offered parameter on the forecast grid

1. Click Tools=>Forecasting.
2. Click Modify...=>Weekly total.
3. Under Specify how you want to change the weekly total, specify how you want to modify Calls Offered over the week:
   - Increase or decrease by a percent of the values
   - Select a fixed value
4. Under Apply to totals, specify if you want to modify the original values or the current grid values.
5. Click Apply.

Performing forecasts

NOTE: You must load historical data before you can perform a forecast. See “Loading historical data” on page 276.

To run a forecast

1. Specify the Service Level %, Service Level Time, Wrap Up Time, and Agent Efficiency % you expect for the queue or queue group.
2. Click Perform forecast.
   You can perform what-if scenarios on the historical data using different Service Level objectives until you are satisfied with the forecast.
Printing forecasts
After you generate forecast data you can print it.

To print a forecast
1. Click Export Forecast.
   The Forecast data export window opens.
2. Click Printer.
3. Click Export.
   The print preview window opens.
4. Click the print direct icon, or click the print icon, specify your printer options, and click OK.

Saving forecasts as Excel files
After you generate forecast data you can export it to a Microsoft Excel spreadsheet.

To export a forecast as an Excel file
1. Click Export Forecast.
   The Forecast data export window opens.
2. Click Microsoft Excel.
3. Click Export.
   The forecast opens in a Microsoft Excel spreadsheet you can modify and save.
Chapter 10
Data-mining

ACD Inspector
SMDR Inspector
Auditor
Data Mining

The data-mining tools comprise

- **ACD Inspector**
  ACD Inspector searches for agent and ACD queue event records.

- **SMDR Inspector**
  SMDR Inspector searches through SMDR data to find specific contact center events.

- **Auditor**
  Using Auditor you can view the historical real-time events that occurred on a particular date, in the sequence they occurred, at your own pace.

**NOTE:** For ACD Inspector and SMDR Inspector to function effectively when using Internet Explorer 8 as your browser, you must add Contact Center Management to the Internet Explorer Trusted Sites category and set the Internet security to medium. See "Starting Contact Center Management on the Enterprise Server or on a client computer" in the *Contact Center Management Installation Guide*.

**ACD Inspector**

ACD Inspector searches through telephone data obtained from the telephone system, for agent and ACD queue event records. For example, using ACD Inspector, you can find the exact time an agent logs off at lunch. You can run a search and examine the activities of individual agents or all of the agents in a particular agent group or customer service queue during that time interval. You can also search on specific agent states and other parameters, such as the number of calls waiting and the number of active agents. The search follows a wild card format. Your specifications do not have to be exact. You can make the search as inclusive or exclusive as you wish. The results are placed in an easy-to-interpret grid that can be printed or saved to file. You can verify that your reports are valid by conducting searches against raw telephone system data.

There are four types of search result tabs:

- Agent events
- Queue events
- Date events
- Exception events

**Running searches in ACD Inspector**

**NOTE:** When you program the telephone system with a path number such as six, you enter this number in the YourSite database as queue reporting number P006 (for the SX-2000). When you run searches on queues in ACD Inspector, be sure to include a P preceding the queue number.

When you run a search, ACD Inspector searches through the raw telephone system data on the local hard drive. Each search requires the following information:

**Select dates/Delete dates**
The Select dates button specifies the date range within which you want to search. The Delete dates button deletes days within the range you selected. The date is displayed month first, then day, then year.

**Select media servers**
The Select media servers check boxes specify the origin of the data used in the search. Currently you can search on telephone activity only. In the future, you will be able to search on email, chat, and fax activity.

In addition to the date and media server parameters, the ACD Inspector has the following search criteria tabs:

- Agent events
- Queue events
- Option events

You can use the Reset criteria button to reset all of the search parameters to their default settings.
Agent events criteria for searches

**NOTE:** When conducting a search, if you accept the default settings—all check boxes—the search output will contain all of the event records. You can clear check boxes to narrow down your search. For example, if you clear all of the agent states except for the Agent login and Agent logout check boxes, the agent event search output will include log on and log off event records only.

When you click Tools=>Data mining=>ACD Inspector, the Agent events tab opens. It displays the agent event criteria used in the search. (See Figure 10-1.)

**Figure 10-1  ACD Inspector main window - Agent events tab**

The Agent events tab has the following search criteria:

**Agent information**

The Agent information boxes specify the agent’s ID and extension number, and line numbers for one or more telephone lines to which the agent connects. You can search for agent information records for a particular agent, or for all of the agents. The agent information specifies the Agent ID for the media server you have already selected. For example, if you selected the media server Phone, ensure you select the Agent Login ID for the media server Phone. It is specified in YourSite=>Configuration=>Agent Login=>Agent Login.
Agent events
The Agent events criteria are listed and automatically selected.

Idle event modifiers
The idle event modifier check boxes provide additional agent event searches. You can select one or more check boxes to include records for agents who are in the following states: unknown, idle, DND, Make Busy, and both DND and Make Busy.

**NOTE:** When conducting a search, if you accept the default settings the search output will contain all of the event records. You can clear check boxes to narrow down your search.

ACD queue
The ACD queue specifies the queue to which your agent belongs. For example, if the agent belongs to Tech Support, then you specify the Tech support queue. The agent’s queue is specified in YourSite=>Configuration=>Queue. When you enter an ACD queue number and an agent number (in the Agent ID box), the search results contain records for all of the calls the agent receives from the queue.

Table 10-1 describes the ACD information provided by the Agent events tab.

**Table 10-1: Agent events criteria**

<table>
<thead>
<tr>
<th>Agent events</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Agent Login</strong></td>
<td>This record is produced whenever an agent successfully logs on.</td>
</tr>
<tr>
<td><strong>Agent Logout</strong></td>
<td>This record is produced whenever an agent successfully logs off. If agent A is currently logged on extension X and agent B logs on to extension X, a log off record is automatically produced for A. This is followed by the log on record for B. Make Busy is automatically enabled on the extension when the agent logs out. No remove Make Busy record is produced. The extension number is the prime line of the ACD set which an agent is logged on.</td>
</tr>
<tr>
<td><strong>Agent Set Do Not Disturb</strong></td>
<td>A record is not produced when a hunt group is placed in DND. The records do not differentiate between setting DND locally and remotely. The extension number reported is always the prime line of the ACD extension. A set DND record will be produced for the following conditions:</td>
</tr>
<tr>
<td></td>
<td>• Setting DND locally by using the DND access code</td>
</tr>
<tr>
<td></td>
<td>• Setting DND remotely by using the remote DND access code</td>
</tr>
<tr>
<td></td>
<td>• Setting DND remotely by using the attendant console features key</td>
</tr>
<tr>
<td></td>
<td>• Setting DND locally on a SUPERSET 4 telephone by pressing the select features hardkey and dialing the digit 2 or setting it on a SUPERSET 4DN or SUPERSET 430 telephone by pressing the Do Not Disturb Feature Key</td>
</tr>
<tr>
<td><strong>Agent Remove Do Not Disturb</strong></td>
<td>The extension number is always the prime line of the ACD extension. A clear DND record will be produced for the following conditions:</td>
</tr>
<tr>
<td></td>
<td>• Clearing DND locally by using an access code</td>
</tr>
<tr>
<td></td>
<td>• Clearing DND remotely by using the Cancel Remote DND access code</td>
</tr>
<tr>
<td></td>
<td>• Clearing DND remotely by using the attendant console feature key</td>
</tr>
<tr>
<td></td>
<td>• Clearing DND by using the Cancel All Features access code</td>
</tr>
<tr>
<td></td>
<td>• Clearing DND by using the Cancel All DND feature on the attendant console</td>
</tr>
<tr>
<td></td>
<td>• Agent logging in on an extension in DND</td>
</tr>
</tbody>
</table>
Table 10-1: Agent events criteria

<table>
<thead>
<tr>
<th>Agent events</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Set Make Busy</td>
<td>This record is produced whenever an extension is placed in the Make Busy state. A record is not produced when an agent logs out because Set Make Busy is implied when an agent log out record is received. The extension number is always the prime line of the ACD extension.</td>
</tr>
<tr>
<td>Agent Remove Make Busy</td>
<td>This is similar to Set Make Busy. No record is produced when the agent logs on. The remove Make Busy is implied by the log in record. The extension number is always the prime line of the ACD extension.</td>
</tr>
<tr>
<td>Agent Answer ACD</td>
<td>This record is produced whenever an agent answers a call that was directed to the ACD hunt group. The event record contains the Agent ID and extension number (hunt group pilot number to which the call was placed). The ACD extension that answered the call can be determined by using the last agent log in event for that extension. If the ACD set does not have a logged in agent, the Agent ID area is blank and the extension number is that extension’s prime line.</td>
</tr>
<tr>
<td>Agent Answer Personal</td>
<td>A record of all of the non-ACD hunt group calls are included in this category. The extension number is always the prime line of the ACD extension that answered.</td>
</tr>
<tr>
<td>Agent Make Outbound</td>
<td>This record is produced whenever an agent originates a call and enters a conversation. A record is not produced under the following conditions: entering a feature access code, dialing an invalid number, or hanging up before the called party answers. An agent extension number is always the prime line of the ACD set that originated the call.</td>
</tr>
<tr>
<td>Agent Idle</td>
<td>If work timer is in effect, the Agent Idle record is produced when the work timer expires or when it is cancelled. If the agent enters Make Busy while work timer is in effect, an Agent Idle record is produced followed immediately by a set Make Busy record. A record is not produced to show the end of the call or the start of the work timer. This entire period is treated as part of the time to process the call. If work timer is not in effect, the Agent Idle record is produced at the end of a call, not when the agent hangs up. For example, if the agent presses the HANG-UP softkey and remains off hook for 5 seconds, the record is produced when the HANG-UP is pressed, not when the agent actually goes on hook. The extension number is always the prime line of the ACD set that is now idle.</td>
</tr>
<tr>
<td>Agent Work timer Stat</td>
<td>This record is produced when an agent terminates an ACD call and the work timer is started for that agent. If the work timer cannot be started, an idle event record is produced instead.</td>
</tr>
<tr>
<td>Agent Remove Work timer</td>
<td>This record is produced when the work timer expires for that agent.</td>
</tr>
<tr>
<td>Agent Hold Active</td>
<td>When an agent places a call on hold, a record is produced. If the agent places another call or answers a call on a second line, the second call will be recorded independently of the first.</td>
</tr>
<tr>
<td>Agent Hold Retrieve</td>
<td>When the held call is retrieved, a record is produced, indicating that the agent is now busy on that line.</td>
</tr>
<tr>
<td>Agent Hold Abandon</td>
<td>When the held call is abandoned, a record is produced for that line.</td>
</tr>
</tbody>
</table>
**Table 10-1: Agent events criteria**

<table>
<thead>
<tr>
<th>Agent events</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent Answer Remote ACD</td>
<td>When an agent answers a remote ACD call, a record is produced. When you have networked ACD (more than one telephone system networked together), local calls are calls routed through the same telephone system that the agent’s extension is located, remote calls are calls routed through the other telephone system.</td>
</tr>
<tr>
<td>Agent Ringing ACD</td>
<td>This record is produced when the telephone rings with an ACD call.</td>
</tr>
<tr>
<td>Interactive Contact Center Queue Set DND Request</td>
<td>This record is produced when the agent set the queue in DND.</td>
</tr>
<tr>
<td>Interactive Contact Center Queue Set DND</td>
<td>A record is produced when the supervisor puts a queue in DND and when the Contact Center Management system puts a queue in DND. In YourSite=&gt;Configuration=&gt;Queue, on the Business Hours tab, you set the hours of operation for the business. The Contact Center Management system reads these hours of operation and will put this queue in DND during off hours.</td>
</tr>
<tr>
<td>Interactive Contact Center Queue Remove DND Request</td>
<td>This record is produced when the agent removed the queue from DND.</td>
</tr>
<tr>
<td>Interactive Contact Center Queue Remove DND</td>
<td>A record is produced when the supervisor removes the queue from DND and when the Contact Center Management system removes the queue from DND. In YourSite=&gt;Configuration=&gt;Queue, on the Business Hours tab, you set the hours of operation for the business. The Contact Center Management system reads these hours of operation and will remove this queue from DND during business hours.</td>
</tr>
<tr>
<td>Interactive Contact Center Agent Login Request</td>
<td>This record is produced when the agent logged on.</td>
</tr>
<tr>
<td>Interactive Contact Center Agent Login</td>
<td>This record is produced when the supervisor logged on the agent.</td>
</tr>
<tr>
<td>Interactive Contact Center Agent Logout Request</td>
<td>This record is produced when the agent logged off.</td>
</tr>
<tr>
<td>Interactive Contact Center Agent Logout</td>
<td>This record is produced when the supervisor logged off the agent.</td>
</tr>
<tr>
<td>Interactive Contact Center Set MKB with Reason Code Request</td>
<td>This record is produced when the agent sets himself as Make Busy.</td>
</tr>
<tr>
<td>Interactive Contact Center Set MKB with Reason Code</td>
<td>This record is produced when the supervisor sets the agent in Make Busy.</td>
</tr>
<tr>
<td>Interactive Contact Center Remove MKB Request</td>
<td>This record is produced when the agent sets himself in Make Busy.</td>
</tr>
</tbody>
</table>
Queue events criteria for searches

When performing a queue events search, you can search on the following criteria:

- Agent group statistics
- Queue statistics
- Date

The Queue events tab has the following search criteria:

### Queue information

The Queue information box specifies the ACD queue or agent group used in the search. When you type an ACD queue or agent group number, the search results contain records specific to that ACD queue or agent group.

### Queue event

When you select all three queue event check boxes (Agent Group statistics, Queue statistics, Date), the search results contain records for all of the agent groups and queues, and all of the telephone system refresh cycles. The telephone system performs a re-synchronization and generates a refresh record every time it notices the date or hour has changed (once an hour).

### Agent information

The Agent information boxes specify the range of values for the Agents Available statistic used in the search. For example, if you select a range of 5 to 10, the search results contain records for all of the calls during periods when 5 to 10 agents were logged on to the ACD, but not in Make Busy or Do Not Disturb.
Calls waiting/Longest waiting settings
The Calls waiting settings and Longest waiting settings boxes specify ranges of values for the Calls waiting and Longest waiting statistics. For example, selecting a range from 10 to 999 in the Calls waiting box produces all of the records for calls received during periods when more than 10 callers waited in queue.

The Queue events tab displays the queue event criteria used in the search. (See Figure 10-2.)

Figure 10-2  ACD search criteria - Queue events tab

Option events criteria for searches
The Option events tab displays the telephone system refresh records, error, and information criteria used in the search. (See Figure 10-3.)

The Option events tab has the following search criteria:

Time ranges
The Time ranges boxes specify the time interval used for the search. The time interval applies to searches on agent and queue events.
Exception records
Collector Service tags telephone system records that contain errors with an E (telephone system 1) or e (telephone system 2). Under Exception records, you select the Error records check box to include these records in the search output.

Collector Service writes a log record to the data stream upon start up. It tags the log record with an I to indicate it is an information record. You select the Information records check box to include log records in the search output. ACD Inspector displays the error and information search result records on the Exception records tab.

In contact centers that have two telephone systems, Collector Service tags records from the second telephone system with an S. You specify the Com ports used by your telephone systems on the Data collection tab of YourSite Configuration.

Output record count
The Output record count specifies the maximum number of rows of records to display.

Figure 10-3 ACD search criteria - Option events tab

Running agent events searches
NOTE: When you run a search on Agent Answer ACD, type the Agent ID but do not type the agent’s extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You will get no data if you type the agent’s extension. You can run an Agent events search to find all of the records of when agent 2005 was on ACD and used Set Make Busy.
To run an Agent events search

1. Click Tools=>Datamining=>ACD Inspector.
   The Agent events tab of the ACD Inspector criteria tab opens.
3. Under Select media servers, Phone is preselected.
   NOTE:
   When you run a search on Agent answer ACD, type the Agent ID but do not type the agent’s extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You will get no data if you type the agent’s extension.
   You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent login. The Agent ID is located under the Agent login ID heading. Ensure you select the Agent ID associated with the Phone media server.
4. Under Agent information, type the Agent ID, 2005.
5. Under Agent events, if you are not selecting all events, clear Select all.
6. Select the Agent event(s) you want to search on, in this case, Agent answer ACD, Set Make Busy, and Remove Make Busy.
7. You can leave the ACD queue blank.
8. Click Start search.
   The ACD Inspector results - Agent events tab opens.

Agent events search results

This section describes the records produced when you run searches in ACD Inspector. Table 10-2 describes the ACD information provided by the Agent events tab. The Agent events tab displays the ACD activity and the Make Busy activity for agent 2005. (See Figure 10-4.)
Narrowing an Agent events search

You can use the Options tab in conjunction with the Agent events search or the Queue events search. Using the Options tab, you narrow down the time frame for either search.

You can run an Agent events search to find all of the records for a specific agent who was on ACD and when that agent used Set Make Busy. Then you narrow the search with the Options tab to search between 9:00 A.M. and 11:00 A.M. only. The ACD Inspector results on the Agent events tab display the ACD activity and the Make Busy activity for agent 2005 between 9:00 A.M. and 11:00 A.M. (See Figure 10-5.)
To run an Agent events/Options events search

1. Click **Tools=>Datamining=>ACD Inspector.**
   The **Agent events** tab of the **ACD Inspector criteria** tab opens.
2. Click **Select dates** and select March 3, 2007 to March 5, 2007.
3. Under **Select media servers**, **Phone** is preselected.
   
   **NOTE:**
   When you run a search on Agent answer ACD, type the Agent ID but do not type the agent’s extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You will get no data if you type the agent’s extension.
   You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent login. The Agent ID is located under the Agent login ID heading. Ensure you select the Agent ID associated with the Phone media server.
4. Under **Agent information**, type the Agent ID, 2005.
5. Under **Agent events**, if you will are not selecting all events, clear **Select all**.
6. Select the **Agent event(s)** you want to search on, in this case, **Agent answer ACD**, **Set Make Busy**, and **Remove Make Busy**.
   You can leave the ACD queue blank.
7. Click the **Option** tab.
8. Under **Time ranges**, select the **Start at** and **End at** times with which to narrow the Agent events search.
   In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.
9. Click **Start search**.
   The ACD Inspector results - Agent events tab opens.

### Figure 10-5 ACD search results - Agent events tab

<table>
<thead>
<tr>
<th>Media Server</th>
<th>Function</th>
<th>Date</th>
<th>Time</th>
<th>Extension Queue</th>
<th>Agent ID</th>
<th>L</th>
<th>Idle Event M</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>Agent Answer ACD</td>
<td>3/4/2004</td>
<td>10:08:58</td>
<td>P280</td>
<td>2005</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Phone</td>
<td>Agent Answer ACD</td>
<td>3/5/2004</td>
<td>10:11:35</td>
<td>P280</td>
<td>2005</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

### Running queue events searches

You can run a Queue events search to determine when you had too few agents available to answer calls for a particular queue. You search for a maximum of two agents and local calls that waited between one and three minutes.
To run a Queue events search

1. Click **Tools=>Datamining=>ACD Inspector**.
   The **Agent events** tab of the **ACD Inspector criteria** tab opens.
2. Click the **Queue events** tab.
3. Click **Select dates** and select March 1, 2003 and March 4, 2003.
4. Under **Select media servers, Phone** is preselected.
5. Under **Queue information**, type the ACD Queue, p280.
6. Under **Queue event**, select **Queue stats**.
7. Under **Agent information**, type 0-2 agents.
   In this example, you want to know when you have only two agents scheduled to answer the queue.
8. Under **Calls waiting setting**, select 0-999 Local calls waiting.
   In this example, you want to know the number of calls waiting on the telephone system to which your agent is connected. If you have only one telephone system, you do not have any remote calls waiting.
9. Under **Longest waiting settings**, select 1-3 minutes.
   In this example, you want to know the number of local calls that waited between 1-3 minutes. You think waiting up to a minute is acceptable, so you did not search for calls less than a minute. If you have only one telephone system, you do not search for the remote longest waiting.
10. Click **Start search**.
    The ACD Inspector results - Agent events tab opens.
11. Click the **Queue events** tab.

**Queue events search results**

The Queue events tab displays the number of calls that waited between one and three minutes (one call), when there were a maximum of two agents available, for the dates selected, for queue 280. (See Figure 10-6.)

**Figure 10-6 ACD search results - Queue events tab**
Table 10-3 describes the ACD information provided by the Queue events tab.

Table 10-3  Queue events result information

<table>
<thead>
<tr>
<th>Column heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media server</td>
<td>The Media server box identifies the telephone system (with or without MiTAI) application that produced the event record.</td>
</tr>
<tr>
<td>Function/Event</td>
<td>The Function/Event box indicates whether the event record is for a queue or an agent group.</td>
</tr>
<tr>
<td>Date</td>
<td>The Date box displays the date of the event record (month/day/year).</td>
</tr>
<tr>
<td>Time</td>
<td>The Time box displays the time the event occurred (in seconds).</td>
</tr>
<tr>
<td>Queue/Agent group</td>
<td>The Queue/Agent group box displays the queue or agent group number.</td>
</tr>
<tr>
<td>Agents available</td>
<td>The Agents available box displays the current number of agents logged on to the ACD system, who are not in Make Busy or Do Not Disturb.</td>
</tr>
<tr>
<td>CW (Number of local calls waiting)</td>
<td>The CW box displays the number of local callers waiting for an available agent.</td>
</tr>
<tr>
<td>LW (Longest local call waiting)</td>
<td>The LW box displays the wait time for the caller waiting the longest in queue for an available agent.</td>
</tr>
<tr>
<td>Rem CW (Number of remote calls waiting)</td>
<td>When you have networked ACD (more than one telephone system networked together), the Rem CW box displays the number of remote callers waiting for an available agent.</td>
</tr>
<tr>
<td>Rem LW (Longest remote call waiting)</td>
<td>When you have networked ACD (more than one telephone system networked together), the Rem LW box displays the wait time for the caller waiting the longest in a remote queue for an available agent.</td>
</tr>
</tbody>
</table>

Narrowing a Queue events search

You use the Options tab in conjunction with the Agent events search or the Queue events search. Using the Options tab, you can narrow down the time frame for either search.

You can run a Queue events search to find when you have too few agents available to answer calls for a particular queue. You search for a maximum of two agents and local calls that waited between one and three minutes. Then you narrow the search with the Options tab to search between 9:00 A.M. and 11:00 A.M. only.

To run a Queue events/Options events search

1. Click **Tools=>Datamining=>ACD Inspector**.
   The **Agent events** tab of the **ACD Inspector criteria** tab opens.
2. Click the **Queue events** tab.
3. Click **Select dates** and select March 1, 2003 to March 4, 2003.
4. Under **Select media servers**, **Phone** is preselected.
5. Under **Queue information**, type the ACD Queue, p280.
6. Under **Queue event**, select **Queue stats**.
7. Under **Agent information**, type 0-2 agents.
   In this example, you want to know when you have only two agents scheduled to answer the queue.
8. Under **Calls waiting setting**, select 0-999 Local calls waiting.
   In this example, you want to know the number of calls waiting on the telephone system to which your agent is connected. If you have only one telephone system, you do not have any remote calls waiting.
9. Under **Longest waiting settings**, select 1-3 minutes.
   In this example, you want to know the number of local calls that waited between 1-3 minutes. You
   think waiting up to a minute is acceptable, so you did not search for calls less than a minute. If you
   have only one telephone system, you do not search for the remote longest waiting.

10. Click the **Option** tab.

11. Under **Time ranges**, select the **Start at** and **End at** times with which to narrow the Agent events
    search.
    In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.

12. Click **Start search**.
    The ACD Inspector results - Agent events tab opens.

13. Click the **Queue events** tab.

The Queue events tab displays the number of calls that waited between one and three minutes, when there
were a maximum of two agents available, for the dates selected, between 9:00 A.M. and 11:00 A.M. for queue
280. There was only one call that waited between one and three minutes in the selected time frame and
queue. (See Figure 10-7.)

**Figure 10-7 ACD search results - Queue events tab**

![Queue events tab screenshot]

**Running wild card queue events searches**

When performing searches on the Queue Events tab, you can enter a *P800* under Queue information and the
search will produce records involving Queue 800 only. Alternatively, you can run wild card searches. When
you perform wild card searches, you use * to represent the wild card. For example, if you enter "*00" under
Queue information on the Queue events tab, the search will produce records for all of the Queues or Agent
groups that end in "00" (for example, 200, 300).

To run a wild card Queue events search, where all of the queues end in "00".

1. Click **Tools=>Datamining=>ACD Inspector**.
   The **Agent events** tab of the **ACD Inspector criteria** tab opens.
2. Click the **Queue events** tab.
4. Under **Select media servers**, **Phone** is preselected.
5. Under **Queue information**, type *00*. In this example, you are searching for all of the queues that end in "00".
6. Under **Queue event**, select **Queue stats**.
7. Under **Agent information**, type 0-2 agents. In this example, you want to know when you have only two agents scheduled to answer the queue.
8. Under **Calls waiting setting**, select 0-999 Local calls waiting. In this example, you want to know the number of calls waiting on the telephone system to which your agent is connected. If you have only one telephone system, you do not have any remote calls waiting.
9. Under **Longest waiting settings**, select 1-3 minutes. In this example, you want to know the number of local calls that waited between 1-3 minutes. You think waiting up to a minute is acceptable, so you did not search for calls less than a minute. If you have only one telephone system, you do not search for the remote longest waiting.
10. Click **Start search**. The ACD Inspector results - Agent events tab opens.
11. Click the **Queue events** tab. See Figure 10-8.

**Figure 10-8  ACD Wild card search results - Queue events tab**

<table>
<thead>
<tr>
<th>Media...</th>
<th>Function...</th>
<th>Date</th>
<th>Time</th>
<th>Queue...</th>
<th>Agent...</th>
<th>CW</th>
<th>LW</th>
<th>I</th>
<th>R...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>16:07:44</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>17:07:44</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>17:07:45</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>18:07:44</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>18:07:45</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>19:07:44</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>19:07:45</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>20:07:44</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>20:07:45</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>21:07:45</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>21:07:46</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>22:07:45</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>22:07:46</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/9/2004</td>
<td>23:07:46</td>
<td>P800</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/8/2004</td>
<td>23:07:47</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>00:07:46</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>00:07:47</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>01:07:46</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>01:07:47</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>02:07:46</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>02:07:47</td>
<td>P800</td>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Phone</td>
<td>Queue Stats</td>
<td>2/10/2004</td>
<td>03:07:47</td>
<td>P300</td>
<td></td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Wild card queue events search results

The Queue events tab displays the Queue statistics when there were a maximum of two agents available, for the dates selected, for all of the queues that end in "00". The Queue statistic in this case are the records of the telephone system performing re-synchronization. A refresh record is produced every time the system notices the date or hour has changed (once an hour).

Running searches for error and information records

Using the Options tab, you can run a search for error and information records. The error messages are records of sequence errors. The information records are records of when the Collector restarts.

To run an exception events search:
1. Click the ACD Inspector criteria tab.
2. Click the Options tab.
3. Click Select dates and select a date.
4. Under Select media servers, Phone is preselected.
5. Under Time ranges, type the Start at and End at times.
6. Under Exception records ensure the Error records and/or Information records check boxes are selected.
7. Under Output record count, select the maximum number of records you want to display.
8. Click Start search.
   The ACD Inspector results - Agent events tab opens.
9. Click the Exception events tab.

Exception events search results

Table 10-4 describes the ACD information provided by the Exception events tab.

<table>
<thead>
<tr>
<th>Column Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media server</td>
<td>The Media server box identifies the telephone system (with or without MiTAI) application that produced the event record.</td>
</tr>
<tr>
<td>Record</td>
<td>The Function/Event box displays refresh records. The refresh event signifies the start of a new cycle of group and queue statistics.</td>
</tr>
</tbody>
</table>

SMDR Inspector

SMDR Inspector searches through SMDR data to find specific contact center events. For example, suppose you receive a complaint from a caller who waited 16 minutes in queue for a customer service agent, sometime between 1:00 P.M. and 1:30 P.M. sometime last week. In a single session, you can search through data from multiple days to find a specific event. The search follows a wild card format. Your specifications do not have to be exact. You can make the search as inclusive or exclusive as you wish. The results are placed in an easy-to-interpret grid that can be printed or saved to file. You can verify that your reports are valid by conducting searches against raw telephone system data.

Common SMDR Inspector searches include searches for all of the records on:
- Queue P001
- Calls the telephone system sent to agent group 23
- The queue for which agent 8000 answered calls
- Outbound calls made by agent 2311 (internal and external)
- Where Account Codes were entered
- DNIS that start with 89
- Calls transferred to trunks
The search result tabs consist of the following:
- SMDR search results
- Exception results

**Starting SMDR Inspector**

To start SMDR Inspector on the client computer:

1. Start Internet Explorer and type your Enterprise Server IP address `http://[your Enterprise Server IP address]/CCMWeb/`.
2. Type your username and password and click **Submit**.
3. Click **Tools=>Data mining=>SMDR Inspector**.

**Running searches in SMDR Inspector**

When you run a search, SMDR Inspector searches through the raw telephone system data on the local hard drive. Each search requires the following information:

**Select dates/Delete dates**
The Select dates button specifies the date range within which you want to search. The Delete dates button deletes days within the range you selected. The date is displayed month first, then day, then year.

**Select media servers**
The Select media servers check boxes specify the origin of the data used in the search. Currently you can search on telephone activity only. In the future, you will be able to search on email, chat, and fax activity.

In addition to the date and media server parameters, SMDR Inspector has the following search criteria tabs:
- Call parties
- Call types
- Options

**Call parties criteria for searches**
The Call parties criteria helps you to find call events such as, what calls an agent received (Called party), what calls an agent made (Calling party), or what extension the call was transferred to (Third party). (See Figure 10-9.)

The Call parties tab search options are as follows.

**Digits dialed**
The Digits dialed box specifies the queue number of the queue that picks up the call (for inbound calls). The ANI digits box specifies the area code and telephone number for an inbound call. The search results contain records that match the data the user typed in the ANI field.

The DNIS digits box specifies the phone number the caller dialed. The DNIS could be product specific, or it could specify demographic variables or marketing targets.

The Account Code box specifies the Account Code number used in the search. Agents enter Account Code numbers to tag inbound and outbound calls.

**Outbound calls**
The Outbound calls box specifies telephone number the agent dials (for outbound calls).
Call parties
The Calling party box specifies the extension or agent number (for an outbound call), or the trunk number (for an inbound call) used in the search.

The Called party box specifies the answering extension or the trunk number (for an outbound call) used in the search.

The Third party box searches for call records on the extension number used in a transfer.

Call identification
The Call identification box specifies the Mitel call IDs assigned to a call segment.

The Sequence ID box specifies the sequence number assigned to the call record by the telephone system.

The Associated ID box specifies the number attached to associated data records of the call assigned by the telephone system.

Figure 10-9 SMDR search criteria - Call parties tab

Call types criteria for searches
The Call types tab displays the types of calls the agent receives, for example, ACD or non-ACD, abandoned, interflowed, requeued, unavailable, or outbound calls. (See Figure 10-10.)
The Call types tab search options are as follows.

**Call types**
The Call types check boxes specify one or more categories of calls used in the search. The telephone system generates an Unavailable (Queue unavailable calls) event record when a caller dials a queue and the queue is not available (in DND) or there are no agents logged on to handle the call.

**Answer supervision**
The Answer supervision check box searches for instances where calls were answered by the called party. If you have answer supervision and you make an outbound call but the called party does not answer (you hang up) then an SMDR record is generated with no duration. If you do not have answer supervision then no SMDR record is generated at all.

**Busy call**
The Busy call check box searches for call records on queues or extensions the caller dials but finds busy.

**Error by caller**
The Error by caller check box searches for call records on numbers the caller dials that are not recognized by the telephone system.

**TAFAS answered**
The TAFAS Answered check box searches for call records that involve calls manually picked up by agents at alternate extensions. In a TAFAS answered call, an employee hears another employee’s phone ring and dials a number to pick up the call.

**Internal call**
The Internal call check box searches for call records on calls between employees that do not involve trunks.

**Blank**
The Blank check box searches for call records that have no data in the Call completion box. That is, when the check box is selected, the search output contains records where there is nothing recorded in the Call completion box.

**Attendant involved**
The Attendant involved options specify whether or not call records for calls involving an automated attendant are used in the search.

**Transfer/Conference**
The Transfer/Conference check box searches for records on transferred or conferenced calls.

**Speed call/Forward**
The Speed call/Forward check boxes search for call records involving a speed dial and/or conference function. When the Blank check box is selected, the search output contains records where there is nothing recorded in the Speed or Fwd check boxes.

**System ID**
The System ID check box searches for call records that pertain to a specific telephone system. In a multi-site enterprise, you program each telephone system with a 3-digit system ID number. You can distinguish records by their system ID number. The telephone system appends it to all of the SMDR records.
Figure 10-10  SMDR search criteria - Call types tab

Options criteria for searches

When you click Tools=>Data mining=>SMDR Inspector the Options tab opens. The Option criteria work in conjunction with the Call parties criteria and the Call types criteria to narrow down the search. (See Figure 10-11.)

The Options tab search options are as follows.

**Time ranges**
The Time ranges boxes specify the time interval used for the search.

**Call duration**
The Call duration boxes specify a range of values for the Call duration statistic used in the search.

**Time to answer**
The Time to answer boxes specify a range of values for the Time to answer statistic used in the search. For example, if you select a time to answer of 240 to 999 seconds, the search records include calls that were answered by an agent after waiting at least 240 seconds to be answered.
Exception records
The Collector Service tags telephone system records that contain errors with an E (telephone system 1) or e (telephone system 2). You select the Error records check box to include these records in the search output. The Collector Service writes a log record to the data stream upon start up. It tags the log record with an I to indicate it is an information record. You select the Information records check box to include log records in the search output. ACD Inspector displays the error and information search result records on the Exception Records tab.

In contact centers that have two telephone systems, the Collector Service tags records from the second telephone system with an S. You specify the Com ports used by your telephone systems on the Data collection tab in YourSite Configuration.

Output record count
The Output record count specifies the maximum number of rows of records to display.

Figure 10-11 SMDR search criteria - Options tab
## SMDR search results information

The SMDR Search results tab shows the search results for Call parties, Call types, and Options searches. Table 10-5 describes the SMDR information provided by the SMDR Search results tab.

### Table 10-5  SMDR search results information

<table>
<thead>
<tr>
<th>Column heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media server</td>
<td>The Media server box identifies the telephone system (with or without MiTAI) that produced the event record.</td>
</tr>
<tr>
<td>Start time</td>
<td>The Start time of a call is reported in hours and minutes in either a 12- or 24-hour format. If a 12-hour clock is used, the letter P indicates P.M. (HH:mm)</td>
</tr>
<tr>
<td>Date</td>
<td>The Date box displays the date of the event record (month/day/year).</td>
</tr>
<tr>
<td>Total duration</td>
<td>The duration of a call is reported in hours, minutes and seconds (hh:mm:ss). Leading zeros are output (Maximum time = 99 hours, 59 minutes, 59 seconds). If the call duration exceeds 100 hours, a call duration of 99 hours, 99 minutes, 99 seconds will be recorded.</td>
</tr>
<tr>
<td>Calling party</td>
<td>The Calling party is the identity of the party that/who originated the call. It may be a station, an attendant, or an incoming trunk, as described below:</td>
</tr>
<tr>
<td></td>
<td>(a) Station number as Calling party (cccc). A station number (extension number or agent ID) may be one to four digits (0-9, *, #) which are left-justified (that is, no leading zeros).</td>
</tr>
<tr>
<td></td>
<td>(b) Attendant as Calling party (ATTm). Calls originated by an attendant that do not involve a third party are reported as a calling party by ATT, followed by the console number. When the console number is in the range of 10 through 99, the format is modified to be ATmm. If an attendant calls an outside party on behalf of a station or trunk, that station or trunk is reported as the caller but the attendant flag symbol [*] is shown in the Attendant was Involved box.</td>
</tr>
<tr>
<td></td>
<td>(c) Trunk number as Calling party (Tnnn or Xnnn). When the originating party is an incoming CO trunk, Tnnn is shown on the record, where nnn is the number of the trunk. If the trunk number is less than three digits long, it is left-padded with zeros. If the extended digit length option is enabled, the trunk number nnnn may be up to four digits long, left-justified and without leading zeros. When the originating party is an incoming non-CO trunk, Xnnn is shown in the trunks record. The T or X ensures that CO trunks and CO Attendant trunks can be distinguished from tie trunks. The trunk number is the trunk ID specified during customer data entry in the Trunk Assignment form.</td>
</tr>
<tr>
<td>Attendant flag</td>
<td>This 1-digit box contains an asterisk [*] when a call is assisted by, or initially answered by, an attendant. This flag will not be shown if a call is transferred to an attendant.</td>
</tr>
<tr>
<td>Time to answer (Time to Ans)</td>
<td>This is the number of seconds from the time an incoming external call rings the destination until the call is answered. If a call is never answered, this box displays three asterisk [***]. Leading zeros are output and the box remains at 999 when an overflow is reached. If the Call Distribution (MCD) feature package is installed, and the MCD report transfers option is enabled, this box contains the total time to answer regardless of the number of times the call is rerouted. This box does not apply to Internal SMDR. <strong>NOTE:</strong> Time to answer does not include the duration the request waits in queue outside of regular business hours.</td>
</tr>
</tbody>
</table>
**Table 10-5 SMDR search results information**

<table>
<thead>
<tr>
<th>Column heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digits dialed</td>
<td>External SMDR records the digits dialed on the outgoing trunk. A maximum of 26 digits is recorded. This number is reduced to 20 when the Report Meter Pulses option is selected in CDE. This box does not include the trunk group access code on outgoing calls. The digits recorded are the actual digits outpulsed on the trunk after digit modification has been performed. On incoming calls, the digits dialed in on the trunk are recorded. The digits dialed field contains the digits the telephone system used to route the call. For an incoming call this could be the extension or the path to which the call is being routed. For outgoing calls this is the number the caller dialed. When more than 26/20 digits are dialed, the remaining digits are ignored. If the MCD option is enabled, each device is listed whenever the call is rerouted, rather than the last device as in non-MCD loads. To reflect the MCD option, the Digits dialed on the Trunk box displays dd1 ddd2 ddd3.</td>
</tr>
</tbody>
</table>
| Call completion flag | External SMDR (Outgoing calls) This reports the completion status of an outgoing call in so far as the telephone system is able to determine it. When an outgoing call fails toll-denial checking and is dropped, this box contains a T. When the trunk group is programmed to receive Answer Supervision and a supervision is received, an A is reported. When the trunk group is programmed for Toll Reversal and a supervision is received, a T is reported.  
External SMDR (Incoming calls) The telephone system can monitor the outcome of a call and can provide a comprehensive report on call completion. When the station or hunt group to which a call is directed is busy, a B is recorded. When an incoming trunk accesses an invalid number and receives reorder tone, an E is reported. An E is also reported for incomplete calls. A T is reported if the incoming trunk is answered with Trunk Answer From Any Station (TAFAS) and if an outgoing trunk call is toll denied, or if the call is Pickup answered. When an incoming call is forwarded by an attendant to a busy station, a B is shown in the call completion status box, the number called is shown as the third party, and the Attendant is shown as the called party.  
Internal SMDR An I indicates that an internal call was completed.  
Speed Call or Call forward flags (S or F) This box contains an S when the number is speed dialed, and an F when an external call is forwarded through the external call forward feature. If Internal SMDR is enabled, an F is also recorded when an internal call is forwarded through the call forward feature. However, for internal calls the Third Party box does not contain the number of the station that initiated the call forward feature. The Third Party box is left blank because the Digit dialed box identifies the station that has call forward enabled. |
| Speed call forward | The Speed call/Forward check boxes search for call records involving a speed dial and/or conference function. When the Blank check box is selected, the search output contains records where there is nothing recorded in the Speed or Fwd check boxes. |
### Table 10-5 SMDR search results information

<table>
<thead>
<tr>
<th>Column heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Called party</td>
<td>A Called party can be a station number, an attendant, or for outgoing calls, the outgoing trunk number. The Called party output format is identical to that used for the Calling party. See Calling party. For incoming calls to an attendant, the called party is recorded as the attendant unless the attendant transfers a call to a station. For direct-in-lines, it would be the station number. On outgoing calls handled by an attendant, the called party would be the outgoing trunk’s ID.</td>
</tr>
<tr>
<td>Transfer/Conference call (Trans Conf)</td>
<td>This box identifies calls involving three or more parties. It contains a T for supervised transfers, X for unsupervised transfers (that is, transfer in to busy reports a T, transfer in to ringing reports an X), and a C for 3-way conversations or conferences.</td>
</tr>
<tr>
<td>Third party</td>
<td>The Third party box contains the number of the station to which a trunk call has been transferred. When several transfers take place during a trunk call, the first party is the only one reported, as long as MCD Report transfers = No, and Record transfers = No. If an external call is made to a station whose call forwarding is set to an external number, the Third party box contains the number of the station that initiated the call forward feature. For internal calls, the Third Party box is left blank because the Digit dialed box identifies the station that has external call forward enabled.</td>
</tr>
<tr>
<td>Account Code</td>
<td>Enabling the report Account Codes option in the SMDR Options Assignment form allows an Account Code of two to 12 digits to be recorded here, if one is used to make a call. Leading zeros are reported if they are entered.</td>
</tr>
<tr>
<td>Route optimization flag</td>
<td>At the starting and end nodes of a network call a flag will be shown in this box if route optimization has taken place. A route optimized call involves two trunks to the same party: the pre-optimization trunk and the post-optimization trunk. An SMDR record will be produced for both trunks, which will be distinguished by a lower case r for the pre-optimization trunk, and an upper case R for the post-optimization trunk. Route optimization is available with the MSDN/DPNSS Voice IV feature package only.</td>
</tr>
<tr>
<td>ANI/DNIS</td>
<td>ANI/DNIS digits are recorded in this box. ANI and DINS numbers can be up to 10 digits in length, and are recorded for incoming calls on ANI/DNIS trunks. COS option ANI/DNIS reporting must be enabled.</td>
</tr>
<tr>
<td>System identifier</td>
<td>This optional 3-digit box may contain values from 000 to 999. 000 indicates that no identifier has been entered. In the absence of a System identifier, a Node identifier is printed (when programmed). When more than one node identifier exists, the first one on the programmed list is printed. When both a System ID and a Node ID are programmed, the System ID takes precedence. Programming of System Identifiers and Node Identifiers is described in the Customer data entry volume.</td>
</tr>
<tr>
<td>Call ID</td>
<td>The Call ID box specifies the call number to which the record relates.</td>
</tr>
<tr>
<td>Call ID seq</td>
<td>The Sequence ID box specifies the sequence number assigned to the call record.</td>
</tr>
<tr>
<td>Assoc call ID</td>
<td>The Associated ID box specifies the number attached to associated data records of the call.</td>
</tr>
<tr>
<td>System ID</td>
<td>This optional 3-digit box may contain values from 000 to 999. 000 indicates that no identifier has been entered. In the absence of a System identifier, a Node identifier is printed (when programmed). When more than one node identifier exists, the first one on the programmed list is printed. When both a System ID and a Node ID are programmed, the System ID takes precedence. Programming of System Identifiers and Node Identifiers is described in the Customer data entry volume.</td>
</tr>
<tr>
<td>Record</td>
<td>See “SMDR record boxes” on page 307.</td>
</tr>
</tbody>
</table>
### SMDR record boxes

This section describes the SMDR search output records available. The information originates from the "SX-2000 Applications Package" on the "SX-2000 Technical Documentation CD-ROM" (PN 9125-080-221-NA).

The telephone system records SMDR data in table format. Table 10-6 provides information used to interpret the SMDR Inspector search output. It summarizes the SMDR record boxes and provides the meaning of the symbols used.

**Table 10-6 Summary of boxes in SMDR records**

<table>
<thead>
<tr>
<th>Name</th>
<th>Format</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>mm/dd</td>
<td>mm = Month</td>
<td>dd = Day</td>
</tr>
<tr>
<td>Start time</td>
<td>hh:mm[p]</td>
<td>hh = Hours</td>
<td>mm = Minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>p = pm</td>
<td>hh = 00 - 12 or 00 - 23</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>mm = 00 - 59</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>p = P.M. (12-hour clock)</td>
</tr>
<tr>
<td>Duration of call</td>
<td>hh:mm:ss</td>
<td>hh:mm:ss = duration in hours:minutes:seconds</td>
<td>hh = 00 - 99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>mm = 00 - 99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ss = 00 - 99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>hhhh:mm:ss = duration in hours:minutes:seconds</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>hhhh = 0000 - 9999</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>mm = 00 - 99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>ss = 00 - 99</td>
</tr>
<tr>
<td>Calling party</td>
<td>pppp</td>
<td>ccccc = Extension #</td>
<td>Tnnn = Trunk # (CO)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tnnn = Trunk # (CO)</td>
<td>Xnnn = Trunk # (non-CO)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ATTm = Attendant</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ppppppp</td>
<td>ccccccc = Extension #</td>
<td>Tnnnn = Trunk # (CO)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tnnnn = Trunk # (CO)</td>
<td>Xnnnn = Trunk # (Non-CO)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ATTmm = Attendant</td>
<td></td>
</tr>
<tr>
<td>Attendant</td>
<td>f</td>
<td>* = Attendant</td>
<td>c = 0 - 9, *, #</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-- = Attendant not involved</td>
<td>nnn = 000 - 999</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>m = Console # (ATmm for Attendant 00 - 99)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>c = 0 - 9, *, #</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>nnnn = 0000 - 999</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>mm = Console #</td>
</tr>
<tr>
<td>Time to answer</td>
<td>ttt</td>
<td>ttt = time in seconds (000 - 999) *** = Call unanswered</td>
<td>Leading zeros output. Incoming calls only.</td>
</tr>
<tr>
<td>Digits dialed on the trunk</td>
<td>xx...x</td>
<td>Up to 26 (20 if metering) digits dialed on the trunk</td>
<td>x = 0 - 9, *, #</td>
</tr>
<tr>
<td></td>
<td>x...x y...y</td>
<td>Network Format: up to 26 digits (20 if metering) in total</td>
<td>y = 0 - 9, *, #</td>
</tr>
<tr>
<td></td>
<td>or Tx...x y...y (Network Format)</td>
<td></td>
<td>x...x = Node ID &amp; Extension # (up to 14 digits)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>y...y = actual digits dialed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tx...x = Node ID &amp; Trunk #</td>
</tr>
<tr>
<td>Call completion status</td>
<td>h</td>
<td>A = Answer supervision</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B = Called party busy</td>
<td>Incoming Direct/Dial-in</td>
</tr>
<tr>
<td></td>
<td></td>
<td>E = Caller error</td>
<td>Incoming/Dial-in incoming</td>
</tr>
<tr>
<td></td>
<td></td>
<td>I = Internal call</td>
<td>Incoming/Outgoing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>T = Toll-denied, TAFAS answered, or Pickup answered</td>
<td></td>
</tr>
</tbody>
</table>

...
# Table 10-6 Summary of boxes in SMDR records

<table>
<thead>
<tr>
<th>Name</th>
<th>Format</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Speed call or</td>
<td>S or F</td>
<td>S = Number was Speed called</td>
<td>Outgoing</td>
</tr>
<tr>
<td>Call fwd flags</td>
<td></td>
<td>F = External call forwarded through</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>External call fwd feature or internal</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>call forwarded through Call forward feature</td>
<td></td>
</tr>
<tr>
<td>Called party</td>
<td>qqqq</td>
<td>ccccc = Extension #</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tnnn = Trunk # (CO)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Xnnn = Trunk # (non-CO)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>ATTm = Attendant</td>
<td></td>
</tr>
<tr>
<td></td>
<td>qqqqqqq</td>
<td>cccccc = Extension #</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tnmm = Trunk # (CO)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Xnmm = Trunk # (non-CO)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>ATTmm = Attendant</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>c = 0 - 9, *, #</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>nnn = Range specified in telephone system form programming</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>m = Console # (ATmm for Attendant 00 - 99)</td>
<td></td>
</tr>
<tr>
<td>Transfer/</td>
<td>K</td>
<td>T = Supervised transfer</td>
<td>U and I only apply to ACD TELEMARKETER® 2000.</td>
</tr>
<tr>
<td>Conference call</td>
<td></td>
<td>X = Unsupervised transfer</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>C = 3-Way or Conference</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>R = re-queue call</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>U = Path unavailable</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>I = Interflow</td>
<td></td>
</tr>
<tr>
<td>Third party</td>
<td>rrrr</td>
<td>ccccc = Extension #</td>
<td></td>
</tr>
<tr>
<td></td>
<td>rrrrrr</td>
<td>cccccc = Extension #</td>
<td></td>
</tr>
<tr>
<td>Account Code (opt.)</td>
<td>aa....a</td>
<td>Length of 2 to 12 digits</td>
<td>a = 0 - 9, space-filled</td>
</tr>
<tr>
<td>Route optimization flag</td>
<td>s</td>
<td>r = pre-optimization trunk</td>
<td></td>
</tr>
<tr>
<td>(opt.)</td>
<td></td>
<td>R = post-optimization trunk</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- = Space (no route optimization)</td>
<td></td>
</tr>
<tr>
<td>System identifier</td>
<td>iii</td>
<td>Entered by System ID</td>
<td></td>
</tr>
<tr>
<td>(optional)</td>
<td></td>
<td>i = 0 - 9</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>iii = 000 - 999</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>000 = No code entered</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>In the absence of a System ID, a Node ID is printed (if programmed).</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>When both System ID and Node ID are programmed, System ID takes precedence.</td>
<td></td>
</tr>
<tr>
<td>ANI/DNIS</td>
<td>xx...xxxxxxx</td>
<td>Format</td>
<td>For Extended digit length format only the 7 right most DNIS digits</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-aaaaaaaaaa-ddddddddddd</td>
<td>are recorded</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- = blank</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>a = ANIS digit</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>d = DNIS digit</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Extended digit length format</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>-aaaaaaaaaaa-ddddddd</td>
<td></td>
</tr>
</tbody>
</table>
Running call parties searches

You can run a Call party search to find out who called agent 2005 on March 10, 2004.

To run a Call parties search

1. Click the SMDR Inspector criteria tab.
   The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click Start search.
   The SMDR Inspector results - SMDR Search results window opens.

Call parties search results

The SMDR Search results tab displays the results of who called agent 2005. The agent’s extension is 1106. He answers calls that come to queue 280 and dial zeros (which is extension 1290). On line one of the results, an outside call dialed the agent’s extension. On line two, the agent answered a call from his queue (P280). On line three, we see that extension 1107 called the agent. On line four, we see that extension 1112 called his extension. (See Figure 10-12.)

Figure 10-12 SMDR search results tab - Call parties search
Running call types searches
You run a Call types search when you want to narrow down the Call parties search. Previously, you have completed a Call parties search for agent 2005 (Call parties tab). Now you want to narrow the search to include only Answer non-ACD call types.

To run a Call types search
1. Click the SMDR Inspector criteria tab. The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click the Call types tab.
7. Under Call types, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click Start search. The SMDR Inspector results - SMDR Search results window opens.

Call types search results
The SMDR search results tab displays the call parties/call type results. All of the non-ACD calls received by agent 2005 on March 10, 2004 are displayed. They included external and internal calls where the caller dialed the agent's extension (1106), and all of the dial zero calls. (ACD calls are calls that are sent through the queue.) (See Figure 10-13.)

Figure 10-13  SMDR search results - Call types search
Running option searches

You run Option searches to narrow down further, Call types and Call parties searches. Previously, you ran a Call parties search for agent 2005, and then a Call types search to include only Answer non-ACD calls. Now you want to search for Answer non-ACD calls for agent 2005 that occurred between 9:00 A.M. and 1:00 P.M.

To run an Options search

1. Click the **SMDR Inspector criteria** tab. The Options tab opens.
2. Click the **Call parties** tab.
3. Click **Select dates** and select March 10, 2003.
4. Under **Select media servers**, **Phone** is preselected.
5. Under **Call parties**, type the Called party, agent ID 2005.
6. Click the **Call types** tab.
7. Under **Call types**, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click the **Options** tab.
9. Under **Time ranges**, after the Start At time, type 9:00:00.
11. Click **Start search**. The SMDR Inspector results - SMDR Search results window opens.

Options search results

The SMDR search results tab displays the call parties/call type/options results. All of the non-ACD calls received by agent 2005 on March 10, 2004 between 9:00 A.M. and 1:00 P.M. are displayed. They included external and internal calls where the caller dialed the agent’s extension (1106), and all of the dial zero calls. (ACD calls are calls that are sent through the queue.) For results column heading descriptions, see “SMDR search results information” on page 304. (See Figure 10-14.)

Figure 10-14  SMDR Search result - Options search

<table>
<thead>
<tr>
<th>M</th>
<th>Start Time</th>
<th>Date</th>
<th>Total Duration</th>
<th>Call...</th>
<th>T</th>
<th>Digits Dialed</th>
<th>I</th>
<th>S</th>
<th>Call...</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Phone</td>
<td>03/10/2004</td>
<td>00:00:25</td>
<td>T8101</td>
<td>1</td>
<td>1106</td>
<td></td>
<td></td>
<td>2005</td>
</tr>
<tr>
<td></td>
<td>Phone</td>
<td>03/10/2004</td>
<td>00:00:25</td>
<td>T8102</td>
<td>1</td>
<td>1106</td>
<td></td>
<td></td>
<td>2005</td>
</tr>
<tr>
<td></td>
<td>Phone</td>
<td>03/10/2004</td>
<td>00:00:13</td>
<td>T8103</td>
<td>8</td>
<td>1106</td>
<td></td>
<td></td>
<td>2005</td>
</tr>
</tbody>
</table>
Running searches for error and information records

Using the Option tab you can run a search for error and information records. The error messages are records of sequence errors. The information records are records of when the Collector restarts.

Previously, you ran a Call parties search for agent 2005, and then a Call types to include Answer non-ACD that occurred between 9:00 A.M. and 1:00 P.M.

To run an Exception event search
1. Click the SMDR Inspector criteria tab.
   The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click the Call types tab.
7. Under Call types, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click the Options tab.
9. Under Time ranges, after the Start At time, type 9:00:00.
10. Under Time ranges, after the End At time, type 12:59:59.
11. Under Exceptions, select the Error records and Information records check boxes.
12. Click Start search.
   The SMDR Inspector results - SMDR Search results window opens.

Exception search results

There was an information record produced every five minutes. Either the alarm is set incorrectly (the system thinks it should be receiving data because the business hours indicate the business is open), or the connection has died. The Exception results tab displays error and information records. (See Figure 10-15.)

The Exception search has the following results information:

Media server
The Media server box identifies the telephone system (with or without MiTAI) that produced the event record.

Record
The Data record box displays detailed information on the exception record.
Figure 10-15  SMDR search results - Exception results tab

<table>
<thead>
<tr>
<th>Media Server</th>
<th>Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 06:58:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----SetNoDataAlarmActive-[TCP;10.1.2.2:1752];[SMDR Records]-[300 Secs Since Record]-Closing Port!</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 06:58:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----CPF One Stream:FinishStartComReset-Closing Port-[TCP;10.1.2.2:1752];[SMDR Records]-Fo...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 06:58:50</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----Opening Port-[TCP;10.1.2.2:1752];[SMDR Records]-RESET COMPLETE...Waiting For Data...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:03:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----StillNoData-[TCP;10.1.2.2:1752];[SMDR Records]-[600 Secs Since Record]-Closing Port!</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:03:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----CPF One Stream:FinishStartComReset-Closing Port-[TCP;10.1.2.2:1752];[SMDR Records]-Fo...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:03:50</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----Opening Port-[TCP;10.1.2.2:1752];[SMDR Records]-RESET COMPLETE...Waiting For Data...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:08:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----StillNoData-[TCP;10.1.2.2:1752];[SMDR Records]-[000 Secs Since Record]-Closing Port!</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:08:20</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----CPF One Stream:FinishStartComReset-Closing Port-[TCP;10.1.2.2:1752];[SMDR Records]-Fo...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:08:51</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----Opening Port-[TCP;10.1.2.2:1752];[SMDR Records]-RESET COMPLETE...Waiting For Data...</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:13:21</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----StillNoData-[TCP;10.1.2.2:1752];[SMDR Records]-[1200 Secs Since Record]-Closing Port!</td>
</tr>
<tr>
<td>Phone</td>
<td>INFORMATION-Wednesday, March 10, 2004 07:13:21</td>
</tr>
<tr>
<td>Phone</td>
<td>INFO----CPF One Stream:FinishStartComReset-Closing Port-[TCP;10.1.2.2:1752];[SMDR Records]-Fo...</td>
</tr>
<tr>
<td>SMDR Search Results</td>
<td>Exception Results</td>
</tr>
</tbody>
</table>

Wild card searches

NOTE:

- To search for a string of numbers within a digits dialed string, enclose the string of numbers in parenthesis, such as “8905”. The search will produce records that include 8905 only in the digits dialed string.
- To search for records where the calling, called or third party involved a trunk (BOTH T and X in one search), put a C in the calling, called or third party box.

When performing searches on the Queue Events tab, you can enter a P800 under Queue information and the search will produce records involving Queue 800 only. Alternatively, you can run wild card searches. When you perform wild card searches, you use * to represent the wild card. For example, if you enter "*00" under Queue information on the Queue events tab, the search will produce records for all of the Queues or Agent groups that end in "00" (for example, 200, 300).

Exporting search results

You can save the ACD Inspector and SMDR Inspector search results in the following formats:

- HTML
- Microsoft Excel
- Microsoft Access
- XML
- Text
To export the search results

1. Click **Save search**. The Inspector Search Results Export window opens.
2. Select the format in which you want the search results saved: **HTML, Microsoft Excel, Microsoft Access, XML**, or **Text**.
3. Click **Next**.
4. Click the ellipses to select the location where you want to save the file.
5. After **File name**, type the file name.
6. Click **Save**.
7. Click **Next**.
8. Click **Next** to confirm the format in which you want to save the file and the location of the file. A window opens with the message "Inspector Search Results export to \[export type\] complete."
9. Click **OK**.
10. Click **Finish**. A window opens with the message "Would you like to view/open this file now?"
11. If you want to view the file immediately, click **Yes**. The file opens.

**Auditor**

Using Contact Center Auditor you can view historical, multimedia real-time events, at your own pace. Auditor makes it easy for you to analyze when and why past service problems occurred. You can see a series of events that led to a problem and analyze when and why it occurred. In the future, you will be able to recognize when another problem is about to occur.

For example, you notice that on July 15 you have 12 contacts abandon between 10:00 AM and 10:15 AM. You can review the contacts and the agents’ actions on that date for that time period with Auditor. Did all of the contacts arrive at the same time? Did all of the agents go on break at the same time? If all of the contacts arrived at once, you need to schedule more people. If all of the agents went on break at the same time, you need to adjust their break schedule.

Using Auditor you can also track when employees log on and log off the system. It is easy to determine if any of the employees consistently start late or finish early.

The first tool bar consists of real-time monitors that provide information on agent availability, queue statistics, and graphic displays on queues. (See Figure 10-16.)

Using Auditor, you can use existing profiles, including alarm thresholds, when viewing past days run in real-time.

**Figure 10-16 Auditor**

![DefaultProfile - Contact Center Client](image)
Auditor icons

Using Auditor’s second toolbar you select the date of the historical real-time events that you want to view and the speed at which to play the events. The icons are described in Table 10-7.

Table 10-7 Auditor Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="calendar.png" alt="Calendar" /></td>
<td>Calendar</td>
<td>You can select the date of the historical real-time events that you want to view by clicking the calendar.</td>
</tr>
<tr>
<td><img src="speed.png" alt="Speed of audit" /></td>
<td>Speed of audit</td>
<td>The Speed of audit is expressed as a ratio of real-time to play speed. You can select the speed from a list of ratios that opens when you click the clock: 1:1, 1:2, 1:5, 1:10, 1:30, 1:60, and 1:120. If you select the ratio 1:1, it will take you one second to view one second of the past day. If you select 1:60, it will take you one second to view one minute of the past day.</td>
</tr>
<tr>
<td><img src="rewind.png" alt="Rewind" /></td>
<td>Rewind</td>
<td>If you click Rewind when the play is stopped, you jump back to the beginning of the day.</td>
</tr>
<tr>
<td><img src="stop.png" alt="Stop" /></td>
<td>Stop</td>
<td>You can stop the real-time historical events from playing, and jump back to the beginning of the day, by clicking Stop.</td>
</tr>
<tr>
<td><img src="pause.png" alt="Pause" /></td>
<td>Pause</td>
<td>You can pause the real-time historical events by clicking Pause.</td>
</tr>
<tr>
<td><img src="play.png" alt="Play" /></td>
<td>Play</td>
<td>You can play the real-time historical events by clicking Play.</td>
</tr>
<tr>
<td><img src="step.png" alt="Step forward" /></td>
<td>Step forward</td>
<td>You can select the increment (in seconds) you will advance from a list that opens when you click the down arrow to the right of Step forward: 1 sec, 2 sec, 5 sec, 10 sec, 15 sec, 30 sec, and 45 sec. If you select 30 seconds, then when the play is stopped, you can step forward in 30 second increments each time you click Step forward. When you reach the end of data for that day, you will automatically jump to the end of the day.</td>
</tr>
<tr>
<td><img src="jump.png" alt="Jump forward" /></td>
<td>Jump forward</td>
<td>You can select the increment (in minutes) you will advance from a list that opens when you click the down arrow to the right of Jump forward: 1 min, 2 min, 5 min, 10 min, 15 min, 30 min, and 60 min. If you select 10 minutes, then when the play is stopped, you can jump forward in 10 minute increments each time you click Jump forward. When you reach the end of data for that day, you will automatically jump to the end of the day.</td>
</tr>
<tr>
<td><img src="slider.png" alt="Slider" /></td>
<td>Slider</td>
<td>As you view the events of the day, the slider indicates the time at which the events occurred. The length of the slider represents the length of the day for which you are viewing historical real-time events.</td>
</tr>
</tbody>
</table>
Viewing historical real-time events
You start Contact Center Client to gain access to Auditor functionality. For more information on Contact Center Client real-time monitoring, see “Contact Center Client” on page 240.

To view historical real-time events, you must

1. Start Contact Center Client.
2. Open the grids in which you want to view historical events.

Starting Contact Center Client
You must start Contact Center Client before you can view Auditor.

To start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password.
3. Click OK.

Opening monitors
NOTE: You cannot view the Contact Center Client marquee, Network Monitor, Interactive Visual Queue, Contact Center PhoneSet Manager, or Contact Center Softphone applications (which function in real time only) in Auditor.

You must open the monitors in which you want to view historical events with Auditor. In the following example we will open the Agent State by Position monitor.

To open a grid

1. Click View=>Real time to view the Contact Center Client icons.
2. Click the Position icon and select Agent State by Position.
3. Under Agent groups, select agent groups to monitor and/or under Agents, select agents to monitor.
4. Click OK.

Starting Auditor
NOTE: If you are using the Contact Center Client marquee, Network Monitor, Interactive Visual Queue, Contact Center PhoneSet Manager, or Contact Center Softphone applications (which function in real time only), open Auditor in another instance of Contact Center Client.

To open Auditor

1. Click View=>Auditor controls to view the auditor toolbar and to switch from real-time to Auditor mode.
2. On the second toolbar, click the calendar and select a date.
   The date opens to the left of the slider.
3. Click the clock and select the speed of audit.
   The speed of audit, expressed as a ratio of real-time to play speed, opens to the right of the clock.
4. Click the play button to play the real-time events of the selected date.
   The historical real-time events start to play.
   See Figure 10-17.
Figure 10-17  Auditor: Agent State by Time (playing)
Network Monitor
Troubleshooting data collection issues
Data Collection

The telephone system generates real-time and historical data used to manage your contact center. You use real-time data to monitor the current Call Load and agent availability, and make minute-to-minute adjustments. You use historical information for forecasting, staffing, and scheduling.

The Enterprise Server Collector Service writes SMDR and ACD data to text files. The text files are located on the Enterprise Server in C:\Program Files\prairieFyre Software Inc\CCM\DataDirectory\Node_x

Network Monitor

The Network Monitor application resides in Contact Center Client. Network Monitor provides information on the status of media server real-time data collection. You can verify if alarms are enabled for your media servers and if the media servers are reporting any alarms.

Viewing Network Monitor

**NOTE:** When you open Contact Center Client, it automatically points Network Monitor to the Enterprise Server default IP address. If you have more than one server at your site, ensure that Contact Center Client is pointing to the correct server.

Network Monitor is available to users whose security permissions permit them to use Network Monitor.

To view Network Monitor

1. Click **Start==>Programs==>Mitel==>Contact Center Client**.
2. Type your user name and password.
3. Verify the Enterprise Server IP address.
4. Click **Log on**.
5. The Contact Center Client window opens.
6. Click **View==>Network Monitor**.

Opening the Network Monitor

After you view Network Monitor, you can minimize or close it. When you close Network Monitor, it resides in the Network Monitor toolbar.

To open Network Monitor from the toolbar

- Double-click the Network Monitor toolbar.
  Network Monitor opens.

Viewing alarms

In Network Monitor, the Enterprise and Media server windows display critical alarms and warning alarms. Critical alarms are activated when Collector Service is not receiving data, the Enterprise Server disk space is low, and in other instances where the Enterprise Server is prevented from functioning optimally. When there is a critical alarm, Network Monitor displays the alarm and you are emailed a notification. Warning alarms are activated when license violations occur, duplicate records are created, and for other non-critical issues. When there is a warning alarm, the Network Monitor icon in the System Tray blinks.

**NOTE:** You must configure settings for your SMTP mail server in YourSite Enterprise in order to receive alarm notifications by email.

In YourSite, you can configure alarms to notify you if Collector Service is not receiving data or if the server disk space is low. See “Configuring data alarms for media servers” on page 105. (See Figure 11-1.)
To view a summary of alarms and the status of the Enterprise Server

- In the Enterprise window, under **Description**, view if there are any critical alarms and if the Enterprise Server is online.

To view the status of the alarms

- In the Media servers window, view any Critical alarms and Warning alarms. The Media Servers window displays all critical and non-critical alarms for the media servers installed on the Enterprise Server and remote servers.

To view data and system alarms with Administrative tools:

- On the Enterprise Server, click **Start=>Settings=>Control Panel=>Administrative tools=>Event viewer** to view more information on the error.

**Figure 11-1  Network Monitor**

![Network Monitor](image)

**Enterprise: Critical alarms: 1  Warning alarms: 0**

<table>
<thead>
<tr>
<th>Severity</th>
<th>Description</th>
<th>Start time</th>
<th>End time</th>
<th>Alarm ID</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>At least one critical alarm is being reported on your network</td>
<td>9/19/2006</td>
<td>11:50:22 A</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>The Enterprise Server is online</td>
<td>9/19/2006</td>
<td>11:50:21 A</td>
<td>26</td>
</tr>
</tbody>
</table>

**Media servers: Critical alarms: 1  Warning alarms: 1**

**Source: 6120: Critical alarms: 0  Warning alarms: 0**

<table>
<thead>
<tr>
<th>Severity</th>
<th>Description</th>
<th>Start time</th>
<th>End time</th>
<th>Alarm ID</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Media Server is Online</td>
<td>9/19/2006</td>
<td>11:50:20 A</td>
<td>26</td>
</tr>
</tbody>
</table>

**Source: I0 Server: Critical alarms: 0  Warning alarms: 1**

**Source: pfad1: Critical alarms: 0  Warning alarms: 0**

**Source: pfad2: Critical alarms: 1  Warning alarms: 0**

**Source: Pfprim: Critical alarms: 0  Warning alarms: 0**
Verifying media servers are receiving telephone system data

The Data link window displays the following information:

- **SMDR/ACD** displays SMDR/ACD records as they arrive from the telephone system.
- **Records today** displays the total number of SMDR/ACD records received by Collector Service for the day that were valid SMDR or ACD records.
- **Last received** displays the date and time Collector Service received the SMDR/ACD record last sent.
- **Clear records** clears the records displayed on the Data links window.
- **Reset SMDR link/Reset ACD link** button resets the SMDR/ACD data link from the telephone system to Collector Service when SMDR data stream/ACD data stream shows no data is streaming. If you attempt to reset the link and data does not start streaming, check your cabling connections from the telephone system to the TCP/IP sockets of the server.

To verify a media server is receiving telephone system data

1. In the Media Servers window, under the media server, click **Data link**. The Data link window opens. See Figure 11-2.

To reset the data links

1. In the Media Servers window, under the media server, click **Data link**. The Data link window opens.
2. If no data is streaming in the SMDR or ACD panes, click **Reset SMDR/ACD link**.

Figure 11-2 Data link for the Intelligent Queue Server
Configuring enterprise and media server alarm notifications

You can define alarms notifications that alert you when the Enterprise Server and media servers are not functioning optimally. You can specify the severity of, and performance thresholds for each server malfunction.

Client notifications are specific to each computer. You can be notified of enterprise and media server alarms in several ways:

- A pop-up notification opens on your desktop.
- A sound prompt, such as a beep or .wav file, plays.
- You are notified by email.
- Contact Center Client opens on top of all open applications.

To configure notifications

1. Add alarm thresholds.
2. Specify threshold colors.
3. Specify threshold notification.

Adding alarm thresholds

When configuring thresholds for alarms, you must specify the following alarms as warnings rather than critical alarms (because these alarms will always be warnings when they are active):

- No alarms configured
- PBX PC time drift
- ACD sequence number error
- Alarm outside of business hours
- Maintenance
- Intelligent Queue Watchdog Service is down
- Intelligent Queue low disk space
- Intelligent Queue has detected a MiTAI error

You configure all other alarms as critical because they will have a severity of critical when they are triggered.

In addition to configuring an alarm threshold with a severity of warning or critical (for a specific alarm), you can configuring an alarm threshold with a severity of normal. Network Monitor then notifies you when the alarm is cleared.

To add performance thresholds for enterprise and media server alarms

1. In Network Monitor, right-click the Enterprise window (to configure enterprise alarm notifications) or the Media server window (to configure media server alarm notifications) and select Set enterprise notifications or Set media server notifications.
   The Set alarms window opens.
2. Under Devices, select the enterprise server or one or more servers/media servers or select the Select all check box to select all servers/media servers.
3. In the Performance variables list, select an alarm type.
4. Under Alarm Thresholds, click Add value.
5. Under Severity select Normal, Warning, or Critical.
6. Click OK.
Specifying threshold colors

To configure performance threshold colors
1. For the alarm threshold for which you want to specify colors, under Background, click the arrow. A color palate opens.
2. Select a color.
3. Under Font color, click the arrow. A color palate opens.
4. Select the font color for the alarm threshold.
5. Click OK.

Specifying threshold notification

To configure performance threshold sound notification
1. For the alarm threshold for which you want to be notified by a sound, under Sound, select the check box. The Sound window opens.
2. Specify the alarm triggering properties.
3. Specify the sound you want played when the alarm is triggered.
4. Click Save.

To configure performance threshold pop-up window notification
1. For the alarm threshold for which you want to be notified by a pop-up window, under Pop-up, select the check box. The Pop-up window opens.
2. After Duration, type the number of seconds you want the pop-up alarm to be displayed when threshold conditions are satisfied.
3. If you want to display the pop-up alarm on top of all of the other applications, select the Keep this message visible on mouse over check box.
4. Optionally, click the Format font button to specify font attributes for the pop-up alarm message.
5. In the text box, type the message for the performance threshold and click the Add variable button to insert performance variables. (for example, type CW P001 = <calls waiting variable>).
6. Click Save.

To specify that Contact Center Client opens on top of all other applications when a performance threshold is satisfied
1. For the alarm threshold for which you want to be notified, under Bring to front, select the check box.

To configure performance threshold email notification
1. For the alarm threshold for which you want to be notified, or notify others by email, under Email, select the check box. The Email window opens.
2. After Distribution, specify which contacts are to be notified by email when threshold conditions are satisfied. See “Emailing reports” on page 262.
3. After Subject, type the subject of the email to be sent (for example, type Calls Wtg in Sales Queue 1 >10!).
4. In the message box, type the body of the email.
5. Click Save.
Troubleshooting data collection issues

If data is not being collected for a particular voice media server (has “timed out”), Network Monitor will display the SMDR/ACD data collection timeout alarm.

There are several possible reasons why data does not stream. The following solutions address the most common streaming problems:

**SMDR data is not streaming**

SMDR data records are generated at the end of calls. If SMDR data is not flowing through the TCP/IP sockets, then the telephone system is not producing data records, your Class of Service and/or SMDR Options Assignment forms are not configured correctly, or something is wrong with the TCP/IP sockets.

If SMDR data is not streaming
1. On a client computer or on the Enterprise Server, in Network Monitor, on the Data link window of the telephone system media server, click **Reset SMDR Link** to restore the connection.
2. Wait 60 seconds.
3. If you have an ethernet connection, verify it is up and running.
4. If SMDR data is still not flowing, on the Enterprise Server, verify the SMDR Options and Class of Service Options Assignment forms are configured correctly on the telephone system. See “Common 3300 IPC and SX-200 programming errors” and “Programming reporting options for the 3300 ICP/SX-2000” in the *Mitel Contact Center Management Installation Guide*.
5. If SMDR data is still not flowing, on the Enterprise Server, use a hyperterminal session to verify data is flowing through the TCP/IP sockets.
7. If SMDR data is still not flowing, call prairieFyre software at 613-599-0045, option 3.

**ACD data is not streaming**

ACD data records are generated with each agent event and with periodic refresh events produced by the telephone system. If ACD data is not flowing through the TCP/IP sockets, then the telephone system is not producing data records or something is wrong with the TCP/IP sockets.

If ACD data is not streaming
1. On a client computer or on the Enterprise Server, in Network Monitor, on the Data link window of the telephone system media server, click **Reset ACD Link** to restore the connection.
2. Wait 60 seconds.
3. If you have an ethernet connection, verify it is up and running.
4. If ACD data is still not flowing, on the Enterprise Server, use a hyperterminal session to verify data is flowing through the TCP/IP sockets.
5. Restart Collector Service.
6. If ACD data is still not flowing, please call prairieFyre software at 613-599-0045, option 3.

**Viewing the data collection TCP/IP ports with Hyperterminal**

You can use Hyperterminal to verify if data is flowing from the TCP/IP sockets.

To view the TCP/IP sockets with Hyperterminal
2. Click **Start=>Programs=>Accessories=>Communications=>HyperTerminal**.
3. Create a session (using the TCP/IP address displayed on the Data link window in Network Monitor) and verify data is flowing through the TCP/IP sockets.
**Restarting Collector Service**

You must restart Collector Service after you view the TCP/IP sockets with Hyperterminal.

To stop Collector Service

1. On the Enterprise Server, click **Start=>Settings=>Control Panel=>Administrative Tools=>Services**.
2. Right-click **prairieFyre Collector Service (v5)** and click **Restart**.
Chapter 12

Interactive Contact Center

Using Interactive Contact Center
Interactive Contact Center

Interactive Contact Center is an optional application that enables supervisors who have a 3300 ICP, 5000, or Axxess telephone system to control the availability of agents and ACD queues. Agents can control their own availability: they can log themselves on or off, and place themselves in or remove themselves from Make Busy or Do Not Disturb.

Using Interactive Contact Center

Interactive Contact Center is designed for agents and supervisors.

Supervisors and Interactive Contact Center

Using Interactive Contact Center, supervisors can
- Control the availability of agents and ACD queues
- Log agents on and off of the telephone system
- Remove agents from particular queues and place them in other queues
- Place agents in Make Busy
- Place agents in Do Not Disturb
- Place queues in Do Not Disturb

If an agent has multiple voice agent IDs, the agent can answer calls for multiple queues. In order to move the agent from one queue to another queue, the supervisor logs off the agent and then logs on the agent using a different agent ID.

You create associations between agents and queues in YourSite Explorer.

You can restrict individual supervisors from managing particular monitors and devices in Contact Center Management, YourSite=>Security.

Agents and Interactive Contact Center

Using Interactive Contact Center, agents can
- Log themselves on and off of the telephone system
- Remove themselves from particular queues and place themselves in other queues
- Place themselves in Make Busy
- Place themselves in Do Not Disturb

You can restrict individual agents from managing particular monitors and devices in Contact Center Management using YourSite Security.

Every time agents leave their desks they must set Make Busy or Do Not Disturb. There are many reasons why agents leave their desks. You assign each of these reasons a Make Busy or Do Not Disturb Reason Code and then agents can apply the codes. When you run an Agent Performance by Make Busy / DND Code report, the report clearly indicates when an agent went in Make Busy or Do Not Disturb, and why (which code the agent selected each time).
Starting Contact Center Client

You start Contact Center Client to access real-time functionality. Supervisors and agents can view real-time voice statistics. In contact centers that have the optional Multimedia Contact Center application, supervisors and agents can view real-time voice, email, chat, and fax statistics. After starting Contact Center Client, you can choose to minimize it to either the system tray or the taskbar, depending on your operating system.

If you are working from the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select SSL.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
4. Click Log on.

If you are working outside of the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
2. Select the Connect using Teleworker check box and click Change Teleworker settings.
3. Verify the Teleworker Server IP address.
4. If you use Secure Socket Layer, select SSL and click OK.
   See “Providing Contact Center Client functionality to teleworkers” on page 273.
5. Click Log on.

When you minimize Contact Center Client and you are using Windows XP as your operating system, the Contact Center Client icon displays in your desktop system tray.

If you are using Windows Vista, you can optionally configure Contact Center Client to display in your desktop taskbar.

To display Contact Center Client in the taskbar

1. In Contact Center Client, click Tools=>Options.
2. Under Device control, clear the Hide when minimized check box and click OK.
   Contact Center Client, when minimized, will display in the taskbar.
3. To save the profile, click File=>Save as.
4. Type a Name for the profile and click OK.
   The profile is saved and will automatically be applied each time you open Contact Center Client.

Agent control

Using Interactive Contact Center and Contact Center Client, you can control agents on the following monitors:

- Agent State by Position and Employee State by Position
- Agent State by Time and Employee State by Time
- Agent Shift

Agent control gives you control over individual agents. Monitor control gives you control over all of the agents on a monitor. All of the agents on the monitor are affected simultaneously by the action you take.

NOTE: Monitor control is available only if you configure extensions for your employees.
Hiding the Monitor control option

When you right-click a device on a real-time monitor a menu is displayed. If you have Interactive Contact Center and you are permitted to use agent and queue control, you will see a Monitor control option on this menu. If you do not use Monitor control, you can hide this option so it is not displayed on the menu.

To hide the Monitor control option

1. In Contact Center Client, click **Tools=>Options**.
2. Select the **Display monitor device control option** check box.
3. Click **OK**.

Logging on an agent

**NOTE:**

- An ACD hot desking agent must enter an extension number each time the agents logs on to the telephone system using Interactive Contact Center. The agent cannot rely on the extension number last used when logging on. This is because the ACD data stream unifies the agent ID and the extension. After a hot desking agent logs on or off of the telephone system using Interactive Contact Center, sometimes the Interactive Contact Center agent controls are not available to the agent for two to five minutes.
- Mitel 5000/Axxess agents that are logged on to all available queues are set to work timer. If they are logged on to a single queue, they are set to idle.
- You will be unable to log in an agent to the ACD if there are no available 3300 ICP user licenses.
- If your contact center participates in the use of PINs, supervisors with the correct Class of Service do not require an agent’s PIN to interactively log in a hot desking agent.

In the following example we will use the Agent State by Position monitor to illustrate Agent control.

To log on an agent

1. In Contact Center Client, click **View=>Real time** to view the supervisor monitor icons.
2. Click the **Position** icon and click **Agent State by Position**.
3. Select agents to monitor.
4. Click **OK**.
   
   Contact Center Client displays the devices across the monitor in the order you specified.
   
   **NOTE:** The first time you log on an agent, you must click By extension and specify the agent’s extension number so Interactive Contact Center knows to which phone the agent is logged on.
5. Right-click the cell of an agent who is logged off and click **Agent control=>Log on=>By extension**.
6. After **Agent login**, select one of the agent’s agent login IDs.
7. After **Extension**, type the agent’s extension number.
8. Click **OK**.

Logging off an agent

To log off an agent

- Right-click the cell of an agent who is logged on and click **Agent control=>Log off**.

Logging off all of the agents on a monitor

To log off all of the agents

- Right-click the monitor and click **Monitor control=>Log off**.
Logging an agent out of one queue and into another queue

Employees can log out of one answer point and into another answer point if they have multiple agent login IDs that are associated with different answer points.

For example, Chris Y. has three Agent login IDs: 740, 741, and 742. They are associated with Queues P007, P003, and P001 respectively. Queue P007 is associated with Spanish calls. Queue P003 is associated with French calls. Queue P001 is associated with English calls. When the English call volume increases, Chris can log out of the Spanish Queue and into the English Queue. Figure 12-1 shows Chris logged in using Agent ID 742.

To log Chris out of P007 and into P001

1. Right-click the monitor.
2. Click Agent control=>Log on. A list of available agent login IDs opens.
3. Select 742: Y, Chris from the list.
Chris is now handling English calls.

Figure 12-1 Logging an agent into another queue

Using agent group presence

If you have a Mitel 3300 ICP (MCD 4.0 SP1 and 4.1) or 5000/Axxess telephone system, you can add agents to and remove agents from one or more agent groups using Interactive Contact Center.

NOTE:
- To enable agents to add or remove themselves from agent groups, Group Presence Control must be enabled on the Class of Service Options Assignment form on the Mitel 300 ICP for all agents.
- To enable supervisors to add or remove agents from agent groups, Group Presence Third Party Control must be enabled on the Class of Service Options Assignment form on the Mitel 3300 ICP for all dialable numbers associated to the supervisor in YourSite Explorer.
- Advanced real-time and reporting must be enabled in YourSite Explorer for all agents. See “Adding agents” on page 136.
- Supervisors must have third party control enabled for all dialable numbers in YourSite Explorer.
- For supervisors to control agent group presence in Interactive Contact Center, the agent and at least one of the agent's dialable numbers must be enabled for Real time and reporting or Advanced Real time and reporting. See “Adding agents” on page 136.
- To control agent presence in Interactive Contact Center, you must have the following security role enabled. See “Configuring security” on page 175.
• May control the real-time presence of agents in Interactive Contact Center
• To control supervisor presence in Interactive Contact Center, you must have the following security role enabled. See “Configuring security” on page 175.
• May control my real-time presence in Interactive Contact Center

The Mitel 3300 ICP (MCD 4.0 SP1 and 4.1) enables agents to be placed in or removed from multiple agent groups (up to 16 on the Mitel 3300 MXe II Controller and up to 30 on the Mitel 3300 MXe server). Agents can be added and removed from agent groups using Feature Access Codes (FAC), a Feature Access Key (FAK) programmed on their set, or using Interactive Contact Center.

The agent group presence option is controlled by class of service. Once the appropriate class of service has been set, the agent group presence status can be changed in the following ways.

• Feature access keys can be programmed on a Mitel multiline phoneset. One button would be used to join or leave each agent group to which the agent is a member.
• Supervisors and agents can dial a feature access code followed by the group number to change their status for that group or to change their status for all groups to which they are a member.
• The desktop tool in the embedded system management can be used to make status changes.
• MiTAI controls are also available to make status changes.

Agent group presence best practices
It is important to note that agents may join or leave agent groups but not queues. Agents become absent from a queue indirectly if they leave all agent groups associated with that queue. An agent who is present in an agent group which is associated to all queues would be disassociated from all queues simultaneously if they became absent in their agent group. Since the goal of agent group presence is to provide a dynamic response to varying queue activity, allowing agents to become absent from all queues simultaneously is counterproductive.

As a best practice, we recommend you associate agent groups to queues based on business groups within your organization. A unique agent group to business group queue(s) association allows agents who leave an agent group associated to a particular business group to remain present in an agent group(s) associated to other business group(s).

Adding agents to and removing agents from agent groups
After logging into Contact Center Client, agents use Interactive Contact Center to control their presence status in agent groups. Optionally, supervisors can use Interactive Contact Center to control the presence status of agents in specific agent groups.

NOTE:
• An agent's ACD hot desk line remains in service while they are logged in as an ACD hot desk user even if they are not present in any ACD groups and not receiving ACD calls.
• If you do not own Interactive Contact Center, you will be unable to control an agent's presence status.

To add an agent to an agent group from a real-time monitor
1. Right-click the cell of an agent who is logged on and click **Agent control=>Join/Leave agent group**.
2. Select the agent group(s) to add the agent to.
3. Click **OK**.
Placing agents in Make Busy

To place an agent on a monitor in Make Busy
- Right-click the cell of an agent who is logged on and click Agent control=>Set Make Busy=>reason code.

To place all of the agents on a monitor in Make Busy
- Right-click the monitor and click Monitor control=>Set Make Busy=>reason code.

Removing agents from Make Busy

To remove an agent from Make Busy
- Right-click the cell of an agent who is in Make Busy and click Agent control=>Remove Make Busy.

To remove all of the agents on a monitor from Make Busy
- Right-click the monitor and click Monitor control=>Remove Make Busy.

Placing agents in Do Not Disturb

NOTE:
- For the 5000/Axxess, Synchronization must be performed before Do Not Disturb with Reason codes can be used by agents and supervisors.
- For the 5000/Axxess, if you set an agent to Do Not Disturb and do not enter any notes, clicking Cancel on the Do Not Disturb Notes dialog box will place the agent in Do Not Disturb with no notes, without cancelling the Do Not Disturb state.
- If an agent in Make Busy sets and later removes Do Not Disturb on their extension, work timer will not work until the agent either logs off the telephone system or until calls remove Make Busy on the extension (even though the agent state is set to idle).

To place an agent in Do Not Disturb
- Right-click the cell of an agent who is logged on and click Agent control=>Set Do Not Disturb=>reason code.

To place all of the agents on a monitor in Do Not Disturb
- Right-click the monitor and click Monitor control=>Set Do Not Disturb=>reason code.

Removing agents from Do Not Disturb

To remove an agent from Do Not Disturb
- Right-click the cell of an agent who is in Do Not Disturb and click Agent control=>Remove Do Not Disturb.

To remove all of the agents on a monitor from Do Not Disturb
- Right-click the monitor and click Monitor control=>Remove Do Not Disturb.
Cancelling agents in Work Timer
To cancel an agent in Work Timer
- Right-click the cell of an agent who is in Work Timer and click Agent control=>Cancel Work Timer.

To cancel all of the agents on a monitor in Work Timer
- Right-click the monitor and click Monitor control=>Cancel Work Timer.

Queue Control
Using Interactive Contact Center and Contact Center Client, you can control queues on the Queue Now monitor.

You can control queues
- Manually
- Using a schedule
- Using a Queue control plan

Manually controlling queues
NOTE:
- You can see queue statistics during business hours as long as the business schedule you configure in YourSite=>Schedule is consistent with your company’s hours of operation. You assign business-hours schedules to queues in YourSite=>Configuration=>Queue=>Queue.
- Manual queue control overrides queue schedules and queue control plans.

Interactive Contact Center Queue control enables you to control individual queues. Monitor control enables you to control all of the queues on a monitor.

Hiding the Monitor control option
When you right-click a device on a real-time monitor a menu is displayed. If you have Interactive Contact Center and you are permitted to use agent and queue control, you will see a Monitor control option on this menu. If you do not use Monitor control, you can hide this option so it is not displayed on the menu.

To hide the Monitor control option
1. In Contact Center Client, click Tools=>Options.
2. Select the Display monitor device control option check box.
3. Click OK.

Placing queues in Do Not Disturb
Using manual queue control, you can place queues in and remove queues from Do Not Disturb on the Queue Now monitor. A call will not enter a queue that is in Do Not Disturb. The call is sent to an unavailable answer point programmed in the telephone system.

To place a queue in Do Not Disturb
- Right-click the cell of an active queue and click Queue control=>Set Do Not Disturb.
  See Figure 12-2.
### Figure 12-2 Placing a queue in Do Not Disturb

To place all of the queues on a monitor in Do Not Disturb
- Right-click the monitor and click **Monitor control=>Set Do Not Disturb**.

### Removing queues from Do Not Disturb
To remove a queue from Do Not Disturb
- Right-click the cell of a queue that is in Do Not Disturb and click **Queue control=>Remove Do Not Disturb**.

To remove all of the queues on a monitor from Do Not Disturb
- Right-click the monitor and click **Monitor control=>Remove Do Not Disturb**.

### Controlling queues using a schedule
A Queue control schedule opens queues during business hours and closes queues after business hours.

### Scheduling queues to enter or leave Do Not Disturb
Using a schedule, you can place queues in and remove queues from Do Not Disturb on the Queue Now monitor.

To schedule a queue to enter or leave Do Not Disturb

1. Click **YourSite=>Configuration**.
2. On the **Configuration menu**, click **Queue=>Queue**.
3. Across from a 3300 ICP/5000/Axxess queue, click **Edit**.
4. On the **Interactive Contact Center Queue control** tab, after **Interactive Contact Center Queue control schedule**, select a schedule.
5. Click **Manage schedule**.
6. Click **Edit schedule** or **Create a new schedule**.
   - You can edit the default 24/7 schedule or you can click Create new schedule to create a new schedule.
7. If you are creating a new schedule, after **Name**, type the name of the schedule.
8. Specify the time you want the queue to enter and leave Do Not Disturb.
   - For example, your business opens on Monday at 9:00 A.M. and closes on Friday at 5:00 P.M. You select a start time of 9:00 A.M for the days Monday to Friday. You select an end time of 5:00 P.M for the days Monday to Friday. For Saturday and Sunday you select Disable for day. Your queues will be in Do Not Disturb at all times except for Monday to Friday, from 9:00 A.M. to 5:00 P.M.
9. Click **Apply schedule**.
Controlling queues using Queue control plans

NOTE: You must install Interactive Contact Center before you can use Interactive Contact Center Queue control.

If you have a 3300 ICP/5000/Axxess, using Queue control plans, you can place queues in and remove queues from Do Not Disturb automatically based on predefined criteria. Each queue control plan monitors one queue, and based on the activity of the queue, either places a queue in or removes a queue from Do Not Disturb.

Creating Queue control plans

Queue control plans open and close queues based on plan parameters only during business hours. Each queue is controlled by only one queue control plan at a time. You can apply the same queue control plan to several queues. For information on how to create queue control plans, see “Configuring Interactive Contact Center Queue control” on page 145.
Chapter 13
Interactive Visual Queue

Using Interactive Visual Queue
Interactive Visual Queue

Interactive Visual Queue is a Contact Center Client real-time monitor that works in conjunction with Contact Center Management and Interactive Contact Center. Interactive Visual Queue comprises a Queued calls grid and an Abandoned calls grid. In the Queued calls grid, supervisors and agents can view calls within queues and then use a drag-and-drop operation to move calls from busy queues to less active queues. In the Abandoned calls grid, supervisors can view abandoned call information, including the caller name, phone number, and time of the abandoned call. Agents can use the Abandoned calls grid to call back abandoned callers.

Using Interactive Visual Queue

Interactive Visual Queue works in conjunction with Contact Center Management. Before you use Interactive Visual Queue you must configure options in Contact Center Management so they mirror those of the 3300 ICP, 5000, or Axxess telephone system.

NOTE: In order to use Interactive Visual Queue, you must enable all HCI options on Class of Service Assignment form 1 (COS 1). See “Appendix A 3300 ICP port configuration” in the Intelligent Queue Installation Guide.

Configuring options in Contact Center Management

In YourSite Configuration, for each queue you want to monitor, you must configure the priority level and the method for handling interflowed calls. The values you configure must match the values specified on the Path Assignment form of your telephone system.

NOTE: The YourSite Configuration settings for Interactive Visual Queue monitors do not affect call flow activity on the actual queues. These settings only affect the way Interactive Visual Queue displays the queue monitors in Contact Center Client. If you want to modify call flow on the actual queues, you must change the telephone system settings.

If the telephone system settings and Interactive Visual Queue settings do not match, Interactive Visual Queue will not display the correct call activity. For example, if Queue 1 is set to a priority of 10 on the telephone system and a priority of 20 in YourSite Configuration, Interactive Visual Queue will display calls in Queue 1 as priority 20. However, the actual queue will handle the calls as priority 10.

For more information on changing Interactive Visual Queue options in YourSite Configuration, see “Adding queues” on page 141.

Starting Contact Center Client

Interactive Visual Queue resides in Contact Center Client.

If you are working from the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select SSL.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
4. Click Log on.
If you are working outside of the office, to start Contact Center Client

1. Click **Start=>Programs=>Mitel=>Contact Center Client.**
   **CAUTION:** Do not select “Remember my credentials” if you intend to work both at the office and from home.
2. Select the **Connect using Teleworker** check box and click **Change Teleworker settings**.
3. Verify the Teleworker Server IP address.
4. If you use Secure Socket Layer, select **SSL** and click **OK**.
   See “Providing Contact Center Client functionality to teleworkers” on page 273.
5. Click **Log on**.

**Opening Interactive Visual Queue**

You access Interactive Visual Queue by logging on to Contact Center Client and then opening the Real-time toolbar.

To open an Interactive Visual Queue monitor

1. Log on to Contact Center Client.
2. On the main menu, click **View=>Real time**.
   The Real-time toolbar appears.
3. Click **Now=>Interactive Visual Queue**.
   The Add/Remove device IDs window appears.
4. Select a queue from the Queues list and click **OK**.
   See Figure 13-1.
   **NOTE:** To use Interactive Visual Queue effectively, you should open two or more queue monitors.

**Figure 13-1 Interactive Visual Queue monitor**

```
<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Contact Center Chat Ian C Online</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Position Time Shift Period Now Charts Marquee Adherence</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Logged off Actions Answer Hang up Trans/Conf Cancel Dial pad Account Code Volume</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LOGGED OUT Phonebook</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

**Queued calls**

<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Caller #</td>
<td>Caller Name</td>
<td>Priority</td>
<td>Time Offered to</td>
<td>Time in Queue</td>
<td>Time Offered to</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
<td>-------------</td>
<td>----------</td>
<td>----------------</td>
<td>---------------</td>
<td>----------------</td>
</tr>
<tr>
<td>1</td>
<td>8102302000</td>
<td></td>
<td>0 2:30 PM</td>
<td>00:01:19</td>
<td>2:30 PM</td>
<td>00:01:19</td>
</tr>
</tbody>
</table>

**Abandoned calls**

<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Caller #</td>
<td>Caller Name</td>
<td>Time Abandoned</td>
<td>Time Since Abandoned</td>
<td>Last Callback Employee</td>
<td>Last Callback Time</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>----------------</td>
<td>----------------------</td>
<td>------------------------</td>
<td>-------------------</td>
<td></td>
</tr>
<tr>
<td>2167551230</td>
<td></td>
<td>8/26/2009 3:45 PM</td>
<td>22:45:55</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Ready | Calls in queue 1 | Dalable 2080 |
**Interactive Visual Queue monitor grids**

The Interactive Visual Queue monitor comprises the Queued calls grid and the Abandoned calls grid. The Queued calls grid lists the calls that are currently in the selected queue. The Abandoned calls grid lists abandoned calls. The calls are listed in order of priority, and the columns cannot be sorted. You can configure the column headings and specify which columns are displayed.

The following list provides descriptions of the column headings available in the Queued calls grid:

- **Position (#)** displays the answer position relative to other calls in the queue
- **Caller Number** is the originating phone number of the call
- **Caller Name** is the name associated with the phone number (if available)
- **Priority** is the priority of the call in the queue (the lower the number, the higher the priority)
- **Time Offered to Queue** is the time the call entered the current queue
- **Time in Queue** is the call's total time in the current queue
- **Time Offered to System** is the time the call first entered the system
- **Time in System** is the call's total time in the system
- **Queue Hops** is the number of times a call has changed queues
- **Call ID** is a unique identification number that is assigned to the call by the telephone system
- **DNIS Number** displays the DNIS identification number associated with the digits dialed by the customer, as configured in Contact Center Management
- **DNIS Name** displays the name you have configured in Contact Center Management for the associated DNIS number
- **Collected Digits** displays the customer-entered digits provided by Intelligent Queue. Collected digits requires Intelligent Queue and Collect Caller-entered Digits or Verified Collected Digits and, optionally, Remote Database Verification or CTI Developer Toolkit
- **Collected Information** displays the single or series of collected results provided by Intelligent Queue. Collected information requires Intelligent Queue and Verified Collected Digits and, optionally, Remote Database Verification or CTI Developer Toolkit

The following list provides descriptions of the column headings available in the Abandoned calls grid:

- **Caller Number** is the originating phone number of the call
- **Caller Name** is the name associated with the phone number (if available)
- **Time Abandoned** is the time at which the caller abandoned the queue
- **Time Since Abandoned** is the elapsed time since the caller abandoned the queue
- **Last Callback Employee** is the employee name and employee ID associated with the most recent callback attempt
- **Last Callback Time** is the time at which the most recent callback was attempted
- **Time Offered to Queue** is the time the call entered the queue
- **Time in Queue** is the call's total time in the queue
- **Time Offered to System** is the time the call first entered the system
- **Time in System** is the call's total time in the system
- **Queue Hops** is the number of times a call has changed queues
- **Call ID** is a unique identification number that is assigned to the call by the telephone system
- **DNIS Number** displays the DNIS identification number associated with the digits dialed by the customer, as configured in Contact Center Management
- **DNIS Name** displays the name you have configured in Contact Center Management for the associated DNIS number
- **Collected Digits** displays the customer-entered digits provided by Intelligent Queue. Collected digits requires Intelligent Queue and Collect Caller-entered Digits or Verified Collected Digits and, optionally, Remote Database Verification or CTI Developer Toolkit
- **Collected Information** displays the single or series of collected results provided by Intelligent Queue. Collected information requires Intelligent Queue and Verified Collected Digits and, optionally, Remote Database Verification or CTI Developer Toolkit
Redirecting calls
A call can move between queues automatically (interflow) or manually (redirection).

Interflow
You can configure queue settings on the telephone system to automatically move a call from one queue to another after a specific duration. For example, you can configure your system to move a call from Queue 1 to Queue 2 if the call has not been answered within 30 seconds. Interflow occurs without any user interaction.

Redirection
Using Interactive Visual Queue, you can manually redirect a call from a queue to another queue or a dialable number.

There are two ways a call can be removed from the system. If a call is moved more than 10 times, either by redirection or by interflow, the call is dropped from the system. You can see the current number of times a call has moved between queues in the Queue Hops column. A call will also be automatically removed from the system if its total time in the system exceeds 24 hours. The Total Time column lists the call’s duration in the system.

You can manually redirect a call in the Queued calls grid using the following methods:
- Drag and drop a call between queues.
- Use the right-click menu to move a call between queues.
- Use the right-click menu to send a call to a specific dialable number (for example, an extension, callback port, or voice mail port).

You may notice that the first two methods perform the same action. However, the second method is convenient when queue monitor is maximized and you want to move a call without having to resize one or more monitors.

NOTE: If you right-click a call and redirect it to a specific extension, the call will no longer be considered an ACD call for reporting purposes. If you redirect a call using either of the other two methods, the call remains an ACD call.

When you manually redirect (drag and drop) a call in Interactive Visual Queue, Contact Center Management changes the way the call is pegged on the Queue Performance reports. If you redirect a call before the short abandon time set for the queue, the call is pegged as Unavailable. If you redirect a call after the short abandon time set for the queue, the call is pegged as Interflowed. An internal ACD call is pegged as Abandoned if the call is redirected at any time.

Redirecting calls between queues
To redirect a call from one queue to another queue using a drag-and-drop operation
1. In the Queued calls grid, click anywhere in the row of the call you want to move.
2. Use a drag-and-drop operation to move the call from its original queue monitor to a new queue monitor.

To redirect a call from one queue to another queue using the menu
1. In the Queued calls grid, right-click the row of the call you want to redirect and click Send to. A list of available queues appears.
   NOTE: You can select multiple rows to move multiple calls to a new queue.
2. Click the name of the queue to which you want to move the call.
Redirecting calls to specific numbers

Using the Send to menu option, you can redirect calls in Interactive Visual Queue to any extension. In addition, if you have Contact Center Softphone installed, you can send a call directly to your own extension by selecting Send to=>Me.

To redirect a call to a dialable number

1. In the Queued calls grid, right-click the row of the call you want to redirect and click Send to=>[Extension]. When you click [Extension], it changes to a text box.
2. Type a number in the text box and press Enter.

See Figure 13-2.

**NOTE:** You cannot use the Extension option if you have multiple calls selected. Only one call can be sent to a dialable number at a time.

Figure 13-2  Redirecting a call to an extension

To redirect a call to your extension

1. In the Queued calls grid, right-click the row of the call you want to redirect.
2. Click Send to=>Me.

**NOTE:** This option is not available unless you have Contact Center Softphone installed and configured on your computer.
Removing calls

To remove a call from Interactive Visual Queue

1. Right-click the row of the call you want to remove.
2. Click Delete.
   The call is removed from Interactive Visual Queue.

NOTE: Deleting a call from an Interactive Visual Queue monitor will not remove it from the actual queue. This will just cause Interactive Visual Queue to stop tracking the call.

Calling back abandoned callers

The Abandoned calls grid displays abandoned call information and enables agents to call back abandoned callers.

NOTE:

• If you want Interactive Visual Queue to automatically insert 1 when calling back long distance phone numbers, you must program your telephone system ARS accordingly. For more information, see "Automatic Route Selection (ARS)" in the Mitel 3300 ICP System Administration Tool Help.
• Abandoned call information is automatically deleted from the Abandoned calls grid after 24 hours.
• Abandoned calls can not be transferred to agents.

To call back an abandoned caller

1. Right-click the row of the abandoned call you want to call back, and select Call to automatically dial the abandoned caller.
   NOTE: Each time an agent attempts to call back an abandoned caller, their name and ID are attached to the call record and display in the Last callback employee column of the Abandoned calls grid.
2. After you have contacted the abandoned caller, right-click the row associated with that call, and select Delete to remove the abandoned call record from the Abandoned calls grid.

Configuring alarms

You set alarms on Interactive Visual Queue monitors similar to the way you set alarms on Contact Center Client monitors. The main difference is that some of the variables you can monitor, Caller Number, Caller Name, DNIS Number, DNIS Name, Collected Digits, and Collected Information, use a string for their value as opposed to a threshold boundary. For example, you can set an alarm that is triggered when a specific name appears in the Caller Name column.

The value you type for Caller Number or Caller Name alarms is a wildcard, which means the alarm will trigger if that value appears in any form. For example, if you configure a Caller Name alarm for the value John, the alarm will trigger for the values John Smith, Johnathan, longjohn, and so on.

To configure alarms:

1. Right-click an Interactive Visual Queue monitor and click Set alarms.
   The Set Alarms window appears.
2. Under Performance variables, select the variable you want to monitor.
3. Under Alarm thresholds, click Add value and select a boundary (or value) for the variable you selected as well as the alarm type(s) that will indicate when the variable exceeds those boundaries. For more information on configuring monitor alarms, see “Setting alarms” on page 209.
4.  If you want to add further alarms for the variable, repeat step 3.
5. Click OK to save the alarms.
Understanding call priority

Each queue has a default priority level. When a call enters the system for the first time, the call adopts the default priority of whichever queue it enters. If all calls in a queue have the same priority, the position of the calls are based on each call’s total time in the current queue. If a queue contains calls that have multiple priority levels, higher priority calls will have a higher position in the queue than lower priority calls.

As long as a call remains in a queue, it maintains its priority. However, if a call moves from one queue to another queue, the call’s priority may change, based on the method used to move the call.

When you redirect a call manually, the call always adopts the default priority level of the destination queue. For example, suppose Queue 1 has a priority of 1 and Queue 2 has a priority of 15. When a call first enters Queue 1, it has a priority of 1. However, if you manually move that call to Queue 2, using either a drag-and-drop operation or the right-click menu, the call priority lowers to 15. The rules work the same in reverse. If you manually move a priority 15 call from Queue 2 to Queue 1, the call priority increases to 1 when it enters Queue 1.

Calls interflowed automatically retain the original call priority, or adopt the priority of the new queue based on telephone system settings. The interflow options you specify for a queue on the Interactive Visual Queue tab in YourSite Configuration must be identical to those of the telephone system. For more information on configuring interflowed calls, see “Adding queues” on page 141.
Chapter 14

Contact Center PhoneSet Manager and Contact Center Softphone

Using Contact Center PhoneSet Manager and Contact Center Softphone
Contact Center PhoneSet Manager and Contact Center Softphone

The Contact Center PhoneSet Manager and Contact Center Softphone applications are designed for the 3300 ICP telephone system. They provide ACD agent functions and enable agents to use their desktop computers as IP-based phones.

NOTE:
- Soft phone is not supported on the Enterprise Server.
- Interactive Contact Center is required to control the availability of agents and ACD queues. See “Interactive Contact Center” on page 331.

Using Contact Center PhoneSet Manager and Contact Center Softphone

Contact Center PhoneSet Manager and Contact Center Softphone enable agents to use their desktop computers as IP-based phones. Contact Center PhoneSet Manager automates Mitel IP phone sets from the computer desktop. An agent who uses Contact Center PhoneSet Manager has a headset connected to a desk phone. Contact Center Softphone provides complete phone set functionality from the computer desktop. A computer and wired or wireless USB headset deliver calls to the agent.

Starting Contact Center Client

Contact Center Softphone and Contact Center PhoneSet Manager reside in Contact Center Client.

If you are working from the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
2. Type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select SSL.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
4. Click Log on.

If you are working outside of the office, to start Contact Center Client

1. Click Start=>Programs=>Mitel=>Contact Center Client.
   CAUTION: Do not select “Remember my credentials” if you intend to work both at the office and from home.
2. Select the Connect using Teleworker check box and click Change Teleworker settings.
3. Verify the Teleworker Server IP address.
4. If you use Secure Socket Layer, select SSL and click OK.
   See “Providing Contact Center Client functionality to teleworkers” on page 273.
5. Click Log on.

Supported phone sets

Contact Center PhoneSet Manager is designed for the 3300 ICP (5235, 5330, 5340, and Navigator) telephone system.
Tested headsets

We have tested the following headsets to confirm they work with Contact Center PhoneSet Manager:
- GN Netcom GN 6120 Bluetooth office headset—wireless (part number GN 6120)
- Plantronics SupraPlus Noise-Canceling—monaural (part number H251N)
- Plantronics SupraPlus Noise-Canceling—binaural (part number H261N)
- GN Netcom Monaural over-the-head, SoundTube clarity (part number GN 2110 ST)
- GN Netcom Binaural over-the-head, SoundTube (part number GN 2115 ST)

**NOTE:** In order for the Plantronics and GN Netcom headsets to work with Contact Center PhoneSet Manager you must have the correct amplifier adaptor for the Mitel phones.

We have tested the following headsets to confirm they work with Contact Center Softphone:
- Plantronics DSP PC 500—binaural (part number DSP 500)
- Plantronics CS50 Wireless Office Headset System (part number CS50)
- Plantronics SupraPlus Noise-Canceling—monaural (part number H251N)
- Plantronics SupraPlus Noise-Canceling—binaural (part number H261N)
- GN Netcom Monaural over-the-head, SoundTube clarity (part number GN 2110 ST)
- GN Netcom Binaural over-the-head, SoundTube (part number GN 2115 ST)

**NOTE:** In order for the Plantronics and GN Netcom headsets to work with Contact Center Softphone you must have the correct USB adaptor.

**USB-to-headset adaptors**

For Contact Center Softphone, the Plantronics H251N and H261N and the GN Netcom GN 2110 ST and GN 2115 ST headsets must be connected to your computer by a USB-to-headset adaptor. We have tested the following USB-to-headset adaptors to confirm they work with Contact Center Softphone:
- Plantronics DA60 USB-to-Headset Adaptor (part number DA60)
- GN Netcom USB-to-headset adaptor (part number GN 8110)
- GN Netcom USB-to-headset adaptor (part number GN8120)

You can integrate the GN 8120 with Contact Center Softphone and use the three different function buttons on the GN 8120 to perform specific functions in Contact Center Soft phone. Table 14-1 shows the GN 8120 button functions.

**Table 14-1  GN 8120 button functions**

<table>
<thead>
<tr>
<th>Button</th>
<th>State</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue volume control</td>
<td>Any state</td>
<td>Increases or decreases the headset speaker volume, which controls the volume at which you can hear a caller</td>
</tr>
<tr>
<td>White button</td>
<td>Any state</td>
<td>Turns the mute function on or off</td>
</tr>
<tr>
<td>Green button</td>
<td>Incoming call is ringing on one of your line appearances</td>
<td>Answers a call</td>
</tr>
<tr>
<td></td>
<td>You are currently talking to someone, and you do not have anyone on consultation hold</td>
<td>Hangs up a call</td>
</tr>
<tr>
<td></td>
<td>You are currently talking to someone, and you have someone on consultation hold</td>
<td>Performs a swap with the party on hold</td>
</tr>
<tr>
<td>Red button</td>
<td>You are currently talking to someone, and you do not have anyone on consultation hold</td>
<td>Places the current call on hold</td>
</tr>
<tr>
<td></td>
<td>You currently have someone on hold</td>
<td>Retrieves the call on hold</td>
</tr>
<tr>
<td></td>
<td>You are currently talking to someone, and you have someone on consultation hold</td>
<td>Cancels the current call and returns you to the party on hold</td>
</tr>
</tbody>
</table>
Table 14-2 shows situations where the LEDs will be lit or flashing based on the state of Contact Center Softphone.

<table>
<thead>
<tr>
<th>What you are doing</th>
<th>GN 8120 LED displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>All lines are idle, and the mute function is off</td>
<td>All LEDs are off</td>
</tr>
<tr>
<td>The mute function is on</td>
<td>Blue LED above the white button is on</td>
</tr>
<tr>
<td>A call is ringing</td>
<td>Green LED above green button is flashing</td>
</tr>
<tr>
<td>You are currently dialing, waiting for an answer, or</td>
<td>Green LED above green button is on</td>
</tr>
<tr>
<td>talking to someone, and you do not have anyone on hold</td>
<td></td>
</tr>
<tr>
<td>You are currently talking to someone, and he has put</td>
<td>Green LED above green button is flashing</td>
</tr>
<tr>
<td>you on hold</td>
<td></td>
</tr>
<tr>
<td>You put someone on hold</td>
<td>Red LED above red button is on</td>
</tr>
<tr>
<td>You are currently talking to someone, and you have</td>
<td>Green LED above green button is on</td>
</tr>
<tr>
<td>someone on consultation hold</td>
<td>Red LED above red button is flashing</td>
</tr>
</tbody>
</table>

**Integrating the GN 8120 with Contact Center Softphone**

To integrate the GN 8120 with Contact Center Softphone

1. Log on to Contact Center Client.
2. On the main menu, click **View=>Soft phone**.
3. Click **Soft phone**.
4. After **Input audio device**, choose the GN 8120.
5. After **Output audio device**, choose the GN 8120.
6. Click **OK**.

For more information about the GN 8120, visit the product page on GN Netcom’s website at http://www.gnnetcom.com/US/EN/MainMenu/Products/Computer-VoIP/GN8120USB.htm.

**Setting up the soft phone**

The functionality of Contact Center PhoneSet Manager and Contact Center Softphone is similar. For simplicity, we will use **soft phone** when referring to features and functionality common to both applications.

**NOTE:**

- Before you set up the soft phone on your client computer, ensure your network administrator has configured your soft phone as a 5020 IP phone on the telephone system.
- Users who are upgrading to Contact Center Management Version 5.7 SP1 or greater must uninstall MiAUDIO Desktop Edition before they use Contact Center Softphone. MiAUDIO is now bundled in the Contact Center Management software and no longer runs as the IP Phone Emulation Service.
- Although Inter-Tel users can log in to multiple extensions simultaneously, this functionality is not currently supported by Contact Center Solutions applications.

To set up a client computer to use the soft phone

1. Consult your network administrator to confirm your soft phone extension number.
2. Ensure your headphone is connected.
3. Configure sound and audio device properties.
   See "Configuring sound and audio device properties" on page 356.
   See "Installing Client Component Pack using an administrative procedure" on page 44.
5. Run Client Component Pack.
   See "Installing Client Component Pack using an administrative procedure" on page 44.
Configuring sound and audio device properties

To configure sound and audio device properties for Windows XP and Vista operating systems, you must set the PC speakers as the default audio device and adjust the volume of the PC speakers, headset speakers, and headset microphone.

Configuring sound and audio device properties for Windows Vista

The following procedures describe how to configure sound and audio device properties for Windows Vista.

To set the PC speakers as the default audio device

1. In Control Panel, double-click **Sound** to open the Sound dialog box.
2. Select the **Playback** tab.
3. Click the **Speakers** icon.
4. Click the **Set Default** button.
5. Click **OK** to save the Speakers as your default device.

This enables your PC speakers to be used as the default audio device, so when you receive calls on the soft phone, the ring tone plays through your headset and your PC speakers.

To adjust the PC speaker volume

1. In Control Panel, double-click **Sound** to open the Sound dialog box.
2. Select the **Playback** tab and double-click the **Digital Output Device** icon.
3. Select the **Levels** tab and adjust the PC speaker volume by moving the **Digital Output Device** volume slider from left to right.
4. Click **OK** to save your volume setting.
5. Click **OK** to close the Sound dialog box.

To adjust the headset speaker volume

1. In Control Panel, double-click **Sound** to open the Sound dialog box.
2. Select the **Playback** tab and double-click the **Speakers** icon.
3. Select the **Levels** tab and adjust the headset speaker volume by moving the **Audio output** volume slider from left to right.
4. Click **OK** to save your volume setting.
5. Click **OK** to close the Sound dialog box.

To adjust the headset microphone volume

1. In Control Panel, double-click **Sound** to open the Sound dialog box.
2. Select the **Recording** tab and double-click the **Microphone** icon.
3. Select the **Levels** tab and adjust the headset microphone volume by moving the **Microphone** volume slider from left to right.
4. Click **OK** to save your volume setting.
5. Click **OK** to close the Sound dialog box.

Configuring sound and audio device properties for Windows XP

The following procedures describe how to configure sound and audio device properties for Windows XP.

To set the PC speakers as the default audio device

1. In Control Panel, double-click **Sounds and Audio Devices**.
2. Select the **Audio** tab and select your sound card device from the **Default device** drop-down under **Sound playback**.
   This enables your PC speakers to be used as the default audio device, so when you receive calls on the soft phone, the ring tone plays through your headset and your PC speakers.
3. Click **OK** to save your settings.
To adjust the PC speaker volume

1. In Control Panel, double-click **Sounds and Audio Devices**.
2. Select the **Volume** tab and adjust the PC speaker volume by moving the **Device volume** slider from left to right.
3. Click **OK** to save your settings.

To adjust the headset speaker volume

1. In Control Panel, double-click **Sounds and Audio Devices**.
2. Select the **Voice** tab and select your headset device from the **Default device** drop-down list under **Voice playback**.
3. Click the **Volume** button, located under **Voice Playback**.
4. Adjust the headset speaker volume by moving the **Volume** slider, located under **Speaker**, up or down.
5. Click **OK** to save your settings.

To adjust the headset microphone volume

1. In Control Panel, double-click **Sounds and Audio Devices**.
2. Select the **Audio** tab and select your headset device from the **Default device** drop-down list under **Sound recording**.
3. Click the **Volume** button, located under **Sound recording**.
4. Adjust the headset microphone volume by moving the **Volume** slider up or down.
5. Click **OK** to save your settings.

**Opening the soft phone**

To open the soft phone

1. Click **Start=>Programs=>Mitel=>Contact Center Client**.
2. On the main menu, click **View=>Soft phone**.
   
   See Figure 14-1.
3. Click **Add Extensions** to search and select from all extensions.

4. Select your phone extension from the list of extensions. 
   **NOTE:** Although Inter-Tel users can log in to multiple extensions simultaneously, this functionality is not currently supported by Contact Center Solutions applications.

5. If you have Contact Center PhoneSet Manager, click **Desk phone**. If you have Contact Center Softphone, click **Soft phone**.

6. If you want to log on automatically to the soft phone with your phone extension the next time you open the current profile, select the **Remember my extension** check box. 
   You must save the current profile before you quit the soft phone for this option to work.
   If you are a hot desk agent who participates in the use of PINs, the PIN login dialog box opens. If you are a traditional agent or a hot desk agent who does not participate in the use of PINs, go to step 9.

7. Type your **Login PIN**.
   If you want Contact Center Client to remember your Login PIN, select the Remember your credentials check box. This option is not available if your Contact Center Client profile is shared.

8. Click **Login**.
   **NOTE:** If the Login PIN you entered is invalid the login will fail and you will be asked to enter a valid Login PIN.

9. If you want Contact Center Client to be the top-most window on ringing, select the **Bring to front on ringing** check box.

10. If you selected Soft phone in step 5, under **Soft phone settings**, configure soft phone options.

11. After **Address book source for contacts**, select **YourSite contacts** or **Outlook contacts**. 
   Contact Center PhoneSet Manager and Contact Center Softphone users can access YourSite database phone extensions or Outlook Personal Contact or Global Address List phone numbers when they handle calls.
12. To automatically log off the agent from the telephone system when closing the soft phone, select the **Automatically log off this ACD agent when closing the soft phone** check box.

13. If you want to synchronize online presence indicators with ACD agent states in real-time monitors, select the **Synchronize my Office Communicator presence with my ACD state** check box.

14. If you want to show call notes on the soft phone display and on the Call Notes monitor, ensure the **Display call notes** check box is selected.

15. Click **OK**.

The Contact Center Client window displays the soft phone, Phone and Functions toolbars. See Figure 14-2.

**Figure 14-2 Soft phone toolbars**

Logging on to the ACD

Agents can log on to the ACD a number of ways, such as selecting the Superkey button in Contact Center Softphone, or using the agent control function in Interactive Contact Center. See “Contact Center PhoneSet Manager and Contact Center Softphone” on page 353.

We recommend that soft phone users who are hot desking agents log on to the ACD using the soft phone Actions menu. This enables the soft phone to identify agents.

To log on to the ACD

- On the soft phone **Functions** toolbar, click **Actions=>Log on** and select an agent ID.

**NOTE:** When a hot desk agent logs in to the ACD a 3300 ICP user license is taken from the available licensing pool and when the agent logs out the license is released back to the licensing pool. Agents are notified upon login attempt if the number of concurrent logins exceeds the number of available user licenses. If there are no available user licenses the login attempt will fail.

Phone and Functions toolbars

The Phone toolbar displays your:

- Extensions (grey oval buttons)
- Hold button (red oval button)
- Superkey button (blue oval button, for Contact Center Softphone only)
- Current phone state (Idle, Dialing, Talking) box with a down arrow that displays a call details window
- Dial box (field for dialing extensions or phone numbers)
- Dial button (Contact Center PhoneSet Manager only)
- Redial button (Contact Center Softphone only)
- Cancel button (Contact Center Softphone only)
- Message button (for retrieving voice mail messages, Contact Center Softphone only)
The Functions toolbar displays
- Your current ACD state (Logged On/Off, in Make Busy, in Do Not Disturb)
- The ACD actions currently available
- Telephony buttons
  See “Displaying, hiding, and retiring toolbar buttons” on page 362.

**Phone functions**

You can readily answer calls or forward them to extensions or phone numbers using the soft phone. You can select people from contact and speed dial lists, and perform the following actions: Redial (Contact Center Soft phone only), Transfer, Conference, Mute, Forward, Request help, Hold, Retrieve, Split, Swap, Camp on, Leave a message, Retrieve a message, Call me back, Hang up, and Cancel.

Table 14-3 lists the soft phone telephony options and their corresponding meanings.

**Table 14-3  Agent actions**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account Code</td>
<td>tags a call with an Account Code</td>
</tr>
<tr>
<td>Answer</td>
<td>answers a ringing call</td>
</tr>
<tr>
<td>Auto answer</td>
<td>If enabled, answers a ringing call without you having to click Answer</td>
</tr>
<tr>
<td>Call me back</td>
<td>notifies you as soon as the extension number you are trying to call is available</td>
</tr>
<tr>
<td>Camp on</td>
<td>notifies an employee you are attempting to call with a series of audible beeps</td>
</tr>
<tr>
<td>Cancel</td>
<td>terminates your connection to a caller and reconnects you to the held party</td>
</tr>
<tr>
<td>Conference</td>
<td>connects three or more people together for a conversation</td>
</tr>
<tr>
<td>Dial pad</td>
<td>enables you to dial a number using a keypad</td>
</tr>
<tr>
<td>Forward</td>
<td>forwards a call to a phone number or extension</td>
</tr>
<tr>
<td>Hang up</td>
<td>terminates a call</td>
</tr>
</tbody>
</table>
Table 14-3  Agent actions

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hold</td>
<td>places the current call on hold</td>
</tr>
<tr>
<td>Leave a message</td>
<td>leaves a message waiting notification on an employee’s extension</td>
</tr>
<tr>
<td>Mute</td>
<td>if you have Contact Center Softphone, disables your microphone so you can consult privately with another employee while on a call</td>
</tr>
<tr>
<td>Request help</td>
<td>calls an employee who can click Answer and listen to an in-progress call without the caller knowing</td>
</tr>
<tr>
<td>Retrieve</td>
<td>picks up a call that is held or camped on to your extension</td>
</tr>
<tr>
<td>Speed dial</td>
<td>enables you to make a call to a specified number with one mouse click</td>
</tr>
<tr>
<td>Split</td>
<td>disconnects one person from a conference call</td>
</tr>
<tr>
<td>Swap</td>
<td>swaps between the current and the held party</td>
</tr>
<tr>
<td>Transfer</td>
<td>forwards an in-progress call to another answer point</td>
</tr>
<tr>
<td>Transfer/Conference</td>
<td>places a caller on hold and makes a consultation call</td>
</tr>
<tr>
<td>Volume</td>
<td>if you have Contact Center Softphone, adjusts the volume of your speakers and/or microphone</td>
</tr>
<tr>
<td>Call Notes</td>
<td>enables you to view the notes associated with the current call and add notes</td>
</tr>
</tbody>
</table>

**Customizing the soft phone**

You can enhance productivity by configuring the following time-saving options in the soft phone:

- Toolbar customization
- Sounds and notifications
- Call forward destinations
- Speed dial contacts
- Shortcut keys
- Pre-announcement messages
Configuring soft phone settings

To specify soft phone settings

1. Right-click the Phone toolbar and click **Configure**.
2. After **Input audio device**, select an audio device for your microphone.
3. After **Output audio device**, select an audio device for your speakers or headset.
4. Click **OK**.

Specifying the address book source for contacts

To specify the address book the soft phone uses for contacts (Microsoft Outlook or the Contact Center Management YourSite database)

1. Right-click the Phone toolbar and click **Configure**.
2. After **Address book source for contacts**, select **YourSite contacts** or **Outlook contacts**.
3. Click **OK**.

Resizing toolbar buttons

To resize toolbar buttons

1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. After **Functions toolbar**, select a size for displaying the Functions toolbar buttons.
4. After **Phone toolbar**, select a size for displaying the Phone toolbar buttons.
5. Click **OK**.

Displaying, hiding, and retiring toolbar buttons

You can display telephony buttons, hide them so they appear on the Functions toolbar only when required, and retire them for actions you rarely perform, such as Camp on and Request help.

**To display telephony buttons**

1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. Under **Selected buttons**, select the check boxes of the telephony buttons you want to display.
4. Click **OK**.

**To hide telephony buttons**

1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. Under **Selected buttons**, clear the check boxes of the telephony buttons you want to hide from view.
4. Click **OK**.

**To retire telephony buttons**

1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. Under **Selected buttons**, select the telephony buttons you want to retire and click the left arrow to add these buttons to the Available buttons list.
4. Click **OK**.
To restore telephony buttons
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. Under **Available buttons**, select the telephony buttons you want to restore and click the right arrow to add these buttons to the **Selected buttons** list.
4. Click **OK**.

**Repositioning toolbar buttons**
To specify the order in which telephony buttons appear
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Toolbars** tab.
3. Under **Selected buttons**, select a telephony button.
4. Click the up or down arrow to change the position of the button relative to other buttons on the **Functions toolbar**.
5. Click **OK**.

**Configuring sounds and notifications**
You can configure sounds for individual phone events for incoming calls, secondary incoming calls, and/or the digits dialed on your primary extension, or on all extensions. A primary incoming call is a call you receive while you are in the idle state and are available to take the call. A secondary incoming call is a call you receive while you are on a call on another extension and are not available to take the call.

Every time you receive a call a pop-up window notifies you the call has arrived. You can disable the pop-up notification.

To configure a sound for a phone event
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Sounds** tab.
3. Select the **Incoming calls, Secondary incoming calls**, and/or **Play sounds when dialing digits** check boxes.
4. After **Phone events**, select a phone event.
5. After **Sound file name**, click **Browse** and select a sound file.
6. If you want to play the sound file when the phone event occurs on any of your extensions, click **Apply to all lines**.
7. Click **OK**.

To disable the call arrival pop-up notification
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Sounds** tab.
3. Under **Phone events**, click a phone line.
4. Clear the **Display pop-up notification for incoming calls** check box.
5. Click **OK**.

**Making calls ring through your computer speakers**
You can make calls ring through your computer speakers instead of your headset.

To make calls ring through your computer speakers
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Sounds** tab.
3. After **Play the rings sounds on** select the sound output device for your computer speakers.
Adjusting the volume of your speakers and microphone

If you have Contact Center Softphone, you can adjust the volume of your speakers and microphone.

To adjust the volume of your speakers
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Adjust the volume by moving the speaker slider.

To adjust the volume of your microphone
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Adjust the volume by moving the microphone slider.

Configuring call forward destinations

You can forward calls manually to pre-configured call forward destinations. In addition, you can configure and enable call forwarding so the telephone systems forwards calls to other answer points when you are temporarily unavailable or away from the office. For example, you could specify all External call busy calls you receive be forwarded to a co-worker's extension. Rather than directing these call to voice mail, the telephone system would forward these calls to your co-worker.

To configure call forward destinations for calls you will forward manually
1. Right-click the Phone toolbar and click Configure.
2. Click the Call forward tab.
3. Under Name, type the name of the person to whom you will forward calls.
4. Under Number, type an extension or phone number (preceded by a number you dial to access an outside line).
5. Click OK.

To configure and enable call forward destinations for calls the telephone system will forward
1. Right-click the Phone toolbar and click Configure.
2. Click the Call forward tab.
3. Specify the source for call forwarding.
4. Specify destinations for the following call types:
   - All calls (all calls you receive)
   - External call busy (external calls to your extension when you are unavailable)
   - External call no answer (external calls to your extension that you do not answer)
   - Internal call busy (internal calls to your extension when you are unavailable)
   - Internal call no answer (internal calls to your extension that you do not answer)
5. If you want to activate the call forwarding rules immediately, select the Enabled check boxes of the call forwarding types to be activated.
6. Click OK.

Configuring speed dial numbers

When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the Functions toolbar.

You can display a button for each speed dial number or display one button with a down arrow that lists all of the speed dial numbers you have configured. You can speed dial calls manually to pre-configured extensions and phone numbers.
To configure a speed dial number
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Speed dial** tab.
3. Under **Name**, type the name of the person to whom you will speed dial calls.
4. Under **Number**, type an extension or phone number (preceded by a number you dial to access an outside line).
5. Click **OK**.

**Configuring shortcut keys**
You can assign a shortcut key to a telephony function to perform it with a simple keystroke. This enables you to perform telephony functions while the soft phone is minimized or another application is currently selected.

To configure a shortcut key for a telephony function
1. Right-click the Phone toolbar and click **Configure**.
2. Click the **Shortcut keys** tab.
3. Under **Shortcut key**, select a telephony function.
4. Click the down arrow, select Ctrl, Alt, Shift, or Win, and select a keyboard number, letter, or function from the list.
5. Click **OK**.

**Configuring pre-announcement messages**
Agents who have Contact Center PhoneSet Manager or Contact Center Softphone can record introductions that are played to callers (for example, “Hi. This is Paul Jones in Customer Support. Could you please tell me your customer site key?”) The introduction that is played is based on the queue the call arrives on and the time of day it is received. The recorded introduction provides customers with a consistent greeting and gives the agent extra time to retrieve customer information. You can stop pre-announcement messages at any time.

You can configure more than one pre-announcement rule. For each rule, you specify the conditions in which the soft phone will play a particular pre-announcement message. If one or more conditions is satisfied for a particular rule, the soft phone will play the associated pre-announcement message. You can order the rules on the Pre-announcement rules table to establish their priority. Pre-announcement rules are evaluated in the order shown in the table. If one pre-announcement rule is satisfied, the associated sound file is played and no other rules are evaluated.

**NOTE:** To use pre-announcement messages with Contact Center PhoneSet Manager, you must have a Mitel ACD desk phone (for example, 5212) and a PCTI adaptor. The PCTI adaptor enables the audio being played from the agent PC and the audio from the agent desk phone to be mixed.

To configure a pre-announcement rule for Contact Center PhoneSet Manager
1. Right-click the Phone toolbar and click **Configure**.
2. Under **This extension is a**, select Desk phone.
3. To use audio devices for pre-announcements, select Use audio devices for pre-announcements and specify the input and output audio device.
4. Click the **Pre-announcement** tab.
5. Click **Add rule**.
The Add / Edit pre-announcement rule window opens.
6. Select the conditions that determine when the pre-announcement message will play.
7. Specify parameters for each condition.
8. Select or record a wave file to play when the above conditions are met.
9. Type a name for the pre-announcement rule.
10. If you want to hear ringing on your desk phone, select Enable ringing sound in desk phone.
11. Click **OK**.
To configure a pre-announcement rule for Contact Center Softphone

1. Right-click the Phone toolbar and click **Configure**.
2. Under **This extension is a**, select **Soft phone**.
3. Click the **Pre-announcement** tab.
4. Click **Add rule**.
   - The Add / Edit pre-announcement rule window opens.
5. Select the conditions that determine when the pre-announcement message will play.
6. Specify parameters for each condition.
7. Select or record a wave file to play when the above conditions are met.
8. Type a name for the pre-announcement rule.
9. Click **OK**.

To re-order pre-announcement rules

1. Select a rule.
2. Click the up or down arrow to change the priority of the rule.
3. Click **OK**.

**Making and terminating calls using Contact Center Phoneset Manager**

When you make calls, on the Functions toolbar you can readily select contacts you pre-configure in Microsoft Outlook, or speed dial numbers you configure in Contact Center PhoneSet Manager. See “Configuring speed dial numbers” on page 364 and “Displaying, hiding, and retiring toolbar buttons” on page 362.

You can dial any extension number or phone number. Contact Center PhoneSet Manager typically uses your primary extension to make calls. You can optionally select a different extension on the Phone toolbar to make calls.

**Making calls**

To dial by phone number or extension number using Contact Center PhoneSet Manager

1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the dial box and type a number or extension on the dial pad.
2. Click **Dial**.
3. If you want to view the call details window, click the down arrow adjacent to the box that displays your current phone state. See Figure 14-3.

To dial internally from a real-time monitor using Contact Center PhoneSet Manager

- From any real-time monitor, right-click an agent, employee, or extension cell and click **Call**.
Making calls to your contacts
To make a call to an extension in your contact list
1. Click the arrow adjacent to the dial box and click the Contacts tab.
2. Select a contact in the list.
3. Click Dial.

Making calls using speed dial
To dial using speed dial
• Click Speed dial and select a name in the list.

Terminating calls
To terminate a call
• Click Hang up.

Forwarding and answering calls using Contact Center Phoneset Manager
You can forward calls manually to pre-configured call forward destinations without having to speak to the caller first. In addition, you can configure and enable call forwarding so the telephone system forwards calls to other answer points when you are temporarily unavailable or away from the office. See “Configuring call forward destinations” on page 364.

If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the default call forward destination configured in the telephone system. If you click the down arrow adjacent to the Forward button, you can select an extension or phone number for call forwarding.

Forwarding calls
When a call is ringing on your extension, to forward the call using Contact Center PhoneSet Manager
1. Click Forward.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Forward button and select a contact.
3. Click Dial.
**Answering calls**

When an agent receives a call with Contact Center PhoneSet Manager detailed caller information is displayed on the desktop. (See Figure 14-4.) Agents can choose to answer the call or forward it to another agent. Additionally, the display can provide access to call notes, which are notes an agent adds to the call before transferring it. See “Adding call notes to a call” on page 369.

If configured and available the following information is provided in the soft phone display:

- **Caller name**—name of the caller
- **ANI**—telephone number of the caller
- **DNIS**—telephone number the caller dials
- **DNIS name**—the name associated to the DNIS number in YourSite database
- **Agent ID**—agent who transferred the call
- **Extension**—extension from which the call was transferred
- **Queue**—queue from which the call originated
- **Collect Caller Entered Digits**—digits the caller enters for identification purposes, such as a customer site key (Intelligent Queue required)
- **Customer Collected Information**—information collected from a third party OBDC database. Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and optionally, Remote Database Verification or CTI Developer Toolkit
- **Call notes**—notes added by an agent

You can answer calls by right-clicking the Contact Center PhoneSet Manager system tray icon and selecting Answer, or by clicking the Answer toolbar button.

**Figure 14-4  Contact Center PhoneSet Manager display**

To answer a call using Contact Center PhoneSet Manager

- Click **Answer**.

**Handling calls using Contact Center PhoneSet Manager**

You can handle calls by right-clicking the Contact Center PhoneSet Manager system tray icon and selecting telephony functions, or by selecting telephony buttons on the Functions toolbar. The telephony buttons available depend on the action you last performed. You can configure the toolbar buttons so they are always visible, or visible only when required. See “Displaying, hiding, and retiring toolbar buttons” on page 362.

When you pre-configure speed dial numbers in Contact Center PhoneSet Manager, these contacts are available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the Functions toolbar. See “Configuring speed dial numbers” on page 364.
Placing calls on hold
To place a call on hold
• Click Hold (red oval button).

Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.

To retrieve a call
• Click Retrieve.

Adding call notes to a call
When agents are speaking with customers, they can add notes to calls to share with other contact center employees involved in the call. This ensures agents and supervisors have context on calls and know what information has been provided to customers upon call transfer.

When a call is being transferred to an agent or supervisor, the soft phone display shows the most recent note associated with the call. When the agent answers the call, Contact Center Client appears on top of all other open applications and displays the Call Notes monitor. The monitor includes all of the call notes associated with the current call.

Agents can add notes each time a call is transferred, and agents on conference calls can add notes simultaneously. Each set of notes includes the agent’s name and a date/time stamp. When an agent completes a call and answers a new call or closes the Call Notes monitor, all call note information is saved and appended to the Lifecycle reports.

NOTE:
• On the Soft phone configuration window, you can clear the Enable call notes check box to hide the Call Notes monitor and prevent call notes from being displayed.
• You must have Contact Center PhoneSet Manager or Contact Center Softphone open in order to view or add call notes.
• For 5000/Axxess configurations that use CT Gateway, time stamps are based on the Enterprise Server’s PC clock. If the 5000/Axxess configuration includes remote servers, then time stamps are based on the remote server’s PC clock. For the 3300 ICP, time stamps are based on the telephone system clock.

To add a call note
1. As a call is ringing on your extension, on the soft phone display click Answer to answer the call. Contact Center Client appears on top of all open applications and displays the Call Notes monitor.
2. After Enter a new call note, type a note.
   Call notes can include a maximum of 100 characters.
3. Click Add.
   The call note is added to the Call notes text box and is included in the soft phone display upon call transfer.
Transferring calls

You can perform a blind transfer or a supervised transfer.

To perform a blind transfer using Contact Center PhoneSet Manager

1. While on a call, click **Trans/Conf**.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line if required). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
3. Click **Dial**.
4. Click **Hang up**.

To perform a supervised transfer

1. While on a call, click **Trans/Conf**.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
3. Click **Dial**.
   - The system places the caller on Hold.
4. Wait for the called party to answer. If you receive a busy signal or a voice mail greeting, click **Cancel** to return to the initial party. Otherwise, speak to the agent and identify the caller.
5. Click **Transfer** to transfer the call.

Conferencing calls

You can include up to eight people in a conference call. The following example illustrates a three-way conference call.

To set up a conference call

1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line).
2. Click **Dial**.
3. After you speak with the person who answers, click **Trans/Conf** to add a person to an in-progress call. The system places the person on Hold.
4. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
5. Click **Dial**.
6. Speak to the person who answers.
7. Click **Conference** to initiate a three-way conference call.

To split a conference call

- Click **Split**.
  - The last person you added to the conference call is placed on hold, and you can speak privately with the first person.
Consulting with people while on calls
To consult with a person while on a call using Contact Center PhoneSet Manager

1. Click Trans/Conf to conference in the person.
   The system places the initial party on Hold.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
3. Click Dial.
4. After you consult with the person, either click Conference to conference in the person, click Cancel to hang up on the person, click Transfer to transfer the call to the person, or click Swap to talk to the initial party.

Requesting help while on calls
To request help while on a call using Contact Center PhoneSet Manager

1. Click Request help.
2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click the down arrow adjacent to the Request help button and select a contact.
3. Click Dial.
   The system calls the employee. The employee can click Answer and listen in on the call without the caller knowing and can click Conference to join the conversation at any time.

Using Camp on
The Camp on feature is available when you make a call to an extension and receive a busy signal because the employee is already on a call. Camp on notifies the employee you are attempting to call with a series of audible beeps.

NOTE:
- Callers cannot camp on to your extension if you have call forwarding or voice mail configured on the extension.
- You cannot camp on to an extension that is in Make Busy or Do Not Disturb.

To camp on to an extension

1. In the dial box, type an extension number.
2. Click Dial.
3. If you receive a busy signal, click Camp on.
   The employee you called will hear a series of beeps and can click Retrieve to place the caller on hold and speak with you. After speaking with you, the employee can click Swap to return to the caller.

Leaving and retrieving messages
The Leave a message feature is available when you make a call to an extension that is idle or on a call. You must use the dial pad to type a number when you are retrieving a message.

To leave a message

1. In the dial box, type an extension number.
2. Click Dial.
3. If the employee does not answer, click Leave a message.
   The telephone system leaves a message waiting notification on the employee’s extension and the Contact Center Client icon flashes red and white in the employee’s system tray.
To retrieve a message

1. Click **Dial pad** and type the number configured in the telephone system for message retrieval.
2. Press **Enter**.
   The automated attendant will ask you for your password.
3. Type your password on the dial pad.
4. Follow the instructions provided by the automated attendant to retrieve the message.

**NOTE:** If agents leave Call me back messages you must use your physical phone set to retrieve the messages.

**Using Call me back**

The Call me back feature is available when you make a call to an extension that is idle or on a call. When you select the Call me back button, the telephone system monitors the called employee’s other extension. When the employee’s other extension returns to idle, your phone rings. If you pick up the call, the employee’s phone will ring. If you do not pick up the call, the callback will expire.

To leave a callback message

1. In the dial box, type an extension number.
2. Click **Dial**.
3. If the employee does not answer, click **Call me back**.
   The telephone system monitors the called employee’s extension. Your phone will rings when the called employee’s other extension returns to the idle state.
4. When your phone rings, click **Answer** to pick up the call and speak with the employee.

**Tagging calls with Account Codes**

You can tag calls with Account Codes you pre-configure in Contact Center Client.

To tag an in-progress call with an Account Code or a Classification Account Code

- Click the down arrow adjacent to the Account Code button and select a traditional Account Code or a Classification Account Code.

After hanging up, while in work timer mode, you can tag calls with Classification Account Codes.

To tag a call, after hanging up, with a Classification Account Code

1. Click the down arrow adjacent to the **Account Code** button.
2. Select **After Call Classification** and select the appropriate Classification Account Code from the drop-down list.

**Making and terminating calls using Contact Center Softphone**

When you make calls, on the Functions toolbar you can readily select from contacts you pre-configure in Microsoft Outlook, or speed dial numbers you configure in Contact Center Softphone. See “Configuring speed dial numbers” on page 364 and “Displaying, hiding, and retiring toolbar buttons” on page 362.

You can dial any extension number or phone number. Contact Center Softphone typically uses your primary extension to make calls. You can optionally select a different extension on the Phone toolbar to make calls.

For information on how to use the superkey and phone book functionality of Contact Center Softphone, refer to the **5220 IP Phone User Guide** at http://edocs.mitel.com/UG/Index.html.
Making calls

To dial by phone number or extension number using Contact Center Softphone

1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the dial box and type a number or extension on the dial pad.
2. If you want to view the call details window, click the down arrow adjacent to the box that displays your current phone state. See Figure 14-5.

To dial internally from a real-time monitor using Contact Center Softphone

- From any real-time monitor, right-click an agent, employee, or extension cell and click Call.

Making calls to your contacts

To make a call to an extension in your contact list

1. Click the arrow adjacent to the dial box and click the Contacts tab.
2. Double-click a contact in the list.

Making calls to contacts who have called you recently

To make a call to a contact who has called you recently

1. Click the arrow adjacent to the dial box and click the Recent tab.
2. Double-click a contact in the list.

Making calls using speed dial

To dial using speed dial

- Click Speed dial and select a name in the list.

Redialing numbers

To dial the contact who last called you

- Click Speed dial and select a name in the list.
Terminating calls

To terminate a call

- Click **Hang up**.
  Alternatively, on the Phone toolbar, click **Cancel**.

Forwarding and answering calls using Contact Center Softphone

You can forward calls manually to pre-configured call forward destinations without having to speak to the caller first. In addition, you can configure and enable call forwarding so the telephone system forwards calls to other answer points when you are temporarily unavailable or away from the office. See “Configuring call forward destinations” on page 364.

If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the default call forward destination configured in the telephone system. If you click the down arrow adjacent to the Forward button, you can select an extension or phone number for call forwarding.

Forwarding calls

When a call is ringing on your extension, to forward the call using Contact Center Softphone

1. Click **Forward**.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Forward button and select a contact.

Answering calls

When an agent receives a call with Contact Center Softphone detailed caller information is displayed on the desktop. (See Figure 14-6.) Agents can choose to answer the call or forward it to another agent. Additionally, the display can provide access to call notes, which are notes an agent adds to the call before transferring it. See “Adding call notes to a call” on page 369.

If configured and available the following information is provided in the soft phone display

- **Caller name**—name of the caller
- **ANI**—telephone number of the caller
- **DNIS**—telephone number the caller dials
- **DNIS name**—the name associated to the DNIS number in YourSite database
- **Agent ID**—agent who transferred the call
- **Extension**—extension from which the call was transferred
- **Queue**—queue from which the call originated
- **Collect Caller Entered Digits**—digits the caller enters for identification purposes, such as a customer site key (Intelligent Queue required)
- **Customer Collected Information**—information collected from a third party OBDC database. Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and optionally, Remote Database Verification or CTI Developer Toolkit
- **Call notes**—notes added by an agent

You can answer calls by right-clicking the Contact Center Softphone system tray icon and selecting Answer, or by clicking the Answer toolbar button.
To answer a call using Contact Center Softphone
  •  Click Answer.

Handling calls using Contact Center Softphone
You can handle calls by right-clicking the Contact Center Softphone system tray icon and selecting telephony functions, or by selecting telephony buttons on the Functions toolbar. The telephony buttons available depend on the action you last performed. You can configure the toolbar buttons so they are always visible, or visible only when required. See “Displaying, hiding, and retiring toolbar buttons” on page 362.

When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the Functions toolbar. See “Configuring speed dial numbers” on page 364.

Placing calls on hold
To place a call on hold
  •  Click Hold (red oval button).

Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.

To retrieve a call
  •  Click Retrieve.

Using Mute
To use Mute
  1.  Click Mute.
     The system disables your microphone so you can consult privately with another employee.
  2.  To restore your microphone, click Resume.
Transferring calls
You can perform a blind transfer or a supervised transfer.

To perform a blind transfer using Contact Center Softphone
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
3. Click Hang up.

To perform a supervised transfer
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact. The system places the caller on Hold.
3. Wait for the called party to answer. If you receive a busy signal or a voice mail greeting, click Cancel to return to the initial party. Otherwise, speak to the agent and identify the caller.
4. Click Transfer to transfer the call.

Conferencing calls
You can include up to eight people in a conference call. The following example illustrates a three-way conference call.

To set up a conference call
1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line).
2. After you speak with the person who answers, click Trans/Conf to add a person to an in-progress call. The system places the person on Hold.
3. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
4. Speak to the person who answers.
5. Click Conference to initiate a three-way conference call.

To split a conference call
- Click Split.
  The last person you added to the conference call is placed on hold, and you can speak privately with the first person.

Consulting with people while on calls
To consult with a person while on a call using Contact Center Softphone
1. Click Trans/Conf to conference in the person.
   The system places the initial party on Hold.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
3. After you consult with the person, either click Conference to conference in the person, click Cancel to hang up on the person, click Transfer to transfer the call to the person, or click Swap to talk to the initial party.
Requesting help while on calls
To request help while on a call using Contact Center Softphone

1. Click Request help.
2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click the down arrow adjacent to the Request Help button and select an employee.
   The system calls the employee. The employee can click Answer and listen in on the call without the caller knowing and can click Conference to join the conversation at any time.

Using Camp on
The Camp on feature is available when you make a call to an extension and receive a busy signal because the employee is already on a call. Camp on notifies the employee you are attempting to call with a series of audible beeps.

NOTE:
- Callers cannot camp on to your extension if you have call forwarding or voice mail configured on the extension.
- You cannot camp on to an extension that is in Make Busy or Do Not Disturb.

To camp on to an extension

1. In the dial box, type an extension number.
2. If you receive a busy signal, click Camp on.
   The employee you called will hear a series of beeps and can click Retrieve to place the caller on hold and speak with you. After speaking with you, the employee can click Swap to return to the caller.

Leaving and retrieving messages
The Leave a message feature is available when you make a call to an extension that is idle or on a call.

To leave a message

1. In the dial box, type an extension number.
2. If the employee does not answer, click Leave a message.
   The telephone system leaves a message waiting notification on the employee’s extension and the Contact Center Client icon flashes red and white in the employee’s system tray.

To retrieve a message

1. In the dial box, type your voice mail access number.
   The automated attendant will ask you for your password.
2. In the daily box, type your password.
3. Follow the instructions provided by the automated attendant to retrieve the message.

NOTE: If agents leave Call me back messages for you to check your messages, your Contact Center Client tray icon will not clear the messages once you have checked your messages.

To clear a message

1. On the Phone toolbar, click Message.
2. After CALL ME BACK?, click Yes.
3. Click Erase.
   The telephone image displays NO MORE MESSAGES.
Using Call me back

The Call me back feature is available when you make a call to an extension that is idle or on a call. When you select the Call me back button, the telephone system monitors the called employee’s other extension. When the employee’s other extension returns to idle, your phone rings. If you pick up the call, the employee’s phone will ring. If you do not pick up the call, the callback will expire.

To leave a callback message

1. In the dial box, type an extension number.
2. If the employee does not answer, click Call me back. The telephone system monitors the called employee’s extension. Your phone will rings when the called employee’s other extension returns to the idle state.
3. When your phone rings, click Answer to pick up the call and speak with the employee.

Tagging calls with Account Codes

You can tag calls with Account Codes you pre-configure in Contact Center Client.

To tag an in-progress call with an Account Code or a Classification Account Code

• Click the down arrow adjacent to the Account Code button and select a traditional Account Code or a Classification Account Code.

After hanging up, while in work timer mode, you can tag calls with Classification Account Codes.

To tag a call, after hanging up, with a Classification Account Code

1. Click the down arrow adjacent to the Account Code button.
2. Select After Call Classification and select the appropriate Classification Account Code from the drop-down list.

Controlling your availability

You can log yourself on or off, cancel Work Timer, and place yourself in or remove yourself from Make Busy with reason or Do Not Disturb with reason using the soft phone.

To log on to the ACD

• Click Actions=>Log on and select an agent ID.

To log off of the ACD

• Click Actions=>Log off.

To set Make Busy with reason

• Click Actions=>Set Make Busy and select a Make Busy Reason Code.

To remove Make Busy with reason

• Click Actions=>Remove Make Busy.

To set Do Not Disturb with reason

• Click Actions=>Set Do Not Disturb and select a Do Not Disturb Reason Code.

To remove Do Not Disturb

• Click Actions=>Remove Do Not Disturb.

To cancel Work Timer

• Click Actions=>Cancel Work Timer.
Making and handling calls using Contact Center Client

You can open an agent, employee or extension monitor, or the Queue Now monitor and right-click an agent and select telephony functions. For example, when you are on a call you can consult with an idle employee by right-clicking the employee's cell and clicking Transfer/Conference, or by sending the employee an instant message. (See Figure 14-7.)

Figure 14-7  Consulting with a person while on call

Making calls

To call an agent using Contact Center Client

• Right-click the cell of an idle agent and click Call.

Forwarding calls

If a call is ringing on your extension, to forward the call using Contact Center Client

• Right-click the cell of an idle agent and click Forward.

Answering calls

If a call is ringing on another agent’s extension, to pick up the call using Contact Center Client

• Right-click the cell of the agent and click Pick up.

Adding call notes

When agents are speaking with customers, they can add notes to calls to share with other contact center employees involved in the call. This ensures agents and supervisors have context on calls and know what information has been provided to customers upon call transfer. See “Adding call notes to a call” on page 369.
To add a call note

1. As a call is ringing on your extension, on the soft phone display click **Answer** to answer the call. Contact Center Client appears on top of all open applications and displays the Call Notes monitor.
2. After **Enter a new call note**, type a note.
   Call notes can include a maximum of 100 characters.
3. Click **Add**.
   The call note is added to the Call notes text box and is included in the soft phone display upon call transfer.

**Recording calls**

There are occasions when an agent wants to temporarily stop recording a call for confidentiality reasons, or, if the call is not currently being recorded, the agent may want to start recording if the conversation becomes hostile or sensitive in nature and a call record may be required. On the Agent State by Time, Agent State by Position, and Agent State by Queue by Time monitors, the Call recording option enables you to start, stop, and restart call recording at any time during a call, using OAISYS call recording functionality. Requirements for this on-demand call recording feature are Contact Center Management, Contact Center PhoneSet Manager or Contact Center Softphone, Interactive Contact Center, and the OAISYS call recording connector.

To record a call

1. Right-click the associated cell of an agent and select **Call Recording=>Start Recording**.
2. To stop recording, right-click the cell and select **Call Recording=>Stop Recording**.

**Silent monitoring calls**

Silent monitoring is the process of listening to the voice conversations of internal or external calls between agents and callers. Silent monitoring enables you to track call handling techniques and determine where improvements can be made in individual performance. Silent monitoring is supported for the 3300 ICP telephone system and requires Contact Center Management, Contact Center PhoneSet Manager or Contact Center Softphone, and Interactive Contact Center.

**NOTE:**

- The monitoring extension and the extension being monitored must coexist on the same telephone system.
- The monitoring extension must be permitted by security role to interactively control other agents.
- The monitoring extension’s soft phone tool bar must be open.

To silent monitor a call using Contact Center Client

- Right-click the associated cell of an agent and select **Silent Monitor**.
  
  **NOTE:** If the telephone system settings are incorrect or the monitoring extension and the extension being monitored are on separate telephone systems, you will be unable to Silent monitor and will instead see "Not Allowed" when you right-click the cell. See “Programming Silent monitoring for the 3300 ICP” in the *Mitel Contact Center Management Installation Guide* for more information. If the extension you want to monitor is not currently on a call, you will see "Waiting" when you right-click the cell.

**Transferring calls**

To perform a blind transfer using Contact Center Client

- While on a call, right-click the cell of an idle agent and click **Transfer call**.
Consulting with employees while on calls
To consult with an employee while on a call using Contact Center Client
1. Right-click the cell of an idle agent and click Consult.
   The system placed the initial party on Hold.
2. After you consult with the employee, in the soft phone click Transfer to transfer the call to the employee, click Swap to talk to the other party, or click cancel to end the consultation call.

Requesting help while on calls
To request help while on a call using Contact Center Client
- Right-click the cell of an idle agent and click Request help.
  The system calls the employee. The employee can click Answer in the soft phone and listen in on the call without the caller knowing. The employee can click Conference in the soft phone to join the conversation at any time.
Chapter 15
Contact Center Screen Pop

Using Contact Center Screen Pop
Contact Center Screen Pop

Contact Center Screen Pop is an optional application that requires Contact Center Management, and Contact Center Softphone or Contact Center PhoneSet Manager. Optionally, if you want to screen pop based on caller entered digits, you require Intelligent Queue with the Collect Caller Entered Digits options.

Contact Center Screen Pop launches applications or Web pages. In addition, it enables agents to automatically receive caller and account information via pop-ups on their computer monitors every time they receive calls. Contact Center Screen Pop provides agents with the caller name, caller phone number (ANI), called number (DNIS), and the queue used in the call. Optionally, if you have the Intelligent Queue Collect Caller Entered Digits option, Contact Center Screen Pop displays the digits the customer entered.

Using Contact Center Screen Pop

When an agent receives a call, Contact Center Screen Pop can launch an application or Web page. For example, when integrated with a Customer Relationship Management (CRM) database, Contact Center Screen Pop can launch a customer account page from the CRM database based on call information.

For contact centers that have Contact Center Screen Pop, the pop-up provides

- **Caller name**—name of the caller
- **ANI**—telephone number of the caller
- **DNIS**—telephone number the caller dials
- **DNIS name**—the name associated to the DNIS number in YourSite database
- **Agent ID**—agent who transferred the call
- **Extension**—extension from which the call was transferred
- **Queue**—queue from which the call originated
- **Collect Caller Entered Digits**—digits the caller enters for identification purposes, such as a customer site key (Intelligent Queue required)
- **Customer Collected Information**—information collected from a third party OBDC database. Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and optionally, Remote Database Verification or CTI Developer Toolkit
- **Call notes**—notes added by an agent

Configuring options in Contact Center Management

You configure Contact Center Screen Pop options in Contact Center Management. You can specify which information fields the pop-up displays and whether an application or Web page is launched when an agent receives a call. See “Configuring Contact Center Screen Pop options” on page 386.

Enabling Contact Center Screen Pop

To enable Contact Center Screen Pop

1. Start Contact Center Client.
   See “Starting Contact Center Client” on page 240
2. Right-click the Phone toolbar and click Configure.
3. Click the *Screen pop* tab.
4. Select the **Display Contact Center Screen Pop** check box.
5. Click **OK**.
Configuring Contact Center Screen Pop options

If you are licensed for ANI, DNIS, and/or Collect Caller Entered Digits and want to display these in the pop-up.

To configure Contact Center Screen Pop options

1. Click YourSite=>Enterprise.
   The Enterprise tab opens.
2. Click the Screen pop tab.
3. Ensure the Display Intelligent Queue licensed options (ANI, DNIS, and Collect Caller Entered Digits) on the soft phone pop-up check box is selected.
4. If you want to launch an application or Web page when agents answer a call, select the Launch an application or Web page when agents answer ACD calls check box.
   - If you want to launch Outlook contact information for callers and create a journal entry for each caller, select Display caller-specific Microsoft Outlook Contact Information and create Journal entries. This is the default option. Microsoft Outlook will display the contact information of that caller, using the name and/or number of the caller to find their file in the Personal Address Book. A journal entry will also be created for the call. If you select this option, ensure that you complete “Configuring Contact Center Screen Pop display variables” on page 387 and “Configuring Contact Center Screen Pop to display Outlook contacts” on page 389. A default path or URL is automatically entered in the Contact Center Screen Pop tab. Contact Center Screen Pop will launch this application or Web page box when it is used.
   - If you want to display call statistics for incoming ACD calls, select Display the caller-specific Inbound trace report Web page. The Inbound Trace report tells you the number of times the caller has called in the last seven days and contains the following fields: Call Start Time, Call Duration, DNIS name, Agent name, Extension, and Account Code. (See Figure 15-1).
   - A default path or URL is automatically entered in the Contact Center Screen Pop tab. Contact Center Screen Pop will launch this application or Web page box when it is used.
   - If you have created a Web page or an application to launch when agents answer calls, select Display a specific application or Web page and type the path for the executable file or the URL of the Web page. Click How do I enter this value? for instructions. See “Configuring Contact Center Screen Pop display variables” on page 387.
5. If you want to enable screen pop on non-ACD calls select the Screen pop on non-ACD calls check box.
6. Click Save.
Patrick M has called our company 43 times in the last 7 days
Phone Number: 6135990045

Configuring Contact Center Screen Pop display variables
The variables described in Table 15-1 are used by Contact Center Screen Pop to determine the application area or Web page that launches when an agent answers an ACD call. Ensure the required Intelligent Queue options are enabled to use these variables.

NOTE: The variable names are case-sensitive.

Table 15-1 Contact Center Screen Pop display variables

<table>
<thead>
<tr>
<th>Variable</th>
<th>Intelligent Queue feature required</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%PFCALLERNAME%</td>
<td>ANI/DNIS routing option, enabled</td>
<td>Caller name as provided by the telephone carrier. For example, &quot;John Smith&quot;</td>
</tr>
<tr>
<td>%PFANI%</td>
<td>ANI/DNIS routing option, enabled</td>
<td>Caller number (ANI), the telephone number of the calling party. For example, &quot;6135990045&quot;</td>
</tr>
<tr>
<td>%PFDNIS%</td>
<td>ANI/DNIS routing option, enabled</td>
<td>Dialed Number Identification Service (DNIS), numbers passed from the public telephone network to identify what phone number the caller dialed. This is typically used to identify different 1-800 or 1-900 numbers. For example, &quot;9875&quot;</td>
</tr>
<tr>
<td>%PERVERIFIEDCOLLEDCOLLECTEDDIALS%</td>
<td>Collect Caller Entered Digits option, enabled and configured</td>
<td>The digits entered by the user during the call. For example, account number &quot;78831&quot;</td>
</tr>
<tr>
<td>%Queue%</td>
<td>ANI/DNIS routing option, enabled</td>
<td>Name of the queue from which the call is answered. For example, &quot;Sales&quot;</td>
</tr>
<tr>
<td>%ReceivingAgent%</td>
<td>n/a</td>
<td>Contains the Agent ID for the agent receiving the current call</td>
</tr>
<tr>
<td>%ReceivingExtension%</td>
<td>n/a</td>
<td>Contains the Extension ID for the extension receiving the current call</td>
</tr>
<tr>
<td>%SendingAgent%</td>
<td>n/a</td>
<td>Contains the Agent ID for the agent sending or transferring the call to the current recipient</td>
</tr>
<tr>
<td>%SendingExtension%</td>
<td>n/a</td>
<td>Contains the Extension ID for the extension sending or transferring the call to the current recipient</td>
</tr>
</tbody>
</table>
To launch an application

- Type the URL of the executable file followed by the required variables.
  For example, C:\MyProgram\CustomerManagement.exe "%PFCALLERNAME%" "%PFANI%" "%PFDNIS%" "%PFVERIFIEDCOLLECTEDDIGITS%" "%Queue%"

**NOTE:** Variables must be in quotes and be separated by a space.

If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number (78831), and is then routed to the Sales queue, the executable file will use the actual values of the call, for example, C:\MyProgram\CustomerManagement.exe "John Smith" "6135990045" "9875" "78831" "Sales".

To launch a Web page

- Type the URL of the Web page followed by the required variables, as per standard HTTP protocol.
  For example, http://myintranetsite.business.com?CALLERNAME=%PFCALLERNAME%&ANI=%PFANI%&DNIS=%PFDNIS%&COLLECTEDDIGITS=%PFVERIFIEDCOLLECTEDDIGITS%&QUEUE=%Queue%

If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number (78831), and is then routed to the Sales queue, the Web page will use the actual values of the call, for example, http://myintranetsite.business.com?CALLERNAME=John%20Smith&ANI=6135990045&DNIS=9875&COLLECTEDDIGITS=78831&QUEUE=Sales.

Configuring Contact Center Screen Pop Outlook options for journal entries

**NOTE:** Contact Center Screen Pop can search the contacts available in Outlook Personal Contacts only.

You can configure Contact Center Screen Pop to automatically record information in journal entries. You must complete the following instructions if you selected Display caller-specific Microsoft Outlook Contact Information and create Journal entries in “Configuring Contact Center Screen Pop options” on page 386. This step must be performed on every agent computer that uses Contact Center Screen Pop.

For information on viewing and searching for journal entries, see Microsoft Office Outlook Help.

To configure Contact Center Screen Pop Outlook options for journal entries

1. Start Contact Center Client.
2. Right-click the Phone toolbar and click **Configure**.
3. Click the **Screen pop** tab.
4. Click **Configure Outlook screen pop options**.
5. Select **Create a journal entry for each incoming call and include the following properties**.
6. Select the properties that you want to include in your journal entries.
   - **Name**—caller name as provided by the telephone carrier (for example, John Smith)
   - **Phone number**—telephone number of the caller (for example, 6135990045)
   - **DNIS**—number passed from the public telephone network that identify the phone number the caller dialed. DNIS is typically used to identify different 1-800 or 1-900 numbers (for example, 9875).
   - **Queue**—queue from which the call originated. Only the first word of the queue name is recorded.
   - **Collect Caller Entered Digits**—the Collect Caller Entered Digits option, enabled and configured. These are the digits entered by the user during the call (for example, account number 78831)
7. Click **OK**.
Configuring Contact Center Screen Pop to display Outlook contacts

Contact Center Screen Pop searches the Outlook contact list for a caller’s information and displays it in an Outlook window. You must complete this section if you selected Display caller-specific Microsoft Outlook Contact Information and create Journal entries in “Configuring Contact Center Screen Pop options” on page 386.

To configure Contact Center Screen Pop to display Outlook contacts

1. Start Contact Center Client.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Click Configure Outlook screen pop options.
5. Select the Search for an Outlook contact check box.
   • If you want to search for a contact using their name, select By name.
   • If you want to search for a contact using their telephone number, select By number.
   You can select both By name and By number to enable Contact Center Screen Pop to search for contacts using either method.
6. Click OK.

Configuring Contact Center Screen Pop to display Goldmine contacts

The FrontRange Goldmine connector for Contact Center Screen Pop searches Goldmine contact lists for caller phone numbers and displays the caller’s contact page. The following procedure details how to configure Contact Center Screen Pop to display FrontRange Goldmine contact information.

To configure Contact Center Screen Pop to display FrontRange Goldmine contacts

1. Click YourSite=>Enterprise.
2. Click the Screen pop tab.
3. Select the Launch an application or Web page when agents answer ACD calls check box.
4. Select Display a specific application or Web page.
5. Under Contact Center Screen Pop will launch this application or Web page, type the path of the executable file followed by the required variables: `<drive>:\Program Files\prairieFyre Software Inc\CCM\Applications\ContactCenterClient\GoldmineScreenPopConnector.exe"%PFANI%"`
   If you want to suppress Goldmine from maximizing and being popped to the front of all active windows, follow the above string with -s.
   See “Configuring Contact Center Screen Pop options” on page 386 and “Configuring Contact Center Screen Pop display variables” on page 387.
6. Click Save.

If you do not want Contact Center Screen Pop to display Goldmine contacts, you can disable this option for individual desktops using Contact Center Client.

To disable the FrontRange Goldmine screen pop on individual desktops

1. Start Contact Center Client.
2. Click View=>Soft phone.
3. Right-click the Phone toolbar and click Configure.
4. Click the Screen pop tab.
5. Ensure the Display Contact Center Screen Pop option is deselected.
6. Click OK.
Testing Contact Center Screen Pop search functions

This test will confirm that Contact Center Screen Pop will function with the software you selected. For example, if you selected the Display caller-specific Microsoft Outlook Contact Information and create Journal entries option, the test will attempt to pop up a sample caller-specific Outlook Contact window, and create a sample Journal entry. See “Configuring Contact Center Screen Pop options” on page 386.

To test the search function in Contact Center Screen Pop

1. Start Contact Center Client.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Click Test.
5. Type the variables using the described format
   - PFCALLERNAME—first name followed by last name, separated by a space (for example, John Smith)
   - PFANI—phone number (including area code if relevant) with no spaces, dashes, or brackets (for example, 6135558769)
   - PFDNIS—phone number (including area code if relevant) with no spaces, dashes, or brackets (for example, 8005556598)
   - PFVERIFIEDCOLLECTEDDIGITS—all digits the caller has entered since entering the telephone system, with no spaces, dashes or brackets (for example, 1113)
   - Queue—queue that the caller first entered (for example, P500)
6. Click OK.
   A screen pop that contains the test parameters you specified will display. The outcome of the Contact Center Screen Pop test will change depending on the type of screen pop you have configured and the test parameters you entered.

Disabling Contact Center Screen Pop

If you prefer some client computers do not use Contact Center Screen Pop, you can disable it on one or more computers. This procedure affects one agent profile only.

To disable Contact Center Screen Pop on a client computer

1. Start Contact Center Client.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Clear the Display Contact Center Screen Pop check box.
5. Click OK.
Chapter 16
Flexible Reporting

Using Flexible Reporting
Flexible Reporting

Flexible Reporting is an optional application that works with Contact Center Management Enterprise Edition. In addition to the over 425 reports provided by Contact Center Solutions and Call Accounting, Flexible Reporting enables you to design your own reports.

To install Flexible Reporting on a client computer, select the Flexible Reporting option in the Client Role Selector (Start=>Programs=>Mitel =>Client Role Selector).

To access Flexible Reporting, employees must be associated with a security role that allows them to manage reporting (the May manage reporting check box must be selected).

With Flexible Reporting you can:
- Use a wizard interface to create customized reports with existing statistics (column headings)
- Create custom calculations using expressions
- Select column headings to build custom reports
- Select only the columns you want to view
- Select like data for two or more device types and combine them in one report
- Arrange the columns in the order in which you want to view them
- Customize the names of statistics (column headings) so they are meaningful to your department, business, and industry
- Save the reports in Excel and .pdf formats

Using Flexible Reporting

In Flexible Reporting you can
- Create new reports
- Modify standard Contact Center Management report templates
- Modify existing Flexible Reporting report templates
- Design reports
- Manage your Flexible Reporting reports
- Run reports

Starting Flexible Reporting

To start Flexible Reporting

1. Click Start=>Programs=>Mitel=>Flexible Reporting.
2. Log on with your user name and password.
   The Welcome to Flexible Reporting dialog box opens.
3. You can select from: Run a report, Create a new report, Redesign a standard report, Modify an existing report, or Do not show this dialog box again. If you want to initiate a procedure, click OK and see the associated section in this chapter. Otherwise, close the dialog box.
Viewing the Flexible Reporting user interface

The Flexible Reporting user interface comprises the following (See Figure 16-1):

- Report Designer wizard
- Layout designer window
- Flexible Reporting button
- Ribbon
- Toolbox window

Figure 16-1 Flexible Reporting user interface
You can customize the position of the windows in the following ways:
• Dock to the left, right, top, or bottom of the user interface
• Float
• Hide
• Auto-hide

Report Designer wizard
Whether you are building a new report or modifying an existing Contact Center Management report, the Report Designer wizard leads you through the following steps to select data for the report:
• Create a new report based on an existing one, or design a new report
• Select a report type (Performance reports, Answering points, Make Busy, and Account Code reports, or Summarized/Detailed Agent Event reports)
• Select the device types
• Select the statistics (column headings), and the order in which you want them displayed
• Specify the time frame options

Layout designer window
The layout designer window comprises two tabs: design and preview. The window displays the report header and data grid. You can perform the following functions in the layout designer window.

On the design tab you can
• Add images to report headers
• Edit the report header titles
• Adjust the placement of the report header titles and values
• Remove report header titles and values
• Add existing or custom columns
• Move columns
• Delete columns
• Edit column heading names
• Specify column width and row height
• Specify row colors
• Freeze and unfreeze columns
• Save report templates

On the preview tab you can
• Run and preview reports
• Save reports
• Export reports
• Print reports

Flexible Reporting button
The Flexible Reporting button is the circular button located in the upper left corner of the window. The following options are available from the Flexible Reporting button: New, Open, Save, Save as, Close, About, Log out, Exit, and Log out and exit.
Ribbon

The ribbon provides the same functionality as traditional toolbars. Use the tools on the ribbon to help you design your reports. The ribbon comprises the Home, Insert, and View tabs.

On the Home tab of the ribbon, you will find the tools to help you
• Change the font type, size, and style
• Select text justification
• Specify column width, auto-fit column width, and row height
• Change row colors

On the Insert tab of the ribbon, you will find the tools to help you
• Insert and remove images from the report header
• Select the report header titles to open in the report header
• Add existing or custom columns
• Remove columns
• Freeze and unfreeze columns
• View or modify expressions

On the View tab of the ribbon, you will find the tools to help you
• Show and hide the Toolbox window
• Manage reports

Toolbox window

The Toolbox window contains the following:
• **Report header**
  Report header is a list of report header titles that are currently not included in the report header. If the Report Header list is empty, all of the report header titles will be applied to the report. When report header titles are removed from a report they are shown in the Report headers list.

• **Column heading**
  Column heading displays a list of all of the column headings (for only those devices selected for the report) that are not currently included in the report grid. When you add a column heading to the report, it is removed from the list. Similarly, if you remove a column heading from the report, it displays in the Column headings list.

Creating new reports

Using the Report Designer wizard you can build new reports with existing column headings. Use the Report Designer wizard to select the data for the report.

The Report Designer wizard guides you through the following steps:
• Select how you want to display the report data
  • Performance reports display data for agents, queues, trunks, DNIS, or extensions by interval. Each row in the report represents a specific period. The supported periods are: 15 minutes, 30 minutes, 60 minutes, day of week, day of month, and month.
  • Answering points, Make Busy, and Account Code reports display data for a single device per row (including employee, agent, queue, ANI, DNIS, Account Code, Make Busy code, Trunk busy minutes, agent ID, and devices associated with device groups). Each row in the report represents a device. Examples of by device reports are Employee Group by Employee, Queue Group by Queue, Queue by Agent, or Queue ANI by Area Code.
Summarized/Detailed Agent Event reports display ACD-based agent activity data. The data can be grouped by login/logout pair or can be viewed as a trace of all login/logout pairs. For example, Detailed Agent Event Data reports show the agent state activity for each login/logout pair performed by the agent. Summarized Agent Event Data reports group the data and show one line representing the agent's total activity.

- Select the device(s) on which you want to report
- Select the statistics (column headers) that will be shown in the report
- Select the time frames over which you want to run the report

To create a new report
1. Click the Flexible Reporting button and select **New** to launch the Report Designer wizard.
2. Click **Next**.
3. Click **Create a new report** and follow the steps in the wizard.
   - At the end of the Report Designer wizard, the new report opens automatically on the Design tab.
4. Design the report.
   - See “Designing reports” on page 399.
5. Click the Flexible Reporting button and select **Save** to save the report.

Modifying standard Contact Center Management report templates

Using the Report Designer wizard you can modify standard Contact Center Management voice report templates. In the wizard, you can remove data (column headings) and add new data (additional devices and column headings).

The Report Designer wizard guides you through the following steps:
- Select the report you want to modify from a list of standard Contact Center Management reports
- Select the time frames over which you want to be able to run the report
  - Choosing options on this page enables you to select time frames when submitting or previewing reports. The start and end times enable you to run the report for a specific time frame for each day in the report. For example, you can run the report for your hours of operation only, 8 A.M. to 6 P.M. The days of the week time frame enables you to run the report for specific days. For example, every Friday over the last two months.

Table 16-1 lists the standard Contact Center Management report templates.

### Table 16-1: Standard Contact Center Management report templates

<table>
<thead>
<tr>
<th>Agent report templates</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Agent by Make Busy Code</td>
</tr>
<tr>
<td>• Agent Group by Make Busy Code</td>
</tr>
<tr>
<td>• Agent Group Performance by Period</td>
</tr>
<tr>
<td>• Agent Performance by Account Code</td>
</tr>
<tr>
<td>• Agent Performance by Period</td>
</tr>
<tr>
<td>• Agent Shift by Period</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DNIS report templates</th>
</tr>
</thead>
<tbody>
<tr>
<td>• DNIS Group Performance by Period</td>
</tr>
<tr>
<td>• DNIS Performance by Period</td>
</tr>
</tbody>
</table>
To modify a standard Contact Center Management report template

1. Click the Flexible Reporting button and select New to launch the Report Designer wizard.
2. Click Next.
3. Select the Redesign a standard report option and follow the steps in the wizard.
   At the end of the Report Designer wizard, the new report template opens automatically on the Design tab.
   
   **NOTE:** On the Select an existing report template page of the wizard, under Filter by device type, select All devices if you want to see all available reports for all devices.
4. Design the report.
   See “Designing reports” on page 399.
5. Click the Flexible Reporting button and select Save to save the report.

Modifying existing Flexible Reporting report templates

To modify an existing Flexible Reporting report template

1. Click the Flexible Reporting button and select Open.
   The Reports List window opens, giving you access to all personal and shared Flexible Reporting reports.
2. Select the report you want to modify.
3. Click Open.
4. Modify the report.
   See “Designing reports” on page 399.
5. Click the Flexible Reporting button and select Save to save the changes to the report template, or select Save As to save the report as a new template.
6. If you want to run the report, click the Preview tab.

### Table 16-1: Standard Contact Center Management report templates

<table>
<thead>
<tr>
<th><strong>Employee report templates</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Employee Group Performance by Employee</td>
</tr>
<tr>
<td>• Employee Performance by Agent ID</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Extension report templates</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Extension Group Performance by Period</td>
</tr>
<tr>
<td>• Extension Performance by Period</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Queue report templates</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Queue ANI by Area Code</td>
</tr>
<tr>
<td>• Queue Group Performance by Queue</td>
</tr>
<tr>
<td>• Queue Performance by Account Code</td>
</tr>
<tr>
<td>• Queue Performance by Agent</td>
</tr>
<tr>
<td>• Queue Performance by Period</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Trunk report templates</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Trunk Group Performance by Period</td>
</tr>
<tr>
<td>• Trunk Performance by Period</td>
</tr>
</tbody>
</table>
Designing reports

Using the options available on the ribbon, design the report by modifying the report header, columns, and rows.

**NOTE:** You can open and edit report templates you previously created in Flexible Reporting.

Adding images to report headers

To add an image to a report header

1. On the **Insert** tab of the ribbon, click the **Insert** button.
2. Select an image file and click **Open**. The image displays on the report header.
3. Drag the image to where you want it to be shown on the report header.

Deleting images on report headers

To delete an image

1. Select an image on the report header.
2. On the **Insert** tab of the ribbon, click the **Remove** button.

Editing report header titles

Report headers comprise titles and values. Edit the report header titles to customize the look of your reports.

You can edit the font type, size, and style of report header titles.

You can edit the titles of the following report headers:

- Report
- Site
- Device
- Date range
- Date created
- Created by

**NOTE:** You cannot edit the report header values as these are driven by the options selected when the report is submitted.

To edit a report header title

1. Click a report header title.
2. Edit the text in the box.

Moving report header titles and values

You can drag and drop report header titles and values independently.

To move a report header title or value

- Drag and drop the report header title or value to where you want it to be shown on the report header.
Removing report header titles and values

All report header titles and values are shown on a report when it is first created. If you remove a report header title, the corresponding value will also be removed from the header. For example, if you remove the Date range title, the date range will not be shown on the report.

To remove a report header title and value

- On the **Insert** tab of the ribbon, click the **Header** button and deselect the check box of the report header title you want to remove. You can optionally drag and drop the report header title from the report to the Report header list.

  Report header titles removed from the report are shown in the Report header list in the Toolbox window.

Adding report header titles and values

To add a report header title and value to a report

- On the **Insert** tab of the ribbon, click the **Header** button and select the check box of the report header title you want to add. You can optionally drag and drop the report header title from the Report header list to the report.

Adding existing columns

To add an existing column

1. On the **Insert** tab of the ribbon, click **Add=>Existing**.
   Optionally, right-click the report and select **Insert column=>Existing** from the drop-down list.
   The Add columns window opens.
   **NOTE:** You can also drag and drop items from the Column heading list in the Toolbox window to add existing columns to your report.
2. Select the columns you want to add to the report.
3. Click **OK**.

Adding custom columns

You can add custom columns to create custom calculations using expressions or blank columns. The ability to create custom calculations using expressions enables you to further customize report data to suit your specific business needs. Blank columns can be used as spacers to make reports easier to read, or as placeholders for importing third-party data after a Flexible Reporting report has been generated.

**NOTE:**

- Adding columns containing custom calculations requires a thorough understanding of Microsoft Excel and regular expressions.
- We recommend you preview reports containing custom calculations in Flexible Reporting before saving the changes and generating the report in the Contact Center Management website.

To add a column containing custom calculations

1. On the **Insert** tab of the ribbon, click **Add=>Custom**.
   Optionally, right-click the report and select **Insert column=>Custom** from the drop-down list.
   A blank column displays in the report.
2. Right-click a cell in the blank column and select **Expression**.
   The Edit expression window opens.
   **NOTE:** You cannot create calculations using expressions in a header cell.
3. Select an option in the **Options** list to view the associated **Item** list.
4. Select an item in the **Item** list to view the associated item **Description** and expression **Example**.
5. Double-click the item in the Item list to insert its expression into the Expression box.
6. Repeat steps 3 to 5 until the complete calculation is entered in the Expression box and click OK. The expression displays in row two of the blank column in the report.
7. If you want to edit the expression you created, right-click the cell and select Expression to return to the Edit expression window.

After adding a column containing custom calculations you can choose to view or modify the expression.

To view or modify an expression:
1. Select the cell in the report, for which you want to view or modify the expression.
2. On the Insert tab of the ribbon, click Expression. Optionally, right-click the column and select Expression from the drop-down list. The Edit expression window opens.
3. Select an option in the Options list to view the associated Item list.
4. Select an item in the Item list to view the associated item Description and Expression example.
5. Double-click the item in the Item list to insert its expression into the Expression box.
6. Repeat steps 3 to 5 until the complete calculation is entered in the Expression box and click OK. The expression displays in row two of the blank column in the report.

You can restrict the number of decimal places that will display for results. As an example, setting the number of decimal places that will display for the Average Manned Agent statistic is described below.

To set the number of decimal places that display for results:
1. In the Design view, right-click the Average Manned Agent column in the report and select Expression from the drop-down list.
3. Click OK.
4. Click Save. The column is formatted to display one decimal place. To alter the number of decimal places displayed, enter the appropriate number in place of 1.

To add a blank column:
1. On the Insert tab of the ribbon, click Add=>Custom. Optionally, right-click the report and select Insert column=>Custom from the drop-down list. A blank column displays in the report.
2. Optionally, click the header cell of the blank column and type a name for the column.

Moving columns
To move a column:
- On the report grid, drag and drop the column to where you want it on the grid.

Deleting columns
To delete a column:
1. Click a column on the report grid.
2. On the Insert tab of the ribbon, click the Remove button. Optionally, right-click the column and select Delete column from the drop-down list.

NOTE: Some statistics require specific columns to ensure a report is meaningful. These statistics are associated with the required columns and cannot be deleted on their own. For example, in by period reports, you cannot delete the interval; in by device reports, the reporting number cannot be deleted.
Editing column heading names

You can edit the names of column headings so they are meaningful to your department, business, and industry. You can change the font type, size, and style as well as edit the text.

To edit a column heading name

1. Click a column heading on the report grid.
2. On the Home tab of the ribbon, use the font options to change
   • the font type, size, and style
   • the justification
3. Optionally, edit the name of the column heading.
   If, after renaming a column heading, you want to see the original column heading name, hover over the column heading. The original column heading name displays after Name.

Specifying column width

To specify the column width

1. Click a column.
2. On the Home tab of the ribbon, after Column width, type the width (in pixels).
   Optionally, right-click the column and select Column width from the drop-down list.

To auto-fit the column width

1. Click a column.
2. On the Home tab of the ribbon, after Scale to fit, click Auto.
   Optionally, right-click the column and select Auto-fit Column width from the drop-down list.

Specifying row height

You can specify a different row height for the header row than the body rows.

To specify the header row height

1. Click the header row.
2. On the Home tab of the ribbon, after Row height, type the height (in pixels).
   Optionally, right-click the header row and select Row height from the drop-down list.

To specify the body row height

1. Click a body row.
2. On the Home tab of the ribbon, after Row height, type the height (in pixels).
   Optionally, right-click the body row and select Row height from the drop-down list.
   All of the body rows will be the same height.

Specifying row colors

You can alternate row colors to make report data easier to read.

1. On the Home tab of the ribbon, select the primary and alternate colors.
2. After Alt row count, type the number of rows for each color.
Freezing columns
Frozen columns remain stationary when you scroll to view columns to the right.

To freeze a column heading
1. On the report grid, click the column to the right of the ones you want to freeze.
2. On the Insert tab of the ribbon, click the Freeze column button. Optionally, right-click the column and select Freeze column from the drop-down list.

Unfreezing columns
To unfreeze a column heading
1. On the report grid, click the column to the left of the frozen column.
2. On the Insert tab of the ribbon, click the Unfreeze column button. Optionally, right-click the column and select Unfreeze column from the drop-down list.

Managing your Flexible Reporting reports
You manage your Flexible Reporting reports on the My Reports window. My Reports gives you access to all of the reports you have created.

NOTE: You can access all the reports you have created and all shared reports created by others, by clicking the Flexible Reporting button=>Open.

In the My Reports window you can
• Change access properties: Shared or not Shared
• Rename reports
• Delete reports

Changing access properties
To change the access properties of a report
1. On the View tab of the ribbon, click My reports.
2. Select the report(s).
3. If you want to share the report(s), under Shared, select the check box. Otherwise, clear the check box and the report(s) will be available to you only.
4. Click OK.

Renaming reports
To rename a report
1. On the View tab of the ribbon, click My reports.
2. Select a report and click Rename.
3. Edit the name.
4. Click OK.
Deleting reports

You can only delete the reports you create.

To delete a report

1. On the View tab of the ribbon, click My reports.
   NOTE: You cannot delete a report that is open in Flexible Reporting.
2. Select the report(s) you want to delete and click Delete.
3. Click Yes to delete the selected report(s).
4. Click OK.

Running reports

You can run Flexible Reporting reports on the Contact Center Management website or in Flexible Reporting. However, you can schedule reports on the Contact Center Management website only.

From the Contact Center Management website, you can run Flexible Reporting reports on demand, or schedule them, the same way you run standard reports. See “Reporter” on page 259 and “Scheduled Reports” on page 263.

In Flexible Reporting you can run, save, and print reports on the Preview tab. After you run a report, printing options enable you to view the print layout, and configure page setup and printer properties.

NOTE:
• Flexible Reporting will run reports only when there is data to generate the report.
• If you run a report on the Preview tab and the report data is all zeros, ensure you selected a device on which to run the report. If you selected a device, ensure the selected time period is one that would have incurred activity.

Running reports in the Contact Center Management website

To run an on-demand report in the Contact Center Management website

• Click Reporter=>Flexible Reporting and select and run the report.
  You will have access to all Flexible Reporting reports created by you and shared Flexible Reporting reports created by others.

NOTE: When a report supports more than one device type, click on each tab to select the devices on which you want to report.

To schedule a report on the Contact Center Management website

1. On the Contact Center Management website, click Reporter=>Scheduled reports.
2. If you want to create a new schedule, click Next. Otherwise, select an existing schedule and click Manage schedule properties.
3. Configure the schedule properties and distribution attributes.
   For more information, see “Creating Contact Center Management Report schedules” on page 264.
4. Click Add a report.
5. Click Flexible Reporting and select a report to add to the schedule.
Running reports in Flexible Reporting

To run reports in Flexible Reporting

1. On the Preview tab, under Devices, select the device(s).
2. Specify the date and time parameters.
3. Click Run report.
   Flexible Reporting generates the report and displays it in the preview pane.

Saving templates and reports

In Flexible Reporting you can save

- Templates
  The report templates you create in Flexible Reporting are saved on the Enterprise Server so you can run them from Flexible Reporting and the Contact Center Management website.
  NOTE: Report templates are not saved automatically. You must save your report template before you exit Flexible Reporting if you want to use it to run reports or modify the template later.

- Reports
  After you run a report in Flexible Reporting, you can save the output (report) on your computer or elsewhere on your network. Reports can be saved or, optionally, exported in Excel or .pdf formats.

To save a report template as a new document

1. Click the Flexible Reporting button and select Save as.
2. After File name, type the name of the new template.
   NOTE: Only you can run and view reports you have created and designated as not shared. Shared reports can be run and viewed by others.
3. If you want to allow others to run the report, select the Shared check box.
4. Click Save.

To save modifications to a report template

- Click the Flexible Reporting button and select Save.

To export a report in Excel or .pdf format

- In the Preview window, above the generated report, click the Save button, select Excel, and specify the location to save the report as an Excel file, or select Acrobat (PDF) file and specify the location to save the report in .pdf format.
   Optionally, click the Export report button, on the View tab of the ribbon, and specify the file type and location, as above.

Printing reports

To print a report you ran on the Preview tab

- On the Preview window toolbar, click the Print button.
Chapter 17
Intelligent Queue

Using Intelligent Queue
Intelligent Queue functionality
Planning the number of ports you require
Understanding the call flow process
Setting up Intelligent Queue
Callback and recording plans
Maintaining Intelligent Queue and Contact Center Management
Web callback
Downloading the Web callback example page
Customizing your Web callback page
Troubleshooting Intelligent Queue Issues
Intelligent Queue

Intelligent Queue is an all-in-one, scalable, web-based, integrated voice processing solution providing static messaging, intelligent messaging, voice and web callbacks, call recording, enhanced routing, reporting capabilities, and caller-entered digit screen pop when integrated with Contact Center Screen Pop.

Intelligent Queue is an optional application that works with Contact Center Management. Contact Center Management provides real-time statistics (required for queue conditional messaging) and historical reporting of Intelligent Queue activity (Call detail reporting option). It supports the G729 codec with a voice compression rate of 1/8. The compression optimizes network bandwidth so that networked branches of a company can communicate more quickly and efficiently with each other.

Intelligent Queue is easily and effectively managed through a web-based interface with .wav file recordings. Administrators dynamically configure the application ports and features of Intelligent Queue from an Internet Explorer browser. This flexibility makes the system highly responsive to the needs of the contact center manager.

Using Intelligent Queue

The Getting started section provides information on licensing, registering, activating, and upgrading Intelligent Queue.

Licensing Intelligent Queue

Intelligent Queue consists of the following core and optional functionality. (See Table 17-1).
Table 17-1: Overview of Intelligent Queue functionality

<table>
<thead>
<tr>
<th>Licenses</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Software (4 port basic RAD with access to one 3300 ICP)</td>
<td>Incoming call handling</td>
<td>RAD messaging</td>
</tr>
<tr>
<td></td>
<td>MiTAI Integration</td>
<td>The addition of MiTAI provides Intelligent Queue with the ability to deliver flexible ports. MiTAI is used by Intelligent Queue to monitor its ports.</td>
</tr>
<tr>
<td></td>
<td>VoIP Integration on the 3300 ICP/SX-200 ICP</td>
<td>With IP device licenses you can implement Intelligent Queue on the 3300 ICP/SX-200 ICP without analog integration.</td>
</tr>
<tr>
<td></td>
<td>Music on hold</td>
<td>Music on hold</td>
</tr>
<tr>
<td></td>
<td>System administration</td>
<td>Administration via phone</td>
</tr>
<tr>
<td></td>
<td>Alarms for critical functions*</td>
<td>Alarms for critical functions*</td>
</tr>
</tbody>
</table>
### Table 17-1: Overview of Intelligent Queue functionality (Continued)

<table>
<thead>
<tr>
<th>Licenses</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smart Choice Trees, Time of Day, Day of Week, Time in Queue, and Reporting</td>
<td>Smart Choice Trees, Time of Day, Day of Week, Time in Queue, and Reporting</td>
<td>Provides callers with expected wait times and position in queue and updated position messaging.</td>
</tr>
<tr>
<td></td>
<td>Time in Queue messaging*</td>
<td>Provides callers with expected wait times and position in queue and updated position messaging.</td>
</tr>
<tr>
<td></td>
<td>Unlimited layers for interactive trees</td>
<td>Interactive Trees can capture all departments and potential customer requirements with unlimited sub-menu.</td>
</tr>
<tr>
<td></td>
<td>Voice trees (Smart Choice)</td>
<td>Performs automated attendant operations to guide callers to the most appropriate information, Automatic Call Distribution (ACD) path or extension.</td>
</tr>
<tr>
<td></td>
<td>Enhanced call flow</td>
<td>When programming interactive trees in Intelligent Queue, you can now direct call flow based on conditions, and other trees, as well as actions.</td>
</tr>
<tr>
<td></td>
<td>Updated position in queue*</td>
<td><strong>CAUTION:</strong> Updated position in queue is supported on the 3300 ICP and the SX-2000. With Updated position in queue, Intelligent Queue informs callers of their queue position when they first enter a queue, and keeps callers updated throughout their wait as their position changes. <strong>NOTE:</strong> In order to use Updated position in queue, you must enable all HCI options on Class of Service Assignment form 1 (COS 1). See &quot;Appendix A 3300 ICP port configuration&quot; in the Intelligent Queue Installation Guide.</td>
</tr>
<tr>
<td></td>
<td>Post choice greetings</td>
<td>Intelligent Queue has the ability to play a greeting after a customer has made a choice in the interactive tree and prior to being transferred.</td>
</tr>
<tr>
<td></td>
<td>Expected wait time messaging*</td>
<td>You can now base time in queue messaging on the expected wait time, in addition to providing a customer with the current number of callers in queue, or the current longest waiting caller. (Average Talk Time X Current Calls Waiting)/Agents Available = Expected Wait Time.</td>
</tr>
<tr>
<td></td>
<td>Intelligent messaging</td>
<td>Intelligent Messaging provides callers with time of day, day of week and exception-based messaging. It reassures callers that their calls are important and informs them of special time/day exceptions.</td>
</tr>
<tr>
<td></td>
<td>Reporting*</td>
<td>Enables Intelligent Queue reporting.</td>
</tr>
<tr>
<td>Licenses</td>
<td>Feature</td>
<td>Details</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Voice Callback</td>
<td>Voice call back processing</td>
<td>Provides callers in queue with the option of entering their phone number and voice message requesting a queued callback from the contact center.</td>
</tr>
<tr>
<td></td>
<td>Multiple Callback Profiles for voice or Web callback</td>
<td>Intelligent Queue can create distinct callback profiles based on the type of callback. These profiles enable an agent to understand the origin of the callback request by providing a specific callback greeting to the customer, such as, “This is an XYZ callback”, and an introduction to the agent, such as, “You have an XYZ callback.”</td>
</tr>
<tr>
<td>Web Callback</td>
<td>Web call back processing</td>
<td>Enables a customer to submit a request for contact via the Web.</td>
</tr>
<tr>
<td>ANI/DNIS</td>
<td>Routes incoming callers based on ANI and DNIS numbers</td>
<td>Allows calls to be routed by Automatic Number Identification (ANI), and DNIS (the number dialed).</td>
</tr>
<tr>
<td>Collect Caller-entered digits</td>
<td>Caller-entered digits</td>
<td>For customers who are not identified by ANI, Intelligent Queue has the ability to request and collect caller-entered digits.</td>
</tr>
</tbody>
</table>
| Remote Database Verification | Interact with third-party ODBC-compliant databases to provide remote database verification and routing decisions based on ANI/ DNIS and/or collect caller-entered digits | Required: ANI/DNIS option Remote database verification and advanced routing based on ANI or DNIS.  
Required: Collect Caller Entered Digits option Remote database verification and advanced routing based on user collected digits.  
Voice readback Intelligent Queue can now provide digit verification, by reading back digits callers dialed, using system prompts. It can also read back a number, such as an account balance, when provided with an account number. |
| Agent recording  | Recording                         | CAUTION: Recording is supported on the 3300 ICP only. Intelligent Queue enables you to access administrative screens and record agents based on agent IDs or extensions. Calls are recorded into .wav files in the order in which the extension IDs were entered and saved within the Intelligent Queue administration. |
| Additional 4 ports | Add 4 ports to the base         | Intelligent Queue Enterprise Edition supports 60 ports.                                                                                   |
Table 17-1: Overview of Intelligent Queue functionality (Continued)

<table>
<thead>
<tr>
<th>Licenses</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Works</td>
<td>All options included with 8 ports, single site</td>
<td></td>
</tr>
<tr>
<td>Enterprise Node</td>
<td>Enables messaging to 1 additional 3300 ICP/SX-200 ICP</td>
<td>Multi-PBX support/Multi-site support</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can configure multiple telephone systems on the same server.</td>
</tr>
<tr>
<td>Enterprise Node Gateway</td>
<td>Enables messaging to 1 additional 3300 ICP?SX-200 ICP Gateway</td>
<td></td>
</tr>
<tr>
<td>Enterprise Node Gateway Upgrade</td>
<td>Converts the Enterprise Node Gateway to an Enterprise Node</td>
<td></td>
</tr>
<tr>
<td>BE (Business Edition Package)**</td>
<td>4 port basic RAD with access to one PBX</td>
<td>Messaging and Reporting Flexible (dynamic) messaging/ Routing ports Ports can play messages, and interact with or route callers based on any combination of call properties such as the schedule (Time of Day/Day of Week/Day of Year), ANI (the number from which a call originates), DNIS (the number dialed), information forwarding (redirection), queue conditions, and/or operating mode.</td>
</tr>
<tr>
<td>ANI/DNIS</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Voice Callback</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Collect Caller-entered Digits</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remote Database Verification</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Registering and Activating Intelligent Queue

Before you register Intelligent Queue, ensure you have your site key available. The site key is the five-digit number located in your product fulfillment email.

You must contact prairieFyre by phone at 613-599-0045 and select option 3 for technical support to register and activate your Intelligent Queue software. Registration can be completed online or offline. Upon registration, prairieFyre will issue you a key to license your Intelligent Queue software and a MOSS password you will require during the activation process.

Registering your Intelligent Queue software

To register your Intelligent Queue software

1. Contact prairieFyre by phone at 613-599-0045, select option 3, and provide the technical support representative with the five-digit site key located in your product fulfillment email. prairieFyre will issue you a license key and a MOSS password. Ensure you write this information down as it is required during the activation process.
2. Click Start=>Programs=>Mitel=>Intelligent Queue=>Intelligent Queue License Client. The Registration dialog box opens.
3. If you have an active internet connection, click Register Online. See Registering online.
   If you do not have an active internet connection, click Register Offline. See Registering offline.

Registering online

NOTE: To ensure you are able to register online, any firewalls and proxies must be configured to allow traffic over port 80 to IP address 142.46.199.66.

To register Intelligent Queue online

1. Click Start=>Programs=>Mitel=>Intelligent Queue=>Intelligent Queue License Client.
2. Click Register Online.
3. Type the License Key in the Online Registry form and click OK. Your Intelligent Queue software is registered automatically. When complete, the Online Registration: Successfully Licensed message opens.
4. Click OK and close the Registration window.

Table 17-1: Overview of Intelligent Queue functionality (Continued)

<table>
<thead>
<tr>
<th>Licenses</th>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add 2 ports to base</td>
<td>Maximum 8 ports/site</td>
<td></td>
</tr>
</tbody>
</table>

* For Enterprise Edition, you must have Contact Center Management to have the following functionality: time in queue, updated position in queue, expected wait time messaging, alarms for critical functions via Network Monitor, and Intelligent Queue reporting.

** For Business Edition, you must have Contact Center Management to have the following functionality: time in queue, expected wait time messaging, alarms for critical functions via Network Monitor, and Intelligent Queue reporting.
Registering offline

If you do not have access to the Internet or if you cannot access our license server, you can register offline. After you register offline, the License Client application will register a seven-day demo license while you wait for your license file from prairieFyre Software.

To register Intelligent Queue offline

1. Click Start=>Programs=>Mitel=>Intelligent Queue=>Intelligent Queue License Client. The Registration window opens.
2. Click Register Offline.
3. Type the License Key in the Offline Registry form and click OK. The Offline Registration engine generates the IQ.dlsc file in your Intelligent Queue install folder.
4. Locate the IQ.dlsc file and email it to the Technical Support representative. He will sign the IQ.dlsc file electronically and send it back to you.
5. Replace the existing IQ.dlsc file with the signed copy.

Registering a seven-day demo license

With the seven-day demo license you receive 24 ports, callbacks, and CDR so you can continue using Intelligent Queue. However, you should replace the demo license file before the seven days expire to ensure you have continuous access. After you replace the demo license with your license, only the purchased options will be enabled.

To register Intelligent Queue offline

1. Click Start=>Programs=>Mitel=>Intelligent Queue=>Intelligent Queue License Client. The Registration window opens.
2. Click the Install Demo button.
3. Start Intelligent Queue (Start=>Programs=>Mitel=>Intelligent Queue=>Intelligent Queue).

Activating your Intelligent Queue software

To activate your Intelligent Queue software

1. Click Start=>Programs=>Mitel=>Intelligent Queue. The Purchased Options page opens.
2. Enter the Mitel Options (MOSS) Password provided to you during the registration process.
3. Click Save.

Upgrading an existing license

If you are upgrading from Intelligent Queue Version 3.1.x to Version 5.x, you must upgrade your license. Before you start the license upgrade, you will need a new MOS password. If you do not have it, contact prairieFyre Software Inc. Technical Support (dial 613-599-0045 and select option 3, Technical Support).

To upgrade an existing Intelligent Queue license

1. Log on to Intelligent Queue with the default user name and password:
   - Username: mitel
   - Password: setup
2. Click Administration=>Purchased options. The Purchased options window opens.
3. Verify your Mitel Product Key matches the MOSS Options sheet.
4. After **Enter the Mitel Options Password**, type the MOS password you received for the license upgrade.
5. Enter your system options.
6. Click **Save**.
   If the information you entered is correct, menu items will open. The menu items correspond to your purchased options. If you entered incorrect information, the Incorrect select window opens and you will need to correct your system options entries.

### Intelligent Queue functionality

In general terms, the functionality that the Intelligent Queue offers can be broken down into the following core and optional behaviors.

**Incoming call handling**
Incoming call handling behaviors cover the conditions and actions that are triggered when a call is received, such as information messaging, interactive trees, and routing.

**Music on hold**
Music on hold describes the music subsystem and how it behaves.

**System administration**
System administration covers the system behaviors that are related to configuring and maintaining Intelligent Queue.

### Optional functionality

**Callback processing**
Callback processing addresses all the behaviors that occur between the callback request by the customer to the processing of the callback by an ACD agent. Callbacks consist of two parts: intelligent call processing that stems from interactive tree choices and callback processing that requires dedicated ports based on volume.

**Agent call recording**
Agent call recording addresses the behavior of the quality monitoring feature.

**Call detail reporting**
Call detail reporting allows the system to report on the activity of Intelligent Queue through Contact Center Management.

**Caller-entered digits**
Caller-entered digits addresses how the caller can enter digits for identification purposes with screen pop on the agent's desktop through integration with Contact Center Screen Pop.

### Core functionality

Intelligent Queue consists of the following core functionality:

**Incoming call handling**
Intelligent Queue defines port behavior dynamically, based on call properties, schedule, current queue conditions, and operating mode.
**Music on hold**
You can use Intelligent Queue as a music on hold source for your telephone system using a PC sound card, if equipped. Intelligent Queue plays music through the sound card using a rotating (loop) playlist. Music sources for the playlist include any or all of the following: audio CD, stored .wav file, and stored MP3 file. The playlist can include music or prerecorded information messages.

The behavior begins when the music engine is started, either by the Windows service or via the user interface. A user with Intelligent Queue administrator rights can start or stop the music engine from the user interface. Once started, the music engine will loop through the play list, playing continuously until it is stopped.

**System administration**
Intelligent Queue enables you to record announcements or change the Emergency Mode status using the phone. When you record new system prompts, they are stored in a temporary inbox folder until you name the message and assign it to an action or message plan via the Web interface.

System administration includes starting/stopping the engines and event logging.

**Incoming call handling**
The action an Intelligent Queue port takes when a call is received is defined by an action plan. A call’s action plan depends on the conditions defined for the port group.

**Incoming call handling conditions**
When a call is detected at an Intelligent Queue port, the system consults its database to determine which are defined for that port. Conditions are defined in the user interface and act as a decision tree structure. Each port or group of ports has a set of conditions that determine which action plan applies to the current call. If no conditions are defined, or no defined conditions are met, the port uses a default action plan. Action plan selection starts when a call is first detected on the Intelligent Queue port and is completed before the call is answered.

Multiple conditions can be applied to each port, and any condition can lead to another subcondition or action plan. The order in which the conditions are defined in the user interface determines the order that the conditions are applied to a call.

An Intelligent Queue port uses the following conditions to determine an action plan:

**Caller’s telephone number (ANI)**
The system compares a caller’s telephone number to a list (ANI map) of telephone numbers or digit patterns. If a match is detected, the defined action plan or subcondition is applied.

**The number dialed by the caller (DNIS)**
The number that is presented to the telephone system as the dialed digits can be used as a condition.

**Redirection number**
If applicable, the original destination of the call can be used as a condition for determining the action plan. The original destination is the number from which the call was diverted, forwarded, or transferred (unsupervised transfers). For ACD interflow, this device is the ACD path from where the call came.

**Day of the year**
Any specific date can be defined as a condition. You can apply a subcondition, such as time of day, to make the condition more specific.

**Day of the week**
Any specific day of the week can be defined as a condition. You can apply a subcondition, such as time of day, to make the condition more specific.
**Time of day**
A specific time period can be defined as a condition. You can specify the start and end times for which the condition is valid.

**Number of calls in queue**
If you have Contact Center Management, you can use the total number of calls waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port, as a condition for applying an action plan to a call. The system queries Contact Center Management at decision time to determine the current queue conditions.

**Queue waiting times**
If you have Contact Center Management, you can use the longest amount of time that a caller has been waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port, as a condition for applying an action plan to a call. The system queries Contact Center Management at decision time to determine the current queue conditions.

**Operating mode**
The current operating mode of the system or of a port group can be either Normal or Emergency. An Intelligent Queue administrator can place the call flows in Emergency mode to force all calls on a port to use a predefined Emergency action plan. This would typically be due to an unforeseen temporary closure of a contact center, as in the case of a natural disaster.

**Incoming call handling action plans (messaging, callback, and routing)**
All calls are eventually handled by an action plan. An action plan is a set of call handling instructions that defines how to manage a specific call. The relationship between conditions and action plans is that conditions define which action plan is chosen for a specific call. If no conditions are met, a default action plan is used to handle the call. An action plan begins upon selection and carries a call for the duration of its existence within Intelligent Queue.

An action plan can be defined as any of the following call handling types:

**Do nothing (default)**
This is the default type for any action plan.

**Play a message**
The Intelligent Queue port answers the offered call and plays a predefined .wav file that is determined by the condition. Messages can be static, prerecorded phrases or complex messages made up of a set of concatenated phrases. Complex messages can include queue condition values, such as number of callers in queue, call load, and longest waiting call in queue.

**NOTE:** This is the only type of action plan that can be used if the port is defined as a RAD port. In this case, the Intelligent Queue port(s) used to play the RAD would be dedicated.

**Redirect the call**
The call is not answered and is redirected to a predefined destination. Since the call is not answered, no message is played to the caller, and the caller is unaware of the redirection.

**Transfer the call**
The Intelligent Queue port answers the call. Once answered, an optional greeting can be played for the caller and then the call blind transfers to a predefined destination.

**Interact with the caller**
This type of action plan uses a predefined Interactive Tree that is configured to offer choices to the caller. The caller makes their selections using their keypad to navigate to the information or destination that they desire. You can define each digit on the keypad (0-9, *, #) as an option that can perform any one of the following functions: play a message, transfer a call, leave a voice callback, collect digits, manage the system, offer a submenu, go to another choice, repeat the choices, offer Voice callback.
**Offer voice callback**
The Intelligent Queue port answers the offered call and then prompts the caller for information required by a predefined voice callback structure.

**Collect digits**
This option must be purchased and in use on the PBX where Intelligent Queue resides. This option would prompt the caller to enter a digit string, such as an account number. This account number would be sent to the ACD agent that eventually answers the call, for screen pop into a desktop application. The number of digits can be pre-defined, or can be terminated by a digit, such as #, or by a pre-defined duration of silence.

**Manage the system**
The Intelligent Queue port answers the offered call and then prompts the caller for a password. The caller enters the password using their keypad. Once the password is validated, Intelligent Queue allows the caller to record system prompts or change the system’s operating mode (Emergency or Normal mode) using their telephone. When a caller chooses to record new system prompts, Intelligent Queue stores the prompts in a temporary “Inbox” folder. The message is named and assigned to an action plan or message list. When the caller chooses to change the system’s operating mode, the change is immediate and will be reflected when Intelligent Queue receives the next call.

**Music on hold**
You can use Intelligent Queue as a music on hold source for your telephone system using a PC sound card, if equipped. Intelligent Queue plays music through the sound card using a rotating (loop) playlist. Music sources for the playlist include any or all of the following: audio CD, stored .wav file, and stored MP3 file. The playlist can include music or prerecorded information messages.

The behavior begins when the music engine is started, either by the Windows service or via the user interface. A user with Intelligent Queue administrator rights can start or stop the music engine from the user interface. Once started, the music engine will loop through the play list, playing continuously until it is stopped.

**System administration**
You can configure and manage Intelligent Queue through the web-based user interface. The first step is to authenticate the user name and password. This user name/password combination defines the user’s access level. Users will generally be granted selected permissions, while administrators will grant themselves full permissions. Intelligent Queue can run on multiple servers simultaneously. When multiple instances of Intelligent Queue are running at once, the system and user IDs are shown at the top right of the user interface to help users identify which system they are making changes to.

**Starting/stopping the engines**
The messaging engines start automatically when the operating system is started. You can manually start or stop the engines from Services in the Control Panel or through a dialog in the user interface.

**Event logging**
Event logging is applicable to all incoming and outgoing calls. Event logging begins when a call is first detected and ends when a transfer terminates the call or hangs up. Each log contains a self-describing record of the event.

The following events will cause an event to be logged:

- **Call received**
  When a call first enters Intelligent Queue, the system logs all known properties of the call.

- **Action plan selected**
  When Intelligent Queue selects an action plan for a call, the system logs the action plan, as well as the selection criteria.
• **System action**
  The system logs all actions taken by the Intelligent Queue port.

• **Caller action**
  The system logs all actions taken by a caller while connected to an Intelligent Queue port.

• **Agent action**
  The system logs the actions that an agent takes while in a callback.

• **Callback**
  The system logs all actions and events of a callback.

### Optional functionality

Intelligent Queue consists of four types of optional functionality:

**Callback processing**

Intelligent Queue processes callbacks on a first in/first out basis. Upon receipt of a callback request, agents listen to the caller's message, then either place the call, requeue the request, or reject the request.

**Agent call recording**

Agent call recording is used for quality monitoring. Intelligent Queue enables you to access administrative screens and record agents based on agent IDs or extensions.

**Call detail reporting**

Call detail reporting enables the system to report on Intelligent Queue call activity.

**Caller-entered digits**

Caller-entered digits enable callers to enter digits with their keypad for identification purposes.

### Callback processing

Callback processing consists of

- Voice callback requests
- Web callback requests

Intelligent Queue processes callback requests in a continuous loop using the ports that are dedicated to callback processing. Each callback queue on the telephone system needs to be created, identifying the group and priority for the callbacks. Each callback request is submitted with a callback action plan. This structure defines the ACD path to attempt, the client's telephone number, the client's name, the greeting to be played, queue thresholds, and the language in which the call should be processed. Intelligent Queue processes callbacks on a 'first in/first out' basis, but each call has a maximum number of attempts and a retry interval. If the client does not answer the call, the system requeues the callback request to a maximum number of attempts. Intelligent Queue will not attempt the callback again until the retry interval has been exceeded. However, if the callback request reaches a customer's voice mailbox, the agent can then leave a voice mail message.

Each callback structure also defines the maximum amount of time the callback port will wait for an agent to answer, before requeuing the call and moving to the next request. Upon receipt of a callback request, agents can listen to the caller's message, place the call, requeue the request, or reject the request. Callback requests can be viewed, prioritized, deleted, changed, or executed immediately from the user interface by a user with administrator privileges.

### Voice callback request

Voice callback allows a caller to request an agent callback instead of staying on the line. You can create distinct callback profiles based on the type of callback. These profiles enable the agent to understand the origin of the callback request by providing a specific callback greeting to the customer and an introduction to the agent.
A voice callback request prompts the caller for the following information:

- A telephone number at which they can be contacted
- The caller’s name (recorded as a .wav file for playback by an ACD agent)
- A confirmation to submit the request

Once the caller provides the information, Intelligent Queue hangs up and records the request in the database for processing.

**Web callback request**

Web callback allows a customer to request an agent callback via the Web. The customer completes a Web callback request on an HTML/ASP page that is designed and hosted by the Intelligent Queue customer. Intelligent Queue then submits the information to the database for callback processing.

A web callback request prompts the caller for the following information:

- The telephone number at which they can be contacted
- The customer’s name (presented as a Text To Speech (TTS) rendition to the ACD agent)
- The target ACD path

Intelligent Queue then submits the information to the database for callback processing.

**Agent call recording**

Call recording, for quality monitoring purposes, requires that ports be dedicated as recording ports to ensure availability and to avoid call collisions with incoming calls. Intelligent Queue administration initiates this functionality and saves all recordings as .wav files.

Using Intelligent Queue, a user with sufficient rights enters an agent ID or extension number to request that a current call, or the next call received, be recorded. An agent that is being recorded cannot be monitored by anyone else at the same time. Once the recording completes, the user can access the recording with Intelligent Queue Administration to view the success or failure of the request and to play, export, or delete the recording.

Please check your municipal, provincial/state, and federal laws governing the use of call recording. Agent call recording is for "ad hoc" recording, and not for recording all agent calls.

**Call detail reporting**

The Call detail reporting option requires Contact Center Management (version 5 or higher) and Microsoft Excel to generate reports. Call detail reporting allows the system to report on the activity of Intelligent Queue. For example, you can generate a report that lists the choices callers are making in the interactive trees. This option helps you to make decisions about future call handling and processes, with an eye to continually improving service and effectiveness. You can create reports based on selections made by in-queue callers to navigate through Intelligent Queue.

**Planning the number of ports you require**

**NOTE:**
- System requirements change based on the number and type of ports you add.
- You must be a registered user to access Mitel OnLine. First time users will be prompted to register and create a username and password which can be used on all subsequent visits.
It is important that you carefully plan the total number of each port type you require before you configure Intelligent Queue. Visit the Contact Center Portal on Mitel OnLine to view the Intelligent Queue port sizing tool (Excel spreadsheet). Port usage is inherently tied to the amount of traffic that the queues will be getting, as well as from the frequency of updates, and length of the messages played during the updates. The best way to determine the number required is to use the Intelligent Queue port sizing tool.

If an action plan calls for RAD messaging, a dedicated port is required. The number of RAD ports required is based on the volume of calls and of distinct messaging sequences. If an action plan requires one-to-one interaction, the number of ports required is based on volume.

To access the Intelligent Queue port sizing tool


Types of ports

The type of port(s) you assign to the call flow determines what happens when the caller presses a telephone digit. Generally, messaging ports should make up the largest percentage of ports. If you do not have voice callback, you do not need callback ports.

Intelligent Queue uses several types of ports:

**Messaging ports**

Messaging ports are used for all incoming calls to Intelligent Queue. Messaging ports provide one-to-one interaction with the caller through interactive trees, messaging, routing, and taking callback requests. Messages can be either static or dynamic if you have Contact Center Management. Every messaging port is dynamic unless it is defined as a RAD (Recorded Announcement Device) on the communications system. A RAD port is a dedicated port that plays the same message for up to 50 callers simultaneously.

**Management ports**

Management ports are a type of messaging port used for emergency and prompts.

**Callback ports**

Callback ports are dedicated ports used for the outbound portion of callback requests. This type of port executes the callback with the ACD Agent.

**Recording ports**

Recording ports are dedicated ports used by supervisors to record ACD calls for quality monitoring purposes.

**Updated position in queue ports**

Updated position in queue ports are ports used for the Updated position in queue message. A port can play more than one updated position in queue message, however, it sends that message to one caller at a time only.

**NOTE:** In order to use Updated position in queue, you must enable all HCI options on Class of Service Assignment form 1 (COS 1). See "Appendix A 3300 ICP port configuration" in the Intelligent Queue Installation Guide.

Types of messaging ports

Several factors affect the number of messaging ports you require for your Intelligent Queue system:

- the type of messaging: RAD or intelligent messaging (interactive trees)
- the nature of the message
- the length of the message
- the number of callers to whom you want to play an Updated position in queue message
- RAD messaging ports
When programmed on your telephone system as a RAD, Intelligent Queue ports are dedicated to a distinct messaging sequence. The Class of Service (COS) given to each RAD port has the Recorded Announcement Device option enabled in the COS. When configured as a RAD, the Intelligent Queue port does not receive any of the audio or DTMF digits entered by a caller. The telephone system processes the DTMF input instead of passing the digits to Intelligent Queue.

An Intelligent Queue port that is programmed as a RAD can play messages to callers who are waiting in an ACD path. The primary function of a RAD is to supply messages to up to 50 incoming calls simultaneously. This feature is beneficial to companies that want to supply general announcements. Each RAD (or distinct messaging sequence) requires a dedicated port, a directory number, and its own Class of Service. The number of RAD ports in a system depends upon the number of distinct announcements required by the customer and the call volume.

Up to 50 callers can listen to one RAD simultaneously. Any caller routed to a busy RAD is put on hold until the recording is finished. When the port clears down, the RAD is seized and all waiting callers receive the announcement. All calls maintain their position in the incoming queue, either while listening to the RAD or while queued for service. If an agent becomes free while a caller is listening to a RAD, Intelligent Queue routes the caller to that agent immediately.

**RAD port conditions**

RAD ports are not as flexible as intelligent messaging ports and require dedicated ports on Intelligent Queue. RADs play for up to 50 people at a time, making it impossible to use some of the conditions that make other ports flexible.

You can apply the following conditions to RAD ports to make them more flexible:

- Schedule conditions (time of day, day of week, day of year)
- Queue conditions
- Emergency conditions

You cannot apply the following conditions to RAD ports, because there are up to 50 different callers on the call at once:

- ANI conditions
- DNIS conditions
- Redirection conditions

The number of Intelligent Queue RAD ports that you require depends on the number of distinct messaging sequences that you require in your ACD environment, as well as basic traffic requirements. The following ACD path example requires three Intelligent Queue ports for RAD messaging.

The first port in this scenario identifies the department that the caller has reached. There are two departments offered (Sales and Support), so the system requires two distinct messages. In both ACD paths, the second message that a caller hears is a generic, *please hold* type of message that can be shared between the paths. Only one port is required for the common message. However, the number of ports required might increase based on volume.

Intelligent Queue can use a RAD port for the PBX Auto Attendant, because the DTMF is processed by the PBX. For example, a caller might hear the message, “If you know the extension of the person you wish to reach, please dial it now.”
Intelligent call processing ports

When you use an intelligent call processing port, Intelligent Queue handles a single caller at a time. The amount of time that the port is in use depends on the options given to a caller. You can configure intelligent messaging ports to execute the following actions: play messages, accept callback requests, collect digits, manage the system, offer a submenu, go to another point in the tree, replay the greeting, or route callers to predefined destinations (queue/voice mail/extension). The action the system takes depends on the following conditions: ANI, DNIS, redirection, schedule, queue conditions, and system mode. When the port is used to accept callback requests, Intelligent Queue collects the caller’s information on the intelligent messaging port, but the actual processing of the callback takes place on a separate, dedicated callback port.

Callback processing ports

Callback ports are Intelligent Queue ports that are dedicated to processing all of the collected callback requests based on a callback plan. Callbacks are action plans that can be associated with each individual request, rather than with a predefined port. When an agent answers, the system gives the agent the option to listen to the message or place the call. Once the agent places the call, the callback port begins processing the next request in the database. The number of callback ports required depends on the expected number of callback requests to be processed.

Recording ports

Recording ports are Intelligent Queue ports that are dedicated to quality monitoring. You can initiate call recording from the Intelligent Queue user interface. Using Intelligent Queue, a supervisor enters an Agent ID, extension number, or Agent Group ID to request that the current call or the next call received be recorded. Once the recording completes, the system notifies the user of the success (or failure) of the request, as well as the file name with which the call recording has been stored.

Updated position in queue ports

A port can play more than one updated position in queue message, however, it sends that message to one caller at a time only. Updated position in queue ports are Intelligent Queue ports that are dedicated to continually informing customers of their current position in queue. Intelligent Queue tells customers their queue position when they first enter queue and keeps customers updated throughout their wait as their position changes. For example, Intelligent Queue states “Three” when the customer is third in line to be answered. As the customer’s position in queue changes, Intelligent Queue will continue to update the customer, stating “Two” and then “One.” You add a .wav file to play in front of the position provided by Intelligent Queue and you configure how often Intelligent Queue will update the customer. For example, “You are caller number” “Three” can be configured to play once every minute. You specify the number of customers Intelligent Queue will inform of their Updated position in queue, keeping in mind that each call requires a port.

NOTE: In order to use Updated position in queue, you must enable all HCI options on Class of Service Assignment form 1 (COS 1). See "Appendix A 3300 ICP port configuration" in the Intelligent Queue Installation Guide.

Types of messages

You can program ports on Intelligent Queue as either RAD or interactive ports. You must consider how the ports are programmed on the system as well as call volume when determining the number of ports required. The number of required RAD ports is based on the number of dedicated ports per distinct messaging sequence and call volume. The number of required interactive ports is based on how many telephones are programmed on the system as a device (telephone) and the call volume.
The type of the message played by a port also has an effect on the number of ports required by Intelligent Queue. If the message is generic in nature and can be shared by several applications, the system requires fewer ports. For instance, if a RAD port plays the message, “Please hold to maintain your call priority,” then more than one ACD group can use this port. If the message is more specific, a new port is required. For example, only a sales ACD group would use a RAD port that plays the message, “Please hold to speak with a sales representative.”

With Intelligent Queue, you can combine different types of messages within a messaging plan:

**Interactive tree messages**
Interactive trees play advanced messages that are played before a caller enters the queue. An initial message greets callers and lists their options. The caller selects from the options by pressing a telephone digit. The caller can then navigate through multiple options to arrive at the information or ACD path that best suits their needs.

**RAD messages**
RAD messages are basic in-queue messages. Intelligent Queue plays RAD messages to greet callers and provide advertisements or information while callers wait for an agent. These are “Thank you for holding” type messages. Messages must be .wav files. Music can be .wav or MP3 files or an external music source such as an audio CD.

**Time in queue messages**
NOTE: If you have Contact Center Management version 4.x, and you want to use time in queue messaging, you must have the Client Component Pack installed before you install Intelligent Queue.

Time in queue messages are played to a caller while in queue. They are based on real-time ACD statistics, such as the expected wait time before the call is answered.

This is how Intelligent Queue calculates the expected wait time: If there are agents available: Expected Wait Time = (Average Talk Time for the Queue x Calls Waiting in the Queue) / Available Agents, and if there are no agents available: Expected Wait Time = Average Time to Answer for the Queue

**Updated position in queue messages**
Updated position in queue messages are played to a caller while in queue. They inform customers of their initial queue position, and keep them informed of their position as it changes, at preset intervals.

Intelligent Queue Updated position in queue will provide the position but will not provide the message. If you want the callers in queue to hear a message, for example, “Your call will be answered next” or “You are in position...” you must record the message. See “Recording voice prompts” on page 478.

**Length of messages**
You should consider the length of the message that callers hear when determining the number of ports the system requires. If all of the ports are busy playing messages to callers, new callers have to wait until the previous message finishes before they are answered.

Intelligent Queue has no restriction on the length of the message files, however, the PBX does. You must program the length of the message in the PBX Class of Service (COS).

**Number of ports purchased**
The number of Intelligent Queue ports you have purchased is shown on the Mitel Options sheet and in the Intelligent Queue Administration menu. Intelligent Queue supports a maximum of 60 IP ports per PBX.
Understanding the call flow process

Mitel ACD, an advanced automatic call distribution feature package that is fully integrated with Mitel enterprise communications platforms, provides the following capabilities:

- Route calls to the most appropriate group(s)
- Queue and prioritize callers
- Distribute calls fairly within a group—longest idle or highest skilled agent gets the call
- Automatically reroute or expand the availability of agents based on current queue conditions
- Network multiple contact centers together
- In-queue messaging

Mitel’s ACD functionality allows contact centers to distribute incoming calls to the longest idle agent or the agents with the highest skill level.

Each ACD agent receives a unique agent ID number. The agent ID number is similar to a telephone directory number and can be assigned a name in the telephone directory.

You can use agent groups to group agents according to their line of business. Up to four agent groups can be programmed to an ACD queue. You can assign agent groups to one or more queues. Each queue supports up to four RAD messages, with the last being replayed as often as required, based on wait time.

Creating call flows

You can use Intelligent Queue to help determine where each call should go (ACD queue) and what each caller will hear.

To create a call flow

1. Assign conditions and actions.
   - Define conditions (ANI, DNIS, emergency, queue, redirection and schedule conditions)
   - Define actions (callbacks, digit collection, interactive trees, management, messaging and routing)
2. Assign call flows to port groups.

The ACD queue

The ACD queue is a flexible call routing method that provides the information required for handling incoming calls. The ACD queue controls the resources used, the order in which resources are encountered, and the timing of the steps. Calls are queued for an agent group based on the call priority and order of arrival at that path. Queuing is the same for new calls and overflow calls. If an agent group is not available, the system routes calls to an alternative agent group or "interflows" to another destination. Up to 256 ACD queues are supported, including one primary agent group and three overflow agent groups per queue.

Queue priority

Each ACD queue is assigned a priority level in the range of one to 64, with one being the highest.

Agent groups

An agent group consists of a logical grouping of agents trained to support a particular type of call. All queues are routed to one primary agent group and up to three overflow groups. Intelligent Queue supports up to 64 different agent groups to handle incoming ACD traffic.

Call flow

Typically, you program the ACD to ensure that the first call to arrive is routed to the longest idle agent or the agent with the highest skill level. If multiple agents are free when an ACD call is presented to a group, the system sends the call to the longest idle agent. Idle time is calculated from completion of an agent’s last ACD call.
A caller should never receive a busy tone from an available queue. Intelligent Queue handles an incoming ACD call with the following actions: the caller receives a ringback tone, the RAD timer starts, the interflow timer programmed in the queue starts, the overflow timer for the primary group in the queue starts, the call goes to the longest idle/highest skilled agent.

When a trunk picks up a call, it forwards it through to a group of agents handling calls or to another answering point. The call arrives at the ACD queue of an agent group. The length of time the caller waits in queue is the queue time. While waiting in queue, the caller listens to product features, announcements, or other messages provided by a RAD. The caller can wait in queue for an available agent, leave a voice mail message, or abandon the call by hanging up, depending on how Intelligent Queue and the telephone system have been programmed.

When an agent is available, the customer connects immediately to the agent. When no agent is available, the caller automatically queues to the primary agent group in the queue. In both cases, the caller’s communication path remains unaffected and the caller remains listening to its ringback tone, RAD or music on hold. The caller receives a ringback tone until the first RAD answers, an agent answers, interflow occurs, or the caller hangs up.

**Overflowing calls**
A queue contains one primary agent group and can have up to three overflow groups. The overflow groups provide backup resources to the primary agent group to ensure that service level goals are met. Calls that overflow maintain their position in queue. Agent group overflow timers determine how long a call waits before overflowing.

Intelligent Queue places an ACD call that is not answered immediately in a queue. If an agent does not pick up the call after a set amount of time (the overflow time), the system places the call in the queue of another agent group, in addition to keeping it in the first group. The first available agent in either group handles the call. The overflow feature limits the delay for callers by queuing calls against two or more agent groups.

**Interfowing calls**
You can program the telephone system to direct a call to voice mail or to another answering point. The interflow timer runs independently of the overflow timer. If the interflow timer expires, the system removes the call from the queue and redirects it to another answering point, such as a trunk or voice mail.

Interflow is a time- or load-based feature that takes an ACD call out of the queue and routes it to the interflow answer point (if one is programmed). A call that interflows to another queue adopts the priority of the => queue and does not look back for an agent to become available from the initial queue in the following instances: the new queue has *Interflow to this path uses this path priority* set to Yes in its Path Assignment form, or the call interflows from a queue that has a priority of 64.

Otherwise, the call’s priority does not change.

**Setting up Intelligent Queue**
This section includes information on
- Administration procedures
- Configuring ports, PBX settings, Contact Center Management settings, Music Manager, and Updated position in queue
- Managing actions
- Managing conditions
- Managing call flows
- Managing port groups
- Viewing the status of a queue
Administration procedures

In this section, you will learn how to
- Log on and off as an administrator
- Enter your purchased options
- Set up administrator and user permissions
- Change system modes
- Change passwords
- Set up the automatic backup

Logging on and off for the first time (Administrator)

**CAUTION:** Your toolbars and your firewall might interfere with your ability to view Intelligent Queue. Ensure you have turned off any pop-up blockers found on your tool bars, and made the Intelligent Queue site an exception on your firewall. To turn off the Microsoft Pop-up Blocker, click Tools=>Pop-up Blocker=>Turn Off Pop-up Blocker.

Once the installation completes successfully, you can log on to the Intelligent Queue server for the first time. The initial logon opens the System options window, which requires you to select your purchased options and enter the number of licensed ports. Consult your MOSS Options Sheet, enter your Mitel Options password (MOP), and save the settings.

To log on to Intelligent Queue from the server computer

1. In Internet Explorer, type `http://[your server address]/Intelligent Queue`. The Login window opens.
   **NOTE:** Alternatively, you can launch the application from the Start menu.
2. **After Login**, type `mitel`.
   **NOTE:** mitel is the default user name you will use until you set up your administrator account. You will need to create your own user account as "mitel" is proprietary. After you create an administrator’s account and log out, you can log back on with your new account information.
3. **After Password**, type `setup`.
4. Click **OK**.
5. Click **OK**.
   The Purchased options window opens.
   See “Entering your purchased options” on page 429.
   **NOTE:** After you save your options, your Mitel Options password becomes the password for the Mitel account.

Logging off

To log off Intelligent Queue
- Click **Logout** in the toolbar.
  The login page opens.

Logging on as an administrator after initial setup

To log on to Intelligent Queue from the server computer

1. In Internet Explorer, type `http://[your server address]/Intelligent Queue`.
   The Login window opens.
   **NOTE:** Alternatively, you can launch the application from the Start menu.
2. **After Login**, type the user name you created during initial setup.
3. **After Password**, type the password that you created during initial setup.
4. Click **OK** to launch Intelligent Queue.
Entering your purchased options

To enter your purchased options

1. After **Select the product key**, verify your Mitel Product Key matches the MOSS Options Sheet.  
   **NOTE:** Your Mitel Product Key is entered by default.
2. Using your MOSS Options Sheet, enter your Mitel Options password, the system options and the number of ports you purchased.
3. Click **Save**. If the information you entered is correct, menu items will open. The menu items correspond to your purchased options. If the information you entered is not correct, the Incorrect selection window opens.
4. If you entered incorrect information, click **OK** to return to the **Purchased Options** window to correct your entries.
5. Click **Save**.

Setting up administrator and user permissions

Only an administrator should create user accounts. First, create an administrator account with all permissions, including the Manage user accounts permission. Then, create user accounts with selected permissions.

Creating an administrator account

To create an administrator account with full permissions

1. Click **Administration=>Manage users**.
2. Type a user name and password. 
   **NOTE:** The user name and password are case sensitive.
3. Re-type the password for confirmation.
4. Click **Select all** to give the account full permissions.
   **NOTE:** Allow login and View system status are selected by default for every user.
5. Click **Save**. 
   Intelligent Queue adds the user name to the Users list.

After you create an administrator account, you can create user accounts.

Creating a user account

To create a user account with selected permissions

1. Click **Administration=>Manage users**.
2. Type a user name and password. 
   **NOTE:** The user name and password are case sensitive.
3. Re-type the password for confirmation.
4. Select the permissions you want to assign to the user account. 
   **NOTE:** Allow login and View system status are selected by default for every user. If you select Configure ports, Manage port groups will be selected by default.
5. Click **Save**. 
   Intelligent Queue adds the user name to the Users list.

Changing system modes

A user with the proper permissions can control the operating mode of Intelligent Queue. The operating mode determines incoming call handling. If the system or port group is operating in a normal state, Intelligent Queue handles the call according to its assigned call flow conditions. If the system or port group is operating in Emergency mode, the system ignores the assigned conditions and follows a special call flow.
To change system modes
1. Click Administration=>System mode.
2. Select a system mode.
   • In Normal state, port groups follow a normal call flow pattern, except for port groups that have
     been placed into an emergency call flow pattern.
     If the system mode is in Normal state, Intelligent Queue checks the port group to see if it is in an
     Emergency state.
   • In Emergency state, port groups follow an emergency call flow pattern.
     The emergency call flow is followed without checking the state of the port groups.
3. Under Normal state and Emergency state, select individual or multiple port groups, and then click
   the appropriate arrow to move your port groups between Normal and Emergency states:
   • Click >> to move all Normal state port groups into Emergency state.
   • Click > to add selected Normal state port groups into Emergency state.
   • Click < to add selected Emergency state port groups into Normal state.
   • Click << to move all Emergency state port groups into Normal state.
4. Click Save.

Changing passwords
Once logged in, any user can change their own password. However, if a user forgets their password and is
unable to log on, only an administrator can clear the password field of that user account and enable the user
to log on and change their password. Alternatively, the administrator can assign a password to the user and
enable the user to log on and change their password.

NOTE: Only users with the Manage user accounts permission can access the Manage users menu item.

To change your user password
1. Click Administration=>Change password.
   The Change password window opens. The Current user name field is populated by default.
2. Type your old password.
3. Type a new password.
4. Re-type the new password for confirmation.
5. Click Save.

If a user forgets their password and is unable to log in, they can contact an administrator to clear the password
field. The user can then log on to Intelligent Queue and create a new password. Alternatively, the
administrator can assign a password to the user. The user can log on with that password and change it to a
new password.

To clear the password field of a user account
1. Click Administration=>Manage users.
   NOTE: You must have administrator privileges, including the Manage user accounts permission, to
   access this option.
2. Under User name, type the name of a user or select a name from the list.
   The Change password button is enabled.
3. Click Change password.
4. Clear the Password field.
5. Click Save.

The user can now log on using their login name and no password. After logging on, they create a new
password for themselves in the Change password window.
Setting up the automatic database backup

NOTE: Maintenance Service must be running to perform the automatic backups.

Intelligent Queue introduces automatic database backups in Version 5.2. Besides being able to configure the interval of the backups, you can also configure the time of day at which the backup occurs, and the number of files you want Intelligent Queue to keep. The automatic backup is performed by the Maintenance Service.

The automatic backup files are kept in the Intelligent Queue installation directory, under Data\Automatic Backups directory. Unless the user changes the default installation folder, the application installs in the directory C:\Program Files\Mitel\6160. The files are named Autobackup_<day of week>, <date>.xml., for example, Autobackup_Sunday, December 24, 2006.xml.

The GlobalSettings.xml file controls when and if the automatic backup occurs. In the GlobalSettings.xml file, you will see the following <AUTOBACKUP> section.

```
<AUTOBACKUP>
  <ENABLED>true</ENABLED>
  <INTERVAL>2</INTERVAL>
  <TIMEOFDAY>3:00</TIMEOFDAY>
  <MAX_BACKUP>50</MAX_BACKUP>
</AUTOBACKUP>
```

Enabling the automatic backup

To enable the automatic backup

1. In the Intelligent Queue installation directory, under \XML\Config, locate the GlobalSettings.xml file.
2. Between the ENABLED tags, type true.

Disabling the automatic backup

To disable the automatic backup

1. In the Intelligent Queue installation directory, under \XML\Config, locate the GlobalSettings.xml file.
2. Between the ENABLED tags, type false.

Assigning the interval of the automatic backups

You can configure the interval of the backups. We recommend the default interval of every two days, but you can configure Intelligent Queue to perform backups more often or less often.

- Select 1
  Intelligent Queue will back up the database once every day.
- Select 2
  Intelligent Queue will back up the database once every two days.
- Select 3
  Intelligent Queue will back up the database once every three days, etc.

To assign the interval of the automatic backups

1. In the Intelligent Queue installation directory, under \XML\Config, locate the GlobalSettings.xml file.
2. Between the INTERVAL tags, type a number.
   The number represents the number of days between automatic backups.
Assigning the time of day of the automatic backup

**NOTE:** When assigning the time of day, you must use the 24 hour clock, for example, 22:00 represents 10:00 P.M.

To assign the time of day of the automatic backup

1. In the Intelligent Queue installation directory, under \XML\Config\, locate the GlobalSettings.xml file.
2. Between the **TIMEOFDAY** tags, type the time at which the automatic backup will occur, using the 24 hour clock.

Assigning the number of backup files to keep

**NOTE:** Intelligent Queue, by default, keeps 50 backup files. Each file represents 1 backup, so 50 files equals 50 backups. Only the most current files are kept.

To assign the number of backup files to keep

1. In the Intelligent Queue installation directory, under \XML\Config\, locate the GlobalSettings.xml file.
2. Between the **MAX_BACKUP** tags, type the number of backup files you want to keep.
   Each time you backup you produce one file.

Configuring ports

**NOTE:** If you add or remove ports after the initial installation, you need to restart the services on the System status window. See the Mitel Intelligent Queue Installation Guide or "Viewing system status" on page 463 for more information about restarting the system.

You initially configure ports outside of Intelligent Queue, which reads the registry for the PBX, extension number and port group. From within Intelligent Queue, you can add editorial comments to each port.

To configure your ports

1. Click **Configure=>Ports**.
   The Configure Ports window opens.
2. Verify the extension numbers are correct for each port.
   **NOTE:** The extension numbers must be present and correct.
3. To add a comment for a particular port, click **Edit** in the appropriate row.
   A text box opens under **Comment**. Edit is replaced by Update and Cancel.
4. Type a comment in the **Comment** text box and click **Update** to save the comment.
5. To navigate through multiple pages of listings, click **Previous** or **Next**.

Configuring PBX settings

Intelligent Queue version 5 supports multiple PBXs configured on the same system. Although your PBX settings are populated at login, you can configure each PBX on the PBX Settings window.

Manually configuring PBX settings

To manually configure your PBX settings

1. Click **Configure=>PBX settings**.
   The PBX settings window opens.
2. If the media server type is SX-200 ICP, under **SX-200 ICP**, select the check box across from the media server.
   If you have an SX-200 ICP, and do not select the check box, the Intelligent Queue system will not connect to the SX-200 ICP server.
   If you have changed to an SX-200 ICP from a different type of media server, you need to restart the services for the new setting to take effect.
   See "Viewing system status" on page 463.
3. Click **Ping** to test a PBX connection.  
The ping results open in the Results box.
4. Click **Edit** in the appropriate row to add or edit a silent monitor code, ARS digits, external digits, and a media name for a PBX.
5. Click **Update**.
6. Click **Save**.
   **NOTE:** When you save PBX settings, the Intelligent Queue services require at least 20 seconds to save your changes to the server. The length of time is based on the complexity of the call flows. You can continue working during this period.

### Configuring Contact Center Management settings

If you have installed both Contact Center Management and Client Component Pack, configure your Contact Center Management settings.

**To configure your Contact Center Management settings**

1. Click **Configure=>Contact Center Management settings**.  
The Settings tab opens.
2. After **Address**, type the host name or IP address of the Contact Center Management server.
3. After **Port**, the port of the Contact Center Management server number is shown by default.
4. Click **Ping** to test your Contact Center Management connection.
5. Click **Save** to save your IP address and port configuration.
6. To query a queue/path, under **Contact Center Management queue/path**, select a queue/path from the list box.
7. Click **Get queue statistics**.  
   Results displays the number of agents in queue.
8. Click **Refresh queue** to refresh the list box.
9. Click **Clear results** to clear the Results box.

### Configuring Music Manager

Intelligent Queue uses Music Manager to upload music files and configure playlists from those files. Music Manager plays a continuous loop of the playlist in the background of Intelligent Queue. The music in a playlist is what callers hear when they are on hold. After callers hear a message, Intelligent Queue places them in a queue where they hear the playlist until an agent answers the telephone. The playlist can contain CD songs, MP3 files and/or .wav files. The play list can include music or pre-recorded information messages.

**To create a playlist**

1. Click **Configure=>Music Manager**.  
The Play List tab opens.
2. After **Media type**, select a file type.
3. To add a track to the playlist, select one of more tracks from the list box and click >.
   **NOTE:** You can select multiple files by holding down the **Ctrl** key while selecting files. To select a range of files, hold down the **Shift** key, select the file at the top of the range and then select the file at the bottom of the range. All files in between will be selected.
4. Repeat steps 2 and 3 to add other media types to the playlist.
   **NOTE:** Within the Windows environment, you can also copy multiple music files into the music folder.  
   If you accepted the default settings during installation, the default path name to your music folder is Program Files\Mitel Networks\Intelligent Queue\Music
5. To navigate through the playlist, click **Previous** or **Next**.
6. To delete a file from the playlist, click **Remove** beside the track name you wish to delete.
7. Click the **Upload files** tab to select files to upload to the server.
8. Click **Browse** to navigate to a file you want to upload.
9. Click **Add** to add the file to the Upload file list.
10. If you want to remove a file you added to the list, click Remove.
11. If you want to remove all files you added to the list, click Remove all.
12. To save the list of files to the server, click Upload.
13. Click the Volume tab to adjust the volume of music on hold.
14. For each volume level type, click the appropriate radio button (10 is loudest) under each level. To mute a sound type, select Mute beneath the appropriate volume level.
   NOTE: The Master volume level increases/decreases the system volume. When you adjust the volume of music on hold, you are also adjusting the server volume.

**Disabling Windows sounds**

Windows sounds play through the music on the playlist. If you use the Intelligent Queue server as a music on hold source, you must disable these sounds.

To disable Windows sounds

1. Click Start=>Settings=>Control Panel. The Control Panel window opens.
2. Double-click Sounds and Multimedia.
3. Click the Sounds tab.
4. Under Scheme, click No Sounds.
5. Click Apply.
6. Click OK.

**Preventing CDs from starting automatically**

You do not want your CD-ROM to start automatically, because if you insert a CD while music on hold is on, the caller will hear both the music from the playlist and music from the CD. You must alter the registry to disable the AutoRun feature.

To disable the AutoRun feature

1. In the registry, navigate to
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom.
2. Set the AutoRun value to 0.

In addition, you can manually prevent a CD from running by pressing the Shift key when you close the CD tray.

**Removing a music file from the play list**

To remove a music file from the play list

1. Click Configure=>Music Manager. The Play List tab opens.
2. Under Play List, select the music file(s) you want to remove from the playlist.
3. Click Remove to remove the selected files from the playlist. Click Remove all to clear the entire playlist.
Adjusting music volume

You can adjust the volume of the .wav or MP3 message files, the volume of the CD, or the system volume level.

To adjust the music volume

1. Click Configure=>Music Manager.
   The Play List tab opens.
2. Click the Volume tab.
   The Volume window opens.
3. For each volume type, click the appropriate radio button (10 is loudest) to set the volume level. To mute a sound type, select Mute beneath the appropriate volume level.
   NOTE: The Master volume level increases/decreases the system volume. When you adjust the volume of music on hold, you are also adjusting the server volume.

Configuring Updated position in queue

CAUTION:

• In order to use Updated position in queue, you must enable all HCI options on Class of Service Assignment form 1 (COS 1). See "Appendix A 3300 ICP port configuration" in the Intelligent Queue Installation Guide.

• Updated position in queue messages for the queue must be programmed to play less frequently than RAD messages for the queue, otherwise, the RAD messages will not play. The Updated position in queue message frequency is configured in Intelligent Queue. Click Configure=>Updated position in queue. The RAD message frequency is programmed on the switch. See “Receiving an Updated position in queue message” on page 496.

• In a multi-PBX scenario, a queue will play Updated position in queue messages only when the port group and the queues are on the same PBX. For example: PBX A has both Port Group 1 and Queue 1. PBX B has no port group but has Queue 2. You can play Updated position in queue messages on Queue 1. You cannot play Updated position in queue messages on Queue 2 because no ports are available. You must add an Updated position in queue port group to PBX B, restart the system from the Intelligent Queue Status>System Status page, and then create an Updated position in queue port group for PBX B.

Updated position in queue definitions:

Available queues
Available queues are all of the queues in your contact center. All queues are programmed in Contact Center Management. See “Configuring Contact Center Management settings” on page 433.

Monitored queues
Monitored queues are the queues for which callers will receive updated position messages.

Disabled
Selecting Disabled prevents the callers from receiving the updated position message.

Do not inform callers if their positions in queue drop
If a caller’s position in queue drops, because higher priority callers arrive in queue, do not inform the caller. The caller will continue to hear the highest position obtained. For example, a caller who was third in queue, who dropped to seventh in queue, will continue to hear “You are caller number three.”

Initial delay to update callers in queue
Initial delay to update caller in queue is the duration between when callers arrived in queue and when they are informed of their queue position. For example, if you configure five seconds, Intelligent Queue informs callers of their initial position five seconds after they arrive in queue.
Frequency to update callers in queue
Frequency to update callers in queue is the duration after the start of the previous message, when callers are informed of their updated positions. For example, if you configure two minutes, Intelligent Queue informs callers of their updated positions every two minutes. The initial update occurs two minutes after the start of the previous message.

Maximum position to report
Maximum position to report is the number of callers who will receive the updated position message.

Default message plan for positions
The default message plan is the plan used to inform callers of their position in queue. For example, "You are in position five."

Before you configure Updated position in queue messages
Before you can configure an Updated position in queue message, you must
• Ensure you are connected to Contact Center Management. The connection to Contact Center Management provides Intelligent Queue with real-time data. When you are connected the list of queues is available on the Updated position window. (Configure=>Updated position in queue.) See “Configuring Contact Center Management settings” on page 433.
• Ensure a media server, site, and Updated position in queue are configured in Contact Center Management. To create a media server, site, and queue, see the YourSite chapter of the Mitel Contact Center Solutions User Guide.
• Configure telephone system settings. Updated position in queue functionality is dependent on the information provided by Contact Center Management, so you must ensure you are pointing to the correct PBX. For example, if the media server in Contact Center Management is named “London” not 10.1.1.123, you need to ensure the PBX Intelligent Queue is pointing to is “London” and not 10.1.1.123. See “Configuring PBX settings” on page 432.
• Create a Updated position in queue port group. An Updated position in queue port group must be configured on the media server on which the queue resides. For example, if the updated position in queue is on 10.1.1.123, you need to create an Updated position in queue port group on 10.1.1.123 as well, and assign ports to it. See “Managing port groups: updated position in queue, messaging, callback, and recording ports” on page 461.

Configuring Updated position in queue for all queue positions
To configure an Updated position in queue message for all queue positions
1. Click Configure=>Updated position in queue.
2. After Available queues, select a queue from the list for which you want to provide callers with updated positions in queue.
3. Click Add. The queue will open under Monitored queues.
4. After Monitored Queues, if you have selected more than one queue, drag the queues to arrange them by priority, the top queue being the highest priority queue.
5. Select the queue for which you want to provide an updated position message.
6. After Initial delay to update callers in queue, select the number of minutes/seconds after which the caller arrives in queue, before the caller is informed of his position. For example, you can configure Intelligent Queue to inform callers of their position five seconds after they arrive in queue.
7. After **Frequency to update callers in queue**, select the number of minutes/seconds after the start of the previous message, that callers will hear their updated position. For example, you can configure Intelligent Queue to inform callers of their updated positions every two minutes. The initial update occurs two minutes after the start of the previous message.

8. After **Default message plan for positions**, select the message plan, previously configured, to use as the updated position message. For example, “You are in position five.” Intelligent Queue Updated position in queue will provide the position but will not provide the message. If you want the callers in queue to hear a messages, for example, “Your call will be answered next” or “You are in position...” you must record the message.

   See “Recording voice prompts” on page 478.

9. After **Maximum position to report**, type the number of callers in each queue who will receive the updates.

10. Click **Save**.

After you have configured a default message that will play to all queues, you can optionally configure a unique message for specific queue positions.

**Configuring Updated position in queue for specific queue positions**

To configure an Updated position in queue message for specific queue positions

1. Click **Configure=>Updated position in queue**.
2. Click the **View and edit individual positions** tab.
3. Select the position. For example, select Position 1.
4. Click **Edit**.
   The default message, configured on the Settings tab, is displayed. You must edit the message plan to add the message you want to play for specific queue positions.
   Intelligent Queue Updated position in queue will provide the position but will not provide the message. If you want the callers in queue to hear a messages, for example, “Your call will be answered next” or “You are in position...” you must record the message.
   See “Recording voice prompts” on page 478.
5. Under **Range programming**, after **Assign the following message plan**, select the message plan.
6. After **from the positions**, select the position with the highest priority for which the message will be played.
7. After **to**, select the position with the lowest priority for which the message will be played.
   If the message is unique to just one position, then select the same position twice. For example, if the message “Your call will be answered next” is unique to the position in priority one, then select “from the positions 1 to 1 inclusive.”
8. Click **Save**.

**Creating action plans**

An action plan is a set of call handling instructions that defines how to manage a specific call. An action plan begins upon selection and carries a call for the duration of its existence within Intelligent Queue. This section details how to configure the following types of action plans:

- Unverified collected digits
- Verified collected digits
- Interactive tree
- Messaging
- Emergency messaging
- Management
- Routing

**NOTE:** When you save an action plan, the Intelligent Queue services require at least 20 seconds to save your changes to the server. The length of time depends on the complexity of the call flows in the action plan. You can continue working during this period.
Creating unverified collected digits plans

You can use the unverified collected digits plan in conjunction with Contact Center Screen Pop only. Digits are collected by Intelligent Queue and transferred to Contact Center Screen Pop to process.

The unverified collected digits option prompts the caller to enter a digit string, such as an account number. The account number is sent to the desktop PC of the ACD agent who eventually answers the call. The number of digits can be predefined or can be terminated by a digit, such as #, or by a predefined duration of silence.

To create an unverified collected digits plan

1. Click Manage=>Actions=>Unverified collected digits.
2. Under Plan Name, type a new plan name or select an existing plan.
3. After Greeting message, select a greeting message from the list box.
4. After Terminating digit, type a digit the caller can press to indicate they have no more digits to enter. The terminating digit is optional.
5. Type the maximum number of digits to be collected.
6. After No digit timeout, type the number of seconds the caller has between DTMF digit keypresses before the system times out.
7. Click Save.
8. Click the Action to take tab.
9. After Digits collected, select an action to take if digits are successfully collected.
   • If you click None, control will return to the call flow.
     If the collect digits plan was invoked from an interactive tree, the menu is played. If the collect digits plan was assigned as the action, the call hangs up.
   • If you click Action, select an action plan type (message, routing, or interactive tree) and then select an action plan from the list box.
     The selected action plan will be followed if digits are successfully collected.
10. After No digits collected, select an action to take if digits are not collected.
    • If you click None, control will return to the call flow.
     If the collect digits plan was invoked from an interactive tree, the menu is played. If the collect digits plan was assigned as the action, the call hangs up.
    • If you click Action, select an action plan type (message, routing, or interactive tree) and then select an action plan from the list box.
     The selected action plan will be followed if digits are successfully collected.
11. Click Save to save your configuration, or click New to clear the fields and create a new unverified collected digits plan.

To delete an unverified collected digits plan

1. Click Manage=>Actions=>Unverified collected digits.
2. Under Plans, select a plan.
3. Click Delete.

NOTE: A confirmation dialog box will ask you to confirm before deleting an unverified collected digits plan. If you try to delete an unverified collected digits plan with associated plans, a more detailed confirmation box will open that allows you to view the associated plans before you can proceed with the deletion. Deleting the selected plan will only remove the reference to the associated plans.
Creating verified collected digits plans

NOTE: Intelligent Queue cannot read words. For Verified collected digits action plans, you must use string values that represent numbers. (String values are numbers that are not mathematically manipulated.) Ensure that all columns included in your SQL statement are string type columns. If you do not use string type columns, the query will not run successfully. The readback values must also be strings, between -999,999.999 and 999,999.999.

Intelligent Queue can respond to callers' inquiries in one of four ways: produce an action based on a true response, produce an action based on a false response, send the caller to a dialable number, or read back digits/values.

After customers press telephone digits, Intelligent Queue can read back the digits and read values accessed from a database in all supported language (US English, UK English, NA French, EU French, EU Spanish, LA Spanish, or Dutch). Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in all languages, are provided in US English and UK English only. You must record your own .wav files if you want them in additional languages.

Digit read back
If you want your customers to hear a number one digit at a time, Intelligent Queue now gives you that option. Generally, digit read back is preferred for phone numbers and account numbers. Instead of reading back “nine hundred eighty-seven,” Intelligent Queue digit read back states “nine, eight, seven.” Digit read back is available in all supported languages.

Digit read back for verification
With an advanced verified collected digits query, Intelligent Queue verifies the digits customers press. For example, after pressing the digits of an extension, customers will hear “You have entered nine, eight, seven.” You can configure Intelligent Queue to permit customers to change their digit selection after read back.

Database value read back
Intelligent Queue, using the verified collected digits action plan, compares digits customers press to a list in a database. For example, you create a database table that contains two columns: the customers’ account numbers and the customers’ bank balances. Next you create a verified collected digits action plan that collects the account numbers. The advanced query first checks the account numbers column. If the account numbers column contains the digits pressed, the query checks the account balance for that row and Intelligent Queue will audibly state the customer’s account balance. “Your account balance is nine hundred eighty-seven.”

Previously collected digits
With Previously collected digits, customers dial the requested digits just once, but can perform many actions that depend on the digits. For example, customers who provide a bank account number once can perform many future actions which depend upon that account number, without having to reenter the account number again.

You can create a verified collected digits plan in four steps:

1. Select the type of collected digits
2. Configure ODBC database parameters
3. Select an action to take

Before you create a verified collected digits plan, you must create an ODBC (Open Database Connectivity) connection to a valid data source.
Creating ODBC connections

When you create a verified collected digits plan, you specify a data source against which Intelligent Queue compares the collected digits. To connect to a data source, you must first create an ODBC connection. Intelligent Queue officially supports three data source formats:

• SQL Server
• Microsoft Access
• Microsoft Excel

Creating an ODBC connection for SQL Server

To create an ODBC connection for SQL Server

1. Click Start=>Control Panel.
2. Double-click Administrative Tools.
3. Double-click Data Sources (ODBC).
   The ODBC Data Source Administrator window opens.
4. Click the System DSN tab.
5. Click Add.
   The Create New Data Source window opens.
6. Select SQL Server and click Finish.
   The Create a New Data Source to SQL Server window opens.
7. Specify your ODBC data source information and click Next.
   Your SQL Server can be local or remote.
8. Click With SQL Server authentication using a login ID and password entered by the user.
9. Verify the Login ID and Password are valid for the database you selected in the previous window.
10. Click Next.
11. Check Change the default database to and select a database from the list.
12. Click Next.
13. Click Finish.
14. If you want to test your ODBC connection, click Test Data Source. Otherwise, click OK to complete the ODBC setup.
   The ODBC connection is now available on the System DNS tab.
   NOTE: It is highly recommended you test the ODBC connection before using it with Intelligent Queue.

Creating an ODBC connection for Microsoft Access

To create an ODBC connection for Microsoft Access

1. Click Start=>Control Panel.
2. Double-click Administrative Tools.
3. Double-click Data Sources (ODBC).
   The ODBC Data Source Administrator window opens.
4. Click the System DSN tab.
5. Click Add.
   The Create New Data Source window opens.
7. Click Finish.
   The ODBC Microsoft Access Setup window opens.
8. Specify a data source name.
9. Click Select.
10. Browse to the Access database you want to use and click OK.
11. Click OK to complete the ODBC setup.
Creating an ODBC connection for Microsoft Excel
If you use Microsoft Excel as your data source, you need to specify which section of the spreadsheet will be used as the database “table.”

To format a spreadsheet for use with Intelligent Queue
1. Open the spreadsheet you want to format.
2. Highlight the region of the spreadsheet you want to define as a table.
   NOTE: The first row in the region must be the column names.
3. Click `Insert=>Name=>Define`.
   The Define Name window opens.
4. Type the name for the region you highlighted.
   The name you type is the database table name of the region.
5. Click `OK`.

To create an ODBC connection for Microsoft Excel
NOTE: If the IQ server is not on the same Active Directory as the computer hosting the excel file, the ODBC connection will be invalid.
1. Click `Start=>Control Panel`.
2. Double-click `Administrative Tools`.
3. Double-click `Data Sources (ODBC)`.
   The ODBC Data Source Administrator window opens.
4. Click the `System DSN` tab.
5. Click `Add`.
   The Create New Data Source window opens.
6. Select `Microsoft Excel Driver`.
7. Click `Finish`.
   The ODBC Microsoft Excel Setup window opens.
8. Specify a data source name.
9. Click `Select Workbook`.
10. Browse to the Excel document you want to use and click `OK`.
11. Click `OK` to complete the ODBC setup.

Selecting the type of collected digits
The Parameters tab specifies the type of digits you will be collecting: ANI, DNIS, a user-entered digit string, or a previously collected digit string. If you select ANI or DNIS, Intelligent Queue will automatically collect these digits from the call detail information.

With a Previously collected digit string, customers dial the requested digits just once, but can perform many actions that depend on the digits. For example, customers who provide a bank account number once can perform many future actions which depend upon that account number, without having to reenter the account number again.

To select the type of collected digits
1. Click `Manage=>Actions=>Verified collected digits`.
   The Verified collected digits window and the Parameters tab opens.
2. Under `Plan name`, type a new plan name or select an existing verified collected digits plan from `Plans`.
3. If you want to collect the digits of the telephone number of the caller, select `ANI`.
4. If you want to collect the digits of the telephone number the caller dialed, select `DNIS`.
5. If you want to prompt the user to type a digit string, select `User collected digits`, or if you want to use digits the user already typed, select `Previously Collected Digits`.
NOTE: You can program one type of message to follow another type of message. For example, you can team the confirmation and the instruction message, so that Intelligent Queue reads back the digits dialed by the caller, and then gives the caller the option to continue by pressing 1, or to correct the digits dialed by pressing STAR.

Configure the following options:

- **Greeting message**
  Select a message that prompts the user to enter digits.

- **Confirmation message**
  Select a message that confirms the digits dialed, for example, “You have entered...”

- **Instruction message**
  Select a message that instructs the customer to dial digits, for example, “Press 1 to confirm, STAR to retry.” The caller gets a preset number of attempts to retry after which, an error message plays and Intelligent Queue moves the call to the fail path.

- **Terminating digit**
  Type a digit the caller can press to indicate they have no more digits to enter

- **Maximum digits to be collected**
  Type the maximum number of digits to be collected for the digit string.

- **No digit timeout (seconds)**
  Type the number of seconds the caller has between DTMF digit keypresses before the system times out.

- **Number of attempts**
  Type the number of attempts to press a valid digit a caller is allowed before Intelligent Queue moves the call to the fail path.

- **Timeout message**
  Select a message that plays if a user does not press a digit within the time you specified in the No digit timeout option.

- **Message to be played before retrying**
  Select a message that plays before the caller retries pressing digits.

- **Error message**
  Select a message that plays when the caller fails to enter a valid digit string within the maximum number of attempts.

6. Click **Save**.

**Readback parameters**

The Readback Parameters tab specifies Verified Collected Digits readback information.

NOTE:

- Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in all languages, are provided in US English and UK English only. You must record your own .wav files if you want them in additional languages.
  See “Recording voice prompts” on page 478.

- To view a list of readback .wav file names, such as Dollars.wav, see “Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in all languages, are provided in US English and UK English only. You must record your own .wav files if you want them in additional languages. The files are located in the following directory: %Voice%/language\System%. There are ten language folders: US English, UK English, NA French, EU French, EU Spanish, LA Spanish, Dutch, Brazilian Portuguese, Simplified Mandarin Chinese, and Italian. See “Recording voice prompts” on page 478. (See Table 17-10).” on page 479. The files are located in the following directory: %Voice%/language\System%. There are seven language folders: US English, UK English, NA French, EU French, EU Spanish, LA Spanish, and Dutch.
To select the type of collected digits

1. Click **Manage => Actions => Verified collected digits**.
   Select the Readback Parameters tab.
2. Configure the following options:
   - **Readback language**
     Select the language Intelligent Queue uses to respond to customer queries.
   - **Gender of the word following the number**
     If the message will be in a language where numbers can be either feminine or masculine, select the appropriate gender of the number, depending on the word following the number. The word following the number will be the readback variable unless you have selected “Number” as the readback variable.
   - **Readback variable**
     Select the readback variable, such as dollar, euro, pound, number (for example the amount “nine hundred, eighty-seven”), or digit (for example, the account number “nine, eight, seven”).
   - **Response message**
     Select a message that is a response to the customers request, for example, “Your account balance is...”
   - **Response instruction message**
     Select a message that both provides a response to the customer’s request and instructs the customer to dial digits, for example “Press 1 to confirm. Press STAR to retry.”
3. Click **Save**.

**Configuring ODBC database parameters**

The ODBC Parameters tab specifies the database used in the collected digits verification and the parameters used to define the query.

Intelligent Queue enables you to verify the collected digits using either a simple or an advanced query. The simple query configuration prompts you for a database table and column. Intelligent Queue automatically creates a query based on this information that compares the collected digits to all the values in the column.

An advanced query configuration requires you to write your own query using SQL. An advanced query is more complicated to configure than the simple query but it provides more options when evaluating collected digits.

**NOTE:** The collected digits are saved as strings so the values you compare them against must also be strings. Verify that any columns included in your SQL statement are string type columns. If you do not use string type columns, the query will not run successfully. There are workarounds to this, particularly with the advanced query, but we recommend you use string values to avoid errors.

**Configuring a simple query**

For an action plan with a simple query, you enter a database table name, a column name, and optionally, a readback column name. After Intelligent Queue receives a collected digit string, it compares the value with all the values in the database column. If the value exists anywhere in the column, the query returns a value of **True** and the appropriate action follows, as selected in the **Query returned true** section on the **Action to take** tab. If the value does not exist, the query returns a value of **False**, and the action selected in the **Query returned false** section of the **Action to take** tab follows.

To configure a simple query

1. In the **Verified collected digits** window, select the **ODBC Parameters** tab.
2. After **ODBC Database system DSN**, select the data source you want to use to verify the collected digits.
   **NOTE:** The data source must be on the same domain/work group as the Intelligent Queue server.
3. Type a valid user name and password for the data source you selected.
4. After **Query type**, select **Simple**.
5. **After Database table name**, select the database table that contains the data you want to use to verify the collected digits.
   For example, select the table that has all of the bank account information.

6. **After Database column name**, select the column in the selected table that contains the data you want to use to verify the collected digits.
   For example, select the column that has the bank account numbers.
   **NOTE:** The database column type must be a string type column.

7. **After Read Back Column Name**, which is optional, you can select the column in the selected table that contains the data you want the system to read back.
   For example, Intelligent Queue uses the system prompts to audibly state the bank account balance.
   **NOTE:** If you have selected a Confirmation Message or an Instruction Message on the Parameters tab, and you then leave the Database Read Back Column Name blank, Intelligent Queue will audibly state the digits dialed by the caller, for example, the bank account number. If you have not selected a Confirmation Message or an Instruction Message on the Parameters tab, and you leave the Database Read Back Column Name blank, Intelligent Queue will not read back anything.

8. **After Test with (ANI/DNIS/User collected digits) equal to**, you can type a value to use in a test query of your table and column name options.
   **CAUTION:** You should test the query before you save the plan. If the query is not valid, the call defaults to the False path on the Action to take tab.

9. If you want to test your database configuration options, click **Test query**.
   If the value you typed in Test with does not exist in the database, or the database information is incorrect, the query returns a False value.

10. Click **Save**.

**Configuring an advanced query**

An action plan with an advanced query gives you more flexibility in verifying digits, but it also requires that you have a working knowledge of SQL. In addition to returning string values of **True** or **False**, the advanced query can return a value that consists of a string of numbers or symbols (0-9,#,*) one to seven characters in length. This string defines a transfer destination for the call.

The advanced query can also return a second piece of information in addition to True, False, or Dialable Number. Returning extra information with the result set allows supervisors and agents to view this information in the Contact Center Client software before the call is answered. Attaching Collected Information to the call is done by populating the second column of the result set with a string containing the prefix "PFCOLLECTED INFO|" followed by the information you want to associate with the call.

**Example 1: Blind Transfer**

The following example illustrates the benefit of using an advanced query instead of a simple query. Suppose your company has several important customers that you want to route to a high priority queue whenever they call your contact center. You would also like to add their warranty status to the call. You create a database table that contains a column with the customer’s telephone number (ANI column), a column with the customer’s warranty status, and a column that contains a queue number (Queue column).

Next, you create a verified collected digits action plan that collects the ANI digits (the telephone number of the caller) of a call. With a simple query, you can only determine whether the collected digits exist (**True**) in the ANI column or not (**False**).
With an advanced query, you have another option. The advanced query first checks the ANI column to determine whether the collected digits exist or not. If the value exists, the query checks the Queue column in that row. If the Queue column contains a number, the query returns that value as well as the warranty status and the call is immediately transferred (a blind transfer) to that queue. Using Interactive Visual Queue the supervisors are able to see the warranty status under the Collected Info column. Based on this information the supervisor could reroute the call to a sales queue if the warranty status is set to Expired. Upon receiving the call the agent is able to see the warranty status in the screen pop of Contact Center PhoneSet Manager or Contact Center Softphone before answering the call. Intelligent Queue handles return values of True or False the same way it does with the simple query, by consulting the Action to take tab.

Please note that this is just one example of how you can use advanced query. As long as your query returns a true, false, or string value, the SQL statement can be as simple or complex as you want.

Example 2: Readback

Confirm the callers input in any language supported by Intelligent Queue

With an advanced verified collected digits query, Intelligent Queue can now verify the digits customers press, and give customers the option to subsequently adjust their digit selection. For example, after pressing the digits of an extension, customers will hear “You have entered 1234.” After readback, if customers want to change their selection, they may.

Read back a value returned by the database query

Suppose you want your customers to be able to check their bank balances without needing to talk to a person. You create a database table that contains two columns: the customer’s account number and the customer’s bank balance. Next you create a verified collected digits action plan that collects the account number. The advanced query first checks the account number column. If the account number column contains the digits dialed, the query checks the account balance for that row. Intelligent Queue, using the system prompts, will audibly state the customer’s account balance.

NOTE: The verified collected digits action plan can only query a string value that represents a positive integer. It cannot read words, or complex numbers. It can read decimal numbers in a two query process by using the previously collected digits input method. Verify that all columns included in your SQL statement are string type columns. If you do not use string type columns, the query will not run successfully. The return values must also be strings. The four possible return values are True, False, the read back value, or a dialable number.

To configure an advanced query

1. In the Verified collected digits window, select the ODBC Parameters tab.
2. After ODBC Database system DSN, select the database you want to use to verify the collected digits.
3. Type a valid user name and password for the database you selected.
4. After Query type, select Advanced.
5. After Action, select Blind Transfer or Read Back.
   If you want the call to be immediately transferred to the extension dialed, you select Blind Transfer.
   If you want Intelligent Queue to read the digits in the database, you select Read Back.
6. After Define your query, type an SQL statement that compares the collected digit value to a database value.
   NOTE: You can click Insert the variable as a shortcut when typing the full variable name in the text box.
7. If you want to test your database configuration options, click Test query.
8. After Test with (ANI/DNIS/User collected digits) equal to, you can type a value to use in a test query of your SQL statement.
   CAUTION: You should test the query before you save the plan. If the query is not valid, the call defaults to the False path on the Action to take tab.
9. If you want to test your database configuration options, click Test query.
   If the value you typed in Test with does not exist in the database, or the database information is incorrect, the query returns a False value.
10. Click Save.
Selecting an action to take

The Action to take tab specifies the type of action or subcondition the verified collected digits action plan follows, based on whether the query returns a string value of True or False.

To select an action

1. In the Verified collected digits window, select the Action to take tab.
2. After Query returned true, select an action to take if the digits pass verification.
   - If you select None, control will return to the call flow.
   - If you select Action, select an action type and then select an action plan from the list box.
     The selected action plan will be followed if the digits are successfully verified.
   - If you select Condition, select a condition type and then select a condition plan for the list box.
     The selected condition plan will be followed if the digits are successfully verified.
3. After Query returned false, select an action to take if the digits fail verification.
   - If you select None, control will return to the call flow.
   - If you select Action, select an action type and then select an action plan from the list box.
     The selected action plan will be followed if the digits fail verification.
   - If you select Condition, select a condition type and then select a condition plan for the list box.
     The selected condition plan will be followed if the digits fail verification.
4. Click Save.

Writing advanced queries

This section includes two examples of SQL queries you can use with advanced query on the ODBC Parameters tab. In each example, $USER_COLLECTED_DIGITS refers to the digits Intelligent Queue collected.

Query that dials the customer’s phone number

SELECT PhoneNumber FROM Customer WHERE ID = $USER_COLLECTED_DIGITS

Intelligent Queue collects a customer ID, runs the query, and if the customer ID is found, that customer’s phone number is dialed. If the customer does not exist, the query returns a value of ‘False.’

Query, within more than one table, with only one possible return value and Collected Information


Intelligent Queue collects a customer ID. The query searched both Employee and Customer tables. If the Customer ID exists on the Customer table, and that customer’s EmployeeID exists on the Employee table, the employee’s extension is dialed.

Creating interactive tree plans

Interactive trees are reusable sets of choices and functions that you present to a caller in order to help them find the information or functionality for which they are searching. Intelligent Queue plays menus for callers, who then make their selection using the telephone’s DTMF keypad. As of Intelligent Queue Version 5.2, an interactive tree can be assigned to multiple actions, conditions, and other interactive trees. Previously, you could assign multiple actions only.

The Answer Menu is the main menu and offers callers their starting choices. Each digit from a menu (0-9, *, #) can be defined as an option.
DTMF options
Intelligent Queue includes the following DTMF options.

Callback Action
This option activates a predefined voice callback action plan. After the callback plan completes, the call is terminated.

Unverified Collect Digits Action
This option prompts the caller to enter a digit string, such as an account number. The system sends this number to the ACD agent who answers the call, resulting in a screen pop on a desktop application. The number of digits can be predefined or can be terminated by a digit (such as #) or a predefined duration of silence.

Go To (another DTMF option) Action
This option takes the caller to a predefined location (DTMF option) elsewhere in the tree.

Management Action
This option activates a Manage system action plan. This choice is a hidden option reserved for administrators and is not typically advertised in the menu greeting. Once the caller selects this option, the same password rules apply as in a Manage system action plan.

Play Message Action
This option plays a predefined information message (.wav file), and then the caller returns to the menu from which the choice was made.

Replay Greeting Action
This option replays the previous menu greeting.

Submenu Action
This option plays a new menu for callers, giving them more choices (DTMF options) defined by the digits 0-9, *, and #. An interactive tree can have an unlimited number of submenus. Each menu has a defined "no-digit" action that the call performs if the caller fails to press a digit. Each menu has an invalid digit action that the call performs if the caller presses an undefined digit. The menu also defines how many attempts to press a valid digit are allowed before the "no digit" or invalid digit actions are taken.

Transfer Action
This option defines a routing plan that plays a greeting for the caller and then blind transfers the call to a predefined destination.

Verified Collected Digits Action
The verified collected digits plan is similar to the unverified collected digits plan since both plans can prompt the user to enter a digit string, such as an account number. The verified collected digits plan can also collect the ANI or DNIS from an incoming call. The verified collected digits plan then compares the collected digits to a list in a database. You can configure the plan to take one action if the value exists in the database and another action if the value does not exist.

ANI Condition
The system compares a callers's telephone number to a list (ANI map) of telephone numbers or digit patterns. If a match is detected, the defined action plan or subcondition is applied.

DNIS Condition
The number that is presented to the telephone system as the dialed digits can be used as a condition.
Queue Condition

- **Number of calls in queue** If you have Contact Center Management, you can use the total number of calls waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port, as a condition for applying an action plan to a call. The system queries Contact Center Management at decision time to determine the current queue conditions.

- **Queue waiting times** If you have Contact Center Management, you can use the longest amount of time that a caller has been waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port, as a condition for applying an action plan to a call. The system queries Contact Center Management at decision time to determine the current queue conditions.

Redirect Condition

If applicable, the original destination of the call can be used as a condition for determining the action plan. The original destination is the number from which the call was diverted, forwarded, or transferred (unsupervised transfers). For ACD interflow, this device is the ACD path from where the call came.

Schedule Condition

- **Day of the year** Any specific date can be defined as a condition. You can apply a subcondition, such as time of day, to make the condition more specific.

- **Day of the week** Any specific day of the week can be defined as a condition. You can apply a subcondition, such as time of day, to make the condition more specific.

- **Time of day** A specific time period can be defined as a condition. You can specify the start and end times for which the condition is valid.

Emergency Condition

The current operating mode of the system or of a port group can be either Normal or Emergency. An Intelligent Queue administrator can place the call flows in Emergency mode to force all calls on a port to use a predefined Emergency action plan. This would typically be due to an unforeseen temporary closure of a contact center, as in the case of a natural disaster.

Interactive Tree

Interactive trees are reusable sets of choices and functions that you present to a caller in order to help them find the information or functionality for which they are searching. Intelligent Queue plays menus for callers, who then make their selection using the telephone's DTMF keypad. As of Intelligent Queue Version 5.2, an interactive tree can be assigned to multiple actions, conditions, and other interactive trees.

Creating interactive trees

Creating an interactive tree involves the following steps.

1. Plan your interactive tree.
2. Associate a DTMF action with each digit that you plan to use in your main menu and any submenus you create.
3. Select each DTMF action in the Interactive Tree, configure it, and then save your DTMF options.
   **NOTE:** Save the DTMF option for each DTMF. Once you save the tree, make sure there are no red DTMF options left to configure. Unconfigured options are displayed in red. Configured options are displayed in black.
4. Save the interactive tree plan.

To create an Interactive Tree

1. Plan your interactive tree according to your needs.
2. Select **Manage=>Actions=>Interactive Tree**.
   The **Construct a Tree** tab opens by default.
   **NOTE:** When DTMF options are created, the **Configure DTMF Option** tab opens automatically. To return to the **Construct a Tree** tab, click the main **Answer Menu** or any submenus in the tree and then click the **Construct a Tree** tab.
3. In the **Plan Name** field, create a relevant plan name. This field is required before you can continue.
4. Build your tree structure by clicking on the corresponding drop-down box beside each digit and selecting one of the following actions/conditions/interactive tree for each DTMF digit.
5. Continue to assign actions to each telephone digit in any sub menus you create. 
   **NOTE:** DTMF Actions which have yet to be configured are displayed in red. Configured DTMF Actions are displayed in black.

6. After you create your tree structure, click **Answer (Main Menu)** and configure the options that will govern the menu. 
   The Configure DTMF Option tab opens. See Figure 17-1.

**Figure 17-1 Configure DTMF Options tab**
7. To rename the **Answer (Main Menu)** DTMF Option, type a new name under **DTMF Option Details**.
8. Click **Save DTMF Option** after configuring each option.
   See Table 17-2.

**Table 17-2: DTMF options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Action Taken</th>
</tr>
</thead>
<tbody>
<tr>
<td>Greeting</td>
<td>Plays the main greeting when a call is received.</td>
</tr>
<tr>
<td># of attempts</td>
<td>Defines the number of attempts to press the correct digit a caller is allowed before one of the following actions is taken by Intelligent Queue:</td>
</tr>
<tr>
<td></td>
<td>Error message is played</td>
</tr>
<tr>
<td></td>
<td>(if the Error message option is selected)</td>
</tr>
<tr>
<td></td>
<td>Call is transferred;</td>
</tr>
<tr>
<td></td>
<td>(if the Transfer call option is selected)</td>
</tr>
<tr>
<td></td>
<td>System hangs up.</td>
</tr>
<tr>
<td></td>
<td>(if Hang up is selected by default)</td>
</tr>
<tr>
<td>Timeout (seconds)</td>
<td>Defines the length of time the system will wait for a DTMF response before timing out.</td>
</tr>
<tr>
<td>No digit</td>
<td>Plays a message that no digit has been entered.</td>
</tr>
<tr>
<td>Invalid digit</td>
<td>Plays a message that an invalid digit has been entered.</td>
</tr>
<tr>
<td>Error message</td>
<td>Plays a message when the number of attempts exceeds the limit set in the <strong># of attempts</strong> option.</td>
</tr>
<tr>
<td>Force greeting</td>
<td>Forces the caller to listen to the greeting before the caller can transfer to a selection offered on the menu.</td>
</tr>
</tbody>
</table>

10. If you select **# of attempts** and **Timeout**, you can accept the default values or specify your own. **NOTE:** The # of attempts and Timeout fields are required for the interactive tree to function properly.
11. If you select **Transfer call**, Hang up is the default setting. **NOTE:** The Transfer call option will be executed only if selected and if the number of attempts has been exceeded.
12. After you configure the **Answer (Main Menu)** **DTMF Option Details**, click **Save DTMF Option**.
13. Continue to configure each of the following options under the **Answer (Main Menu)** and any submenus you’ve created: Callback, Collect Digits, Go To, Management, Play Message, Replay Greeting, Sub Menu, and Transfer.
14. To change the name of a DTMF option, type a new name in the text field.
15. Remember to click **Save DTMF Option** after configuring each DTMF Option.
16. Click **Save** once again to save the tree structure.

**Setting up messaging plans**

Intelligent Queue answers a call and plays a predefined .wav file. Messages can be prerecorded phrases (static), or messages that are made up of a set of concatenated phrases (dynamic). Dynamic messages deliver queue statistics and are usually combined with static messages.

**NOTE:** You set up messaging plans before you set up management plans.
To create a message plan

1. Click Manage=>Actions=>Message.
   The Create Message Plan tab opens.
2. Click New.
3. Under Plan Name, type a unique plan name.
4. After Select a folder, select the language of the message you want to create.
5. After Pre-recorded phrase, select a pre-recorded phrase and click Insert.
6. If you want to create a dynamic message that displays queue statistics:
   • After Contact Center Management Queue/Path, select a path.
   • Click Refresh queue at anytime to refresh the field.
   • After Queue Condition, select a queue statistic.
   • Click Insert.
   NOTE: If you are using French or Spanish phrases, after Gender of the noun, select the gender of
   the noun that Queue Condition quantifies. For example, in the French phrase “La temps d’attende
   est estime a une minute” (The estimated wait time is one minute), select the gender of minute to
   ensure the number, in this case une, uses the correct gender.
7. To move a message up or down in the Message List, select the message and click the up or down
   arrow.
   NOTE: The phrases are played in the order you list them. The Play value represents the static part
   of the message, for example, "The longest call waiting is ...". The Say value represents the dynamic part
   of the message (the value of the statistic) retrieved from the Remote Server (as long the Contact
   Center Management server is running and configured).
8. To delete a message string, in the Message list box, click the string and click the X icon.
9. Click Save to save the message plan.
10. Click New to clear the fields and create another message plan.

To manage messages

1. From the Manage=>Actions=>Message window, click the Manage Files tab.
2. Select a language folder from the drop-down list box.
   NOTE: With Intelligent Queue, you can create language folders. If you accepted the default settings
   during installation, the default path will be Program Files\Mitel Networks\Intelligent Queue\Voice\US
   English. You can create a new directory on the Intelligent Queue server, such as Program Files\Mitel
   Networks\Intelligent Queue\Voice\Latin. If you are also playing dynamic messages, you will need to
   add system files (1.wav, 2.wav, ...), such as Program Files\Mitel Networks\Intelligent
   Queue\Voice\Latin\System.
3. Click a .wav file to select it, and then click Rename to enter a new name for the message on the
   server, or click Delete to remove messages from the language directory.
4. Click Save.

To upload files

1. From the Manage=>Actions=>Message window, click the Upload Files tab.
2. Select the appropriate language folder from the drop-down list box.
   US English is selected by default.
3. Click Browse to navigate to the directory containing messages that have been created.
4. Click a .wav file to select it and click Add to add the selected file to the Upload File List.
   NOTE: Intelligent Queue requires .wav files to be in a specific format.
   See “Recording voice prompts” on page 478 for more information.
5. Click Remove to remove any file from the Upload File List. Click Remove all to remove all files from
   the Upload File List.
6. Click Upload.
   NOTE: You can upload one message file at a time. You can, however, copy multiple messages files
   directly into the appropriate language directory.
Configuring emergency messaging

You can configure Intelligent Queue to enable supervisors to call in and activate emergency messaging over the phone from remote locations.

To configure Intelligent Queue so that supervisors can activate emergency messaging over the phone you must

1. Set up a management plan
2. Set up an emergency message plan
3. Set up an emergency call flow
4. Apply the emergency call flow to your port group.

Supervisors can then activate emergency messaging over the phone. See “Activating emergency messaging over the phone” on page 454.

Setting up an emergency message plan

To set up an emergency message plan

1. Click Manage=>Actions=>Message.
2. Click New.
3. Under Plan name, type a unique plan name.
4. After Select a folder, select the language of the message you want to create.
5. After Pre-recorded phrase, select a pre-recorded emergency message phrase and click Insert.
6. Click Save to save the message plan.

Setting up an emergency call flow

To set up an emergency call flow

1. Click Manage=>Call flows.
2. Under Call flow name, type a unique call flow name.
3. Click the Default action tab.
4. Select Action.
5. After Choose an action, select a message plan type.
6. After Select a plan, select the emergency message plan you created.
7. Select the Check the box if this call flow is used in an emergency state check box to designate the call flow as an emergency call flow.
8. Click Save.

Applying the call flow to your port group

To apply the call flow to your port group

1. Click Manage=>Port groups.
2. Under Port groups, select the port group to which you will apply the emergency message plan.
3. Under Assign call flows, after Emergency state, select the emergency call flow you created.
4. Click Save.

Setting up management plans

You can configure a management plan for your interactive tree that allows supervisors to call in and interact with Intelligent Queue over the phone. After you configure a management plan (assign ports for future use), supervisors can call in and put messaging port groups into Emergency mode (or back into Normal mode) and can record messages over the phone from remote locations. When you configure a management plan, you need to enable the Changing system mode via phone option. This enables supervisors to call in and invoke the plan over the phone.

NOTE: You set up messaging plans before you set up management plans.
To set up a management plan

1. Click Manage=>Actions=>Management.
2. After Plan name, type a new plan name or select an existing plan.
3. On the Settings tab, under Record Prompts, after Recording Prompts via phone is, select Enabled to allow a supervisor to record prompts over the phone.
4. After <drive>, type the destination you wish to save the recordings to.
   CAUTION: Typing 0 enables the supervisor to record infinitely long messages which can consume large amounts of hard drive space.
5. After Recording Timeout (seconds), type the time limit within which the supervisor must record the message (in seconds).
   The default value is 120 seconds. The value can range from 1 to 3600 seconds.
   When determining the duration of the message remember that the longer the message, the more port resources are used.
6. Type the name of the subdirectory where the files you record will be saved. If you accept Inbox as the default setting, any files that you record will be saved to the Inbox folder of Voice.
   The default path is C:\Program Files\Mitel Networks\Intelligent Queue\Voice\Inbox.
7. Under Change system mode, after Changing system mode via phone is, select Enabled to permit supervisors to put selected port groups into Normal mode or Emergency mode over the phone.
8. Under Available Messaging Port Groups, select the port groups that can be placed into Emergency mode, by moving them from the Available messaging port groups box, to the Selected messaging port groups box.
   • Click >> to add all port groups to the list.
   • Click > to add a selected port group to the list.
   • Click < to remove a selected port group from the list.
   • Click << to remove all port groups from the list.

Defining the messages within your management plan

To define the messages within your management plan

1. On the Manage=>Actions=>Management window, click the Options tab.
2. After Password prompt, select a message plan to prompt the caller to enter a password using their DTMF keypad.
3. After Management menu, select a message plan to offer menu options to callers.
   See Table 17-3 for a sample Management Plan configuration.

Table 17-3: Sample management plan configuration

<table>
<thead>
<tr>
<th>To do the following...</th>
<th>Press this digit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record system prompts</td>
<td>1</td>
</tr>
<tr>
<td>Change the system mode</td>
<td>2</td>
</tr>
<tr>
<td>If you have chosen to change the system mode:</td>
<td></td>
</tr>
<tr>
<td>Change the system into Normal Mode</td>
<td>1</td>
</tr>
<tr>
<td>Change the system into Emergency Mode</td>
<td>2</td>
</tr>
</tbody>
</table>

4. After Recording instructions, select a message plan to provide recording instructions that allow callers to record system prompts
5. After Recording completed message, select a message plan to provide a message to callers that their recording has completed.
6. After Change system mode instructions, select a message plan to provide instructions on how to change the system’s operating mode using the telephone keypad.
7. After **Normal mode selected message**, select a message plan to specify a message that plays when the system is placed into Normal Mode.

8. After **Emergency mode selected message**, select a message plan to specify a message that plays when the system is placed into Emergency Mode.

9. After **Invalid digit**, select a message plan to specify the message that plays when an invalid digit is pressed.

10. After **Password access**, type a password that is comprised of digits (0-9, *, #) and related to the Telephone User Interface (TUI) of your telephone.

11. After **Digit timeout**, type a number (of seconds) the system will wait for a DTMF response before timing out. The default is 5 seconds.

12. Click **Save**.

**Activating emergency messaging over the phone**

To activate emergency messaging remotely over the phone

1. Using your telephone, dial into the Intelligent Queue server management port group.
2. Type your user name and password.
3. Listen to the message options and press the number indicated to change your system mode.
4. When you are prompted to specify the message mode, press the number indicated to activate the emergency mode.

**Setting up routing plans**

Three types of routing plans allow you to route calls to another queue path or extension.

- **Redirected** means the call is not answered, no greeting plays, and the call immediately redirects. For example, a call might be redirected if the number of calls waiting in queue is exceeded.

- **Blind** transfer means the call is answered, a greeting is played (optional), and the call is transferred to the destination. After transferring, the extension performing the transfer hangs up and does not wait to determine the outcome of the call. The advantage of a blind transfer is that the immediate release to the PBX frees the port for a new call.

- **Supervised** transfer means the call is answered, and then put on hold while being transferred. The advantage of a supervised transfer is that, because they are on hold, customers cannot hear the phone ringing during the transfer. However, if the Timeout expires (the duration that the call is kept on hold) before the call is transferred, the caller can hear the phone ringing during the transfer. The Intelligent Queue port is not available to take a new call until the Timeout expires or the destination answers the call.

To create a routing plan

1. Select **Manage=>Actions=>Routing**.
   The Routing parameters window opens.
2. Under **Plan name**, type a new plan name or click an existing plan under **Plans**.
3. To redirect a call immediately without playing a message
   - Click **Redirect**.
   - After **Routing destination**, type an extension number.
4. To perform a blind transfer
   - Click **Blind**.
   - Select a greeting from the drop-down list box (if desired).
   - After **Routing destination**, type an extension number.
5. To perform a supervised transfer
   - Click **Supervised**.
   - Select a greeting from the drop-down list box (if desired).
   - After **Routing destination**, type an extension number.
   - After **Timeout (seconds)**, type the maximum duration the call will be placed on hold (between 10-1000 seconds).
Managing Conditions: Assigning conditions to call flows

NOTE:
• Do not use the same condition for both the condition and the subcondition. This will create loops within your conditions. For example, you will create a loop if you select a weekday plan as your condition, a time plan as your subcondition, and then the weekday plan as another subcondition.
• When you save a condition, the Intelligent Queue services require at least 20 seconds to save your changes to the server. The length of time is based on the complexity of the call flows in the condition. You can continue working during this period.

Under every type of condition, you can create a new condition, delete a condition, or save the current condition. If a condition is matched or met, the condition is true. If a condition is not matched or met, the condition is false. You can select from three courses of action:
• You can do nothing, which forces Intelligent Queue to go back to the call flow and test for the next condition.
• You can select to perform an action, which terminates the call flow.
• You can select a subcondition to be tested (and override the default action in a condition that is false).

To view the actual conditions present for a particular call, view the call logs. This will also help you to define/refine the conditions.

Creating ANI conditions

The Automatic Number Identification (ANI) is the number from which a call originates. ANI can represent a telephone number and an area code, for example.

The ANI condition compares an incoming call on an associated port group to a list of defined digit patterns. If an ANI pattern matches, the associated action follows. Otherwise, the default action for a plan executes. If the default action of a plan is set to None, control returns to the call flow and the next condition is tested.
• If the condition is met (True), an action or subcondition that is defined and associated with the ANI plan occurs.
• If the condition is not met (False), a default condition or action that is defined and associated with the ANI plan occurs.

To create an ANI pattern
1. Select Manage=>Conditions=>ANI.
   The ANI Conditions tab opens by default.
2. Type a new plan name, or click an existing ANI plan to populate the Plan Name field.
3. Under ANI Pattern, type digits from 0-9, *, and ?. The * can be used at the end of a digit string or together at the beginning and end of a digit string, to match any number of digits. You cannot use the asterisk as a leading or embedded wildcard as this will cause an error. The ? can be used anywhere in the digit string to match one digit. (See Table 17-4.)

Table 17-4: Wildcard examples

<table>
<thead>
<tr>
<th>Digits Entered</th>
<th>Would match the following digits ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>*416</td>
<td>Will cause an error.</td>
</tr>
<tr>
<td>41*6</td>
<td>Will cause an error.</td>
</tr>
<tr>
<td>416*</td>
<td>416 ’555555555 ...’, 416 ’123’, 416 ’0’, et cetera</td>
</tr>
</tbody>
</table>
Table 17-4: Wildcard examples

<table>
<thead>
<tr>
<th>Digits Entered</th>
<th>Would match the following digits ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>?416</td>
<td>'1' 416, '2' 416, '3' 416, '4' 416, '5' 416, '6' 416, et cetera</td>
</tr>
<tr>
<td></td>
<td>It would not match '11' 416, as ? can only represent one digit.</td>
</tr>
<tr>
<td>41?6</td>
<td>41 '1' 6, 41 '2' 6, 41 '3' 6, 41 '4' 6, et cetera</td>
</tr>
<tr>
<td>416?</td>
<td>416 '5', 416 '7', 416 '2', et cetera</td>
</tr>
</tbody>
</table>

4. Click > to add it to the ANI Pattern List.
5. Click Remove to delete any ANI patterns from the list.
6. After you have configured your ANI condition, click Save.
7. Click the Action to take tab.
8. After Condition Matched, select an action to take if the ANI pattern matches.
   - If you select None, control returns to the call flow and the next condition is tested.
   - If you select Action, select an action type and then select an action plan from the list box.
   - If you select Condition, select a condition type and then select a condition plan from the list box.
9. After Default Action, select an action to take if the ANI pattern does not match.
   - If you select None, control returns to the call flow and the next condition is tested.
   - If you select Action, select an action type and then select an action plan from the list box.
   - If you select Condition, select a condition type and then select a condition plan from the list box.
10. Click Save to save your configuration, New to clear the fields and create a new ANI plan, or Delete to remove an ANI plan.

NOTE: If you click Delete, a confirmation dialog box will ask you to confirm before deleting an ANI Plan. If you try to delete an ANI plan with associated plans, a more detailed confirmation box opens that allows you to view the associated plans, before you can proceed with the deletion. Deleting the selected plan will only remove the reference to the associated plan.

Creating DNIS conditions

Dialed Number Identification Service (DNIS) is the digits dialed or the number called into the telephone system, including any extensions.

The DNIS condition compares the digits dialed to the DNIS pattern list. If a pattern matches, the associated action follows. Otherwise, the default action for the plan executes. If the default action of the plan is set to None, control returns to the call flow and the next condition is tested.

- If the condition is met (True), an action or subcondition that is defined and associated with the DNIS plan occurs.
- If the condition is not met (False), a default condition or action that is defined and associated with the DNIS plan occurs.

To create a DNIS Plan
1. Select Manage=>Conditions=>DNIS.
   The DNIS Conditions tab opens by default.
2. Type a new plan name, or click an existing DNIS Plan to populate the Plan Name field.
3. Under DNIS Pattern, enter digits from 0-9, *, and ?.
   The * can be used only at the end of a digit string to match any number of digits. You cannot use the asterisk as a leading or embedded wildcard as this will cause an error. The ? can be used anywhere in the digit string to match one digit.
4. Click => to add it to the DNIS Pattern List.
5. Click **Remove** to delete any DNIS patterns from the list.
6. After you have configured your DNIS condition, click **Save**.
7. Click the **Action to take** tab.
8. After **Condition Matched**, select an action to take if the DNIS pattern matches.
   - If you select **None**, control returns to the call flow and the next condition is tested.
   - If you select **Action**, select an action type and then select an action plan from the list box.
   - If you select **Condition**, select a condition type and then select a condition plan from the list box.
9. After **Default Action**, select an action to take if the DNIS pattern does not match.
   - If you select **None**, control returns to the call flow and the next condition is tested.
   - If you select **Action**, select an action type and then select an action plan from the list box.
   - If you select **Condition**, select a condition type and then select a condition plan from the list box.
10. Click **Save** to save your configuration, **New** to clear the fields and create a new DNIS plan, or **Delete** to remove a DNIS plan.

**Creating emergency conditions**

An emergency condition does not put the system or any port groups into Emergency mode. It provides the flexibility to execute an action or test another condition if an emergency condition is required.

If the emergency condition’s operating mode is set to Emergency, the associated action occurs. Otherwise, the default action of the plan executes. If the default action of the plan is set to None, control returns to the call flow and the next condition is tested.

To create an Emergency Plan

1. Select **Manage=>Conditions=>Emergency**. The **Emergency conditions** tab opens by default.
2. Enter a new plan name or click an existing plan to populate the **Plan Name** field.
3. Select one of the following operating modes:
   - **Normal** follows a default action.
   - **Emergency** follows an associated action.
4. After you have configured your emergency condition, click **Save**.
5. Click the **Action to take** tab.
6. After **Condition Matched**, select an action to take if the Emergency condition is true.
   - If you select **None**, control returns to the call flow and the next condition is tested.
   - If you select **Action**, select an action type and then select an action plan from the list box.
   - If you select **Condition**, select a condition type and then select a condition plan from the list box.
7. After **Default Action**, select an action to take if the Emergency condition is false.
   - If you select **None**, control returns to the call flow and the next condition is tested.
   - If you select **Action**, select an action type and then select an action plan from the list box.
   - If you select **Condition**, select a condition type and then select a condition plan from the list box.
8. Click **Save** to save your configuration, **New** to clear the fields and create a new Emergency plan, or **Delete** to remove an Emergency plan.
Creating queue conditions

The queue condition checks the Number of calls waiting, Longest wait time, Path DND (Do Not Disturb), Agents available, Call load, and Agents idle conditions. If any of these conditions exceed the tolerance entered, then the condition is true, and the associated action occurs. Otherwise, the default action of the plan executes. If the default action of the plan is set to None, control returns to the call flow and the next condition is tested.

- If the condition is met (True), an action or subcondition that is defined and associated with the queue plan occurs.
- If the condition is not met (False), a default condition or action that is defined and associated with the queue plan occurs.

NOTE: The Call Load statistic uses the following formulas: if there are one or more agents available, Call Load = Calls Waiting / Agents Available. If there are 0 agents available, Call Load = Calls Waiting.

To create a queue plan

1. Select Manage=>Conditions=>Queue.
   The Queue conditions tab opens by default.
2. Type a new plan name or click an existing plan to populate the Plan Name field.
3. Select one of the following conditions:
   - Number of calls waiting
   - Longest wait time
   - Path DND (Do Not Disturb)
   - Agents available
   - Call Load
4. Enter the Maximum Number of Calls.
   If the maximum is exceeded, the condition is true and the associated action will be followed, otherwise, the default action will be executed.
   - If you select None, then control is passed back to the call flow where the next condition will be tested.
5. Select a Contact Center Management Queue/Path from the drop-down list box.
6. Click Refresh Queue to refresh the Contact Center Management Queue/Path drop-down list box.
7. After you have configured your queue condition, click Save.
8. Click the Action to take tab.
9. Under Condition Matched, select None, Action, or Condition. None is selected by default.
   - If you select None, control is passed back to the call flow where the next condition will be tested.
   - If you select Action, select an Action and then select an Action Plan from the drop-down list boxes. The selected action will be followed if the condition is matched, and therefore, true.
   - If you select Condition, select a condition and then select a plan from the drop-down list boxes.
     - The selected sub-condition will be followed if the condition is matched, and therefore, true.
10. Repeat the previous step for Default Action.
11. Click Save.

Creating redirection conditions

The redirection condition checks to see if the call was redirected from another queue or device against the patterns in the Redirection list. If a pattern matches, the associated action occurs. Otherwise, the default action of the plan executes. If the default action of the plan is set to None, control returns to the call flow and the next condition is tested.
To create a Redirection Plan

1. Select Manage=>Conditions=>Redirection. The Redirection conditions tab opens by default.
2. Enter a new plan name or click an existing plan to populate the Plan Name field.
3. Under Redirection Pattern, enter digits from 0-9, *, and ?
   The * can only be used at the end of a digit string to match any number of digits. You cannot use the
   asterisk as a leading or embedded wildcard as this will cause an error. The ? can be used anywhere
   in the digit string to match one digit.
4. Click => to add it to the Redirection Pattern List.
5. Click Remove to delete any redirection patterns from the list.
6. After you have configured your redirection condition, click Save.
7. Click the Action to take tab.
8. Under Condition Matched, select None, Action, or Condition. None is selected by default.
   • If you select None, control is passed back to the call flow where the next condition will be tested.
   • If you select Action, select an Action and then select an Action Plan from the drop-down list
     boxes. The selected action will be followed if the condition is matched, and therefore, true.
   • If you select Condition, select a condition and then select a plan from the drop-down list boxes.
     The selected sub-condition will be followed if the condition is matched, and therefore, true.
9. Repeat the previous step for Default Action.
10. Click Save.

Creating schedule conditions
There are three different schedule plans to configure. You can configure schedules to offer different options,
    based on the following values:
    • Time of day
    • Day of the week
    • Specific calendar dates

If a condition is true
The Time schedule checks the current time. If the current time is between the start and stop times, the
condition is true, and the associated action occurs.

The Day schedule checks the current day of the week. If the day is selected, the condition is true, and the
associated action occurs.

The Date schedule checks the current date. If the date is selected, the condition is true, and the associated
action occurs.

If a condition is not matched
If the condition does not match, the default action of the plan executes. If the default action of the plan is set to
None, control returns to the call flow and the next condition is tested.

Overview of schedule plan creation
• Create a Date schedule, create an action to take, and save it.
• Create a Day schedule, create an action to take, and save it.
• Create a Time schedule, create an action to take, and save it.

To create a schedule plan
1. Select Manage=>Conditions=>Schedule. The Schedule conditions tab opens by default.
2. Enter a new plan name or click an existing plan to populate the Plan Name field.
   Select one of the following schedule types:
   • Time Schedule (checks to see whether the current time falls between start and stop times)
   • Day Schedule (checks to see whether the current day matches a selected day, Monday through
     Sunday)
   • Date Schedule (checks to see whether the current date matches selected dates)
Configure the schedule type you have selected:

- For a Time schedule, enter the start and stop times.
- For a Day schedule, select the appropriate day or days.
- For a Date schedule, click the hyperlinks to change the month and click the appropriate dates within the selected month. The present month is selected by default. You can go back one month, or advance one month in the calendar year. To delete any dates you have selected, click Remove.

4. Check Callback test condition if you want to use this schedule plan as a test condition for a Callback plan. If you want to use this as a callback condition, you will only be able to select from other Schedule Plans that are used for callback conditions.

5. After you have configured your schedule condition, click Save.

6. Click the Action to take tab.

7. Under Condition Matched, select None, Action, or Condition. None is selected by default.
   - If you select None, control is passed back to the call flow where the next condition will be tested.
   - If you select Action, select an Action and then select an Action Plan from the drop-down list boxes. The selected action will be followed if the condition is matched, and therefore, true.
   - If you select Condition, select a Condition and then select a plan from the drop-down list boxes. The selected sub-condition will be followed if the condition is matched, and therefore, true.

8. Repeat the previous step for Default Action.

9. Click Save to save your configuration. Click New to clear the fields and create a new Schedule Plan. Click Delete to remove a Schedule Plan.

Managing call flows

Essentially, a call flow is created from the bottom up. When you plan to create a call flow, think in terms of first assigning actions to conditions, then conditions to call flows, and finally, call flows to port groups.

The messaging engine that handles the call tests the conditions for a call flow. If the current test condition is false, the engine returns to the call flow to test the next condition. If all conditions are false, a default action for the call flow occurs. The default action also occurs if none of the conditions in the call flow result in an action. If the engine tests for a default action and you have not configured a default action, the call terminates.

Overview of creating a call flow

The creation of a call flow consists of the following steps:

- Assigning actions or subconditions to conditions
- Assigning conditions to call flows
- Assigning call flows to port groups

As you create a call flow, you can save your conditions and then select and review the entire call flow in order to revise it.

To create a call flow

1. Select Manage=>Call Flows. The Build Call Flow tab opens by default.
2. Enter a new name or select an existing call flow to populate the Call Flow Name field.
3. Select a Condition from the drop-down list box. View the related plans in the Select a Plan field.
4. Assign Conditions to call flows:
   - Click Add to add the selected conditions to the end of call flow.
   - Click Add All to add all of the conditions listed to the end of the call flow.
   - Click Insert to insert the selected conditions above the selected call flow condition.
   - Click Insert All to insert all of the conditions listed above the selected call flow condition.
5. To change the order of your call flow, click a call flow condition and then click the up or down arrow to move the position of the item up or down in the call flow.
6. Click the X icon beside the Call Flow Conditions text box to delete an item from the call flow.
7. Click the Default Action tab.
8. Under DEFAULT ACTION, select None or Action. None is selected by default. The default action will be followed if none of the conditions in the call flow result in an action.
   • If None is accepted, the call will be terminated.
   • If you select Action, select an Action and then select an Action Plan from the drop-down list boxes.
9. Under EMERGENCY CALL FLOW, check the box if the call flow is to be used when the system or port group is in an emergency mode.
10. After you have set the parameters of your plan, click Save to save your configuration. Click New to clear the fields and create a new Collect Digits Plan. Click Delete to remove a Collect Digits Plan.
11. To browse selected call flow Conditions, click the magnifying glass in the upper right corner of the Call Flow Conditions field.
12. Select any condition or action to view its particulars. See Table 17-5 for the meanings of icons and text colors used in the expanded view.

Table 17-5: Call flow condition legend

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Meaning</th>
<th>Meaning of Text Color</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Condition</td>
<td>Selected conditions are displayed in black, including the ‘do nothing’ condition. If no condition has been selected for Condition Matched, text is displayed in red.</td>
</tr>
<tr>
<td></td>
<td>Action</td>
<td>Selected actions are displayed in blue, including ‘do nothing’ action. If no action has been selected for Default Action, text is displayed in red.</td>
</tr>
<tr>
<td></td>
<td>Circular reference error</td>
<td>Please review your selection to avoid the creation of a loop.</td>
</tr>
</tbody>
</table>

Managing port groups: updated position in queue, messaging, callback, and recording ports

A port can only be assigned to one port group. The behavior of the port depends on the behavior assigned to the port group. You configure port groups in Manage=>Port Groups.

You can configure four types of ports:
• Updated position in queue ports.
• Messaging ports handle incoming calls to the PBX.
• Callback ports handle outgoing callback calls from the agents to the callers.
• Recording ports handle the recording of calls between agents and callers.

You need to configure most of your ports as messaging ports. You also need to configure at least one updated position in queue port, one callback port and at least one recording port, if you purchased these options. You can record one agent at a time on one recording port. If you want to record more than one agent at a time, you need to assign more than one of your ports as a recording port.

NOTE: When you save a port group, the Intelligent Queue services require at least 20 seconds to save your changes to the server. The length of time is based on the complexity of the call flows in the port groups. You can continue working during this period.
Configuring an updated position in queue port group

To configure an updated position in queue port group

1. Select Manage=>Port Groups. The Configure tab opens by default.
2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
3. Select UPIQ under PORT BEHAVIOR.
4. Accept the default setting of 2,000 milliseconds (2 seconds) for the Audio Guard Timer.
   **NOTE:** The Audio Guard Timer reflects the timing of the messages. To adjust the timing, enter a number which is higher or lower than the default setting.
5. Click Configure=>Updated Position in Queue.
6. Select the queue to monitor from the Available Queues drop-down menu.
7. Click Add.
8. Click the Assign Ports tab.
9. Select a port or ports from the list of Available Ports.
   Click >> to add all available Ports to the Port Group.
   Click > to add selected Ports to the Port Group.
   Click < to remove selected Ports from the Port Group.
   Click >> to remove all Ports from the Port Group.
   Click Make All Ports Available to clear the port selections and begin again. This will remove all ports from all Port Groups, not just the selected Port Group.
10. After you have finished assigning ports to port groups, click Save.

Configuring a messaging port group

To configure a messaging port group

1. Select Manage=>Port Groups. The Configure tab opens by default.
2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
3. Select Messaging under PORT BEHAVIOR.
4. Accept the default setting of 2,000 milliseconds (2 seconds) for the Audio Guard Timer.
   **NOTE:** The Audio Guard Timer reflects the timing of the messages. To adjust the timing, enter a number which is higher or lower than the default setting.
5. Assign Call Flows using the drop-down list boxes after Normal State and Emergency State under ASSIGN CALL FLOWS.
6. Under EMERGENCY STATE, select Check the box to place the port group in an emergency state if required.
   **NOTE:** This will already be checked if you have placed the selected port group in Emergency State under Administration=>System Mode. If you deselect it and click Save, the system mode will return to Normal State.
7. Click the Assign Ports tab.
8. Select a port or ports from the list of Available Ports.
   Click >> to add all available Ports to the Port Group.
   Click > to add selected Ports to the Port Group.
   Click < to remove selected Ports from the Port Group.
   Click >> to remove all Ports from the Port Group.
   Click Make All Ports Available to clear the port selections and begin again. This will remove all ports from all Port Groups, not just the selected Port Group.
9. After you have finished assigning ports to port groups, click Save.

Configuring a callback port group

To configure a callback port group

1. Select Manage=>Port Groups. The Configure tab opens by default.
2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
3. Select Callback as the Port Behavior.
4. Assign Call Flows to Normal and Emergency States using the drop-down list boxes.
5. Check **Emergency State** to place the port group in an emergency state, if required.  
   **NOTE:** This will already be checked if you have placed the selected port group in Emergency State under **Administration=>System Mode**. If you deselect it and click **Save**, the system mode will return to Normal State.

6. Click the **Assign Ports** tab.

7. Select a port or ports from the list of Available Ports.
   * Click >> to add all available Ports to the Port Group.
   * Click > to add selected Ports to the Port Group.
   * Click < to remove selected Ports from the Port Group.
   * Click >> to remove all Ports from the Port Group.
   * Click **Make All Ports Available** to clear the port selections and begin again.

8. After you have finished assigning ports to port groups, click **Save**.

### Configuring a recording port group

**To configure a recording port group**

1. Select **Manage=>Port Groups**. The Configure tab opens by default.
2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
3. Select **Recording** as the Port Behavior.
   
   If you are supporting more than one PBX with Intelligent Queue, select the destination PBX.
4. Select a port group for the PBX.
   
   Only ports from this PBX can be used and they will only be able to record ports from that PBX.
5. Click the **Assign Ports** tab.
6. Select a port or ports from the list of Available Ports.
   * Click >> to add all available Ports to the Port Group.
   * Click > to add selected Ports to the Port Group.
   * Click < to remove selected Ports from the Port Group.
   * Click >> to remove all Ports from the Port Group.
   * Click **Make All Ports Available** to clear the port selections and begin again.
7. After you have finished assigning ports to port groups, click **Save**.

### Viewing system, port, and callback queue status

**In this section, you will learn how to**

- View system status
- View port status
- View callback queue status

#### Viewing system status

The System status window opens after you log on to Intelligent Queue. The System status window displays the current status (**Started or Stopped**) of all Intelligent Queue services. The Emergency status section of the System status window indicates the current system mode: Emergency or Normal.

**NOTE:** Before logging on (after initial setup), ensure that the services have been started. If you log on before the services have started, the system status will not be accurate.

**To view system status**

1. Select **Status=>System Status**.
2. Click **Start** to restart a stopped service.
3. Click **Stop** to stop a running service.
4. After **Port Groups** under **EMERGENCY STATUS**, click the number to view the port groups that are in Emergency mode.
5. To restart the services, click the **Restart Systems** button. You can also use this button to re-establish a Contact Center Management connection, if a connection is configured.
Viewing port status

To view port status

1. Select Status=>Port Status. The Select Ports tab opens by default.
2. Choose to view the status of all Port Groups or selected Port Groups. Only port groups with assigned ports will be displayed.
   - Click View All to view the port status for all port groups.
   - Click View Selected to view the port status for selected Port Groups
3. Choose to view the status of all Ports or selected Ports. Only ports assigned to port groups will be displayed.
   - Click View All to view the port status for all ports
   - Click View Selected to view the port status for selected ports
4. Click the Port Status tab to view your selection.
5. To navigate through multiple pages of listings, click Previous or Next.
6. Click Stop to stop Intelligent Queue from displaying port status information. Click Continue to allow the application to continue to display port status information.

Viewing callback queue status

You can view and manage callback queues in Status=>Callback queue. The four tabs within the Callback queue status window display data for Current, Completed, Incomplete, and All callbacks. Intelligent Queue lists callbacks in order of priority and latest date.

The possible callback queue status states, with their explanations, are as follows:

- **NEW_REQUEST** - starting state
- **WAITING_FOR_SCHEDULE** - The callback schedule condition was not met, so waiting
- **WAITING_FOR_QUEUE** - The queue condition was not met, so waiting
- **WAITING_FOR_AGENT_NO_ANSWER** - When the callback engine dialed the agent, the agent did not answer
- **WAITING_FOR_AGENT_BUSY** - When the callback engine dialed the agent, the agent's line was busy
- **WAITING_FOR_CLIENT_NO_ANSWER** - When the callback engine dialed the customer, the customer did not answer
- **WAITING_FOR_CLIENT_BUSY** - When the callback engine dialed the customer, the customer's line was busy
- **AGENT_REQUEUED** - The agent used the requeue option when the callback was offered to them
- **IN_PROGRESS** - The callback is currently being processed (This happens initially and then it transitions to another state)
- **AGENT_REJECTED** - The agent rejected the callback when the callback was offered to the agent
- **EXPIRED** - The callback engine tried to contact the client the maximum number of times and will not try again
- **FAILED_INVALID_AGENT_DESTINATION** - The agent destination was invalid (for example, it was an invalid path number)
- **FAILED_INVALID_CLIENT_DESTINATION** - The client destination was invalid (for example, they left a phone number with only six numbers)
- **FAILED** - General error
- **COMPLETE** - The callback is complete
- **DIALING_CLIENT** - The system is currently dialing the client
To view callback queue status

2. Click the appropriate tab to view the status of the following:
   - Click the Current callbacks tab to view current callback queues. You can change the priority of the callback request using the list box.
   - Click the Completed callbacks tab to view successful callbacks.
   - Click the Incomplete callbacks tab to view failed callback requests. You can click Requeue to requeue a failed callback.
   - Click the All callbacks tab to view a snapshot of all callback queues.
3. To navigate through multiple callback pages, click Previous or Next.
4. Click an individual callback to view the following particulars:
   - Caller’s name
   - Caller’s phone number
   - Customer’s IP Address (if the callback you selected is a Web Callback)
   - Message (click the hyperlink to listen to the recorded .wav file)
5. Click Select All to select all the displayed callbacks. Click Unselect All to de-select all the displayed callbacks.
6. Click Refresh to refresh the callback queue listing.
   To delete an individual callback listing or selected callbacks, click Delete.

Callback and recording plans

This section includes information on
- Managing outgoing calls
- Managing recording plans

Managing outgoing calls: Voice and Web Callbacks

In this section, you will learn how to
- Set up callback plans
- Assign caller messages to callback plans
- Assign agent messages to callback plans
- Assign agent options to callback plans
- Set callback plan parameters

Overview of voice and web callbacks

Callback requests allow Intelligent Queue to wait in queue for an agent, on a caller’s behalf. The system can take callback requests from a voice call, from a web page, or the requests can be generated by a third party business application. A reusable callback action plan in the user interface defines the inputs that are required for a request.
Callback call processing

Intelligent Queue processes callback requests in a continuous loop using each of the ports that are dedicated to callback processing. Each callback request is submitted with a call "profile". This profile is an action plan that defines the ACD path to attempt, the client’s telephone number, the client’s name, queue thresholds to adhere to, and the language in which the call should be processed. The system processes calls in the order that they are received, but each call has a maximum number of attempts and a retry interval. If the client does not answer the call, the callback request requeues to a maximum number of attempts. The system does not attempt the callback until the retry interval is exceeded. Each callback structure also defines the maximum amount of time the callback port will wait for an agent to answer, before requeuing the call and moving on to the next request.

Upon receipt of a callback request, agents can listen to the caller’s message, place the call, requeue, or reject the request.

A user with administrative privileges can view, prioritize, requeue, and delete callback requests from the user interface.

Voice callback requests

A voice callback request can ask the caller for the following information:

• A telephone number at which they can be contacted
• The caller’s name (recorded as a .wav file for playback by an ACD agent)
• A confirmation to submit the request

Once the caller provides the information, Intelligent Queue hangs up and records the request in the database for processing.

For voice callbacks, you need to assign both caller messages and agent messages to your callback plans.

Web callback requests

A customer completes a Web callback request on an HTML/ASP page that is designed and hosted by the Intelligent Queue customer. You can see an example of a sample web page at Start=>Programs=>Mitel Networks=>Intelligent Queue=>Intelligent Queue DotNet Webcallback Example. A customer who wants to receive a callback from an ACD Agent fills out the following required information on the web form:

• The telephone number at which they can be contacted
• The customer’s name (presented as a TTS rendition to the ACD agent)
• The target ACD path

Intelligent Queue then submits the information to the database for callback processing.

For Web callbacks, you need to assign only agent messages (not caller messages) to your callback plans.

Campaign callback requests

Campaign callback requests are requests that are originated by a business application used by an Intelligent Queue customer. A customer can make callback requests directly to Intelligent Queue by submitting a new record in the database. If the record includes the required information, the request is processed in the callback queue. The Campaign table of the database is password-protected to ensure that only authenticated applications can generate requests.
Configuring web callbacks in Windows Server 2003
To configure web callbacks in Windows Server 2003

1. Log on to the Intelligent Queue server.
2. Browse to the Intelligent Queue installation directory (<drive>:\Program Files\Mitel Networks\6160).
3. Copy the WebCallbackExample folder to a folder on your IIS Server.
4. To modify the web callback page to display your company logo and slogan, see “Customizing your Web Callback page” on page 484.
5. On the Intelligent Queue server, click Start=>Administrative Tools=>Internet Information Services (IIS) Manager.
6. Expand <computer_name> (local computer).
7. Expand the Web Sites folder.
8. Right-click Default Web Site and select New=>Virtual Directory...
The Virtual Directory Creation Wizard opens.
9. Click Next >.
10. Under Alias, type webcallback and click Next >.
11.Browse to the VB statically net folder (<drive>:\Program Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet) and click OK.
12. Click Next >.
13. Under Allow the following permissions, select Run scripts (such as ASP) and Execute (such as ISAPI applications or CGI) and click Next >.
14. Click Finish.
15. Browse to the VB statically net folder (<drive>:\Program Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet) and open Web.config.
16. In the string value="http://localhost/6160/CallbackWebService.asmx", replace localhost with the computer name or the IP address of the Intelligent Queue server.
17. In the string value="webCallback", replace webCallback with the name of the callback plan you configured in Intelligent Queue.
18. Click File=>Save and close the Web.config file.

Configuring web callbacks in Windows Server 2008
To configure web callbacks in Windows Server 2008

1. Log on to the Intelligent Queue server.
2. Browse to the Intelligent Queue installation directory (<drive>:\Program Files\Mitel Networks\6160).
3. Copy the WebCallbackExample folder to a folder on your IIS Server.
4. To modify the web callback page to display your company logo and slogan, see “Customizing your Web Callback page” on page 484.
5. On the Intelligent Queue server, click Start=>Administrative Tools=>Internet Information Services (IIS) Manager.
6. Expand <computer_name> (local computer).
7. Expand the Sites folder.
8. Right-click Default Web Site and select Add Virtual Directory...
The Add Virtual Directory dialog box opens.
10. Under Physical path: browse to <drive>:\Program Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet and click OK.
11. Browse to the VB statically net folder (<drive>:\Program Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet) and open Web.config.
12. In the string value="http://localhost/6160/CallbackWebService.asmx", replace localhost with the computer name or the IP address of the Intelligent Queue server.
13. In the string value="webCallback", replace webCallback with the name of the callback plan you configured in Intelligent Queue.
Setting up callback plans

For voice callbacks, assign caller messages and then proceed to assign agent messages to your callback plans.

To create a callback plan

1. Select Manage=>Actions=>Callback. The Conditions tab opens by default.
2. Under Plan Name, enter a new plan name or click an existing Callback Plan under Plans to populate the Plan Name field.
3. Under Schedule Condition, click Allow callbacks anytime, no schedule restrictions apply to allow callbacks anytime.
   The Schedule Plan drop-down list box is disabled. However, if you wish to attach a Schedule Plan to your Callback Plan, leave the check box unchecked and select a schedule you have created from the Schedule Plan drop-down list box.
4. Under Queue Conditions, click Allow callbacks anytime, no queue restrictions apply to allow callbacks anytime, regardless of queue designation.
   The Contact Center Management Queue/Path drop-down list box, the Maximum calls waiting threshold and the Maximum longest call waiting threshold check boxes are disabled. However, if you wish to assign a queue condition to your Callback Plan, leave the check box unchecked and select a queue path from the Contact Center Management Queue/Path drop-down list box.
5. If you have not selected Allow callbacks anytime, no queue restrictions apply, you will be able to set thresholds for the maximum number of calls waiting and the maximum longest call waiting, if required.
6. To set the Maximum number of calls waiting threshold, select Check against the maximum calls waiting threshold and enter a number in the Maximum calls waiting threshold field. If the number of calls meets or exceeds the number you have entered, Intelligent Queue will not perform a callback. If the number of calls is lower than the number you have entered, Intelligent Queue will perform a callback.
7. To set the Maximum longest call waiting threshold, check Check against the maximum longest call waiting threshold and enter a number in the Maximum longest call waiting threshold (seconds) field. If the number of seconds meets or exceeds the number you entered, Intelligent Queue will not perform a callback. If the number of calls is lower than the number you have entered, then Intelligent Queue will perform a callback.
8. To perform a check for an available agent before submitting the callback to the queue, check Check against the agents idle threshold and enter a number in the Minimum agents idle threshold field. If the number of idle agents meets or exceeds the threshold number, Intelligent Queue will submit the callback to the queue. If the number of idle agents is lower than the threshold value, Intelligent Queue will not submit the callback to the queue.

Assigning caller messages to callback plans

For voice callbacks, first assign caller messages and then agent messages to your callback plans. You do not need to assign caller messages for Web callbacks.

To assign caller messages to callback plans

1. From the Manage=>Actions=>Callback window, click the Messages tab. The Messages tab opens.
2. Click the Caller Messages sub tab. The Caller Message sub tab opens.
3. Under Caller Messages, define the messages that a caller will receive when requesting a callback, using the drop-down list boxes.
4. After Prompt for Telephone Number, select a Message Plan you have created to enable callers to hear a message prompting them to leave their phone number. The static message you select could be, "Please use your telephone keypad to enter your seven-digit phone number, followed by the # (pound) key", for example.
5. Make your selections from the two drop-down list boxes after **Confirm Telephone Number**.
   - Step 1: Select the first pre-recorded phrase. The static message you select could be, "You have entered ...", for example.
   - Step 2: Select the second pre-recorded phrase. The static message you select could be, "Is this number correct? Press 1 for yes. Press 2 for no."

6. Select the playback language in which the caller’s DTMF selection will be played back. US English is selected by default.

7. After **Record a Message**, select a Message Plan you have created to enable callers to leave a message. The static message you select could be, "Please leave a message after the tone", for example.

8. After **Request Confirmation**, select a Message Plan you have created to enable callers to hear a confirmation message. The static message you select could be, "Press 1 to Save your Callback Request. Press 2 to Cancel your Callback Request", for example. Saving the callback request submits it to the database. Cancelling the callback request means it will not be submitted to the database.

9. After **Request Submitted**, select a Message Plan you have created to enable callers to hear the message that their callback request has been submitted. The static message you select could be, "Your request has been successfully submitted", for example.

10. After **Request Cancelled**, select a Message Plan you have created to enable callers to hear the message that they have successfully cancelled their callback request. The static message you select could be, "You have successfully cancelled your request", for example.

### Assigning agent messages to callback plans

For voice callbacks, once you have assigned caller messages, proceed to assign agent messages to your callback plans. For Web callbacks, proceed directly to assign agent messages to your callback plans.

**To Assign Agent Messages to Callback Plans**

1. From the Manage=>Actions=>Callback window, click the Messages tab. The Messages tab opens.
2. Click the Agent Messages sub tab. The Agent Messages sub tab opens.
3. Under Agent Messages, define the messages that agents will hear when establishing a callback, using the drop-down list boxes.
4. After **Agent Greeting**, select a Message Plan you have created to allow agents to hear a greeting once a connection to an agent is established.
   The default message for a Voice Callback Request (18.wav) is, "You have a Voice Callback request."
   The default message for a Web Callback Request (19.wav) is, "You have a Web Callback request."
5. After **Agent Instruction**, select a Message Plan you have created to offer menu selection to agents.
   The default message (20.wav) is, "To listen to the caller’s message, press 1. To place this call, press 2. To requeue this request, press 3. To reject this request, press 4. To hear these options again, press star (*)."
6. After **Agent Connecting**, select a Message Plan you have created to allow agents to hear that the call is being established.
   The default message (22.wav) is, "Please wait while the call is established."
7. After **Client Greeting**, select a Message Plan you have created to allow callers to hear a message that they are being connected to an agent.
   The default message (26.wav) is, "You have a callback. We are connecting you to an agent now."
8. After **Client Failure**, select a Message Plan you have created to allow agents to hear that the callback could not be established.
   The default message (27.wav) is, "The callback could not be established."
After **Agent Rejected**, select a Message Plan you have created to allow callers to hear a message confirming that they have successfully cancelled their callback request. The default message (29.wav) is, "Your request has been cancelled. Goodbye."

After **Agent Requeue**, select a Message Plan you have created to allow callers to hear a message that they are being redirected to an available queue.

After **Agent Pre-Connect**, select a Message Plan you have created to allow callers to hear a message before being connected.

### Assigning agent options to callback plans

After you have assigned agent messages for either voice or Web callbacks, you will need to assign agent options to your callback plans.

**To assign Agent Options to Callback Plans**

1. From the Manage=>Actions=>Callback window, click the Agent Options tab. The Agent Options tab opens.
2. Select a DTMF digit (0-9, *, #) that agents will type to invoke each of the following options:
   - Listen to caller’s message/name. The default digit is 1.
   - Connect to the telephone number. The default digit is 2.
   - Requeue the callback request. The default digit is 3.
   - Reject the callback request (to delete the callback request from the queue). The default digit is 4.
   - Replay the agent instruction message. The default digit is 5.

### Setting callback plan parameters

**To set callback plan parameters**

1. From the Manage=>Actions=>Callback window, click the Parameters tab.
2. After **Callback destination**, type the extension number or hunt group number to connect to an agent. If you are supporting more than one PBX with Intelligent Queue, select the callback destination PBX. **CAUTION:** Typing 0 enables the caller to record infinitely long messages which can consume large amounts of hard drive space.
3. After **Client Recording Timeout (seconds)**, type the time limit within which the caller must record the callback message (in seconds). The default value is 600 seconds. The value can range from 1 to 3600 seconds.
4. After **No answer timeout for agent**, type the time limit (in seconds) a callback port will wait for an agent to answer. The default is 120 seconds.
5. After **No answer timeout for clients**, type the time limit (in seconds) a callback port will wait for a client to answer. The default is 15 seconds.
6. After **Number of attempts to contact client**, type the maximum number of times Intelligent Queue will attempt to return the client’s call. The default is three times.
7. After **Retry interval between contacting client**, type a number (of minutes). The default is 30 minutes.
8. After **Minimum number of digits required to place an external call**, type a number. The default is 7.
9. After **Leading digit(s) required to call back external clients**, type the digit required to access an external phone line, if required. The default is 9.
10. After **Minimum number of digits required for a valid callback**, type a number. The default is 7.
11. Select the **On requeue, retain original callback date/time stamp** check box to prioritize callbacks by the original date and time of the callback.  
**NOTE:** The oldest callbacks will always be offered to agents before newer callbacks, regardless of requeue.

12. For **Web Callbacks**, type the number of calls that the system will consider to be too many to process a callback to a queue after **maximum number of simultaneous callback requests from single IP address**. Alternatively, select the **Check box for unlimited callback requests from a single IP address**.  
**NOTE:** Mitel Networks Corporation recommends that you type a maximum number to avoid being flooded by simultaneous callbacks from a single IP Address.

13. Click **Save** to save your configuration. Click **New** to clear the fields and create a new Callback Plan. Click **Delete** to remove a Callback Plan.

### Managing recording plans

Call recording for quality monitoring purposes was introduced in Intelligent Queue version 3. This feature requires that ports be dedicated as recording ports to ensure availability and to avoid call collisions with incoming calls. You can initiate call recording from the Intelligent Queue user interface.

Using Intelligent Queue, a user with sufficient rights enters an Agent ID, extension number, or Agent Group ID to request that a current call, or the next call received, be recorded. Once the recording completes, the system notifies the user of the success (or failure) of the request, as well as the file name with which the call recording has been stored.

Please note the following conditions of the Agent call recording option:
- Only SUPERSET telephones with the ACD Silent Monitoring - Accept option enabled in their Class of Service can be recorded.
- An agent can only be recorded by one supervisor at a time.
- Recording is denied on a broker’s call, because any agent who has a call on soft hold cannot be recorded.
- Agent call recording is not permitted on a non-prime line.
- A SUPERCONSOLE 1000 or SUPERSET 7000 console cannot be recorded.
- Networked ACD does not support agent call recording of remote agent subgroups from the Distributor system.
- Agent call recording is not supported on MSDN networks.

To record an agent
1. Select **Manage=>Recordings**. The Recording Queue tab opens by default.
2. Under **Directory number**, type the directory number you wish to record
3. Select the port group that uses the directory number.
4. Click **Record**.
5. Under **Recording Queue**, view the recordings in queue. To navigate through multiple pages of listings, click **Previous** or **Next**.
6. To remove a recording from a queue, click **Remove**.
7. To terminate the recording of a call, click the **Stop** button.
8. Click the **Download Recordings** tab to play or download a recording.
9. Follow the on-screen instructions:  
   To play a recording, left click a recording to select it.  
   To download a recording from the server and save it to your local hard drive, right-click a recording, select **Save Target As...**, and select a folder to which the recording will be saved.
10. Recordings are saved in a Recordings folder. Provided you accepted the default settings during installation, the folder can be found at the following location: Program Files\Mitel Networks\Intelligent Queue\Recordings
11. Click the **Completed Requests** tab to view completed or failed recordings.
Maintaining Intelligent Queue and Contact Center Management

This section includes information on
- Adding an Intelligent Queue media server to Contact Center Management
- Using Network Monitor with Intelligent Queue
- Configuring Intelligent Queue devices
- Creating reports
- Using Reporter

Adding an Intelligent Queue media server to Contact Center Management

To add an Intelligent Queue media server
1. Click YourSite=>Enterprise.
2. After Name, type the name of the media server.
3. After Site, select the site where this media server resides.
4. After This media server is installed on the computer you have named, select the computer on which the media server is installed.
5. Click Save.

Using Network Monitor with Intelligent Queue

You can use Network Monitor (located in Contact Center Client) to provide information on the status of real-time data collection on your Intelligent Queue media server. Network Monitor can verify if alarms are enabled for your media servers and if the media servers are reporting any alarms.

The following list includes some of the alarms Network Monitor provides:
- SQL Server down
- Messaging Service down
- Recording Service down
- Callback Service down
- Music Service down
- Mitel IP Service down
- No audio
- Bad audio file detected
- MiTAI down
- Low disk space on installation drive
- Invalid agent destination for callback detected

To configure Network Monitor for use with Intelligent Queue, you must
1. Add an Intelligent Queue media server to Contact Center Management. See “Adding an Intelligent Queue media server to Contact Center Management” on page 472.
2. Configure the data collection settings for the Intelligent Queue media server.
3. Configure Contact Center Management settings in Intelligent Queue.

For more information on using Network Monitor, see “Network Monitor” on page 321.
Configuring data collection settings for Intelligent Queue media servers
To configure the data collection settings for an Intelligent Queue media server
1. Open Contact Center Management and click **YourSite=>Enterprise**.
2. Expand the Enterprise Configuration tree and select the Intelligent Queue media server you want to configure.
3. Select the **Data collection** tab.
4. Select **IP address** and type the IP address of your Intelligent Queue server.
5. Click **Save**.

Configuring Contact Center Management settings in Intelligent Queue
To configure your Contact Center Management settings
1. Open Intelligent Queue and click **Configure=>Contact Center Management Settings**.
2. After **Address**, type the IP address of your Contact Center Management server.
3. Click **Save**.

Resolving Network Monitor alarms
When Network Monitor detects an alarm, it provides a general description of the alarm. Though the types of alarms can vary, you can resolve many alarms with the following methods:

- If a service is down, restart the service that is down.
- View the Intelligent Queue log in Event Viewer for more specific details about the alarm.
  See “Viewing event logs” on page 490.

For more information on troubleshooting Intelligent Queue alarms in Network Monitor, see “Recording voice prompts” on page 478.

Configuring Intelligent Queue devices
**NOTE:** You must have the Intelligent Queue application and an Intelligent Queue media server at your site before you can view the Intelligent Queue option on the YourSite Configuration menu.

Intelligent Queue Smart Choice layers
You can configure your ports to act as options or Smart Choice message trees. Each option plays a user-defined message and transfers the caller to a user-defined destination, or allows the customer to create a voice callback, if this option has been purchased.

Viewing Intelligent Queue Smart Choice layers in the YourSite database
To view Intelligent Queue Smart Choice layers in the YourSite database
1. Click **YourSite=>Configuration=>Intelligent Queue=>Smart Choice=>Smart Choice layer**
   The Intelligent Queue Smart Choice layer window opens.
   Under Name, the Intelligent Queue Smart Choice layer names are listed.
   Under Reporting, the Intelligent Queue Smart Choice layer reporting numbers are listed.
Adding Intelligent Queue Smart Choice layer groups to the YourSite database

To add an Intelligent Queue Smart Choice layer group to the YourSite database

1. Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice layer group. The Smart Choice layer group window opens.
2. Click Add.
3. After Reporting, type the reporting number of the Smart Choice layer group.
4. After Name, type the name of the Smart Choice layer group.

Adding Intelligent Queue Smart Choice layers to an Intelligent Queue Smart Choice layer group

To add Intelligent Queue Smart Choice layers to an Intelligent Queue Smart Choice layer group

1. Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice layer group. The Smart Choice layer group window opens.
2. Across from the record of the Smart Choice layer group just created, click Members.
3. Under Available members, select the check boxes of the members you want to add to the group and click >>.
4. Click Save.

Intelligent Queue ports

In this section, you will learn how to use Intelligent Queue ports.

Viewing Intelligent Queue ports in the YourSite database

To view Intelligent Queue ports in the YourSite database

1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice port. The Intelligent Queue Smart Choice port window opens.
2. Under Media server, the media server associated with each Intelligent Queue port is listed.
3. Under Reporting number, the Intelligent Queue port reporting numbers are listed.
4. Under Name, the Intelligent Queue port names are listed.
5. Under Dialable number, the dialable numbers are listed.

Adding Intelligent Queue port groups to the YourSite database

To add an Intelligent Queue port group to the YourSite database

1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice port group. The Intelligent Queue Smart Choice port group window opens.
2. Select Add.
3. After Reporting number, type the Intelligent Queue port group reporting number.
4. After Name, type the Intelligent Queue port group name.
Adding Intelligent Queue ports to an Intelligent Queue port group
To add Intelligent Queue ports to an Intelligent Queue port group

1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart Choice port group. The Intelligent Queue Smart Choice port group window opens.
2. Across from the record of the Intelligent Queue Smart Choice port group just created, click Members. The Edit Intelligent Queue Smart Choice port group members window opens.
3. Under Available Intelligent Queue Smart Choice ports, select the check box of the member you want to add to the group and click >>.

Intelligent Queue exit codes
Exit Codes trigger each exit from a queue or from the auto attendant. They apply to Smart Choice message queues, RAD queues, and routing queues.

Viewing Intelligent Queue Smart Choice layer exit codes in the YourSite database
To view Intelligent Queue Smart Choice layer exit codes in the YourSite database

1. Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice layer exit code. The Intelligent Queue Smart Choice layer exit code window appears.
2. Under Reporting number, the Intelligent Queue exit code reporting numbers are listed.
3. Under Name, the Intelligent Queue exit code names are listed.

Creating reports
You must have Contact Center Management (version 4 or greater), a Contact Center Management Enterprise Node license, and Excel to view reports. They all must be installed prior to installing Intelligent Queue.

Before you can produce a report
The Intelligent Queue server must point to both of the following:

- Contact Center Management server
- Contact Center Management Enterprise Node (requires the Enterprise Node license)

The Contact Center Management database automatically synchronizes with the paths, ports, and exits information provided by Intelligent Queue. From the real-time SMDR and ACD, Intelligent Queue data is generated that drives the reports.

NOTE: If you want to produce reports on agents (Intelligent Queue ports), you must create unique employee IDs and then associate these employee IDs to the agents.

Report types
The reports are found at www.prairiefyre.com (requires Internet Explorer 6 or greater). You can create two types of reports: Smart Choice Layer reports and Smart Choice Port reports.
Smart Choice reports
The Smart Choice reports consist of the following types:

- **Smart Choice Layer Reports**
  Smart Choice Layer reports provide statistics on layer use.
  - Smart Choice Layer Group by Layer
  - Smart Choice Layer Group by Exit Code
  - Smart Choice Layer Group by Layer by Exit Code

- **Smart Choice Port Report**
  Smart Choice Port reports provide statistics on the calls routed through ports associated with Smart Choice messaging.
  - Smart Choice Port Group Performance by Port

**Smart Choice Layer Group by Layer**
The Smart Choice Layer Group by Layer report shows call statistics for each layer associated to the layer group. (See Table 17-6.)

**Table 17-6: Smart Choice Layer Group by Layer**

<table>
<thead>
<tr>
<th>Report Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total calls entering layer</td>
<td>the total number of calls that reach the layer in the decision tree</td>
</tr>
<tr>
<td>Total number of repeats</td>
<td>the total number of repeats that occurred on this layer</td>
</tr>
<tr>
<td>Total true calls entering calls</td>
<td>the number of distinct calls entering the layer</td>
</tr>
<tr>
<td>Total calls exiting layer</td>
<td>the total number of calls that exit the layer to go to another layer or answering point (path, extension, or voice mailbox)</td>
</tr>
<tr>
<td>Total calls terminating in layer</td>
<td>the total number of calls abandoned on the layer</td>
</tr>
<tr>
<td>Total duration in layer (hh:mm:ss)</td>
<td>the total duration of calls, from the time they enter the layer to the time they exit the layer</td>
</tr>
<tr>
<td>Average duration in layer (hh:mm:ss)</td>
<td>the average duration for calls in the layer, from the time they enter the layer to the time they exit the layer</td>
</tr>
</tbody>
</table>

**NOTE:** The prairieFyre Maintenance Manager deletes ANI records that are 15 days or older each night at 2:00 A.M. In addition, ANI records are deleted chronologically when the number of records in the database exceeds 10,000.

**Smart Choice Layer Group by Exit Code**
The Smart Choice Layer Group by Exit Code report shows calls statistics for each exit code selected inside a layer. Smart Choice Layer Group by Exit Code report provides the following information: (See Table 17-7.)

**Table 17-7: Smart Choice Layer Group by Exit**

<table>
<thead>
<tr>
<th>Report Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total count</td>
<td>the total number of calls that leave the layer group by selected code</td>
</tr>
<tr>
<td>Total duration (hh:mm:ss)</td>
<td>the total duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
<tr>
<td>Average duration (hh:mm:ss)</td>
<td>the average duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
<tr>
<td>Total</td>
<td>the total of each of the columns</td>
</tr>
</tbody>
</table>
**Smart Choice Layer Group by Layer by Exit Code**
The Smart Choice Layer Group by Layer by Exit Code report shows calls statistics for each exit code selected inside a layer, for each layer associated to the layer group.

Smart Choice Layer Group by Exit Code report provides the following information. (See Table 17-8.)

**Table 17-8: Smart Choice Layer Group by Layer by Exit Code**

<table>
<thead>
<tr>
<th>Report Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit code number</td>
<td>the number of the exit code</td>
</tr>
<tr>
<td>Exit code name</td>
<td>the name of the exit code</td>
</tr>
<tr>
<td>Total count</td>
<td>the total number of calls that leave the layer group by selected code</td>
</tr>
<tr>
<td>Total duration (hh:mm:ss)</td>
<td>the total duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
<tr>
<td>Average duration (hh:mm:ss)</td>
<td>the average duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
</tbody>
</table>

**Smart Choice Port Group Performance by Port**
The Smart Choice Port Group Performance by Port report shows call statistics for each port associated with the Smart Choice Tree selected. (See Table 17-9.)

**Table 17-9: Smart Choice Port Group Performance by Port**

<table>
<thead>
<tr>
<th>Report Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Smart Choice calls</td>
<td>the total number of calls that reach the layer that are Smart Choice (automated attendant guided) calls</td>
</tr>
<tr>
<td>Total duration (hh:mm:ss)</td>
<td>the total duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
<tr>
<td>Average duration (hh:mm:ss)</td>
<td>the average duration of calls, from the time they are picked up by the port to the time they exit the layer</td>
</tr>
<tr>
<td>Average menu choices per call</td>
<td>the average number of menu choices callers select while in the Smart Choice tree</td>
</tr>
<tr>
<td>Total calls ending in Smart Choice</td>
<td>the total number of callers that hang up while in the Smart Choice tree</td>
</tr>
<tr>
<td>Total calls transferred out from Smart Choice</td>
<td>the total number of calls that are transferred out of the Smart Choice tree to another answering point such as Path or Extension</td>
</tr>
</tbody>
</table>
Recording voice prompts

You can record unique messages, use the provided messages (in US English, UK English, NA French, EU French, EU Spanish, LA Spanish, Dutch) or replace voice prompts provided by Intelligent Queue with your own messages. Your .wav files must have the following format:

- Bitrate: 64 kbps
- Audio sample size: 8 bit
- Channels: 1 (mono)
- Audio sample rate: 8kHz
- Audio format: CCITT u-Law

We suggest you keep messages short. The longer the message, the greater the number of ports the system requires. If all of the ports are busy playing messages to callers, new callers have to wait until the previous message finishes before they are answered.

Recording messages

There are two ways to record Intelligent Queue messages: use a microphone or a telephone. The quality of the messages is higher if you record messages with a microphone, rather than a telephone.

Recording messages with a microphone

To record messages with a microphone, follow the directions that come with your recording software. Save the audio files in the .wav format. Intelligent Queue requires a specific type of .wav file. To convert them to the format that Intelligent Queue requires, see “Converting .wav files” on page 479.

Recording messages with a phone, using Intelligent Queue

To record a message with a phone

1. On the Manage=>Actions=>Management window, click the Options tab.
2. After Recording prompts via phone is... select Enabled.
3. Click Save.
4. If you have set up your management plan, skip to step 6. If you have not, see “Setting up management plans” on page 452.
   See “Defining the messages within your management plan” on page 453.
5. On your phone, dial your password to enter Intelligent Queue.
6. Press 1 to record a message.
7. Record your message.
8. Press any number to stop recording a message.
   Your recorded messages, by default, are saved under the Voice folder, Inbox. The name of the recorded message is: month, day, year, hour, minute, second.wav. For example, 11-2-2006 - 8hr 28m 46s.wav.
9. Locate the recorded message and click on it to listen to the message.
10. If you want to keep the message, rename the message to something meaningful now. For example, if it is the greeting, rename it “Greeting.” Or, if you want to replace a voice prompt provided with Intelligent Queue, re-name the message you recorded with the name of the message you want to replace.
11. Move the message to the appropriate location C:\Program Files\Mitel Networks\Intelligent Queue\Languages\[Language Name].
12. Design your call flow.
   See “Managing call flows” on page 460.
Converting .wav files

If you created your voice recordings on an external source, you must convert your .wav files to the format Intelligent Queue requires.

To convert .wav files to the correct format

1. Click Start=>Programs=>Accessories=>Entertainment=>Sound Recorder. The Sound Recorder window opens.
2. Click File=>Open and select the file you want to convert.
3. Click Open.
4. Click File=>Save As. The Save As window opens.
5. Click Change. The Sound Selection window opens.
6. After Format, select CCITT u-Law.
7. After Attributes, select 8.000 kHz, 8 Bit, Mono 7 kb/sec.
8. Click OK.
9. If you do not want to overwrite the original file, change the file name.
10. After Save as type, verify that Sounds (*.wav) is selected.
11. Click Save.

Readback .wav file names

Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in all languages, are provided in US English and UK English only. You must record your own .wav files if you want them in additional languages. The files are located in the following directory: \Voice\language\System\. There are ten language folders: US English, UK English, NA French, EU French, EU Spanish, LA Spanish, Dutch, Brazilian Portuguese, Simplified Mandarin Chinese, and Italian. See “Recording voice prompts” on page 478. (See Table 17-10).

Table 17-10: Smart Choice Port Group Performance by Port

<table>
<thead>
<tr>
<th>.wav files</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dollars.wav (plural)</td>
<td>For example “two dollars.”</td>
</tr>
<tr>
<td>Dollars-singular.wav</td>
<td>For example “one dollar.”</td>
</tr>
<tr>
<td>Cents.wav (plural)</td>
<td>For example “two cents.”</td>
</tr>
<tr>
<td>Cents-singular.wav</td>
<td>For example “one euro.”</td>
</tr>
<tr>
<td>Euros.wav (plural)</td>
<td>For example “two euros.”</td>
</tr>
<tr>
<td>Euros-singular.wav</td>
<td>For example “one euro.”</td>
</tr>
<tr>
<td>Negative.wav</td>
<td>For example “negative three.”</td>
</tr>
<tr>
<td>Pence.wav (plural)</td>
<td>For example “two pence.” (When you record the .wav file, you must save it as Pence.wav and Pence-singular. wav to be used in both the singular and plural instance.)</td>
</tr>
<tr>
<td>Pence-singular.wav</td>
<td>For example, one pence. (When you record the .wav file, you must save it to be used in both the singular and plural instance.)</td>
</tr>
<tr>
<td>Point.wav</td>
<td>For example “point 45.”</td>
</tr>
<tr>
<td>Pounds.wav (plural)</td>
<td>For example “two pounds.”</td>
</tr>
<tr>
<td>Pounds-singular.wav</td>
<td>For example “one pound.”</td>
</tr>
</tbody>
</table>
### Recorded phrases

The phrases are located in `C:\Program Files\Mitel Networks\Intelligent Queue\Languages\[Language Name]`. You can enter a message defined using the Voice Prompts tab.

**NOTE:** The UK English .wav file scripts are identical to the US English .wav file scripts. (See Table 17-11.)

#### Table 17-11: Included .wav files

<table>
<thead>
<tr>
<th>File Name</th>
<th>Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>FR-1.wav</td>
<td>Tous nos représentants s'ont présentement occupés. On vous répondra dès qu'un d'entre eux sera disponible.</td>
</tr>
<tr>
<td>FR-2.wav</td>
<td>Bonjour! Merci de votre appel. Tous nos représentants sont présentement occupés. On vous répondra dès qu'un d'entre eux sera disponible.</td>
</tr>
<tr>
<td>FR-3.wav</td>
<td><em><strong>Exact same recording as FR-2</strong></em></td>
</tr>
<tr>
<td>FR-4.wav</td>
<td>Merci de votre appel. En raison du nombre d'appel actuel, le temps d'attente sera d'environ...</td>
</tr>
<tr>
<td>FR-5.wav</td>
<td>Merci de votre appel. En raison du nombre d'appel exceptionnellement élevé, le temps d'attente sera d'environ...</td>
</tr>
<tr>
<td>FR-6.wav</td>
<td>Minute</td>
</tr>
<tr>
<td>FR-7.wav</td>
<td>Merci de votre appel. Le temps d'attente est présentement de cinq à dix minutes. Veuillez patienter pour conserver votre priorité d'appel. Merci de votre compréhension.</td>
</tr>
<tr>
<td>FR-9.wav</td>
<td>Cette option n'est pas disponible.</td>
</tr>
<tr>
<td>FR-10.wav</td>
<td>Merci de votre appel. Nos bureaux sont présentement fermés. Veuillez rappeler du lundi au vendredi de 8h à 17h.</td>
</tr>
<tr>
<td>FR-12.wav</td>
<td>Merci de votre appel. En raison du nombre d'appel exceptionnellement élevé, on vous répondra dès qu'un représentant sera disponible. Merci de votre compréhension.</td>
</tr>
<tr>
<td>FR-13.wav</td>
<td>Veuillez composer un numéro de téléphone où vous joindre, suivi du carré.</td>
</tr>
<tr>
<td>FR-14.wav</td>
<td>Vous avez composé le...</td>
</tr>
<tr>
<td>FR-17.wav</td>
<td>Pour soumettre cette demande de rappel, faites le un. Pour l’annuler et quitter le système, faites l’étoile.</td>
</tr>
<tr>
<td><strong>File Name</strong></td>
<td><strong>Script</strong></td>
</tr>
<tr>
<td>----------------</td>
<td>------------</td>
</tr>
<tr>
<td>FR-18.wav</td>
<td>Vous avez une demande de rappel vocale.</td>
</tr>
<tr>
<td>FR-22.wav</td>
<td>Veuillez patienter pendant que nous effectuons l’appel.</td>
</tr>
<tr>
<td>FR-23.wav</td>
<td>Connexion en cours.</td>
</tr>
<tr>
<td>FR-24.wav</td>
<td>Il y a d’autres demandes de rappel.</td>
</tr>
<tr>
<td>FR-25.wav</td>
<td>Il n’y a pas de demande de rappel en attente.</td>
</tr>
<tr>
<td>FR-27.wav</td>
<td>Le rappel n’a pu être établi.</td>
</tr>
<tr>
<td>FR-28.wav</td>
<td>Votre appel est acheminé. Un moment s’il vous plaît.</td>
</tr>
<tr>
<td>FR-29.wav</td>
<td>Votre demande a été annulée. Au revoir.</td>
</tr>
<tr>
<td>FR-31.wav</td>
<td>Veuillez s’il vous plaît composer votre mot de passe de gestionnaire.</td>
</tr>
<tr>
<td>FR-32.wav</td>
<td>Pour enregistrer les invitations du système, composez le un. Pour changer le mode d’opération de ce système, composez le deux.</td>
</tr>
<tr>
<td>FR-33.wav</td>
<td>Commencez à parler après la tonalité. Quand vous aurez terminé, appuyez sur n’importe quelle touche.</td>
</tr>
<tr>
<td>FR-34.wav</td>
<td>Enregistrement terminé. Votre enregistrement a été sauvegardé dans votre boîte de réception.</td>
</tr>
<tr>
<td>FR-35.wav</td>
<td>Pour configurer vos ports d’accès, en mode normal, composez le un. Pour les configurer en mode d’urgence, composez le deux.</td>
</tr>
<tr>
<td>FR-36.wav</td>
<td>Vos faisceaux d’accès fonctionnent maintenant en mode normal.</td>
</tr>
<tr>
<td>FR-37.wav</td>
<td>Vos faisceaux d’accès fonctionnent maintenant en mode d’urgence.</td>
</tr>
<tr>
<td>FR-38.wav</td>
<td>Cette sélection n’est pas valide.</td>
</tr>
<tr>
<td>FR-39.wav</td>
<td>Le nombre d’appelants en attente est de...</td>
</tr>
<tr>
<td>FR-40.wav</td>
<td>Votre rang dans la file d’attente est...</td>
</tr>
<tr>
<td>FR-41.wav</td>
<td>Votre demande a été mise dans la file d’attente...</td>
</tr>
<tr>
<td>FR-42.wav</td>
<td>D’attente la plus longue est de...</td>
</tr>
</tbody>
</table>
Table 17-11: Included .wav files (Continued)

<table>
<thead>
<tr>
<th>File Name</th>
<th>Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>NA-1.wav</td>
<td>All of our representatives are busy helping other callers. Your call will be answered as soon as an agent becomes available.</td>
</tr>
<tr>
<td>NA-2.wav</td>
<td>Good morning, and thank you for calling. All of our representatives are busy helping other callers. Your call will be answered as soon as an agent becomes available.</td>
</tr>
<tr>
<td>NA-3.wav</td>
<td>Good afternoon, and thank you for calling. All of our representatives are busy helping other callers. Your call will be answered as soon as an agent becomes available.</td>
</tr>
<tr>
<td>NA-4.wav</td>
<td>Thank you for calling. Based on current call volumes, the expected wait time is...</td>
</tr>
<tr>
<td>NA-5.wav</td>
<td>Thank you for calling. Due to the unusually high number of calls, the expected wait time is...</td>
</tr>
<tr>
<td>NA-6.wav</td>
<td>...minutes.</td>
</tr>
<tr>
<td>NA-7.wav</td>
<td>Thank you for calling. The current wait times are between 5 and 10 minutes. Please continue to hold to maintain your call priority. We thank you for your patience.</td>
</tr>
<tr>
<td>NA-8.wav</td>
<td>Thank you for calling. Due to the unusually high volume of calls, the current wait times are greater than 10 minutes. Please continue to hold to maintain your call priority. We thank you for your patience.</td>
</tr>
<tr>
<td>NA-9.wav</td>
<td>That option is not available.</td>
</tr>
<tr>
<td>NA-10.wav</td>
<td>Thank you for calling. Our offices are now closed. Please call back Monday to Friday, between the hours of 8 A.M. and 5 P.M.</td>
</tr>
<tr>
<td>NA-11.wav</td>
<td>Thank you for calling. Our offices are now closed for the holiday. Please call back Monday to Friday, between the hours of 8 A.M. and 5 P.M.</td>
</tr>
<tr>
<td>NA-12.wav</td>
<td>Thank you for calling. We are currently experiencing an unusually high volume of calls. Your call will be answered as soon as an agent becomes available. We thank you for your patience.</td>
</tr>
<tr>
<td>NA-13.wav</td>
<td>Please enter a telephone number where you can be reached, followed by the pound sign.</td>
</tr>
<tr>
<td>NA-14.wav</td>
<td>You have entered...</td>
</tr>
<tr>
<td>NA-15.wav</td>
<td>If this is correct, press one. If this is not correct, please press the star key.</td>
</tr>
<tr>
<td>NA-16.wav</td>
<td>At the tone, please record your name. When you have finished recording, press one.</td>
</tr>
<tr>
<td>NA-17.wav</td>
<td>To submit this callback request, press one. To cancel this request and leave the system, please press the star key.</td>
</tr>
<tr>
<td>NA-18.wav</td>
<td>You have a voice callback request.</td>
</tr>
<tr>
<td>NA-19.wav</td>
<td>You have a Web callback request.</td>
</tr>
<tr>
<td>NA-20.wav</td>
<td>To listen to the caller’s message, press one. To place this call, press 2. To requeue this request, press 3. To reject this request, press 4. To hear these options again, press star.</td>
</tr>
</tbody>
</table>
Web Callback

With Web Callback, callers can submit callback requests from the company website. Each caller must type a telephone number, name, and time frame within which the call should be returned. You can download an example of a Web Callback page and edit it for use by company. (See Figure 17-2.)

Viewing the Web Callback example page

You can view the Web Callback example page at <installation_drive>:\Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet.
Customizing your Web Callback page

You edit elements of the Web Callback example to create your own customized Web Callback page.

You can edit the following files

- Header.aspx
- Footer.aspx
- Styles.aspx
- Web.config
- WebCallback.aspx

Figure 17-2  Web Callback
Customizing the header

In the example, the header consists of the Mitel logo and the words “Intelligent Queue.”

To edit the header image

1. Create a .gif image to replace the Mitel header.
2. Under WebCallback\IMAGES folder, save the file as header_product_mitel_iq.gif. The new image will replace the Mitel header.

Customizing the footer

In the example, the footer consists of the Mitel logo with the words “It’s about YOU.”

To edit the footer image

1. Create an .gif image to replace the Mitel footer.
2. Under WebCallback\IMAGES folder, save the file as MitelLogo_ABOUT_YOU_20percent.jpg. The new image will replace the Mitel footer.

Customizing the Cascading Style Sheet

The Cascading Style Sheet (CSS) defines how HTML elements are displayed. CSS enables you to control the style and layout of multiple Web pages all at once.

To edit the CSS

1. Open Styles.css.
2. Edit the heading and body font sizes and styles, or spacing.
3. Click Save.

Customizing the Web configuration

This is the configuration file for the Web Callback page. Review the following settings to ensure the Web Callbacks function properly.

The following settings are used in the Web Callback example. (See Figure 17-3.)

Figure 17-3  Web Callback example.

```xml
<appSettings>
    <add key="WebCallbackPlanName" value="webCallback"/>
    <add key="YourCountryCode" value="1"/>
    <add key="TDDInternationalDialingPrefix" value="011"/>
</appSettings>
```
To edit the Web configuration

1. Open `Web.config`.
2. If you use SSL, add an `s` after http in `<add key="WebCallbackService.CallbackWebService" value="http://localhost/6160/CallbackWebService.asmx"/>` and modify `localhost` to what was specified in the CSR request under Common Name (CN).
3. After `"WebCallbackService.CallbackWebService" value=""` ensure it states your Intelligent Queue website address.  
   The default value provided is correct unless you changed the default name of the virtual directory when you installed Intelligent Queue.
4. After `"Web Callback Plan Name" value=""` replace `webCallback` with the name of the callback plan you defined in Intelligent Queue.  
   The plan will be executed when the user submits a Web callback.
5. After `"YourCountryCode" value=""` replace 1 with your country code.
6. After `"IDDInternationalDialingPrefix" value=""` replace 011 with the international prefix your company uses as part of the telephone number to return the callback.  
   This value is used only when the callback request destination IDD is different from your IDD.
7. Click `Save`.

**Customizing the content of the Web Callback page**

You can change the content of the Web Callback page to reflect your business, however, below is a list of critical elements that you must not change or remove. (See Table 17-12.)

**Table 17-12: Critical elements that must not be changed or removed**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>txtName</td>
<td>This is the text box for the client’s name.</td>
</tr>
<tr>
<td>RequiredFieldNameValidator</td>
<td>This is the required field validator for txtName.</td>
</tr>
<tr>
<td>txtPhoneNumber</td>
<td>This is the text box for the phone number.</td>
</tr>
<tr>
<td>phoneNumberRegexValidator</td>
<td>This validates whether the value in txtPhoneNumber is a valid phone number.</td>
</tr>
<tr>
<td>RequiredFieldPhoneNumberValidator</td>
<td>This is the required field validator for txtPhoneNumber.</td>
</tr>
<tr>
<td>nonNorthAmericanNumberRegexValidator</td>
<td>This validates whether the value in txtPhoneNumber is a valid phone number outside of north America.</td>
</tr>
<tr>
<td>rblLongDistance</td>
<td>This is the radio button list for choosing whether the phone number is long distance.</td>
</tr>
<tr>
<td>RequiredFieldLongDistanceValidator</td>
<td>This is the required field validator to ensure the user has said Yes or No to whether the phone number entered is long distance.</td>
</tr>
<tr>
<td>lblCountryCode</td>
<td>This is the corresponding label for ddlCountryCode drop down list and this can not be deleted because it’s visibility is toggled based on if you choose yes or no to whether the call is long distance or not. However, the label’s text can be changed to say anything.</td>
</tr>
<tr>
<td>ddlCountryCode</td>
<td>This is the drop down list for the country codes.</td>
</tr>
</tbody>
</table>
To edit Web Callback page content

2. Edit the content.
3. Click Save.

Troubleshooting Intelligent Queue issues

This section includes information on troubleshooting:
- The database
- Event logs
- Web access to Intelligent Queue
- Intelligent Queue music and telephony services
- Intelligent Queue installation from a local or shared hard drive
- Updated position in queue
- Internet Explorer WebControls
  See Table 17-13.

Table 17-13: Troubleshooting

<table>
<thead>
<tr>
<th>Problem</th>
<th>Reason</th>
<th>Possible Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Invalid username and password&quot; when logging in with the default username and password.</td>
<td>The password might be incorrect.</td>
<td>Double check the password with attention to the use of upper and lower cases.</td>
</tr>
<tr>
<td>The RAD message does not play the complete message file.</td>
<td>The Answer Plus Message Length Timer and the expected Offhook Timer in the Class of Service Options Assignment form are incorrect.</td>
<td>See “Configuring ports” on page 432. See “Types of messages” on page 424 and “Length of messages” on page 425.</td>
</tr>
<tr>
<td>The ACD paths are not shown under Time in Queue settings of RAD ports in Administration.</td>
<td>You have not purchased Contact Center Management version 5 and the Time in Queue Option.</td>
<td>Purchase the application.</td>
</tr>
</tbody>
</table>
### Table 17-13: Troubleshooting

<table>
<thead>
<tr>
<th>Problem</th>
<th>Reason</th>
<th>Possible Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intelligent Queue and Contact Center Management are not communicating.</td>
<td>Type the correct IP address for the Contact Center Management server if Intelligent Queue is a remote installation. See “Configuring Contact Center Management settings” on page 433. The host name should be found if the server address is entered correctly. See also “Server Requirements” in the Intelligent Queue User Guide.</td>
<td></td>
</tr>
<tr>
<td>Intelligent Queue and Contact Center Management are located on different subnets.</td>
<td>Type the gateway information in your TCP/IP properties. Test your connection to the gateway with the ping utility.</td>
<td></td>
</tr>
<tr>
<td>The ACD paths are not shown in the menu when creating a Queue plan.</td>
<td>The Time In Queue Settings were not applied.</td>
<td>See “To create a queue plan” on page 458.</td>
</tr>
<tr>
<td>No messages will be shown under my plans when defining messaging plans.</td>
<td>You have not associated any messages with this plan.</td>
<td>See “Setting up messaging plans” on page 450.</td>
</tr>
<tr>
<td>You do not have audio or DTMF reception, or your ports do not work.</td>
<td>The Intelligent Queue Server must be on the same subnet as the PBX.</td>
<td>Put the Intelligent Queue Server on the same subnet as the PBX.</td>
</tr>
</tbody>
</table>

### Troubleshooting using the configuration wizard

You can perform the following actions using the configuration wizard. (See Figure 17-14.)

### Table 17-14: Troubleshooting using the configuration wizard

<table>
<thead>
<tr>
<th>Action</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>Re-register DLLs</td>
<td>Music volume cannot be controlled.</td>
</tr>
<tr>
<td>Log cleanup</td>
<td>Logs are taking up too much hard drive space.</td>
</tr>
<tr>
<td>Database cleanup</td>
<td>Database errors.</td>
</tr>
<tr>
<td>IIS Reconfiguration</td>
<td>Website errors.</td>
</tr>
<tr>
<td>Restart all Intelligent Queue services</td>
<td>Severe telephony issues or the database will not refresh.</td>
</tr>
<tr>
<td>Port enumeration</td>
<td>Ports are added. See “Configuring ports” on page 432.</td>
</tr>
<tr>
<td>Database migration</td>
<td>Database upgrade.</td>
</tr>
</tbody>
</table>
Establishing a connection to the database

If you try to start Intelligent Queue and are unable to establish a connection to the database, the Database Error window opens. (See Figure 17-4.)

Figure 17-4  Database Error window

There are a couple of ways to troubleshoot the database.

- Using the Control Panel to verify that SQL Server has been started
- Viewing the tray icon to verify that SQL Server has started

Scenario 1: Using Control Panel to verify SQL Server has started

To verify that SQL Server has started

1. From the Start Menu, select **Settings/Control Panel/Administrative Tools/Services**.
2. Scroll down to MSSQLSERVER and verify that the service has started.
   
   **NOTE:** The start icon in the toolbar has been disabled.
   
   The Services window opens with MSSQLSERVER started.
   
   See Figure 17-5.
3. To start, stop, or restart the service, click the corresponding icons in the toolbar. Or click the **Action** menu, and then click the appropriate icon from within the dialog box.
Scenario 2: Viewing the tray icon to verify SQL Server has started

To verify that SQL Server has started

1. Locate the SQL Server Service icon in your tray.
   - A tower icon with a green arrow means that the service is running.
   - A tower icon with a red square means that the service has stopped.
2. Double-click the tray icon or right-click to select Open SQL Server Service Manager menu. If the SQL Server is running, the SQL Services are running window appears. If the SQL Server is not running, the SQL Services have stopped window appears.

**NOTE:** Accept the default selection to Auto-start service when OS starts.

Viewing event logs

From the Control Panel, you can access the following Administrative Tools:

- Event Viewer
- Internet Services Manager
- Services

Logging events

Event Viewer is used to view and manage logs of system, application, and security events on your computer. Event Viewer gathers information about hardware and software problems, and monitors Windows security events.

To view logs

1. Click **Status=>Log Viewer**
2. Click the **Call Logs** tab.
   The Call Logs tab appears.

Event logging applies to all incoming and outgoing calls on the Intelligent Queue system. Logging begins when a call is first detected and ends when the call is terminated by transfer, or hang-up. Each log contains a plain English record of the event. The following events will cause an event to be logged:
**Call Received**
When a call is first received by Intelligent Queue, all known properties of the call will be logged, including the following properties: the date/time stamp of the call, caller’s telephone number, digits dialed, redirection information, caller’s name, and the Intelligent Queue port that received the call.

For 5000/Axxess configurations that use CT Gateway, time stamps are based on the Enterprise Server’s PC clock. If the 5000/Axxess configuration includes remote servers, then time stamps are based on the remote server’s PC clock. For the 3300 ICP, time stamps are based on the telephone system clock.

**Action Plan Selected**
Once an action plan has been selected, the plan, as well as the selection criteria used, will be written to the logs.

**System Action**
All actions taken by the Intelligent Queue port will be written as logs. System actions include any function that affect the call, such as answering or redirecting a call, playing or recording a message, beginning a transfer, dialing or hanging up.

**Caller Action**
All actions taken by a caller while connected to an Intelligent Queue port will be logged. Caller actions include the following: pressing a DTMF digit, and recording a voice message.

**Agent Action**
The actions that an agent takes during a callback will be logged. Agent actions include the following: answering, hanging up, and pressing a digit.

**Callback Action/ Callback Event**
All Callback actions/events will be logged including the following: Agent Attempted, Agent Accepted, Agent Rejected, Agent Re-queued, Caller Attempted, Caller Answered, Callback Connected, Callback Failed (and the reason the callback failed).

**Gaining Web access to Intelligent Queue**
You can use the Internet Services Manager to manage your Internet Information Services (IIS) which enables web access to Intelligent Queue. Intelligent Queue is a web-based application and IIS is the Windows component that makes it easy to publish information and bring business applications to the Web. With IIS, you can create a strong platform for network applications and communications.

If you are having difficulty gaining Web access to Intelligent Queue, troubleshoot your IIS:

1. From the Start Menu, click **Settings/Control Panel/Administrative Tools/Internet Services Manager**.
2. Verify that your PC is connected. See Figure 17-6.
3. Click the PC to expand the tree view
4. Verify whether the Default FTP Site, Web Site, and SMTP Virtual Server are running. See Figure 17-7.

5. Click any of these defaults and click the Intelligent Queue folder to view the details. The Intelligent Queue folder contains the same files as the Webroot folder. See Figure 17-8.
Troubleshooting the login

Inability to see the login window when launching Intelligent Queue might be the result of one or more of the following problems:

- If you are seeing a page of HTML code instead of the login window, you will need to use the aspnet_regiis.exe tool.
- If you are seeing a white page instead of the login window, you need to verify that the ASP.NET State Service is present and running.

**NOTE:** You can have multiple versions of the .NET framework on your PC. The versions are located in the following directory: systemroot\Microsoft.NET\Framework\v1.x.xxxx. Intelligent Queue tests for the presence of version 1.14322.

Using the aspnet_regiis.exe tool

1. On the Windows desktop, click **Start**.
2. Select **Programs=>Accessories=>Command Prompt**.
   A DOS window will open.
3. At the > prompt, type in `cd C:\WINNT\Microsoft.NET\Framework\v1.1.4322` and press Enter.
   **NOTE:** If your System Drive is on another drive, the installation would have defaulted to that drive.
4. At the > prompt, type in `aspnet_regiis.exe -i`.
   See Figure 17-9.
Verifying the ASP.NET State Service
During installation, the Intelligent Queue setup application tests for the presence of the ASP.Net State Service. If it is missing, an error message appears.

If ASP.NET State Service is not installed
This error represents a potential problem with the .NET framework. Some possible solutions are as follows:

- Restart the PC
- Open the Services control panel and check for the presence of ASP.NET State Service. Start the service if required.
- If you are unable to find the ASP.NET State Service, you might want to remove the .NET Framework and reinstall it.

If ASP.NET State Service is not started
During installation, the Intelligent Queue setup application changes the ASP.NET State Service startup mode to Automatic. When the user restarts the PC after the installation, the ASP.NET Service should start automatically. If it does not, use the following procedure to start ASP.NET:

1. Open the Services Control Panel.
2. Look for the ASP.NET State Service.
3. Start the service.
4. Change the startup type to "Automatic" if required.

If ASP.NET State Service cannot be started due to error message “Could not start ASP.NET State Service”
See the following Microsoft Knowledge Base article:
- http://support.microsoft.com/default.aspx?scid=kb;en-us;827189

Setting the Intelligent Queue Web session timer
The Intelligent Queue Web session timer default value is five minutes. After five minutes of inactivity, you will be logged out.

**NOTE:** The Web session timer value must be between 1 and 20 minutes.
To increase the Web session timer threshold value

1. Browse to `<Intelligent Queue Installation folder>\XML\CONFIG\`.
2. Open `GlobalSettings.xml`.
3. Locate the `<SESSION_TIMEOUT>5</SESSION_TIMEOUT>` tag.
4. Change the Web session timer from the default (5) to a value you specify.
   
   NOTE: The Web session timer value must be entered in minutes.
5. Save the file.

Using the Services tool

You can use the Services tool to manage the Intelligent Queue Music and Telephony Services on your computer, to set recovery actions to take place if a service fails, and to create custom names and descriptions for services so that you can easily identify them.

Services are used to manage the services on your computer, set recovery actions to take place if a service fails, and to create custom names and descriptions for services that are easily identifiable.

To troubleshoot Intelligent Queue Music and Telephony Services

1. On the Windows desktop, click **Start**.
2. Select **Settings/Control Panel/Administrative Tools/Services**.
3. View the IQR3 Music and IQR3 Telephony and verify that they are running.
4. You can click the appropriate icon in the taskbar to start, stop, or restart the services.
   
   NOTE: Pause is not supported in Intelligent Queue Release 3.0.
   See Figure 17-10.

Figure 17-10  Services window with Music and Telephony services started
Installing Intelligent Queue from a shared or local drive

If you attempt to install Intelligent Queue from a shared or local drive, you might experience the following issues.

Scenario 1: Receiving a System IO Error

If you are installing Intelligent Queue from a directory with a long path or a path name which includes spaces, you might receive a System IO Error which will halt the installation.

Solution: Use a short directory name without spaces, such as C:\6160Install.

Scenario 2: Being unable to install Microsoft .Net Framework

If the Microsoft .Net Framework is not present when you are installing Intelligent Queue and a popup appears asking if you want to install it now, the installation of the Microsoft .Net Framework might not initialize when you click Yes.

Solution: Run the dotnetfx.exe from the NetFramework directory.

Receiving an Updated position in queue message

If your caller does not receive an Updated position in queue message, it could be because of one of the following two reasons:

- There are too many Updated position in queue messages for the switch to process.
- There are not enough ports to provide a message to each caller who is programmed to receive a Updated message in queue.

There are too many Updated position in queue messages

The number of Updated position in queue messages (tap internal calls) your switch can handle is 1500 or less. If the number of Updated position in queue messages exceeds the recommended number, some messages will be delayed or might not play at all. You will need to reduce the number of Updated position in queue messages, or increase the number of ports.

There are not enough ports

If you do not have an adequate number of ports to run Intelligent Queue, as programed, your callers might not receive Updated position in queue messages. Intelligent Queue provides queues with the greatest priority ports first. If you run out of ports, it is queues with lower priorities that would not receive the Updated position in queue messages.

If Updated position in queue is running low on ports you will receive an error message. If you run out of ports you will receive a critical error message. In the event that you receive either of these messages, you can take one of the following actions to make more ports available:

- Purchase more ports as required.
- Decrease the frequency of queue updates.
- Decrease the number of users updated in the queue.
- Reduce the number of queues being monitored.
- Reduce the number of Updated position in queue messages.
- Reassign ports to Updated position in queue.

You can use the port sizing tool to determine the number of ports you require to run Intelligent Queue. See “Planning the number of ports you require” on page 421.
Your callers hear only a position, not a message

If your callers hear only their position in queue, for example, “3” or “2,” you did not record the Updated position in queue message. Intelligent Queue Updated position in queue will provide the position but will not provide the message. If you want the callers in queue to hear a messages, for example, “Your call will be answered next” or “You are in position...” you must record the message. See “Recording voice prompts” on page 478.

Updated Position in Queue and RAD messages do not play when expected

Updated Position in Queue logic is handled directly by Intelligent Queue whereas RAD logic is handled by the telephone system; therefore there is an inherent limitation when combining the two technologies. Updated Position in Queue functionality interferes with the way a RAD operates. To prevent the interference, when Updated Position in Queue and RAD messages are played for the same queue, you must program the initial Updated Position in Queue message to play before the first RAD message, and subsequent Updated Position in Queue messages to play after the last RAD message.

Configure Intelligent Queue messages in the following order:

1. Updated Position in Queue 1: 5 seconds
2. RAD1: 20 seconds
3. RAD2: 20 seconds
4. RAD3: 30 seconds
5. Updated Position in Queue 2: 2 minutes

Removing Internet Explorer WebControls from a workstation

To remove the Internet Explorer WebControls from a workstation, perform the following

1. On the Windows desktop, click Start.
2. Select Settings and then click Control Panel.
3. When the Windows Control Panel appears, double-click Add/Remove Programs.
4. In the Add/Remove Programs properties dialog box, select Internet Explorer WebControls and then click Add/Remove. The InstallShield wizard will appear.
5. Select Remove and click Next. The uninstall wizard will then remove the Internet Explorer WebControls.
Chapter 18
Workforce Scheduling
Schedule Adherence
and Employee Portal

Before installing Workforce Scheduling
Upgrading from Contact Center
Scheduling to Workforce Scheduling
Installing Workforce Scheduling
Using Workforce Scheduling
Workforce Scheduling and your contact center
Before you start scheduling
Schedule setup and customization
Schedule creation
Schedule distribution
Configuring adherence preference
Viewing adherence monitors in Contact Center Client
Running adherence reports
Employee functionality
Supervisor functionality
Employee Portal reports
Workforce Scheduling

Workforce Scheduling is an optional application that works in conjunction with Contact Center Management and the Mitel 3300 ICP, SX-200 ICP, SX-2000, 5000 CP, and Axxess. You configure employees in YourSite Explorer and schedule them with Workforce Scheduling. Using historical data from Contact Center Management, Workforce Scheduling forecasts the number of employees required to meet your contact center's Service Level objectives. Using Workforce Scheduling, you can build schedules with forecast information. If you enter employee payroll information in Contact Center Management, Workforce Scheduling can use this information for scheduling and budgeting purposes.

To install Workforce Scheduling, select the Workforce Scheduling option in Client Role Selector (Start=>Programs=>Mitel =>Client Role Selector).

**NOTE:** In order to access Workforce Scheduling, you require the May manage Workforce Scheduling security role. For more information on configuring security roles, see “Creating and applying security roles” on page 173.

Using Workforce Scheduling in conjunction with Contact Center Management, you can

- Customize schedules
- Forecast scheduling requirements
- Match an employee’s skills to those skills required for jobs in each schedule
- View the distribution of employees across each schedule
- Print schedule reports

There are two optional applications that work in conjunction with Workforce Scheduling: Schedule Adherence and Employee Portal. For more information on these applications, see “Schedule Adherence” on page 537 and “Employee Portal” on page 542.

Before installing Workforce Scheduling

Before you install and run Workforce Scheduling or view Schedule Adherence monitors in Contact Center Client, you must enable remote SQL Server connections and grant SQL Server permissions to Workforce Scheduling users.

Enabling remote SQL Server connections

To enable remote SQL Server 2005 connections

1. On the Enterprise Server, click **Start==>All Programs==>Microsoft SQL Server 2005==>Configuration Tools==> SQL Server Surface Area Configuration**.
2. Under **Configure Surface Area for localhost**, click **Surface Area Configuration for Services and Connections**.
3. Expand the `<SQL Server name>` tree to Database Engine and select Remote Connections.
4. Select **Local and remote connections**.
5. Select **Using both TCP/IP and named pipes**.
6. Expand the **SQL Server Browser** tree and select **Service**.
7. After **Startup type**, select **Automatic**.
8. Click **Apply**.
9. Click **Start**.
10. Click **OK**.
To enable remote SQL Server 2008 connections:

1. On the Enterprise Server, click **Start=>All Programs=>Microsoft SQL Server 2008=>Configuration Tools=> SQL Server Configuration Manager.**
2. Under SQL Server Configuration Manager (Local), expand SQL Server Network Configuration and click Protocols for <SQL Server instance name>.
3. In the right pane, right-click **Named Pipes** and click **Enable.**
4. In the right pane, right-click **TCP/IP** and click **Enable.**
5. Under **SQL Server Configuration Manager (Local),** click **SQL Server Services.**
6. In the right pane, right-click **SQL Server (<SQL Server instance name>)** and click **Restart.**
7. In the right pane, right-click **SQL Server Browser and click Properties.**
8. Click the **Service tab and after Start Mode, select Automatic.**
9. Click **Apply.**
10. Click **OK.**
11. In the right pane, right-click **SQL Server Browser and click Start.**

**Granting SQL Server permissions**

**NOTE:**
- If your enterprise uses remote SQL and SQL Authentication, you can skip this step, because the required credentials are provided during the configuration of Contact Center Management.
- If you do not currently have a copy of Microsoft SQL Server Management Studio installed, you can download a free copy from http://www.microsoft.com/downloads/details.aspx?FamilyId=C243A5AE-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en

To grant SQL Server 2005 permissions:

1. Click **Start=>All Programs=>Microsoft SQL Server 2005=>SQL Server Management Studio.**
2. Connect to the desired SQL Server.
3. In the left pane, expand the **Security** tree and select **Logins.**
4. If the desired user is not listed, right-click **Logins and select New Login.**
5. After **Login name,** type the name of the new user. Optionally, click **Search** to search for the user name.
6. If you have users configured in groups on your domain, you can optionally add the group to add all users at once.
   - If you want to grant SQL Server permissions to a domain group, you must click Search, click Object Types, and select the Groups check box.
7. Click **User Mapping.**
8. Under **Users Mapped to this login,** select **CCMData.**
9. Click **OK.**
10. Under **Database role membership for: CCMData,** select **db_owner.**
11. Click **OK.**
12. Repeat steps 5-11 for all Workforce Scheduling users.

To grant SQL Server 2008 permissions:

1. Click **Start=>All Programs=>Microsoft SQL Server 2008=>SQL Server Management Studio.**
2. Connect to the desired SQL Server.
3. In the left pane, expand the **Security** tree and select **Logins.**
4. If the desired user is not listed, right-click **Logins and select New Login.**
5. After **Login name,** type the name of the new user. Optionally, click **Search** to search for the user name.
6. If you have users configured in groups on your domain, you can optionally add the group to add all users at once.
   - If you want to grant SQL Server permissions to a domain group, you must click Search, click Object Types, and select the Groups check box.
7. Click User Mapping.
8. Under Users Mapped to this login, select CCMData.
9. Click OK.
10. Under Database role membership for: CCMData, select db_owner.
11. Click OK.
12. Repeat steps 5-11 for all Workforce Scheduling users.

Upgrading from Contact Center Scheduling to Workforce Scheduling

NOTE:

• Before you upgrade to Workforce Scheduling Version 5.7 SP1 from Contact Center Scheduling Version 5.3 or earlier, we recommend you backup your configuration data and store it on a shared storage drive or CD-ROM/DVD-ROM.
• After upgrading from Contact Center Scheduling to Workforce Scheduling, you may need to delete extra holidays that are added to the database during the upgrade. For example, if you previously had three holidays configured in Contact Center Scheduling for Canada Day (July 1 2007, 2008, and 2009), you would have four holidays configured after the upgrade (the three previously configured holidays plus the default holiday configured in Workforce Scheduling).

If you were previously using Contact Center Scheduling Version 5.3 or earlier, when you upgrade to Workforce Scheduling Version 5.7 SP1, your schedule configuration data and scheduled shifts previously created in Contact Center Scheduling are automatically re-created in Workforce Scheduling.

Installing Workforce Scheduling

NOTE: Workforce Scheduling can only be installed on client computers that are part of the same Windows domain as the SQL Server.

To use Workforce Scheduling, you must first install Contact Center Management Version 5.7 SP1. Workforce Scheduling is installed during the installation of Contact Center Management Version 5.7 SP1. To install Workforce Scheduling on a client computer, you must install Client Component Pack. You then install Workforce Scheduling and can then begin configuring scheduling options.

To install Workforce Scheduling
1. In Contact Center Management, click Help=>Software downloads/Installations.
2. To install Client Component Pack, click Client Component Pack.
3. Follow the steps in the wizard to install Client Component Pack.
4. On a client computer, click Start=>All Programs=>Mitel=>Client Role Selector.
5. Using a Supervisor or Power User role, install Workforce Scheduling.

Using Workforce Scheduling

Before you start using Workforce Scheduling read the following sections on how to

• View the Workforce Scheduling user interface
• Understand forecasting concepts
• Understand the Workforce Scheduling process
Viewing the Workforce Scheduling user interface

Figure 18-1 displays scheduling information, such as the employees who are scheduled, employee shift start and end times, the time interval shift totals, and the shift details for each employee.

The Workforce Scheduling user interface is comprised of the following panes:

- People pane
- Time bar pane
- Totals pane
- Schedule details pane

Figure 18-1  Scheduler window
People pane

The people pane is located in the upper-left portion of the scheduler window. The people pane lists the employees included in the schedules you are viewing. (See Figure 18-2.)

Figure 18-2 People pane

<table>
<thead>
<tr>
<th>Full Name</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A, Avril</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C, Mike</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D, Abdal</td>
<td></td>
<td></td>
</tr>
<tr>
<td>G, Dave</td>
<td></td>
<td></td>
</tr>
<tr>
<td>M, Ghislain</td>
<td></td>
<td></td>
</tr>
<tr>
<td>M, Trevor</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Time bar pane

The time bar pane is located in the upper-right portion of the scheduler window. The time bar pane displays a time bar for each scheduled employee. Time bars display the shifts, breaks, jobs, time off, and unavailable periods for employees listed in the people pane. You can view the time bar pane in the following time intervals: 6 hours, 12 hours, 1 day, 2 days, 1 week, 2 weeks, and 1 month. (See Figure 18-3.)

You can view previous or upcoming dates using the horizontal scroll bar under the time bar pane. If you reach the end of the month and want to view dates for the next month, you can click the arrow on the scroll bar to load the schedule for the next month (as indicated by the red square in the following image).

Figure 18-3 Time bar pane

Totals pane

The totals pane appears when you select event totals to view. The totals pane is located in the center of the scheduler window. Each value represents the total number of employees scheduled for an event. (See Figure 18-4.)
Figure 18-4 Totals pane

<table>
<thead>
<tr>
<th>Totals</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>5</th>
<th>5</th>
<th>5</th>
<th>5</th>
<th>5</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scheduled</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>On Break</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>On ACD Job</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>On Non ACD Job</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>At Work</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>4</td>
</tr>
<tr>
<td>Over/Under</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Overtime</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

You can view the following event totals:

**Forecasted**
The *Forecasted* total displays after you apply a forecast to the schedule. This total represents the forecasted number of employees required to handle contact requests and meet the Service Level objectives you specify. You can optionally adjust the Forecasted total in the totals pane. See “Modifying forecast totals in the event totals pane” on page 532.

**Scheduled**
The *Scheduled* total represents the number of employees scheduled for the time you are viewing.

**On break**
The *On break* total represents the number of employees scheduled for a break at a specific time.

**On ACD Job**
The *On ACD Job* total represents the number of employees scheduled to perform ACD work.

**On Non ACD Job**
The *On Non ACD Job* total represents the number of employees scheduled to perform non-ACD work.

**At work**
The *At work* total represents the number of employees scheduled to handle contact requests.

**Over/Under**
The *Over/Under* total represents the difference between the number of employees at work compared to the number of employees forecasted. A value of 4 means 4 additional employees are working compared to the forecasted requirement. A value of (4) means 4 fewer employees are working compared to the forecasted requirement.

**Overtime**
The *Overtime* total represents the number of employees scheduled to perform overtime work.

**Schedule details pane**
The schedule details pane is located at the bottom of the scheduler window. It displays details on scheduled employees. You can modify the start and end times of scheduled events in the schedule details pane. For example, you can adjust the length of a scheduled break. See “Modifying event times and notes in the schedule details pane” on page 532. (See Figure 18-5.)
Figure 18-5  Schedule details pane

<table>
<thead>
<tr>
<th>Employee Name</th>
<th>Schedule</th>
<th>Event Type</th>
<th>Start Date</th>
<th>Start Time</th>
<th>End Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>M, Ghisain</td>
<td>6120 Training</td>
<td>Regular</td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>05:00 PM</td>
</tr>
<tr>
<td>D, Abdallah</td>
<td>6120 Training</td>
<td>Sales</td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>04:00 PM</td>
</tr>
<tr>
<td>G, Dave</td>
<td>6120 Training</td>
<td>Regular</td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>05:00 PM</td>
</tr>
<tr>
<td>A, Avril</td>
<td>6120 Training</td>
<td>Support Weekday</td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>10:00 PM</td>
</tr>
<tr>
<td>M, Trevor</td>
<td>Mat Leave</td>
<td></td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>06:00 PM</td>
</tr>
<tr>
<td>C, Mike</td>
<td>6120 Training</td>
<td>Regular</td>
<td>2/22/2008</td>
<td>08:00 AM</td>
<td>01:00 PM</td>
</tr>
</tbody>
</table>

You can sort the information in the schedule details pane by organizing the headings. The schedule details column headings are as follows:

- **Employee name**—the employee to which the specified time event is scheduled
- **Schedule**—the schedule to which the specified time event is scheduled
- **Event type**—the events to which the specified time event is scheduled
- **Start date**—the start date of each scheduled event. You can modify this parameter in the schedule details pane. Changes are immediately reflected in the time bar pane
- **Start time**—the start time of each scheduled event. You can modify this parameter in the schedule details pane. Changes are immediately reflected in the time bar pane
- **End time**—the end time of each scheduled event. You can modify this parameter in the schedule details pane. Changes are immediately reflected in the time bar pane
- **Paid hours**—the total number of paid hours for the scheduled shift
- **Budget**—the total cost of the scheduled shift
- **Notes**—the notes on scheduled events you enter in this field

Understanding forecasting concepts

Workforce Scheduling assists you in scheduling employees for work and holiday periods. It offers an integrated forecasting component that uses historical data to partially automate the scheduling process. Scheduling is not entirely automated. You may have to modify employee schedules and enter shift and employee variables manually after creating a schedule based on forecasted data.

You schedule employees so the number of incoming calls at any given time typically exceeds the number of employees currently available. This ensures callers experience a slight delay before employees answer their calls. The expected number of incoming calls forecasted for the time of day and day of the week influence scheduling decisions when trying to find the right balance between call volume and available staff.

For detailed information on forecasting variables and how to improve forecasting accuracy, see “Step #3 Forecast the Call Load” on page 28.

For detailed information on Service Level variables and how to calculate the Service Level Percent, see “Understanding the Service Level” on page 22.
Understanding the Workforce Scheduling process

The flowchart in Figure 18-6 provides an overview of how to schedule employees with Workforce Scheduling, such as adding employees to a schedule, configuring schedule parameters, and building a schedule.

You configure employees, agent IDs, agent groups, queues, queue groups, overtime types, time off types, holidays, and skills in YourSite Explorer. After you configure these devices, you must decide if you will use forecasted data to build your schedules. When you build a schedule in Workforce Scheduling using forecasted data, we recommend you associate the schedule with the queue group you will use to perform the forecast. You must ensure that the employees you want to schedule are associated with the queue group you associate to the schedule. In Contact Center Management, you must associate the agent IDs with agent groups, associate the agent groups to queues, and associate the queues to the queue group associated with the schedule. This is recommended so employees in the schedule align with forecasted data. You can optionally associate a schedule to a queue group with different employees, which can be useful for scheduling a new group of employees based on the forecasted data of other employees.

As soon as you start Workforce Scheduling, you can begin creating your schedules. After you log in, you are asked to create or select a schedule. You create a schedule by assigning it a name. If you are using a forecast to build the schedule, you associate the schedule with a queue group.

After you create the schedule, you configure schedule parameters, such as shifts, breaks, jobs, and scheduling preferences/options for each employee.

You can automate the schedule building process with the Schedule Builder tool. It helps you quickly build a schedule, with or without a forecast. If you build schedules using forecasted data, we recommend you use Schedule Builder. Alternately, you can build a schedule manually. This involves inserting or removing events (shifts, breaks, jobs, time off, unavailable periods) and making events recur. You can manually build a schedule based on forecast totals in the Totals pane. After you build a schedule using Schedule Builder, you may need to make a few adjustments.
Figure 18-6 Scheduling with Workforce Scheduling

1. Start YourSite Explorer
2. Create schedules without forecasting

**NO**
- Will you use forecasting to schedule employees?
- Configure employees, overtime, time off, holidays, and skills
- Start Contact Center Scheduling
- Create a schedule
- Add employees to a schedule
- Configure business hours for a schedule
- Add fixed/variable shifts, breaks, and jobs
- Add breaks and jobs to shifts
- Specify warnings for manual scheduling
- Configure scheduling preferences/options for each employee in a schedule

**YES**
- Create schedules using forecasting
- Associate Agent IDs to Agent Groups (in Contact Center Management)
- Associate Agent Groups to Queues (in Contact Center Management)
- Optionally, associate Queues to Queue Groups (in Contact Center Management)
- Associate the schedule to a Queue or Queue Group
- Build a schedule (manually or using Schedule Builder)
- Adjust the schedule as required
- Perform a forecast in Contact Center Management and export it into Contact Center Scheduling
- Build a schedule with a forecast using Schedule Builder
- Print/email Contact Center Scheduling reports (in Contact Center Management)
- Daily schedule maintenance
Workforce Scheduling and your contact center needs

Using Workforce Scheduling, you can schedule your employees to best suit your contact center needs. You can
  • Customize schedules for your contact center groups
  • Forecast scheduling requirements
  • Match employee skills to the skills required for each schedule
  • View the distribution of employees across schedules
  • Print schedule reports

For information on scheduling considerations, and how to calculate the Shrinkage Factor and optimize scheduling, see “Step #5 Schedule agents” on page 32.

Using Workforce Scheduling, you can create schedules for your contact center using a variety of options. Depending on your contact center, some options may be more suitable than others. To help your company use Workforce Scheduling most effectively, we have created configuration scenarios that describe how to implement Workforce Scheduling, based on the type of scheduling used in your contact center.

Each Workforce Scheduling configuration scenario provides a description of the scheduling method and an example of contact centers that typically use that method. Each scenario also provides some tips on how to configure Workforce Scheduling for each style of scheduling. The scenarios include the following scheduling configurations:
  • Assigned shift
  • Availability
  • Rotational
  • Forecast

Assigned shift-based scheduling configuration scenario

The assigned shift scheduling method uses fixed shifts staffed by employees who are permanently assigned to specific shifts. Contact centers that use assigned shift scheduling have consistent call volumes. Employees are primarily full-time staff and are guaranteed a specific number of hours of employment per week. Typically, you plan a schedule three to six months in advance with assigned shift scheduling.

Contact centers ideal for assigned shift scheduling

Assigned shift scheduling is best suited to contact centers that have a steady and predictable call volume, such as a contact center that runs a conventional “nine to five” operation. Examples of contact centers that use assigned shift scheduling include banks and government offices.
To configure Workforce Scheduling for an assigned shift scheduling environment
  • Create fixed shifts
  • Use shift names that describe a shift's purpose, such as "9 to 5 shift" or "1st shift"
  • Use mass recurrence to repeat scheduled events for multiple weeks
  • Configure employee hours using shift assignment by day of week

Availability-based scheduling configuration scenario

The availability scheduling method uses fixed shifts, but unlike assigned shift scheduling, the employees that work a given shift are not permanently attached to that shift. Contact centers that use availability scheduling fill shifts using a pool of employees.

A contact center supervisor sets staff availability based on day of week and time of day. When staffing a shift, the supervisor can assign any employee who is listed as available for that date and time to the shift. Typically, you plan a schedule two to four weeks in advance when you use availability scheduling.
Contact centers ideal for availability scheduling

Availability scheduling is best suited to contact centers driven by shifts, such as hotels or companies that focus on catalog sales. These contact centers have a specific number of shifts that can be filled by any qualified employees who are available. This type of schedule is frequently used with contact centers that operate 24/7.

To configure Workforce Scheduling for an availability scheduling environment

- Primarily use fixed shifts, but do not assign employees to specific shifts
- Assign employees all of the possible shifts they can work
- Set employee availability by day of week and time of day
- Use filters to assign the best employee available for a shift, based on skill set, seniority, or personal priority number

Rotational-based scheduling configuration scenario

The rotational scheduling method consists of two or more unique schedules that recur at defined intervals. For example, if a contact center rotates four schedules, the week one schedule repeats in week five, week nine, and so on. The rotational scheduling method enables contact center schedules to be consistent in the long-term, while allowing shifts to vary from week to week.

Contact centers ideal for rotational scheduling

Rotational scheduling is best suited to contact centers that require specific employees to cover unique periods of time, such as medical clinics that are open on weekends. If each contact center employee is required to work one weekend a month, a rotational schedule can ensure an even distribution of weekend work for each employee.

To configure Workforce Scheduling for a rotational scheduling environment

- Primarily use assigned shifts with defined employees. The staff changes from one schedule rotation to the next ensure fair coverage on nights, weekends, and holidays
- Recur the shifts multiple times based on the number of rotations
- Manually track and adjust which employees are assigned to each rotation; Workforce Scheduling does not create a balanced schedule so you will need to make changes if you want to ensure the schedule is fair
- Optionally use rotational scheduling in conjunction with other schedule types. For example, create a schedule that uses the assigned shift method to cover Monday to Friday shifts and a second schedule that uses the rotational shift method to cover shifts such as weekends or holidays

Forecast-based scheduling configuration scenario

The forecast scheduling method references historical data to create schedules. Contact centers that use forecast scheduling have call volumes that can change considerably over relatively short periods of time, resulting in inconsistent scheduling.

Forecast scheduling provides more flexibility than other scheduling methods since shifts are not defined. A contact center that uses forecast scheduling does not have a fixed staff or fixed hours, as both change based on the expected call volume. Typically, you plan a schedule one to two weeks in advance with forecast scheduling.
Contact centers ideal for forecast scheduling
Forecast scheduling is best suited to contact centers driven by call volume, such as companies that focus on sales campaigns, promotions, or seasonal sales.
To configure Workforce Scheduling for a forecast scheduling environment
• Generate historical data specific to the type of event you are scheduling (for example, to create a schedule for a winter sales campaign, use historical data from a previous winter campaign)
• Create shifts with flexible start and end times to provide Schedule Builder with the greatest number of options when populating the shifts with employees
• Remember that shift variables, such as start/end times and breaks, will vary for employees on a day-to-day basis
• Due to the variety of shift start and end times, create breaks based on the Time to qualify variable
• Do not configure availability or shift assignment

Before you start scheduling
You use Workforce Scheduling in conjunction with YourSite Explorer. Before you can schedule employees with Workforce Scheduling, you must add and configure them in YourSite Explorer.
To configure employee information for scheduling
1. Select the employee or employees you want to configure.
2. Specify the employee role.
   See “Configuring employee roles” on page 166.
3. Specify employee work hours.
   See “Configuring employee work hours” on page 166.
4. Specify employment status.
   See “Configuring employment status” on page 166.
5. Specify employee payroll information.
   See “Configuring employee payroll information” on page 166.
6. Assign shifts to the employee.
   See “Configuring employee availability” on page 167.
7. Specify employee availability.
   See “Configuring employee availability” on page 167.
8. Specify time off information
   See “Configuring employee time off” on page 167.
9. Specify employee skills
   See “Configuring employee skills” on page 168.

Before you can make schedules in Workforce Scheduling, you must configure the following scheduling options in YourSite Explorer
1. Holidays
   See “Configuring holidays” on page 168.
2. Overtime types
   See “Configuring overtime types” on page 169.
3. Time off types
   See “Configuring time off types” on page 169.
4. Skills
   See “Configuring skills” on page 170.
Selecting a scheduling method

You can build schedules in Workforce Scheduling:
- Using a forecast
- Manually

The setup you require depends on the scheduling method you choose. If you incorporate forecast data when you build a schedule, you must build the schedule using Schedule Builder.

Scheduling using forecast data

**NOTE:** When you use forecast data to build a schedule, you can apply historical data from any queue or queue group to the schedule. It is not necessary to use historical data from the queue group with which the schedule is associated. Forecast data is simply the number of required agents. It can be used in schedules which are not associated with a queue or queue group.

Before you build a schedule using a forecast, as a best practice, we recommend you associate your schedule with a queue group. You should also ensure that the employees to be scheduled are associated with this queue group.

In YourSite, you
1. Associate the agent IDs with an agent group.
   See “Associating agents with agent groups (in the Contact Center Management website)” on page 140.
2. Associate the agent group with a queue.
   See “Associating queues with queue groups (in YourSite Explorer)” on page 152.
3. Associate the queue with the queue group (that you will associate with the schedule).
   See “Associating queues with queue groups (in YourSite Explorer)” on page 152.

Scheduling manually

You have the most flexibility when you build a schedule manually. However, this can be time consuming if you must schedule a large number of employees or if you must create a schedule covering a long time period where shift assignments do not recur. You can also use manual scheduling to tweak schedules you build with Schedule Builder. See “Creating and adjusting schedules manually” on page 529.

Schedule setup and customization

**NOTE:** In order to access Workforce Scheduling, you require the May manage Workforce Scheduling security role. For more information on configuring stitchery roles, see “Creating and applying security roles” on page 173.

In order to build a schedule in Workforce Scheduling, whether you build your schedule with forecasting or you build it manually, you must perform the following tasks to set up and customize your schedule:
1. Start YourSite Explorer.
2. Configure employees, overtime types, time off types, holidays, and skills.
3. Start Workforce Scheduling.
4. Configure schedule options.
5. Configure shifts, breaks, and jobs.
6. Assign shifts to schedules.
7. Assign shifts to employees.
8. Specify scheduling preferences/options for each employee in the schedule.
9. Specify schedule warnings.
Starting Workforce Scheduling on a client computer

To log on to Workforce Scheduling

1. Click Start=>Programs=>Mitel=>Workforce Scheduling.
The Login window appears.
2. Type your user name and password.
3. Verify or type the IP address of the Enterprise Server.
4. Optionally, select the Remember my credentials check box.
5. Click Login.
The first time you log on, or if you have not created any schedules, the scheduler window appears.
See “Configuring schedule options” on page 514.
Otherwise, if schedules exist, the Load schedule window appears.
See “Loading schedules” on page 530.

Configuring schedule options

NOTE:
• If you associate a schedule with a queue group, only those employees included in the selected queue
  group can be configured in the schedule. (Agents are members of agent groups, which are
  associated with queues that are members of queue groups.)
• If you do not associate a schedule with a queue group, you can schedule any employee whose profile
  enables you to schedule them in Workforce Scheduling. See “Adding employees” on page 132.

Before you can build a schedule, either manually or using Schedule Builder, you must create a new schedule.

To create a new schedule, you must:
• Name the schedule
• Associate the schedule with a queue or queue group (optional)
• Add employees to the schedule
• Configure business hours for the schedule
• Activate/Deactivate the schedule

You can create new schedules and configure all Workforce Scheduling options using the Schedule wizard.
Optionally, use the Schedule tool to add, delete, rename, and activate/deactivate schedules. Within the
Schedule configuration window, you can click Apply at any time to apply changes to the schedule without
closing the Schedule configuration window.

Configuring scheduling options using the Schedule wizard

You can create new schedules and configure all Workforce Scheduling options using the Schedule wizard.

To configure scheduling options using the Schedule wizard

1. Click the Configuration tab.
2. In the Schedules group, click Schedule wizard.
3. Follow the steps in the Schedule wizard to configure schedules, business hours, employees, fixed/
   variable shifts, fixed/variable breaks and jobs, and fixed/variable shift assignments.
4. Click Finish.
Creating schedules

To create a schedule

1. On the Application menu or ribbon, click New schedule.
2. After Schedule name, type a name for the schedule.
3. Under Employee association, select either All employees, Employees associated with this queue group only, or Employees associated with this queue only.
   - If you select Employees associated with this queue group, select a queue group from the list.
   - If you select Employees associated with this queue, select a queue from the list.
4. If this schedule will be an active schedule, select the This schedule is active check box. Otherwise, select the This schedule is used for planning purposes only check box.
5. Click OK.
6. Select the check boxes of the employees to add to the schedule.
7. Click OK.

See “Configuring business hours for schedules” on page 515.

Adding employees to schedules

Schedules that contain fewer than 100 employees are easiest to manage. Each employee should belong to one active schedule only. However, if employees belong to more than one schedule, you can still view the shifts for which they are scheduled.

To add an employee to a schedule

1. Click the Configuration tab.
2. In the Schedules group, click Select employees.
3. After Schedule, select a schedule.
4. If you want to group employees in the list by supervisor, select the Group by supervisor check box.
5. Select the check boxes of the employees to add to the schedule.
6. Click OK.

Configuring business hours for schedules

You can specify different business hours for each schedule. By default, you are warned if you try to schedule shifts outside business hours.

To configure the business hours of a schedule

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, select Schedules.
4. Under Schedules, select the schedule to modify.
5. After First day of the schedule week, specify the day that the schedule will begin.
6. Specify business hours for the schedule.
   - If you want to schedule employees 24 hours a day, seven days a week, under Business hours, click Open 24/7.
   - After Open, select the check boxes of the days of the week to schedule.
   - After From, specify the start times for each day of the week to schedule.
   - After To, specify the end times for each day of the week to schedule.
7. Click OK.
Renaming schedules

You can rename a schedule without losing any information associated with the schedule.

To rename a schedule
1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. Under **Schedules**, select the schedule to rename.
4. Click **Rename**.
5. After **Name**, type a new name for the schedule.
6. Click **Rename**.
7. Click **OK**.

Deleting schedules

**CAUTION:** Deleting a schedule deletes all of the information associated with that schedule. This cannot be undone.

To delete a schedule
1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. Under **Schedules**, select the schedule to delete.
4. Click **Delete**.
5. Click **Yes**.
6. Click **OK**.

Activating / Deactivating schedules

You can activate or deactivate a schedule at any time. Deactivating schedules is useful for performing “what-if” scenarios, for seasonal schedules, and for retaining schedules to be used at a later time.

To activate or deactivate a schedule
1. On the Application menu or ribbon, click **Activate / Deactivate**.
   The **Activate / Deactivate Schedule** dialog box opens.
2. Select the schedule that you want to activate / deactivate.
   You can load multiple active schedules. However, if you load an inactive schedule, all other schedules close.
3. Click **Activate** to activate an inactive schedule or **Deactivate** to deactivate an active schedule.
4. Click **Close**.

Configuring shifts

A shift represents work hours on a given day for an employee. You can assign shifts to specific employees for any day of the week. You can create several shifts for one or more schedules. There are two types of shifts: fixed shifts and variable shifts. Fixed shifts have a fixed start time and duration. Variable shifts are based on the following shift variables:

- **Typical hours**—the number of work hours for the shift
- **Minimum hours**—the minimum number of hours for the shift
- **Maximum hours**—the maximum number of hours for the shift
- **Minimum start**—the time of day after which the shift must start
- **Maximum start**—the time of day by which the shift must start
- **Color**—the color in which the shift appears in the time bar pane
You configure the following shift options using the Schedule tool:

- Add fixed shifts
- Add variable shifts
- Rename shifts
- Delete shifts

### Adding fixed shifts

To add a fixed shift

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. In the left pane, click **Shifts**.
4. In the right pane, click the **FixedShifts** tab.
5. In the right pane, click **Add**.
6. After **Name**, type a name for the fixed shift.
7. Click **Create**.
8. Under **Start time**, type the start time of the fixed shift.
9. Under **Duration**, type the duration of the fixed shift.
10. Under **Color**, select a color for the fixed shift.
11. Click **OK**.

### Adding variable shifts

To add a variable shift

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. In the left pane, click **Shifts**.
4. In the right pane, click the **VariableShifts** tab.
5. In the right pane, click **Add**.
6. After **Name**, type a name for the variable shift.
7. Click **Create**.
8. Under **Minimum hours**, type the minimum number of hours in a day you can schedule the shift.
9. Under **Typical hours**, type the typical number of hours in a day you can schedule the shift.
10. Under **Maximum hours**, type the maximum number of hours in a day you can schedule the shift.
11. Under **Minimum start**, type the time of day after which the shift must start.
12. Under **Maximum start**, type the time of day by which the shift must start.
13. Under **Color**, select a color for the variable shift.
14. Click **OK**.

### Renaming shifts

You can rename fixed/variable shifts without losing any information associated with the shifts.

To rename a shift

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. Click the **Shifts** tab.
4. If you want to rename a fixed shift, click the **Fixed shifts** tab. Otherwise, to rename a variable shift, click the **Variable shifts** tab.
5. Under **Name**, click the name of the shift to rename.
6. Type a new name for the shift.
7. Click **OK**.
Deleting shifts

CAUTION: Deleting a shift deletes all of the instances of that shift, including those inserted in schedules.

To delete a shift

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click the Shifts tab.
4. If you want to delete a fixed shift, click the Fixed shifts tab. Otherwise, to delete a variable shift, click the Variable shifts tab.
5. Under Name, select the shift to delete.
6. Click Delete.
7. Click Yes.

Configuring breaks

You configure the following break options using the Schedule tool:

- Add fixed breaks
- Add variable breaks
- Rename breaks
- Delete breaks

Examples of common breaks are morning break, lunch, afternoon break, and dinner break.

Adding fixed breaks

To add a fixed break

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Breaks.
4. In the right pane, click the Fixed Breaks tab.
5. Click Add.
6. After Name, type a name for the break.
7. Click Create.
8. If the break is a paid break, enable the check box under Is paid.
9. Under Start time, type the time at which the break must start.
10. Under Duration, type the amount of time allotted for the break.
11. Under Color, select a color for the break.
12. Click Ok.

Adding variable breaks

To add a variable break

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Breaks.
4. In the right pane, click the Variable Breaks tab.
5. Click Add.
6. After Name, type a name for the variable break.
7. Click Create.
8. Under Duration, type the amount of time allotted for the break.
9. If the break is a paid break, select the check box under Paid.
10. Under Time to qualify, type the minimum duration of a shift before you can schedule the break.
11. Under **Must start time**, type the amount of time from the beginning of the shift that employees must work before they are entitled to the break.
12. Under **Must end time**, type the amount of time from the beginning of the shift by which employees must complete the break.
13. Under **Minimum time before end of shift**, type the amount of time before the end of the shift that the break must end.
14. Under **Color**, select a color for the shift.
15. Click **OK**.

### Renaming breaks

You can rename a break without losing any information associated with the break.

To rename a break

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. In the left pane, click **Breaks**.
4. If you want to rename a fixed break, in the left pane, click the **Fixed Breaks** tab. Otherwise, to rename a variable break, click the **Variable Breaks** tab.
5. Under **Name**, click the name of the break to rename.
6. Type a new name for the break.
7. Click **OK**.

### Deleting breaks

**CAUTION:** Deleting a break deletes all of the instances of the break, including those inserted in schedules.

To delete a break

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Schedule**.
3. In the left pane, click **Breaks**.
4. If you want to delete a fixed break, in the left pane, click the **Fixed Breaks** tab. Otherwise, to delete a variable break, click the **Variable Breaks** tab.
5. Under **Name**, select the name of the break to delete.
6. Click **Delete**.
7. Click **OK**.

### Configuring jobs

Use jobs in a schedule to differentiate the non-ACD tasks that employees perform. You create jobs for a specific shift. If the job requires a specific set of skills, you can associate skills to jobs. After you associate skills to jobs, you can compare the skill (and skill level) of the employees to the skill required to perform a job. This will ensure the employees you schedule have the appropriate skills for their assigned jobs.

You configure the following job options using the Schedule tool:

- Add fixed jobs
- Add variable jobs
- Rename jobs
- Delete jobs
Adding fixed jobs

To add a job for a fixed shift

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. In the right pane, click the Fixed Jobs tab.
5. Click Add.
6. After Name, type the name of the job.
7. Click Create.
8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
9. Under Start time, type the time at which the job must start.
10. Under Duration, type the duration of the job.
11. Under Color, select a color for the job.
12. Click OK.

Adding variable jobs

To add a job for a variable shift

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. In the right pane, click the Variable Jobs tab.
5. Click Add.
6. After Name, type the name of the job.
7. Click Create.
8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
9. Under Color, select a color for the job.
10. Click OK.

Renaming jobs

You can rename a job without losing any information associated with the job.

To rename a job

1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. If you want to rename a fixed job, click the Fixed Jobs. Otherwise, to rename a variable job, click the Variable Jobs tab.
5. Under Name, click the name of the job to rename.
6. Type a new name for the job.
7. Click OK.
Deleting jobs

CAUTION: Deleting a job deletes all of the instances of the job, including where it is inserted in schedules.

To delete a job
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. If you want to delete a fixed job, click the Fixed Jobs. Otherwise, to delete a variable job, click the Variable Jobs tab.
5. Under Name, select the name of the job to delete.
6. Click Delete.
7. Click Yes.

Adding breaks or jobs to shifts

To add a break or a job to a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click Assignments.
4. In the right pane, click the Breaks and Jobs tab.
5. Under Shifts, select the shift for which you will add shifts to.
6. Under Breaks, select the break to add to a shift.
7. Click > to assign the break to the shift.
8. Under Jobs, select the job to add to a shift.
9. Click > to assign the job to the shift.
10. Click OK.

Removing breaks and jobs from shifts

To remove a break or a job from a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click Assignments.
4. In the right pane, click the Breaks and Jobs tab.
5. Under Shifts, select the shift for which you will remove breaks/jobs from.
6. Under Breaks, select the break to remove from the shift.
7. Click < to remove the break from the shift.
8. Under Jobs, select the job to remove from the shift.
9. Click < to remove the job from the shift.
10. Repeat steps 5-9 to remove additional breaks and/or jobs from shifts.
11. Click OK.

Assigning shifts to schedules

NOTE: Schedule Builder uses the shifts you assign, combined with the employees’ availability and shift assignment, to schedule shifts (or variations of them).

To assign shifts to schedules
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Assignments.
4. In the right pane, click the **Shifts** tab.
5. Under **Schedules**, select the schedule to which you will add shifts.
6. Under **Fixed Shifts**, select the fixed shift to add to the schedule.
7. Click > to assign the shift to the schedule.
8. Under **Variable Shifts**, select the variable shift to add to the schedule.
9. Click > to assign the shift to the schedule.
10. Repeat steps 6-9 for each shift you want to add to a schedule.
11. Click **OK**.

### Assigning shifts to employees

To assign a shift to an employee:

1. Click the **Configuration** tab.
2. In the **Schedules** group, click **Configure employees**.
3. In the left pane, under **Schedules**, select the schedule containing the employee(s) to which you will assign shifts.
4. Under **Employees**, select the employee to which you will add shifts.
5. Under **Shift Assignment**, select the checkboxes of the shifts that will be available to this employee.
6. Repeat steps 4-6 for each employee to which you will assign shifts.
7. Click **OK**.

### Configuring event display preferences

To make events easy to identify at a glance, you can specify how you want to display the scheduled events.

You can specify the following event display preferences:

- **Time bar content display**—provides descriptions, notes, or icons for scheduled events in the time bar pane
- **Smallest scheduling interval**—the smallest increment with which you insert events into the time bar pane
  
  **NOTE:** The default scheduling interval is five minutes. Schedule Builder uses this setting when scheduling employees. The smaller the interval, the longer Schedule Builder will take to automatically generate a schedule.
- **Default shift color**—the color for all of the shifts in the time bar pane. To override the default shift color, see “Configuring shifts” on page 516
- **Default break color**—the color for all of the breaks in the time bar pane. To override the default break color, see “Renaming breaks” on page 519
- **Default job color**—the color for all of the jobs in the time bar pane. To override the default job color, see “Configuring jobs” on page 519
- **Default time off color**—the color for all of the time off types in the time bar pane. To override the default job color, see “Configuring jobs” on page 519
- **Unavailable color**—the color for unavailable periods in the time bar pane
- **Tool tip display**—provides event information in tool tips on the time bar pane. The tool tip appears as a series of brackets depending on the information criteria you select
- **Time display**—the time format of the time bar pane. For example, 3 o’clock in the afternoon appears as 3 P.M. if you select **12 Hours**, or 15 if you select **24 Hours**

### Configuring the time bar display

You can select from the following three time bar display options:

- **Icon**—refers to the icons of the scheduled shifts, time off events, and unavailable periods in the time bar pane
- **Type name**—refers to the names of the scheduled jobs in the time bar pane
- **Type notes**—refers to the notes of the scheduled jobs in the time bar pane
To specify how events display in the time bar
1. On the application menu, click **Preferences**.
2. Click the **Display** tab.
3. Under **Time bar content display**, select the time bar content to display for Shifts, Jobs, Breaks, Time off, and Unavailable periods.
4. Click **OK** to save and close the Preferences window.

**Configuring the smallest scheduling time interval**

By default, events are snapped to the time bar grid in 30 minute increments. However, you can adjust the snap-to-grid interval to 5, 15, 30, or 60 minutes. Set the smallest scheduling time interval to the minimum number of minutes you want to insert events into a schedule. For example, if you select 15 minutes as the smallest scheduling interval, you cannot insert events for an employee in increments smaller than 15 minutes.

**NOTE:** The default scheduling interval is five minutes. Schedule Builder uses this setting when scheduling employees. The smaller the interval, the longer Schedule Builder will take to automatically generate a schedule.

To configure the smallest scheduling time interval
1. On the application menu, click **Preferences**.
2. Click the **General** tab.
3. Under **Scheduling preferences**, after **Smallest scheduling interval**, select the snap-to-grid time interval.
4. If you want to prevent the user from manually making any change that would trigger a warning, select the **Warnings are hard limits for the user** check box.
5. Click **OK** to save and close the Preferences window.

**To prevent users from manually making changes that trigger warnings**

You can configure Workforce Scheduling to prevent users from making changes that trigger warnings.

To prevent users from manually making changes that trigger warnings
1. On the application menu, click **Preferences**.
2. Click the **General** tab.
3. Select the **Warnings are hard limits for the user** check box.
4. Click **OK** to save and close the Preferences window.

**Configuring the default colors on the time bar**

To configure the default colors used for events on the time bar
1. On the application menu, click **Preferences**.
2. Click the **Display** tab.
3. Under **Default time bar colors**, after **Default shift color**, select a color.
4. Repeat step 3 for **Default break color**, **Default job color**, **Default time off color**, and **Unavailable color**.
5. Click **OK** to save and close Preferences window.
Configuring the time format

There are two time formats you can select from: the 24 hour international format or the 12 hour format which uses A.M. and P.M. to indicate morning and afternoon. For example, 3 o’clock in the afternoon appears as 15 if you select the 24 hour time format or 3 P.M. if you select the 12 hour time format.

To configure the time format
1. On the application menu, click Preferences.
2. Click the General tab.
3. After Hour format, select either 12 hours or 24 hours.
4. Click OK.

Configuring tool tip display

You can specify the following information in tool tips for shifts, jobs, breaks, time off events, unavailable periods, and shadow events:

• Schedule name—provides the name of the schedule in which the event appears.
• Is recurring—displays if the event recurs.
• Type—provides the name of the event.
• Type name—states if the event is a shift, job, break, time off event, unavailable period, or shadow event.
• Start/End Time—provides the start and end time of the event.
• Event Notes—provides any notes from the detail grid for the event.

To configure the tool tip display
1. On the application menu, click Preferences.
2. Click the Display tab.
3. Under Tool tip display, select the check boxes for the tool tips to display.
4. Click OK.

Configuring warnings

Warnings notify you when you try to schedule events outside of your scheduling parameters.

You can set the following warnings:

• Schedule warnings
• Shift warnings
• Break warnings
• Job warnings
• Overtime warnings
• Time Off warnings
• Employee warnings
• Schedule Builder warnings
• Employee selection warnings

To configure warnings
1. On the application menu, click Preferences.
2. Click the Warnings tab.
3. Ensure the check boxes of the warnings you want to configure are selected.
   See Table 18-1.
4. Click OK.
### Table 18-1 Warnings

<table>
<thead>
<tr>
<th>Warning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scheduling work on company holidays</td>
<td>notifies you when events are scheduled on company holidays</td>
</tr>
<tr>
<td>Scheduling work outside business hours</td>
<td>notifies you when you try to schedule events outside of your contact center’s business hours</td>
</tr>
<tr>
<td>When scheduling outside a person’s availability</td>
<td>notifies you when you try to schedule employees who are not available at the specified time</td>
</tr>
<tr>
<td>Violates length of service qualifications</td>
<td>notifies you when an employee has worked fewer or more months required to qualify for a specific type of time off</td>
</tr>
<tr>
<td>Exceeds accrued hours</td>
<td>notifies you when an employee is scheduled for more time off hours than is available to that employee at that time</td>
</tr>
<tr>
<td>Exceeds maximum scheduling limit</td>
<td>notifies you when an employee is scheduled for more time off hours specified for that type of time off</td>
</tr>
<tr>
<td>Less than minimum scheduling limit</td>
<td>notifies you when an employee is scheduled for fewer time off hours specified for that type of time off</td>
</tr>
<tr>
<td>Employee does not have required skills</td>
<td>notifies you when an employee does not have the required skills for the job for which they are scheduled</td>
</tr>
<tr>
<td>Exceeds daily maximum work hours</td>
<td>notifies you when an employee is scheduled for more hours in a day than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Below daily minimum work hours</td>
<td>notifies you when an employee is scheduled for fewer hours in a day than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Exceeds weekly maximum work hours</td>
<td>notifies you when an employee is scheduled for more hours in a week than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Below weekly minimum work hours</td>
<td>notifies you when an employee is scheduled for fewer hours in a week than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Exceeds maximum hours</td>
<td>notifies when an employee is scheduled for a shift more hours in a day than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Below minimum hours</td>
<td>notifies you when an employee is scheduled for a shift fewer hours in a day than defined by the parameter for that shift</td>
</tr>
<tr>
<td>Start time outside of specified range</td>
<td>notifies you when an employee’s shift is scheduled to start before (minimum) or after (maximum) the parameters defined for that shift</td>
</tr>
<tr>
<td>Is within minimum time between shifts</td>
<td>notifies you when an employee is scheduled to start another shift too soon following the one previously completed</td>
</tr>
<tr>
<td>Below hours worked to qualify</td>
<td>notifies you when an employee is scheduled for a break before working enough hours after the last break in that shift to qualify for another break</td>
</tr>
<tr>
<td>Starting before earliest start time</td>
<td>notifies you when an employee is scheduled for the first break in a shift before a break can be taken</td>
</tr>
</tbody>
</table>
Schedule creation

You can create and customize schedules in Workforce Scheduling using specific parameters that suit the needs of your contact center. You can build schedules manually or with the Schedule Builder tool. Schedule Builder automates the schedule building process. It uses pre-defined employee and schedule options to create schedules. See “Schedule setup and customization” on page 513.

Schedule Builder helps you build a schedule with or without forecast data. However, you must use the Schedule Builder if you want to build a schedule with forecast data. See “Forecasting tool” on page 276.

You can also use manual scheduling to modify schedules you build with Schedule Builder. See “Creating and adjusting schedules manually” on page 529.

**NOTE:** After you generate a schedule with Schedule Builder, you must accept or reject schedule changes before you can generate another schedule.

Schedule Builder uses the following parameters to create a schedule automatically:

- Date/time range
- Shifts
- Breaks
- Forecast data
- Business hours
- Employees
- Employee scheduling preferences
- Scheduling options
- Shift options
- Schedule algorithm options

### Building schedules with Schedule Builder

**NOTE:** After you generate a schedule with Schedule Builder, you must accept or reject schedule changes before you can generate another schedule.

To build a schedule with Schedule Builder

1. Click the **Tools** tab
2. In the Schedule Builder group, click **Manual**.
3. Under **Schedule name**, select a schedule.
4. Specify the scheduling parameters on each tab of the Schedule Builder tool.
5. Click **Build**.
   A dialog box appears reminding you that changes to the schedule will not be committed to the database until you click **Accept Schedule**.

---

**Table 18-1  Warnings**

<table>
<thead>
<tr>
<th>Warning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>End after latest end time</td>
<td>notifies you when an employee is scheduled for the last break in a shift after a break can be taken</td>
</tr>
<tr>
<td>Removing an employee from a schedule</td>
<td>notifies you when you attempt to delete an employee from the schedule</td>
</tr>
<tr>
<td>Accepting a generated scheduler</td>
<td>notifies you when you attempt to save a schedule you have built</td>
</tr>
<tr>
<td>Scheduled shift will cause overtime</td>
<td>notifies you when a shift qualifies an employee for overtime</td>
</tr>
</tbody>
</table>
6. Click OK. The Accept Schedule and Reject Schedule buttons appear in the toolbar.
7. Verify the schedule.
8. Make any required modifications manually.
9. Click Accept schedule to save the new schedule.

NOTE:
- After you click Accept Schedule, the schedule is live in the database and the Accept Schedule button disappears. If you click Reject Schedule, the automatically generated schedule and any manual modifications are deleted from the schedule. See “Creating and adjusting schedules manually” on page 529.
- If there are any conflicts, a dialog box appears stating the number of conflicts. You cannot save a schedule with conflicts. Click Yes to delete the conflicts and accept the schedule, or click No to adjust the schedule. When you have resolved the conflicts, click Accept Schedule again to save the schedule.

Configuring the date and time range
To configure the date and time range for a schedule using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Dates and times, on the Date / Time tab, select the date range of the schedule.
3. Under Time, select either Use business hours, 24/7, or Custom.
4. If you selected Custom in the previous step, select the time the schedule starts and ends each day.
5. If you want to exclude dates from the schedule, click the Exclusion tab.
6. Hold down CTRL and then click the dates to exclude.

Scheduling shifts
To schedule shifts using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule/Optimize, select the Shifts check box.
3. Under Event selection, on the Shift selection tab, select the check boxes of the shifts to add to the schedule.
4. Click the Shift & Break options tab.
5. Under Shift options, specify how shifts will be distributed.
   - If you want to count existing shifts when determining the number of employees to be scheduled, select the The Schedule Builder counts existing shifts when determining the number of employees which must be scheduled check box.
   - If you want to optimize existing unlocked shifts, select the Allow Schedule Builder to optimize existing unlocked shifts check box.
   - If you want to optimize existing locked shifts, select the Allow Schedule Builder to optimize existing locked shifts check box.
   - If you want to schedule unassigned shifts for times when there are not enough employees available to satisfy the scheduling requirements, select the Generate unassigned shifts when not enough employees are available to satisfy the schedule requirements check box.
   - If you want to ignore employee shifts assignments when building the schedule, select the Ignore employee shift assignments check box.
Scheduling breaks
To schedule breaks using Schedule Builder

1. In Schedule Builder, click the General tab.
2. Under Schedule/ Optimize, select the Breaks check box.
3. Under Event selection, on the Break selection tab, select the check boxes of the break types to add to the schedule.
4. Click the Shift & Break options tab.
5. Under Schedule/ Optimize breaks, select the check boxes of the shift types to apply breaks.
6. If you want to schedule employees to cover for breaks, select the Cover for breaks check box.
7. Under Distribution, specify how breaks will be distributed.
   - If you want to reduce the number of concurrent breaks, select Reduce the number of concurrent breaks.
   - If you want to distribute breaks using a fixed offset, select Schedule breaks and specify the number of minutes apart.

Generating schedules with forecast data
To build a schedule with forecast data using Schedule Builder

1. In Schedule Builder, click the General tab.
2. Under Schedule Builder method, after Method, select Forecasted data.
3. If you want fewer employees scheduled than are forecasted, move the slider towards Under schedule.
4. If you want more employees scheduled than are forecasted, move the slider towards Over schedule.
5. If you want to adjust the number of forecasted employees, next to Increase/decrease the number of forecasted employees by, enter a number.

Generating schedules without forecast data
To build a schedule without forecast data using Schedule Builder

1. In Schedule Builder, click the General tab.
3. After Number of employees to schedule, enter a number.
4. If you want fewer employees scheduled than are forecasted, move the slider towards Under schedule.
5. If you want more employees scheduled than are forecasted, move the slider towards Over schedule.

Generating schedules for your entire workforce
To build a schedule for your entire workforce using Schedule Builder, regardless of employee availability

1. In Schedule Builder, click the General tab.
3. If you want to enable employee filtering, select the Enable employee filtering check box.

Selecting employees
To select the employees you want to schedule using Schedule Builder

1. In Schedule Builder, click the Employee filtering tab.
2. If you want to filter employees by agent group, under Agent group, select the check boxes of the agent groups to schedule.
3. If you want to filter employees by their skills, under Skill, select the check boxes of the required skills. Otherwise, skip to step 6.
4. Under the list of available skills, select an operand.
   • If the employees must have a skill level greater or equal to the skill level required, select \( \geq \).
   • If the employees must have a skill level lower or equal to the skill level required, select \( \leq \).
   • If the employees must have a skill level exactly equal to the skill level required, select \( = \).
5. If you want to filter employees by name, under Select employees with this name, type an employee's name.
6. If you want to select specific employees, under Selected employees, select the check boxes of the employees to schedule.
7. Click the Employee sorting tab.
   \textbf{NOTE:} You must configure the employee payroll information in order to select the seniority and pay rate parameters.
8. If you want to prioritize how shifts are distributed to employees, select the Use employee sorting check box, and select the criteria with which to sort employees.
9. If you want to assign or edit employee priority numbers, under Employee priority, select an employee.
10. Under Priority, type a personal priority number.
11. Click the Overrides tab.
12. If you want to override employee work hour preferences, under Work hours, select the check boxes to override daily work hours, weekly work hours, and the minimum time between shifts.
13. If you want to override employee availability, under Availability, select the check boxes to override employee availability and unavailable events currently applied to the schedule.
14. If you want to override scheduled time off, under Time off, select the Override time off events currently applied to the schedule check box.

Configuring scheduling options

To configure schedule options Schedule Builder uses to create a schedule

1. In Schedule Builder, click the Advanced options tab.
2. Under Schedule algorithm performance, specify the settings Schedule Builder will use to build the schedule.
3. If you want to optimize break distribution, under Optimization types, select the Optimize break distribution check box.
4. If you want to optimize shift placement, select the Optimize shift placement check box.
5. If you want to optimize shift size, select the Optimize shift size check box.
6. If you want to balance the distribution of employee shifts over the week, select the Balance over the week check box.
   Selecting this option ensures that Schedule Builder does not completely fill the requirements of the first few days of the schedule and understaff employee requirements by the end of the week.

Creating and adjusting schedules manually

You can create entire schedules manually. However, if you must schedule a large number of employees it can be quite complicated and time consuming. Schedule Builder automates the process and builds schedules for you. You can manually adjust schedules created with Schedule Builder. You can create and adjust schedules manually in the following ways:

• Load a schedule
• Populate a schedule with events
• Drop insert an event
• Drag insert an event
• Recur an event
• Mass recur an event
• Mass delete an event
• Mass apply time off
• Modify a forecast total
• Modify event times or notes
Loading schedules

**NOTE:** Your access rights determine which schedules you can view, modify, or manage.

To load a schedule

1. On the Application menu or ribbon, click **Load schedules**.
2. Under **Please select the schedule(s) you want to download**, select the schedule(s) to load.
3. If you want to load all schedules, select the **Select all** check box.
4. Click **Load**.

Populating schedules with events

**NOTE:**
- Your access rights determine which schedules you can view, modify, or manage.
- For ease of use and accuracy when inserting events, select a schedule view of less than 1 week (View=>Schedule View) prior to insertion.

You can manually insert the following events into a schedule:
- Shifts
- Breaks
- Jobs
- Time off
- Unavailable periods

You can insert events in a schedule by either dropping or dragging them on an employee’s time line on the time bar pane. You can optionally drop insert breaks or jobs into already existing fixed shifts. Drop inserting events is most useful for fixed events, as the duration of the shift is predefined. Drag inserting events is most useful for variable shifts, as the duration can vary depending on the defined parameters for a specific event.

**NOTE:** To accommodate for last minute scheduling changes, you can optionally schedule time off and unavailable events in the middle of scheduled shifts or schedule a shift in the middle of time off and unavailable events.

**Drop inserting events**

To drop insert an event

1. Click the **Insert** tab.
2. Click **Drop**.
3. Under **Event**, select the event to add to the schedule.
4. Under **Schedule**, select the schedule to add events to.
5. Under **Event name**, select the name of the event to add to the schedule.
6. On the time bar pane, click the employee’s time line to insert the event.
   The event is added to the schedule.
7. Repeat steps 3-6 for every event to add to the schedule.

**Drag inserting events**

To drag insert an event

1. Click the **Insert** tab.
2. Click **Drag**.
3. Under **Event**, select the event to add to the schedule.
4. Under **Schedule**, select the schedule to add events to.
5. Under **Event name**, select the name of the event to add to the schedule.
6. On the time bar pane, click the employee’s time line and drag the cursor from the start time to the end of the event.
7. Repeat steps 3-6 for every event to add to the schedule.
Recurring events
You can recur shifts, time off, and unavailable events.

To make an event recur
1. On the time bar pane, on the employee’s time line, right-click the event to recur.
2. Click Recurring.
3. Click Daily, Weekly, Monthly, or Yearly recurring.
4. Specify the pattern and range of the recurrence.
5. Click OK.

Mass recurring events
You can use the Mass recurrence wizard to create multiple recurrences for several events automatically. The wizard allows you to mass recur shifts, time off, and unavailable periods based on either a daily or weekly template.

NOTE: Manual or mass deletion is required to remove the generated events.

To mass recur events
1. Click the Tools tab.
2. In the Bulk operations group, click Recurrence.
   The Mass Recurrence wizard opens.
3. Click Next.
4. Follow the steps in the wizard to specify the parameters of the events to mass recur.
5. Click Finish.
6. Click Yes.

Mass deleting events
You can delete one or more scheduled events (shifts, time off periods, unavailable periods, breaks, and jobs) at a time with the Mass delete option. Only the selected events are deleted from the schedules.

To mass delete scheduled events
1. Click the Tools tab.
2. In the Bulk operations group, click Delete.
3. Specify the date range affected, event types to delete, and the schedules to delete events from.
   You can optionally filter the mass delete by employee, reporting number, full time/part time status, and fixed/variable shift type.
4. Click OK.

Mass applying time off
You can apply time off to any or all agents in a schedule simultaneously.

To mass apply time off
1. Click the Tools tab.
2. In the Bulk Operations group, click Time Off.
   The Timeoff Mass Insert dialog box opens.
3. Select a schedule from the Schedules drop-down list.
4. Hold down CTRL and then click the agents to which you want to apply the time off type. If you want to select all agents, click Select All.
5. Under Time off, select the time off type from the list.
6. Select the start and end dates, days of the week, and start and end times for the time off type.
7. After selecting the time off time, select Mark remaining periods of the day as unavailable if you want the hours outside of the start and end times to be unavailable for scheduling.
8. Click OK.
Modifying forecast totals in the event totals pane

If you build schedules with forecast data, you can adjust the forecast totals on the event totals pane. On the events totals pane, you can change forecast totals in time intervals as small as 15 minutes. The schedule view you select determines the time interval of the forecast totals. See “Changing the time interval of the time bar pane” on page 533.

For example, if you select the 8 hour schedule view, you can change the forecast data in 15 minute intervals. However, if you select the 1 day schedule view, you can change the forecast data in 1 hour time intervals. When you change the forecast data in an interval larger than 15 minutes and then change the view to smaller intervals, you will notice that the change applies to each of the smaller intervals.

NOTE: Schedule Builder uses the latest forecast data to calculate the number of employees required.

To change the forecast totals in the events totals pane

1. After Totals, click +.
2. Select the Forecast check box and the check boxes of any other event totals to view.
3. Click -.
4. Click the View tab.
5. Under Schedule view, select a time interval.
   See Table 18-2, “Schedule views and corresponding event total time intervals” on page 534.
6. Click the + before Forecasted to expand the forecast tree.
   The event totals for the loaded schedules appear.
   NOTE: You can use the Tab key to select cells to the right, and the Shift+Tab keys to select cells to the left.
7. Click a cell in the forecast event total grid and type the new forecast total for this time interval.

Modifying event times and notes in the schedule details pane

The changes you make to event start times and end times in the schedule details pane are immediately reflected in the time bar pane.

To modify the start and end times of events in the schedule details pane

1. On the schedule details pane, click the start or end time of an event.
2. Type the new time.
   The new time is immediately reflected in the time bar pane.
3. Repeat for any other event times to modify.

To modify the start and end times of events in the time bar pane

1. Click the Insert tab.
2. Click Select.
3. On the time bar pane, select the event to modify.
4. Drag and drop the event to adjust its start and end times.
   The new time is immediately reflected in the time bar pane.
5. Repeat for any other event times to modify.

To add/edit a note for a scheduled employee

1. On the schedule details pane, click the note field for an employee.
2. Click the ... button.
   The Notes editor appears.
3. Type/edit a note.
4. Click OK.
Schedule distribution

You can specify viewing preferences, specify access rights to schedules, and run and print reports.

Viewing schedules

You can specify how you view the time bar pane. Use the scroll bar to view other days and times in the schedule. If you reach the end of the month and want to view dates for the next month, you can click the arrow on the scroll bar to load the schedule for the next month. By default, events you insert into a schedule are snapped to the grid in 30 minute increments.

To view a specific date

1. From any tab in Workforce Scheduling, click Select date.
2. Click the date to view.
   The time bar will display the date you selected to view.

Viewing scheduled events

NOTE: If employees belong to more than one schedule and you are viewing only one of the schedules to which the employees belong, any events scheduled in the other schedule will appear as a shadow event (grey bar) in the time bar view.

You select how event time bars appear in Configuration=>Preferences. You can isolate shifts, time off, and unavailability to view them separately in the time bar pane. You must view breaks and jobs with shifts. You cannot isolate breaks and jobs in the time bar pane. See "Configuring event display preferences" on page 522.

To view shifts

• On the View tab, in the Show/Hide group, select the Shift check box.

To view jobs

• On the View tab, in the Show/Hide group, select the Job check box.

To view breaks

• On the View tab, in the Show/Hide group, select the Break check box.

To view time off

• On the View tab, in the Show/Hide group, select the Time off check box.

To view unavailable periods

• On the View tab, in the Show/Hide group, select the Unavailable check box.

To view shadow events

• On the View tab, in the Show/Hide group, select the Shadow check box.

Changing the time interval of the time bar pane

You can view schedules in the time bar pane over 8 hour, 12 hour, 1 day, 2 day, 1 week, 2 week, or 1 month time intervals. The default view is the 12 hour view.

To change the time interval in the time bar pane to one week

1. Click the View tab.
2. In the View options group, under Schedule view, select the interval to view.
3. Optionally, under Group view, select Supervisor to group employees in the time bar pane by schedule.
Viewing event totals

Event totals represent the total number of employees for an event. You can view event totals in 15 minute, 30 minute, 1 hour, 4 hour, or 1 day time intervals. Table 18-2 displays the event total time intervals that correspond to the schedule views.

Table 18-2 Schedule views and corresponding event total time intervals

<table>
<thead>
<tr>
<th>Schedule view</th>
<th>Event totals time interval</th>
</tr>
</thead>
<tbody>
<tr>
<td>8 hour</td>
<td>15 minute</td>
</tr>
<tr>
<td>12 hour</td>
<td>30 minute</td>
</tr>
<tr>
<td>1 day</td>
<td>1 hour</td>
</tr>
<tr>
<td>2 day</td>
<td>4 hour</td>
</tr>
<tr>
<td>1 week</td>
<td>1 day</td>
</tr>
<tr>
<td>2 week</td>
<td>1 day</td>
</tr>
<tr>
<td>1 month</td>
<td>1 day</td>
</tr>
</tbody>
</table>

You can select from the following event totals:

- **Forecast**—appears only after you have applied a forecast to a schedule. This total represents the number of employees required to meet your specified Service Level objectives.

- **Scheduled**—represents the number of employees scheduled at that time

- **Over/Under**—represents the excess (over) or inadequate (under) number of employees scheduled when compared to the number of employees forecasted.

- **On Break**—represents the number of employees scheduled for a break at a certain time

- **ACD Jobs**—represents the number of employees scheduled to perform ACD jobs

- **Non-ACD Jobs**—represents the number of employees scheduled to perform non-ACD jobs

- **At work**—represents the number of employees scheduled to handle contact requests

- **Overtime**—represents the number of employees scheduled for overtime

To view event totals

1. In the **Totals** pane, click +.
2. Select the check boxes of the event totals to view.
3. Click -.
   The totals pane appears with the event totals you selected.

Viewing schedule details

To group information in the schedule details pane

- On the schedule details pane, drag and drop the column header to organize to the Drag a column header here to group by that column area on the window.

To sort information in the schedule details pane alphabetically

- On the schedule details pane, click the header of the column to sort alphabetically.
To filter information in the schedule details pane

1. On the schedule details pane, click the arrow on a column header.
2. Select the filter criteria.

Synchronizing views

You can synchronize the people pane, time bar pane, and totals pane with the order of the information in the schedule details pane. Once you have organized the details of your schedules (sorting, filtering, and grouping) in the schedule details pane, synchronize views to reflect the order you have selected. For information on how to sort, filter, or group schedule details, see “Viewing schedule details” on page 534.

To synchronize views

1. Click the View tab.
2. Select the Synchronize time bar view with details view check box.
3. Optionally, select the Vertical scrolling check box.

Running schedule reports

The Workforce Scheduling reports are produced in Microsoft Excel format. You must run and print the following Workforce Scheduling reports from Contact Center Management. See the Mitel Contact Center Solutions Enterprise Edition Reports Guide for more information.

You can produce on-demand reports and scheduled reports for the following reports:

- Detailed Schedule by Employee with Totals
- Schedule by Employee by Time Off by Day of Week
- Employee Configuration
- Summary Schedule by Employee
- Totals Pane

Running on-demand reports

To run an on-demand report

1. In Contact Center Management, click Reporter=>Workforce Scheduling=>Schedules.
2. Under Report type, select a report.
3. Under Schedule, select a schedule.
4. Under Employee, select an employee.
5. Under Start date, select the start date of the report.
6. Under End date, select the end date of the report.
7. Optionally, click the Filter tab and specify the report filters options for the Workforce Scheduling report.
8. Click the Advanced tab.
9. If you want to create a separate report for each day in the selected date range, select the Create one report for each day in the selected date range check box.
10. After Report output language, select the language for the report.
11. After Reader type, select either Excel or PDF.
12. If you want to email the report, under Excel distribution, select the Email the report to check box and specify the contact group, contact, and/or email address.
13. If you want to print the report, select the Print the report check box.
14. If you want to include charts with the printed report, select the Include charts when printing check box.
15. Click Submit.
Running scheduled reports
If you need the same reports at the same time on a regular basis, you can schedule Workforce Scheduling
reports to run at a specific time of day, such as:

• Every day
• On a specific day of the week
• On the first or last day of the month
• Each weekday

You can run scheduled reports to span the following time frames:

• Current or previous day
• Previous five or seven days, including or excluding the run day
• Current month to date
• Previous month
• Current year to date
• From a given start date to the current date
• Next five days to six months, including the run day

NOTE: You must create a report schedule before you can add reports to it.

Creating report schedules
To create a report schedule

1. In Contact Center Management, click Reporter=>Scheduled reports.
2. Click the Workforce Scheduling report schedules tab.
3. Click Next.
4. After Schedule name, type the name of the report schedule.
5. After Schedule will run, select when the schedule will run.
6. After at, select the time of day.
7. After Reports time span, select the time frame the report will cover.
8. Click the Distribution tab.
9. Select the groups to which you will email scheduling reports.
10. Click Save.
11. Click Add a report.
12. Click the Workforce Scheduling tab.
13. Click Workforce Scheduling scheduled reports.
15. After Schedule, select a schedule.
16. After Employee select an employee.
17. Optionally, click the Filter tab and specify the report filters options for the Workforce Scheduling
report.
18. Click the Advanced tab.
19. After Output language, select the language for the report.
20. Click Save or Execute now.

Modifying report schedules
To modify a report schedule (for example, add a report)

1. In Contact Center Management, click Reporter=>Scheduled reports.
2. After Select a schedule, select a schedule.
3. Click Manage schedule properties.
4. Click the Properties tab and modify when the schedule runs the reports.
5. Click the Distribution tab and modify how the reports are distributed.
6. Click the Reports tab and modify the reports included in the schedule.
7. Click Save.
Schedule Adherence

Mitel Schedule Adherence is an optional application that works in conjunction with Contact Center Management and Workforce Scheduling. Schedule Adherence resides in the Contact Center Client real-time monitors and enables you to view the real-time state of contact center employees scheduled in Workforce Scheduling. Schedule Adherence compares the current activities of employees to the configured schedule and alerts you in real time when employees are out of adherence. Employees are considered out of adherence if they are early or late for their scheduled events or if they are not performing scheduled activities.

Schedule Adherence is made available in Workforce Scheduling and Contact Center Client when you are licensed for Contact Center Management, Workforce Scheduling, and Schedule Adherence.

Once you have configured a schedule in Workforce Scheduling, you
• Configure adherence preferences in Workforce Scheduling
• View adherence monitors in Contact Center Client
• Set adherence alarms on the Employee State by Position/Time monitors (optional)
• Run reports on employee adherence to scheduled activities

Configuring adherence preference

You can configure adherence thresholds for shifts, breaks, and jobs. You can set parameters for each event type to suit the needs of your business. You select employee states and assign them to relevant events and specify event time tolerance levels. You can optionally configure groups of employee states and then associate them to relevant employee events.

NOTE:
• Schedule Adherence will handle two or more overlapping adherence thresholds in one of the following ways. If only one of the events is valid for the current employee state, that event will be used. If more than one event is valid for the current employee state, the first event, using start time, will be used.
• If no states are specified for an event type, all states will be considered in adherence.

Configuring adherence parameters

To configure adherence parameters

1. In Workforce Scheduling, click the Configuration tab.
2. In the Adherence group, click Adherence Configuration.
   The Adherence Parameters window opens.
3. In the left pane, expand the event type list and select the event to which you want to add relevant adherence states.
4. Under Event start tolerance (hh:mm), specify the times before and after which an employee state will be reported on as out of adherence.
5. Under Event end tolerance (hh:mm), specify the times before and after which an employee state will be reported on as out of adherence.
6. Under Available states, select the states which are relevant for the specified event type and click > to move the state to the Assigned states list.
7. Repeat steps 2-6 for each event type for which you want to configure adherence parameters.
8. Click OK.
Configuring state groups

To configure a state group

1. In Workforce Scheduling, click the Configuration tab.
2. In the Adherence group, click State groups. The State groups window opens.
3. Click Add.
4. Type a name for the state group and click Create.
5. Under Available states, select the states that are relevant for the state group and click > to move the state to the Assigned states list.
6. Repeat steps 2-5 for each state group you want to configure.
7. Click OK.

Viewing adherence monitors in Contact Center Client

Schedule Adherence includes two Contact Center Client monitors that enable you to monitor employee adherence to schedules in real time. The Schedule Adherence monitors alarm on employees who are not adhering to schedules based on the thresholds you specify in Workforce Scheduling and the alarms you configure in Contact Center Client. You can optionally set adherence alarms on the Employee State by Position/Time monitors.

Adherence Detail Grid monitor

The Adherence Detail Grid monitor provides a drill-down view of employee scheduled activities, expected states, and event totals. It enables you to easily compare expected employee states and actual employee states in real time.

There are three levels to the Adherence Detail Grid monitor. The first level provides a high level overview of employee adherence. The second level has two grids. The first lists all of the embedded events (breaks and jobs) for the shift and the associated adherence information. The second grid lists the out of adherence record for the shift. The final level has only one grid, which represents the out of adherence record for the embedded events.

You can set Adherence Detail Grid alarms based on the following variables:

- Out of adherence
- Scheduled
- Expected states
- Actual state
- Actual start
- Current out of adherence
- Total our of adherence
- Shift time
- % out of adherence

Table 18-3 details provides column heading definitions for the Adherence Detail Grid monitor.
Table 18-3  Adherence Detail Grid monitor headings

<table>
<thead>
<tr>
<th>Heading</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee</td>
<td>the name of the employee being monitored</td>
</tr>
<tr>
<td>Is in Adherence</td>
<td>the check box is enabled when the employee is adhering to the schedule</td>
</tr>
<tr>
<td>Scheduled</td>
<td>the type of event (shift, break, or job) the employee is performing, whether in or out of adherence</td>
</tr>
<tr>
<td>Expected States</td>
<td>the employee states that are relevant for the type of scheduled activity the employee is scheduled to perform</td>
</tr>
<tr>
<td>Actual State</td>
<td>the current employee state. If this is one of the expected states, the employee is adhering to the schedule</td>
</tr>
<tr>
<td>Scheduled Start</td>
<td>the time at which the employee is scheduled to start the scheduled activity</td>
</tr>
<tr>
<td>Actual Start</td>
<td>the time at which the employee started the scheduled activity. This column may be blank if the employee has not come into adherence for the scheduled event</td>
</tr>
<tr>
<td>Scheduled End</td>
<td>the time at which the scheduled event is to end</td>
</tr>
<tr>
<td>Current Out Of Adherence</td>
<td>the amount of time the employee has been out of adherence for the scheduled activity. This column will be blank if the employee is adhering to the schedule</td>
</tr>
<tr>
<td>Total Out Of Adherence</td>
<td>the total amount of time the employee has been out of adherence for all scheduled activities for the current shift</td>
</tr>
<tr>
<td>Shift Time</td>
<td>the duration of time the employee has been working the current shift</td>
</tr>
<tr>
<td>% Out Of Adherence</td>
<td>the percent of time the employee has been out of adherence for the elapsed portion of the scheduled shift</td>
</tr>
<tr>
<td>Shift</td>
<td>the name of the shift for which the employee is scheduled</td>
</tr>
<tr>
<td>Embedded</td>
<td>the name of the embedded event type (break or job)</td>
</tr>
<tr>
<td>Start</td>
<td>the time at which the employee went out of adherence</td>
</tr>
<tr>
<td>End</td>
<td>the time at which the employee came back into adherence</td>
</tr>
</tbody>
</table>

To open the Adherence Detail Grid monitor

1. Click View=>Real time to view the Contact Center Client real-time monitor icons.
2. Click the Adherence icon and select Detail Grid.
   The Adherence Detail Grid monitor opens. See Figure 18-7.
3. Under Schedules, select a schedule to include in the monitor or under Employees, select the employees to monitor.
4. Click OK.
To set an Adherence Detail Grid monitor alarm

1. Right-click the Adherence Detail Grid monitor and click **Set Alarms**.
   
   **NOTE:** You can select the Apply the alarm thresholds to all devices displayed on the monitor option to apply the threshold settings for performance variables across all employees. Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for performance variables to a list of employees.

2. If you selected **Apply the alarm thresholds to a specific list of devices**, under **Devices**, select the employee(s) to which you want to apply the alarm thresholds.

3. Under **Performance variables**, select the performance variable to which you want to set an alarm.

4. Under **Alarm threshold**, click **Add a threshold** and specify the font color, background, sound, popup, bring to front, and email alarm options you want to apply to the alarm threshold.

5. Click **OK**.

### Adherence Timebars monitor

The Adherence Timebars monitor provides a schedule time bar, based on the employee time bar and event colors configured in Workforce Scheduling, for each employee’s scheduled activities. The current time is identified by a green line on the employee time bar and past events are shaded purple.

You can set Adherence Timebar alarms based on the following variables:

- Shift out of adherence
- Break out of adherence
- Job out of adherence
To open the Adherence Timebar monitor

1. Click View=>Real time to view the Contact Center Client real-time monitor icons.
2. Click the Adherence icon and select Timebars.
   The Adherence Timebars monitor opens. See Figure 18-8.
3. Under Schedules, select a schedule to include in the monitor or under Employees, select the employees to monitor.
4. Click OK.

Figure 18-8 Adherence Timebars monitor

<table>
<thead>
<tr>
<th>Adherence Timebars</th>
<th>Thursday, July 31, 2008</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>4</td>
</tr>
<tr>
<td>G, Scott</td>
<td></td>
</tr>
<tr>
<td>S, Peter</td>
<td></td>
</tr>
</tbody>
</table>

To set an Adherence Timebar monitor alarm

1. Right-click the Adherence Timebar monitor and click Set Alarms.
   NOTE: You can select the Apply the alarm thresholds to all devices displayed on the monitor option to apply the threshold settings for performance variables across all employees. Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for performance variables to a list of employees.
2. If you selected Apply the alarm thresholds to a specific list of devices, under Devices, select the employee(s) to which you want to apply the alarm thresholds.
3. Under Performance variables, select the performance variable to which you want to set an alarm.
4. Under Alarm threshold, click Add a threshold and specify the background, sound, pop-up, bring to front, and email alarm options you want to apply to the alarm threshold.
5. Click OK.

Employee State by Position/Time monitors

You can now optionally alarm on employees who are not adhering to schedules on the Employee State by Position/Time monitors.

To set an adherence alarm on the Employee State by Position/Time monitors

1. Right-click an Employee State by Position/Time monitor and click Set Alarms.
   NOTE: You can select the Apply the alarm thresholds to all devices displayed on the monitor option to apply the threshold settings for performance variables across all employees. Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for performance variables to a list of employees.
2. If you selected Apply the alarm thresholds to a specific list of devices, under Devices, select the employee(s) to which you want to apply the alarm thresholds.
3. Under Performance variables, select the performance variable to which you want to set an alarm.
4. Under Alarm threshold, click Add a threshold and specify the background, sound, pop-up, bring to front, and email alarm options you want to apply to the alarm threshold.
5. Click OK.
Running adherence reports

The Schedule Adherence reports are produced in Microsoft Excel format. You must run and print the following Schedule Adherence reports from Contact Center Management. See the Mitel Contact Center Solutions Enterprise Edition Reports Guide for more information.

You can produce on-demand reports and scheduled reports for the following reports:

- Employee and Employee Group Adherence Trace
- Employee Group Time Out of Adherence by Employee by Day of Week
- Employee Group Time Out of Adherence by Day of Month
- Employee Group Adherence by Period

You run Schedule Adherence reports in the Contact Center Management website, under Reporter=>Schedule Adherence.

Employee Portal

Mitel Employee Portal enables employees to view and trade shifts online and request changes to schedules for time off, shifts, and availability. Employee Portal enables schedulers to view employee requests, perform what-if scenarios, quickly approve or deny requests, and automatically update schedules.

Employee Portal is made available in Workforce Scheduling and the web-based user interface when you are licensed for Contact Center Management, Workforce Scheduling, and Employee Portal.

Employee functionality

Using Employee Portal, employees can

- View their currently scheduled shifts
- View messages from supervisors and employees and receive updates about the status of their requests on the home page
- Offer shifts to the bulletin board for other employees to take or trade
- Remove shifts from the bulletin board
- Propose to take shifts from the bulletin board
- Propose to trade shifts from the bulletin board
- Accept or reject employee proposals to take or trade your shift
- Request time off
- Request changes to your availability

The Employee Portal home page provides links to the bulletin board, view and offer your scheduled shifts for take or trade, view your pending offers, request time off, and request availability changes. Any Employee Portal alerts that require your attention also display on the home page. These include

- You have approved shift requests
- You have denied shift requests
- You have shift requests pending supervisor approval
- You have shift proposals pending your acceptance
- You have shift proposals pending acceptance or that have been rejected
- You have time off requests pending supervisor approval
- You have notes regarding your availability

If a home page alert is red, it requires your attention. Click View to view the alert and any employee or supervisor notes in detail.
Starting Employee Portal

To start Employee Portal

1. Click Start=>Programs=>Mitel=>Employee Portal.
2. Type your username and password.
3. Click Log on.

Creating a desktop shortcut to Employee Portal

To create a desktop shortcut to Employee Portal

1. Click Start=>Programs=>Mitel=>Employee Portal.
2. Drag and drop the Employee Portal web address from the address bar to your computer desktop.

Viewing currently scheduled shifts

To view your currently scheduled shifts

1. In Employee Portal, click My shifts.
2. If you want to view shifts starting on a specific calendar day, select the start date from the calendar.
3. Optionally, to view the break and job details for a specific shift, under Details, click Select.

Offering shifts for other employees to take or trade

You can offer shifts to the bulletin board for other employees to take or trade. You can remove shifts from the bulletin board at any time as long as no employees have proposed to take or trade the shift. Shifts that have already begun cannot be posted to the bulletin board for other employees to take or trade.

To offer a shift for other employees to take or trade

1. Click Offer my shifts.
2. Next to the shift you want to offer for other employees to take or trade, click Select.
   The shift details display.
3. Click Continue.
4. Optionally, type a note to accompany your offer.
5. Click Submit.

Removing shifts from the bulletin board

You can remove shifts from the bulletin board at any time as long as no employees have proposed to take or trade the shift. If a proposal has been made, you will need to reject it first before you can remove the shift from the bulletin board.

To remove a shift from the bulletin board

1. Click My pending offers.
2. Next to the shift you want to remove from the bulletin board, click Select.
   The shift details display.
3. Click Continue.
   The shift offer is removed from the bulletin board.

Proposing to take shifts

To propose to take a shift

1. Click Bulletin board.
2. Next to the shift you want to take, click Select.
   The shift details display.
3. Click Continue.
4. Click **Next**.
5. Optionally, add a note to accompany your proposal.
6. Click **Next**.
7. Click **Submit**.

**Proposing to trade shifts**

To propose to trade a shift
1. Click **Bulletin board**.
2. Next to the shift you want to take, click **Select**.
   The shift details display.
3. Next to the shift you want to propose for trade, click **Select**.
4. Optionally, add a note to accompany your proposal.
5. Click **Next**.
6. Click **Submit**.

**Accept or reject an employee proposal to take or trade your shift**

To accept or reject an employee proposal to take or trade your shift
1. On the Employee Portal home page, next to **You have <#> shift proposals pending your acceptance**, click **View**.
   The Proposals window displays.
2. Next to the proposal you want to view, click **Select**.
   The proposal details display with any relevant employee notes.
3. Click **Accept** to accept the proposed shift change. Otherwise, click **Reject** to reject the proposed shift change.

**Requesting time off**

To request time off
1. Click **Request time off**.
   The Request time off window displays, including a list of any time off you have already scheduled.
2. Click **Request time off**.
3. Select a time off type from the list.
4. Click **Next**.
5. Specify the time off start and end times.
6. Click **Next**.
7. Optionally, add a note to accompany the time off request.
8. Click **Next**.
   The time off request summary displays.
9. Click **Submit**.

**Requesting availability changes**

**NOTE:** You can click Clear request at any time to reset the Request availability change window to your currently configured availability.

To request an availability change
1. Click **Request availability change**.
   The Request availability change window displays with your current availability.
2. If you need to change existing availability, under **Update current availability**, select a day of the week and click **Remove**. Otherwise, continue to step 3.
3. Under **Change availability**, specify the dates and times you are available to work.
   - After **Day of week**, specify the day of week you are available.
   - If you are only available during certain hours, select **Part of the day**, and specify the times at which you are available.
   - If you are available to work at any time during the day, select **Full day**.
4. Click **Add** to add the new availability to the request.
5. You can optionally select a currently configured availability day or time in the **Update current availability list** and click **Remove** to remove it from the list.
   **NOTE:** The Add button is for adding new availability to the Update current availability list only and not for replacing specific dates and times from the currently configured availability list.
6. Optionally, under **Employee note**, add a note to accompany your request.
7. Click **Accept**.
   The Confirm availability change window displays.
8. Specify the date that your requested availability will take effect.
9. Click **Submit**.

### Supervisor functionality

Using Employee Portal, supervisors can
- View employee scheduling requests
- Preview the effect of approving or denying employee shift change requests
- Approve or deny employee proposals to take or trade shifts
- Approve or deny employee requests for time off
- Approve or deny employee requests for availability changes

### Handling employee scheduling requests

**NOTE:** If you attempt to approve an employee's request for time off for a period where a schedule has yet to be built, time off will not be decremented properly and the time off will be entered as an unavailable event in the schedule.

To view, approve, or deny employee scheduling requests

1. Click **Start=>Programs=>Mitel=>Workforce Scheduling**.
2. Log on to Workforce Scheduling.
3. Load an active schedule.
4. Click the **Employee Portal** tab.
5. Click the **Request mode** icon.
6. In the details pane, click the **Shift changes**, **Time off**, and **Availability** tabs to view any employee scheduling requests pending your approval.
7. Next to **Approve**, click the + to view the scheduling request details.
8. If you are viewing the Shift change tab, click **View timebar** to view the scheduled shift.
9. In the Employee requests group, click **Preview** to view the effect of approving the request.
10. In the Employee requests group,
    - Click **Approve** to approve the request.
    - Click **Deny** to deny the request.
   The schedule is automatically updated and employees are notified of the schedule request status.
Employee Portal reports

The Employee Portal reports are produced in Microsoft Excel format. You must run and print the following Employee Portal reports from Contact Center Management. See the *Mitel Contact Center Solutions Enterprise Edition Reports Guide* for more information.

The following reports are available with Employee Portal:

- **Employee Portal Availability Requests**
  Provides a detailed summary of employee requests for availability changes

- **Employee Portal Time Off Requests**
  Provides a detailed summary of employee requests for time off

- **Employee Portal Shift Requests**
  Provides a detailed summary of employee requests to take or trade shifts

- **Employee Portal Shift Change Status**
  Provides a detailed summary employee requests that have been approved or denied

You run Employee Portal reports in the Contact Center Management website, under **Reporter=>Workforce Scheduling=>Employee Portal.**
Chapter 19
Traffic Analysis

Using Traffic Analysis
Traffic Analysis

Traffic Analysis is an optional application that works with Call Accounting and Contact Center Solutions. Traffic Analysis works in conjunction with the SX-2000 and 3300 ICP telephone systems.

In order to have summarized data for Traffic Analysis reports you must wait until the nightly maintenance routine runs the summary (at midnight each night). The data for these reports is derived from the traffic stream. Traffic Analysis reports are not available in real-time.

For detailed information about traffic reports, refer to the Mitel Call Accounting Reports Guide. Traffic reports provide call statistics on DTMF receivers, route lists, route plans, routes, and trunks. You can create the following on-demand and scheduled traffic reports:

- Attendant Console Traffic by Interval report
- Attendant Traffic by Interval
- Attendant Group Traffic by Interval
- DTMF Receiver Group Traffic by Interval
- Route List Traffic by Interval
- Route Plan Traffic by Interval
- Route Traffic by Interval
- Trunk Traffic by Interval
- Trunk Busy Hour Traffic by Day of the Week
- Trunk and Trunk Group Traffic Usage by Day of the Week
- Trunk Group Outgoing Traffic by Interval
- Trunk Group Outgoing Traffic Usage by Day of the Week
- Trunk Group Outgoing Busy Hour Traffic by Day of the Week

Using Traffic Analysis

Before you generate Traffic Analysis reports you must configure data collection for Traffic Analysis.

To configure data collection for Traffic Analysis

1. Set up the telephone systems to collect traffic data
2. Configure the media servers in Contact Center Management for traffic data collection
   (YourSite=>Enterprise)

Setting up telephone systems to collect traffic data

You can collect traffic data from an SX-2000 telephone system using datasets or using FTP without datasets. You can collect traffic data from a 3300 ICP telephone system over TCP/IP.

Setting up the SX-2000 without datasets

Using FTP and VT100, you can collect traffic data from an SX-2000 telephone system without requiring datasets. (See Figure 19-1.)

FTP traffic data collection consists of two parts:

1. VT100 Transport Agent
   The VT100 Transport Agent logs in to the maintenance port of the SX-2000 and issues commands to transfer traffic data via FTP to a pre-configured server. This operation occurs every two hours.

2. FTP data collection
   The FTP data collection then downloads the traffic data files from the FTP server to the Enterprise Server. This occurs during the summarize function.
The system works as follows:

1. .Net Collector opens a VT100 connection to the SX-2000 and issues transfer commands.
2. SX-2000 sends traffic files to the pre-configured FTP server.
3. The Summarize process downloads, merges and files traffic data to the Enterprise Server from the FTP server.

**Figure 19-1  SX-2000 architecture without datasets**

Setting up the 3300 ICP

You must specify traffic data options on the 3300 ICP Traffic Options Assignment form in order to collect traffic data and produce reports with the Traffic Analysis application.

The Traffic Options Assignment form is a form-driven method to obtain time-based traffic reports on telephone system usage. You can generate reports that cover attendant usage, channel utilization, system activity, data station usage, delay to dial tone, extension-to-extension calls, feature usage, and trunk use.

**NOTE:**
- You can define up to six different time slots.
- If the start and stop time are blank while the time slot is active, an error message is displayed when the commit operation is attempted; in this case, the changes will not be committed.
- No two traffic slot stops should be less than 5 minutes apart. This time is required for the system time to generate the previous report.
- Making changes to the data in this form and recommitting interrupts a traffic report that is running.

**Programming the Traffic Options Assignment form**

To program the Traffic Options Assignment form:

1. Log onto the 3300 ICP telephone system.
2. Browse to the Traffic Options Assignment form.
3. Click Change.
4. Configure the traffic options as described in Table 19-1.
### Table 19-1 3300 ICP Traffic Options Assignment form

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Slot Active</td>
<td>Select Yes to start a traffic session at the time specified in Start Time field and finish at the Stop Time field for each of up to six different slots. The report is resumed the next day at the same time. Select No to suspend the traffic report for the associated time slot. The traffic report will not run until Yes is entered and the form recommitted. Default is No. There can be no overlapping of ACTIVE time slots. <strong>Select: Yes</strong></td>
</tr>
<tr>
<td>Start Time (-Hours, -Minutes)</td>
<td>Select the time the traffic report is to start running. Default is blank. The start time must be assigned for active time slots; it can be blank for inactive time slots. If the start time equals the stop time then the time period is 24 hours. <strong>Select: 00:00</strong></td>
</tr>
<tr>
<td>Stop Time (-Hours, -Minutes)</td>
<td>Select the stop time for the report. If the session is to run for 24 hours, enter the same time as the start time. Default is Blank. The stop time must be assigned for active time slots; it can be blank for inactive time slots. If the start time equals the stop time then the time period is 24 hours. <strong>Select: 24:00</strong></td>
</tr>
<tr>
<td>Period Length</td>
<td>Select the length of time(15, 30, or 60 minutes) that data is to be collected for the session before a traffic report is formatted and output. Default is 60 minutes. <strong>Select: 15</strong></td>
</tr>
<tr>
<td>Usage Units</td>
<td>Select the type of units the report will use. Default is Erlangs. <strong>Select: Erlangs</strong></td>
</tr>
<tr>
<td>Autoprint</td>
<td>Select Yes to spool the traffic report to the printer assigned to this function in the Application Logical Port Assignment form. Default is No. We will be using the LPR1 Port 1754 to output traffic. <strong>Select: Yes</strong></td>
</tr>
<tr>
<td>Maximum Number of Traffic Files</td>
<td>Enter the maximum number of traffic reports to be stored in disk. Default is 10. <strong>Select: 10</strong></td>
</tr>
</tbody>
</table>
Assigning ports

You must assign a port to the 3300 ICP to output traffic data.

To enable traffic data output

1. Log on to the 3300 ICP telephone system.
2. Browse to **Application Logical Port Assignment**.
3. Select **Traffic Report Port**.
4. Click **Change**.
5. Under **Port Physical Name**, type **LPR1**.
6. Click **Save**.

Verifying the traffic output

Before you configure traffic collection settings for the 3300 ICP, verify traffic data is being output through port 1754.

To verify traffic is being output through port 1754.

1. Click **Start=>Programs=>Accessories=>Communication=>Hyperterminal**.
2. After **Name**, type **Traffic**.
3. Click **OK**.
4. After **Host address**, type the IP address of the 3300 ICP.
5. After **Port number**, type **1754**.

### Table 19-1  3300 ICP Traffic Options Assignment form

<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sections to include in Traffic Report</td>
<td>Select Yes to enable the collection of data for each resource group you want to include in the traffic report. The default is No.</td>
</tr>
<tr>
<td>Route Plans</td>
<td>Yes</td>
</tr>
<tr>
<td>Route Lists</td>
<td>Yes</td>
</tr>
<tr>
<td>Routes</td>
<td>Yes</td>
</tr>
<tr>
<td>Trunk Groups</td>
<td>Yes</td>
</tr>
<tr>
<td>Trunks</td>
<td>Yes</td>
</tr>
<tr>
<td>Links</td>
<td>No</td>
</tr>
<tr>
<td>Groups of Links</td>
<td>No</td>
</tr>
<tr>
<td>Channels</td>
<td>No</td>
</tr>
<tr>
<td>DTMF Receivers</td>
<td>Yes</td>
</tr>
<tr>
<td>Data Transceivers</td>
<td>No</td>
</tr>
<tr>
<td>Modem Groups</td>
<td>No</td>
</tr>
<tr>
<td>Data Station Groups</td>
<td>No</td>
</tr>
<tr>
<td>Attendant Groups</td>
<td>Yes</td>
</tr>
<tr>
<td>Attendant Consoles</td>
<td>Yes</td>
</tr>
<tr>
<td>Attendants</td>
<td>Yes</td>
</tr>
</tbody>
</table>
6. After **Connect using**, select **TCP/IP**.
7. Click **OK**.
8. Wait the interval time you selected in the Traffic Options Assignment, for example 15, 30 or 60 minutes. The traffic should then output to your screen.
9. After the output is complete, you can disconnect and close the hyper terminal window.

### Configuring media servers in YourSite

You must configure traffic collection settings in YourSite for the media servers from which you collect traffic data.

**3300 ICP**

You do not require a dataset to collect traffic data from a 3300 ICP. The traffic data is directed to the printer port, 1754, on the 3300 ICP telephone system. See “Configuring data collection settings for a 3300 ICP in the Contact Center Management website” on page 84.

**SX-2000**

You must configure Com port data collection settings when a dataset is used to collect traffic data from an SX-2000. See “Adding an SX-2000 ACD media server” on page 93.

Using FTP and VT100, you can collect traffic data from an SX-2000 telephone system without datasets. See “Configuring FTP traffic data collection settings” on page 91.

### Verifying traffic data is saved on the Enterprise Server

To verify the traffic collection for the 3300 ICP

1. Double click the Contact Center Management Enterprise Server icon on your desktop.
2. Using an administrative username and password, log on to the Contact Center Management website.
3. Click **YourSite=>Enterprise**.
4. Expand the tree of the site for which you want to configure traffic options.
5. Click a **3300 ICP** media server.
6. Click the **Data Collection** tab.
7. Verify the **Traffic Analysis** check box is selected and the port is 1754.
8. Wait the interval time you selected in the Traffic Options Assignment, for example 15, 30 or 60 minutes.
9. On the Enterprise Server, browse to `<drive letter:>`\program files\prairieFyre Software Inc\CCM\Data Directory\Node_0X.`
   This is the directory of the media server for which you configured traffic options.
   You should see a new file with the following naming convention, TYYYYMMDD.txt. For example, T20050127.txt, where YYYY is the year, MM is the month, and DD is the day.
10. Double-click the file to open it and view the traffic data.
Chapter 20
Multimedia Contact Center

Multimedia Contact Center options in Contact Center Management
Multimedia Contact Center options in Outlook
Agent actions
Contact management
Multimedia Contact Center

Multimedia Contact Center distributes emails, SMS messages, chats (customer-initiated, Internet-based chat sessions), and faxes to contact center agents, and tracks handling across media types. Agents access Multimedia Contact Center from Microsoft Outlook. When your corporate email server is a Microsoft Exchange Server, agents view both Multimedia Contact Center and Microsoft Office Outlook email inboxes in one window.

Before you use Multimedia Contact Center for the first time on your client computer, you must

1. Install Client Component Pack.
   See “Installing Client Component Pack using an administrative procedure” on page 44.
2. Run Client Role Selector.
   See "Using Client Role Selector to select your Contact Center Client role” on page 45.
3. Start Contact Center Management and configure options for Multimedia Contact Center.
   See “Starting Contact Center Management” on page 42.
4. Start Contact Center Client and log on and then log off.
   See “Starting Contact Center Client” on page 240.
5. Start Outlook and log on to Multimedia Contact Center.
   See “Starting Multimedia Contact Center on a client computer” on page 558.
6. In Outlook, specify real-time server connection parameters for Multimedia Contact Center.
   See “Verifying real-time server connection parameters” on page 560.

Using Multimedia Contact Center

You use Multimedia Contact Center in conjunction with Contact Center Management. Multimedia Contact Center integrates all media types in Contact Center Management for multimedia reporting and real-time monitoring. Before you use Multimedia Contact Center you must configure options in Contact Center Management and Outlook.

Multimedia Contact Center options in Contact Center Management

The YourSite database includes Enterprise, Configuration, Network Monitor, Schedules, and Security application areas. You must configure these before you can use Multimedia Contact Center. For information on how to configure YourSite, see “YourSite database application areas” on page 69.

When you configure the YourSite database, ensure you configure the following Multimedia Contact Center options:

- Multimedia Contact Center Email, SMS, WebChat, and/or Fax media servers and queues and queue groups.
  See “Adding a Multimedia Contact Center Email media server” on page 94.
  **NOTE:** Before you configure user settings you must disassociate email addresses before applying them to Multimedia Contact Center queues.
  See “Disassociating email addresses” on page 558.
- Multimedia Contact Center user settings for employees.
  See “Employee Quick Setup” on page 123.
- Employee personal details.
  See “Adding employees” on page 132.
- Multimedia Contact Center Email, SMS, WebChat, and Fax queues.
  See "Adding queues" on page 141.
When you configure agent IDs in Contact Center Management, you can use the same agent ID across voice, email, SMS, chat, and/or fax media types. For example, in YourSite=>Configuration, you could add Agent 1000, and associate Agent 1000 with voice, email, SMS, chat and/or fax media types.

If you want each of your employees to have only one agent ID, then you must set up your contact center as described in Configuration scenario 1. See “Configuration scenario 1” on page 108. If you want your employees to have an agent ID for each agent group to which they belong, then you must set up your contact center as described in Configuration scenario 2. See “Configuration scenario 2” on page 109.

Disassociating email addresses

If you want the same company email addresses that you used prior to purchasing Multimedia Contact Center, for example, support@yourcompany.com, to arrive in your Multimedia Contact Center agent inboxes, then you must first disassociate the email addresses from their original associations. Once they are disassociated, you can then configure these email addresses for Multimedia Contact Center.

To disassociate an email address
1. Click Start=>Programs=>Microsoft Exchange=>Active Directory Users and Computers.
   The Active Directory Users and Computers window opens.
2. Expand the tree until you see the Users folder.
3. Click the Users folder.
   The Users folder opens.
4. In the right pane, double-click Support.
   The Support window opens.
5. Click the Email Addresses tab.
6. Select support@yourcompany.com.
7. Click Edit.
8. Change support@yourcompany.com to support1@yourcompany.com.
9. Click OK.
10. Click OK.

Starting Multimedia Contact Center on a client computer

NOTE:
- The first time you start Outlook, you will be asked if the Multimedia Contact Center plug-in should be installed each time you start Outlook. Select the Yes check box.
- You must configure real-time server parameters in order to be able to log in as a Multimedia Contact Center agent. See “Verifying real-time server connection parameters” on page 560.

To log on to Multimedia Contact Center
1. Click the Outlook desktop icon.
   The Multimedia Contact Center login window opens.
   **NOTE:** You use the same user name and password to start Multimedia Contact Center as you do to start Contact Center Management.
2. Type your user name and password.
   See Figure 20-1.
3. Select the check box beside the agent IDs to which you are logging on, for one or more media types.
4. Select the **Save as default** check box.
5. Click **Log On**.
   Outlook starts and displays your Multimedia Contact Center inbox (Agent Inbox). See Figure 20-2.

**Figure 20-2  Agent Inbox**

---

### Multimedia Contact Center options in Outlook

Before you use Multimedia Contact Center, you configure Multimedia Contact Center options in Outlook:

- Real-time server connection parameters
- Startup options
- Arrival options
- Agent Inbox columns
Verifying real-time server connection parameters

The real-time server connection parameters specify the IP address and port number used by Multimedia Contact Center. Multimedia Contact Center uses the same IP address as the Enterprise Server and the same port number as Contact Center Client.

To verify Multimedia Contact Center Server connection parameters

1. In Outlook, click Tools=>Options and select the Multimedia Contact Center tab. See Figure 20-3.
2. Under IP address, type the IP address of the Enterprise Server. You can find the IP address under YourSite=>Enterprise on the Enterprise tab.
3. Under Port number, type the real-time port number. You can find the real-time port number under YourSite=>Enterprise, on the Enterprise tab. **CAUTION:** If you select SSL, ensure the IP address is the one you used when applying the SSL certificate.
4. If you use Secure Socket Layer, select SSL.
5. Click OK.

**Figure 20-3  Multimedia Contact Center tab**
Configuring Multimedia Contact Center startup options

You can specify Outlook displays

- Multimedia Contact Center shortcuts
- The Multimedia Contact Center agent login window when you start Outlook
- The Agent Inbox instead of your Personal Inbox when you start Outlook

Displaying shortcuts

The Multimedia Contact Center shortcuts window lists shortcuts to your Personal Inbox and Agent inbox. When you click the Agent Desktop shortcut, Outlook displays two panes.

- **Personal Inbox** displays emails you receive from friends and colleagues.
- **Agent Inbox** displays ACD emails, SMS messages, chats, faxes (contacts) you receive from customers.

To display Multimedia Contact Center shortcuts

1. In Outlook, click **Tools**=>**Options** and select the **Multimedia Contact Center** tab.
2. Under **Multimedia Contact Center startup options**, select the **Display Multimedia Contact Center shortcuts** check box.
3. Click **OK**.

Displaying the agent login window

You can specify the Multimedia Contact Center agent login window is displayed when you start Outlook. On the agent login window, you select an agent login ID for each media type to which you are logging on.

To specify the Multimedia Contact Center agent login window opens when you start Outlook

1. In Outlook, click **Tools**=>**Options** and select the Multimedia Contact Center tab.
2. Under **Multimedia Contact Center startup options**, select the **Display login form** check box.
3. Click **OK**.

Configuring which inbox opens when you start Outlook

When you start Outlook you can scroll up or down in the Mail Folders pane to view your inboxes.

To specify your Agent Inbox opens when you start Outlook

1. In Outlook, click **Tools**=>**Options** and select the **Multimedia Contact Center** tab.
2. Under **Multimedia Contact Center startup options**, select the **Go to my Agent Inbox folder** check box.
3. Click **OK**.

Displaying real-time queue statistics

You can specify that Outlook displays a toolbar of real-time ACD queue statistics.

To view real-time ACD queue statistics in Outlook

1. In Outlook, click **Tools**=>**Options** and select the **Multimedia Contact Center** tab.
2. Under **Multimedia Contact Center startup options**, select the **Display real-time queue statistics** check box.
3. Click **OK**.
Configuring Multimedia Contact Center arrival options
You can specify arrival options for contacts so you are notified when ACD contacts arrive in your inbox: you can configure Outlook to open on top of all other applications and play unique sound files when contacts arrive.

Displaying Outlook as your top window when contacts arrive
NOTE: You can apply this option to email/SMS, chat, and fax media types only.
To specify Outlook opens on top of all other open applications when emails arrive
1. In Outlook, click Tools=>Options and select the Multimedia Contact Center tab.
2. Click the Email arrival options tab, Chat arrival options tab, or Fax arrival options tab.
3. Select the Make Outlook my top window check box.
4. Select the unless an email is active check box.
5. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply settings to all tabs.
6. Click OK.

Directing ACD contacts to your Agent Inbox
NOTE: You can apply this option to email/SMS, chat, and fax media types only.
To specify ACD contacts are sent to your Agent Inbox
1. In Outlook, click Tools=>Options and select the Multimedia Contact Center tab.
2. Click the Email Arrival Options tab, Chat Arrival Options tab, or Fax Arrival Options tab.
3. Select the Go to my Agent Inbox when an email/SMS/chat/fax arrives check box.
4. Select the and when it is finished check box.
5. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply Settings to All Tabs.
6. Click OK.

Configuring contact arrival sounds
NOTE: You can apply this option to email/SMS, chat, multi-chat, and fax media types only.
To specify a Multimedia Contact Center contact arrival sound file
1. In Outlook, click Tools=>Options and select the Multimedia Contact Center tab.
2. Click the Email Arrival Options tab, Chat Arrival Options tab, Multi-Chat Options, or Fax Arrival Options tab.
3. Select the Audibly notify me check box.
4. Select the every check box and select the number of seconds.
5. Click Advanced.
6. Select the Play sound for new message check box.
7. If you want to play a beep, click Play beep and specify the tone and select the number of times the beep will repeat. Otherwise, click Play wav file and click the ellipses button and select the file.
8. Click OK.
9. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply Settings to All Tabs.
10. Click OK.
To specify a Multimedia Contact Center multi-chat contact arrival sound file

1. In Outlook, click **Tools=>Options** and select the **Multimedia Contact Center** tab.
2. Click **Advanced**.
   The Multi chat options window opens.
3. Select the **Play sound for new message** check box.
4. If you want to play a beep, click **Play Beep** and specify the tone and select the number of times the beep will repeat. Otherwise, click **Play Wave File** and click the ellipses button and select the file.
5. Click **OK**.
6. Click **OK**.

**Checking spelling**

**NOTE:** You can apply this option to email/SMS, multi-chat, and fax media types only.

To specify Outlook checks the spelling of emails, SMS messages, and faxes before you send them

1. In Outlook, click **Tools=>Options** and select the **Multimedia Contact Center** tab.
2. Click the **Email Arrival Options** tab, **Chat Arrival Options** tab, or **Fax Arrival Options** tab.
3. Select the **Spell check language** check box.
4. If you want to apply this option to email, SMS messages, and fax contacts, click **Apply Settings to All Tabs**.
5. Click **OK**.

**Replying to faxes with the original fax request**

**NOTE:** You can apply this option to fax only.

To include part or all of the original fax request when you reply to a fax

1. In Outlook, click **Tools=>Options** and select the **Multimedia Contact Center** tab.
2. Click the **Fax Arrival Options** tab.
3. Select the **When replying, send back** check box.
4. Click **first** and specify the number of pages of the original fax to include. Otherwise, if you want to include all pages of the original fax, click **all pages**.
5. Click **OK**.

**Customizing the Agent Inbox columns**

If you right-click the gray bar below Agent Inbox, and select Field Chooser, then select PF6150MCC.ACD, you can select column headers for the Agent Inbox. You drag and drop the columns you want to display. prairieFyre recommends you add the Ticket Number column header to the Agent Inbox.

The Field Chooser Forms list consists of the following column headers for email.

- **From** lists the name of the person who emailed you.
- **No Reply Needed** has a check box you enable if you want to remove a unopened email from your Agent Inbox.
- **Queue ID** lists the email address the customer used to contact your business (support@prairieFyre.com) and the queue that we have assigned to that email address (P505).
- **Last State Change** lists the date (YYYY-MM-DD) the email last changed.
- **Multimedia Contact Center status** lists the status of the email. Arrival status is 1, reply status is 2, and hold status is 3.
- **Client ID** lists customer (client) IDs. A client ID is assigned to a client the first time the client emails your company. The client keeps the same ID for as long as he does business with your company. You cannot manually select client IDs.
• Agent ID lists the email agent ID of the agent who receives the email request.
• Ticket Number lists a unique number for each email.
• Subject lists the subject for each email.
• Received lists the date and time the email arrived in the Agent Inbox.

The Field chooser forms list consists of the following column headers for WebChat.

• Client Chat Name is the name that the customer enters on the chat request form to initiate a chat session with your company.
• Rand (Random) ID number is a randomly generated number used by Multimedia Contact Center for tracking. The agent does not need this number. The agent needs the Session ID number to track the chat message.
• Session ID number is the number the agent uses to track the chat message. It is similar to the ticket number used for email contacts.

Agent actions

Agents use Multimedia Contact Center to control their availability to receive contacts, handle contacts, create and use Multimedia Contact Center templates, and view agent and queue statistics.

Performing agent actions

The Agent actions toolbar menu includes the following submenus:

Employee Control
You can log an agent on or off of all of the media types to which the agent is logged on and set or remove Make Busy Reason Codes for all of the media types to which the agent is logged on.

The Reconnect to the real-time server command reconnects you to the Enterprise Server should you become disconnected. When you click Reconnect to the real-time server, the Multimedia Contact Center login window opens.

Voice, Email/SMS, Chat, and Fax Actions
You can Log an agent on or off of the media type selected and set or remove Make Busy Reason Codes for the media type selected.

Force Forward
If an agent is responding to a contact receives a second contact, the agent can click Force Forward to place themselves in Make Busy and requeue the second contact (so it can be handled by another agent). For example, if an agent handling a call receives a chat request, the agent can click Force Forward to requeue the chat.

NOTE: If you accidentally close Outlook, Multimedia Contact Center requeues any contacts waiting in your Agent Inbox.

Logging on

Multimedia agents can log on and off of email/SMS, chat, fax, and voice queues individually or simultaneously. Using Employee Control, agents can configure default logins that log them on to specific media types using specific IDs. See “Logging in to multiple media types” on page 565.
Logging in to multiple media types

To log in to voice, email/SMS, chat, and/or fax

1. In Outlook, click Agent Actions=>Employee Control=>Log On=>Log On (Custom).
2. Select the check boxes of the agent IDs to which you will log on.
3. Select the Save as default check box.
4. Click Log On.
   The Outlook toolbar displays the IDs you used to log in, and the duration of time you have been logged in, for each media type.
   See Figure 20-4.

Figure 20-4 Logging in to multiple media types

Ng in to one media type at a time

To log in to voice, email/SMS, chat, or fax

1. In Outlook, click Agent Actions=>Chat Actions/Email Actions/Fax Actions/Voice Actions=>Log On.
2. Select the check box of the agent ID to which you are logging on, for the media type currently selected.
3. Click Log On.
   The Outlook toolbar displays the agent ID and the duration of time you are logged on to the media type selected.

Setting Make Busy Reason Codes

Multimedia agents can set and remove Make Busy Reason Codes for email/SMS, chat, fax, and voice individually or simultaneously. Using Employee control, agents can set Make Busy for multiple media types simultaneously. See “Setting Make Busy Reason Codes for multiple media types” on page 565.

Alternatively, you can set Make Busy for email/SMS, chat, fax, and voice individually. See “Setting Make Busy Reason Codes for one media type at a time” on page 566.

Setting Make Busy Reason Codes for multiple media types

To set Make Busy Reason Codes across multiple media types

• In Outlook, click Agent Actions=>Employee Control=>Set Make Busy=>Break1.
   Outlook places the agent IDs to which you are logged on, in Make Busy.
   See Figure 20-5.
Figure 20-5  Setting Make Busy

Setting Make Busy Reason Codes for one media type at a time

To set Make Busy Reason Codes for individual media types

- In Outlook, click Agent Actions=>Chat Actions/Email Actions/Fax Actions=>Set Make Busy=>Break1.

  Outlook places the agent ID to which you are logged in, in Make Busy, for the media type selected.

Requeuing contacts

To requeue a contact (place it back in the queue to be handled by another agent)

1. In Outlook, select your Agent Inbox and the email/SMS, chat or fax contact to be requeued.
2. Click Agent Actions=>Force Forward.
3. Click OK.

Contact management

NOTE: The times required to handle contacts differ across media types. You must configure the agent requeue time, hold time, and interflow time for each email, SMS, chat, and fax queue. See “Adding queues” on page 141 to configure handling times.

The Multimedia Contact Center agent handling features include

Replying to contacts

The Reply command displays a window in which you type a response or select a response template. The window provides agent handling options (for example, Account Codes, Hold, Transfer, No Reply Needed).

Applying Account Codes

The Account Codes command tags an email, SMS, or fax contact with an Account Code (for example, to identify what service or product a customer is requesting, or to indicate if the customer is happy with the service). You can tag a contact with multiple account codes.

Placing contacts on Hold

The Hold command places an email, SMS, or fax contact on hold while you gather information or respond to another contact.

Transferring contacts

The Transfer command transfers an email, SMS, or fax contact to another agent, to an external email address (a non-Multimedia Contact Center agent), or to a queue.
**Setting No Reply Needed**
The No Reply Needed command tags an email, SMS, or fax contact with *No Reply Needed* or *Junk Mail*. If an agent receives an email, SMS, or fax from a customer and no response is required, the agent can tag the contact with *No Reply Needed*. The No Reply Needed tag enables you to generate reports showing the contact as having been received, but not requiring a response. If an agent receives an email, SMS, or fax from an unsolicited sales organization, the agent can tag the contact with *Junk Mail*. The system removes contacts tagged with Junk Mail from the ACD Calls Offered and ACD Calls Handled pools so they are excluded from the reports.

**Viewing a client’s history**
The Client history tab displays a client’s contact history.

**Creating and using Multimedia Contact Center templates**
You can create a folder of response templates (standard company responses to frequently asked questions). You can use templates to optimize productivity, reduce response times, and ensure quality with uniform responses when you reply to email, SMS, and chat contacts.

**Creating templates**
To create a template

1. In Outlook, click the Folder List button below the left pane to view a list of Outlook folders.
2. Expand the Public Folder list, right-click All Public Folders, and select New Folder. The Create New Folder window opens.
3. Under Name, type Multimedia Contact Center templates.
4. Click OK. The Multimedia Contact Center templates folder opens in the All Public Folders folder.
5. On the toolbar next to New, click the down arrow.
6. Select Post in This Folder. The Untitled - Discussion window opens.
7. After Subject, type the name of the queue for which you are creating the template (for example, type Support).
8. Type a response in the template.
9. Click Post.

**Using templates**
To select a template and reply to a contact

1. In Outlook, select your Agent Inbox and double-click an unanswered contact to select it.
2. Click Reply. The Reply window opens.
3. Click Select Template.
4. Click the Folder List button below the left pane to view a list of Outlook folders.
5. Expand the Public Folder list, click All Public Folders, and click Multimedia Contact Center templates.
6. Under Multimedia Contact Center templates, double-click a template to select it. The template information opens in the body of your message.
7. Type any additional information required.
8. Click Send.
Replying to emails/SMS messages
To reply to an email/SMS message
1. In Outlook, double-click an email/SMS message in your Agent Inbox to open it.
2. Click **Reply**.
   The Reply window opens.
3. Type a response and/or double-click a response template to insert the content into the body of the email/SMS message.
4. Click **Send**.

Replying to chats
To reply to a chat
1. In Outlook, double-click a chat request in your Agent Inbox to open it.
2. Click **Reply**.
   See Figure 20-6.
3. Type a response and/or double-click a response template to insert the content into the body of the email.
   See "Creating and using Multimedia Contact Center templates" on page 567.
4. Click **Send**.

Figure 20-6 Chat reply

To chat with multiple people
1. In Outlook, while you have a chat open in the chat window, click a second chat to open it.
2. Click the chat tabs to switch between the chat sessions.
   **NOTE:** You can click **View longest waiting client** to open the chat window of the client who has been waiting the longest for a chat reply.
Viewing faxes
When you open a fax contact in Outlook, it will open in the Multimedia Contact Center fax viewer. Within fax viewer, you can control the following options:
- **Zoom**
  Enables the user to zoom in and out of the selected page view.
- **Thumbnail viewer**
  Enables the user to preview pages in the left pane of the fax viewer.
- **Page selector**
  Enables the user to select which page of the fax will display in the right pane of the fax viewer.
- **Thumbnail toggle**
  Enables the user to show/hide the thumbnail pane.
- **Print**
  Enables the user to quickly print the fax document to the default printer.
- **Magnifier**
  Enables the user to zoom in to a specific section of the fax, which can be useful for viewing small text or smeared sections of the faxed document.

Replying to faxes
To reply to a contact
1. In Outlook, double-click a fax in your Agent Inbox to open it.
2. Click **Reply**.
   The Reply window opens.
3. Type a response.
   You can reply by email, SMS, or fax.
4. Click **Send**.

Tagging contacts with Account Codes
You configure Account Codes in YourSite Configuration. See “Adding Make Busy Reason Codes” on page 161.

To tag a contact with an Account Code
1. In Outlook, double-click a contact in your Agent Inbox to open it.
2. Click **Reply**.
   The Reply window opens.
3. Click **Account Codes**.
4. elect the check box of the Account Code to be applied.
5. Click **Submit**.

Placing contacts on hold
If you cannot answer a contact immediately, you can place it on hold temporarily. You can still receive other contacts while the initial contact is on hold. When you are ready to answer the contact, you select it, respond to it, and send it as you would a new contact.

To hold a contact
1. In Outlook, double-click a contact in your Agent Inbox to open it.
2. Click **Reply**.
   The Reply window opens.
3. Click **Hold**.
   The agent state icon changes to indicate the agent is holding the contact.
   See Figure 20-7.
Transferring contacts
To transfer a contact to an agent
1. In Outlook, double-click a contact in your Agent Inbox to open it.
2. Click Reply.
   The Reply window opens.
3. Click Transfer.
   The Multimedia Contact Center transfer window opens.
4. Select the check box of the Agent ID to which you are transferring the contact.
5. Click Transfer.

Setting No Reply Needed
To set No Reply Needed
1. In Outlook, double-click a contact in your Agent Inbox to open it.
2. Click Reply.
   The Reply window opens.
3. Click No Reply Needed.
   The Multimedia Contact Center Outlook Plug-in window opens.
4. Click Yes.

Viewing client history
A client history record displays case numbers, ticket numbers, and transcript for a case. You can view client history on the Client history tab of each Multimedia Contact Center contact.

The Client history tab displays contact history in the following ways
• All correspondence associated with the current case
• The entire history of all contacts, from and to customers
• The history of a specific contact (you request by typing the message ID of the contact)
• The transcript of the current message
**Viewing current case history**

To view all correspondence associated with the current case

1. In Outlook, double-click a contact in your Agent Inbox.
2. Click the **Client history** tab.
3. Click **Display current case**.
   - The case and transcript numbers for the current case are highlighted.

**Viewing entire contact history**

To view the entire history of all contacts

1. In Outlook, double-click a contact in your Agent Inbox.
2. Click the **Client history** tab.
3. Click **Display entire history**.

**Viewing a specific contact history**

To view a specific email, SMS, chat, or fax

1. In Outlook, double-click a contact in your Agent Inbox.
2. Click the **Client history** tab.
3. Click **Display specific email/SMS/chat/fax**.
4. Type the message ID, proceeded by pf (for example, pf0000000029).
5. Click **OK**.
Chapter 21

Contact Center Management
Enterprise Node

*Enterprise Node Configuration*
*Enterprise Node Installation*
Contact Center Management Enterprise Node

NOTE: A single Contact Center Management Enterprise Node can collect data for one voice media server, one email media server, and one chat media server. If you have two voice media servers, you require a second Enterprise Node license.

The Enterprise Node enables you to set up a remote collection point at a separate location. Enterprise Node provides multi-site contact center capabilities using a single-server configuration.

Enterprise Node software
Enterprise Node software collects raw data from the remote media server and both files the data to the local hard drive and streams it to the prairieFyre Collector Service (on the Enterprise Server) over TCP/IP. The prairieFyre Collector Service gathers the data, and the Enterprise Service makes it available for enterprise-wide real-time monitoring and reporting. Enterprise Node software does not require SQL, IIS, or other server support applications at your remote sites. This results in significant cost savings. In addition, the redundant data collection provides added security in case of network outages.

The Enterprise Node software performs the following functions:
• Collects ACD and SMDR data from single or co-located telephone systems
• Stores ACD and SMDR data on the local Enterprise Node server
• Streams real-time ACD and SMDR data to the Enterprise Server for enterprise-wide real-time statistics which automatically synchronizes and stores all contact center statistics on the Enterprise Server for accurate, multi-site, historical reporting
• Uses a telephone system neutral collection process that allows you to collect data and run reports on contact centers with various Mitel telephone systems

Enterprise Node license
An Enterprise Node license enables a company to collect call costing data from co-located or geographically dispersed telephone systems beyond the single telephone system collection license included in Contact Center Management.

Enterprise reporting
Enterprise reporting relies on two types of collectors: the Enterprise Node (located at branch offices) and the prairieFyre Collector Service (a remote node, collector service that communicates with the Enterprise Service).

In order for data to be collected at a remote site, the Enterprise Node software must be deployed at that site. The Enterprise Node contains a data collector. It collects data from a Mitel telephone system or from other media types, and stores the information at that site. The prairieFyre Collector Service, which resides at the Enterprise Server site, gathers the information from your remote site server (Enterprise Node server) and stores it as raw data. The Enterprise Service, which also resides on the Enterprise Server, summarizes and then stores the data (SQL), and produces real-time data for the real-time monitors.

Enterprise Node versus Enterprise Server
The Enterprise Node collector collects raw data from a single media server at the remote site. The Enterprise Node streams this data to the Enterprise Server.

The Enterprise Server consists of the prairieFyre Collector Service and the Enterprise Service. The prairieFyre Collector Service collects raw data from all of the (both local and branch office) media servers. The Enterprise Service summarizes the raw data, stores it on the SQL Server, and produces enterprise-wide data for the real-time and reporting applications. (See Figure 21-1.)
**Figure 21-1  Enterprise Node versus Enterprise Server**

**Enterprise Node**

The Enterprise Node collector collects raw data from media servers at the remote site.

**Enterprise Server**

- **prairieFyre .NET Collector**
  
  The prairieFyre .NET Collector collects raw data from all media servers.

- **Enterprise Service**
  
  The Enterprise Service summarizes the raw data and stores it on the SQL server, and it produces real-time data for monitors and reports.

**Enterprise Node configuration**

**NOTE:** If the Wide Area Network (WAN) link between a remote site and the Enterprise Server goes down, the managers and supervisors at the remote site cannot view real-time data on their site until the WAN connection is restored. However, if the WAN link is down, data collection at the remote site continues.

You can run both the Enterprise Node software and the Enterprise Server on a single computer or on separate computers.

**Setting up Enterprise Node examples**

You can set up the Enterprise Node in the following ways.

- Enterprise Node server at the remote site (recommended)
- No dedicated server at the remote site

**Scenario 1 - With a dedicated server at the remote site**

In this example, the enterprise consists of the following. (See Figure 21-2.)

**Contact center 1 - Kanata (prairieFyre Collector Service) with one media server (SX-2000 ACD)**

The Enterprise Server resides at site 1 in Kanata. The prairieFyre Collector Service collects data from all of the media servers at that site. There is one media server at the Kanata site (SX-2000 ACD). No Enterprise Node is required at this site.

When setting up your enterprise, you add the first site (Kanata) and then add the first media server (SX-2000 ACD). The first media server has the IP address 28.1.1.1 and IP port 5400.
Contact center 2 - Boston (Enterprise Node) with one media server (3300 ICP)
The second media server resides at site 2 in Boston. The media server in Boston is a 3300 ICP. You do not require a dedicated server because you have a 3300 ICP media server. However, you must install an remote note at the remote site if the media servers communicate over RS-232, and not TCP/IP. The media servers like the 3300 ICP, which communicate over TCP/IP, have the unique ability to send data over TCP/IP without the use of a dedicated server. However, to prevent data loss from the Boston site should the WAN go down, you decide to install a dedicated server in Boston. The Enterprise Node software is deployed on the dedicated server. Therefore, all of the Boston raw data is stored on the dedicated server in Boston. If the WAN goes down, data is still collected locally in Boston and no data is lost. All of the raw and summarized data is stored at the site with the Enterprise Server (Miami) by the prairieFyre Collector Service. Continuing to set up your enterprise, you add the second site (Boston) and then add the Boston media server (3300 ICP). The Boston media server has the IP address 256.1.1.1 and IP port 5401. You must have the Enterprise Node license to add the remote site to your enterprise.

Figure 21-2  Enterprise Node scenario 1 connectivity

Scenario 2 - No dedicated server at the remote site

CAUTION: If you do not have a dedicated server at the remote site, data at the remote site is permanently lost if the WAN goes down.

In this example, the enterprise consists of the following. (See Figure 21-3.)

Contact center 1 - Miami (prairieFyre Collector Service) with one media server (SX-2000 ACD)
The Enterprise Server resides at site 1 in Miami. The prairieFyre Collector Service collects data from all of the media servers at that site. There is one media server at the Miami site (SX-2000 ACD). No Enterprise Node is required at this site. When you set up the enterprise, you add the first site (Miami) and then add the first media server (SX-2000 ACD). The first media server has the IP address 73.1.1.1 and IP port 5400.
Contact center 2 - Houston (Enterprise Node) with one media server (3300 ICP)
The second media server resides at site 2 in Houston. The media server in Houston is a 3300 ICP. A
dedicated server is not required because of the 3300 ICP media server. Also, the Enterprise Node software is
not deployed at the remote site. The 3300 ICP media server has the unique ability to send data over TCP/IP
without the use of a dedicated server. Therefore, all of the raw and summarized data is stored at the site with
the Enterprise Server (Miami) and no data can be stored at the Houston site. While the WAN is down, all of
the data produced in Houston is lost.
Continuing to set up your enterprise, you add the second site (Houston) and then add the Houston media
server (3300 ICP). The Houston media server has the IP address 73.1.1.1 and IP port 5401. Using this set up
the prairieFyre Collector Service collects the raw data from the Houston site, therefore, you use the Miami IP
address. You must have the Enterprise Node license to add the remote site to your enterprise.

Figure 21-3 Enterprise Node scenario 2 connectivity

Enterprise Node Installation
In multi-site contact centers that use Contact Center Management, it is necessary to install an Enterprise
Node at each site except the site where the Enterprise Server resides (a remote site with a media server that
communicates over TCP/IP is the exception). The prairieFyre Collector Service resides at the contact center
that has the Enterprise Server software installed and it collects data at that site. See “Scenario 2 - No
dedicated server at the remote site” on page 577.

Enterprise Node software collects the raw data from all of the media servers at the remote site. The Enterprise
Node enables supervisors at remote sites to monitor contact center activities in real-time and run reports on
their sites without having to install an Enterprise Server at that site.
Installing Enterprise Node software

To install Enterprise Node software on the remote site server

1. Start Internet Explorer and browse to the Enterprise Server by typing http://[your Enterprise Server IP address]/CCMWeb/.
2. Obtain a user’s account from your system administrator and log on to the Enterprise Server. The Contact Center Management Web application opens.
3. Click Help=>Software Downloads/Installations=>Remote Server to install the Contact Center Management Enterprise Node software.

Viewing the status of the data collection

Enterprise Node software collects the data from all of the media servers at the remote site (a remote site with a media server that communicates over TCP/IP is the exception) See “Scenario 2 - No dedicated server at the remote site” on page 577.

You can use Network Monitor to verify you are collecting data and to view the status of data collection. See “” on page 319.
Chapter 22
CTI Developer Toolkit

Functional overview
Primary object classes
Sample applications
Common user scenarios and source code examples
Troubleshooting
CTI Developer Toolkit

NOTE: If you require the calculations used to populate Contact Center Management and Call Accounting reports to use in your custom application built with the CTI Developer Toolkit, a subset of these calculations can be found in the Advanced Data Access Guide, which can be found at http://www.prairiefyre.com/support/download-software.

Mitel Computer Telephony Integration (CTI) Developer Toolkit is a programmable .NET C# Dynamic-link library (DLL) that can be used in any .NET 3.5 SP1 application or website. The CTI Developer Toolkit completes the migration from Mitel Agent Portal to Mitel Contact Center Screen Pop.

The CTI Developer Toolkit is offered in two forms: server side and client side license. The server side license provides the ability to insert custom real-time IVR collected data to each incoming call. It also uses the Contact Center Screen Pop infrastructure to deliver third-party data to agent desktops (using either the client side license or Contact Center PhoneSet Manager). The client side license provides basic telephony functions (answer, hang up, transfer, and hold), provides agent control (such as set/remove Make Busy) and delivers caller information such as ANI, DNIS, Collected Digits, and call notes in real time as calls arrive. The client side license may be used to display information in CRM, Microsoft Outlook, or custom applications.

For installation information and procedures, see "Installing the CTI Developer Toolkit" in the Contact Center Management Installation Guide.

NOTE: Once you have installed the CTI Developer Toolkit, typically to <installation_drive>:\Program Files\prairieFyre Software Inc\CTI Developer Toolkit, you can access the DLLs required to create customized applications in the CTI Developer Toolkit\Redist folder. You must include the entire Redist folder with your final compiled custom application or it will not function properly.

The CTI Developer Toolkit includes a number of sample applications, including source code, that can be used to test CTI Developer Toolkit functionality. For a complete overview of the sample applications included, see “CTI Developer Toolkit sample applications” on page 587.

The CTI Developer Toolkit is currently available with the following functionality:

- Connect and disconnect from the Contact Center Management Enterprise Server with user authentication
- Retrieve devices from the Contact Center Management configuration database, based on all
  - All agent devices for the user currently logged on to the system
  - All agent devices associated with employees
  - All extensions
  - All queues
- Set real-time monitors on agents, extensions, and queues to receive notification when
  - A call is received (including call detail information)
  - A device state changes (for example, idle, ACD, and hold)
- Set phone monitors on agents and extensions to receive notification when
  - A call is received (including call detail notification)
  - A call is made
  - A call is cleared
  - A call is transferred
  - A call is conferenced
  - A call is established
  - A call fails
• Control a device (for example, set/remove Do Not Disturb or Make Busy)
• Make calls from agent or extension devices
• Place calls on hold
• Retrieve calls that are on hold
• Remove calls from queues
• Redirect calls from queues to agents/extensions
• Transfer or conference calls between agent and extension devices
• Clear calls for agent and extension devices
• Add call detail information from third-party IVRs and dialers. This information is available to client applications in the Call Received event

Table 22-1 lists the major areas of functionality exposed with each version of the CTI Developer Toolkit. The version specified indicates the most recent version, including any service packs, available to customers.
### Table 22-1 Supported functionality by version

<table>
<thead>
<tr>
<th>Functional Area</th>
<th>Version 5.4</th>
<th>Version 5.5</th>
<th>Version 5.6</th>
<th>Version 5.7 SP1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Application events</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Connection state changes</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Configuration loaded</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td><strong>Device Information</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Get all devices</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Get all extension</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Get all agents</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Get all queues</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Get agents by login</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Get agents for all employees</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Device events</strong>¹</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Device state changed</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Voice events</strong>²</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Call info received</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Call delivered</td>
<td></td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Call received</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Call cleared</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Call transferred</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Call established</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Call failed</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Call diverted</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Call originated</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Call retrieved</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td><strong>Extension events</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Extension state changed</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Agent events</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Agent state changed</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Functional Area</td>
<td>Version 5.4</td>
<td>Version 5.5</td>
<td>Version 5.6</td>
<td>Version 5.7 SP1</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------</td>
<td>-------------</td>
<td>-------------</td>
<td>----------------</td>
</tr>
<tr>
<td><strong>Queue events</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Queue Now statistics</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Queue totals statistics</td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>• Interactive Visual Queue delta</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Interactive Visual Queue snapshots</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Voice control</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Make call</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Clear call</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>• Answer call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Hold call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Retrieve held call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Conference call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Transfer call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Make consultation call</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Transfer consultation call</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>• Cancel consultation call</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Agent control</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Login</td>
<td>x(^4)</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Logout</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Set Make Busy</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Remove Make Busy</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Set Do Not Disturb</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Remove Do Not Disturb</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Cancel work timer</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Conference call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Group presence</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td><strong>Queue control</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Redirect call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>• Remove call</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>IVR integration</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Add call detail(^5)</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>
Device events are supported by all device types.

Voice events are supported by extension and agent devices.

Voice control is supported by extension and agent devices.

Only hot desk agent logins are supported in Version 5.4. Both hot desking and traditional agent logins are supported with Version 5.5 SP1 or greater.

The AddCallDetail method requires a CTI Developer Toolkit server license.

**NOTE:** The CTI Developer Toolkit may also be referred to as the prairieFyre.CallControl.Toolkit namespace throughout this chapter and in the CHM help file documentation, as the CHM help file included with the CTI Developer Toolkit is sourced from the source code, which refers to the namespace by this name.

Table 22-2 lists and describes the top level classes available with the CTI Developer Toolkit.

### Table 22-2 Primary object classes

<table>
<thead>
<tr>
<th>Class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeviceManager</td>
<td>This class contains functionality to manage the connection to the Enterprise Server and provides access to configured agents, extensions, and queues.</td>
</tr>
<tr>
<td>Device</td>
<td>This abstract class includes the core properties for all device types. Objects of this class may not be directly instantiated.</td>
</tr>
<tr>
<td>Voice</td>
<td>This class is derived from the Device class and serves as the base class for the agent and extension classes. It includes properties and functionality that is specific to devices with voice characteristics.</td>
</tr>
<tr>
<td>Agent</td>
<td>This class is derived from the Voice class. It represents both traditional ACD and hot desking agents. Specialized functionality handled in this class includes agent control operations, such as agent login and set/remove Make Busy.</td>
</tr>
<tr>
<td>Extension</td>
<td>This class is derived from the Voice class. It represents configured extensions.</td>
</tr>
<tr>
<td>Queue</td>
<td>This class is derived from the Device class. It represents configured queues. It includes properties and functionality that is specific to the queue device. Specialized functionality handled in this class includes set/remove Do Not Disturb, redirect call, and remove call.</td>
</tr>
</tbody>
</table>

**CTI Developer Toolkit sample applications**

There are currently four sample applications, including source code, that are included with the CTI Developer Toolkit.

**Device Monitor**

The Device Monitor sample application provides a graphical user interface that enables developers to connect to the Contact Center Solutions Enterprise Server, retrieve a list of devices, perform agent control activities on the retrieved devices (for example, login/logout, set/remove Make Busy, etc.), perform call control activities (for example, make call, answer call, clear call, etc.), and retrieve call event notifications. (See Figure 22-1.)
To use the CTI Developer Toolkit Device Monitor sample application

1. Click **Start**=>**All Programs**=>**Mitel**=>**CTI Developer Toolkit**=>**Device Monitor**. The Device Monitor sample application opens.
2. Click **File**=>**Connect**.
3. Type the IP address of the Enterprise Server, user name, and password and click **OK**.
4. Click **Devices** and select one of the following options:
   - Retrieve agents for current login
   - Retrieve agents for all employees
   - Retrieve all agents
   - Retrieve all extensions
   - Retrieve all queues
   - Retrieve all devices
5. Once the devices you selected have loaded, you perform actions on the selected device(s) by clicking **Actions** and selecting an available action or by right-clicking and selecting an available action from the list:
   - Set monitor=>Phone, Real time, All
   - Remove monitor=>Phone, Real time, All
   - Login
   - Logout
   - Set Make Busy
   - Remove Make Busy
   - Set DND
   - Remove DND
   - Cancel work timer
   - Make call
   - Answer call
- Hold call
- Retrieve call
- Transfer call
- Conference call
- Clear call
- Add call notes
- Make consultation call
- Transfer consultation call
- Cancel consultation call

Queue Monitor
The Queue Monitor sample application displays the functionality and support for queue device types included with the CTI Developer Toolkit. The QueueMonitor application is similar to the optional Interactive Visual Queue monitor that is housed in Contact Center Client. It enables developers to connect to the Contact Center Solutions Enterprise Server, load a set of queues, and view real-time call activity (calls entering and exiting queues) and queue statistics (for example, calls waiting, number of agents available, longest waiting, etc.). (See Figure 22-2.)

Figure 22-2 Queue monitor sample application

To use the CTI Developer Toolkit Queue Monitor sample application
1. Click Start=>All Programs=>Mitel=>CTI Developer Toolkit=>Queue Monitor. The Device Monitor sample application opens.
2. Click File=>Connect.
3. Type the IP address of the Enterprise Server, user name, and password and click OK.
4. Click Actions:
5. Select one or more queues to open.
6. Click **OK**.
   If you selected multiple queues, you can toggle between them using the tabs at the bottom of the queue monitor.

7. Once the queues you selected have loaded, you perform actions on the selected device(s) by clicking **Actions** and selecting an available action or by right-clicking and selecting an available action from the list:
   - Open queue
   - Close queue
   - Set DND
   - Remove DND
   - Redirect call
   - Remove call

**Console Call Monitor**

The ConsoleMonitor sample application displays call received information for either single or multiple agents or extensions in a simple console application window. It is intended to be a very brief example, with little error handling, that can be used to demonstrate the basics of coding screen pop displays.

To use the CTI Developer Toolkit Console Call Monitor sample application

1. Click **Start=>Run**.
2. Type **cmd** and click **Enter**.
3. Type `cd "<installation_drive>:\Program Files\prairieFyre Software Inc\CTI Developer Toolkit\Samples\ConsoleCallMonitor\bin"` and click **Enter**.
4. Type **ConsoleCallMonitor.exe Device Number/Telephone System IP Address/Type** and click **Enter**.

   The Console Call Monitor application takes multiple parameters in the following form, Device Number/Telephone System IP Address/Type. For example, 2000/10.1.1.1/Agent 1800/10.1.1.10/Extension would invoke agent 2000 on telephone system 10.1.1.1 and extension 1800 on telephone system 10.1.1.10.

**Console Queue Monitor**

The ConsoleQueueMonitor sample application displays information on calls entering/exiting queues and queue statistics in a simple console application window. Similar to the ConsoleCallMonitor application, it represents a minimal set of code required to build a real-time queue monitoring application.

To use the CTI Developer Toolkit Console Queue Monitor sample application

1. Click **Start=>Run**.
2. Type **cmd** and click **Enter**.
3. Type `cd "<installation_drive>:\Program Files\prairieFyre Software Inc\CTI Developer Toolkit\Samples\ConsoleQueueMonitor\bin"` and click **Enter**.
4. Type **ConsoleQueueMonitor.exe Queue/Telephone System IP Address** and click **Enter**.

   The ConsoleQueueMonitor application takes multiple parameters, in the following form: Queue/Telephone System IP Address. For example: P200/10.1.1.1 P180/10.1.1.10 would invoke monitoring calls on two queues, queue P200 on telephone system 10.1.1.1 and queue P180 on telephone system 10.1.1.10.
Best practices for custom development

The following best practices must always be followed when developing custom developments to work in conjunction with Contact Center Solutions software.

• Before you begin development
  • Verify that the CTI Developer Toolkit and Contact Center Solutions software are the same version and that you are properly licensed for all desired functionality
  • Verify that you have access to the Contact Center Management Enterprise Server
  • Verify that the Contact Center Solutions Enterprise Server has been properly set up and configured with the extensions, agents, and queues that you will be using with your custom application
  • Verify that the telephone system(s) in your enterprise has been properly set up and configured with the extensions, agents, and queues that you will be using with your custom application
  • Verify that all pre-installation and post installation steps have been completed. See "Installing the CTI Developer Toolkit" in the Contact Center Management Installation Guide
  • Confirm the telephone system conforms to the guidelines stated in the Golden Rules document. In particular, aspects of the CTI Developer Toolkit rely on the ability to set MiTAI monitors on devices. As such, the "HCI Options" must be enabled for the Class of Service on all monitored devices. See http://www.prairiefyre.com/wp-content/rscs/documentation/Golden%20Rules.xls
  • Verify you have Microsoft .NET Framework Version 3.5 SP1 or greater installed on your workstation
  • Verify you have an IDE installed on your workstation, either Visual Studio 2005/2008 or SharpDevelop

• When developing custom applications and integrations
  • Verify the what you are attempting to build is possible by attempting the functions from an alternate client application, such as Contact Center Client, the Device Monitor sample application, or MiTAI Browser
  • Routinely check the log files of all related services, specifically the Enterprise Server, Collector, and MiTAI Proxy Server to ensure there are no unusual or unexpected warnings or errors
  • Routinely check the log files of alternative client applications for any unusual or unexpected warnings or errors (as listed in the previous bullet)

The following best practices must always be followed when developing custom connectors to third-party IVRs.

• Third-party IVR ports and Intelligent Queue ports must all be programmed in YourSite Explorer, but not enabled with Advanced Real-time and Reporting licenses
• In addition to whatever custom data your third-party IVR is sending, it must also send the same data that Intelligent Queue does (using the same naming conventions). These are PFANI, PFCALLERNAME, and PFDNIS. This will ensure that the existing MiTAI record linking logic within the Contact Center Management Enterprise Server gets the correct information, which is typically at the first controller/port
Common user scenarios and source code examples

This section details the following common user scenarios for developing custom integrations and applications using the CTI Developer Toolkit:

- Click to dial
- Call received notification
- Add call detail (using a third-party IVR)

Click to dial

NOTE: This code sample is not included in the sample project that is included with the CTI Developer Toolkit.

The following C# code fragment provides sample source code that can be used to build a console application with click-to-dial functionality.

```csharp
static void Main()
{
    DeviceManager dm = DeviceManager.Instance;
    string pbxIpAddress = "10.1.1.10";
    string server = "the-CCM-server-IP-address-here";
    string username = "your-username-here";
    string password = "your-password-here";
    Voice extension;

    if (!dm.Connect(server, 5024, username, password))
    {
        Console.WriteLine("Unable to connect to server");
        return;
    }

    extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;

    if (extension == null)
    {
        Console.WriteLine("Unable to retrieve extension device");
        return;
    }

    if (!extension.SetMonitor())
    {
        Console.WriteLine("Unable to monitor extension");
        return;
    }

    device.MakeCall("16135990045");

    dm.ReleaseAllDevices();
    dm.Disconnect();
    Console.WriteLine("Exit application");
}
```

This source code will connect to the specific Enterprise Server using the supplied username and password. It then initiates a call from extension 1100 on the telephone system with IP address 10.1.1.10 to the phone number 16135990045.
Call received notification

The following C# code fragment shows a condensed version of the source code provided with the ConsoleCallMonitor sample application that is shipped with the CTI Developer Toolkit.

```csharp
static void Main()
{
    DeviceManager dm = DeviceManager.Instance;
    string pbxIpAddress = "10.1.1.10";
    string server = "the-CCM-server-IP-address-here";
    string username = "your-username-here";
    string password = "your-password-here";
    Voice extension;

    if (!dm.Connect(server, 5024, username, password))
    {
        Console.WriteLine("Unable to connect to server");
        return;
    }

    extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;

    if (extension == null)
    {
        Console.WriteLine("Unable to retrieve extension device");
        return;
    }

    if (!extension.SetMonitor())
    {
        Console.WriteLine("Unable to monitor extension");
        return;
    }

    device.CallInfoReceived += CallInfoReceivedHandler;

    Console.WriteLine("Listening for calls on extension 1100");
    Console.WriteLine("Press any key to end application.");
    while (!Console.KeyAvailable) ;

    dm.ReleaseAllDevices();
    dm.Disconnect();
    Console.WriteLine("Exit application");
}

static void CallInfoReceivedHandler(object sender, CallInfoReceivedEventArgs e)
{
    Console.WriteLine("-----------------------------------------------");
    Console.WriteLine("Call Info Received:");
    Console.WriteLine("  Caller Name      : " + e.Info.CallerName);
    Console.WriteLine("  Caller Number    : " + e.Info.CallerNumber);
    Console.WriteLine("  DNIS             : " + e.Info.DNIS);
    Console.WriteLine("  Collected Digits : " + e.Info.CollectedDigits);
}
```
Add call detail (using a third-party IVR)

The following C# code fragment shows a condensed version of using the AddCallDetail method to toolkit users can invoke to add custom key/value pairs into call information.

In summary, this code fragment does the following:

- `Device_CallReceived` is an event handler that is invoked whenever a monitored IVR extension/port receives a call. This is needed to acquire the MiTAl Call ID which is used to link these extra information records (--w records in ACD data files to other call records
- When this event handler is invoked, it makes three sequential calls to the AddCallDetail method, adding call values for the following keys: `PFANI`, `PFCALLERNAME`, and `PFDNIS`
- The keys used above are the ones that the default screen pop display recognizes, but developers can easily make up their own key names as well, provided they have toolkit code on the client side to pull the custom information from the `CallInfoRecievedEvent` notifications

```csharp
public void Device_CallReceived(object sender, CallReceivedEventArgs e)
{
    Device device = sender as Device;

    DeviceManager.Instance.AddCallDetail(
        e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID, 
        "PFANI", "6135990045");

    DeviceManager.Instance.AddCallDetail(
        e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID, 
        "PFCALLERNAME", "John Smith");

    DeviceManager.Instance.AddCallDetail(
        e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID, 
        "PFDNIS", "8001");
}
```
Troubleshooting CTI Developer Toolkit issues

Diagnosing any issues experienced while using the CTI Developer Toolkit requires a high level of familiarity with Contact Center Solutions and Call Accounting applications and CTI Developer Toolkit functionality. This section details several troubleshooting tips and tricks when encountering issues with CTI Developer Toolkit functionality.

The CTI Developer Toolkit and any custom applications created using it rely heavily on the proper configuration and operation of the Contact Center Solutions Enterprise Server. Ensuring that the server is operating correctly is the first diagnostic step that should be taken when troubleshooting CTI Developer Toolkit issues. This includes:

- Verifying that the CTI Developer Toolkit and Contact Center Solutions software are the same version and that you are properly licensed for the desired functionality
- Verifying that all pre-installation and post installation steps have been completed. See "Installing the CTI Developer Toolkit" in the Contact Center Management Installation Guide
- Checking the log files of all related services, specifically the Enterprise Server, Collector, and MiTAI Proxy Server to ensure there are no unusual or unexpected warnings or errors
- Attempting the same operation using an alternate client application. This can be any of the following, depending on the underlying issue:
  - Contact Center Client
  - Device Monitor sample application
  - MiTAI Browser
- Checking the log files of alternative client applications for any unusual or unexpected warnings or errors (as listed in the previous step)
- Confirming the telephone system conforms to the guidelines stated in the Golden Rules document. In particular, aspects of the CTI Developer Toolkit rely on the ability to set MiTAI monitors on devices. As such, the "HCI Options" must be enabled for the Class of Service on all monitored devices. See http://www.prairiefyre.com/wp-content/rscs/documentation/Golden%20Rules.xls

Troubleshooting specific issues

This section describes some specific problems that may be encountered when working with the CTI Developer Toolkit and provides any recommended steps for diagnosing issues and potential solutions.

Retrieve All commands does not display any devices

If any of the Retrieve All commands in the Device Monitor application return an empty list of devices, there may be a configuration problem with the IPAddress values stored in the CCMData database table named tblEnterpriseConfig_Node.

To troubleshoot this issue, run the following SQL query and pay particular attention to values in the [IPAddress] column. This query simulates the query used by the CTI Developer Toolkit and will return a list of agents and extensions for all voice media servers.
SELECT node.Name AS [Node],
    node.IPAddress AS [IP Address],
    'Agent' AS [Type],
    device.FirstName AS [First Name],
    device.LastName AS [Last Name],
    device.Reporting AS [Reporting Number]
FROM tblConfig_Agent device INNER JOIN tblEnterpriseConfig_Node node
    ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
    ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
UNION
SELECT
    node.Name AS [Node],
    node.IPAddress AS [IP Address],
    'Extension' AS [Type],
    '' AS [First Name], -- No first name on extensions
    '' AS [Last Name], -- No last name on extensions
    device.Reporting AS [Reporting Number]
FROM tblConfig_Extension device INNER JOIN tblEnterpriseConfig_Node node
    ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
    ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
ORDER BY [Node], [Type]

The [IP Address] values in the query results should contain the IP address of the telephone system that is associated with the voice media server. If this value is incorrect or blank, use YourSite Explorer to set the IP address to the correct value.

**GetDevice method fails or returns null unexpectedly**

If a custom application calls the `GetDevice` method and returns null even though the device is valid and programmed in Contact Center Management, there may be a timing issue with the Connect operation. When a custom application calls the `Connect` method in the CTI Developer Toolkit, the operation returns as soon as an authenticated connection has been established with the Enterprise Server. However, there may still be some basic configuration loading occurring in the background, which must complete before calls to `GetDevice` can be successful.

In Version 5.6 and Version 5.7 SP1, a new event named `ConfigurationLoaded` is provided, which is used to notify custom applications that background configuration loading has completed. In previous versions, the Device Monitor sample application used a workaround method of issuing a `Sleep` method call on the active thread to give background configuration loading time to complete.

**Agent control actions succeed while call control actions fail**

In this scenario, agent control actions (for example, login, logout, and set/remove Make Busy) succeed, while call control actions (for example, make call, answer call, and clear call) fail. The key difference between these two types of operations is that call control actions require a MiTAI monitor set on the device and agent control actions do not. Your investigation should start with an analysis of MiTAI related configuration, including:

- Verifying that the MitaiEnabled flag set properly for devices in the database
- Checking telephone system (for example, HCI Options enabled)
- Confirming the telephone system version is supported
Unable to set monitor on agent device

In some cases, using the Device Monitor to issue a Set Monitor operation on an agent will fail. If you have the Errors view open in the application, it displays a MiTAI error, indicating "Operation failed: MessageTag[8] ReturnCode [SXERR_FEATURE_NOT_ALLOWED]"

In this case, you should verify that the agent device is properly configured on the telephone system, including HCI Options enabled for the associated Class Of Service. If the problem persists, check to see if the CTI Developer Toolkit is Version 5.5 or earlier and if the agent is a traditional or hot desking agent. There was a known issue setting monitors on traditional ACD agents using the CTI Developer Toolkit that was corrected in 5.5 SP1. For earlier versions, one workaround is to set the monitor on the extension the agent logs in to.

Web service errors occurring in log files

If you encounter Web service error messages in log files and an application built with the CTI Developer Toolkit is experiencing errors, check to ensure that the Microsoft.Web.Services3.dll file is present under the Windows system directory or in the custom application directory.

"Softphone proxy did not respond after 30 seconds" error

If you encounter this message and the Contact Center Solutions software is Version 5.5 SP2 or earlier, there is a known licensing issue where the MiTAI Proxy Server will fail to send clients messages unless there is at least one Contact Center Softphone or Contact Center PhoneSet Manager license in your enterprise. This issue was corrected in version 5.5 SP3. To workaround this problem, you will need to contact prairieFyre Software technical support at 613-599-0045 and have them create new license files.
Chapter 23
Salesforce.com Integration

Installing Salesforce.com Integration
Using Salesforce.com Integration
Salesforce.com Integration

Salesforce.com Integration is an optional client application that works in conjunction with Contact Center Management and/or Call Accounting and requires an account with Salesforce.com (Enterprise edition), and, optionally, Intelligent Queue (for Collect Caller Entered Digits only).

NOTE: Salesforce.com Integration is currently supported for use with the 3300 ICP only.

Salesforce.com Integration enhances the functionality of Salesforce by embedding your Mitel phone directly into the Salesforce user interface. This improves productivity by providing fast and easy access to accounts, contacts, cases, and other Salesforce objects directly related to incoming calls. Using Salesforce.com Integration enables your contact center agents to perform their job functions through a single user interface.

Salesforce.com Integration is compatible with the Salesforce.com Microsoft Outlook connector. Users can synchronize their Salesforce.com contacts, tasks, and calendar events, associate Outlook email messages, and map custom fields in Salesforce.com to fields in Outlook.

Salesforce.com Integration manages interactions between the Contact Center Management server and the hosted Salesforce.com server through the agent’s Salesforce user interface. Salesforce.com Integration offers a wide variety of enhancements and capabilities to agents, including

• Unified login
  Automatically log into Contact Center Management when logging into Salesforce.

• Hot desking support
  ACD hot desking agents and non-ACD general business hot desking extensions are supported for use with the Salesforce.com Integration.

• Click to dial
  Agents can save time and avoid misdialed calls by using click to dial to contact customers, co-workers, or extensions.

• Screen pop
  When an external call arrives, the relevant Salesforce customer record displays on the agent’s screen. If the call is subsequently transferred or joins a conference, the record displays on the screen of the agent receiving the transferred call or taking part in the conference. Immediate access to customer information increases agent productivity and improves customer satisfaction. Screen pop can be configured to work with Automatic Number Identification (ANI), Dialed Number Identification Service (DNIS), or Collect Caller Entered Digits (requires Intelligent Queue with the Collect Caller Entered Digits option).
  Pertinent customer information also displays in the Salesforce soft phone user interface, for example, Caller Name, Collect Caller Entered digits, ANI, DNIS, and any search results you configure in the Salesforce soft phone layout. See “Configuring soft phone layouts” on page 586.

• Call control
  Agents can save time by having all their typical desk phone functions embedded and available directly from the Salesforce user interface. With complete customer information on the screen, agents can quickly access alternate numbers for customers.

• Call logging capabilities
  Agents can log all call data using Salesforce. Call details are also captured by Contact Center Management for reporting purposes. This ensures compliance with your business processes, increasing consistency, and providing improved reporting.

• Agent status (ACD agents only)
  Agents can view the availability of associate agents before transferring calls or initiating conference or consultation calls.

• Make Busy codes and Wrap-up codes (ACD agents only)
  Agents can place themselves in and remove themselves from Make Busy to show their availability to receive calls. After agents indicate they are not ready for calls, they can select from a variety of Make Busy codes that describe their activity. After finishing an external ACD call, agents can select from a list of Wrap-up codes (also known as Call Classification codes). Supervisors can use this information to track call activity and measure agent performance.
Installing Salesforce.com Integration

Salesforce.com Integration is installed during the installation of Contact Center Management. To install Salesforce.com Integration on a client computer, you must install the Client Component Pack.

To install Salesforce.com Integration

1. In Contact Center Management, click Help=>Software downloads/Installations.
2. Click Client Component Pack.
3. Follow the steps in the wizard to install Client Component Pack.
4. Once the installation is complete, click Start=>All Programs=>Mitel=>Client Role Selector.
5. Select a Supervisor, Agent, Administrator, or Power User role.
6. Click Next.
7. Select Salesforce Integration.
   Selecting Salesforce Integration creates a shortcut to Salesforce.com on your desktop.
8. Click Finish.

Using Salesforce.com Integration

To use the soft phone embedded in Salesforce, you must first create a call center, add users to it, and configure the soft phone layout from within the Salesforce user interface.

NOTE: Whenever you make changes to your call center settings, you must log out of and back into Salesforce for these changes to take effect.

Creating your first call center

To use Salesforce.com Integration, you first create a call center.

To create a call center

1. In Salesforce, click Setup=>Customize=>Call Center=>Call Centers.
   If the Introducing Call Center Edition splash page appears, click Continue.
2. Click Import.
3. Click Browse and navigate to the Salesforce.com Integration installation directory (usually C:\Program Files\prairieFyre Software\CCM\Applications\SalesforceIntegration\).
4. Select the Mitel3300 .xml file and click Open.
   The path will be entered in the Call Center Definition File field.
5. Click Import.
6. Before the name of the new call center, click Edit.
   The Call Center Edit window opens.
   NOTE: We recommend you do not alter any of the general information fields.
7. Under CTI Server Info
   • After IP/Name, type the IP address or name of your CTI server.
   • After Use SSL, type Yes if the CTI server uses Secure Sockets Layer.
8. Under Lists of available agents, after Queues and Agent Groups to watch, type the reporting numbers of the queues and agent groups, separated by commas, for which you want to view availability.
   NOTE: The maximum number of agent groups or queues you can configure is five.
9. Under **Advanced Queries**
   - **After Search by IQ Collected Digits**, type the desired object type.field.
     The default is Case.CaseNumber. Object types include Account, Contact, Lead, Case, Campaign, Event, Opportunity, Task, and User. You can also create customized object types.
   - **After Search Cases by ANI**, type **Yes** if you want to search cases by ANI.
     The default is No. If you type Yes when an incoming call’s ANI corresponds to a contact or account object, cases attached to the contact or account are opened.
10. **Under If Records are Found for both ANI and DNIS**
    - **After Open the ANI Records**, type **Yes** if you want to open records matching the ANI.
    - **After Open the DNIS Records**, type **Yes** if you want to open records matching the DNIS.
11. **Under If Records are Found for both ANI and/or DNIS and Advanced Queries**
    - **After Open the ANI and/or DNIS Records**, type **Yes** if you want to open records matching the ANI and/or DNIS.
      **NOTE:** Whether you open records matching the ANI or the DNIS depends on the information you entered in the **If Records are Found for both ANI and DNIS** section (in step 10).
    - **After Open the Advanced Queries Records**, type **Yes** if you want to open Advanced Queries records.
      **NOTE:** Whether you open records matching IQ Collected Digits or open records attached to Contact or Account objects matching the ANI depends on the information you entered in the **Advanced Queries** section (in step 9).
12. **Under Dialing Options**
    - **After Outside Prefix**, type the number you dial to access an outside line.
    - **After Long Distance Prefix**, type the first number you must dial for long distance calls.
      For example, the long distance prefix for North America and the Caribbean is 1.
    - **After International Prefix**, type your three-digit country code.
      For example, the North American international prefix is 011.
    - **After Local Area Codes**, type your local area code(s), separated by commas.
      If the dialed number does not include one of the configured local area codes, the long distance prefix is automatically dialed first. If you always want the long distance prefix to dial first, do not configure any local area codes.
13. **Click Save.**

**Adding users to a call center**

Salesforce users must be added to a call center before they can use any Salesforce Call Center Edition features.

To add users to a call center

1. In Salesforce, click **Setup=>Customize=>Call Center=>Call Centers**.
2. Click the name of the call center to which you will add users
   The default is Mitel Contact Center Integration.
3. In the Call Center Users list, click **Manage Call Center Users**.
4. Click **Add More Users**.
5. Specify the search criteria for the Salesforce users you want to add to the call center.
6. **Click Find**.
   **NOTE:** Users can only be assigned to one call center at a time. Users who already belong to a call center are excluded from search results.
7. Select the check box next to each user you want to add to the call center.
8. Click **Add to Call Center**.
Configuring soft phone layouts

Configuring soft phone layouts enables you to control the information that displays in the screen pop. Once you have configured soft phone layouts, you can assign them to agents. Assigning customized soft phone layouts increases efficiency by giving agents access to the most pertinent customer information.

To configure a soft phone layout

1. In Salesforce, click Setup=>Customize=>Call Center=>SoftPhone Layouts.
2. If you want to create a new soft phone layout, click New. Otherwise, click Edit to modify the current soft phone layout.
3. If you are creating a new soft phone layout
   • After Name, type a name for the soft phone layout.
   • After Select Call Type field, select the type of call that applies to the soft phone layout, either Inbound or Outbound.
4. In the Display these call-related fields section, click Edit.
5. To add, remove, or change the order of call-related fields, select each appropriate call-related field in the Available or Selections boxes and click Add, Remove, or Up or Down.
6. In the Display these Salesforce Objects section, click Add/Remove Objects.
7. To add, remove, or change the order of objects, select each appropriate object in the Available or Selections boxes and click Add, Remove, or Up or Down. Selected objects display in a list below the Available and Selections boxes.
8. For each selected object, after If single <object> found, display:, click Edit.
9. From the Available or Selections boxes, select the field(s) you want to display in the soft phone layout if a single record for the object is found.
10. Click Add, Remove, or Up or Down to move the field(s) to either the Available or Selections box and to change their order.
11. Click Save.
   NOTE: If you want to configure soft phone layouts for both inbound and outbound calls, you must do so separately.

To assign a soft phone layout to an agent

1. In Salesforce, click Setup=>Customize=>Call Center=>SoftPhone Layouts.
2. Click SoftPhone Layout Assignment.
3. From the drop-down lists, select a soft phone layout for each agent.
   NOTE: The list of agents only includes those who have been added to a call center.
4. Click Save.

Using the soft phone with Salesforce

This section explains how to log into your soft phone and discusses operations that you can perform once logged in.

Logging into your soft phone

You must first log into Salesforce and then log in separately to your Salesforce soft phone to use it in Salesforce Call Center Edition.

NOTE:
• The soft phone is located in the left pane of the Salesforce user interface and appears only when you are assigned to a call center in Salesforce.
• You can verify Salesforce.com Integration installation by looking at the system tray on your computer. If the icon is displayed, Salesforce.com Integration is open.
• If all of your Salesforce licences have been used and you attempt to log into your soft phone, you will be unable to do so.
To log into your soft phone

2. Type your Salesforce.com user name and password and click Login.
3. Type your call center Username, Password, Agent ID, and Extension. **NOTE:** If you have not entered agent ID, you will not have ACD functionality but can continue to use your phone for non-ACD calls.
4. If you are using a hotdesking agent ID or extension, enable the Hotdesking Agent check box.
5. If you want Salesforce to remember your soft phone login credentials every time you log into Salesforce, select the check box next to Remember me.
6. Click Log In.

To automatically log into your call center when logging into Salesforce

1. In Salesforce, click Setup=>Call Center Settings=>Edit your SoftPhone settings.
2. Select the check box next to Automatically log into your call center when logging into Salesforce.
3. Click Save.

**Salesforce.com Integration functionality**

**NOTE:** If using a true soft phone, you must first open Contact Center Client, click View=>Soft phone, and configure soft phone options. If you use Salesforce.com Integration with a desk phone there is no need to open Contact Center Client.

You can use Salesforce.com Integration to perform the following

- **Dial phone numbers**
  Dial a phone number by clicking Line 1, entering the number into the soft phone, and clicking Dial. Alternatively, dial by clicking the icon next to a phone number associated with a contact, lead, activity, account, or any other phone field you have created. ACD agents can also dial by clicking on available employee or extension links. See “Show agent availability” below. You can also dial numbers using the dial pad on your desk phone.

- **Answer phone calls**
  Answer an external phone call by clicking Answer or using your desk phone. If the caller's number is in your Salesforce database, their customer information page will appear. Salesforce.com Integration supports one incoming line per user.

- **Create new leads while on calls**
  Once you have answered an internal/external call, the soft phone will display a New Lead button. Click the New Lead button to open a new lead and auto-populate the Lead phone number field with the caller's phone number.

- **Search on outbound calls**
  Search results for outbound calls display in the Salesforce soft phone user interface, but do not generate screen pops.

- **Show agent availability (ACD agents only)**
  You can show the availability of other agents by clicking Show Agents in [Agent Group or Queue Name or Queue Reporting ID]. You can view up to 10 agents in the soft phone window at one time. If you want to view additional agents, click << to view the first page of agents, >> to view the last page of agents, and < and > to move back and forth between consecutive pages of agents. You can call available agents by clicking on the employee name or extension in the list. You can also make consultation calls to them if you are already on a call. Once a connection is established, the call can be transferred by clicking Complete Transfer or a conference can be started by clicking Complete Conference.

- **Transfer calls**
  Transfer a call by clicking the Transfer button. The original call is placed on hold while you connect to the third party. Once connected, click Complete Transfer to transfer the original party. You can also transfer calls by using the "Show agent availability" feature described above.
• **Place callers on hold**
  To place a caller on hold, click the Hold button while on a call. Retrieve the call by clicking Retrieve from Hold.

• **Initiate conference calls**
  Initiate a conference call by clicking the Conference button while on a call. Your original call is placed on hold while you connect to the new participant. Once you have connected, click Complete Conference to place all parties on the same line. You can also initiate conference calls by using the “Show agent availability” feature described above.

• **Tag calls with Account Codes**
  Click on Show Account Codes to display a list of available Account Codes, then click on the account code link that you want to apply.

• **Set Make Busy codes (ACD agents only)**
  Click on the arrow in the agent state bar and select Not Ready for Calls. Select from the list of available Make Busy codes.

• **Set Wrap-up codes (ACD agents only)**
  When an external ACD call ends, select an appropriate Wrap-up code (also known as a Call Classification code) from the Call Result list of the Current Call Log window.

• **Attach comments to a call**
  During the call, type text into the Comments field. When the call ends, the comments are automatically saved. Call log information can be accessed from either the recent calls area of the soft phone or by clicking the Records tab and selecting Activity History.

• **Edit completed call logs**
  Call logs are automatically created for all external calls an agent makes or receives. You can edit a call log by clicking a link to the call in the Recent Calls area of the soft phone.

• **Associate Salesforce records with a call**
  You can associate up to two records with a call. From the Name drop-down list in the call log area, select the contact, lead, or person account record to associate with the call. If you want to associate any other record type with a call, select it from the Related to drop-down list in the call log area.

• **Look up phone numbers in your Salesforce Call Center directory**
  Look up a phone number by clicking the icon, typing all or part of the name for which you are searching, and clicking Go. Click the phone number to enter it into your soft phone’s dial pad.

• **Choose how a call record is displayed**
  If an incoming call has only one associated record, you can choose to always open the record automatically or never open the record automatically. This setting is configured in Setup=>Edit your SoftPhone settings=>My SoftPhone Settings.

• **View recent call activity**
  Access recent call activity by clicking on Last Call or My Calls Today.
Contact center terms and definitions

ACD
An Automatic Call Distributor (ACD) is a specialized telephone system application for distributing incoming calls. ACDs are programmed to process calls in a pre-defined order, queue calls, provide in-queue messaging, and report on real-time and historical activities.

ACD calls handled
A handled call is a call picked up by a live agent. Calls that listen to in-queue RAD messages are not considered to be answered until an agent connects.

ACD calls interflowed
Interflow is a mechanism that directs a queue-delayed call to voice mail or to another answering point. If the interflow timer expires, the call is removed from the ACD queue and re-directed to yet another answering point, usually another voice mail box. The interflow time runs independently of the overflow time.

ACD calls offered
All calls received by the ACD queue, regardless of how they are handled or routed, are referred to as the ACD calls offered. This includes ACD calls handled, and long abandoned calls. ACD calls requeued, Queue unavailable calls, and short abandoned calls are not considered. Telephone system data on the calls offered and Average Talk Time is used by the Erlang C equation in calculating the agents required.

ACD calls requeued
When an agent receives an ACD call and fails to pick up the call after X seconds or X rings, the telephone system logs out the agent. The telephone system requeues the call (places the call back in the same queue) and offers it to the next available agent.

ACD handling time
The ACD Handling Time is the talk time plus the hold time. If the agent calls the supervisor in search of more information (while the caller is on hold) and/or transfers or conferences the call, these times are added to the ACD Handling Time value.

For example, an agent speaks to a caller for two minutes and then puts the caller on hold for three minutes and tries to solve the problem. This may include a call to the supervisor. The agent then initiates a conference call with the caller and a third party and they speak for three minutes and resolve the issue. Therefore, the ACD Handling Time for the agent is 2 + 3 + 3 = 8 minutes.

Agent load
The agent load includes the time the agent spends with the caller (ACD Handling Time) plus Wrap Up Time. See ACD Handling Time.

Agents available
The Agents available is the current number of agents logged on to the ACD system, who are not in Make Busy or Do Not Disturb.

ANI
Automatic Number Identification (ANI) is a technology that identifies telephone numbers of callers to your contact center, so agents can receive a screen pop along with the call. Connecting a database to your telephone system allows the caller information and call to be sent simultaneously.

Answered by
Answered by is a count of all of the calls answered by the first, second, third, and forth answer points.

ASA
The Average speed of answer (ASA) measures how long the average caller waits on hold before his or her call is picked up by an agent.
Auto-acknowledgement
An auto-acknowledgement is the response the customer receives (after emailing or sending a chat message to your company). For example, the Payment Response acknowledgement sent to a customer upon payment for an order might be “Thank you for shopping with us. Your order is scheduled for delivery on May 05, 2002 between the hours of 9:00 A.M. and 5:00 P.M., pending credit approval.”

Average abandon time
The average abandon time is the average number of seconds callers wait in queue before they abandon a call.

Blocked call
A blocked call is a call that does not get through to the system because no trunks are available. The caller receives a busy signal.

Busy hour traffic
The busy hour traffic, measured in Erlangs, is the number of hours of call traffic (or trunk traffic) there are during your busiest hour of operation. It is important that your busy hour figure represent the busiest Call Load your trunks will ever be offered, and not just today’s peak traffic. The busy hour traffic = \((\text{average call duration} + \text{average delay}) \times \text{calls per hour} ÷ 3600\). This value represents the total trunk load (occupancy) in hours.

Call Load
The Call Load is the aggregate effect of the number of calls received by the ACD queue and their duration, or the calls offered multiplied by the (average handling time plus average Wrap Up Time).

Call routing
Call routing is the set of instructions programmed in the telephone system that automate the movement of calls to their intended answering points.

Call volume see ACD calls offered

Calls abandoned
An abandoned call is a call that does not reach an agent because the caller hung up.

Calls abandoned
The calls abandoned can be short abandoned calls or long abandoned calls. If the abandon time is less than the call abandoned parameter, then it is a short abandoned call. If the abandon time is more than the call abandoned parameter, then it is a long abandoned call.

You assign the calls abandoned parameter (called the queue short abandon time) values to ACD queues in the YourSite database.

Callers can abandon after they reach a trunk (before they reach the ACD queue) or while they are in queue waiting for an available agent (either before or after the short abandon time you specify).

Calls abandoned (long)
Call abandoned (long) calls abandon with an abandon time greater than the call abandoned parameter. These long abandoned called are included in call statistics.

Calls abandoned (short)
Call abandoned (short) calls abandon with an abandon time less than the call abandoned parameter. These short abandoned calls are not included in the call statistics.
Calls answered  see ACD calls handled

Calls handled  see ACD calls handled

Calls interflowed  see ACD calls interflowed

Calls offered  see ACD calls offered

Calls requeued  see ACD calls requeued

Calls waiting
The calls waiting is the number of callers queued up waiting for an agent to become available, including those listening to silence, music, or a recorded announcement.

CO
The local Central Office (CO) or telephone exchange connects subscribers’ telephone lines to switching equipment. This allows long distance and local subscribers to connect to one another.

CTI
Computer telephony integration (CTI) is the merging of computer technology with telephone systems. Today’s PC-based telephone systems allow you to deliver synchronized voice and data delivery, voice and data conferencing, automatic information retrieval for calls, caller-based messaging and routing, and desktop productivity tools.

Delayed call
A delayed call is a call placed in the ACD queue because it cannot be immediately answered by an agent. The ACD queue allows the caller to wait for an available agent rather than being blocked from entering the system.

Dialable number
The dialable number is the digit or series of digits a caller dials to reach an agent at an extension, an ACD Queue, voice mail, or some other answering point.

DND
Do Not Disturb (DND) is an agent state in which the agent disables his/her extension to prevent any calls from being routed there.

DNIS
Dialled Number Identification Service (DNIS) is a feature of toll-free lines that provides the number the caller dials. This assists agents who handle calls for more than one business or product line. Each business or product line has its own toll-free number. When a toll-free number is dialled, the telephone system forwards information to the agent allowing him/her to identify who the caller dialled.

Enterprise
The enterprise is all of the contact center sites that comprise your company. The enterprise consists of a single site where the Enterprise Server is installed, and branch offices.

Erlang
An Erlang measures telephone traffic, or the flow of calls and call attempts to your contact center during a given period of time. One Erlang equals one hour or 60 x 60 = 3,600 seconds of telephone conversation. This could be one call lasting 1 hour, six calls lasting 10 minutes, or any combination of calls and call durations which equal 60 minutes. The Erlang series of formulae provide a mathematical basis for making predictions about randomly arriving workloads.

Erlang C
Erlang C was developed in 1917 by A.K. Erlang, a Danish engineer who worked for the Copenhagen Telephone Company. The Erlang C equation is commonly used for agent and delay calculations where ACD queueing is involved. It predicts the resources required to keep wait (delay) times within your Service Level objective. The Erlang C formula uses your historical Call Load data and the Service Level Percentage, Service Level Time, and Wrap Up Time you specify and predicts the agent requirement for the time interval and date range in the forecast.
Extension
An extension is an answering point for a call. A caller to your center is presented with options to dial various answering points. The caller can dial an individual agent at an extension through a queue number (address mechanism for a queue or other answering point).

Grade of service
The grade of service (GOS) relates the number of trunks to the level of traffic, and indicates the likelihood an attempted call will receive a busy signal. The Grade of Service (GOS) is expressed as a decimal fraction. A GOS of P.02 means that a caller has a two percent chance of receiving a busy signal.

Handled percent
The handled percent is the calls handled compared to the calls offered.

Handling time see ACD handling time

Inbound
Inbound calls are incoming calls to your contact center.

LAN
The Local Area Network (LAN) connects multiple computers together over short distances. LANs typically operate within a building. The computers share information, applications, and peripherals, such as printers.

Logged off
An agent is logged off when the agent signs out of the ACD system.

Logged on
An agent is logged on when the agent signs in to the ACD system. The agent may or may not be ready to receive calls.

Longest waiting
The Longest waiting is the duration, in minutes and seconds, of the call that has been waiting the longest in queue.

Make Busy
Make Busy is an agent state in which the agent removes him/herself from the ACD queue. While in Make Busy, the agent does not receive any ACD queue calls, but can receive calls dialled directly to his or her extension.

Media servers
The media servers are the means by which the customer communicates with you. For example, if your system allows customers to contact you by telephone only, and you have an SX-2000 telephone system, then you would select the SX-2000 ACD media server.

MIS
Management Information System (MIS) is the manipulation or processing of data produced by the telephone system. The MIS database uses telephone system records to provide forecasting, real-time monitoring, and reporting functions.

On ACD
An agent is on ACD when he or she is involved in an ACD call.

On non-ACD
An agent is on non-ACD when he or she is currently involved in an incoming non-ACD call or an agent originated call.
Overflow

*Overflow* is a mechanism that limits the delay faced by callers by queuing calls against two or more agent groups. An ACD call that cannot be answered immediately is placed in an ACD queue. If the call is not answered after a set amount of time (the *overflow time*), it is placed in the ACD queue of another agent group, in addition to keeping its place in the first queue. The first available agent in either group handles the call.

Path unavailable *see* Queue unavailable

Pooling principle

The *pooling principle* is a consolidation of resources that allows the same number of contact center agents to handle more calls while maintaining Service Levels. The Pooling Principle also applies when determining the number of contact centers required, and how they are networked across time zones in your ACD enterprise.

Probability of delay

The *probability of delay* is the likelihood a call will be delayed in the ACD queue. It relates the number of agents/extensions compared to the level of traffic carried by the trunks and indicates the likelihood and amount of delay experienced.

PSTN

The *Public Switched Telephone Network* (PSTN) is a global collection of CO's interconnected by long distance telephone switching systems.

Quality of service

The *quality of service* reflects an agent's ability to provide excellent assistance to each customer.

Queue number

*A queue number* is an address mechanism for a queue or other answering point. The programming associated with the queue number defines the routing and timing options available to the call.

Queue unavailable

The *queue unavailable* is the rerouting of calls to the unavailable answer point as defined in the telephone system because the queue is unavailable. The path is unavailable because it is in Do Not Disturb, either because there are no agents logged on, or the supervisor puts the path into Do Not Disturb. The queue unavailable column represents a peg count for the number of calls received while the path was in Do Not Disturb.

Readerboard *see* Wall sign

Real-time adherence

Whether or not agents are performing the activities for which they are scheduled is known as *real-time adherence*. Workforce management tools keep supervisors informed of discrepancies between agents' work schedules and the actual activities they perform.

Recorded announcement device

A *Recorded Announcement Device* (RAD) is a system that provides prerecorded messages to callers waiting in the ACD queue.

Reporting number

The *reporting number* is the number assigned to contact center resources, such as trunks, and to devices, such as ACD queues, for reporting purposes.

Service Level Percent

The *Service Level Percent* is the total number of calls which are handled, abandoned, and interflowed before a defined threshold time (*Service Level Time*), compared to the total number of calls handled, abandoned, and interflowed. The Service Level Percent = (calls answered + long calls abandoned + long interflow) within the specified Service Level Time ÷ (calls answered + long calls abandoned + long interflow).
**Service Level Time**
The *Service Level Time* is the threshold time used in calculating the Service Level Percentage, such as 90 percent of calls answered in 20 seconds. The Service Level Percentage and Service Level Time are parameters you define as your service objective.

**Silent monitoring**
Silent monitoring is the process of capturing the voice conversations between agents and callers. Silent monitoring systems allow you to track call handling techniques and determine where improvements can be made in individual performance. They complement ACD statistics by providing a snapshot of both quality and productivity in your contact center.

**Site**
A *site* is an office location with one or more media servers.

**SQL**
Structured Query Language (SQL) is the language used to talk to popular Relational database Management Systems (RDBMSs). SQL is a standard query language that can be used to enter, query, and change data in a database. SQL is also used to create and administer databases. Administration of YourSite is done using Microsoft’s SQL Server, a database management system.

**Support systems**
Support systems are information products and technologies that allow agents to provide prompt and complete information to callers. They provide agents with immediate online access to a customer’s records and case history, products and services, and company policies and procedures.

**Talk time** see *ACD Handling time*

**TCP/IP**
Transmission Control Protocol-Internet Protocol (TCP/IP) is the basic communication language (protocol) of the Internet, and is used as a communications protocol in private networks (intranets). When you are set up with direct access to the Internet, you are provided with a copy of the TCP/IP program. Other computers that you may get information from also have a copy of TCP/IP.

**Telephone system**
A *telephone system* is a business telephone switch or Private Branch Exchange (PBX) used to process incoming and outgoing calls to your contact center.

**Time stamp**
The term *time stamp* is the time collated queue statistics were last updated by the telephone system.

**Time to answer**
Time to answer is the number of seconds from the time an incoming external request enters the queue until the request is answered. This does not include the duration the request waits in queue outside of regular business hours for the queue.

**True talk time**
The *true talk time* is the time the caller is connected to an agent. The true talk time does not include hold time.

**Trunk load**
The *trunk load* includes the time from when a trunk picks up a call until the agent finishes speaking to the caller and disconnects. The trunk load does not include Wrap Up Time.

**UCD**
A *Uniform Call Distributor* (UCD) is a specialized telephone system application for distributing incoming calls. UCD routes incoming calls to agents according to the information or service required by the caller. All of the telephones that are a part of the hunt group ring at once.
**Unavailable** see *Queue unavailable*

**Wall board** see *Wall sign*

**Wall sign**
A *wall sign* is a large electronic sign placed on the wall of a contact center. Wall signs provide real-time ACD statistics to agents and supervisors, such as the number of calls in queue, the wait time of the longest waiting caller, and the number of available agents.

**WAN**
*Wide Area Networks* (WANs) connect computers across wide geographic areas. WANs operate over telephone carrier lines through bridges or routers. Router options enable communication between high speed LAN links and slower speed WAN links (that tie LAN segments together).

**Workforce management**
*Workforce management* is the forecasting and scheduling of agents. Some workforce management systems use telephone system data to monitor the real-time adherence of agents to scheduled activities, so you to know how many agents are currently logged in and available to handle calls.

**Wrap Up Time**
The *Wrap Up Time* is the time the agent spends completing transactions associated with a call after he or she hangs up. The Wrap Up Time is a standardized period of time during which an agent is not available to receive calls. If an agent requires additional time to complete paperwork or online transactions, the agent can remove him/herself from the ACD queue temporarily for this purpose.
Multimedia Contact Center terms and definitions

Agent Requeue Time
The Agent requeue time is the length of time a contact sits in the assigned agent’s inbox before it is re-queued (put back into the same queue and offered to the next available agent).

When an agent receives a contact and fails to respond to the contact after X seconds, Multimedia Contact Center places the agent in Make Busy and re-queues the contact. This re-queued contact has priority over all others and will be the next contact message answered.

Auto-acknowledgment Message
The Auto-acknowledgment message is a message that is automatically sent to the client upon receipt of the client's email. For example, “Thank you for your interest in prairieFyre Software. We have received your email, and it is being handled by one of our agents. Please expect a reply shortly.”

The response message is created with the Responses tab.

Hold Requeue Timeout
The hold requeue time is the length of time an email message sits in the assigned agent’s queue before a warning is flashed to indicate that the email message will soon be reassigned to another agent’s queue if not answered.

Interflow Queue
The interflow queue is the queue the email message is directed to when it first arrives at a company’s email address.

Interflow Time
The interflow is the path along which the email message is directed. The interflow time is the length of time the email message will wait in the queue that the interflow directed it to. This ensures the email message does not go unanswered for long.

Media Server
The media server is where Multimedia Contact Center and Contact Center Management organizes and distributes email and phone calls throughout your company. If your company is large, you might have several media servers.

Name
The name is the queue name. For example, the name might be Q1.

Non Available Request Timeout
Multimedia Contact Center knows which agent answered which email. If a customer has already received a response from an agent but has further questions, the customer’s next email is directed back to the original agent. However, that agent might not be available. The non available request timeout time is the length of time the email will sit in the original agent’s queue before being forwarded to another agent. If the non available request timeout is 60 minutes, and an email is sent after office hours, then the email would be forwarded to another agent.

Overflow Agent Group
The overflow agent group is the agent group that an email message is forwarded to because the email message was not answered by the primary agent group within a set period of time (the overflow time). The email message is placed in the queue of the overflow agent group in addition to keeping its place in the first queue. The first available agent in either group answers the call.

If the email message is not answered by overflow agent group 1 within the overflow time, it is placed in the queue of overflow agent group 2 in addition to keeping its place in the first queue (primary agent group) and second queue (overflow agent group 1). There are three possible overflow agent groups: overflow agent group 1, overflow agent group 2, and overflow agent group 3.
Overflow Time
The overflow time is the length of time an email will sit in the primary agent group queue before also being forwarded to a overflow agent group.

Primary Agent Group
The primary agent group is the group assigned to answer a particular email message first.

Priority
Priority assigns priority to queues. The highest priority is 1, and the lowest priority is 10. This allows you to answer queues of higher priority first.

Public Folder Name
The public folder name is the windows user name.

Public Mail Address
The public mail address is the company email address. This is the address the customers will use to email you.

Reporting Number (for a queue)
The reporting number is assigned for reporting purposes. This report number is referenced when creating a report about email data from a particular queue. A queue reporting number must start with P and have three digits following. For example, the reporting number for a queue might be P123.

Service Level
The term service level is the turn-around-time goal. For example, if the service level is 20 minutes, the agents provided excellent service if they can respond to all emails within 20 minutes of receiving them.
### Mitel 5000/Axxess terminology compared

Table 1 compares Mitel Contact Center Solutions and telephone system terminology and the corresponding Mitel 5000/Axxess telephone system terminology and details any critical need-to-know differences between the terms.

<table>
<thead>
<tr>
<th>Mitel term</th>
<th>5000/Axxess term</th>
<th>Definition / Differences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Server</td>
<td>Media Servers</td>
<td>Media Servers are the means by which the customer communicates with you (for example, an Mitel 5000 or Axxess telephone system).</td>
</tr>
<tr>
<td>Queue</td>
<td>Hunt group</td>
<td>5000/Axxess hunt groups are referred to as queues when discussing routing and call treatment options.</td>
</tr>
<tr>
<td>Agent Group</td>
<td>Hunt group</td>
<td>5000/Axxess hunt groups are referred to as agent groups when discussing membership roles.</td>
</tr>
<tr>
<td>Extension</td>
<td>Endpoint (5000) Station (Axxess)</td>
<td>5000/Axxess endpoints will be referred to as extensions, except when discussing 5000/Axxess telephone system programming.</td>
</tr>
<tr>
<td>Presence</td>
<td>Log in</td>
<td>Presence is a new Mitel term used when agents log in to specific queues. Previously, agents were logged in to all queues that they were associated with. Presence enables agents to control the queues they are present in.</td>
</tr>
<tr>
<td>Interflow</td>
<td>Overflow</td>
<td>The Mitel concept of interflow is the path along which a call is directed. The <em>interflow time</em> is the time before the system removes the call from the queue and redirects it to another answering point. The interflow timer runs independently of the Overflow timer.</td>
</tr>
<tr>
<td>Overflow</td>
<td>N/A</td>
<td>While the 5000/Axxess telephone systems have a concept of overflow, the 5000/Axxess use of the term overflow is actually what Mitel refers to as interflow (see above for a definition). The Mitel concept of overflow is the mechanism that limits the delay faced by callers by queuing calls against two or more agent groups. An ACD call that cannot be answered immediately is placed in an ACD queue. If the call is not answered after a set amount of time (the overflow time), it is placed in the ACD queue of another agent group, in addition to keeping its place in the first queue. The first available agent in either group handles the call.</td>
</tr>
</tbody>
</table>
Table 1: Mitel and 5000/Axxess terminology compared

<table>
<thead>
<tr>
<th>Mitel term</th>
<th>5000/Axxess term</th>
<th>Definition / Differences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recorded Announcement Device (RAD)</td>
<td>Call Routing Announcement</td>
<td>A Recorded Announcement Device (RAD) is a system that provides prerecorded messages to</td>
</tr>
<tr>
<td></td>
<td></td>
<td>callers waiting in the ACD queue.</td>
</tr>
<tr>
<td>Reporting Number</td>
<td>N/A</td>
<td>The reporting number is the number assigned to contact center resources, such as trunks,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>devices, and ACD queues, for reporting purposes.</td>
</tr>
<tr>
<td>Dialable Number</td>
<td>Endpoint (5000) Station (Axxess)</td>
<td>The dialable number is the digit or series of digits a caller dials to reach an agent at</td>
</tr>
<tr>
<td></td>
<td></td>
<td>an extension, an ACD queue, voice mail, or some other answering point.</td>
</tr>
<tr>
<td>Make Busy</td>
<td>Do Not Disturb (DND)</td>
<td>Make Busy is an agent state in which the agent removes himself/herself from the ACD queue.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>While in Make Busy, the agent does not receive any ACD queue calls, but can receive</td>
</tr>
<tr>
<td></td>
<td></td>
<td>calls dialled directly to their extension.</td>
</tr>
<tr>
<td>Do Not Disturb (DND)</td>
<td>Do Not Disturb (DND)</td>
<td>Do Not Disturb (DND) is an agent state in which the agent disables their extension to</td>
</tr>
<tr>
<td></td>
<td></td>
<td>prevent any calls from being routed there.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5000/Axxess concept of Do Not Disturb is more aligned with Mitel's concept of Make</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Busy, where an agent removes himself/herself from the ACD queue, but can still receive</td>
</tr>
<tr>
<td></td>
<td></td>
<td>calls dialled directly to their extension.</td>
</tr>
</tbody>
</table>